Чат и оповещение пользователей 1С+Mysql

Публикация № 626508

Администрирование - Администрирование данных 1С - Сервисные утилиты

10
Простое решение реализации чата и оповещение пользователей 1С+Mysql, с внедрением в конфигурацию только одного общего модуля и обработки.

Начнем! Для начала на сервере Mysql создадим базу данных mychat  и в ней две таблицы chat - для переписки пользователей  и feed - для их оповещения, все как на скриншотах.

Скачиваем Connector/ODBC  и устанавливаем на сервере 1С.

Идем в конфигурацию 1С и в модуле обычного приложения  в процедуру "ПриНачалеРаботыСистемы" пропишем два обработчика ожидания. 

Для чата интервал 10 секунд, а для служебных сообщений 1 минута!

    ПодключитьОбработчикОжидания("ПроверитьНаличиеСообщенийПользователю",10,);
    ПодключитьОбработчикОжидания("ПроверитьНаличиеСлужебныхСообщений",60,);

И там же добавим к ним две процедуры.

Процедура ПроверитьНаличиеСлужебныхСообщений() Экспорт
РезультатПроверкиСообщений = ОбщийМодульЧат.ПроверитьСлужебныеСообщения();
Если Не РезультатПроверкиСообщений = "" Тогда
ПоказатьОповещениеПользователя("Новое сообщение от Администратора", ,РезультатПроверкиСообщений);   
КонецЕсли;
КонецПроцедуры
 
  Процедура ПроверитьНаличиеСообщенийПользователю() Экспорт
    РезультатПроверкиСообщений = ОбщийМодульЧат.ПроверитьНаличиеСообщенийСервер();
    Если Не РезультатПроверкиСообщений = "" Тогда
        Форма = Обработки.Чат.ПолучитьФорму("Форма");
        Форма.ЭлементыФормы.ЧатПоле.Значение = РезультатПроверкиСообщений;
        Форма.ЭлементыФормы.ЧатПоле.СоздатьКолонки();
    КонецЕсли;
КонецПроцедуры

Эти процедуры будут получать результат с общего модуля.

Создаем общий модуль ("ОбщийМодульЧат"), в его свойствах выставляем калки "Сервер" и "Вызов Сервера", чтобы все функции выполнялись на сервере, где у нас уже установлен Connector/ODBC.

Добавляем  функции!

/////Функция подключения к серверу MySQL/////
//Прописываем данные для подключения к БД
&НаСервере
  Функция ПолучитьConnectStringDBchat()
       
    server    = ""; //"localhost";
    user     = ""; // логин к базе mySql
    password= ""; // пароль к базе mySql
    database= ""; // имя базы
   
    ConnectString="Driver={MySQL ODBC 5.1 Driver};"
        + "Server=" + server
        + ";Database=" + database
        + ";User=" + user
        + ";Password=" + password
        + ";STMT=SET CHARACTER SET cp1251;"
        + ";Option=3;" ;    
    Возврат ConnectString;
   
КонецФункции
//////////////
// Проверяем наличие сообщений на сервере в таблице chat 
/// на начало и конец текущего дня
// записываем все в таблицу значений и возвращаем результат
// в процедуру ПроверитьНаличиеСообщенийПользователю , которая в свою очередь выведет результат в обработку
&НаСервере
Функция ПроверитьНаличиеСообщенийСервер() Экспорт   
    SQLiteObject = Новый COMОбъект("ADODB.Connection");
  SQLiteConnectionString = ПолучитьConnectStringDBchat();
  Попытка
      SQLiteObject.Open(SQLiteConnectionString);
  Исключение
          Сообщить(ОписаниеОшибки());
      Возврат "" ;
  КонецПопытки;
  RS = Новый COMОбъект("ADODB.RecordSet");
  Стр = "chat"; // таблица чат сообщений
    ДатаНачала = НачалоДня(ТекущаяДата());
    ДатаНачалаU = Формат(Число(ДатаНачала - Дата('19700101')),"ЧГ=0");
    ДатаКонца = КонецДня(ТекущаяДата());
    ДатаКонцаU = Формат(Число(ДатаКонца - Дата('19700101')),"ЧГ=0");
    RS.Open("SELECT data, author, text
    |FROM "+стр+" 
    |WHERE data > "+ДатаНачалаU+" 
    |AND data < "+ДатаКонцаU+"" , SQLiteObject);
 
  ТаблицаРезультат = новый ТаблицаЗначений;
  Для НомерСтолбца = 0 По Rs.Fields.Count-1 Цикл
  ИмяНовойКолонки = Rs.Fields(НомерСтолбца).Name;
    ТаблицаРезультат.Колонки.Добавить(ИмяНовойКолонки);
  КонецЦикла;
  Если Не Rs.eof Тогда
  rs.MoveFirst();
  КонецЕсли;
  Пока Не Rs.eof Цикл
  НоваяСтрока = ТаблицаРезультат.Добавить();
  Для каждого Колонка из ТаблицаРезультат.Колонки Цикл
  ИмяКолонки = Колонка.Имя;
                Если ИмяКолонки = "data" тогда
                Значение = Rs.Fields.Item(ИмяКолонки).Value ;
                Значение = дата(1970,1,1,1,0,0) + Значение; //преобразуем unixtime в дату
                Значение = Значение;
            Иначе
                Значение = Rs.Fields.Item(ИмяКолонки).Value ;
          Значение = Значение;
          КонецЕсли;       
  Если значение <> Null Тогда
  НоваяСтрока[ИмяКолонки] = Значение;
  КонецЕсли;
  КонецЦикла;
  rs.MoveNext();
        КонецЦикла;
  SQLiteObject.Close();
        Возврат ТаблицаРезультат;
КонецФункции
/////////////////
////Отправка сообщений на сервер из обработки "Чат" в таблицу chat
&НаСервере
Функция  ВыгрузкаChat(Текст) Экспорт   
    ConnectString=ПолучитьConnectStringDBchat();
    Connection = Новый COMОбъект("ADODB.Connection");
    Connection.open(ConnectString);   
    Дата=ТекущаяДата();
    Пользователь = Пользователи.ТекущийПользователь();
    Текст = Текст;
    Дата = Формат(Дата - Дата(1970,1,1,1,0,0), "ЧГ=0"); //переводим дату в unixtime 
    Попытка
        ТекстSQL = "insert INTO chat
    |(
    | author, 
    | data,
    | text
    |) VALUES (
    | '"+Пользователь+"',
    | '"+Дата+"',
    | '"+Текст+"'
    |);";
    ss=Connection.Execute(текстSQL);
    Connection.Close();
Исключение
        Сообщить(ОписаниеОшибки());
      Возврат "" ;
    КонецПопытки;   
КонецФункции
////////////////////
////Проверяем наличие сообщений для оповещения пользователя из таблицы feed
/// на начало и конец текущего дня
// возвращаем Значение
  &НаСервере
  Функция ПроверитьСлужебныеСообщения() Экспорт
   
    SQLiteObject = Новый COMОбъект("ADODB.Connection");
  SQLiteConnectionString = ПолучитьConnectStringDBchat();
  Попытка
      SQLiteObject.Open(SQLiteConnectionString);
  Исключение
              Сообщить(ОписаниеОшибки());
      Возврат "" ;
  КонецПопытки;
  RS = Новый COMОбъект("ADODB.RecordSet");
  Стр = "feed";
    ДатаНачала = НачалоДня(ТекущаяДата());
    ДатаНачалаU = Формат(Число(ДатаНачала - Дата('19700101')),"ЧГ=0");
    ДатаКонца = КонецДня(ТекущаяДата());
    ДатаКонцаU = Формат(Число(ДатаКонца - Дата('19700101')),"ЧГ=0");
    RS.Open("SELECT text
    |FROM "+стр+" 
    |WHERE data > "+ДатаНачалаU+" 
    |AND data < "+ДатаКонцаU+"" , SQLiteObject);
 
  Если Не Rs.eof Тогда
  rs.MoveFirst();
  КонецЕсли;
  Пока Не Rs.eof Цикл
    Значение = Rs.Fields.Item("text").Value ;
  rs.MoveNext();
    КонецЦикла;
  SQLiteObject.Close();
    Возврат Значение;
КонецФункции
//////////////
///////Отправка сообщений на сервер из внешней обработки "Оповещения" в таблицу feed
&НаСервере
Функция  ВыгрузкаСлужебныхСообщений(Текст) Экспорт
   
    ConnectString=ПолучитьConnectStringDBchat();
    Connection = Новый COMОбъект("ADODB.Connection");
    Connection.open(ConnectString);   
    Дата=ТекущаяДата();
    Пользователь = Пользователи.ТекущийПользователь();
    Текст = Текст;
    Дата = Формат(Дата - Дата(1970,1,1,1,0,0), "ЧГ=0");
    Попытка
       
        ТекстSQL = "insert INTO feed
    |( 
    | data,
    | text
    |) VALUES (
    | '"+Дата+"',
    | '"+Текст+"'
    |);";
    ss=Connection.Execute(текстSQL);
    Connection.Close();
Исключение
        Сообщить(ОписаниеОшибки());
      Возврат "" ;
    КонецПопытки;   
КонецФункции
////////////////////
/////Очищаем таблицу feed из внешней обработки "Оповещения"
//Чтобы у пользователя не выскакивало окно с оповещением 
&НаСервере
Функция УдалитьСообщенияОповещения () Экспорт
    SQLiteObject = Новый COMОбъект("ADODB.Connection");
  SQLiteConnectionString = ПолучитьConnectStringDBchat();
    SQLiteObject.Open(SQLiteConnectionString);
    Попытка
    ТекстSQL = "TRUNCATE TABLE feed ";
    SQLiteObject.Execute(текстSQL);
    Сообщить("Информация успешно удалена с сервера");
      Исключение
    Сообщить(ОписаниеОшибки());
      Возврат "" ;
  КонецПопытки;
  SQLiteObject.Close();
КонецФункции

Осталось теперь создать две обработки. Начнем с Чата!

Создаем обработку, добавляем реквизит "Текст" на форму кидаем ПолеВвода с этим реквизитом и ТабличноеПоле с именем "ЧатПоле".

Для кнопки "Выполнить" пишем следующую процедуру.

Процедура КнопкаВыполнитьНажатие(Кнопка)
    Если Не ЗначениеЗаполнено(Текст) Тогда
        Сообщить("А кто будет заполнять поле?");
        Возврат;
    Иначе
        ОбщийМодульЧат.ВыгрузкаChat(Текст);
    КонецЕсли;
    ЭлементыФормы.ПолеВвода1.Значение = "";
КонецПроцедуры

На этом все, добавляем обработку в конфигурацию!

Обработка оповещения добавляем реквизит "Текст" на форму кидаем ПолеВвода с этим реквизитом и еще одну кнопку "Удалить" для удаления сообщений с сервера.

    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Текст = ЭлементыФормы.ПолеВвода1.Значение;
    Если Не ЗначениеЗаполнено(Текст) Тогда
        Сообщить("А кто будет заполнять поле?");
        Возврат;
    иначе
    ОбщийМодульЧат.ВыгрузкаСлужебныхСообщений(Текст);
    КонецЕсли;
    ЭлементыФормы.ПолеВвода1.Значение = "";
КонецПроцедур


Процедура УдалитьНажатие(Элемент)
    ОбщийМодульЧат.УдалитьСообщенияОповещения();
КонецПроцедуры

Вот результат, и спасибо всем за внимание!

10

Скачать файлы

Наименование Файл Версия Размер
Чат и оповещение пользователей 1С+Mysql:
.rar 8,11Kb
25.05.17
8
.rar 8,11Kb 8 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
5. BigB 178 31.05.17 14:35 Сейчас в теме
(4) С чего Вы решили, что "Система взаимодействия" реализованная в 8.3.10 стоит денег? Мы ей уже пользуемся и ни копейки не платим.
6. DonAlPatino 129 01.06.17 11:06 Сейчас в теме
(5) Ну так поделитесь как оно, какие грабли и стоит ли того, чтобы в это влезать?
7. BigB 178 01.06.17 11:24 Сейчас в теме
(6) Лично мне нравится. Пока в ней нет звонков, но текстовые сообщения реализованы нормально.
9. DonAlPatino 129 01.06.17 13:32 Сейчас в теме
(7) Ну мне больше интересно мнение пользователей, как они ее используют в работе и кол-во пользователей?
10. BigB 178 01.06.17 13:54 Сейчас в теме
(9) 50 пользователей одновременно в базе. Раньше в скайпе переписывались, теперь в 1С.
Самое интересное это то, что сообщения работают и в копии рабочей базы, которая находится на другом сервере. Во как.
Никакой код в 1С писать не надо. Достаточно её просто включить и можно пользоваться.
Подробнее можно почитать тут https://wonderland.v8.1c.ru/blog/sistema-vzaimodeystviya/
1. starik-2005 1962 25.05.17 17:05 Сейчас в теме
Для чата, ИМХО, лучше использовать механизмы именованных очередей. Их поддерживает, например, REDIS. MySQL здесь явно избыточен.
Сурикат; +1 Ответить
4. JohnnyAlexandrov 20 26.05.17 13:36 Сейчас в теме
(1) Для 30-60 пользователей, которые будут активно переписываться и сообщения в среднем будут весить 5-10кб MySql вполне должен справиться.

(2) Это простой пример реализации, и не нужно ходить к каждому и устанавливать, а потом объяснять как пользоваться jabber, так можно то и просто беседу в viber создать и там общаться)

(3) А вот этот велосипед стоит денег.
2. nytlenc 25.05.17 18:16 Сейчас в теме
Для чата, ИМХО, лучше использовать Jabber сервер, созданный как раз специально для этого, совершенно бесплатно заметьте, а не изобретать велосипед.
3. unichkin 1199 25.05.17 23:34 Сейчас в теме
8. Amur_MVS 118 01.06.17 11:32 Сейчас в теме
Оставьте свое сообщение

См. также

Новости для пользователей 117

Отчеты и формы Пользователь Расширение (cfe) v8 1cv8.cf Абонемент ($m) Универсальные обработки

Для уведомления пользователей программных продуктов 1С о разных событиях, в них включена подсистема «Новостной центр». Это довольно удобная штука, т.к. новостные ленты сообщают о выходе обновлений, о новостях и событиях в сфере учёта. Но можно увеличить пользу от новостной подсистемы используя её локально в рамках 1С базы. Например, внутренняя служба техподдержки или внедряющая компания может через новостную ленту оповещать пользователей информационной базы об изменениях в программе, совещаниях, проведении тестирований, заполнения нужных документов или сдача отчетов к определенной дате и т.п.

1 стартмани

05.08.2019    4430    11    sapervodichka    15       

Быстрый запрос 41

Отчеты и формы Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

Можно ли дать пользователю "удочку", а не "рыбу"? До сих пор ответ на этот вопрос был отрицательным. Всякий инструмент, который мог бы делать с базой данных все или почти все (или хотя бы многое), отвергался пользователями, как слишком сложный. Вспомните тот же SQL, который изначально разрабатывался именно как пользовательский инструмент. "Быстрый запрос" - это попытка устранить сложность, но сохранить при этом универсальность.

1 стартмани

29.04.2019    5470    15    mkalimulin    28       

Блин, мы забыли включить регламентные задания… 51

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 Абонемент ($m) Сервисные утилиты

Привет, Инфостарт! Сегодня расскажу, как я решил проблему с выключенными регламентными заданиями в рабочих базах. Желая исключить человеческий фактор и минимизировать количество ошибок, я написал небольшую конфигурацию.  В конфигурации два регламентных задания. Первое периодически подключается к кластеру и сохраняет текущие параметры: имя, Сервер БД, базу СУДБ, блокировки входа и регламентных заданий и т.д. Второе задание периодически проверяет эти параметры на ошибки.

1 стартмани

08.04.2019    6498    10    slozhenikin_com    36       

LicDataDecoder - расшифровка файла программной лицензии 1С 102

Инструменты и обработки Системный администратор Приложение (exe) v8 1cv8.cf Россия Windows Абонемент ($m) Сервисные утилиты

Представляю вашему вниманию утилиту, предназначенную для работы с файлами программных лицензий 1С (*.lic).

1 стартмани

10.02.2019    11793    160    GeraltSnow    42       

Коннектор: удобный HTTP-клиент для 1С:Предприятие 8 512

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных WEB Универсальные функции Инструментарий разработчика Универсальные обработки

Коннектор - библиотека для работы с HTTP запросами. Библиотека берет на себя всю рутину работы с HTTP запросами. Буквально в одну строку можно получать данные, отправлять, не заботясь о необходимости конструирования URL, кодирования данных и т.п.

1 стартмани

31.01.2019    25240    243    bonv    108       

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX 167

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Практика программирования Разработка

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    12785    62    Synoecium    33       

Редактор объектов информационной базы 8.3 36

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Универсальная внешняя обработка (СДРОбъектУпр) для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.31 от 02.10.2019

2 стартмани

23.01.2019    8594    126    ROL32    21       

Сравнение pdf-файлов актов сверки 1

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП2.0 Россия БУ Дебиторская и кредиторская задолженность Абонемент ($m) Универсальные обработки

Обработка сравнивает два pdf-файла, в которых находятся стандартные печатные формы актов сверки, и показывает на экране совпадающие и/или отличающиеся по суммам документы взаиморасчетов.

1 стартмани

19.12.2018    5666    4    Torin99    2       

Централизованное управление списком доступных баз 1С у пользователей 8

Инструменты и обработки Системный администратор Архив с данными v8 1cv8.cf Россия Windows Абонемент ($m) Стартеры 1С Сервисные утилиты Рабочее место

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

5 стартмани

05.12.2018    4732    7    RomikR    7       

Обнуление остатков регистров бухгалтерии и накопления 40

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::БУ v8::ОУ v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ БГУ ERP2 БП3.0 УТ11 УХ КА2 ЗУП3.x Россия Абонемент ($m) Универсальные обработки Чистка базы

Обработка позволяет обнулить остатки по регистру накопления или бухгалтерии на определенную дату. Поддерживается большинство типовых конфигураций (БП 3, БП 2, УТ 11, УТ 10, ЗУП 3, ЗУП 2, БГУ 2, БГУ 1, ERP, УПП, КА 2, КА 1, УХ 3, УХ 1, УНФ). Гибкая настройка (отборы, заполнение реквизитов и любых полей корр. счета, возможность обнулять ресурсы выборочно). Несколько режимов работы. Два интерфейса: простой и с расширенным набором настроек.

2 стартмани

19.11.2018    8849    162    morozov.sv    30       

Очистка кэша 1С 8 (8.0, 8.1, 8.2, 8.3). Грамотная чистка кэша 1С с сохранением настроек. 32

Инструменты и обработки Системный администратор Компонента, плагин (dll, vbs,..) v8 1cv8.cf Россия Windows Абонемент ($m) Чистка базы Сервисные утилиты Администрирование данных 1С

Эффективное средство для устранения ошибок, возникающих в локальном кэше 1С на клиенте, которым легко сможет воспользоваться пользователь с любым уровнем знаний. Wsf-скрипт, созданный на стандартном языке автоматизации Windows - "WSH JScript", очищает кэш 1С просто, быстро и безопасно. Кроме варианта, очищающего кэш текущего пользователя, имеется также вариант для чистки кэша 1С всех пользователей терминального-сервера.

1 стартмани

04.11.2018    18259    287    Eugen-S    34       

Навигатор по конфигурации базы 1С 8.3 100

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Универсальная внешняя обработка (СДРНавигаторУпр) для просмотра метаданных конфигураций баз 1С 8.3. Отображает свойства и реквизиты объектов конфигурации, их количество, основные права доступа и т.д. Отображаемые характеристики объектов: свойства, реквизиты, стандартные рекизиты, реквизиты табличных частей, предопределенные данные, регистраторы для регистров, движения для документов, команды, чужие команды, подписки на события, подсистемы. Отображает структуру хранения объектов базы данных, для регистров доступен сервис "Управление итогами". Небольшой набор сервисных функций для повседневной работы. Для программистов и пользователей. Платформа 8.3, управляемые формы. Версия 1.1.0.43 от 01.10.2019

3 стартмани

28.10.2018    14899    176    ROL32    43       

Просмотр, изменение реквизитов объекта. Сравнение двух одинаковых объектов метаданных ИБ 0

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Универсальные обработки

Показывает реквизиты объекта (ов) или сравнивает два одинаковых объекта конфигурации справочники, документы.

1 стартмани

26.04.2018    8150    18    Vin_Tik    0       

Мониторинг изменений рабочих конфигураций. Часть 1. Сохранение конфигураций из базы SQL без конфигуратора 102

Статья Системный администратор Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты

Выгружаем исходники из SQL напрямую скриптом, собираем CF и контролируем реальные изменения в рабочих базах из браузера.

1 стартмани

28.02.2018    14000    15    user768334    25       

Построение маршрута доставки с расчётом расстояния для любой базы УФ 56

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Оптовая торговля Абонемент ($m) Универсальные обработки WEB

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    18455    36    KorotkovRV    16       

Навигация по функциональным опциям типовых конфигураций 130

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Пользователю системы

Из релиза в релиз разделы и функциональные опции меняют своё местоположение. Вкупе с многостраничными формами настроек поиск нужной настройки становится испытанием для терпеливых. Я нашел такое решение.

1 стартмани

30.01.2018    16128    71    kuzyara    12       

Практика доступа в базу 1С через протокол oData. Чтение данных 276

Статья Системный администратор Программист Бизнес-аналитик Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Сервисные утилиты Практика программирования Администрирование данных 1С

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    55117    232    Dementor    42       

Быстрое удаление неиспользуемых версий 1С:Предприятие 8, кэша метаданных и информационных баз 45

Инструменты и обработки Системный администратор Приложение (exe) v8 Windows Абонемент ($m) Сервисные утилиты

При обновлении платформы 1С:Предприятие 8 предыдущие версии не удаляются. Со временем количество неиспользуемых версий платформы растет. Они занимают место на диске. Для решения этой проблемы предназначена программа OneCleaner. Она позволяет быстро удалить неиспользуемые версии платформы, а также почистить кэш метаданных и удалить ненужные информационные базы данных.

1 стартмани

14.11.2017    14479    85    bonv    15       

Графическая оболочка для консольной утилиты cnvdbfl.exe 105

Инструменты и обработки Системный администратор Архив с данными v8 Windows Абонемент ($m) Сервисные утилиты

Графическая оболочка для консольной утилиты cnvdbfl.exe предназначенной для преобразования размера внутренней страницы файла базы 1С.

1 стартмани

25.10.2017    29966    215    frkbvfnjh    43       

Инструменты бухгалтера: Виджеты рабочего стола 124

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::БУ БП3.0 Windows Абонемент ($m) Универсальные обработки Рабочее место

Настраиваемые виджеты на начальной странице, своеобразная панель для быстрого доступа к объектам. Виджеты это элементы интерфейса в виде цветных прямоугольников со ссылками на объекты конфигурации. Использование виджетов позволяет сконцентрировать на начальной странице часто используемые функции, например, варианты отчетов, списки документов, или используя виджет вводить новый документ прямо из начальной страницы.

2 стартмани

28.08.2017    25521    158    Bazil    22       

ОСкрипты для деплоя и копирования базы данных 127

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Абонемент ($m) Сервисные утилиты

Набор оскриптов для деплоя базы 1С через хранилище и копирование через sql-бекап одной базы в другую

1 стартмани

02.05.2017    17465    33    Stepa86    25       

Автокликер для 1С 70

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты

Внешняя обработка, запускаемая в обычном (неуправляемом) режиме для автоматизации действий пользователя (кликер). ActiveX компонента, используемая в обработке, получает события от клавиатуры и мыши по всей области экрана в любом приложении и транслирует их в 1С, получает информацию о процессах, текущем активном приложении, выбранном языке в текущем приложении, умеет сохранять снимки произвольной области экрана, активных окон, буфера обмена, а также, в режиме воспроизведения умеет активировать описанные выше события. Все методы и свойства компоненты доступны при непосредственной интеграции в 1С. Примеры обращения к компоненте представлены в открытом коде обработки.

1 стартмани

03.04.2017    23537    69    slava_1c    49       

Поиск и отключение зависших сеансов на сервере 1С: Предприятия 11

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Универсальные обработки

Обработка предназначена для мониторинга и отключения спящих (зависших) сеансов на сервере 1С: Предприятия.

1 стартмани

14.09.2016    22217    67    wowchik_85    9       

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора. 23

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Обработка документов Универсальные обработки Обмен через XML

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    27632    146    Aphanas    4       

Универсальный поиск объектов по глобальному уникальному идентификатору (ГУИД, GUID) 8

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Поиск данных Универсальные обработки

Универсальная обработка поиска объектов информационной базы по глобальному уникальному идентификатору (ГУИД, GUID) или по его части.

1 стартмани

06.09.2016    23248    101    Dzenn    8       

Оптимальный способ расчета контрольной суммы объекта/записи регистра (CRC32, MD5, SHA1, SHA256) 19

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки

Была задача сравнить документы в распределенных базах и пометить на выгрузку измененные. Но сравнение изменений документов методом перебора реквизитов - долгоиграющий процесс, особенно если общее количество сравниваемых данных переваливает за миллион. Был найден выход, который ускоряет процесс сравнения - расчет контрольной суммы объекта и сравнение ее с другой контрольной суммой. Скорость сравнения увеличивается во много раз.

1 стартмани

01.08.2016    21356    5    hakerxp    9       

Просмотр данных системы Платон на картах Google 10

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 1cv8.cf Автомобили, автосервисы Транспорт, автопарки, такси Windows Абонемент ($m) Универсальные обработки WEB

Обработка для просмотра предполагаемых треков движения транспортного средства на карте Google согласно данным, предоставляемым системой Платон в формате CSV. Работает под 8.2 и 8.3, обычное и управляемое приложение, может подключаться к типовым конфигурациям в качестве внешней обработки.

1 стартмани

15.04.2016    22876    21    anig99    8       

ЕГАИС: код алкогольной продукции из штрихкода акцизной марки 15

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Windows Оптовая торговля Розничная торговля Акцизы Абонемент ($m) Универсальные обработки

В последнее время мне пришлось потратить очень много времени на внедрение и реализацию функционала ЕГАИС. Очень часто, на форумах, я встречал вопрос: "Как из штрих-кода акцизной марки получить код алкогольной продукции ЕГАИС?". Несколько раз видел неверную реализацию этой задачи. Глядя на это, я набросал простую обработку пересчета кода акцизной марки (base36) в понятный нам уникальный ФСРАР ID алкогольной продукции (Base10).

1 стартмани

11.02.2016    46489    153    OrcaMax    29       

Снимок экрана для 1С 10

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Универсальные обработки Разработка внешних компонент

Довольно часто люди сталкиваются с необходимостью сделать снимок экрана. Если вы или ваши сотрудники основную часть времени проводят в 1С и у вас есть необходимость прикреплять графические файлы, то эта компонента для вас.

1 стартмани

08.02.2016    20469    30    linkforget    11       

Генерация QR-кода (управляемая форма, обычное и управляемое приложение) 59

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Универсальные функции Универсальные обработки

Обработку можно быстро и легко интегрировать в любую конфигурацию с и без БСП (Библиотека Стандартных Подсистем).

3 стартмани

04.02.2016    35675    153    tunesoft    24       

Интерфейс сопоставления объектов для обмена (для типового регистра СоответствиеОбъектовДляОбмена) 22

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки Перенос данных из 1C8 в 1C8

Вы внедряете обмен данными между двумя типовыми или основанными на типовых БД и вам необходим инструмент, чтобы сопоставить между собой справочники этих конфигураций? Вы хотите навести порядок в обмене данными, потому что вам надоело вылавливать дублирующиеся объекты? Вам очень хочется перепоручить сопоставление объектов обменивающихся баз пользователям, но нет подходящего и понятного пользователям интерфейса? Тогда вам нужна именно эта обработка!

4 стартмани

11.11.2015    29493    221    catsam    8       

[x1c.ru] MXL Stamps - Печати и подписи в макетах печатных форм в несколько кликов 3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Универсальные обработки

Обработка позволяет быстро создавать поля текста из ячеек печатных форм и добавлять "под них" подписи и печати. Работает в конфигурациях на управляемых формах.

1 стартмани

22.08.2015    26678    23    GusevNA    6       

Работа с push сервисами только средствами 1С 8.2 24

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 Windows Абонемент ($m) Сервисные утилиты Инструментарий разработчика Универсальные обработки

Обработка для настройки, тестирования и использования с предустановками для 3-х сервисов. Текст модуля для внедрения в конфигурацию или другие обработки. Уведомления на телефон, компьютер, браузер.

1 стартмани

18.08.2015    23692    45    anig99    1       

Telemonitor - объединяем Telegram и 1С 170

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты Администрирование данных 1С Мобильная разработка

Не так давно Telegram предоставил API для создания ботов. Telemonitor - программа, позволяющая легко настроить собственного бота для работы с 1С.

1 стартмани

09.08.2015    69387    230    salexdv    175       

Отключение назойливых окон и подтверждение легальности обновления(!) для БП 3.0 при помощи расширения 76

Инструменты и обработки no Расширение (cfe) v8 БП3.0 Россия Абонемент ($m) Сервисные утилиты

Отключение назойливых окон и подтверждение легальности обновления(!) для БП 3.0 при помощи расширения

1 стартмани

25.06.2015    40414    284    Йожкин Кот    55       

Завершение работы пользователей (выгонялка) 12

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Сервисные утилиты

Обработка для завершения сеансов пользователей для клиент-серверной базы данных, с возможностью включения монопольного доступа к базе. Разработана на платформе 8.3. Запускается на любой конфигурации, как типовой, так и самописной, как в обычном режиме, так и в управляемом.

1 стартмани

17.06.2015    24712    263    Rusleg    27       

Универсальная обработка "Изменение записей регистров сведений и накопления" (8X) 48

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Универсальные обработки

Обработка для Добавления/удаления/изменения записей в любых регистрах сведений (подчиненных и не подчиненных регистраторам) и накопления. Для Платформ 8.1, 8.2, 8.3

2 стартмани

24.05.2015    47505    1217    Erofeevgv    56       

Нейронная сеть. Создаем, учим и используем. В одной обработке 134

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Обработка для создания, обучения и использования многослойного персептона на платформе родного и любимого 1С-а.

1 стартмани

12.05.2015    32860    232    dusha0020    52       

Яндекс (Yandex) Диск. Обновляйте свои внешние обработки, обработки заполнения, печатные формы и отчеты. 80

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки WEB

Хранить свои внешние обработки на внешнем носителе типа Yandex диска удобно, а обновлять в базах 1С еще удобней.

1 стартмани

15.04.2015    31726    126    Patriot1S    35       

Подсистема проверки контрагентов через сервис ГосРеестра для объединения с любой конфигурацией (или автономной работы) 5

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Windows Абонемент ($m) Универсальные обработки Обработка справочников

Еще один вариант для проверки контрагентов через сервис ФНС. Механизм аналогичен проверке в типовой БП 3.0 и полностью автономен, можно объединить с любой конфигурацией. При первом запуске просит ввести логин и пароль для доступа к сайту поддержки 1С.

1 стартмани

06.04.2015    14032    54    Foxes82    12       

Направляем список пользователей, не закрывающих терминальные сессии 1С, на почту ИТ директору 39

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты Инструментарий разработчика Email

Пятница - лучший день для аншлагов по 1С. У Лены он начался с того, что у одного нашего московского клиента рухнула база по банальной причине ...

1 стартмани

16.03.2015    26208    23    O-Planet    42       

Работа с Excel. Объединение, Стыковка, Свертка 4

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Универсальные обработки Загрузка и выгрузка в Excel

Обработка позволяет работать как с одним, так и с несколькими файлами Excel: Объединять файлы со сходной структурой в одну таблицу, Стыковать файлы с разной структурой по ключевому полю, Группировать результат по выбранным полям и суммировать числовые поля.

1 стартмани

19.02.2015    18428    35    Ekovichev    7       

Hasher Pro 1C \ 8.x \ Абсолютная очистка Кэша \ Кеша \ Хеша \ Временных файлов \ Мусора \ Создание гибкого скрипта очистки VBS \ BAT \ Дополнительные возможности \ УФ и Обычные \ Яркие впечатления 107

Инструменты и обработки Системный администратор Программист Пользователь Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты Чистка базы Администрирование данных 1С

Hasher Pro 1C - это новый подход в очистке кэша 1С:Предприятия. В сообществе временные файлы пользователя 1С называют по разному: кэш, кеш, хеш и т.д. Как правило этот мусор хранится годами на вашем компьютере и занимает очень много места - сотни гигабайт могут быть заняты бесполезными файлами. Hasher Pro 1C сочетает в себе ТРИ варианта очистки Кэша: 1) Быстрый и безопасный, подходит для любого пользователя 1С. 2) Полный и более тщательный, для программистов и уверенных пользователей. 3) Агрессивный с дополнительными административными возможностями. * А так же интерактивное создание скрипт файлов VBS или BAT для отложенной очистки или передачи скрипта коллегам. Используйте обработку Hasher Pro 1C как незаменимый инструмент при работе с 1С:Предприятием 8.1, 8.2 и 8.3 в клиент-серверном и файловом варианте. Поддержка толстого клиента, тонкого клиента, управляемых форм, интерфейса Такси. Совместимость: Windows XP/Vista/7/8/10 (x32/x64) + Серверные платформы.

3 стартмани

02.01.2015    39725    541    ya.Avoronov    34       

Безопасное копирование файловых баз данных 1С (1Cv8.1CD) 37

Инструменты и обработки Системный администратор Приложение (exe) v8 1cv8.cf Windows Абонемент ($m) Сервисные утилиты Архивирование (backup)

Безопасное копирование файловых баз данных 1С (1Cv8.1CD) При подключенных пользователях!

1 стартмани

22.12.2014    43084    116    BorovikSV    27       

Проверка свободных доменов по маске 0

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Универсальные обработки

Обработка предназначена для составления и проверки списка доменов по маске.

1 стартмани

10.12.2014    13114    18    opx    3       

"КОММУНИКАТОР" - обмен заказами, номенклатурой, сообщениями, история работы по сделке без изменения конфигурации. 22

Инструменты и обработки no Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 Россия УУ Учет ТМЦ Абонемент ($m) Универсальные обработки

Внешняя обработка(печатная форма) к конфигурациям УТ 10.3, УПП, КА для совместной работы над заказами между Покупателем и Продавцом - автоматическая передача заказа (распознавание номенклатуры поставщика/покупателя) между базами, обсуждение цен, корректировки состава, проведение согласований и т.д. Имеется лента сообщений в стиле мессенджера, в котором можно обмениваться просто сообщениями или передавать состав заказа. Обработка работает как в направлении от заказчика к покупателю, так и наоборот, т.е. инициатором может быть и менеджер по закупкам, и менеджер по продажам.

1 стартмани

24.10.2014    13265    56    informa1555    10       

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) 410

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Перенос данных из 1C8 в 1C8 Универсальные обработки Распределенная БД (УРИБ, УРБД)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    189942    4180    ekaruk    174