Чат и оповещение пользователей 1С+Mysql

Публикация № 626508

Администрирование - Администрирование данных 1С - Сервисные утилиты

Простое решение реализации чата и оповещение пользователей 1С+Mysql, с внедрением в конфигурацию только одного общего модуля и обработки.

Начнем! Для начала на сервере Mysql создадим базу данных mychat  и в ней две таблицы chat - для переписки пользователей  и feed - для их оповещения, все как на скриншотах.

Скачиваем Connector/ODBC  и устанавливаем на сервере 1С.

Идем в конфигурацию 1С и в модуле обычного приложения  в процедуру "ПриНачалеРаботыСистемы" пропишем два обработчика ожидания. 

Для чата интервал 10 секунд, а для служебных сообщений 1 минута!

    ПодключитьОбработчикОжидания("ПроверитьНаличиеСообщенийПользователю",10,);
    ПодключитьОбработчикОжидания("ПроверитьНаличиеСлужебныхСообщений",60,);

И там же добавим к ним две процедуры.

Процедура ПроверитьНаличиеСлужебныхСообщений() Экспорт
РезультатПроверкиСообщений = ОбщийМодульЧат.ПроверитьСлужебныеСообщения();
Если Не РезультатПроверкиСообщений = "" Тогда
ПоказатьОповещениеПользователя("Новое сообщение от Администратора", ,РезультатПроверкиСообщений);   
КонецЕсли;
КонецПроцедуры
 
  Процедура ПроверитьНаличиеСообщенийПользователю() Экспорт
    РезультатПроверкиСообщений = ОбщийМодульЧат.ПроверитьНаличиеСообщенийСервер();
    Если Не РезультатПроверкиСообщений = "" Тогда
        Форма = Обработки.Чат.ПолучитьФорму("Форма");
        Форма.ЭлементыФормы.ЧатПоле.Значение = РезультатПроверкиСообщений;
        Форма.ЭлементыФормы.ЧатПоле.СоздатьКолонки();
    КонецЕсли;
КонецПроцедуры

Эти процедуры будут получать результат с общего модуля.

Создаем общий модуль ("ОбщийМодульЧат"), в его свойствах выставляем калки "Сервер" и "Вызов Сервера", чтобы все функции выполнялись на сервере, где у нас уже установлен Connector/ODBC.

Добавляем  функции!

/////Функция подключения к серверу MySQL/////
//Прописываем данные для подключения к БД
&НаСервере
  Функция ПолучитьConnectStringDBchat()
       
    server    = ""; //"localhost";
    user     = ""; // логин к базе mySql
    password= ""; // пароль к базе mySql
    database= ""; // имя базы
   
    ConnectString="Driver={MySQL ODBC 5.1 Driver};"
        + "Server=" + server
        + ";Database=" + database
        + ";User=" + user
        + ";Password=" + password
        + ";STMT=SET CHARACTER SET cp1251;"
        + ";Option=3;" ;    
    Возврат ConnectString;
   
КонецФункции
//////////////
// Проверяем наличие сообщений на сервере в таблице chat 
/// на начало и конец текущего дня
// записываем все в таблицу значений и возвращаем результат
// в процедуру ПроверитьНаличиеСообщенийПользователю , которая в свою очередь выведет результат в обработку
&НаСервере
Функция ПроверитьНаличиеСообщенийСервер() Экспорт   
    SQLiteObject = Новый COMОбъект("ADODB.Connection");
  SQLiteConnectionString = ПолучитьConnectStringDBchat();
  Попытка
      SQLiteObject.Open(SQLiteConnectionString);
  Исключение
          Сообщить(ОписаниеОшибки());
      Возврат "" ;
  КонецПопытки;
  RS = Новый COMОбъект("ADODB.RecordSet");
  Стр = "chat"; // таблица чат сообщений
    ДатаНачала = НачалоДня(ТекущаяДата());
    ДатаНачалаU = Формат(Число(ДатаНачала - Дата('19700101')),"ЧГ=0");
    ДатаКонца = КонецДня(ТекущаяДата());
    ДатаКонцаU = Формат(Число(ДатаКонца - Дата('19700101')),"ЧГ=0");
    RS.Open("SELECT data, author, text
    |FROM "+стр+" 
    |WHERE data > "+ДатаНачалаU+" 
    |AND data < "+ДатаКонцаU+"" , SQLiteObject);
 
  ТаблицаРезультат = новый ТаблицаЗначений;
  Для НомерСтолбца = 0 По Rs.Fields.Count-1 Цикл
  ИмяНовойКолонки = Rs.Fields(НомерСтолбца).Name;
    ТаблицаРезультат.Колонки.Добавить(ИмяНовойКолонки);
  КонецЦикла;
  Если Не Rs.eof Тогда
  rs.MoveFirst();
  КонецЕсли;
  Пока Не Rs.eof Цикл
  НоваяСтрока = ТаблицаРезультат.Добавить();
  Для каждого Колонка из ТаблицаРезультат.Колонки Цикл
  ИмяКолонки = Колонка.Имя;
                Если ИмяКолонки = "data" тогда
                Значение = Rs.Fields.Item(ИмяКолонки).Value ;
                Значение = дата(1970,1,1,1,0,0) + Значение; //преобразуем unixtime в дату
                Значение = Значение;
            Иначе
                Значение = Rs.Fields.Item(ИмяКолонки).Value ;
          Значение = Значение;
          КонецЕсли;       
  Если значение <> Null Тогда
  НоваяСтрока[ИмяКолонки] = Значение;
  КонецЕсли;
  КонецЦикла;
  rs.MoveNext();
        КонецЦикла;
  SQLiteObject.Close();
        Возврат ТаблицаРезультат;
КонецФункции
/////////////////
////Отправка сообщений на сервер из обработки "Чат" в таблицу chat
&НаСервере
Функция  ВыгрузкаChat(Текст) Экспорт   
    ConnectString=ПолучитьConnectStringDBchat();
    Connection = Новый COMОбъект("ADODB.Connection");
    Connection.open(ConnectString);   
    Дата=ТекущаяДата();
    Пользователь = Пользователи.ТекущийПользователь();
    Текст = Текст;
    Дата = Формат(Дата - Дата(1970,1,1,1,0,0), "ЧГ=0"); //переводим дату в unixtime 
    Попытка
        ТекстSQL = "insert INTO chat
    |(
    | author, 
    | data,
    | text
    |) VALUES (
    | '"+Пользователь+"',
    | '"+Дата+"',
    | '"+Текст+"'
    |);";
    ss=Connection.Execute(текстSQL);
    Connection.Close();
Исключение
        Сообщить(ОписаниеОшибки());
      Возврат "" ;
    КонецПопытки;   
КонецФункции
////////////////////
////Проверяем наличие сообщений для оповещения пользователя из таблицы feed
/// на начало и конец текущего дня
// возвращаем Значение
  &НаСервере
  Функция ПроверитьСлужебныеСообщения() Экспорт
   
    SQLiteObject = Новый COMОбъект("ADODB.Connection");
  SQLiteConnectionString = ПолучитьConnectStringDBchat();
  Попытка
      SQLiteObject.Open(SQLiteConnectionString);
  Исключение
              Сообщить(ОписаниеОшибки());
      Возврат "" ;
  КонецПопытки;
  RS = Новый COMОбъект("ADODB.RecordSet");
  Стр = "feed";
    ДатаНачала = НачалоДня(ТекущаяДата());
    ДатаНачалаU = Формат(Число(ДатаНачала - Дата('19700101')),"ЧГ=0");
    ДатаКонца = КонецДня(ТекущаяДата());
    ДатаКонцаU = Формат(Число(ДатаКонца - Дата('19700101')),"ЧГ=0");
    RS.Open("SELECT text
    |FROM "+стр+" 
    |WHERE data > "+ДатаНачалаU+" 
    |AND data < "+ДатаКонцаU+"" , SQLiteObject);
 
  Если Не Rs.eof Тогда
  rs.MoveFirst();
  КонецЕсли;
  Пока Не Rs.eof Цикл
    Значение = Rs.Fields.Item("text").Value ;
  rs.MoveNext();
    КонецЦикла;
  SQLiteObject.Close();
    Возврат Значение;
КонецФункции
//////////////
///////Отправка сообщений на сервер из внешней обработки "Оповещения" в таблицу feed
&НаСервере
Функция  ВыгрузкаСлужебныхСообщений(Текст) Экспорт
   
    ConnectString=ПолучитьConnectStringDBchat();
    Connection = Новый COMОбъект("ADODB.Connection");
    Connection.open(ConnectString);   
    Дата=ТекущаяДата();
    Пользователь = Пользователи.ТекущийПользователь();
    Текст = Текст;
    Дата = Формат(Дата - Дата(1970,1,1,1,0,0), "ЧГ=0");
    Попытка
       
        ТекстSQL = "insert INTO feed
    |( 
    | data,
    | text
    |) VALUES (
    | '"+Дата+"',
    | '"+Текст+"'
    |);";
    ss=Connection.Execute(текстSQL);
    Connection.Close();
Исключение
        Сообщить(ОписаниеОшибки());
      Возврат "" ;
    КонецПопытки;   
КонецФункции
////////////////////
/////Очищаем таблицу feed из внешней обработки "Оповещения"
//Чтобы у пользователя не выскакивало окно с оповещением 
&НаСервере
Функция УдалитьСообщенияОповещения () Экспорт
    SQLiteObject = Новый COMОбъект("ADODB.Connection");
  SQLiteConnectionString = ПолучитьConnectStringDBchat();
    SQLiteObject.Open(SQLiteConnectionString);
    Попытка
    ТекстSQL = "TRUNCATE TABLE feed ";
    SQLiteObject.Execute(текстSQL);
    Сообщить("Информация успешно удалена с сервера");
      Исключение
    Сообщить(ОписаниеОшибки());
      Возврат "" ;
  КонецПопытки;
  SQLiteObject.Close();
КонецФункции

Осталось теперь создать две обработки. Начнем с Чата!

Создаем обработку, добавляем реквизит "Текст" на форму кидаем ПолеВвода с этим реквизитом и ТабличноеПоле с именем "ЧатПоле".

Для кнопки "Выполнить" пишем следующую процедуру.

Процедура КнопкаВыполнитьНажатие(Кнопка)
    Если Не ЗначениеЗаполнено(Текст) Тогда
        Сообщить("А кто будет заполнять поле?");
        Возврат;
    Иначе
        ОбщийМодульЧат.ВыгрузкаChat(Текст);
    КонецЕсли;
    ЭлементыФормы.ПолеВвода1.Значение = "";
КонецПроцедуры

На этом все, добавляем обработку в конфигурацию!

Обработка оповещения добавляем реквизит "Текст" на форму кидаем ПолеВвода с этим реквизитом и еще одну кнопку "Удалить" для удаления сообщений с сервера.

    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Текст = ЭлементыФормы.ПолеВвода1.Значение;
    Если Не ЗначениеЗаполнено(Текст) Тогда
        Сообщить("А кто будет заполнять поле?");
        Возврат;
    иначе
    ОбщийМодульЧат.ВыгрузкаСлужебныхСообщений(Текст);
    КонецЕсли;
    ЭлементыФормы.ПолеВвода1.Значение = "";
КонецПроцедур


Процедура УдалитьНажатие(Элемент)
    ОбщийМодульЧат.УдалитьСообщенияОповещения();
КонецПроцедуры

Вот результат, и спасибо всем за внимание!

Скачать файлы

Наименование Файл Версия Размер
Чат и оповещение пользователей 1С+Mysql:

.rar 8,11Kb
8
.rar 8,11Kb 8 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
5. BigB 182 31.05.17 14:35 Сейчас в теме
(4) С чего Вы решили, что "Система взаимодействия" реализованная в 8.3.10 стоит денег? Мы ей уже пользуемся и ни копейки не платим.
6. DonAlPatino 151 01.06.17 11:06 Сейчас в теме
(5) Ну так поделитесь как оно, какие грабли и стоит ли того, чтобы в это влезать?
7. BigB 182 01.06.17 11:24 Сейчас в теме
(6) Лично мне нравится. Пока в ней нет звонков, но текстовые сообщения реализованы нормально.
9. DonAlPatino 151 01.06.17 13:32 Сейчас в теме
(7) Ну мне больше интересно мнение пользователей, как они ее используют в работе и кол-во пользователей?
10. BigB 182 01.06.17 13:54 Сейчас в теме
(9) 50 пользователей одновременно в базе. Раньше в скайпе переписывались, теперь в 1С.
Самое интересное это то, что сообщения работают и в копии рабочей базы, которая находится на другом сервере. Во как.
Никакой код в 1С писать не надо. Достаточно её просто включить и можно пользоваться.
Подробнее можно почитать тут https://wonderland.v8.1c.ru/blog/sistema-vzaimodeystviya/
1. starik-2005 2252 25.05.17 17:05 Сейчас в теме
Для чата, ИМХО, лучше использовать механизмы именованных очередей. Их поддерживает, например, REDIS. MySQL здесь явно избыточен.
Сурикат; +1 Ответить
4. JohnnyAlexandrov 20 26.05.17 13:36 Сейчас в теме
(1) Для 30-60 пользователей, которые будут активно переписываться и сообщения в среднем будут весить 5-10кб MySql вполне должен справиться.

(2) Это простой пример реализации, и не нужно ходить к каждому и устанавливать, а потом объяснять как пользоваться jabber, так можно то и просто беседу в viber создать и там общаться)

(3) А вот этот велосипед стоит денег.
2. nytlenc 25.05.17 18:16 Сейчас в теме
Для чата, ИМХО, лучше использовать Jabber сервер, созданный как раз специально для этого, совершенно бесплатно заметьте, а не изобретать велосипед.
3. unichkin 1332 25.05.17 23:34 Сейчас в теме
8. Matveev_VS 01.06.17 11:32 Сейчас в теме
Оставьте свое сообщение

См. также

Установка предопределенных элементов: просмотр, исправление и поиск ошибок (задвоенных и отсутствующих) Промо

Инструментарий разработчика Универсальные обработки v8 1cv8.cf Абонемент ($m)

Простая обработка для просмотра и установки значений предопределенных элементов. Позволяет заменить значение предопределенного элемента с одного элемента справочника на другой, удалить предопределенный элемент (снять пометку предопределенности), установить пометку переопределенного элемента. Проверяет предопределенные данные на наличие задвоений и отсутствующих. Работает со справочниками, планами счетов, планами видов характеристик, планами видов расчетов.

2 стартмани

06.10.2014    155125    2621    ekaruk    166    

Панель #Расширение объекта: Редактор, Права, Поиск, Сторно, Обмен

Универсальные обработки v8 1cv8.cf Абонемент ($m)

Панель команд текущего объекта (документа, справочника и т.д.) со следующим возможностями: Редактор реквизитов, таблиц и движений текущего объекта, Анализ прав доступа к текущему объекту, Поиск ссылок на объект с отборами, Сторно движений документа, Выгрузка/загрузка текущего объекта между базами. Реализована всплывающей панелью в форме объекта. Подключается как расширение конфигурации (*.cfe) либо отдельными обработками.

1 стартмани

01.05.2020    9981    93    sapervodichka    1    

Работа с файлами (обычная и управляемая форма)

Универсальные обработки v8 v8::УФ 1cv8.cf Абонемент ($m)

Нужно загрузить файл с клиента на сервер или же, наоборот, файл загрузить с сервера на клиент, а впридачу все это на web-клиенте, да еще и асинхронно? Нет ничего проще, читай далее, как это сделать!

1 стартмани

10.06.2019    28809    162    Xershi    76    

Блин, мы забыли включить регламентные задания…

Сервисные утилиты v8 Абонемент ($m)

Привет, Инфостарт! Сегодня расскажу, как я решил проблему с выключенными регламентными заданиями в рабочих базах. Желая исключить человеческий фактор и минимизировать количество ошибок, я написал небольшую конфигурацию.  В конфигурации два регламентных задания. Первое периодически подключается к кластеру и сохраняет текущие параметры: имя, Сервер БД, базу СУДБ, блокировки входа и регламентных заданий и т.д. Второе задание периодически проверяет эти параметры на ошибки.

1 стартмани

08.04.2019    19016    17    slozhenikin_com    37    

Навигатор по конфигурации базы 1С 8.3 Промо

Структура метаданных Универсальные обработки v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная внешняя обработка для просмотра метаданных конфигураций баз 1С 8.3. Отображает свойства и реквизиты объектов конфигурации, их количество, основные права доступа и т.д. Отображаемые характеристики объектов: свойства, реквизиты, стандартные рекизиты, реквизиты табличных частей, предопределенные данные, регистраторы для регистров, движения для документов, команды, чужие команды, подписки на события, подсистемы. Отображает структуру хранения объектов базы данных, для регистров доступен сервис "Управление итогами". Платформа 8.3, управляемые формы. Версия 1.1.0.75 от 15.01.2021

3 стартмани

28.10.2018    36442    322    ROL32    72    

LicDataDecoder - расшифровка файла программной лицензии 1С

Сервисные утилиты v8 1cv8.cf Россия Абонемент ($m)

Представляю вашему вниманию утилиту, предназначенную для работы с файлами программных лицензий 1С (*.lic).

1 стартмани

10.02.2019    35691    311    GeraltSnow    62    

Редактор объектов информационной базы 8.3

Универсальные обработки Обмен через XML v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.51 от 31.08.2020

2 стартмани

23.01.2019    32642    350    ROL32    39    

Сравнение pdf-файлов актов сверки

Универсальные обработки Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Обработка сравнивает два pdf-файла, в которых находятся стандартные печатные формы актов сверки, и показывает на экране совпадающие и/или отличающиеся по суммам документы взаиморасчетов.

1 стартмани

19.12.2018    18686    14    Torin99    2    

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) Промо

Перенос данных из 1C8 в 1C8 Универсальные обработки Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Абонемент ($m)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    210800    4235    ekaruk    184    

Легкое и гибкое управление списком доступных баз 1С у пользователей

Стартеры 1С Сервисные утилиты Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

7 стартмани

05.12.2018    17041    19    RomikR    9    

Выгрузка изображений из справочника на диск

Учет ТМЦ Универсальные обработки Учет ТМЦ v8 УТ11 Оптовая торговля, дистрибуция, логистика Россия Абонемент ($m)

Обработка позволяет записать изображения из справочка Номенклатура на диск в указанное место.

1 стартмани

30.11.2018    18969    7    wrooom    8    

Обнуление остатков регистров бухгалтерии и накопления

Универсальные обработки Чистка базы v8 v8::БУ v8::ОУ v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ БГУ ERP2 БП3.0 УТ11 УХ КА2 ЗУП3.x Россия Абонемент ($m)

Обработка позволяет обнулить остатки по регистру накопления или бухгалтерии на определенную дату. Поддерживается большинство типовых конфигураций (БП 3, БП 2, УТ 11, УТ 10, ЗУП 3, ЗУП 2, БГУ 2, БГУ 1, ERP, УПП, КА 2, КА 1, УХ 3, УХ 1, УНФ). Гибкая настройка (отборы, заполнение реквизитов и любых полей корр. счета, возможность обнулять ресурсы выборочно). Несколько режимов работы. Два интерфейса: простой и с расширенным набором настроек.

2 стартмани

19.11.2018    25329    332    morozov.sv    52    

Обработка "Распознавание штрихкода с помощью утилиты Zbar" для Документооборот ред. 2 Промо

Универсальные обработки Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Абонемент ($m)

В связи с тем, что стандартный функционал программы «Документооборот» ред. 2.1 дает возможность распознавания штрихкодов только форма EAN-13, данная обработка - альтернативный способ для распознавания штрихкода в программе 1С: Документооборот ред. 2 с помощью утилиты Zbar, которая распознает в том числе и в формате Code 128 (один из стандартных штрихкодов кодирования документов, например, «Управление торговлей» ред. 11), а также с возможностью поэтапно проследить все действия от распознавания до прикрепления к документу или простой загрузки в каталоги файлов в базе 1С.

5 стартмани

05.09.2016    21932    164    SEOAngels    11    

Очистка кэша 1С 8 (8.0, 8.1, 8.2, 8.3). Грамотная чистка кэша 1С с сохранением настроек.

Чистка базы Сервисные утилиты Администрирование данных 1С v8 1cv8.cf Россия Абонемент ($m)

Эффективное средство для устранения ошибок, возникающих в локальном кэше 1С на клиенте, которым легко сможет воспользоваться пользователь с любым уровнем знаний. Wsf-скрипт, созданный на стандартном языке автоматизации Windows - "WSH JScript", очищает кэш 1С просто, быстро и безопасно. Кроме варианта, очищающего кэш текущего пользователя, имеется также вариант для чистки кэша 1С всех пользователей терминального-сервера.

1 стартмани

04.11.2018    40930    422    Eugen-S    34    

Универсальный инструмент для переноса данных через табличный документ (УФ)

Обработка документов Универсальные обработки Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Для опытных пользователей, разработчиков, администраторов, консультантов

5 стартмани

15.10.2018    36015    133    json    42    

Просмотр, изменение реквизитов объекта. Сравнение двух одинаковых объектов метаданных ИБ

Универсальные обработки v8 1cv8.cf Россия Абонемент ($m)

Показывает реквизиты объекта (ов) или сравнивает два одинаковых объекта конфигурации справочники, документы.

1 стартмани

26.04.2018    19315    25    Vin_Tik    0    

Перемещение остатков по счету МЦ04 между материально ответственными лицами для конфигураций (8.2). Промо

Обработка документов Универсальные обработки Учет ТМЦ Учет ТМЦ v8 БП2.0 Россия БУ Абонемент ($m)

Небольшая обработка, которая позволяет перекидывать остатки по счету МЦ04 с одного материально ответственного лица на другое

1 стартмани

22.11.2012    16440    102    niksaf    4    

Построение маршрута доставки с расчётом расстояния для любой базы УФ

Универсальные обработки WEB Оптовая торговля Оптовая торговля v8 v8::УФ 1cv8.cf Абонемент ($m)

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    37218    43    KorotkovRV    16    

Быстрое удаление неиспользуемых версий 1С:Предприятие 8, кэша метаданных и информационных баз

Сервисные утилиты v8 Абонемент ($m)

При обновлении платформы 1С:Предприятие 8 предыдущие версии не удаляются. Со временем количество неиспользуемых версий платформы растет. Они занимают место на диске. Для решения этой проблемы предназначена программа OneCleaner. Она позволяет быстро удалить неиспользуемые версии платформы, а также почистить кэш метаданных и удалить ненужные информационные базы данных.

1 стартмани

14.11.2017    22958    90    bonv    15    

Графическая оболочка для консольной утилиты cnvdbfl.exe

Сервисные утилиты v8 Абонемент ($m)

Графическая оболочка для консольной утилиты cnvdbfl.exe предназначенной для преобразования размера внутренней страницы файла базы 1С.

1 стартмани

25.10.2017    40902    275    frkbvfnjh    43    

Работа с картами 1С 4 в 1: Яндекс, Google , 2ГИС, OpenStreetMap(OpenLayers) Промо

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

С каждым годом становится все очевидно, что использование онлайн-сервисов намного упрощает жизнь. К сожалению по картографическим сервисам условия пока жестковаты. Но, ориентируясь на будущее, я решил показать возможности API выше указанных сервисов: Инициализация карты Поиск адреса на карте с текстовым представлением Геокодинг Обратная поиск адреса по ее координатами Взаимодействие с картами - прием координат установленного на карте метки Построение маршрутов по указанным точками Кластеризация меток на карте при увеличении масштаба Теперь также поддержка тонкого и веб-клиента

1 стартмани

28.12.2012    108614    2675    Smaylukk    358    

Инструменты бухгалтера: Виджеты рабочего стола

Универсальные обработки Рабочее место v8 v8::БУ БП3.0 Абонемент ($m)

Настраиваемые виджеты на начальной странице, своеобразная панель для быстрого доступа к объектам. Виджеты это элементы интерфейса в виде цветных прямоугольников со ссылками на объекты конфигурации. Использование виджетов позволяет сконцентрировать на начальной странице часто используемые функции, например, варианты отчетов, списки документов, или используя виджет вводить новый документ прямо из начальной страницы.

2 стартмани

28.08.2017    39052    177    Bazil    28    

ОСкрипты для деплоя и копирования базы данных

Сервисные утилиты v8 1cv8.cf Абонемент ($m)

Набор оскриптов для деплоя базы 1С через хранилище и копирование через sql-бекап одной базы в другую

1 стартмани

02.05.2017    24832    34    Stepa86    27    

Автокликер для 1С

Сервисные утилиты v8 1cv8.cf Абонемент ($m)

Внешняя обработка, запускаемая в обычном (неуправляемом) режиме для автоматизации действий пользователя (кликер). ActiveX компонента, используемая в обработке, получает события от клавиатуры и мыши по всей области экрана в любом приложении и транслирует их в 1С, получает информацию о процессах, текущем активном приложении, выбранном языке в текущем приложении, умеет сохранять снимки произвольной области экрана, активных окон, буфера обмена, а также, в режиме воспроизведения умеет активировать описанные выше события. Все методы и свойства компоненты доступны при непосредственной интеграции в 1С. Примеры обращения к компоненте представлены в открытом коде обработки.

1 стартмани

03.04.2017    32296    76    slava_1c    67    

Консоль сравнения данных (1С 8, 1С 7.7, SQL, CSV, TXT, DBF, XLS, DOC, XML, JSON, табличный документ) (версия 15.4.56)

Универсальные обработки v8 1cv8.cf Абонемент ($m)

Обработка Консоль сравнения данных (КСД) предназначена для сравнения данных, полученных из разных источников данных: информационных баз 1С 8, 1С 7.7, баз данных SQL, файлов формата CSV/TXT/DBF/XLS/DOC/XML, строки JSON, вручную заполненного табличного документа. Минимально необходимая версия платформы: 8.3.6.1977.

1 стартмани

13.02.2017    35463    130    sertak    103    

Поиск и отключение зависших сеансов на сервере 1С: Предприятия

Универсальные обработки v8 1cv8.cf Россия Абонемент ($m)

Обработка предназначена для мониторинга и отключения спящих (зависших) сеансов на сервере 1С: Предприятия.

1 стартмани

14.09.2016    33955    62    wowchik_85    12    

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Обработка документов Универсальные обработки Обмен через XML v8 Абонемент ($m)

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    43190    158    Aphanas    4    

Универсальный поиск объектов по глобальному уникальному идентификатору (ГУИД, GUID)

Универсальные обработки Поиск данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Универсальная обработка поиска объектов информационной базы по глобальному уникальному идентификатору (ГУИД, GUID) или по его части.

1 стартмани

06.09.2016    34431    105    Dzenn    9    

Оптимальный способ расчета контрольной суммы объекта/записи регистра (CRC32, MD5, SHA1, SHA256)

Универсальные обработки v8 1cv8.cf Абонемент ($m)

Была задача сравнить документы в распределенных базах и пометить на выгрузку измененные. Но сравнение изменений документов методом перебора реквизитов - долгоиграющий процесс, особенно если общее количество сравниваемых данных переваливает за миллион. Был найден выход, который ускоряет процесс сравнения - расчет контрольной суммы объекта и сравнение ее с другой контрольной суммой. Скорость сравнения увеличивается во много раз.

1 стартмани

01.08.2016    33033    7    hakerxp    9    

Просмотр данных системы Платон на картах Google

Универсальные обработки WEB v8 1cv8.cf Автомобили, автосервисы Транспорт, автопарки, такси Абонемент ($m)

Обработка для просмотра предполагаемых треков движения транспортного средства на карте Google согласно данным, предоставляемым системой Платон в формате CSV. Работает под 8.2 и 8.3, обычное и управляемое приложение, может подключаться к типовым конфигурациям в качестве внешней обработки.

1 стартмани

15.04.2016    34459    19    anig99    8    

ЕГАИС: код алкогольной продукции из штрихкода акцизной марки

Универсальные обработки Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Акцизы Абонемент ($m)

В последнее время мне пришлось потратить очень много времени на внедрение и реализацию функционала ЕГАИС. Очень часто, на форумах, я встречал вопрос: "Как из штрих-кода акцизной марки получить код алкогольной продукции ЕГАИС?". Несколько раз видел неверную реализацию этой задачи. Глядя на это, я набросал простую обработку пересчета кода акцизной марки (base36) в понятный нам уникальный ФСРАР ID алкогольной продукции (Base10).

1 стартмани

11.02.2016    58695    159    OrcaMax    29    

Снимок экрана для 1С

Универсальные обработки Разработка внешних компонент v8 1cv8.cf Россия Абонемент ($m)

Довольно часто люди сталкиваются с необходимостью сделать снимок экрана. Если вы или ваши сотрудники основную часть времени проводят в 1С и у вас есть необходимость прикреплять графические файлы, то эта компонента для вас.

1 стартмани

08.02.2016    28843    34    linkforget    11    

Генерация QR-кода программная и интерактивная (код открыт, управляемая форма, обычное и управляемое приложение, API)

Универсальные функции Универсальные обработки v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработку можно быстро и легко интегрировать в любую конфигурацию с и без БСП (Библиотека Стандартных Подсистем).

3 стартмани

04.02.2016    49677    174    TuneSoft    30    

Интерфейс сопоставления объектов для обмена (для типового регистра СоответствиеОбъектовДляОбмена)

Инструментарий разработчика Универсальные обработки Перенос данных из 1C8 в 1C8 v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 Абонемент ($m)

Вы внедряете обмен данными между двумя типовыми или основанными на типовых БД и вам необходим инструмент, чтобы сопоставить между собой справочники этих конфигураций? Вы хотите навести порядок в обмене данными, потому что вам надоело вылавливать дублирующиеся объекты? Вам очень хочется перепоручить сопоставление объектов обменивающихся баз пользователям, но нет подходящего и понятного пользователям интерфейса? Тогда вам нужна именно эта обработка!

4 стартмани

11.11.2015    41153    108    catsam    8    

[x1c.ru] MXL Stamps - Печати и подписи в макетах печатных форм в несколько кликов

Печатные формы документов Универсальные обработки v8 1cv8.cf Абонемент ($m)

Обработка позволяет быстро создавать поля текста из ячеек печатных форм и добавлять "под них" подписи и печати. Работает в конфигурациях на управляемых формах.

1 стартмани

22.08.2015    37523    18    GusevNA    6    

Работа с push сервисами только средствами 1С 8.2

Сервисные утилиты Инструментарий разработчика Универсальные обработки v8 Абонемент ($m)

Обработка для настройки, тестирования и использования с предустановками для 3-х сервисов. Текст модуля для внедрения в конфигурацию или другие обработки. Уведомления на телефон, компьютер, браузер.

1 стартмани

18.08.2015    31685    46    anig99    1    

Telemonitor - объединяем Telegram и 1С

Сервисные утилиты Администрирование данных 1С Мобильная разработка v8 1cv8.cf Абонемент ($m)

Не так давно Telegram предоставил API для создания ботов. Telemonitor - программа, позволяющая легко настроить собственного бота для работы с 1С.

1 стартмани

09.08.2015    79147    225    salexdv    178    

Бот для Telegram (платформа 1С 8.3.6+)

WEB Сервисные утилиты v8 v8::УФ 1cv8.cf Абонемент ($m)

Создатели IM-клиента Telegram первыми среди конкурентов открыли API для ботов. Данная разработка представляет собой готовый инструмент для создания бота на 1С.

10 стартмани

26.06.2015    42414    291    vano-ekt    25    

Отключение назойливых окон и подтверждение легальности обновления(!) для БП 3.0 при помощи расширения

Сервисные утилиты v8 БП3.0 Россия Абонемент ($m)

Отключение назойливых окон и подтверждение легальности обновления(!) для БП 3.0 при помощи расширения

1 стартмани

25.06.2015    47607    281    Йожкин Кот    55    

Завершение работы пользователей (выгонялка)

Сервисные утилиты v8 1cv8.cf Россия Абонемент ($m)

Обработка для завершения сеансов пользователей для клиент-серверной базы данных, с возможностью включения монопольного доступа к базе. Разработана на платформе 8.3. Запускается на любой конфигурации, как типовой, так и самописной, как в обычном режиме, так и в управляемом.

1 стартмани

17.06.2015    31087    275    Rusleg    27    

Универсальная обработка "Изменение записей регистров сведений и накопления" (8X)

Универсальные обработки v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Обработка для Добавления/удаления/изменения записей в любых регистрах сведений (подчиненных и не подчиненных регистраторам) и накопления. Для Платформ 8.1, 8.2, 8.3

2 стартмани

24.05.2015    69510    1617    Erofeevgv    66    

Нейронная сеть. Создаем, учим и используем. В одной обработке

Инструментарий разработчика Универсальные обработки v8 Абонемент ($m)

Обработка для создания, обучения и использования многослойного персептона на платформе родного и любимого 1С-а.

1 стартмани

12.05.2015    40109    240    dusha0020    52    

Яндекс (Yandex) Диск. Обновляйте свои внешние обработки, обработки заполнения, печатные формы и отчеты.

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

Хранить свои внешние обработки на внешнем носителе типа Yandex диска удобно, а обновлять в базах 1С еще удобней.

1 стартмани

15.04.2015    39981    130    Patriot1S    37    

Подсистема проверки контрагентов через сервис ГосРеестра для объединения с любой конфигурацией (или автономной работы)

Универсальные обработки Обработка справочников v8 1cv8.cf Абонемент ($m)

Еще один вариант для проверки контрагентов через сервис ФНС. Механизм аналогичен проверке в типовой БП 3.0 и полностью автономен, можно объединить с любой конфигурацией. При первом запуске просит ввести логин и пароль для доступа к сайту поддержки 1С.

1 стартмани

06.04.2015    23323    53    Foxes82    12