Иерархическая нумерация в отчете, основанном на СКД

Программирование - Практика программирования

Правильная!! иерархическая нумерация в отчете на СКД, с учетом всех группировок, в том числе иерархических справочников

Перерыл весь Инфостарт, но так и не нашел готового решения по иерархической нумерации в отчете на СКД. Делюсь своим вариантом решения.

1. Добавляем в отчет вычисляемое выражение

2. Добавляем макет поля на закладке макеты

3. На закладке Настройки для всех! группировок указываем в выбранных полях наше новое поле

Со схемой все.

Далее в модуле отчета, после вывода, пишем постобработку. Для обработки желательно знать первую строку отчета, чтобы не лопатить шапку.

Поиск колонки с номерами

		// Номер по порядку
		Если КолонкаНомераПоПорядку = 0 Тогда
			Для Кол = -Результат.ШиринаТаблицы По -1 Цикл
				Для Стр = Результат.Области.Заголовок.Низ+1 По ПерваяСтрокаОтчета Цикл
					ТекстРасшифровки = Результат.Область(Стр, -Кол).Текст;
					Если ТекстРасшифровки = "№ п/п" Тогда
						КолонкаНомераПоПорядку = -Кол;
						Прервать;
					КонецЕсли;
				КонецЦикла;
			КонецЦикла;
		КонецЕсли;

Собственно проставление номеров

	Если Результат.ВысотаТаблицы = 0
		ИЛИ ПерваяСтрокаОтчета = 0
		ИЛИ КолонкаНомераПоПорядку = 0 Тогда
		Возврат;
	КонецЕсли;
	
	// Проставим иерархические номера
	
	НомераВерхнихУровней = Новый Соответствие();
	НомераВерхнихУровней.Вставить("Уровень1", 0);
	МаксимальныйУровень = 7;
	ПрошлыйУровень = МаксимальныйУровень;
	
	// проходим по всем строкам нужной колонки и заполняем номера
	Для Стр = ПерваяСтрокаОтчета+1 По Результат.ВысотаТаблицы-1 Цикл
		ЗначенияПолейРасшифровки = ДанныеРасшифровки.Элементы[Результат.Область(Стр, КолонкаНомераПоПорядку).Расшифровка].ПолучитьПоля();
		ПолеУровень = ЗначенияПолейРасшифровки.Найти("Уровень");
		Если ПолеУровень = Неопределено Тогда
			Возврат;
		КонецЕсли;
		Если ПолеУровень.Значение < ПрошлыйУровень Тогда
			// обнулим более низкие уровни
			Для ТекущийУровень = ПолеУровень.Значение + 1 По МаксимальныйУровень Цикл
				НомераВерхнихУровней.Вставить("Уровень"+ТекущийУровень, 0);
			КонецЦикла;
		КонецЕсли;
		// увеличиваем текущий уровень
		НомераВерхнихУровней.Вставить("Уровень"+ПолеУровень.Значение, НомераВерхнихУровней["Уровень"+ПолеУровень.Значение]+1);
		// получаем полный номер, с учетом всех вышестоящих уровней
		Номер = "";
		Для ТекущийУровень = 1 По ПолеУровень.Значение Цикл
			Номер = Номер + НомераВерхнихУровней["Уровень"+ТекущийУровень] + ".";
		КонецЦикла;
		Результат.Область(Стр, КолонкаНомераПоПорядку).Текст = Лев(Номер, СтрДлина(Номер)-1);
	КонецЦикла;

У меня этот код вынесен в отдельную функцию

Надеюсь, что мой лайфхак будет полезен для всех любителей СКД. Если у вас есть свой вариант, то делитесь им и я с удовольствием размещу ссылки на этой странице.

См. также

Комментарии
1. Maxim Kolkin (the1) 289 22.06.17 10:00 Сейчас в теме
Лукавите) СКД тут не при чём
itriot11; logarifm; olbu; Трактор; Rustig; nixel; +6 Ответить
2. Илья Васильев (swimdog) 513 22.06.17 10:16 Сейчас в теме
(1) Как же не при чем? Отчет на СКД, настройки в схеме СКД)
3. Maxim Kolkin (the1) 289 22.06.17 10:43 Сейчас в теме
(2) А нумерация в модуле.
logarifm; ice-net; olbu; kadild; 7OH; JohnyDeath; nixel; +7 Ответить
6. ediks (ediks) 325 22.06.17 13:45 Сейчас в теме
(3)
А нумерация в модуле.

Не поверите, но отчет на СКД тоже можно скомпоновать в модуле :). От этого отчет не перестает быть отчетом, выполненным на СКД.
Пока никто не предложил другого решения, то это единственный способ.
23. г. Казань Рустем Гумеров (Rustig) 835 27.09.17 08:45 Сейчас в теме
(6)
Пока никто не предложил другого решения, то это единственный способ.

Для информации:
есть старый способ - использовать для построения отчетов обычную внешнюю обработку - алгоритм построения отчета прописать в модуле обработки, там же прописать вывод полей отчета. Вот примеры, где я использую внешнюю обработку для построения разнообразных отчетов или разнообразных механизмов
https://infostart.ru/public/664095/
https://infostart.ru/public/195627/
https://infostart.ru/public/338386/
- о чем я и говорю: прорисовываете свой интерфейс отчета (макеты), закладываете свою алгоритмическую логику в отчет. Никакого СКД.
Много лет использую - уникальность и универсальность такого способа в том, что таким способом можно создавать сложные и в то же время интересные клиенту отчеты, которые нельзя создать с помощью только СКД без дополнительного программирования в модуле СКД.
То , что вы в модуле прописали алгоритм вывода иерархии, совсем не связано с СКД, как это многими воспринимается в заголовке статьи. Как будто вы обошли ограничение СКД. СКД изначально подается как универсальный инструмент для использования без дополнительного программирования. Если уж начинаете программировать модули, то эффективнее использовать внешнюю обработку.
СКД имеет много ограничений, достаточно сложна для понимания и использования для построения сложных отчетов.
В СКД есть много плюсов - она универсальна для построения простых отчетов. И на основе СКД придумано много интересных механизмов. Но ваша статья не об этом, поэтому и я не буду развивать эту тему.
Вы молодец, что придумали такой способ, и что описали в статье.
Есть любители использовать СКД всегда и везде, а я за золотую середину и компромисс - где-то лучше СКД https://infostart.ru/public/559116/,
где-то - внешнюю обработку и отчет на основе программного вывода данных в табличный документ.
24. Илья Васильев (swimdog) 513 27.09.17 17:51 Сейчас в теме
(23) Есть еще вариант - сделать таблицу и скормить ее СКД. И программисты из 1С часто пользуются этим способом при построении сложных отчетов, которые внутри СКД не построить.
Огромный плюс СКД в том, что не надо рисовать макеты, формы. И самый большой плюс, что пользователь может перестраивать внешний вид отчета, группировки под себя. Особенно продвинутые пользователи.
Моя статья именно для таких отчетов.
А делать отчеты без СКД мы умеем еще со времен 7.7 ))
4. Иван Иванов (spe1c) 22.06.17 10:46 Сейчас в теме
5. Игорь Кахановский (IgorroPadavan) 3 22.06.17 11:32 Сейчас в теме
Спасибо за открытый код решения!
На производительность в больших отчетах насколько влияет- не измеряли?
7. Руслан Рябов (Flover) 11 22.06.17 14:28 Сейчас в теме
И при чем тут СКД, когда табличный документ скомпонован, данные выведены и сгруппированы там?

Вот если в схеме аналогичное действие сделать - тогда да, можно смело написать что это СКД.
olbu; Rustig; +2 Ответить
8. Имя Фамилия (user774630) 22.06.17 14:56 Сейчас в теме
(7) Присоединяюсь. Можно написать с тем же успехом "Иерархическая нумерация в Windows".
olbu; the1; +2 Ответить
11. Илья Васильев (swimdog) 513 22.06.17 16:07 Сейчас в теме
(8) Иерархическая нумерация в СКД является частным случаем "Иерархическая нумерация в Windows". Поэтому мое название точнее и больше подходит к теме статьи.
9. Maxim Kolkin (the1) 289 22.06.17 15:47 Сейчас в теме
10. ediks (ediks) 325 22.06.17 16:04 Сейчас в теме
(7), (8), (9) Не заметили, в основе постобработки лежат поля, определенные в схеме СКД, добавлен свой макет?
12. Илья Васильев (swimdog) 513 22.06.17 16:10 Сейчас в теме
(10) Кстати, да. Обычный отчет этим кодом не пронумеруешь. Его надо дополнять, чтобы узнать уровень группировки.
14. Maxim Kolkin (the1) 289 22.06.17 16:50 Сейчас в теме
(10)
в основе постобработки
ключевое слово.
Никто же не говорит, что метод плохой, просто это не чистая СКД, а с постобработкой
17. Илья Васильев (swimdog) 513 22.06.17 18:16 Сейчас в теме
(14) Согласен, используется модуль отчета. Одной схемой обойтись не получилось.
13. Илья Васильев (swimdog) 513 22.06.17 16:15 Сейчас в теме
(7) Я встречал варианты, как это сделать в самой схеме, но у меня они не заработали. Возможно, в новых релизах эти способы и сработают. У меня не взлетело.
Вот, например, ссылка: http://forum.infostart.ru/forum9/topic146206/
Кстати, там все жестко завязано на группировках. В моем решении группировки могут меняться.
15. Роман Уничкин (unichkin) 699 22.06.17 17:35 Сейчас в теме
ИМХО, было бы интереснее разработать алгоритм нумерации выходного табличного документа.. Вставить колонку перед телом отчета, и пронумеровать ее сообразно иерархии, после вывода. А СКД вообще не трогать.
16. Илья Васильев (swimdog) 513 22.06.17 18:13 Сейчас в теме
(15) Все бы хорошо, но как по таблице узнать уровень строки?
18. Vladimir Polyakov (spectre1978) 40 22.06.17 21:54 Сейчас в теме
Написание кода в СКД, мне кажется, не есть гуд. Нечистая работа, как говорил Остап Бендер. Цимес СКД как раз в том что вы мышкой отчет делаете. А если код писать - так это и клюшки-стайл ничем не плох, с Вывести () и Присоединить ().
19. Илья Васильев (swimdog) 513 23.06.17 01:15 Сейчас в теме
(18) Последние строки статьи написаны именно для Вас )))
25. Роман Ложкин (webester) 24 02.10.17 08:51 Сейчас в теме
(18)Про это писал рустиг в (23) но полностью самостоятельно писать вывод отчета, тоска смертная: вывод заголовков настройка оформления, сбор итогов и пр. всегда даю это на откуп СКД. Ничего плохого нет в постобработке, но да просто заголовок некорректный СКД тут как бы уже не при делах. Можно было бы написать "Нумерация в табличном документе сформированном средствами СКД" это было бы честнее.
26. Илья Васильев (swimdog) 513 02.10.17 12:48 Сейчас в теме
(25) Нумерация в табличном документе сформированном средствами СКД - программистское название. Но в целом согласен, что по названию ждали большего.
20. Яков Коган (Yashazz) 2148 27.06.17 16:22 Сейчас в теме
Фигня. Ибо пост-обработка. На ИС были в разы более красивые решения. Не понимаю, откуда столько плюсов, сиречь восторгов.
21. Илья Васильев (swimdog) 513 27.06.17 17:58 Сейчас в теме
22. Александр (Bell) 33 03.07.17 20:02 Сейчас в теме
Десять дет назад я делал иерархический нумератор (не отчет), еще в 7.7. см. в базе.
Оставьте свое сообщение