Многоуровневая нумерация в отчете СКД (программный вывод)

Публикация № 956767

Разработка - Практика программирования

Иерархическая нумерация многоуровневая СКД

Реализация многоуровневой нумерации при программном выводе отчета СКД основываясь на его структуре.

Задача: нередко при разработке отчетов возникает необходимость многоуровневой нумерации элементов отчета в соответствии с его структурой. Система компоновки данных не предоставляет средств для решения этой задачи. Проблема усугубляется в случае отчетов с иерархической группировкой где количество уровней вложенности произвольно и заранее неизвестно.

Попытки решения данной задачи только средствами СКД успехом не увенчались. Поиск существующих решений желаемых результатов не принес:

  • вариант Ильи Васильева (swimdog) имеет ограничение по уровням вложенности и требует анализа выходного табличного документа для определения размещения номера;
  • вариант Алексея А (Isonic) с произвольной иерархией представляется неудобным в реализации так как вложенность заранее неизвестна и при изменении группировок придется переопределять значение поля иерархической нумерации;

Решение. Предлагаемое решение позволяет решить задачу многоуровневой нумерации путем формирования номера при поэлементном программном выводе отчета. Преимуществом решения является отсутствие привязки к структуре данных, уровень иерархии определяется вложенностью элементов поступающих от процессора компоновки. Для нумерации достаточно создать вычисляемое поле и добавить несложный код вычисления номера в вывод отчета. Настройка размещения и отображения поля осуществляется стандартными средствами СКД.

Фрагмент кода формирования иерархического номера:

///...
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
	ПроцессорВывода.НачатьВывод();
	ЭлементРезультата = ПроцессорКомпоновки.Следующий();
	
	КэшМакетов = Новый Структура;
	
//{{Инициализация переменных и создание структур для расчета иерархической нумерации
	НомерПоИерархии = 0;
	Уровень = 0;
	
	СтекНомеров = Новый ТаблицаЗначений;
	СтекНомеров.Колонки.Добавить("Уровень", Новый ОписаниеТипов("Число"));
	СтекНомеров.Колонки.Добавить("Номер", Новый ОписаниеТипов("Число"));
//}}
	Пока ЭлементРезультата <> Неопределено Цикл
//{{Расчет номера по иерархии и его вывод
		Если ЭлементРезультата.ТипЭлемента = ТипЭлементаРезультатаКомпоновкиДанных.Начало Тогда
			Уровень = Уровень + 1;
		ИначеЕсли (ЭлементРезультата.ТипЭлемента = ТипЭлементаРезультатаКомпоновкиДанных.Конец) Тогда
			Уровень = Уровень - 1;
		КонецЕсли;
		
		Если ЭлементРезультата.ЗначенияПараметров.Количество() > 0 Тогда
			
			МассивИменПараметров = ПолучитьИменаПараметровВМакетеКомпоновкиПоИмениПоля("НомерПоИерархии", ЭлементРезультата.Макет, МакетКомпоновкиДанных, КэшМакетов);
			
			Если МассивИменПараметров.Количество() > 0 Тогда
				НомерПоИерархии = ПолучитьМногоуровневыйНомерПоИерархии(Уровень, СтекНомеров);
				
				Для Каждого ИмяПараметра из МассивИменПараметров Цикл
					ЭлементРезультата.ЗначенияПараметров[ИмяПараметра].Значение = НомерПоИерархии;
				КонецЦикла

			КонецЕсли
		КонецЕсли;
//}}
	    ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
	    ЭлементРезультата = ПроцессорКомпоновки.Следующий();
	КонецЦикла;
	ПроцессорВывода.ЗакончитьВывод()
КонецПроцедуры

Код функции ПолучитьМногоуровневыйНомерПоИерархии:

Функция ПолучитьМногоуровневыйНомерПоИерархии(УровеньОтчетаСКД, СтекНомеров);
	НомерНаУровне = СтекНомеров.Найти(УровеньОтчетаСКД, "Уровень");
			
	Если НомерНаУровне = Неопределено Тогда
		Стр = СтекНомеров.Добавить();
		Стр.Уровень = УровеньОтчетаСКД;
		Стр.Номер = 1;
	Иначе
		НомерНаУровне.Номер = НомерНаУровне.Номер + 1
	Конецесли;
			
	СтрНомерПоИерархии = "";
	
	НомераКУдалению = Новый Массив;
	Для Каждого Номер Из СтекНомеров Цикл
		Если Номер.Уровень <= УровеньОтчетаСКД Тогда
			СтрНомерПоИерархии = СтрНомерПоИерархии + Номер.Номер + ".";
		Иначе
			//Чистим элементы стека нижних уровней
			НомераКУдалению.Добавить(Номер);
		КонецЕсли
	КонецЦикла;
	Для каждого Номер Из НомераКУдалению Цикл
		СтекНомеров.Удалить(Номер);
	КонецЦикла;
	
	Возврат СтрНомерПоИерархии;
КонецФункции

Также вам потребуется функция "ПолучитьИменаПараметровВМакетеКомпоновкиПоИмениПоля" которую можно взять из статьи о установке собственных значений полей при программном выводе отчета СКД либо скачать пример отчета в котором "все включено".

P.S. Алгоритм разработан для иерархической нумерации по строкам отчета, но работает и при наличии группировок колонок. Вывод номера по колонкам не предусмотрен.

Огромная благодарность Денису Урянскому (dhurricane) за вдумчивое тестирование и подсказки.

Внешний отчет с примером иерархической нумерации тестировался на платформе 8.3.13.1644.

Обновление 16.01.2020: Перезагружен файл с примером. Просьба скачавшим связаться с автором для получения новой версии, либо самостоятельно  обновить код функции ПолучитьИменаПараметровВМакетеКомпоновкиПоИмениПоля() из текста статьи про нее. В прежней реализации возможен несистематический пропуск параметров.

Скачать файлы

Наименование Файл Версия Размер
Пример внешнего отчета с иерархической нумерацией.
.erf 8,32Kb
16.01.20
6
.erf 8,32Kb 6 Скачать

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
Избранное Подписка Сортировка: Древо
1. dhurricane 02.07.19 07:48 Сейчас в теме
Спасибо за идею и пример реализации. Единственное, что хотелось бы отметить в качестве недостатка, это анализ типа элемента результата для получения уровня. При работе, например, с таблицей, когда есть группировки не только нумеруемых строк, но и группировки колонок, Ваш алгоритм даст некорректную нумерацию в иерархии.
2. lmnlmn 58 02.07.19 08:27 Сейчас в теме
(1) Спасибо за подсказку. Вообще в реальной ситуации этот алгоритм используется в кросс-таблице с группировкой колонок и проблем нет. Но я добавлю группировку колонок в пример и проверю. Если будут сбои в нумерации - доработаю алгоритм и на этот случай.
3. lmnlmn 58 02.07.19 09:17 Сейчас в теме
(1) Внес исправления в код и пример. Теперь корректно нумерует и при наличии группировок колонок. Но нумерация работает только по строкам. По колонкам лучше не нумеровать.
4. dhurricane 02.07.19 09:42 Сейчас в теме
(3) Спасибо. Есть еще один небольшой недочет, касающийся функции "ПолучитьМногоуровневыйНомерПоИерархии". Вы обходите таблицу номеров стека и в этом же цикле удаляете строки таблицы. Это может привести к ошибкам. Корректнее удалять, например, так:
НомераКУдалению = Новый Массив;
Для Каждого Номер Из СтекНомеров Цикл
	Если Номер.Уровень <= УровеньОтчетаСКД Тогда
		СтрНомерПоИерархии = СтрНомерПоИерархии + Номер.Номер + ".";
	Иначе
		//Чистим элементы стека нижних уровней
		НомераКУдалению.Добавить(Номер);
	КонецЕсли
КонецЦикла;
Для каждого Номер Из НомераКУдалению Цикл
	СтекНомеров.Удалить(Номер);
КонецЦикла;
Показать
Ну и хотел бы предложить небольшое упрощение Вашего алгоритма в целом. А именно избавиться от вычисляемого поля "НомерПоИерархии", а вместо него в выбранные поля добавить "СистемныеПоля.Уровень". Тогда при выводе строк отчета можно значение уровня получать прямо из макета, вычислять номер в иерархии и устанавливать его обратно в системное поле.
5. lmnlmn 58 02.07.19 10:02 Сейчас в теме
(4) Вообще по удалению, формально, ваш вариант "каноничнее", но в данном алгоритме это к проблемам не приведет так как номера нижних уровней надо просто отсечь. Но, да, "дурной тон" в программировании.

С системными полями идея хорошая, но на практике есть одна проблема. Если другой разработчик (да я и сам через полгодика запамятовать могу) будет дорабатывать отчет, то он будет долго и с проклятиями недоумевать что за ерунда вместо уровня пишется, пока разберется в происходящем. А вычисляемое поле с понятным именем путаницу не вносит. Вообще для коллег можно в выражении вычисляемого поля написать "заполняется программно", например.
6. dhurricane 02.07.19 10:23 Сейчас в теме +1 $m
(5)
но в данном алгоритме это к проблемам не приведет
Проблемы будут при удалении нескольких строк, т.е. если разница в уровне между предшествующей и текущей строкой будет больше 1. Для Вашего примера: если "Трансмиссию" переместить на верхний уровень из под подчинения "Автомобилю", то на платформе 8.3.13.1809 в файловой базе получим номера, представленные на скрине ниже.

то он будет долго и с проклятиями недоумевать что за ерунда вместо уровня пишется, пока разберется в происходящем
Согласен, предложенный мной вариант вносит путаницу.
Прикрепленные файлы:
ELInfinito; +1 Ответить
7. lmnlmn 58 02.07.19 10:37 Сейчас в теме
(6)
Проблемы будут при удалении нескольких строк, т.е. если разница в уровне между предшествующей и текущей строкой будет больше 1.

Спасибо, проглядел. Исправил.
Оставьте свое сообщение

См. также

Получение курса валюты за период с помощью СКД

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::СКД 1cv8.cf Россия Windows Абонемент ($m) Практика программирования

Иногда приходится сталкиваться с ситуацией, когда для решения той или иной задачи требуется знать курс валюты на каждый день заданного периода. Есть несколько вариантов решений данной проблемы, один из которых хочу предложить.

1 стартмани

04.02.2020    567    Kawa_neko    2       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Отчет на СКД с выводом остатков по всем датам периода для УТ 10.3 (обычные формы)

Отчеты и формы Программист Пользователь Внешний отчет (ert,erf) v8::СКД УТ10 Россия УУ Windows Абонемент ($m) Практика программирования

Требовалось получить остатки на каждую дату периода с целью дальнейшего вывода в любых целях. В обработке используется вспомогательный макет СКД, из которого и получается таблица остатков. Далее ее просто вывожу через другое СКД, так как это просто пример. Вы можете встроить это себе в любую обработку.

1 стартмани

23.12.2019    899    jump0    0       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Программное добавление параметров редактирования СКД

Отчеты и формы Программист Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

В данной публикации приводится пример программного добавления параметров редактирования для поля выборки в СКД.

1 стартмани

25.11.2019    2973    1    Isonic    7       

Расчет сложных итогов СКД

Отчеты и формы Программист Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf ОС Абонемент ($m) Практика программирования

Малоизвестный прием для расчета итогов в отчетах на СКД.

1 стартмани

05.08.2019    9142    10    masterkio    9       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Вам нравятся запросы в 1С?

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    13259    4    m-rv    86       

Иерархическая нумерация в отчете СКД с помощью макета поля

Отчеты и формы Программист Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования Разработка

Представляю Вашему вниманию вариант решения задачи нумерации строк иерархического отчета на СКД.

1 стартмани

28.06.2019    4466    4    Isonic    14       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Простые примеры сложных отчетов на СКД

Статья Программист Архив с данными v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    19038    17    Hatson    22       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Поле "Отбор" в управляемой форме используя СКД

Отчеты и формы Программист Внешняя обработка (ert,epf) v8::УФ v8::СКД 1cv8.cf Абонемент ($m) Работа с интерфейсом Практика программирования Разработка

Пример, который осуществляет отбор ссылок при помощи СКД, макет компоновки создается программно.

1 стартмани

17.05.2019    4291    3    artms    0       

Вывод вариантов СКД в таблицы на управляемой форме

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Задача стояла такая: есть 2 различных запроса, результаты которых выгружаются на форму обработки в таблицы значений (далее ТЗ) и программно "соприкасаются" между собой определенным образом (как именно- в рамках данной статьи неважно). Нюанс в том, что запросы должны иметь свой компоновщик настроек и могут интерактивно на форме изменяться пользователем. На оригинальность публикации не претендую - изначально в рамках поставленной задачи пытался найти что-то подобное (уже готовый шаблон) на инфостарте, возможно "плохо искал" ;)

05.04.2019    6458    2    artkor    1       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Как в СКД по щелчку на какой-либо ячейке в отчете получить значение другой ячейки

Статья Программист Стажер Архив с данными v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования Разработка

Задача: по щелчку на ячейке в определенной колонке в таблице отчета нужно получить значение ячейки из другой колонки в этой же строке и передать его в другой отчет (т.е. сделать расшифровку значения другим отчетом).

1 стартмани

27.03.2019    9445    12    ellavs    11       

Безопасная работа с транзакциями во встроенном языке

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    20680    8    tormozit    44       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Пример внешней обработки с вызовом типового отчета на СКД и передачей ему настроек и вывода результата в таблицу значений (в частности, для новичков)

Инструменты и обработки Программист Архив с данными v8 v8::СКД 1cv8.cf Россия Абонемент ($m) Инструментарий разработчика Практика программирования

Разрабатывалась на 1С:Зарплата и управление персоналом в кредитных организациях, редакция 3.1 (3.1.5.407), поэтому использует типовой отчет Состояние штатного расписания, но технология работает для любой конфигурации. Пример внешней обработки с вызовом типового отчета на СКД "Состояние штатного расписания" и передачей ему настроек, изменения имен колонок после выполнения на имена указанные в "Пользовательских полях" или "заголовках" и вывода результата в таблицу значений.

1 стартмани

21.03.2019    3296    8    pavel_pss    0       

Пример использования СКД и данных расшифровки на мобильной платформе

Статья Программист Внешняя обработка (ert,epf) v8 v8::Mobile v8::СКД 1cv8.cf Россия Android Абонемент ($m) Практика программирования Разработка

СКД в мобильном приложении и меню действий на основе данных расшифровки (отчет, совместимый с мобильной платформой 8.3.13.45).

1 стартмани

12.03.2019    3318    2    majoram    0       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Вывод характеристик и их значений в динамический список

Инструменты и обработки Программист Архив с данными v8::УФ v8::СКД 1cv8.cf Абонемент ($m) Практика программирования Разработка

Если в запросе динамического списка используется конструкция {ХАРАКТЕРИСТИКИ ...}, то как вывести на форму колонки с характеристиками?

1 стартмани

22.02.2019    3197    kasper076    3       

Сквозной рейтинг по иерархии в отчете на СКД

Статья Программист Архив с данными v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования Разработка

Сквозная нумерация (рейтинг) по группам и элементам справочника в отчете СКД согласно убыванию количества/суммы и т.д.

1 стартмани

07.02.2019    3916    MaxxiMiliSan    2       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Особенность встроенной функции Представление() в СКД [поход на грабли]

Статья Программист Внешний отчет (ert,erf) v8::СКД 1cv8.cf Абонемент ($m) Практика программирования Адаптация типовых решений

Система компоновки данных может доставить достаточно мороки не только новичкам, но и опытным разработчикам. Стоит внести, казалось бы, незначительную правку, и начинает стрелять в самых неожиданных местах. Но давайте уже переходить к делу и рассмотрим маленькую ошибку выполнения встроенной функции СКД, которую я обнаружил на днях в работе стандартного бухгалтерского отчета "Карточка счета".

1 стартмани

15.01.2019    6447    Dementor    5       

Модуль, реализующий хранение настроек отчетов СКД в типовом регистре "Сохраненные настройки"

Инструменты и обработки Программист Архив с данными v8 v8::СКД КА1 БП2.0 ЗУП2.5 УТ10 БП1.6 Абонемент ($m) Практика программирования

Модуль, обеспечивающий хранение настроек отчетов на СКД в типовом регистре "Сохраненные настройки", присутствующем в конфигурациях УПП 1.2, 1.3, УТ 10.3, БП 2.0 и т.д.

1 стартмани

12.01.2019    4038    lunjio    0       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Отладка сложных отчетов на СКД

Отчеты и формы Программист Расширение (cfe) v8 v8::СКД 1cv8.cf Россия Абонемент ($m) Практика программирования

Расширение для отладки сложных отчетов на СКД (в т.ч. для собираемых программно "на лету") и быстрого перехода к отладке таких отчетов в консоли запросов и отчетов на СКД.

1 стартмани

28.12.2018    18247    65    maxx    58       

Шаблон кросс-таблицы с иерархией на СКД

Отчеты и формы Программист Внешний отчет (ert,erf) v8::БУ v8::СКД БП3.0 Россия Абонемент ($m) Инструментарий разработчика Практика программирования

Шаблон для быстрой реализации отчета кросс-таблицы с иерархией и жестко заданной структурой вывода с использованием СКД.

1 стартмани

22.12.2018    6075    6    wizard.ilmir02    3       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

СКД. Сортировка

Статья Программист Внешний отчет (ert,erf) v8::СКД 1cv8.cf Россия Абонемент ($m) Практика программирования

Показана реализация сортировки по двойному щелчку на заголовке колонки отчета и отображение направления сортировки в заголовках колонок.

1 стартмани

03.12.2018    6698    5    slimper    21       

Установка собственных значений полей при программном выводе отчета СКД по имени поля (по принципу "как в макете")

Статья Программист Нет файла v8::СКД Бесплатно (free) Практика программирования

При программном выводе отчета на СКД возникает задача заполнить поля своими значениями. Но при поэлементном выводе отчета параметры "обезличены" как П1, П2, П3, ... Как узнать в какое "П" содержит нужное поле и куда устанавливать значение? Статья поможет программистам начинающим освоение СКД и перешедшим на СКД с "макета" ответить на эти вопросы на примере готового решения.

23.11.2018    6601    lmnlmn    5       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Объединение нескольких печатных форм в один табличный документ

Отчеты и формы Программист Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Простое решение, как объединить табличные документы с различной шириной колонок в один и чтобы ничего не разъехалось.

1 стартмани

17.11.2018    8617    5    echo77    4       

Передача набора данных типа Объект в отчет СКД

Инструменты и обработки Программист Внешний отчет (ert,erf) v8 v8::УФ v8::СКД 1cv8.cf Россия Абонемент ($m) Практика программирования

Пример показывает, каким образом можно передать таблицу значений в отчет СКД (в набор данных объект). Пример работает как на обычных, так и на управляемых формах.

1 стартмани

12.11.2018    19189    4    evgen7938    3