Филимонов Иван | Руководитель группы автоматизации учета | ООО "Трансстроймеханизация"

«Менеджер потоков: Реализация «любой» задачи в потоках»

Реализация «любой» задачи в потоках: Обработка коллекции (например: запись\перезапись элементов справочников\документов, формирование сложных отчетов и т.д.); Обработка зависимых объектов (например, восстановление последовательности, формирование цепочек документов и т.д.). Платформа одна – задач много Единый подход к многопоточным задачам; Вся логика задачи – отдельно («любой» модуль БД / внешняя обработка); Взаимодействие через события. Доп функционал: Контроль за «падением» потоков и их рестарт; Поддержка многократных попыток обработать объект; Возможность оперативно получать «ответ» от потоков; Возможность в любой момент прервать работу; Мониторинг деятельности «Менеджера потоков».

Получение HTML из таблицы значений

Программирование - Практика программирования

Обработка позволяет сформировать HTML таблицу для письма на основании таблицы значений.

Требовалось, чтобы вместо файла вложения, данные были отражены в письме наглядно.

Гдето на просторах нашел кусок не работающей функции и привел ее к рабочему состоянию.

Отправка письма из Альфа-Авто.

Формирование HTML таблицы универсальна.

Скачать файлы

Наименование Файл Версия Размер
ПолучитьHTMLизТаблицыЗначений:
.epf 11,19Kb
29.08.17
3
.epf 11,19Kb 3 Скачать

См. также

Комментарии
Сортировка: Древо
1. DrAku1a 1280 11.09.17 09:45 Сейчас в теме
Для тех, кому лень качать (набрано за 10-15 минут):
Функция ПолучитьHTMLТаблицыЗначений(ТЗ)	
	Перем Ответ, мИменаКолонок, КолонкаТЗ, СтрокаТЗ;
	Ответ = "<TABLE><TBODY><TR>";
	мИменаКолонок = новый Массив;
	Для каждого КолонкаТЗ из ТЗ.Колонки Цикл
		мИменаКолонок.Добавить(КолонкаТЗ.Имя);
		Ответ = Ответ + "<TH>" + ?(ПустаяСтрока(КолонкаТЗ.Заголовок), КолонкаТЗ.Имя, КолонкаТЗ.Заголовок)+"</TH>";
	КонецЦикла;
	Для каждого СтрокаТЗ из ТЗ Цикл
		Ответ = Ответ + "</TR><TR>";
		Для каждого КолонкаТЗ из мИменаКолонок Цикл
			Ответ = Ответ + "<TD>" + Строка(СтрокаТЗ[КолонкаТЗ]) + "</TD>";
		КонецЦикла;
	КонецЦикла;
	Ответ = Ответ + "</TR></TBODY></TABLE>";
	Возврат Ответ;
КонецФункции
Показать
VladC#; igor-pn; +2 Ответить
Оставьте свое сообщение