Автоотключение пользователей 8.3 УФ

Публикация № 667256

Администрирование - Администрирование данных 1С

обработка архивирование отключение пользователей

9
Обработка, отключающая все клиент-серверные соединения (в т.ч. к web-серверу) к серверу 1С: Предприятие. Работает в т.ч. на последней платформе 8.3.10.2561 , предназначена для управляемых приложений. Пример использования - автоматический ее запуск для снятия резервных копий по расписанию.

Если с "Обычными формами" все несколько проще, и существует более одного решения по отключению пользователей, то с управляемыми, и на последних платформах 8.3 возникают различные проблемы.
Во-первых, добавляются веб-подключения.
Во-вторых, 8.3 сама решает, сколько Рабочих Процессов создать (не всегда можно знать заранее их количество).
В-третьих, в обработке предусмотрена ситуация, когда подключение сущестовало на момент запуска обработки, но уже отключилось (завершилось) на момент попытки его отключения.

Информация об этом запишется в лог-файл.

Запускать можно с любого ПК сети, откуда администрируется сервер. То есть это может быть как Windows-cервер, так и сервер с ОС Linux, просто в последнем случае соединения "рубятся" (и обработка запускается) с ПК из сети, а не с самого сервера.

Всегда существует возможность и создать регламентное задание, внеся " отключение пользователей " в конфигурацию, но я не преверженец этого метода.

По задумке, обработка используется в связке с Effector Saver, даже бесплатная версия которой весьма успешно снимает резервные копии с SQL в DT, и умеет хранить указанное количество копий (например, 30 штук). Разумеется, пользователь может снимать резервные копии любым иным способом (но нужна обработка для выгрузки именно в DT; SQL-копиям без разницы, но у них есть другие ограничения).

---

Запуск обработки предполагается скриптом подобного содержания, где
/nBackuper /p123 - запуск от имени пользователя Backuper с паролем 123,
/s127.0.0.1\uf2016 - обращение к локальному адресу, базе uf2016,
/execute E:\scripts\UserKill_v3.epf - запуск обработки UserKill_v3.epf , расположенной по указанному адресу.

echo запуск new_stop_Buh %Time% %Date% >> E:\scripts\log.txt
"C:\Program Files (x86)\1cv8\common\1cestart.exe" ENTERPRISE /s127.0.0.1\uf2016 /nBackuper /p123 /wa- /DisableStartupMessages /RunModeManagedApplication /execute E:\scripts\UserKill_v3.epf

---

Текст обработки по отключению пользователей.
Опять же, не забудьте сменить текст в строке РабПроц.AddAuthentication("Backuper", "123");
В принципе, можно получать логин и пароль из констант в конфигурации - вовсе не обязательно вписывать их в код.


&НаКлиенте
Процедура ПриОткрытии(Отказ)
	текстош="";
	текстош=ПриОткрытииНаСервере();
	если текстош <> "" тогда
		ФайлРегистрации = Новый ЗаписьТекста("E:\scripts\LogFile1c.txt", КодировкаТекста.ANSI, , Истина);
		ФайлРегистрации.Записать(строка(текстош)+Символы.ПС);
		ФайлРегистрации.Закрыть();
	конецесли;	
	ЗавершитьРаботуСистемы(Ложь);

КонецПроцедуры


&НаСервере
функция ПриОткрытииНаСервере()
	текстош="";
	
	Если Найти(СтрокаСоединенияИнформационнойБазы(), "Srvr") > 0 Тогда
		// серверный вариант
		Поиск1 = Найти(СтрокаСоединенияИнформационнойБазы(), "Srvr=");
		ПодстрокаПоиска = Сред(СтрокаСоединенияИнформационнойБазы(), Поиск1 + 6);
		ИмяСервера = Лев(ПодстрокаПоиска, Найти(ПодстрокаПоиска, """") - 1);
		// теперь ищем имя базы
		Поиск1 = Найти(СтрокаСоединенияИнформационнойБазы(), "Ref=");
		ПодстрокаПоиска = Сред(СтрокаСоединенияИнформационнойБазы(), Поиск1 + 5);
		ИмяБазы = Лев(ПодстрокаПоиска, Найти(ПодстрокаПоиска, """") - 1);
	Иначе
		// для других способов подключения алгоритм не актуален
		текстош=" Способ не актуален";
		Возврат текстош;
	КонецЕсли;
	
	Коннектор = Новый COMОбъект("v83.COMConnector");
	Агент = Коннектор.ConnectAgent(ИмяСервера);
	Кластеры = Агент.GetClusters();
	Для каждого Кластер из Кластеры Цикл
		АдминистраторКластера = "Имя администратора кластера";
		ПарольКластера = "Пароль администратора кластера";
		//Агент.Authenticate(Кластер, АдминистраторКластера, ПарольКластера);
		Агент.Authenticate(Кластер,,);
		Процессы = Агент.GetWorkingProcesses(Кластер);
		Для каждого Процесс из Процессы Цикл
			Порт = Процесс.MainPort;
			// теперь есть адрес и порт для подключения к рабочему процессу
			попытка
				РабПроц = Коннектор.ConnectWorkingProcess(ИмяСервера + ":" + СтрЗаменить(Порт, Символы.НПП, ""));
				РабПроц.AddAuthentication("Backuper", "123");
				
				ИнформационнаяБаза = "";
				
				Базы = Агент.GetInfoBases(Кластер);
				Для каждого База из Базы Цикл
					Если База.Name = ИмяБазы Тогда
						ИнформационнаяБаза = База;
						Прервать;
					КонецЕсли;
				КонецЦикла;
				Если ИнформационнаяБаза = "" Тогда
					// база не найдена
				КонецЕсли;
				
				Сеансы = Агент.GetInfoBaseSessions(Кластер, ИнформационнаяБаза);
				Для каждого Сеанс из Сеансы Цикл
					
					Если нРег(Сеанс.AppID) = "backgroundjob" ИЛИ нРег(Сеанс.AppID) = "comconsole" Тогда
						// если это сеансы com-приложения или фонового задания, то не отключаем
						Продолжить;
					КонецЕсли;
					Если Сеанс.UserName = ИмяПользователя() Тогда
						// это текущий пользователь
						Продолжить;
					КонецЕсли;
					Агент.TerminateSession(Кластер, Сеанс);
					Сообщить("Отключен сеанс "+строка(Сеанс.UserName));
				КонецЦикла;
				
				ИнформационнаяБаза2 = РабПроц.CreateInfoBaseInfo();
				ИнформационнаяБаза2.Name = ИмяБазы;
				СоединенияБазы = РабПроц.GetInfoBaseConnections(ИнформационнаяБаза2);
				// Разорвать соединения клиентских приложений.
				Для Каждого Соединение Из СоединенияБазы Цикл
					Если нРег(Соединение.AppID) = "backgroundjob" ИЛИ нРег(Соединение.AppID) = "comconsole" Тогда
						Продолжить;
					КонецЕсли;
					Если Соединение.UserName = ИмяПользователя() Тогда
						// это текущий пользователь
						Продолжить;
					КонецЕсли;
					РабПроц.Disconnect(Соединение);
				КонецЦикла;
			Исключение
				текстош=текстош+" Ошибка при откл пользователей userkill " + строка(ИмяБазы)+ " "+строка(ТекущаяДата());
			конецпопытки;
		КонецЦикла;
	КонецЦикла;
	Сообщить("Завершается работа...");
	Возврат текстош;

КонецФункции

!!! Разумеется, при первом запуске внешней обработки в последних релизах платформы - ее исполнение нужно "разрешить", так что, перед тем, как пустить в свободное плавание - пару раз протестируйте.

9

Скачать файлы

Наименование Файл Версия Размер
Автоотключение пользователей 8.3 УФ:
.epf 7,52Kb
30.08.17
9
.epf 3 7,52Kb 9 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Gilev.Vyacheslav 1839 31.08.17 12:45 Сейчас в теме
dt не является средством резервного копирования о чем прямо сказано в документации 1С
alex-l19041; olegmedvedev; +2 Ответить
2. OlegAr 2 31.08.17 14:16 Сейчас в теме
раз Вячеслав сказал, значит так и есть, не спорим ..
3. rar_xxx 23 31.08.17 23:27 Сейчас в теме
только ms sql бекап забудте о dt причины: 1- mssql бекап в разы быстрее снимается и разворачивается потому что таблицы просто копируются для скорости полезно архивировать, для надежности не архивируйте. 2- при росте базы вы прийдете к тому что не сможете выгрузить в dt ;) хорошо если вовремя узнаете что бекап перестал сниматься 3. из dt вы можете в критический ден просто не восстановить базу. 4. очень интересно еслы вы бекап снимаете я так понимаю только ночью в течении дня бекапов у вас нет. надежда только на железо? Как насчет регулярного бекапа журнала транзакций например каждые 20мин или каждый час?
4. erutan 54 31.08.17 23:51 Сейчас в теме
(3) надежда на железо в плане аппаратного рейда.
С копией SQL комбинирую, но все равно раз в день.
Довольно часто приходится загрузить копию (в смысле sql > dt > файловая) гл.бухгалтеру, бухгалтеру или мне самому.

Нет, бэкапа транзакций не настраивал. Я так понимаю, это должно прикатить к восстановление SQL-копии + восстановление к моменту времени сохраненных транзакций?

Благодарю за комментарии.
5. rar_xxx 23 01.09.17 00:04 Сейчас в теме
Обязательно настройте бекап транзакционного журнала, на сторонний носитель, например раз в 1час или чаще. Таким образом если у вас есть ночной полны sql бекап и в середине дня железо накрывается или вы рушите базу. У вас будет возможность восстановится на любой момент времени, до секунды или конкретной транзакции из забекапленных журналов. Плюс если у вас стоит полная модель восстановления а вы не бекапите журнал, он будет постоянно расти. Так же с помощью журнальных бекапов вам можно отказаться от ежедневных бекапов, которые много весят, но тогда важно отстроить четкий рабочий бекап журналов, это опасная схема и рекомендуется только если у вас нет места на ежедневный бекап. Да и про рейд у нас один раз в схд вылетела вся полка не спас и 10 рейд, винты лучше брать разных серий ;) но для дорогих схд вам придется брать то что дает вендор(
Оставьте свое сообщение

См. также

Списание (корректировка) задолженности контрагентов УНФ 1.6 5

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 УНФ Украина БУ Дебиторская и кредиторская задолженность Абонемент ($m) Закрытие периода Обработка документов

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    6594    4    DMon    1       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Регистрация документов с измененной суммой 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Обработка документов

Обработка берет информацию из истории изменения документов. Удобна для администраторов, когда документы с измененной суммой по какой-то причине не регистрируются в плане обменов. Можно регистрировать не все документы, а только те, которые были изменены.

1 стартмани

20.04.2019    6086    1    ryan    0       

Блин, мы забыли включить регламентные задания… 51

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 Абонемент ($m) Сервисные утилиты

Привет, Инфостарт! Сегодня расскажу, как я решил проблему с выключенными регламентными заданиями в рабочих базах. Желая исключить человеческий фактор и минимизировать количество ошибок, я написал небольшую конфигурацию.  В конфигурации два регламентных задания. Первое периодически подключается к кластеру и сохраняет текущие параметры: имя, Сервер БД, базу СУДБ, блокировки входа и регламентных заданий и т.д. Второе задание периодически проверяет эти параметры на ошибки.

1 стартмани

08.04.2019    8277    10    slozhenikin_com    36       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Валовая прибыль для УПП 1.3, КА 1.1 в режиме РАУЗ (работа типового отчета без доработок конфигурации) 6

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 КА1 УПП1 УУ Абонемент ($m) Обработка документов

Простое и мгновенное решение для использования типового отчета "Валовая прибыль" в конфигурациях "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1" (а также отраслевых решений на их базе) при включенном режиме РАУЗ (расширенная аналитика учета затрат). Не требует настройки или изменения конфигурации, либо может быть, для дополнительного удобства, интегрировано в нее с минимальными доработками.

2 стартмани

21.01.2019    8232    6    stvorl    3       

Централизованное управление списком доступных баз 1С у пользователей 8

Инструменты и обработки Системный администратор Архив с данными v8 1cv8.cf Россия Windows Абонемент ($m) Стартеры 1С Сервисные утилиты Администрирование СУБД

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

5 стартмани

05.12.2018    7068    8    RomikR    9       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

Многопоточная обработка данных 47

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 v8::УФ 1cv8.cf Абонемент ($m) Производительность и оптимизация (HighLoad) Администрирование данных 1С

Конфигурация "Универсальные механизмы: пакеты данных". Набор инструментов для быстрой организации отказоустойчивой многопоточной обработки данных.

1 стартмани

23.11.2018    12387    46    _ASZ_    14       

Обнуление остатков регистров бухгалтерии и накопления 42

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::БУ v8::ОУ v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ БГУ ERP2 БП3.0 УТ11 УХ КА2 ЗУП3.x Россия Абонемент ($m) Универсальные обработки Чистка базы

Обработка позволяет обнулить остатки по регистру накопления или бухгалтерии на определенную дату. Поддерживается большинство типовых конфигураций (БП 3, БП 2, УТ 11, УТ 10, ЗУП 3, ЗУП 2, БГУ 2, БГУ 1, ERP, УПП, КА 2, КА 1, УХ 3, УХ 1, УНФ). Гибкая настройка (отборы, заполнение реквизитов и любых полей корр. счета, возможность обнулять ресурсы выборочно). Несколько режимов работы. Два интерфейса: простой и с расширенным набором настроек.

2 стартмани

19.11.2018    11434    186    morozov.sv    30       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Очистка кэша 1С 8 (8.0, 8.1, 8.2, 8.3). Грамотная чистка кэша 1С с сохранением настроек. 36

Инструменты и обработки Системный администратор Компонента, плагин (dll, vbs,..) v8 1cv8.cf Россия Windows Абонемент ($m) Чистка базы Сервисные утилиты Администрирование данных 1С

Эффективное средство для устранения ошибок, возникающих в локальном кэше 1С на клиенте, которым легко сможет воспользоваться пользователь с любым уровнем знаний. Wsf-скрипт, созданный на стандартном языке автоматизации Windows - "WSH JScript", очищает кэш 1С просто, быстро и безопасно. Кроме варианта, очищающего кэш текущего пользователя, имеется также вариант для чистки кэша 1С всех пользователей терминального-сервера.

1 стартмани

04.11.2018    21934    301    Eugen-S    34       

Перенос данных БП 3.0 => УТ 11 / КА 2 / ERP 2 (ЕРП) (перенос остатков, документов и справочной информации из "1С:Бухгалтерия предприятия 8", ред.3.0). Обновлено до БП 3.0.73.х, УТ 11.4.10.х, КА 2.4.10.х., ERP 2.4.10.х! Промо

Переносятся документы за выбранный период, справочная информация и остатки по счетам бух. учета в программу УТ 11 / КА 2 / ЕРП 2 (ERP). Переносятся все возможные виды операций ввода остатков на нужную дату. Есть отбор по периоду переноса документов и фильтр по организации, доступен выбор даты ввода остатков. Если нужно переносить что-то дополнительно, то обычно бесплатно добавляем это в перенос . Смотрите видеодемонстрацию со звуком - советами по переносу и рекомендациями настройки программ.

29700 руб.

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2 12

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Розничная торговля Абонемент ($m) Обработка документов

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    17236    78    asdfgcom    45       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.127.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Очистка периодических регистров посредством T-SQL (удаление записей, кроме среза последних) 4

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Чистка базы

Обработка для ленивых. Составит вместо Вас запрос для SQL, который удалит все не актуальные записи (т.е все, кроме среза последних)

5 стартмани

22.06.2018    9417    14    Alexander.Shvets    9       

Автоматическое заполнение графиков в ЗУП 3.1 6

Инструменты и обработки Бухгалтер Архив с данными v8 v8::СПР ЗУП3.x Россия БУ Зарплата Учет рабочего времени Абонемент ($m) Обработка справочников

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    11510    16    notserioussam    1       

Онлайн-курс "Технология выполнения проектов ERP-класса – процессный подход". Третий поток. Курс проходит с 21 января по 18 марта 2020 года. Промо

Курс разработан Внедренческим центром «Раздолье». Курс предназначен для подготовки аналитиков, архитекторов и руководителей проектов автоматизации процессов управления с использованием комплексных ИТ-систем (1С:ERP, 1С:УХ, 1С:КА, 1С:УТ). В основе курса лежит методика применения процессного подхода.

9000 рублей

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1) 21

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::СПР ЗУП3.x БУ Управление персоналом (HRM) Абонемент ($m) Обработка справочников

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    18091    51    charivnick    3       

Повышение качества разработок и онлайн контроль ошибок 164

Статья no Расширение (cfe) v8 Абонемент ($m) Журнал регистрации

Анализ ошибок и сбор ошибок журнала регистраций из десятков и сотен баз в одном месте.

09.03.2018    20469    137    DitriX    47       

С 2020 года сервис «Продление поддержки конфигурации 1С:УПП» подорожает вдвое Промо

Успейте продлить поддержку УПП до повышения цен! Фирма «1С» предупредила об изменении цен на сервис «Продление поддержки конфигурации "1С:Управление производственным предприятием"». С 1 января 2020 года сервис подорожает в два раза.

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3 15

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Россия БУ Розничная торговля Абонемент ($m) Обработка документов

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    20020    5    biz-intel    3       

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1 35

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата Абонемент ($m) Обработка документов Загрузка и выгрузка в Excel

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    28208    29    mvv1975    5       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

История формирования отчётов. (Используем новые возможности расширений в 8.3.11) 23

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8::УФ v8::СКД УНФ ДО БП3.0 УТ11 ЗУП3.x Абонемент ($m) Журнал регистрации

Подсистема ведёт историю формирования отчётов и позволяет быстро подгрузить используется настройки в отчёт.

1 стартмани

28.11.2017    11440    17    SeiOkami    1       

Копирование меню в Трактир Management 2

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Рестораны, кафе и фаст-фуд Россия УУ Производство готовой продукции (работ, услуг) Абонемент ($m) Обработка документов

Механизм копирования меню в Трактир Management. Данная обработка расширяет функционал типового решения Трактир Management, позволяя быстро вводить в эксплуатацию новую точку путём создания нового меню на основании имеющегося.

1 стартмани

28.11.2017    16156    2    integrator1983    0       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Быстрое удаление неиспользуемых версий 1С:Предприятие 8, кэша метаданных и информационных баз 45

Инструменты и обработки Системный администратор Приложение (exe) v8 Windows Абонемент ($m) Сервисные утилиты

При обновлении платформы 1С:Предприятие 8 предыдущие версии не удаляются. Со временем количество неиспользуемых версий платформы растет. Они занимают место на диске. Для решения этой проблемы предназначена программа OneCleaner. Она позволяет быстро удалить неиспользуемые версии платформы, а также почистить кэш метаданных и удалить ненужные информационные базы данных.

1 стартмани

14.11.2017    15833    85    bonv    15       

Помощник по закрытию месяца для УТ 11.3 26

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ УТ11 Россия УУ Закрытие периода Абонемент ($m) Закрытие периода Обработка документов

Помощник по закрытию месяца для УТ 11.3. Имеет две функции: обнуление товаров "К оформлению" в интеркампани и обнуление отрицательных остатков в регистре "Себестоимость товаров".

5 стартмани

10.11.2017    14944    Zalipaka    1       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Закрываем всплывающие сообщения платформы 12

Инструменты и обработки no Приложение (exe) v8::УФ Windows Абонемент ($m) Сервисные утилиты

Принудительное закрывание сообщений платформы 8.3.10.

1 стартмани

10.11.2017    9943    14    RomaH    8       

Очистка регистрации обмена 4

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Абонемент ($m) Чистка базы

Данная обработка предназначена для очистки узла. Для очистки необходимо указать период,организацию.

1 стартмани

19.09.2017    10665    4    serg-lom89    0       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей