Автоотключение пользователей 8.3 УФ

Администрирование - Архивирование (backup)

Обработка, отключающая все клиент-серверные соединения (в т.ч. к web-серверу) к серверу 1С: Предприятие. Работает в т.ч. на последней платформе 8.3.10.2561 , предназначена для управляемых приложений. Пример использования - автоматический ее запуск для снятия резервных копий по расписанию.

Если с "Обычными формами" все несколько проще, и существует более одного решения по отключению пользователей, то с управляемыми, и на последних платформах 8.3 возникают различные проблемы.
Во-первых, добавляются веб-подключения.
Во-вторых, 8.3 сама решает, сколько Рабочих Процессов создать (не всегда можно знать заранее их количество).
В-третьих, в обработке предусмотрена ситуация, когда подключение сущестовало на момент запуска обработки, но уже отключилось (завершилось) на момент попытки его отключения.

Информация об этом запишется в лог-файл.

Запускать можно с любого ПК сети, откуда администрируется сервер. То есть это может быть как Windows-cервер, так и сервер с ОС Linux, просто в последнем случае соединения "рубятся" (и обработка запускается) с ПК из сети, а не с самого сервера.

Всегда существует возможность и создать регламентное задание, внеся " отключение пользователей " в конфигурацию, но я не преверженец этого метода.

По задумке, обработка используется в связке с Effector Saver, даже бесплатная версия которой весьма успешно снимает резервные копии с SQL в DT, и умеет хранить указанное количество копий (например, 30 штук). Разумеется, пользователь может снимать резервные копии любым иным способом (но нужна обработка для выгрузки именно в DT; SQL-копиям без разницы, но у них есть другие ограничения).

---

Запуск обработки предполагается скриптом подобного содержания, где
/nBackuper /p123 - запуск от имени пользователя Backuper с паролем 123,
/s127.0.0.1\uf2016 - обращение к локальному адресу, базе uf2016,
/execute E:\scripts\UserKill_v3.epf - запуск обработки UserKill_v3.epf , расположенной по указанному адресу.

echo запуск new_stop_Buh %Time% %Date% >> E:\scripts\log.txt
"C:\Program Files (x86)\1cv8\common\1cestart.exe" ENTERPRISE /s127.0.0.1\uf2016 /nBackuper /p123 /wa- /DisableStartupMessages /RunModeManagedApplication /execute E:\scripts\UserKill_v3.epf

---

Текст обработки по отключению пользователей.
Опять же, не забудьте сменить текст в строке РабПроц.AddAuthentication("Backuper", "123");
В принципе, можно получать логин и пароль из констант в конфигурации - вовсе не обязательно вписывать их в код.


&НаКлиенте
Процедура ПриОткрытии(Отказ)
	текстош="";
	текстош=ПриОткрытииНаСервере();
	если текстош <> "" тогда
		ФайлРегистрации = Новый ЗаписьТекста("E:\scripts\LogFile1c.txt", КодировкаТекста.ANSI, , Истина);
		ФайлРегистрации.Записать(строка(текстош)+Символы.ПС);
		ФайлРегистрации.Закрыть();
	конецесли;	
	ЗавершитьРаботуСистемы(Ложь);

КонецПроцедуры


&НаСервере
функция ПриОткрытииНаСервере()
	текстош="";
	
	Если Найти(СтрокаСоединенияИнформационнойБазы(), "Srvr") > 0 Тогда
		// серверный вариант
		Поиск1 = Найти(СтрокаСоединенияИнформационнойБазы(), "Srvr=");
		ПодстрокаПоиска = Сред(СтрокаСоединенияИнформационнойБазы(), Поиск1 + 6);
		ИмяСервера = Лев(ПодстрокаПоиска, Найти(ПодстрокаПоиска, """") - 1);
		// теперь ищем имя базы
		Поиск1 = Найти(СтрокаСоединенияИнформационнойБазы(), "Ref=");
		ПодстрокаПоиска = Сред(СтрокаСоединенияИнформационнойБазы(), Поиск1 + 5);
		ИмяБазы = Лев(ПодстрокаПоиска, Найти(ПодстрокаПоиска, """") - 1);
	Иначе
		// для других способов подключения алгоритм не актуален
		текстош=" Способ не актуален";
		Возврат текстош;
	КонецЕсли;
	
	Коннектор = Новый COMОбъект("v83.COMConnector");
	Агент = Коннектор.ConnectAgent(ИмяСервера);
	Кластеры = Агент.GetClusters();
	Для каждого Кластер из Кластеры Цикл
		АдминистраторКластера = "Имя администратора кластера";
		ПарольКластера = "Пароль администратора кластера";
		//Агент.Authenticate(Кластер, АдминистраторКластера, ПарольКластера);
		Агент.Authenticate(Кластер,,);
		Процессы = Агент.GetWorkingProcesses(Кластер);
		Для каждого Процесс из Процессы Цикл
			Порт = Процесс.MainPort;
			// теперь есть адрес и порт для подключения к рабочему процессу
			попытка
				РабПроц = Коннектор.ConnectWorkingProcess(ИмяСервера + ":" + СтрЗаменить(Порт, Символы.НПП, ""));
				РабПроц.AddAuthentication("Backuper", "123");
				
				ИнформационнаяБаза = "";
				
				Базы = Агент.GetInfoBases(Кластер);
				Для каждого База из Базы Цикл
					Если База.Name = ИмяБазы Тогда
						ИнформационнаяБаза = База;
						Прервать;
					КонецЕсли;
				КонецЦикла;
				Если ИнформационнаяБаза = "" Тогда
					// база не найдена
				КонецЕсли;
				
				Сеансы = Агент.GetInfoBaseSessions(Кластер, ИнформационнаяБаза);
				Для каждого Сеанс из Сеансы Цикл
					
					Если нРег(Сеанс.AppID) = "backgroundjob" ИЛИ нРег(Сеанс.AppID) = "comconsole" Тогда
						// если это сеансы com-приложения или фонового задания, то не отключаем
						Продолжить;
					КонецЕсли;
					Если Сеанс.UserName = ИмяПользователя() Тогда
						// это текущий пользователь
						Продолжить;
					КонецЕсли;
					Агент.TerminateSession(Кластер, Сеанс);
					Сообщить("Отключен сеанс "+строка(Сеанс.UserName));
				КонецЦикла;
				
				ИнформационнаяБаза2 = РабПроц.CreateInfoBaseInfo();
				ИнформационнаяБаза2.Name = ИмяБазы;
				СоединенияБазы = РабПроц.GetInfoBaseConnections(ИнформационнаяБаза2);
				// Разорвать соединения клиентских приложений.
				Для Каждого Соединение Из СоединенияБазы Цикл
					Если нРег(Соединение.AppID) = "backgroundjob" ИЛИ нРег(Соединение.AppID) = "comconsole" Тогда
						Продолжить;
					КонецЕсли;
					Если Соединение.UserName = ИмяПользователя() Тогда
						// это текущий пользователь
						Продолжить;
					КонецЕсли;
					РабПроц.Disconnect(Соединение);
				КонецЦикла;
			Исключение
				текстош=текстош+" Ошибка при откл пользователей userkill " + строка(ИмяБазы)+ " "+строка(ТекущаяДата());
			конецпопытки;
		КонецЦикла;
	КонецЦикла;
	Сообщить("Завершается работа...");
	Возврат текстош;

КонецФункции

!!! Разумеется, при первом запуске внешней обработки в последних релизах платформы - ее исполнение нужно "разрешить", так что, перед тем, как пустить в свободное плавание - пару раз протестируйте.

Скачать файлы

Наименование Файл Версия Размер
Автоотключение пользователей 8.3 УФ:
.epf 7,52Kb
30.08.17
5
.epf 3 7,52Kb 5 Скачать

См. также

Комментарии
1. Вячеслав Гилёв (Gilev.Vyacheslav) 1759 31.08.17 12:45 Сейчас в теме
dt не является средством резервного копирования о чем прямо сказано в документации 1С
alex-l19041; olgerd666; +2 Ответить
2. oleg babikov (OlegAr) 4 31.08.17 14:16 Сейчас в теме
раз Вячеслав сказал, значит так и есть, не спорим ..
3. Евгений К (rar_xxx) 21 31.08.17 23:27 Сейчас в теме
только ms sql бекап забудте о dt причины: 1- mssql бекап в разы быстрее снимается и разворачивается потому что таблицы просто копируются для скорости полезно архивировать, для надежности не архивируйте. 2- при росте базы вы прийдете к тому что не сможете выгрузить в dt ;) хорошо если вовремя узнаете что бекап перестал сниматься 3. из dt вы можете в критический ден просто не восстановить базу. 4. очень интересно еслы вы бекап снимаете я так понимаю только ночью в течении дня бекапов у вас нет. надежда только на железо? Как насчет регулярного бекапа журнала транзакций например каждые 20мин или каждый час?
4. Erutan Revol (erutan) 37 31.08.17 23:51 Сейчас в теме
(3) надежда на железо в плане аппаратного рейда.
С копией SQL комбинирую, но все равно раз в день.
Довольно часто приходится загрузить копию (в смысле sql > dt > файловая) гл.бухгалтеру, бухгалтеру или мне самому.

Нет, бэкапа транзакций не настраивал. Я так понимаю, это должно прикатить к восстановление SQL-копии + восстановление к моменту времени сохраненных транзакций?

Благодарю за комментарии.
5. Евгений К (rar_xxx) 21 01.09.17 00:04 Сейчас в теме
Обязательно настройте бекап транзакционного журнала, на сторонний носитель, например раз в 1час или чаще. Таким образом если у вас есть ночной полны sql бекап и в середине дня железо накрывается или вы рушите базу. У вас будет возможность восстановится на любой момент времени, до секунды или конкретной транзакции из забекапленных журналов. Плюс если у вас стоит полная модель восстановления а вы не бекапите журнал, он будет постоянно расти. Так же с помощью журнальных бекапов вам можно отказаться от ежедневных бекапов, которые много весят, но тогда важно отстроить четкий рабочий бекап журналов, это опасная схема и рекомендуется только если у вас нет места на ежедневный бекап. Да и про рейд у нас один раз в схд вылетела вся полка не спас и 10 рейд, винты лучше брать разных серий ;) но для дорогих схд вам придется брать то что дает вендор(
Оставьте свое сообщение