Управляемые формы: чтение макетов с объединенными ячейками (в частности, и из экселей)

Публикация № 692579

Разработка - Практика программирования

макеты управляемые формы объединение ячеек чтение xls

14
При чтении данных из файлов через табличный документ у начинающих и продолжающих специалистов по платформе иногда возникают трудности. Например, с тем, как прочитать данные из объединенных ячеек один раз. Статья прояснит некоторые детали.

Всем добрый период времени!

Суть задачи, которую мы разберем, в том, как прочитать данные из объединенных ячеек табличного документа с помощью объекта "ТабличныйДокумент". Также коснемся того, как пройтись по выделенным данным. Итак, приступим.

ЧТЕНИЕ ТАБЛИЧНОГО ДОКУМЕНТА

Для чтения табличного документа в 1С можно использовать как ни странно объект "ТабличныйДокумент". С версии 8.3.7 (если не изменяет память) данный объект способен читать не только MXL-файлы, но и XLS/XLSX/ODT и какие-то еще варианты таблиц (а также, кстати, и писать).

Но как всегда есть одна малюсенькая проблемка - объект создается только на сервере. Но 1С попыталась решить данную проблему создав потоки в памяти и предоставив программисту возможность использовать их вместо пути к файлу в конструкторе объекта, но при этом необходимо указать тип читаемого файла. Правда у меня на платформе Windows 7 pro x64 c 1C 8.3.10.2466 эксель таким образом прочитать не получилось, а вот MXL читает замечательно, поэтому для екселевский файлов все-равно придется создать временный файл.

Итак, код чтения файлов:

&НаСервере
Процедура ЗагрузитьФайлНаСервере(ДД, Расширение)

	Если Расширение = "xml" Тогда 
		ЧД = Новый ЧтениеДанных(ДД);
		Таб.Прочитать(ЧД, СпособЧтенияЗначенийТабличногоДокумента.Значение, ТипФайлаТабличногоДокумента.MXL);
	Иначе
		ИмяФайла = ПолучитьИмяВременногоФайла(Расширение);
		ДД.Записать(ИмяФайла);
		Таб.Прочитать(ИмяФайла);
		УдалитьФайлы(ИмяФайла);
	КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьФайл(Команда)
	
	Длг = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
	Длг.Фильтр = "MXL-files (*.mxl)|*.mxl|XLS-files (*.xls)|*.xls|XLSX-files (*.xlsx)|*.xlsx|ODS-files (*.ods)|*.ods";
	Длг.Показать(Новый ОписаниеОповещения("ПриВыбореФайла", ЭтаФорма));
	
КонецПроцедуры

&НаКлиенте
Процедура ПриВыбореФайла(Рез, Доп) Экспорт 
	
	Если Рез = Неопределено Тогда 
		Возврат
	КонецЕсли;
	
	фл = Новый Файл(Рез[0]);

	ЗагрузитьФайлНаСервере(
			Новый ДвоичныеДанные(Рез[0]),
			НРег(фл.Расширение)
		);

КонецПроцедуры

Создадим форму с табличным документом и кнопкой "Загрузить файл" и получим фот такую формочку, которая сможет прочитать MXL, XLS, XLSX и ODS файлы в табличный документ.

ВЫДЕЛЕННЫЕ ЯЧЕЙКИ

Давайте разберемся, где тут у нас находятся выделенные пользователем ячейки. И вот тут интересная странность платформы в том, что эти выделенные ячейки доступны только на клиенте в соответствующем элементе формы. Давайте пробежимся по выделенным ячейкам и распечатаем результат в строку сообщений:

&НаКлиенте
Процедура СообщитьВыделенное(Команда)
	
	Для Каждого Область ИЗ Элементы.Таб.ПолучитьВыделенныеОбласти() Цикл 
		Для Х = Область.Лево ПО Область.Право Цикл 
			Для У = Область.Верх ПО Область.Низ Цикл 
				Сообщить(Таб.Область(У,Х).Текст);
			КонецЦикла;
		КонецЦикла;
	КонецЦикла;
	
КонецПроцедуры

Если мы выделим теперь первую строку без объединенных ячеек, то получим следующий результат:

Т.е. тут у нас напечаталось А, Б и В. Если же мы выберем вторую строку, то получим иную картину:

Как видите, наличие объединения никоим образом не мешает нам получить данные из строки [2;2], которая у нас объединена со строкой [2;1], При том в обоих этих строках будет находиться значение "А". Если мы выделим третью строку, то получим вывод "А А А" (ну вы уже поняли, почему, да?)

ОБЪЕДИНЕННЫЕ ЯЧЕЙКИ

Для того, чтобы исправить проблему с объединенными ячейками, нужно просто узнать одну подробность: каждая ячейка имеет реквизиты "Лево", "Право", "Верх" и "Низ". И для объединенных ячеек они не будут равны. Для простого объединения по оси Х произвести чтение с учетом объединения будет достаточно просто:

	Для Каждого Область ИЗ Элементы.Таб.ПолучитьВыделенныеОбласти() Цикл 
		Для Х = Область.Лево ПО Область.Право Цикл 
			Для У = Область.Верх ПО Область.Низ Цикл 
				Сообщить(Таб.Область(У,Х).Текст);
				Х = Х + Таб.Область(У,Х).Право - Таб.Область(У,Х).Лево;
			КонецЦикла;
		КонецЦикла;
	КонецЦикла;

Мы просто добавляем к "Х" "право" и вычитаем "лево".

А для оси "У" предлагаю разобраться самостоятельно (в качестве домашнего задания).

Всех благ!

14

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. bulpi 157 29.10.17 13:51 Сейчас в теме
1)В тексте ЗагрузитьФайлНаСервере ошибка, замените xml на mxl
2)А если не выделенные ячейки ? При чем тут выделение на форме к проблеме чтения объединенных ячеек ?
2. starik-2005 1957 29.10.17 16:31 Сейчас в теме
(1) 1. Ну это, как я понял, не мешает верно прочитать.
2. А в чем разница? С выделенными интереснее, а не выделенные и сами прочитаете теперь.
3. shurik_shurik 01.11.17 21:28 Сейчас в теме
Х = Х + Таб.Область(У,Х).Право - Таб.Область(У,Х).Лево;

Может это нужно вынести с цикла по Y ?
И второй момент, зачем вычитать разницу, если можно сделать типа так:
Х =  Таб.Область(У,Х).Право
4. starik-2005 1957 02.11.17 16:38 Сейчас в теме
(3)
зачем вычитать разницу, если можно сделать типа так:
Можно. Цикл в таком случае можно заменить на Пока Х < ...
5. dajen 09.11.17 11:55 Сейчас в теме
Ну не то чтобы очень просто. Если выделять 2 строки, где объединение не тривиально, пример во вложении (если в нижней строке объединение шире и перекрывает что-то из верхней - программа не вернется туда и не выведет).

Почему не поставить просто условие:
Если Таб.Область(У,Х).Верх = У и
Таб.Область(У,Х).Лево = Х Тогда

Сообщить(Таб.Область(У,Х).Текст);
КонецЕсли;

Обходя таким образом выводится все и по одному разу при любых извращениях с объединением, по-моему.
Прикрепленные файлы:
6. starik-2005 1957 09.11.17 13:38 Сейчас в теме
(5)
Таб.Область(У,Х).Верх = У и
Таб.Область(У,Х).Лево = Х
В принципе имеет право на существование. Проблема только в том, что лишние Х и У выбираются, но этим при небольших размерах файла можно пренебречь.
Оставьте свое сообщение

См. также

"Вы всё сломали!". Разбираемся, кто прав, кто виноват 9

Статья Программист Нет файла v8::УФ ИТ-компания Россия Бесплатно (free) Практика программирования

О том, как "всё испортил" программист, а на самом деле виноват заказчик.

20.09.2019    2765    RomanCrow13    26       

Оповещения боту из 1С за 31 минуту 120

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Практика программирования Интеграция

Поделюсь опытом, как быстро сделать бота с оповещениями в Телеграмм из 1С без лишних затрат.

18.09.2019    8327    4    feva    31       

Агрегатные функции СКД, о которых мало кто знает 315

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    9566    ids79    42       

EnterpriseData – часть 3. Загрузка данных, идентификация объектов 61

Статья Программист Нет файла v8 v8::УФ 1cv8.cf ОС Бесплатно (free) Практика программирования Математика и алгоритмы Перенос данных из 1C8 в 1C8 Разработка

Основные этапы загрузки данных через EnterpriseData. Идентификация объектов загружаемых полностью и по ссылке. Приведены схемы процессов загрузки данных. Описание основных операций и обработчиков. Перечень процедур БСП, используемых при загрузке данных, структура «КомпонентыОбмена».

22.08.2019    3256    ids79    7       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 240

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    9929    ids79    22       

Кодовое создание документа на 8.3, управляемые формы (на примере) 11

Статья Программист Стажер Нет файла v8::УФ 1cv8.cf Бесплатно (free) Практика программирования Разработка

В своё время мне нужен был код создания документа через обработку, пол дня потерял пока нашёл гайд по решению данной задачи. Поэтому просто решил поделиться данным решением. Подойдёт только новичкам, опытные программисты могут даже не читать =)

07.08.2019    1774    Nefilimus    15       

Создание отчетов с помощью СКД - основные понятия и элементы 190

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    17048    ids79    16       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 175

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    11346    dmurk    134       

Вставка гиперссылки в форматированный документ 9

Статья Программист Нет файла v8::УФ Бесплатно (free) Практика программирования Разработка

Да, форматированный документ это умеет и сам, но возможности можно расширить!

03.06.2019    1966    Yashazz    0       

Добавление внешних отчетов / обработок в собственные подсистемы 22

Статья Программист Стажер Нет файла v8::УФ Россия Бесплатно (free) Практика программирования Разработка

Краткая инструкция по добавлению функционала доп обработок/отчетов в собственную подсистему.

24.05.2019    3599    login1020    7       

Расшифровка отчета на СКД с детализацией по выбранному полю на основе БСП 91

Статья Программист Нет файла v8 v8::УФ v8::СКД 1cv8.cf Россия Бесплатно (free) Практика программирования Работа с интерфейсом Разработка

В данной статье рассмотрим механизм работы с расшифровкой отчета, созданного при помощи системы компоновки данных, в управляемом приложении. Показывать буду на примере реальной задачи. Условие: использовать имеющиеся в конфигурации механизмы БСП, с минимальными и "правильными" изменениями. Расшифровка должны быть двух видов на каждом поле: 1. Открывать ссылочный объект 2. Открывать новую форму с детализацией табличной части документа. Собственно ради второго пункта и писалась статья, в основном для себя, чтобы не забыть.

14.05.2019    7168    Viktor_Ermakov    6       

Оперативная доработка отчетов без обновления конфигурации или расширения 7

Статья Программист Нет файла v8::УФ 1cv8.cf Россия Бесплатно (free) Практика программирования Разработка

В статье рассматривается вариант оперативной доработки отчетов при помощи механизма дополнительных отчетов и обработок и небольшой модификации конфигурации.

12.05.2019    1999    samvani    0       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4703    m-rv    2       

Автоматизация печатной формы (автоформирование табличного документа на основе любой таблицы значений) 3

Статья Программист Нет файла v8 v8::УФ 1cv8.cf Бесплатно (free) Практика программирования Разработка

Автоматическое формирование табличного документа из выбранной таблицы значений. Пример как можно рутинные действия по оформлению внешнего вида печатной формы переложить на программу. Статья предназначена в первую очередь для тех, кто не сильно владеет СКД (как я, например), но которым не хочется тратить свое время на формирование разных макетов, если вывести документ нужно в стандартном виде. Код полностью открыт, пользуйтесь на здоровье. :)

18.04.2019    1373    NeSPEC    0       

Этюды по программированию. Хитрости создания расширений для конфигураций на БСП. Часть 2 42

Статья Программист Нет файла v8::УФ Бесплатно (free) Практика программирования Разработка

Некоторые нюансы, если вы захотите создавать свои расширения. Продолжение первой части.

16.04.2019    6694    milkers    8       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7211    m-rv    16       

О расширениях замолвите слово... 192

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    16144    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 200

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    12548    ellavs    83       

Выбор периода на управляемой форме почти как на обычных формах 23

Статья Программист Стажер Нет файла v8 v8::УФ 1cv8.cf Бесплатно (free) Практика программирования Разработка

Простой механизм выбора периода на управляемой форме максимально похожий на аналог в обычных формах, тестировалось на платформах 8.3.8.ХХХ и выше.

26.03.2019    2722    independ    6       

Доработка проведения типовых документов в УТ 11.4, КА 2.4, ЕРП 2.4 101

Статья Программист Нет файла v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Бесплатно (free) Практика программирования Универсальные функции Разработка

Различные варианты корректировки типовых механизмов проведения документов, без корректировки основной конфигурации. Использование расширений, подписок на событие и механизма локализации типовых документов.

22.03.2019    8640    ids79    14       

Иерархия групп и элементов в форме списка справочника как в проводнике. УФ 37

Статья Программист Нет файла v8 v8::УФ 1cv8.cf Россия Бесплатно (free) Практика программирования Разработка

Если в форме списке надо выводить группы и элементы в разных таблицах, так как, например, в проводнике - слева группы, справа элементы, то для тех кто не знал или забыл, представлена инструкция, как это сделать.

20.03.2019    4028    rebuzx    11       

Добавление отчетов в типовые конфигурации 1С 200

Статья Программист Нет файла v8::УФ v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Описание различных способов добавления общих и контекстных отчетов в конфигурации 1С, построенные на базе БСП. Основные моменты и нюансы.

07.03.2019    22839    ids79    32       

Программное изменение управляемых форм 29

Статья Программист Нет файла v8::УФ Бесплатно (free) Практика программирования Разработка

При адаптации типовых конфигураций 1С часто приходится изменять в 1С 8 управляемые формы. Такие адаптации сложно потом поддерживать при обновлении. Такие изменения приходится вносить вручную заново, перепроверять корректность изменений в каждом обновлении. И если таких изменений множество, то каждое обновление может представлять серьезные трудозатраты. Есть несколько решений, которые позволяют упростить поддержку и обновление измененных систем 1С. Одно из них – это программное изменение форм. Вести разработку в таком режиме получается немного дольше, чем прямое изменение формы. Но это хорошо компенсируется в дальнейшем при поддержке и обновлении системы 1С. На самом деле ничего сложного в этом нет, просто нужно привыкнуть. Рассмотрим на примерах, как делать доработку управляемых форм кодом в 1С.

05.03.2019    5152    user759624    10       

Функциональные опции 1С 8.3 – все возможные варианты использования 170

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Практика программирования Разработка

Примеры использования функциональных опций для управления интерфейсом и элементами управляемых форм, с различными вариантами хранения значений: константа, реквизит справочника, ресурс регистра сведений.

22.02.2019    15544    ids79    5       

Информирование пользователя. Работа с объектом «СообщениеПользователю» 248

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Практика программирования Разработка

Различные варианты и нюансы использования объекта СообщениеПользователю и другие способы информирования пользователя: без привязки к какой-либо форме и с выводом сообщения в отдельном окне.

15.02.2019    16658    ids79    32       

Установка шрифтов из 1С, управляемые формы 4

Статья Программист Нет файла v8 v8::УФ Windows Бесплатно (free) Практика программирования Разработка

При разворачивании своей конфигурации (специализированной) потребовалось автоматически установить необходимые шрифты. Быстрый поиск привел на статью https://infostart.ru/public/355315/ но у меня шрифты устанавливались неправильно - в реестре информация не обновлялась, да и в списке шрифтов данные так же не обновились (Проверял на Windows 10). Пришлось писать свой код.

04.02.2019    2745    zsrg    0       

Исправление отрицательных остатков по организациям в УТ 11.4, КА 2.4, ЕРП 2.4. Интеркампани, механизм формирования резервов 64

Статья Программист Нет файла v8 v8::УФ ERP2 УТ11 КА2 УУ Учет ТМЦ Бесплатно (free) Практика программирования Адаптация типовых решений

Подробно рассмотрены два способа исправления отрицательных остатков по организациям без использования подсистемы Интеркампани и с использованием. Описан механизм формирования резервов на уровне процедур общего модуля. Доработки механизма и исправление ошибок.

29.01.2019    12766    ids79    25       

Отладка дополнительных отчетов и обработок (Управляемые формы 8.3 БСП) 25

Статья Программист Нет файла v8::УФ 1cv8.cf Россия Бесплатно (free) Практика программирования

Собственно отладка дополнительных отчетов и обработок (Управляемые формы 8.3 БСП).

17.01.2019    6983    aagubarev    22       

Добавление ставки НДС 20% на старой УТ 11.0 за 2 шага 15

Статья Программист Нет файла v8::ОУ v8::УФ УТ11 Оптовая торговля, дистрибуция, логистика Россия НДС Бесплатно (free) Практика программирования

Предлагаю Вам небольшую инструкцию по добавлению ставки НДС 20% в старую "необновляемую" конфигурацию "Управление торговлей 11.0".

02.01.2019    12046    aximo    12       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12537    ids79    27       

Новый подход к обмену данными EnterpriseData 202

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    21118    ids79    72       

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации 117

Статья Программист Нет файла v8 v8::УФ БП3.0 УТ11 Россия Windows Бесплатно (free) Практика программирования Обмен через XML

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    18680    ids79    20       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 125

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20650    ids79    40       

Отладка запроса с содержимым временных таблиц (управляемые формы) 64

Статья Программист Нет файла v8 v8::УФ v8::Запросы 1cv8.cf Россия Бесплатно (free) Практика программирования

Получение данных запроса из отладки. Загрузка текста запроса, параметров, данных временных таблиц

01.11.2018    11180    Evg-Lylyk    43       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20299    tormozit    100       

Приемы работы с СКД: делаем за 5 минут то, на что у других уйдет час 375

Статья Программист Нет файла v8::СКД Бесплатно (free) Практика программирования

Сергей Наумов делится опытом нестандартного использования системы компоновки данных. Он рассказывает о построении сложных отчетов с помощью функций СКД, описывает преимущества использования компоновки в коде для значительного сокращения строк кода и времени на решение задач, а также рассказывает про отладку компоновки и возможности оптимизации ее работы.

03.09.2018    30769    SergeyN    25       

Переопределение кнопки "Провести и закрыть" 8

Статья Программист Нет файла v8::УФ 1cv8.cf Россия Бесплатно (free) Практика программирования

Бывает, что возникает задача, когда перед записью или проведением документа необходимо задать пользователю вопрос для дальнейше записи. Процедура "ПередЗаписью" не всегда может подойти и возникает необходимо переопределить действие кнопки "Провести и закрыть". Ниже расскажу простой способ, как это можно сделать.

17.08.2018    7151    Anchoret    16       

Зачем запросу план и кто его выполняет? 175

Статья Программист Нет файла v8::Запросы Бесплатно (free) Практика программирования

Как определить, почему запрос выполняется слишком долго? Что происходит с запросом на стороне сервера баз данных? В статье приводится объяснение, что такое план запроса и для чего он нужен. А также говорится о том, в чем разница между потоком операторов и потоком данных, как работает оптимизатор и зачем нужна статистика.

09.08.2018    18068    Dem1urg    44       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19156    olegtymko    43       

Добавляем кнопку "Присоединенные файлы" к любому документу без строчки кода 17

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Практика программирования

Добавляем кнопку "Присоединенные файлы" к любому документу на примере базы Зарплата и управление персоналом в кредитных организациях, редакция 3.1 (3.1.4.171)

20.06.2018    8205    pavel_pss    9       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21063    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    16824    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11233    Rustig    9       

Вызов n-го количества немодальных окон из одной процедуры и передача параметров в процедуру печати 3

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Практика программирования

Приветствую! В статье рассматривается пример вызова нескольких форм из одной процедуры для получения неких значений и передача этих значений в процедуру печати табличного документа.

25.03.2018    7263    akor77    0