Алексей Тишков | Заместитель начальника отдела ИТ | ПАО "Амурский судостроительный завод"

«Цифровая трансформация процессов судостроительного предприятия на платформе 1С»

В докладе будет рассмотрен пример построения единого информационного пространства на платформе 1С с использованием комплекса конфигураций: - Управление производственным предприятием; - Документооборот КОРП; - Бухгалтерия предприятия с надстройкой "БИТ:Финанс"; Комплекс конфигураций является фундаментом для внедрения процессного подхода к управлению, системы на платформе 1С используются не только в качестве "учетных", а в качестве среды выполнения формализованных процессов. Таким образом, уровень зрелости и функциональности комплекса перешел от "учетного" к "среде жизненного цикла процессов". Реализованы, в том числе, сквозные процессы между конфигурациями и интегрированными внешними системами (концепция "большие процессы", или "большая единая 1С"), сквозной сбор данных стратегического BI-уровня (контрольные отчеты директора). Используемые технологии: - неквалифицированная цифровая подпись согласно 63-ФЗ (используется для согласования договоров, служебок, исходящих писем, приказов, распоряжений и многих других внутренних документов); - интеграция с внешними системами посредством web-сервисов (интеграция с системой СКУД и управление блокировкой прохода на предприятие из кадровой системы); - интеграция между конфигурациями 1С посредством COM-объектов и web-сервисов; - внешние компоненты; - объекты метаданных Бизнес-процессы и Задачи; На сквозном примере будет рассмотрен общий принцип цифровой трансформации отдельного процесса, выполнение следующего комплекса преобразований: 1. Определение возможного уровня цифровизации, возможности реализации в какой-либо информационной системе весь жизненный цикл процесса (все ли участники процесса присутствуют в информационной системе, могут присутствовать потенциально); 2. Описание и формализация, моделирование текущего состояния процесса, выявление проблемных зон и функций, связанных с вещественной формой передачи информации (на примере модели в нотации EPC); 3. Моделирование трансформированного состояния процесса, определение среды жизненного цикла цифровой формы процесса (подсистемы), измененных форм первичных документов; 4. Закрепление трансформированной формы процесса в системе менеджмента качества (актуализация или создание нормативной базы); 5. Изменение соответствующей информационной подсистемы (архитектура прикладных объектов, кодирование, тестирование); 6. Внедрение и обучение пользователей (участников процесса), постановка на эксплуатацию. Доклад будет интересен практикам внедрения на крупных промышленных предприятиях.

Внешняя компонента 1С для подключения весового терминала Т3 фирмы ФИЗТЕХ

Программирование - Внешние компоненты

Внешняя компонента 1С (*.dll) для подключения и получения данных с весового терминала Т3 фирмы ФИЗТЕХ

Компонента по внешнему событию возвращает строковое значение вида: "[Вес];[Произведено тарирование (0/1)];[Весы успокоены(0/1)];[флаг переполнения(0/1)];[Флаг счетного режима(0/1)]" в случае сбоя получения данных с терминала возвращается строка полученная с весового терминала - "DEBUG:  #00 #00 #00 #00 #00 #00".

Компонента работает уже 6 лет (1с 8.1, 8.2, 8.3), проблем не замечено.

 

 

В архиве две демонстрационные конфигурации v7.7 и v8, сама библиотека DLL и примеры.

Регистрация компоненты в системе:

Запустите от имени Администратор командную строку, введите regsvr32  <Путь к библиотеке>\T3VK.dll 

Например, regsvr32 C:\1c\base\dll\T3VK.dll

Вы должны получить сообщение об успешной регистрации библиотеки.

Для 1С v7.7 пример:

перем t3vk Экспорт; //переменная для объекта внешней компоненты

Функция глЗагрузитьВнешнююКомпоненту(прм_ИмяВК)
	имяф=КаталогИБ()+"DLL\"+прм_ИмяВК+".dll";
	Если фс.СуществуетФайл(имяф)=0 Тогда
		Сообщить("Не обнаружен файл внешней компоненты "+имяф,"!!");
		Возврат 0;
	КонецЕсли;
	
	Если ЗагрузитьВнешнююКомпоненту(имяф)=0 Тогда
		Сообщить("Не удается загрузить внешнюю компоненту "+прм_ИмяВК+".dll","!!");
		Сообщить("Первый запуск конфигурации с внешними компонентами должен производиться под правами администратора или привилегированного пользователя операционной системы.","!!");
		Возврат 0;
	Иначе 
		Сообщить("Внешняя компонента "+прм_ИмяВК+".dll" + " загружена!"," ");
	КонецЕсли;
	
	Возврат 1;
КонецФункции	// глЗагрузитьВнешнююКомпоненту


///////////////////////////////////////////////////////////////////////

Процедура ПриНачалеРаботыСистемы() //Предопределенная процедура 1С
	
	ок=1;
	Если глЗагрузитьВнешнююКомпоненту("T3VK")=0 Тогда
		Сообщить("Внешняя компонента не была загружена!","!");
	Иначе
		t3vk=СоздатьОбъект("AddIn.t3vk");
	    Сообщить("Выполняем: t3vk.ПолучитьВес(COM1)"," ");
	    t3vk.ПолучитьВес("COM1");
	
	КонецЕсли;
КонецПроцедуры

///////////////////////////////////////////////////////////////////////

Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)//Предопределенная процедура 1С
	//Глобальный обработчик внешнего события
	Сообщить("Внешнее событие: Источник="+Источник+"  Событие="+Событие+"  Данные="+Данные);//Данные - Формат получаемой строки: <Вес>;<Произведено тарирование (0/1)>;<Весы успокоены(0/1)>;<флаг переполнения(0/1)>;<Флаг счетного режима(0/1)>;
КонецПроцедуры


Для 1С v8.1 пример: 

 перем t3vk Экспорт; //переменная для объекта внешней компоненты

///////////////////////////////////////////////////////////////////////

Процедура ПриНачалеРаботыСистемы() //Предопределенная процедура 1С
	Попытка
    		ЗагрузитьВнешнююКомпоненту("t3vk.dll");
    		Сообщить("Компонента t3vk загружена");
	Исключение
    		Сообщить("Компонента t3vk не найдена!", СтатусСообщения.Внимание);
	КонецПопытки;
        
	Сообщить("Выполняем: t3vk.ПолучитьВес(COM1)",СтатусСообщения.Важное);
	t3vk=Новый("AddIn.t3vk");
    
	t3vk.ПолучитьВес("COM1");
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////

Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)//Предопределенная процедура 1С
	//Глобальный обработчик внешнего события
	Сообщить("Внешнее событие: Источник="+Источник+"  Событие="+Событие+"  Данные="+Данные);
//Данные - Формат получаемой строки: <Вес>;<Произведено тарирование (0/1)>;<Весы успокоены(0/1)>;<флаг переполнения(0/1)>;<Флаг счетного режима(0/1)>;
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Внешняя компонента 1С (*.dll) для подключения весового терминала Т3 фирмы ФИЗТЕХ
.ZIP 280,26Kb
22.11.17
1
.ZIP 280,26Kb 1 Скачать

См. также

Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение