Дополнительные единицы измерения кодов ТНВЭД (Статистика: Форма учета перемещения товаров) в форматах xlsx, txt, csv

Публикация № 707897

Печать - Классификаторы

Статистика ВЭД ВЭД ДЕИ Статистика: Форма учета перемещения товаров Дополнительные единицы измерения

2
Список дополнительных единиц измерения (ДЕИ) для кодов ТНВЭД, используемых для отправки статистических данных в ФТС (Федеральная Таможенная Служба).

При выгрузке данных по статистике в регламентированной отчетности "Статистика: Форма учета перемещения товаров" программы семейства 1С не умеют определять, какие дополнительные единицы измерения используются у кодов ТНВЭД. Если заполнить все единицы, то при загрузке в ФТС проверка не дает загрузить данные, требуя удалить коды, не используемые как дополнительные, в случае неуказания ДЕИ требует указать эти самые коды. 

Значения данных ДЕИ имеются на сайте ФТС в формате pdf. Проделав некоторые работы, я создал данный список в форматах excel и csv, которые и предлагаю вам скачать и использовать при заполнении регламентированной отчетности.

Данные представляют из себя набор состояний из трех колонок "код ТНВЭД, наименование ДЕИ, код ДЕИ по классификатору".

Пример использования в коде 1С 8.2 обычные формы (критика кода и методов не принимается, код показан в качестве примера перезаполнения уже созданного отчета)

Запрос = Новый запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	РегламентированныйОтчет.Ссылка,
	|	РегламентированныйОтчет.НаименованиеОтчета
	|ИЗ
	|	Документ.РегламентированныйОтчет КАК РегламентированныйОтчет
	|ГДЕ
	|	РегламентированныйОтчет.НаименованиеОтчета = ""Статистика: Форма учета перемещения товаров""";
	
		
	Рез = Запрос.Выполнить().Выгрузить();
	
		
	Кол = 0;
	
	Для каждого стр из Рез Цикл
		Кол = Кол + 1;
		
		Состояние("Обработка: " + Кол  + " из " + Рез.Количество());
			
		Об = стр.Ссылка.ПолучитьОбъект();
		
		ЗапросИнв = новый Запрос;
		ЗапросИнв.Текст = 
		"ВЫБРАТЬ
		|	ИнвойсТовары.Номенклатура.КодТНВЭД КАК КодТовара,
		|	ИнвойсТовары.Номенклатура.Наименование КАК НаименованиеТовара,
		|	""BY"" КАК СтранаТовараКод,
		|	""БЕЛАРУСЬ"" КАК СтранаТовараНаименование,
		|	ИнвойсТовары.СуммаВсего КАК ЦенаТовараВалДоллар,
		|	ИнвойсТовары.Ссылка.Поступление.КурсВзаиморасчетов * ИнвойсТовары.СуммаВсего КАК ЦенаТовараВалРубль,
		|	ИнвойсТовары.Количество КАК ЕдИзмТовараКВО,
		|	ИнвойсТовары.СуммаВсего КАК ЦенаТовараВыбВал,
		|	ИнвойсТовары.Номенклатура.Артикул КАК Артикул,
		|	ИнвойсТовары.Номенклатура.Производитель КАК Бренд
		|ИЗ
		|	Документ.Инвойс.Товары КАК ИнвойсТовары
		|ГДЕ
		|	ИнвойсТовары.Ссылка.НомерВходящегоДокумента = &ВХН
		|	И ИнвойсТовары.Ссылка.Проведен";
		
		ЗапросИнв.УстановитьПараметр("ВХН", Инвойс);
		ТН = ЗапросИнв.Выполнить().Выгрузить();
		
		Отбор = новый структура();
		отбор.Вставить("RenNumber",Инвойс);
        Найд = Таб.НайтиСтроки(отбор);
		
		Копия = Таб.Скопировать(Найд);
				

		
		Хран.ДанныеМногострочныхРазделов.П0001000002.Очистить();
    	ОбработкаПрерыванияПользователя();

		Для каждого стр1 из ТН Цикл
						 
			 Доб = Хран.ДанныеМногострочныхРазделов.П0001000002.Добавить();
			 
			 
			 
			 ЗаполнитьЗначенияСвойств(Доб,Стр1);
			 Доб.КодТовара = Стрзаменить(Стр1.КодТовара," ","");
			 
			 Отбор3 = новый структура;
			 Отбор3.Вставить("ТНВ", Доб.КодТовара);
			 
			 Найд = Таб2.найтиСтроки(отбор3); //Таб2 - таблица ДЕИ
		
			 Если не Найд.Количество() = 0 и НЕ СокрЛП(Найд[0].Код)="" тогда 
				 Спр = Справочники.КлассификаторЕдиницИзмерения.НайтиПоНаименованию(Найд[0].Код);
				 Если Спр = неопределено или Спр = Справочники.КлассификаторЕдиницИзмерения.ПустаяСсылка() Тогда
					 Доб.ЕдИзмТовараКво = 0;
					 Доб.ЕдИзмтовараКод = "";
					 Доб.ЕдИзмТовараКратко = "";
               	 Иначе
					 Доб.ЕдИзмтовараКод = Спр.Код;
					 Доб.ЕдИзмТовараКратко = спр.Наименование;
				 КонецЕсли;
				 
				 
			 Иначе
		     	 Доб.ЕдИзмТовараКво = 0;
				 Доб.ЕдИзмтовараКод = "";
				 Доб.ЕдИзмТовараКратко = "";
         	 КонецЕсли;
			 
			 
			 			 
		 КонецЦикла;
		 Для каждого эл из масУд Цикл
			 Хран.ДанныеМногострочныхРазделов.П0001000002.Удалить(эл);
		 КонецЦикла;
		 

		Об.ДанныеОтчета = Новый ХранилищеЗначения(Хран);
	    Об.Записать();
	КонецЦикла;

В открытом доступе подобной информации мне найти не удалось. Актуальность справочника 01.09.2017 (последняя версия с сайта ФНС).

Причины купить

 Альтернативой является заполнение статистической формы через стороннее 1С программное обеспечение, зачастую в ручную, а при большом объеме данных это очень и очень не приятно.

Достоинства

 Преимуществом является возможность реализации автоматического заполнение дополнительных единиц измерения по кодам ТНВЭД.

2

Скачать файлы

Наименование Файл Версия Размер
Дополнительные единицы измерения кодов ТНВЭД (Статистика: Форма учета перемещения товаров) в форматах xlsx, txt, csv:
.zip 303,44Kb
29.11.17
0
.zip 1 303,44Kb Скачать

См. также

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение