Получение информации о последней версии конфигурации 1С

Публикация № 713433

Администрирование - Сервисные утилиты

Обработка версия конфигурация новое в версии

6
Обработка для получения последней актуальной версии конфигурации и минимальной версии платформы, необходимой для ее работы, а так же информация "Новое в версии". ЛОГИН И ПАРОЛЬ НЕ ТРЕБУЮТСЯ.

Возникла необходимость контролировать актуальность версий различных конфигураций клиентов, не проверяя каждый раз выход новой версии на сайте.

Т.е. организовал список конфигураций клиентов, а с помощью данной обработки получал актуальную информацию по каждой из конфигураций и видел, какие программы требуют обновления. 

Механизм получения данных реализован через веб-сервис сайта 1С.

За основу взят типовой механизм проверки обновлений в различных конфигурациях (УТ 11, БП 3, ЗУП 3 и т.д.).

Обработка может работать абсолютной в любой конфигурации начиная с платформы 8.3, даже в пустой конфигурации. 

Если есть необходимость использовать в программе на 8.2 - придется поставить платформу 8.3 и открыть программу через нее, а так же убрать режим совместимости 8.2 в свойствах конфигурации (или поставить 8.3). В Механизме используются методы, которых нет в платформе 8.2

Для разных интерфейсов (обычных и управляемых) выкладываю свою обработку.

Принцип работы следующий - в веб-сервис отправляется информация о названии конфигурации (на английском), и текущей версии. И если есть более свежая - будет получен ответ.

Например: Название конфигурации - Retail, Текущая Версия - 2.2.2.9. Результат - актуальная версия - 2.2.7.29, мин. платформа 8.3.10.2667.  Информация на момент написания статьи 2017-12-09.

В обработке приведен пример в виде списка конфигураций и версий, начиная с которых веб-сервис 1С возвращает информацию об актуальной версии. Список этот подобран простым методом тыка. Выбирал наиболее популярные программы.

P.S. Отправляя на веб-сервис старые версии конфигураций - в ответ не приходит никакой информации. Потому в обработке и представлены минимальные версии конфигураций, начиная с которых с веб-сервиса приходит ответ.

Обновление от 2017-12-17: Добавлен вывод информации "Новое в версии"

6

Скачать файлы

Наименование Файл Версия Размер
Получить последнюю версию конфигурации (обычные формы):
.epf 21,10Kb
11.12.17
2
.epf 21,10Kb 2 Скачать
Получить последнюю версию конфигурации (Управляемые формы):
.epf 20,62Kb
11.12.17
15
.epf 20,62Kb 15 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. ekaruk 4616 11.12.17 00:44 Сейчас в теме
Нужна ли для этой обработки подписка на ИТС или веб-сервис с общим доступом?
3. Erofeevgv 11.12.17 08:55 Сейчас в теме
(1) Ни логинов, ни паролей, ни подписка не нужны. Нужен прямой доступ в интернет. Использование прокси и прочее не делал.
ryutao; HEKPOH; +2 Ответить
5. ekaruk 4616 11.12.17 09:52 Сейчас в теме
(3) Спасибо. Работает. Как раз искала пример.
10. rpgshnik 1197 19.12.17 11:23 Сейчас в теме
(5) пример то механизм типовой))
11. ekaruk 4616 19.12.17 14:04 Сейчас в теме
(10) Тут удобнее, чем из типовой вырезать.
12. rpgshnik 1197 19.12.17 16:11 Сейчас в теме
2. IsiKosta 711 11.12.17 06:28 Сейчас в теме
Можете сделать вывод информации, что нового в релизе?
4. Erofeevgv 11.12.17 08:57 Сейчас в теме
(2) Хорошая идея. Я посмотрю, возвращается ли какая то информация об этом. Пока не готов не сказать.
6. HEKPOH 70 13.12.17 14:56 Сейчас в теме
(2) В структуре ИнформацияОДоступномОбновлении, которая получается в модуле объекта обработки в процедуре ПолучитьВерсиюНаСервере() имеется свойство Конфигурация (тоже структура) со свойством URLНовоеВВерсии, значением которого является ссылка на новое в релизе
Прикрепленные файлы:
7. Erofeevgv 14.12.17 08:51 Сейчас в теме
(6) Александр, спасибо за наводку )
Буду прикручивать
8. Erofeevgv 18.12.17 07:27 Сейчас в теме
9. rpgshnik 1197 19.12.17 11:22 Сейчас в теме
Код конечно типовой) но всё равно лайк, ибо сам тоже хотел его выдернуть.

Когда ты работаешь в режиме совместимости 8.2.13 и скачал для управляемого интерфейса обработку как я то вам помогут мои костыли :))))

//Котов Д.В. 19.12.2017 
//В платформе 8.3.6 типовая функция возвращает массив строк из строки с разделителями
Функция СтрРазделить(Строка,Разделитель) Экспорт
	Строки = СтрЗаменить(Строка,Разделитель,Символы.ПС);
	ЧислоСтрок = СтрЧислоСтрок(Строки);
	МассивСтрок = Новый Массив;
	Для Счетчик = 1 По ЧислоСтрок Цикл
		 МассивСтрок.Добавить(СтрПолучитьСтроку(Строки, Счетчик));
	КонецЦикла;
	Возврат МассивСтрок;
КонецФункции

//Котов Д.В. 19.12.2017 
//Дада в платформе 8.3.6 есть такая функция
Функция СтрНайти(Строка,Поиск) Экспорт
	Возврат Найти(Строка,Поиск);
КонецФункции

//Котов Д.В. 19.12.2017 
//В платформе 8.3.6 массив собирает в строку с разделителем
Функция СтрСоединить(МассивСтрок,Разделитель) Экспорт
	Строка = "";
	Для Каждого Элемент Из МассивСтрок Цикл
		Строка = Строка + ?(Строка = "","",Разделитель) + Элемент;
	КонецЦикла;
	Возврат Строка;
КонецФункции

Показать


Я как раз на днях сделал себе продеру для HTML рассылки - https://infostart.ru/public/715184/ и скрестив их во едино результат работы меня радует, теперь регламентной задание утром будет проверят:
Прикрепленные файлы:
13. HAMelle_ON 21.12.17 13:11 Сейчас в теме
Оставьте свое сообщение