Функции для хранения рисунков в отдельной базе MSSQL в varbinary с помощью ADODB

Публикация № 77329

Разработка - Практика программирования

В статье приведен набор функций для хранения файлов в отдельной базе MSSQL.

В одной из своих статей я рассказывал, как можно хранить рисунки в отдельной базе данных MSSQL с помощью ADO.Net и Base64Строка (ссылка в профиле). Предыдущий способ имел как плюс (для работы с полученным из базы файлом не требовалось предварительно сохранять данные во временный файл), так и минус (объем данных в базе = объем данных файла * 3).

Из-за увеличенного в 3 раза объема данных страдала и скорость чтения/записи. Поэтому я продолжил свою работу над данным вопросом и через некоторое время набор функций был переработан в сторону хранения данных в поле varbinary. Плюсы: объем данных в базе = объему данных в файле, данные из varbinary можно считывать и записывать и другими программами. Минус - без временного файла тут никак.

В статье я не буду прикладывать обработки и скрипты, все тексты будут представлены явно.

Для начала нам необходима правильная таблица в БД. Вот скрипт:

 

CREATE TABLE [dbo].[FileStore](
	[GUID] [nvarchar](120) NOT NULL,
	[FileName] [nvarchar](256) NOT NULL,
	[Data] [varbinary](max) NOT NULL,
	[UserName] [nvarchar](100) NOT NULL,
	[DateTime] [datetime] NOT NULL
) ON [PRIMARY]

 

Назначение колонок:

GUID - ЗначениеВСтрокуВнутр объекта, к которому привязан файл;

FileName - имя файла;

Data - данные файла;

UserName - текстовое имя пользователя, положившего файл;

DateTime - дата и время, когда файл положили в базу.

Все функции в 1С я положил в модуль РаботаСSQL и вызываю их соответственно из модуля.

 

Функция ПодключитьсяКБазеSQL(АдресСервера = "192.168.0.1", ИмяБД = "AdvancedStore", Логин = "sa", Пароль = "*****", ИмяТаблицы = "FileStore") Экспорт
Con = Новый COMОбъект("ADODB.Connection");
СтрокаПодключения = "Provider=SQLOLEDB; Data Source=" + АдресСервера + ";Initial Catalog=" + ИмяБД + ";Persist Security Info=True;User ID=" + Логин + ";Password=" + Пароль;
Попытка
Con.Open(СтрокаПодключения);
//Сообщить("Подключение прошло успешно");
Исключение
Сообщить(ОписаниеОшибки());
Con = Неопределено;
КонецПопытки;
Возврат Новый
Структура("Подключение, Таблица", Con, ИмяТаблицы);
КонецФункции

Параметры для функции:

АдресСервера - адрес сервера MSSQL;

ИмяБД - имя базы данных в MSSQL;

Логин  - учетная запись для доступа к таблице, где будут храниться файлы;

Пароль - пароль для данной учетной записи;

ИмяТаблицы - имя таблицы в БД, куда будут складываться файлы.

Функция возвращает:

структуру ("Подключение, Таблица"), если подключение прошло успешно;

Неопределено, если подключиться к серверу не удалось.

 

Функция ПоложитьФайлВБазуSQL(Подключение, Ссылка, ИмяФайла, Замещать = Истина) Экспорт
Если Подключение = Неопределено Тогда
Предупреждение("Вначале необходимо подключиться к серверу SQL!");
Возврат Ложь;
КонецЕсли;
ИмяТаблицы = Подключение.Таблица;
ИДСсылки = ЗначениеВСтрокуВнутр(Ссылка);
Stream = Новый COMОбъект("ADODB.Stream");
Stream.Type = 1;
Stream.Open();
Stream.LoadFromFile(ИмяФайла);
RecordSet = Новый COMОбъект("ADODB.RecordSet");
RecordSet.CursorLocation = 3;
RecordSet.LockType = 2;
Имяр = РазобратьСтроку(ИмяФайла, "\");
Имяр = Имяр[Имяр.Количество() - 1].Значение;
Запрос = "select [GUID], [Data], [FileName], [UserName], [DateTime] from [" + ИмяТаблицы + "] where [GUID]='" + ИДСсылки + "' AND [FileName]='" + Имяр + "'";
Попытка
RecordSet.Open(Запрос, Подключение.Подключение);
Исключение
Сообщить(ОписаниеОшибки());
Возврат Ложь;
КонецПопытки;
Если
RecordSet.RecordCount > 0 И Замещать = Ложь Тогда
RecordSet.AddNew();
Имяр = Формат(ТекущаяДата(), "ДФ='dd.MM.yyyy hh-mm-ss'") + " " + Имяр;
ИначеЕсли
RecordSet.RecordCount = 0 Тогда
RecordSet.AddNew();
Иначе
RecordSet.MoveFirst();
КонецЕсли;
RecordSet.Fields("Data").Value = Stream.Read(-1);
RecordSet.Fields("GUID").Value = ИДСсылки;
RecordSet.Fields("FileName").Value = Имяр;
RecordSet.Fields("UserName").Value = СокрЛП(Строка(глТекущийПользователь));
RecordSet.Fields("DateTime").Value = ТекущаяДата();
RecordSet.Update();
Stream.Close();
RecordSet.Close();
Возврат Истина;
КонецФункции

Данная функция принимает следующие параметры:

Подключение - структура подключения, полученная из функции ПодключитьсяКБазеSQL;

Ссылка - ссылка на объект 1С, к которому прикрепляется файл;

ИмяФайла - полное имя файла с путем, который заливается в базу;

Замещать - Истина или Ложь. Сравнивается имя файла и GUID. Если такая запись уже есть, то:

при Истина - данные файла замещаются; при Ложь - создается новый файл, при этом перед именем файла вставляется текущие дата и время.

Функция возвращает:

Истина - файл успешно добавлен в базу;

Ложь - файл не удалось добавить в БД.

 

Функция ЗаменитьОбъектФайлаВБазеSQL(Подключение, ИмяФайла, Ссылка, Ссылка2) Экспорт
Если Подключение = Неопределено Тогда
Предупреждение("Вначале необходимо подключиться к серверу SQL!");
Возврат Ложь;
КонецЕсли;
ИДСсылки = ЗначениеВСтрокуВнутр(Ссылка);
ИДСсылки2 = ЗначениеВСтрокуВнутр(Ссылка2);
Command = Новый COMОбъект("ADODB.Command");
Command.ActiveConnection = Подключение.Подключение;
Command.CommandType = 1;
Command.CommandText = "UPDATE [" + Подключение.Таблица + "] SET GUID = '" + ИДСсылки2 + "' WHERE GUID = '" + ИДСсылки + "' AND FileName = '" + ИмяФайла + "'";
Попытка
Command.Execute();
Исключение
Сообщить(ОписаниеОшибки());
Возврат Ложь;
КонецПопытки;
Возврат Истина;
КонецФункции

Данная функция нужна для перепривязки файла с обного объекта 1С к другому. просто заменяет идентификаторы в базе.

 

Параметры:

Подключение - структура подключения, полученная из функции ПодключитьсяКБазеSQL;

ИмяФайла - имя файла в формате имя.расширение;

Ссылка - ссылка на объект 1С, от которого открепляется файл;

Ссылка2 - ссылка на объект 1С, к которому прикрепляется файл.

Функция возвращает Истина при успехе операции и ложь при ошибке перепривязки.

 

 Функция ПолучитьФайлИзБазыSQL(Подключение, Ссылка, ИмяФайла) Экспорт
Если Подключение = Неопределено Тогда
Предупреждение("Вначале необходимо подключиться к серверу SQL!");
Возврат Неопределено;
КонецЕсли;
Файл = Неопределено;
ИДСсылки = ЗначениеВСтрокуВнутр(Ссылка);
Stream = Новый COMОбъект("ADODB.Stream");
Stream.Type = 1;
Stream.Open();
RecordSet = Новый COMОбъект("ADODB.RecordSet");
RecordSet.CursorLocation = 3;
RecordSet.LockType = 2;
Запрос = "SELECT Data FROM [" + Подключение.Таблица + "] WHERE GUID = '" + ИДСсылки + "' AND FileName = '" + ИмяФайла + "'";
RecordSet.Open(Запрос, Подключение.Подключение);
RecordSet.MoveFirst();
Stream.Write(RecordSet.Fields("Data").Value);
фрис = КаталогВременныхФайлов() + ИмяФайла;
Stream.SaveToFile(фрис);
Stream.Close();
RecordSet.Close();
Файл = Новый ДвоичныеДанные(фрис);
УдалитьФайлы(фрис);
Возврат Файл;
КонецФункции

Функция получает файл из БД и возвращает объект 1С типа Файл.

 

Параметры:

Подключение - структура подключения, полученная из функции ПодключитьсяКБазеSQL;

Ссылка - ссылка на объект 1С, к которому привязан файл;

ИмяФайла - имя файла в формате имя.расширение.

 

Функция ПолучитьСписокФайловИзБазыSQL(Подключение, Ссылка) Экспорт
Табл = Новый ТаблицаЗначений;
Табл.Колонки.Добавить("Наименование", , , 256);
Если Подключение = Неопределено Тогда
Предупреждение("Вначале необходимо подключиться к серверу SQL!");
Возврат Табл;
КонецЕсли;
Файл = Неопределено;
ИДСсылки = ЗначениеВСтрокуВнутр(Ссылка);
Command = Новый COMОбъект("ADODB.Command");
Command.ActiveConnection = Подключение.Подключение;
Command.CommandType = 1;
Command.CommandText = "SELECT FileName FROM [" + Подключение.Таблица + "] WHERE GUID = '" + ИДСсылки + "'";
RecordSet = Новый COMОбъект("ADODB.RecordSet");
Попытка
RecordSet = Command.Execute();
Исключение

Сообщить(ОписаниеОшибки());
Возврат
Табл;
КонецПопытки;
Пока RecordSet.EOF() = 0 Цикл
Строка = Табл.Добавить();
Строка.Наименование = СокрЛП(Строка(RecordSet.Fields(0).Value));
RecordSet.MoveNext();
КонецЦикла;
RecordSet.Close();
Возврат Табл;
КонецФункции

Функция получает список файлов для объекта по ссылке и возвращает таблицу с колонкой "Наименование", где хранятся имена файлов для объекта.

 

Параметры:

Подключение - структура подключения, полученная из функции ПодключитьсяКБазеSQL;

Ссылка - ссылка на объект 1С.

Возвращает таблицу значений. В случае ошибки возвращает пустую таблицу.

 

Функция УдалитьФайлИзБазыSQL(Подключение, Ссылка, ИмяФайла) Экспорт
Если Подключение = Неопределено Тогда
Предупреждение("Вначале необходимо подключиться к серверу SQL!");
Возврат Ложь;
КонецЕсли;
Файл = Неопределено;
ИДСсылки = ЗначениеВСтрокуВнутр(Ссылка);
Command = Новый COMОбъект("ADODB.Command");
Command.ActiveConnection = Подключение.Подключение;
Command.CommandType = 1;
Command.CommandText = "DELETE FROM [" + Подключение.Таблица + "] WHERE GUID = '" + ИДСсылки + "' AND FileName = '" + ИмяФайла + "'";
Попытка
Command.Execute();
Исключение
Сообщить(ОписаниеОшибки());
Возврат Ложь;
КонецПопытки;
Возврат Истина;
КонецФункции

Функция удаляет из БД файл. Возвращает истину при успехе и ложь при неудаче.

Параметры:

Подключение - структура подключения, полученная из функции ПодключитьсяКБазеSQL;

Ссылка - ссылка на объект 1С, к которому привязан файл;

ИмяФайла - имя файла в формате имя.расширение.

 

Функция РазобратьСтроку используется для быстрого получения имени файла из строки с полным именем файла, включающим путь.

 

Функция РазобратьСтроку(_Строка, _Разделитель, _УдалятьПустые = Истина) Экспорт
Результат = Новый СписокЗначений;
= СтрЗаменить(_Строка, _Разделитель, Символы.ПС);
Для Строк = 1 по СтрЧислоСтрок() Цикл
Если СтрДлина(СтрПолучитьСтроку(, Строк)) > 0 ИЛИ не _УдалятьПустые Тогда
Результат.Добавить(СтрПолучитьСтроку(, Строк));
КонецЕсли;
КонецЦикла;

Возврат
Результат;
КонецФункции

 

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. MadDAD 142 26.10.10 04:30 Сейчас в теме
Решал подобную задачу с помощью 1С++ объекта BinaryData. Было реализовано хранилище обработок с раздачей прав в зависимости от должности и подразделения.
5. iov 407 26.10.10 15:29 Сейчас в теме
7. MadDAD 142 28.10.10 09:56 Сейчас в теме
(5) Да, хранение во внешней базе SQL. + история версий с возможностью перехода на предыдущие версии.
8. iov 407 28.10.10 12:54 Сейчас в теме
(7) коммерческий продукт? ...
Я это к чему вопрос просто больно интересный с тех пор как увидел систему которая сразу с 3 мя внешними базами очень хотелось бы посмотреть. Есть возможность поделится своим примером?
P.S. интересуют способы которыми решаются задачи
10. MadDAD 142 29.10.10 03:06 Сейчас в теме
(8) Продукт некоммерческий, сложность в отвязывании от существующей системы. Соберусь на днях - выложу в разработках автономный вариант.
11. MadDAD 142 29.10.10 05:55 Сейчас в теме
15. selesta 17 19.06.12 14:02 Сейчас в теме
(1) MadDAD, +1, переделал Фабрику событий + Хранение сканов документов в СКЛ базе с 1с++ - все отлично
3. СергейКа 684 26.10.10 13:10 Сейчас в теме
Интересно, логотип Linux в заголовке, а речь о MSSQL...
4. Ivon 640 26.10.10 13:38 Сейчас в теме
(3). Просто прикольный рисунок. Ведь статья о хранении рисунков...
6. Silenser 522 27.10.10 16:31 Сейчас в теме
Реализовывал некоторое время назад подобный проект. До сих пор используем и не жалуемся.
http://infostart.ru/public/74821/
ПС: Насколько я помню, то T-SQL с курсорами работает не очень шустро, так что быстрее не отбирать и изменять, а удалять и записывать новую запись. Хотя могу и ошибаться.
9. DeepDiver 5 28.10.10 13:58 Сейчас в теме
12. BRT 33 29.10.10 09:23 Сейчас в теме
Хотелось бы уточнить. Хранение только графических файлов или и любых.
13. Ivon 640 29.10.10 09:58 Сейчас в теме
(12). Вообще-то любых до 2 гиг (вроде бы ограничение varbinary).
14. bytecoded 26 01.12.11 13:31 Сейчас в теме
Спасибо!

Я бы добавил проверку на количество записей в наборе — если он пуст, MoveFirst() приведёт к ошибке.
	RecordSet.Open(Запрос, Подключение.Подключение);
	RecordSet.MoveFirst();

Например, через метод RecordCount():
		Если RecordSet.RecordCount = 0 Тогда
			Возврат Неопределено;
		КонецЕсли;


Он, правда, работает не для всех типов курсора, но в данном случае вполне годится.
16. KroVladS 07.08.12 12:03 Сейчас в теме
Пытаюсь адаптировать для PostgreSQL.
В табличке столбцу "Data" присвоил тип bytea.

при попытке обратиться через Recordset к полю "Data" вываливаеться с ошибкой
Произошла исключительная ситуация (Provider): Недостаточно памяти для завершения операции.

Куда копать подскажите?
Оставьте свое сообщение

См. также

3 онлайн-курса по 1С-программированию: обмен данными, расчетные задачи и бухгалтерские задачи с 12 мая по 8 июля 2020 г. Промо

Практика программирования v8 Бесплатно (free)

Пакет из 3-х курсов по 1С-программированию. Основная цель - сформировать у слушателей практические навыки, связанные с реализацией задач обмена для прикладных решений, работающих на платформе “1С:Предприятие”, а также с разработкой прикладных решений, предназначенных для автоматизации расчета заработной платы и задач бухгалтерского учета.

22.04.2020    4492    23    Infostart    2    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    18816    0    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    18290    0    John_d    22    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    28031    0    Yashazz    45    

Как я начал администрировать сервер 1С: Предприятие 8.3 с телефона Промо

Администрирование данных 1С Мобильная разработка v8 Бесплатно (free)

Развитие инструментов управления кластером серверов 1С:Предприятие 8.3.

14.04.2017    58992    0    user700211_a.straltsou    27    

Как настроить сервер 1С по умолчанию для ПРОФ лицензии после 10.09.2019

Администрирование данных 1С v8 Бесплатно (free)

Здесь мы собираем все данные по настройкам сервера для работы ПРОФ лицензии.

11.09.2019    64606    0    Infostart    90    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    39295    0    rpgshnik    62    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    41436    0    ids79    54    

Копирование числовых ячеек из 1С в Excel Промо

Загрузка и выгрузка в Excel Администрирование данных 1С v8 1cv8.cf Бесплатно (free)

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    21501    0    itriot11    23    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    64526    0    ids79    40    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    48401    0    ids79    11    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    31275    0    ids79    27    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    35409    0    unichkin    45    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    17616    0    SeiOkami    50    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    45712    0    ids79    20    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    22753    0    dmurk    144    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    27804    0    tormozit    100    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    38229    0    YPermitin    30    

Выгрузка документа по условию

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    15327    0    m-rv    2    

Как прикрутить ГУИД к регистру сведений

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    19092    0    m-rv    17    

Отчет по размерам таблиц в базе данных как одно из средств анализа проблем Промо

Статистика базы данных v8 1cv8.cf Бесплатно (free)

Зачастую, когда пользователи обращаются с жалобами на производительность, бывает полезно посмотреть на отчет по размерам таблиц базы данных. Он может отчетливо показать ряд распространенных проблем, устранение которых даст существенный эффект. Приведенная информация вряд ли покажется чем-то новым для опытных специалистов.

21.07.2015    32781    0    Aleksey.Bochkov    15    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    31899    0    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    25188    0    ellavs    88    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    34405    0    ids79    9    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    75337    0    tormozit    129    

Малоизвестная хитрость определения модуля и номера строки при возникновении исключения (без запуска отладки и конфигуратора). Несколько очень удобных, но малоиспользуемых возможностей работы в конфигураторе

Тестирование и исправление v8 Россия Бесплатно (free)

В статье описана возможность получить место возникновения исключения при работе пользователей без участия конфигуратора. Подробно описаны еще некоторые очень полезные приемы при работе в отладке.

17.01.2019    26155    0    PoZiTiFFF    53    

Сервер 1С:Предприятие на Ubuntu 16.04 и PostgreSQL 9.6, для тех, кто хочет узнать его вкус. Рецепт от Капитана

Администрирование данных 1С v8 Бесплатно (free)

Если кратко описать мое отношение к Postgres: Использовал до того, как это стало мейнстримом. Конкретнее: Собирал на нем сервера для компаний среднего размера (до 50 активных пользователей 1С). На настоящий момент их набирается уже больше, чем пальцев рук пары человек (нормальных, а не фрезеровщиков). Следуя этой статье вы сможете себе собрать такой же и начать спокойную легальную жизнь, максимально легко сделать первый шаг в мир Linux и Postgres. А я побороться за 1. Лучший бизнес-кейс (лучший опыт автоматизации предприятия на базе PostgreSQL). Если, конечно, статья придется вам по вкусу.

25.12.2018    35726    2    capitan    147    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    46222    0    tormozit    38    

Чем PostgreSQL может быть полезен разработчику 1С

Администрирование данных 1С v8 1cv8.cf Бесплатно (free)

В статье будут рассмотрены примеры, которые могут оказаться полезными в повседневной работе разработчика 1С и не только: как можно сделать снимок рабочей базы без файла резервной копии, как можно эффективно использовать табличные пространства СУБД PostgreSQL, а также как организовать простой и удобный доступ к админке СУБД посредством мобильных устройств.

20.12.2018    22039    0    Shmell    38    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    37702    0    ids79    72    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    32294    0    ids79    40    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    42190    0    tormozit    74    

Произвольный код в фоновом режиме

Практика программирования v8 1cv8.cf Бесплатно (free)

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    25595    0    nikita0832    42    

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C

Математика и алгоритмы Практика программирования v8 Россия Бесплатно (free)

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    36340    0    Rain88    46    

Тестер: частые вопросы

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    27418    0    grumagargler    26    

Повышаем эффективность разработки правил обмена

Практика программирования Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    27234    0    olegtymko    47    

Как сделать запрос на изменение данных

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    28737    0    m-rv    21    

Строим графы средствами 1С (без GraphViz)

Практика программирования v8 Бесплатно (free)

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    23449    0    slozhenikin_com    20    

Распределение расходов пропорционально продажам

Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Практика программирования Финансовый учет и бюджетирование (FRP) Учет доходов и расходов v8 v8::ОУ УТ10 УУ Бесплатно (free)

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    17608    0    Rustig    9    

Несколько версий сервера 1С на одном компьютере

Администрирование данных 1С v8 Бесплатно (free)

Как установить несколько экземляров сервера 1С на один компьютер. Как установить несколько служб агента 1С на один сервер? Как запустить сервера разных платформ на одном компьютере.

18.04.2018    76645    0    spezc    85    

О лицензиях 1С

Администрирование данных 1С v8 Россия Бесплатно (free)

Разбираем вопросы по получению и переполучению лицензии 1С.

30.03.2018    118553    0    D_e_X_T_e_R    166    

[ВсеПросто] "Оперативный" информатор из 1С за 5 мин.

Практика программирования v8 Бесплатно (free)

Быть всегда в курсе дел, даже в дороге!

22.02.2018    25859    0    DarkAn    25    

Минимализмы 3

Практика программирования Универсальные функции v8 Бесплатно (free)

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    44834    0    ildarovich    45    

Этюды по программированию. Взаимодействие с Microsoft Word

Практика программирования v8 Бесплатно (free)

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    31615    0    milkers    23    

Метод формирования движений в типовых регистрах нетиповыми регистраторами

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    26756    0    itriot11    34