IE 2018

Форма ТОРГ-2 для УТ 10.3

Печать - Печатные формы документов

ТОРГ-2 обработка внешняя печатная форма управление торговлей 10.3 обычные формы

0
Унифицированная форма № ТОРГ- 2 для УТ 10.3 (внешняя печатная форма, обычное приложение).

Унифицированная форма № ТОРГ- 2. Утверждена постановлением Госкомстата России от 25.12.98 г. № 132.

В виде подключаемой внешней печатной формы. Для обычных форм!

Авторегистрация для документа: Поступление товаров и услуг.

Тестировалось на платформе: 1С:Предприятие 8.3 (8.3.11.2899)

Тестировалось на базе Управление Торговлей 10.3, версии: 10.3.29.1

 

При вызове печатной формы из документа "Поступление товаров и услуг":

  • Откроется окно выбора товаров. В этом окне можно галочками выбрать товары, которые нужно отразить в документе. Тут же, сразу можно указать фактическое количество. 
  • После закрытия формы выбора товаров, откроется основная форма ввода данных.
    • Зелеными цветами выделены рекомендуемые поля или группы полей.
    • Синими цветами выделены поля, которые ожидали заполнения по данным документа. Например, представление организации или грузополучателя.
    • Желтые поля - изменяются при изменении ключевого поля. Например, указание Даты акта автоматически проставит эту же дату в поля Дата комиссии и Дата подписания.
  • Практически все поля примитивного типа - текст, число или дата. Т.е. вы можете вписать любое свое значение и оно будет подставлено в печатную форму. Некоторые поля имеют кнопку выбора (для ускорения ввода) - они наполняются предопределенными значениями из модуля формы. Например - тип сопроводительного документа: можно выбрать ТОРГ-12 и УПД. 

Для автоматического заполнения некоторых полей используются следующие нюансы:

  • У контрагента и организации указаны контактные данные - юр. и физ. адрес, телефоны. Если не указаны - подставится только наименование.
  • Сокращение юр.лица производится в функции ПреобразоватьНаименованиеЮрФизЛица(Наименование). Для заполнение берется полное наименование, но тип юр.лица будет оставлен сокращенным. Например Общество с Ограниченной Ответственностью "Рога и копыта" будет представлен как ООО "Рога и копыта".
  • Код ОКПО - берется как реквизит Организации
  • Код по ОКДП - берется как значение доп.свойства с именем "ОКДП" для Организации. Если свойства такого нет - ничего не ставится.
  • Для заполнения Председателя комиссии берется ответственное лицо по складу (регистр Ответственных лиц) из документа поступления. Должность по умолчанию - "зав. складом". 
  • Если у документа указаны номер и дата входящего документа - они будут подставлены в значения СФ на странице 1. 
  • Расшифровки физ-лиц можно подбирать из справочника Физ.лиц
  • Расшифровки должностей можно подбирать из справочника Должностей организации.
  • Главный бухгалтер берется по текущей дате из регистра Ответственных лиц организации из документа.
  • Номенклатуру можно подбирать как из документа, так и из справочника. Можно удалить наименование и вписывать свои названия артикулов, когда они не совпадают с данными поставщика.
  • Расчет излишков и недостачи в строке товаров происходит автоматически при изменении плана и факта.
  • Цена товара изначально берется из документа поступления. При выводе на печать - берется та цена, которая была указана на форме. При расчете сумм ПТВ, Боя, недостачи и излишков - соотв. количество умножается на эту цену.
  • Штук в коробке - это допущение, что в карточке товара для реквизита "Единица для отчетов" установлена единица по типу "коробка" и выводится ее коэффициент. Во всяком случае, так заведено у нас. Поле чисто информативное, для формирования печ. формы не нужно.
  • Все поля товаров на форме можно редактировать, кроме "Штук в коробке".

При нажатии кнопки "Готово" будет сформирована печатная форма, а форма заполнения закроется. Введенные данные не сохраняются, поэтому при повторном открытии их нужно будет вводить заново. 

Чтобы проверить вывод на печать без закрытия обработки - есть кнопка Предварительный просмотр.

 

Примечание: По поводу ОКДП.

Заполняется функцией в модуле обработки 

Функция ПолучитьОКДПОрганизации(Организация)
	// В УТ 10.3 нет реквизита ОКДП.
	// Предположим, что есть свойство ОКДП для справочника Организации в виде строки
	// Его и возьмем
	// ВАЖНО: ОКДП не то же самое, что ОКВЭД. Не подставляйте сюда ОКВЭД
	// Если не можете найти ОКДП - ничего не ставьте. Это не обязательное требование.
	ЗначениеВозврата = "";
	Свойство = ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("ОКДП");
	Если ЗначениеЗаполнено(Свойство) Тогда
		Запрос = Новый Запрос;
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	ЗначенияСвойствОбъектов.Значение
		|ИЗ
		|	РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
		|ГДЕ
		|	ЗначенияСвойствОбъектов.Объект = &Объект
		|	И ЗначенияСвойствОбъектов.Свойство = &Свойство";
		Запрос.УстановитьПараметр("Объект", Организация);
		Запрос.УстановитьПараметр("Свойство", Свойство);
		Результат = Запрос.Выполнить();
		Если Не Результат.Пустой() Тогда
			Выборка = Результат.Выбрать();
			Выборка.Следующий();
			ЗначениеВозврата = СокрЛП(Выборка.Значение);
		КонецЕсли;
	КонецЕсли;
		
	Возврат ЗначениеВозврата;
КонецФункции

 

0

Скачать файлы

Наименование Файл Версия Размер
Форма ТОРГ-2 для УТ 10.3:
.epf 56,51Kb
09.04.18
10
.epf 1.0 56,51Kb 10 Скачать

См. также

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение