Работа с файлами в управляемых формах клиент серверной версии 8.3 и выше

Публикация № 892130

Администрирование - Администрирование данных 1С - Обработка справочников

При попытке работать с файлами по аналогии с толстым клиентом наткнулся на грабли. В 8.3 изменили подход к работе с файлами. Постараюсь кратко его описать.

Для работы с файлами требуется понимание работы платформы и некоторых новшеств.

При необходимости сохранять файлы на сервере, у пользователя, под которыми запущена служба сервера 1С, должен быть доступ на соответствующие каталоги.

Файлы будем хранить в конфигурации в клиент серверной версии 8.3.
Для хранения файлов будем использовать реквизит с типом "ХранилищеЗначения".
Особенностью данного реквизита является его недоступность на клиенте, поэтому работу с ним необходимо проводить только на сервере.

Концепция загрузки с клиента на сервер следующая:
1. Загружаем файлы от клиента на сервер помещая их во временное хранилище
2. На клиенте сохраняем адрес
3. При записи объекта на сервере сохраняем файл в базу данных

Пройдем более детально:
Загрузка файла происходит во временное хранилище на сервере и не передается с контекстом на клиент.
Для передачи адреса файла создадим отдельную переменную формы типа строка, назовем ее "АдресЗагруженногоФайла".

Перед загрузкой нужно получить от пользователя разрешение на работу с его файловой системой.

Если НЕ ПодключитьРасширениеРаботыСФайлами() Тогда
    УстановитьРасширениеРаботыСФайлами();
КонецЕсли;

Для загрузки с клиента на сервер файла используем типовой метод "НачатьПомещениеФайла".
При работе с ним нужно учесть один момент - файл загружается во временное хранилище на сервер и на клиент передается адрес этого хранилища.
Этот адрес необходимо сохранить чтобы файл можно было найти на сервере.
Для этого используем переменную формы "АдресЗагруженногоФайла".

&НаКлиенте
Процедура Загрузить(Команда)

    Если НЕ ПодключитьРасширениеРаботыСФайлами() Тогда
        УстановитьРасширениеРаботыСФайлами();
    КонецЕсли;

    Адрес = "";
    НачальноеИмяФайла = "";
    ОписаниеОповещения = Новый ОписаниеОповещения("ЗагрузитьЗавершение", ЭтаФорма);
    НачатьПомещениеФайла(ОписаниеОповещения, Адрес, НачальноеИмяФайла, Истина, УникальныйИдентификатор);
	
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьЗавершение(Результат, Адрес, ВыбранныйФайл, ДополнительныеПараметры) Экспорт
	
    Если НЕ Результат Тогда
        Возврат;
    КонецЕсли;

    Файл = Новый Файл(ВыбранныйФайл);
    Объект.Имяфайла = Файл.ИмяБезРасширения;
    Объект.РасшриениеФайла = Файл.Расширение;
    Объект.Наименование = Файл.ИмяБезРасширения;
    // для записи в реквизит с типом хранилище значения
    АдресЗагруженногоФайла = Адрес;
			
КонецПроцедуры

У нас есть адрес файла на сервере но нет доступа к реквизиту с типом "ХранилищеЗначений" на клиенте.
Для записи в этот реквизит перед записью на сервере получим файл из временного хранилище и положим в реквизит.

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
	
    Если ЭтоАдресВременногоХранилища(АдресЗагруженногоФайла) Тогда
		
         ЗагруженныйФайл = ПолучитьИзВременногоХранилища(АдресЗагруженногоФайла);
         ЭлементХранилища = Новый ХранилищеЗначения(ЗагруженныйФайл);
         ТекущийОбъект.Файл = ЭлементХранилища;
		
    КонецЕсли;
	
КонецПроцедуры

Загрузка файла в базу данных готова.

Концепция выгрузки с сервера на клиента следующая:
1. Файл достаем с реквизита и ложим во временное хранилище
2. Передаем с сервера на клиент адрес
3. Сохраняем файл на клиенте

Для работы с файлами на клиенте нужно получить от пользователя разрешение на работу с его файловой системой.

Если НЕ ПодключитьРасширениеРаботыСФайлами() Тогда
    УстановитьРасширениеРаботыСФайлами();
КонецЕсли;

На сервере готовим метод который вытащит файл из реквизита и положит во временное хранилще

&НаСервере
Функция ПоместитьШаблонВоВременноеХранилище()
	
    Реквизит = РеквизитФормыВЗначение("Объект");
    ДвоичныйФайл = Реквизит.Файл.Получить();
    Адрес = ПоместитьВоВременноеХранилище(ДвоичныйФайл, УникальныйИдентификатор);
	
    возврат Адрес;
	
КонецФункции

Используем типовой метод "НачатьПолучениеФайлов" для передачи файла с сервера на клиента.
В него необходимо передать массив получаемых файлов.
В этом массиве необходимо указать адреса нахождения файлов на сервере или адреса временных хранилищ файлов.
Во время работы файлы будут загружены по этим адресам и положены в массиве "ПолученныеФайлы" во временные хранилища.
На клиенте из этих хранилищ достаем файлы и сохраняем.

&НаКлиенте
Процедура Выгрузить(Команда)
	
    Если НЕ ПодключитьРасширениеРаботыСФайлами() Тогда
        УстановитьРасширениеРаботыСФайлами();
    КонецЕсли;
	
    ВременнойФайл = ПолучитьИмяВременногоФайла();
    Адрес = ПоместитьШаблонВоВременноеХранилище();

    ИмяСРасширением = Объект.ИмяФайла + Объект.РасшриениеФайла;
	
    ОписаниеОповещения = Новый ОписаниеОповещения("ВыгрузитьЗавершение", ЭтаФорма);
    ПолучаемыеФайлы = Новый Массив;
    ОписаниеПередаваемогоФайла = Новый ОписаниеПередаваемогоФайла(ИмяСРасширением, Адрес);
    ПолучаемыеФайлы.Добавить(ОписаниеПередаваемогоФайла);
	
    ДиалогВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
    ДиалогВыбораФайла.МножественныйВыбор = Ложь;
	
    НачатьПолучениеФайлов(ОписаниеОповещения, ПолучаемыеФайлы, ДиалогВыбораФайла, Истина);
	
КонецПроцедуры

&НаКлиенте
Процедура ВыгрузитьЗавершение(ПолученныеФайлы, ДополнительныеПараметры) Экспорт
	
    Если ПолученныеФайлы = Неопределено Тогда
        Возврат;
    КонецЕсли;

    Для Каждого Файл из ПолученныеФайлы Цикл
	    СохраняемыйФайл = ПолучитьИзВременногоХранилища(Файл.Хранение);
        СохраняемыйФайл.Записать(Файл.Имя);
        ОбщегоНазначенияКлиент.ВывестиСообщение("Сохранен файл " + Файл.Имя);
    КонецЦикла;
			
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Работа с файлами в тонком клиенте в клиент серверной версии 8.3 и выше:

.cf 16,50Kb
23.08.18
15
.cf 16,50Kb 15 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Dream_kz 110 24.08.18 11:00 Сейчас в теме
Ну есть же поиск, ну зачем очередной клон того, что уже есть?
5. СергейКа 684 25.08.18 08:32 Сейчас в теме
(1) Пфф... Зачем нам поиск? Написать свое же всегда круче? Тем более что составить правильно поисковый запрос а потом просмотреть результаты - это дольше чем набрость на коленке.
(0) Пиши исчо! Столько тем неразобранных в синтаксис-помощнике осталось!
2. pashamak 175 24.08.18 12:26 Сейчас в теме
Есть, только перегруженные или не совсем понятно описанные.
3. kirillkr 28 24.08.18 19:36 Сейчас в теме
Это все красиво для тонкого клиента с разрешенными синхронными вызовами, но абсолютно не работает в асинхронной работе тонкого или веб-клиента
7. pashamak 175 20.08.20 07:29 Сейчас в теме
В веб клиенте не проверял, но предполагаю что будет работать или потребуются небольшие доработки по замене методов на более подходящие. В чем видите проблему при асинхронной работе?
4. Xershi 1033 24.08.18 20:40 Сейчас в теме
Надо наверное свою статью выложить с блекджеком и ш......, т.е. с полной асинхронностью, для вебклиента и универсально для любого реквизита, если именовать так как элемент формы=))
acanta; BigB; +2 Ответить
6. Xershi 1033 09.06.19 18:39 Сейчас в теме
(4) Наконец написал свою публикацию с блекджеком и ш...... Работа с файлами (обычная и управляемая форма) все структурировано и методы все актуализированы!
8. pashamak 175 20.08.20 07:43 Сейчас в теме
(6)
Хорошая статья, побольше бы подобных.
Есть пожелания дополнить статью.
1. Нет особенностей работы с реквизитами типа ХранилищеЗначений, которые надо понимать если пишешь код сам.
2. Нет общей концепции работы (в основном код, без описания проблемных моментов), что затрудняет понимание написания подобного кода самому.
3. Статья больше напоминает справочник кода вместо описания и обучения новым механизмам.
9. Xershi 1033 20.08.20 10:13 Сейчас в теме
(8) это не статья, а публикация. Она содержит обработки, которые вы можете скачать и протестировать работу, чтобы вам стало все понятно. А код приведен для тех, кто уже делал подобное, но нужно искать где он это сделал, а так скопировал и вперед.
Потратить кучу времени, чтобы написать по новой спагетти это еще тот мазахизм.
Работа с ХранилищеЗначений это отдельная тема и к файлам в том понимании, в каком сделана публикация, отношения не имеет.
Оставьте свое сообщение

См. также

Правильные аналоги номенклатуры (кроссы запчастей) для 1С / Управляемые формы Промо

Обработка справочников Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::УФ 1cv8.cf УУ Абонемент ($m)

По опыту работы с запчастями много раз сталкивался с проблемой организации кроссов в разных 1С - от записи артикулов через запятую в текстовом поле до хранения кроссов в документах. Предлагаю одну из простейших и функциональных на мой взгляд схем "одноуровневого" хранения кроссов.

5 стартмани

29.07.2015    34698    8    taurus__    22    

Интерактивная справка по объектам 1С (автономное расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Ведётся интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    5867    28    sapervodichka    33    

[Взрыв шаблона!] Новый способ программной настройки условного оформления

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Условное оформление форм и списков это великолепная возможность их настройки по заданным условиям. Но существенным недостатком является трудоемкость написания и сопровождения программного кода. В публикации предлагается новый способ программной настройки условного оформления.

1 стартмани

01.12.2019    11500    39    mszsuz    12    

Альтернативный способ добавления элементов и реквизитов на формы

Работа с интерфейсом v8 ERP2 УТ11 Россия Абонемент ($m)

Предлагаю альтернативный вариант добавления динамически создаваемых элементов и реквизитов на форму.

1 стартмани

09.09.2019    11500    18    bmk74    4    

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) Промо

Обработка документов Обработка справочников Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    63348    360    Tatitutu    48    

[Механизм интерфейса] Свой флажок (чекбокс)

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Создадим свой флажок для интерфейса, используем простой универсальный алгоритм.

1 стартмани

09.08.2019    15868    18    rpgshnik    43    

Открывашка ячеек таблиц

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Глобальное сочетание клавиш для открытия объекта по ссылке из текущей ячейки любой таблицы в большинстве управляемых форм

1 стартмани

27.10.2018    17060    12    tormozit    31    

Универсальный инструмент для переноса данных через табличный документ (УФ)

Обработка документов Универсальные обработки Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Для опытных пользователей, разработчиков, администраторов, консультантов

5 стартмани

15.10.2018    33931    123    json    42    

Менеджер открытых форм Промо

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Обработка получает информацию об открытых формах и позволяет ими манипулировать.

1 стартмани

13.04.2017    21494    37    SeiOkami    19    

Визуализация событий на временной шкале средствами "Поле HTML документа"

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Интересный способ наглядно отобразить события на временной шкале. Например, может быть применен для красивого вывода документов по клиенту. Тестировалось на платформе 8.3.12.1469

1 стартмани

31.07.2018    23802    139    Plotks2017    27    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    47480    17    kalyaka    16    

Автоматическое заполнение графиков в ЗУП 3.1

Зарплата Учет рабочего времени Обработка справочников Зарплата Учет рабочего времени v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    24135    18    notserioussam    2    

Расширенная настройка динамического списка УФ Промо

Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Открывая управляемую форму выбора и не увидев там видимых в форме списка элементов, часто хочется узнать причину их отсутствия там, т. е. какой наложен отбор. Но стандартная настройка списка управляемой формы показывает только пользовательские настройки, скрывая от пользователя фиксированный отбор. Предлагаю вам расширение конфигурации с расширенной настройкой динамического списка, отображающей пользователю кроме пользовательских настроек еще фиксированные.

1 стартмани

31.05.2017    32582    150    tormozit    25    

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    30326    71    charivnick    3    

Тестирование интерфейса в обычном приложении 8.2 при помощи SikuliX

Инструментарий разработчика Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Как же не хватает клиента тестирования на платформе 8.2. Не кликнешь на кнопку, не выберешь из списка, не проверишь видит ли надпись пользователь. Воспользуемся внешним инструментом SikuliX, который позволит нам протестировать функционал форм. Данный инструмент легко встраивается в линию сборки и может "дружить" с уже известным многим Open-source продуктами.

1 стартмани

03.01.2018    29593    5    kraynev-navi    41    

Изменение реквизитов справочников, документов, табличных частей, движений (Обычные и Управляемые формы) Промо

Обработка документов Обработка справочников v8 v8::УФ 1cv8.cf Казахстан Абонемент ($m)

Обработка позволяет редактировать реквизиты справочника, документа, его табличные части и движения.

1 стартмани

15.10.2012    47589    280    Exit_in    42    

Программное формирование форматированной строки в стиле html+inline CSS

Работа с интерфейсом Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Если вам приходилось работать с форматированными строками программно, то вы знаете, какая это боль. Данное решение облегчает программное формирование таких строк.

1 стартмани

18.11.2017    32154    35    bonv    10    

Загрузка дополнительных реквизитов и сведений справочника Номенклатура из Excel и таблиц УТ 11, ERP 2

Обработка справочников Загрузка и выгрузка в Excel Учет ТМЦ Учет ТМЦ v8 v8::ОУ ERP2 УТ11 Россия УУ Абонемент ($m)

Внешняя обработка "Загрузка дополнительных реквизитов и сведений справочника Номенклатура"

1 стартмани

07.08.2017    41147    256    Windyhead    41    

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2

Обработка справочников Оптовая торговля Розничная торговля Ценообразование, анализ цен Ценообразование, прайсы Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    59062    121    myALKleon    40    

Лучший подарок для бухгалтера - счёты 8.2 (со звуком) Промо

Работа с интерфейсом v8 1cv8.cf Россия Абонемент ($m)

(Толстый клиент) Подарите бухгалтеру счеты, и он(а) Вас никогда не забудет.

1 стартмани

13.05.2011    40394    24    Tatitutu    45    

Определение ИНН Сотрудника (service.nalog.ru). ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Внешняя печатная форма для справочника "Сотрудники организаций". ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

1 стартмани

03.02.2017    72642    49    Indgo    33    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    21074    95    igel9780    22    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    26778    135    Stepa86    15    

Отключение доступа уволенным пользователям Промо

Информационная безопасность Обработка справочников Администрирование данных 1С v8 v8::Права БП2.0 УПП1 Абонемент ($m)

Давно хотели навести порядок в пользователях? Надоело, что в списке мешаются давно уволенные сотрудники? Тогда эта обработка для Вас!

3 стартмани

15.10.2013    50160    51    VBod    17    

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации

Управление бизнес-процессами (BPM) Обработка документов Обработка справочников Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf БП3.0 КА2 УУ Абонемент ($m)

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    55105    268    BlizD    210    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    49916    50    yuraos    17    

Автозаполнение реквизитов контрагентов по ИНН для БП3.0, ERP2.4, УТ11.4, КА2.4, Розница 2.2, Документооборот 2.1

Обработка справочников v8 КА1 ERP2 БП3.0 УТ11 Абонемент ($m)

Расширение для конфигурации 1С: БП 3.0, ERP 2.4, УТ 11.4, КА 2.4, Розница 2.3, Документооборот 2.1

3 стартмани

22.01.2016    58980    650    oslokot    347    

1С:Интеграция ЕГАИС + Инвентаризация на ТСД

Обработка справочников Обмен через XML Оптовая торговля Оптовая торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Интеграция ЕГАИС модуля для 1С: 8.3 + модуль WMS контура для инвентаризации алкогольных марок на ТСД.

1 стартмани

10.12.2015    36953    27    JetBrain    5    

Передача реквизитов объекта из основной формы в дополнительную и обратно на управляемых формах

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Наверное, многие сталкивались с ситуацией, когда у некоего редактируемого объекта (справочник, документ, внешняя обработка) кроме основной формы нужно сделать парочку дополнительных, чтобы часть реквизитов заполнять в них, а потом возвращать заполненные значения в основную форму и в сам объект. И если бы речь шла об обычных формах, то проблемы бы и не было. Но в управляемых формах с этим возникает проблема, а в случае отказа от модальности она становится немного больше.

1 стартмани

02.11.2015    33842    12    Wolex    29    

Загрузка изображений с поисковых сайтов сети Интернет в 1С

Обработка справочников WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 v8::ОУ v8::УФ УТ10 УТ11 Абонемент ($m)

Обработка загрузки изображений из интернета в 1С:Предприятие. Платформа 1С:Предприятие версий 8.2 и 8.3.

8 стартмани

13.10.2015    42087    163    premierex    145    

Автоматическая загрузка классификатора адресов КЛАДР

Обработка справочников WEB v8 УТ10 Россия Абонемент ($m)

Обработка автоматически загружает классификатор с сайта www.gnivc.ru, распаковывает и загружает все регионы в информационную базу.

1 стартмани

02.09.2015    25272    39    kolos    1    

Подсистема автоматического удаления дублей в справочниках (управляемые формы, любая конфигурация)

Чистка базы Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Подсистема позволяет проводить автоматическое удаление дублей справочников в соответствии с заданными настройками. Возможно встраивание в любую конфигурацию на управляемых формах. Позволяет задать настройки справочников, в которых ищутся дубли и также поля поиска совпадений. Есть регламентное задание для запуска проверки с заданным периодом. Если в базе найдены ссылки на тот элемент, который будет удален, то они заменяются на тот элемент, который остается. Дублем считается элемент справочника, у которого больше значение кода.

1 стартмани

31.07.2015    37053    86    primat    11    

NativeDraw: Компонента рисования для 1С [V2.6.2]

Разработка внешних компонент Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Рисуйте в формах 1С, также предлагается небольшое количество нерисовальных функций

1 стартмани

13.07.2015    47187    428    ПерваяСистема    147    

Кнопки управления группировками табличного документа для управляемых форм

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Универсальный механизм управления группировками табличного документа из управляемой формы

1 стартмани

02.06.2015    26530    23    unichkin    9    

Альтернативная визуализация данных для 1С 8.3.6

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Нужен приятный Bi Dashboard? Или просто красивый график/диаграмма для сайта? Тогда эта разработка для Вас!

1 стартмани

29.05.2015    31046    78    vano-ekt    3    

Изменение конфиденциальной информации (обработка, управляемые формы)

Обработка документов Обработка справочников Защита и шифрование v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет полностью заменить в базе все конфиденциальные данные - все поля справочников, суммы в документах и прочие значения объектов. Идентична по функционалу обработке с ИТС "Изменение конфиденциальной информации", но работает под управляемыми формами и в интерфейсе "Такси". Есть гибкая настройка тех данных, которые необходимо удалять.

1 стартмани

17.05.2015    33731    136    primat    24    

Подсистема проверки контрагентов через сервис ГосРеестра для объединения с любой конфигурацией (или автономной работы)

Универсальные обработки Обработка справочников v8 1cv8.cf Абонемент ($m)

Еще один вариант для проверки контрагентов через сервис ФНС. Механизм аналогичен проверке в типовой БП 3.0 и полностью автономен, можно объединить с любой конфигурацией. При первом запуске просит ввести логин и пароль для доступа к сайту поддержки 1С.

1 стартмани

06.04.2015    22601    20    Foxes82    12    

Загрузка товаров с Яндекс.Маркет

Обработка справочников WEB v8 УТ10 Абонемент ($m)

Обработка предназначена для загрузки товаров (их описаний, свойств, изображений) с торговой площадки Яндекс.Маркет в базу Управление Торговлей 11. В отличие от других подобных обработок Вам самим не придется парсить страницы Яндекс.Маркет и решать сопутствующие этому процессу проблемы (бан, капча, поиск прокси-серверов, длительное ожидание результатов при больших объемах данных), так как все данные уже загружены на наш сервер и готовы для использования. Обновление данных осуществляется раз в месяц. Таким образом, все что Вам нужно - подключиться раз в месяц к нашему сервису и получить обновленный ассортимент товаров.

1 стартмани

12.01.2015    37267    80    Sirruf    81    

Проверка контрагентов по ИНН и КПП через веб-сервис ФНС (внешняя)

Обработка справочников WEB v8 1cv8.cf Россия Абонемент ($m)

Обработка проверяет контрагентов по ИНН и КПП через веб-сервис ФНС на наличие регистрации в ЕГРН. Может выполняться в любых типовых конфигурациях, при наличии справочника "Контрагенты" и реквизитов "ИНН" и "КПП"

1 стартмани

25.12.2014    39951    130    Willforre    12    

Реестр договоров для 1С:Бухгалтерии

Обработка документов Обработка справочников Документооборот и делопроизводство Документооборот и делопроизводство v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Реестр договоров для 1С:Бухгалтерии - дополнительная обработка для конфигурации "Бухгалтерия предприятия", версия 3.0

5 стартмани

28.10.2014    45337    65    RespectSoft    24    

Загрузка курсов валют

Обработка справочников WEB v8 1cv8.cf Абонемент ($m)

Загрузка актуальных курсов валют с web - сервиса Сбербанка. На обычных и управляемых формах.

1 стартмани

15.10.2014    16773    18    miller-adm    3    

[ТАКСИ] Шаблон внешней обработки...и не только

Универсальные обработки Работа с интерфейсом Универсальные функции v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка предназначена для лентяев, к каковым, в первую очередь, отношу себя. Это в некотором роде шпаргалка в виде шаблона внешней обработки. Для создания новой копируем эту, удаляем ненужное, вставляем нужное - получаем результат. Чем ваять с нуля, каждый раз прописывая одно и то же, проще использовать заготовку, подобную этой... 30.10.2019 - Версия 1.24 - Изменена регистрация из обработки, и функция СведенияОВнешнейОбработке. Изменён пример чтрения XLS - теперь средствами 1С, без необходимости устанавливать офис ...ну и как водится - что-то добавил, что-то поправил....

2 стартмани

22.09.2014    53237    324    Alex_E    28