Работа с файлами в управляемых формах клиент серверной версии 8.3 и выше

Публикация № 892130

Администрирование - Администрирование данных 1С - Обработка справочников

6
При попытке работать с файлами по аналогии с толстым клиентом наткнулся на грабли. В 8.3 изменили подход к работе с файлами. Постараюсь кратко его описать.

Для работы с файлами требуется понимание работы платформы и некоторых новшеств.

При необходимости сохранять файлы на сервере, у пользователя, под которыми запущена служба сервера 1С, должен быть доступ на соответствующие каталоги.

Файлы будем хранить в конфигурации в клиент серверной версии 8.3.
Для хранения файлов будем использовать реквизит с типом "ХранилищеЗначения".
Особенностью данного реквизита является его недоступность на клиенте, поэтому работу с ним необходимо проводить только на сервере.

Концепция загрузки с клиента на сервер следующая:
1. Загружаем файлы от клиента на сервер помещая их во временное хранилище
2. На клиенте сохраняем адрес
3. При записи объекта на сервере сохраняем файл в базу данных

Пройдем более детально:
Загрузка файла происходит во временное хранилище на сервере и не передается с контекстом на клиент.
Для передачи адреса файла создадим отдельную переменную формы типа строка, назовем ее "АдресЗагруженногоФайла".

Перед загрузкой нужно получить от пользователя разрешение на работу с его файловой системой.

Если НЕ ПодключитьРасширениеРаботыСФайлами() Тогда
    УстановитьРасширениеРаботыСФайлами();
КонецЕсли;

Для загрузки с клиента на сервер файла используем типовой метод "НачатьПомещениеФайла".
При работе с ним нужно учесть один момент - файл загружается во временное хранилище на сервер и на клиент передается адрес этого хранилища.
Этот адрес необходимо сохранить чтобы файл можно было найти на сервере.
Для этого используем переменную формы "АдресЗагруженногоФайла".

&НаКлиенте
Процедура Загрузить(Команда)

    Если НЕ ПодключитьРасширениеРаботыСФайлами() Тогда
        УстановитьРасширениеРаботыСФайлами();
    КонецЕсли;

    Адрес = "";
    НачальноеИмяФайла = "";
    ОписаниеОповещения = Новый ОписаниеОповещения("ЗагрузитьЗавершение", ЭтаФорма);
    НачатьПомещениеФайла(ОписаниеОповещения, Адрес, НачальноеИмяФайла, Истина, УникальныйИдентификатор);
	
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьЗавершение(Результат, Адрес, ВыбранныйФайл, ДополнительныеПараметры) Экспорт
	
    Если НЕ Результат Тогда
        Возврат;
    КонецЕсли;

    Файл = Новый Файл(ВыбранныйФайл);
    Объект.Имяфайла = Файл.ИмяБезРасширения;
    Объект.РасшриениеФайла = Файл.Расширение;
    Объект.Наименование = Файл.ИмяБезРасширения;
    // для записи в реквизит с типом хранилище значения
    АдресЗагруженногоФайла = Адрес;
			
КонецПроцедуры

У нас есть адрес файла на сервере но нет доступа к реквизиту с типом "ХранилищеЗначений" на клиенте.
Для записи в этот реквизит перед записью на сервере получим файл из временного хранилище и положим в реквизит.

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
	
    Если ЭтоАдресВременногоХранилища(АдресЗагруженногоФайла) Тогда
		
         ЗагруженныйФайл = ПолучитьИзВременногоХранилища(АдресЗагруженногоФайла);
         ЭлементХранилища = Новый ХранилищеЗначения(ЗагруженныйФайл);
         ТекущийОбъект.Файл = ЭлементХранилища;
		
    КонецЕсли;
	
КонецПроцедуры

Загрузка файла в базу данных готова.

Концепция выгрузки с сервера на клиента следующая:
1. Файл достаем с реквизита и ложим во временное хранилище
2. Передаем с сервера на клиент адрес
3. Сохраняем файл на клиенте

Для работы с файлами на клиенте нужно получить от пользователя разрешение на работу с его файловой системой.

Если НЕ ПодключитьРасширениеРаботыСФайлами() Тогда
    УстановитьРасширениеРаботыСФайлами();
КонецЕсли;

На сервере готовим метод который вытащит файл из реквизита и положит во временное хранилще

&НаСервере
Функция ПоместитьШаблонВоВременноеХранилище()
	
    Реквизит = РеквизитФормыВЗначение("Объект");
    ДвоичныйФайл = Реквизит.Файл.Получить();
    Адрес = ПоместитьВоВременноеХранилище(ДвоичныйФайл, УникальныйИдентификатор);
	
    возврат Адрес;
	
КонецФункции

Используем типовой метод "НачатьПолучениеФайлов" для передачи файла с сервера на клиента.
В него необходимо передать массив получаемых файлов.
В этом массиве необходимо указать адреса нахождения файлов на сервере или адреса временных хранилищ файлов.
Во время работы файлы будут загружены по этим адресам и положены в массиве "ПолученныеФайлы" во временные хранилища.
На клиенте из этих хранилищ достаем файлы и сохраняем.

&НаКлиенте
Процедура Выгрузить(Команда)
	
    Если НЕ ПодключитьРасширениеРаботыСФайлами() Тогда
        УстановитьРасширениеРаботыСФайлами();
    КонецЕсли;
	
    ВременнойФайл = ПолучитьИмяВременногоФайла();
    Адрес = ПоместитьШаблонВоВременноеХранилище();

    ИмяСРасширением = Объект.ИмяФайла + Объект.РасшриениеФайла;
	
    ОписаниеОповещения = Новый ОписаниеОповещения("ВыгрузитьЗавершение", ЭтаФорма);
    ПолучаемыеФайлы = Новый Массив;
    ОписаниеПередаваемогоФайла = Новый ОписаниеПередаваемогоФайла(ИмяСРасширением, Адрес);
    ПолучаемыеФайлы.Добавить(ОписаниеПередаваемогоФайла);
	
    ДиалогВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
    ДиалогВыбораФайла.МножественныйВыбор = Ложь;
	
    НачатьПолучениеФайлов(ОписаниеОповещения, ПолучаемыеФайлы, ДиалогВыбораФайла, Истина);
	
КонецПроцедуры

&НаКлиенте
Процедура ВыгрузитьЗавершение(ПолученныеФайлы, ДополнительныеПараметры) Экспорт
	
    Если ПолученныеФайлы = Неопределено Тогда
        Возврат;
    КонецЕсли;

    Для Каждого Файл из ПолученныеФайлы Цикл
	    СохраняемыйФайл = ПолучитьИзВременногоХранилища(Файл.Хранение);
        СохраняемыйФайл.Записать(Файл.Имя);
        ОбщегоНазначенияКлиент.ВывестиСообщение("Сохранен файл " + Файл.Имя);
    КонецЦикла;
			
КонецПроцедуры

 

6

Скачать файлы

Наименование Файл Версия Размер
Работа с файлами в тонком клиенте в клиент серверной версии 8.3 и выше:
.cf 16,50Kb
23.08.18
4
.cf 16,50Kb 4 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Dream_kz 93 24.08.18 11:00 Сейчас в теме
Ну есть же поиск, ну зачем очередной клон того, что уже есть?
5. СергейКа 673 25.08.18 08:32 Сейчас в теме
(1) Пфф... Зачем нам поиск? Написать свое же всегда круче? Тем более что составить правильно поисковый запрос а потом просмотреть результаты - это дольше чем набрость на коленке.
(0) Пиши исчо! Столько тем неразобранных в синтаксис-помощнике осталось!
2. pashamak 127 24.08.18 12:26 Сейчас в теме
Есть, только перегруженные или не совсем понятно описанные.
3. kirillkr 28 24.08.18 19:36 Сейчас в теме
Это все красиво для тонкого клиента с разрешенными синхронными вызовами, но абсолютно не работает в асинхронной работе тонкого или веб-клиента
4. Xershi 714 24.08.18 20:40 Сейчас в теме
Надо наверное свою статью выложить с блекджеком и ш......, т.е. с полной асинхронностью, для вебклиента и универсально для любого реквизита, если именовать так как элемент формы=))
acanta; BigB; +2 Ответить
6. Xershi 714 09.06.19 18:39 Сейчас в теме
(4) Наконец написал свою публикацию с блекджеком и ш...... Работа с файлами (обычная и управляемая форма) все структурировано и методы все актуализированы!
Оставьте свое сообщение

См. также

Альтернативный способ добавления элементов и реквизитов на формы 29

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 ERP2 УТ11 Россия Абонемент ($m) Работа с интерфейсом

Предлагаю альтернативный вариант добавления динамически создаваемых элементов и реквизитов на форму.

1 стартмани

09.09.2019    2408    4    bmk74    0       

[Механизм интерфейса] Свой флажок (чекбокс) 109

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Создадим свой флажок для интерфейса, используем простой универсальный алгоритм.

1 стартмани

09.08.2019    4170    4    rpgshnik    37       

"Мобильный ТСД" - инвентаризация и сбор штрихкодов для iOS и Android 21

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 v8::Mobile Розница УНФ ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Монитор заказов Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Внешние источники данных Сканер штрих-кода Терминал сбора данных Работа с интерфейсом Мобильная разработка

Простой мобильный терминал сбора данных для iOS и Android, не требующий сложных настроек и установки дополнительных программ. Для выгрузки базы штрихкодов и загрузки собранных штрихкодов в документы учетной системы используется Яндекс Диск или облачный сервис и расширение конфигурации. Работает с конфигурациями Розница 2, УНФ 1.6, УТ 11, ERP, КА2.

3 стартмани

22.04.2019    9960    51    suepifanov    61       

Расширение: Цветовые схемы для 1С: Предприятия 10

Инструменты и обработки Программист Расширение (cfe) v8::УФ 1cv8.cf Абонемент ($m) Работа с интерфейсом

Расширение позволяет сменить цвет оформления для интерфейса Такси.

1 стартмани

10.02.2019    5201    21    spec8s    4       

Шпаргалка разработчика для работы с формами 23

Отчеты и формы Программист Архив с данными v8 Россия Абонемент ($m) Работа с интерфейсом

Сборник помогает быстро освоить встроенный язык и средства конфигурирования при разработке обычных и управляемых форм.

3 стартмани

31.10.2018    7865    68    ELAM    3       

Открывашка ячеек таблиц 85

Инструменты и обработки Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Глобальное сочетание клавиш для открытия объекта по ссылке из текущей ячейки любой таблицы в большинстве управляемых форм

1 стартмани

27.10.2018    9267    11    tormozit    28       

Визуализация событий на временной шкале средствами "Поле HTML документа" 170

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Интересный способ наглядно отобразить события на временной шкале. Например, может быть применен для красивого вывода документов по клиенту. Тестировалось на платформе 8.3.12.1469

1 стартмани

31.07.2018    13944    127    Plotks2017    24       

Работа с данными выбора 38

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    19806    13    kalyaka    15       

Автоматическое заполнение графиков в ЗУП 3.1 6

Инструменты и обработки Бухгалтер Архив с данными v8 v8::СПР ЗУП3.x Россия БУ Зарплата Учет рабочего времени Абонемент ($m) Обработка справочников

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    8020    14    notserioussam    1       

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1) 17

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::СПР ЗУП3.x БУ Управление персоналом (HRM) Абонемент ($m) Обработка справочников

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    14572    45    charivnick    3       

Тестирование интерфейса в обычном приложении 8.2 при помощи SikuliX 105

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Как же не хватает клиента тестирования на платформе 8.2. Не кликнешь на кнопку, не выберешь из списка, не проверишь видит ли надпись пользователь. Воспользуемся внешним инструментом SikuliX, который позволит нам протестировать функционал форм. Данный инструмент легко встраивается в линию сборки и может "дружить" с уже известным многим Open-source продуктами.

1 стартмани

03.01.2018    19611    2    kraynev-navi    40       

Программное формирование форматированной строки в стиле html+inline CSS 52

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом Инструментарий разработчика

Если вам приходилось работать с форматированными строками программно, то вы знаете, какая это боль. Данное решение облегчает программное формирование таких строк.

1 стартмани

18.11.2017    19231    24    bonv    5       

Размеры управляемой формы 101

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом Универсальные функции

Как рассчитать ширину и высоту управляемой формы или отдельного элемента, чтобы адаптировать интерфейс программно при их изменении.

1 стартмани

08.10.2017    17647    51    json    8       

Расширенная настройка динамического списка УФ 114

Инструменты и обработки Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Абонемент ($m) Работа с интерфейсом

Открывая управляемую форму выбора и не увидев там видимых в форме списка элементов, часто хочется узнать причину их отсутствия там, т. е. какой наложен отбор. Но стандартная настройка списка управляемой формы показывает только пользовательские настройки, скрывая от пользователя фиксированный отбор. Предлагаю вам расширение конфигурации с расширенной настройкой динамического списка, отображающей пользователю кроме пользовательских настроек еще фиксированные.

1 стартмани

31.05.2017    24194    144    tormozit    23       

Менеджер открытых форм 33

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ 1cv8.cf Абонемент ($m) Работа с интерфейсом

Обработка получает информацию об открытых формах и позволяет ими манипулировать.

1 стартмани

13.04.2017    16119    31    SeiOkami    16       

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2 99

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Обработка справочников Ценообразование, прайсы

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    39989    49    myALKleon    37       

Простой редактор плана помещения JavaScript 100

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Практика программирования Работа с интерфейсом

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    14866    91    igel9780    16       

HTTP-сервис: отчеты [Расширение] 122

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    18930    125    Stepa86    15       

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации 128

Инструменты и обработки Пользователь Руководитель проекта Архив с данными v8 1cv8.cf БП3.0 КА2 УУ Документооборот и делопроизводство Абонемент ($m) Управление бизнес-процессами (BPM) Обработка документов Обработка справочников

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    36854    218    BlizD    179       

Простые радости жизни программиста 1С: выбор типа значения 51

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    38536    45    yuraos    17       

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) 184

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Обработка документов Обработка справочников Загрузка и выгрузка в Excel

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    49858    373    Tatitutu    49       

Автоматическая загрузка классификатора адресов КЛАДР 9

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 Россия Windows Абонемент ($m) Обработка справочников WEB

Обработка автоматически загружает классификатор с сайта www.gnivc.ru, распаковывает и загружает все регионы в информационную базу.

1 стартмани

02.09.2015    17833    42    kolos    1       

Подсистема автоматического удаления дублей в справочниках (управляемые формы, любая конфигурация) 17

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Чистка базы Обработка справочников

Подсистема позволяет проводить автоматическое удаление дублей справочников в соответствии с заданными настройками. Возможно встраивание в любую конфигурацию на управляемых формах. Позволяет задать настройки справочников, в которых ищутся дубли и также поля поиска совпадений. Есть регламентное задание для запуска проверки с заданным периодом. Если в базе найдены ссылки на тот элемент, который будет удален, то они заменяются на тот элемент, который остается. Дублем считается элемент справочника, у которого больше значение кода.

1 стартмани

31.07.2015    28790    94    primat    9       

NativeDraw: Компонента рисования для 1С [V2.6.2] 106

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 1cv8.cf Windows Абонемент ($m) Разработка внешних компонент Работа с интерфейсом

Рисуйте в формах 1С, также предлагается небольшое количество нерисовальных функций

1 стартмани

13.07.2015    39561    421    ПерваяСистема    140       

Кнопки управления группировками табличного документа для управляемых форм 23

Инструменты и обработки Программист Внешний отчет (ert,erf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Универсальный механизм управления группировками табличного документа из управляемой формы

1 стартмани

02.06.2015    21669    31    unichkin    9       

Изменение конфиденциальной информации (обработка, управляемые формы) 13

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8::УФ 1cv8.cf Windows Абонемент ($m) Обработка документов Защита и шифрование Обработка справочников

Обработка позволяет полностью заменить в базе все конфиденциальные данные - все поля справочников, суммы в документах и прочие значения объектов. Идентична по функционалу обработке с ИТС "Изменение конфиденциальной информации", но работает под управляемыми формами и в интерфейсе "Такси". Есть гибкая настройка тех данных, которые необходимо удалять.

1 стартмани

17.05.2015    27742    144    primat    22       

Подсистема проверки контрагентов через сервис ГосРеестра для объединения с любой конфигурацией (или автономной работы) 5

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Windows Абонемент ($m) Универсальные обработки Обработка справочников

Еще один вариант для проверки контрагентов через сервис ФНС. Механизм аналогичен проверке в типовой БП 3.0 и полностью автономен, можно объединить с любой конфигурацией. При первом запуске просит ввести логин и пароль для доступа к сайту поддержки 1С.

1 стартмани

06.04.2015    14011    54    Foxes82    12       

Подсистема "Планировщик" (версия 1.1) 138

Отчеты и формы no Конфигурация (md, cf) v8 1cv8.cf Россия Абонемент ($m) Практика программирования WEB Работа с интерфейсом

Конфигурация с подсистемой "Планировщик" (календарь). Бесплатная открытая версия для свободного использования не включает двустороннюю интеграцию с сервисом Google и Outlook.com.

5 стартмани

02.03.2015    55746    463    vandalsvq    62       

Загрузка товаров с Яндекс.Маркет 22

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 УТ10 Windows Абонемент ($m) Обработка справочников WEB

Обработка предназначена для загрузки товаров (их описаний, свойств, изображений) с торговой площадки Яндекс.Маркет в базу Управление Торговлей 11. В отличие от других подобных обработок Вам самим не придется парсить страницы Яндекс.Маркет и решать сопутствующие этому процессу проблемы (бан, капча, поиск прокси-серверов, длительное ожидание результатов при больших объемах данных), так как все данные уже загружены на наш сервер и готовы для использования. Обновление данных осуществляется раз в месяц. Таким образом, все что Вам нужно - подключиться раз в месяц к нашему сервису и получить обновленный ассортимент товаров.

1 стартмани

12.01.2015    29889    182    Sirruf    81       

Проверка контрагентов по ИНН и КПП через веб-сервис ФНС (внешняя) 22

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Обработка справочников WEB

Обработка проверяет контрагентов по ИНН и КПП через веб-сервис ФНС на наличие регистрации в ЕГРН. Может выполняться в любых типовых конфигурациях, при наличии справочника "Контрагенты" и реквизитов "ИНН" и "КПП"

1 стартмани

25.12.2014    32011    297    Willforre    12       

Реестр договоров для 1С:Бухгалтерии 14

Инструменты и обработки Бухгалтер Архив с данными v8 v8::БУ БП3.0 Россия БУ Документооборот и делопроизводство Абонемент ($m) Обработка документов Обработка справочников

Реестр договоров для 1С:Бухгалтерии - дополнительная обработка для конфигурации "Бухгалтерия предприятия", версия 3.0

5 стартмани

28.10.2014    33635    110    RespectSoft    23       

Загрузка курсов валют 4

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Обработка справочников WEB

Загрузка актуальных курсов валют с web - сервиса Сбербанка. На обычных и управляемых формах.

1 стартмани

15.10.2014    10591    27    miller-adm    3       

[ТАКСИ] Шаблон внешней обработки...и не только 207

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки Работа с интерфейсом Универсальные функции

Обработка предназначена для лентяев, к каковым, в первую очередь, отношу себя. Это в некотором роде шпаргалка в виде шаблона внешней обработки. Для создания новой копируем эту, удаляем ненужное, вставляем нужное - получаем результат. Чем ваять с нуля, каждый раз прописывая одно и то же, проще использовать заготовку, подобную этой... 24.11.2018 - Версия 1.21 - что-то добавил, что-то поправил.... 16.04.2019 - По просьбам трудящихся (немногочисленным, правда) оставил последнюю версию 1.21, дабы не было путаницы... 17.04.2019 - Версия 1.22 Вернул пример сохранения табличного документа в разных форматах и чтения DBF из версии 1.16 (как потерялось - сам не понял)

2 стартмани

22.09.2014    46059    687    Alex_E    27       

Быстрое создание характеристик номенклатуры по дополнительным реквизитам в УТ11 + ВИДЕО 7

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 УУ Windows Оптовая торговля Учет ТМЦ Абонемент ($m) Обработка справочников

Обработка позволяет создавать характеристики по всевозможным сочетаниям "дополнительных реквизитов характеристик". На форму выводится дерево дополнительных реквизитов характеристик и их возможных значений. Таблицу можно редактировать. Обработка полным перебором значений этих реквизитов создаст всевозможные характеристики.

1 стартмани

06.09.2014    20837    38    GATTUSO    27       

Проверка данных 179

Инструменты и обработки no Архив с данными v8 1cv8.cf БУ НУ УУ Абонемент ($m) Обработка документов Обработка справочников

Простой и удобный инструмент для проверки данных (справочников, документов) сразу в момент записи. Позволяет значительно повысить качество информации, вводимой в любую систему на платформе 1С:Предприятие 8.2-8.3. Прост в освоении и использовании, оптимизирован по быстродействию.

1 стартмани

01.07.2014    36503    329    1c-intelligence    145       

Локализация конфигурации с помощью Google 13

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Обработка позволяет выполнять перевод интерфейсов в любой конфигурации 1С средствами Google. За основу взята обработка: http://infostart.ru/public/190890/

1 стартмани

06.06.2014    15441    32    x-tremeall    6       

Загрузка картинок для номенклатуры (google image API) 6

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Обработка справочников WEB

Обработка предназначена для поиска и загрузки картинок номенклатуры.

1 стартмани

04.06.2014    11020    92    OVladius    4       

Смена валют учета в базе 6

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 КА1 БП2.0 УТ10 УПП1 Windows Абонемент ($m) Обработка справочников

Крымчане столкнулись с проблемой смены валют с гривны на рубль. Эта обработка поможет решить данный вопрос.

1 стартмани

26.05.2014    21792    32    dmbal    4       

Быстрый ввод контрагентов и организаций по данным ФНС 75

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 КА1 БП2.0 УТ10 УПП1 УНФ Windows Абонемент ($m) Обработка справочников WEB

Обработка для быстрого создания карточки контрагента/организации по данным ЕГРЮЛ/ЕГРИП.

1 стартмани

20.05.2014    35722    743    Sirruf    71       

Алгоритмы. Часть 1.1. Динамические соединения. 186

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Конспект первой лекции из свежего курса Принстонского университета США за 2014 год. Вольный перевод с английского с реализацией примеров на 1С. Курс в целом достаточно интересный и полезный для общего развития. Перевел и адаптировал только первую лекцию (в 1 части 11 лекций, 2 часть - еще не завершена преподавателями). Первоисточник на английском - https://www.coursera.org/course/algs4partI. Если сообщество посчитает материал полезным - займусь переводом следующих лекций (но это довольно трудоемко). Enjoy! :)

1 стартмани

04.04.2014    27802    23    Aleksey.Bochkov    33       

Изучаем мобильную платформу 8.3.4: геопозиционирование 155

Инструменты и обработки Программист Архив с данными v8 v8::Mobile Android Абонемент ($m) Работа с интерфейсом

Блеск и нищета geo-инструментов мобильной платформы 8.3.4. Пишем письмо турецкому султану. Но Чекин, как в Foursquare уже реально!

1 стартмани

14.02.2014    57245    198    barelpro    43       

Полнотекстовый поиск по значениям реквизитов 5

Инструменты и обработки no Архив с данными v8 Абонемент ($m) Чистка базы Поиск данных Обработка справочников

Обработка расширяет возможности Полнотекстового поиска, позволяя искать похожие элементы в ЛЮБЫХ Справочниках ЛЮБОЙ конфигурации по проценту совпадения значений выбранных реквизитов. Работает в Обычном и Управляемом режиме!!

1 стартмани

25.12.2013    31878    113    vladim-kul    8       

Групповое изменение скидок и наценок в индивидуальных соглашениях в 1С 8 УТ 11 1

Инструменты и обработки Бухгалтер Руководитель проекта Внешняя обработка (ert,epf) v8 v8::ОУ УТ11 Россия УУ Windows Ценообразование, анализ цен Абонемент ($m) Обработка справочников

Обработка позволяет при изменении скидок или наценок в соглашениях автоматически создать новое соглашение с новыми условиями и закрыть старое соглашение.

2 стартмани

17.12.2013    11136    1    A7758735    2       

Рабочий стол администратора/программиста на управляемой форме 254

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки Работа с интерфейсом Рабочее место

Рабочий стол администратора 1С позволяет: - Производить быструю навигацию по объектам конфигурации - Открывать любую форму, определенную для объекта - Подключать произвольное количество каталогов с внешними обработками - Производить быстрый поиск среди объектов конфигурации и подключенных внешних обработок - Запускать систему 1С от имени другого пользователя с временной заменой пароля или без - Открывать универсальный динамический список для выбранного объекта конфигурации - Добавлять часто используемые объекты в Избранное, видеть и повторять последние совершенные действия через Историю. Обработка совместима с "Такси" без модальных окон и имеет поддержку английского языка.

1 стартмани

07.12.2013    39988    639    Vladimir Litvinenko    53