Загрузка документов из txt и xls*

Обработки - Обработка документов

Вариант загрузки документов (в том числе управляемые формы), с удобным, по крайней мере для меня, интерфейсом и настройками.

Друзья, УРА!

Слава Богу, закончил адаптацию для управляемого режима!

Программа умеет загружать данные из текстовых (т.е. тех, которые можно сформировать текстовым редактором или элементарными выгрузками из других программ), а также из файлов xls, и помещать эти данные в документы.

 

В примере для реквизита номер указана следующая обработка: СтрЗаменить( ТекущаяСтрокаСлепка[ ИмяКолонки(2) ], " ", "" )

ТекущаяСтрокаСлепка — переменная — текущая строка слепка, с которой производится загрузка сейчас. Функция ИмяКолонки, возвращает внутренне имя колонки слепка. Таким образом в номер документа будет записано то, что было во 2 столбце файла загрузки без пробелов.

 

Например строка:

«Справочники.ЦОД_Продукты.НайтиПоКоду( ТекущаяСтрокаСлепка[ ИмяКолонки(5) ] )» означает что реквизит будет найден по коду из справочника «ЦОД_Продукты», а код поиска будет взят из 5-го столбца.

 

Кстати, если кто не разберется с управлением, то, перейдя по ссылке "файлы", можно скачать описание.

Скачать файлы

Наименование Файл Версия Размер
ДокументыИзTXTиXL81
.epf 23,62Kb
24.09.11
114
.epf 23,62Kb 114 Скачать
ДокументыИзTXTиXL82УпрФормы
.epf 21,81Kb
15.12.11
196
.epf 21,81Kb 196 Скачать
ДокументыИзTXTиXL82
.epf 23,60Kb
24.09.11
147
.epf 23,60Kb 147 Скачать
Описание
.pdf 230,85Kb
27.09.11
130
.pdf 230,85Kb 130 Скачать

См. также

Комментарии
1. игорь тос (svet222) 26.09.11 01:10 Сейчас в теме
А в УТ работать будет?
2. uri-fl (dedkov) 26.09.11 08:50 Сейчас в теме
(1). Обработка не привязана к конфигурации.
3. Igоr Sаulеviсh (gutentag) 253 26.09.11 18:23 Сейчас в теме
А в формате DOC или RTF нельзя ли загрузить "Описание" ?
----
а то надо скачивать конвертер в 75мб, который еще и ненайдешь :-/
4. VVV Vit (V_V_V) 26.09.11 21:25 Сейчас в теме
А можно вопрос не по теме? Судя по скриншотам (если я не ошибаюсь) 1С запущен в Linux. Это Wine? Чистый или от Etersoft? Нарекания есть?
5. uri-fl (dedkov) 27.09.11 00:12 Сейчас в теме
(3). Смотри, PDF надеюсь подойдет.
(4). Это чистый вайн, для учебных целей мне подходит. Есть некоторые вопросы с всплывающими меню, с положением "прилипающих" окон, для меня это не критично. Так же есть еще небольшой глючец - если использовать подсистемы, то на большом экране полоска заголовка снизу иногда покрывается полосками. Короче говоря глюки есть, но насколько они критичны и смогут ли испортить впечатление, нужно проверять для конкретной ситуации.
V_V_V; gutentag; +2 Ответить
6. Igоr Sаulеviсh (gutentag) 253 27.09.11 11:32 Сейчас в теме
Кстати, если кто не разберется с управлением, то, перейдя по ссылке "файлы", можно скачать описание



Поясните пожалуйста для простого буха, как сделать загрузку в документы напрямую из файла-XLS(что и где надо заменить)

Спасибо!
7. uri-fl (dedkov) 27.09.11 13:39 Сейчас в теме
(6) Необходимо выбрать в настройках вид документа в который будет грузится информация и табличную часть, указать номера столбцов для реквизитов, которые вы хотите загрузить. Выбрать файл и загружать. Мои контакты, собственно, указаны в профиле, если будет время помогу.
8. Griper Ink (griper) 27.09.11 13:55 Сейчас в теме
Примите благодарности за полезную обработку. Как раз экспериментирую с разными способами загрузки приходных документов из таблиц excel и ваша разработка видится мне наиболее простой и удобной плюс хорошо работает на версии 8.2.
9. uri-fl (dedkov) 27.09.11 17:33 Сейчас в теме
10. uri-fl (dedkov) 27.09.11 17:33 Сейчас в теме
Кстати схемы можно сохранять я надеюсь все это поняли :)
11. uri-fl (dedkov) 27.09.11 17:40 Сейчас в теме
(8) Можно даже плюсик поставить, если есть желание...
12. Zoomby Zoomby (Zoomby) 27.09.11 17:52 Сейчас в теме
Просто вариант загрузки документов, с удобным, по крайней мере для меня, интерфейсом и настройками.


Плюсую пока, скачаю как нибудь потом. )
13. J G (JRG) 28.09.11 16:48 Сейчас в теме
Полезная обработка, рекомендую
14. Адепт Адептов (Adeptus) 89 28.09.11 17:31 Сейчас в теме
15. Адепт Адептов (Adeptus) 89 28.09.11 17:39 Сейчас в теме
16. Дмитрий Осин (theologian) 29.09.11 23:59 Сейчас в теме
Обработка пригодилась. Как раз был большой объем данных для загрузки. Спасибо!
17. Александр Ф (leon111) 6 17.10.11 11:24 Сейчас в теме
загрузить документы из xls еще можно обработкой ЗагрузкаДанныхИзТабличногоДокумента
18. uri-fl (dedkov) 17.10.11 13:26 Сейчас в теме
(17) Спасибо. Хорошо, Когда есть альтернатива.
19. Василий Теркин (Terking) 19.10.11 09:42 Сейчас в теме
Блин, не могу скачать сие чудо. А так нужна подобная штучка! Может кто поможет? если, можно скиньте: 999044@list.ru
20. Евгений (Djonny) 21.10.11 10:07 Сейчас в теме
Доброго дня всем!
скиньте плиз описание: r_djonny@bk.ru
21. A (Kochevnic) 21.10.11 12:14 Сейчас в теме
Спасибо! Обработка очень полезная, по крайней мере мне пригодилась.
22. A (Kochevnic) 21.10.11 12:23 Сейчас в теме
Спасибо! Хорошая обработка. Рекомендую попробовать, не смотря на то, что есть много алтернативных
23. Евгений (Djonny) 21.10.11 14:01 Сейчас в теме
(18) просьба к автору выслать описание на почту!
Спасибо, за понимание:-)
24. Юлия Петрова (petrovaUL) 21.10.11 14:55 Сейчас в теме
Интересно, надо поробовать, пригодится
25. uri-fl (dedkov) 21.10.11 15:12 Сейчас в теме
26. Кирилл Раковский (RakovskiyK) 24.10.11 14:44 Сейчас в теме
инетерсная штука, главное очень полезная и позволяет сэкономить много-много времени :)
27. napan - (napan) 6 24.10.11 19:55 Сейчас в теме
Очень хорошая штука, мне просто очень помогает. Спасибо огромное. Благодарен автору
28. uri-fl (dedkov) 26.10.11 23:41 Сейчас в теме
(26) RakovskiyK, (27) napan, предлагаю поучаствовать в адаптации для использования при управляемом режиме. Самому времени нет, но было бы здорово сохранить концепцию, упростить обращение к ячейкам(исходного файла) и сделать возможным запускать обработку в управляемом режиме.
29. Александр М (Fruit83) 28 15.12.11 20:02 Сейчас в теме
Спасибо за обработку! Сейчас посмотрим будет ли она полезна в моей работе. :)
30. Alyadelf (1c8.2) 15.12.11 20:55 Сейчас в теме
а платежное поручение загрузить можно ?
31. uri-fl (dedkov) 16.12.11 00:41 Сейчас в теме
(30) можно загрузить любой вид документа, конечно если он есть в конфигурации.
32. Альберт Кадымов (sword444) 148 26.01.12 23:06 Сейчас в теме
+ автору, хороший инструмент.
просьба, если можно описание кинуть на мыло 999666_09@mail.ru
33. matrix matrix (matrix1) 15.03.12 14:28 Сейчас в теме
Что такое схема загрузки и где её брать?
34. 1801 26.04.12 11:20 Сейчас в теме
Похоже, обработка действительно очень нужная, а для людей, которые привыкли думать головой перед тем как бросаться решать нудные и масштабные задачи по перебиванию документов из базы в базу, просто незаменимая.
Одобряю. Скачаю обязательно! Люблю вещи, которые экономят время для жизни!
36. Андрей - (Motor24) 06.08.13 15:54 Сейчас в теме
Для коллекции сохраню обязательно. А там, кто знает - может и в постоянную работу войдёт. Спасибо!
37. михаил забудько (mihaizum) 07.08.13 16:45 Сейчас в теме
Не заменимая обработка. Думаю должна очень помочь в работе.
38. nmgmex nmgmex (nmgmex) 09.08.13 09:51 Сейчас в теме
39. сергей (Sergey447) 09.08.13 11:37 Сейчас в теме
40. Василий Пупкин (AgregatAvia) 20.06.14 07:04 Сейчас в теме
Уважаемый автор, ваша инструкция к обработке никуда не годится, хотя бы добавьте пример использования обработки для загрузки какого-нибудь документа. Сама обработка на первый взгляд хороша, но такую справку я бы постыдился выкладывать за отдельный $м.
41. Андрей Дедков (dedkov) 205 20.06.14 19:29 Сейчас в теме
Справку я и не выкладывал за $m. Просто обработку выкладывал очень давно, с тех пор политика Инфостарта менялась, возможно поэтому описание теперь скачивается за $m.
42. Петр Лунегов (pvlunegov) 103 03.05.16 15:06 Сейчас в теме
В обработке версии 8.1 при загрузке из Excel, столбец даты документа, в котором были данные вида "15.02.2016 15:23:49" преобразуется к "15.02.2016". В версии для управляемого приложения дата преобразуется с временем.
В итоге при загрузке документов в 8.1, все документы в одном дне перезаписываются в один документ (так как время одинаковое).
Просьба пофиксить эту проблему, тем более, что в версии для 1с 8.3 у вас такой проблемы нет!
43. Петр Лунегов (pvlunegov) 103 03.05.16 15:12 Сейчас в теме
Автор, большая просьба сделать нормальную инструкцию для пользователя, как начинать пользоваться вашей обработкой.
Пришлось потратить минут 40 чтобы понять что в ней что, какие кнопки нажимать, чтобы увидеть результат.
44. Андрей Дедков (dedkov) 205 12.05.16 18:02 Сейчас в теме
(43) pvlunegov, Действительно актуально?
45. Андрей (zeroplus) 11.08.17 14:43 Сейчас в теме
Автор, спасибо огромное, за шикарную обработку. Но есть один вопрос (сам не разобрался) Можно ли написать в Обработке как создать новый элемент справочника, если не не нашлось ПоНаименованию? (В пользовательском режиме в столбце "Обработка")
46. Андрей Дедков (dedkov) 205 11.08.17 18:53 Сейчас в теме
(45)

Пример текста обработки после загрузки строки
//[ОбработкаПослеЗагрузкиСтроки]
// Этот пример создает элемент справочника "Продукты" в случае если элемент не найден по реквизиту "КодСинхронизации"

ТекСтрокаСлепка = ЗначениеИзСтрокиВнутр(ТекТаблицаТабличныхЧастей.Тек___Строка___Слепка___);

СоздаватьТМЦ = Истина;
Если ТекСтрока.ТМЦ <> Неопределено Тогда
	Если Не ТекСтрока.ТМЦ.Пустая() Тогда
		СоздаватьТМЦ = Ложь;
	КонецЕсли;
КонецЕсли;

Если СоздаватьТМЦ Тогда
	ТекСтрока.ТМЦ = Справочники.Продукты.НайтиПоРеквизиту( "КодСинхронизации", ТекСтрокаСлепка[НОМЕРЯЧЕЙКИКДОДА]);
	Если ТекСтрока.ТМЦ <> Неопределено Тогда
		Если Не ТекСтрока.ТМЦ.Пустая() Тогда
			СоздаватьТМЦ = Ложь;
		КонецЕсли;
	КонецЕсли;
КонецЕсли;

Если СоздаватьТМЦ Тогда
	НовыйПродукт = Справочники.Продукты.СоздатьЭлемент();
	НовыйПродукт.Наименование = ТекСтрокаСлепка[6];
	НовыйПродукт.Реквизит1 = ТекСтрокаСлепка[НОМЕРЯЧЕЙКИРЕКВИЗИТА1];
	НовыйПродукт.Реквизит2 = ТекСтрокаСлепка[НОМЕРЯЧЕЙКИРЕКВИЗИТА2];
	НовыйПродукт.Реквизит3 = ТекСтрокаСлепка[НОМЕРЯЧЕЙКИРЕКВИЗИТА3];
	НовыйПродукт.Записать();
	ТекСтрока.ТМЦ = НовыйПродукт.Ссылка;
КонецЕсли;

// Этот пример создает элемент справочника "Продукты" в случае если элемент не найден по реквизиту "КодСинхронизации"
...Показать Скрыть
47. Андрей Дедков (dedkov) 205 11.08.17 19:53 Сейчас в теме
48. Андрей (zeroplus) 12.08.17 12:31 Сейчас в теме
Андрей, да более чем понятен. Спасибо, огромное.
Оставьте свое сообщение