Подготовка к ЕГЭ сына - школьника (по информатике)

Публикация № 981994

Разработка - Практика программирования

подготовка ЕГЭ программирование Паскаль Pascal

9
Примеры на Паскале. Если сам отец - поддержи ! Если сам водила - посигналь !

Вступление

 

Надеюсь, не один только я готовлюсь к ЕГЭ со своим сыном-школьником! Пора рядом с разделами "Администрирование", "Сообщество" создать раздел "Подготовка к ЕГЭ". (Шутка)

Задания - из кодификатора ЕГЭ-2019 по Информатике, программы составил сын на Pascal. Что он скажет через год-другой, когда опять их увидит ? (Мы знаем).  

Задание 1 переделали по комментариям. Мне лично нравится  задание 3. Оказывается, из двоичной системы счисления очень удобно переводить в восьмеричную. Каждая триада переходит в одну цифру.

 
 Задание 1. Нахождение минимума и максимума двух, трех, четырёх данных чисел без использования массивов и циклов. (Здесь предполагается, что все числа различны)
 
 Задание 2. Нахождение всех корней заданного квадратного уравнения ax2+bx+c = 0 (Здесь рассматриваются все возможные случаи):
 
 Задание 3. Запись натурального числа в позиционной системе с основанием, меньшим или равным 10. Обработка и преобразование такой записи числа.
 
 Задание 4. Нахождение сумм, произведений элементов данной конечной числовой последовательности (или массива). Очевидно, что произведение будет достигнуто лишь изменением счетчика с присвоением ему значения «1» и изменении знаков «+» на «*»:
 
 Задание 5. Использование цикла для решения простых переборных задач (поиск наименьшего простого делителя данного натурального числа, проверка числа на простоту и т.д.).
 
 Задание 6. Заполнение элементов одномерного и двумерного массивов по заданным правилам. Предлагаю рассмотреть лишь двумерный массив, потому что в примерах ранее заполнение одномерного было показано неоднократно:
 
 Задание 7. Операции с элементами массива. Линейный поиск элемента. Вставка и удаление элементов в массиве. Перестановка элементов данного массива в обратном порядке. Суммирование элементов массива. Проверка соответствия элементов массива некоторому условию
 
 Задание 8. Нахождение второго по величине (второго максимального или второго минимального) значения в данном массиве за однократный просмотр массива.
9

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
Избранное Подписка Сортировка: Древо
1. insurgut 196 17.01.19 12:19 Сейчас в теме
Первое точно не так делается. Логика примерно такая:
МаксЧисло = -999999999;
Если ПервоеЧисло > МаксЧисло Тогда
МаксЧисло = ПервоеЧисло;
КонецЕсли;
Если ВтороеЧисло > МаксЧисло Тогда
МаксЧисло = ВтороеЧисло;
КонецЕсли;
Если ТретьеЧисло > МаксЧисло Тогда
МаксЧисло = ТретьеЧисло;
КонецЕсли;
Если ЧетвертоеЧисло > МаксЧисло Тогда
МаксЧисло = ЧетвертоеЧисло;
КонецЕсли;
Сообщить("Максимум: " + МаксЧисло);
Показать


Но ЕГЭ штука такая, им не всегда подходит более простое решение.
2. vasilev2015 1413 17.01.19 12:25 Сейчас в теме
Да, я написал: не читайте, будем переделывать. За идею спасибо, хотел переделать как ниже, но Ваш вариант лучше.

Если ПервоеЧисло > ВтороеЧисло Тогда
Если ПервоеЧисло > ТретьеЧисло Тогда
Иначе
КонецЕсли
Иначе
Если ВтороеЧисло > ТретьеЧисло Тогда
Иначе
КонецЕсли
КонецЕсли
3. insurgut 196 17.01.19 12:34 Сейчас в теме +0.2 $m
(2) поторопился, там даже от одного условия можно избавится:
МаксЧисло = ПервоеЧисло;
Если ВтороеЧисло > МаксЧисло Тогда
   МаксЧисло = ВтороеЧисло;
КонецЕсли;
Если ТретьеЧисло > МаксЧисло Тогда
   МаксЧисло = ТретьеЧисло;
КонецЕсли;
Если ЧетвертоеЧисло > МаксЧисло Тогда
   МаксЧисло = ЧетвертоеЧисло;
КонецЕсли;
Сообщить("Максимум: " + МаксЧисло);
Показать


Но меня не отпускает ощущение, что скрыт какой-то подвох в задании. :)
4. spacecraft 17.01.19 13:05 Сейчас в теме +0.2 $m
(3)
Но меня не отпускает ощущение, что скрыт какой-то подвох в задании. :)

правильные ощущения. Условия: "Нахождение минимума и максимума ..."
(2)
program min_max_of_four_numbers_without_arrays_or_cycles;
var
first_number, second_number, third_number, forth_number, min_number, max_number:real;
begin
    writeln('Последовательно введите четыре числа, которые необходимо сравнить');
    readln(first_number, second_number, third_number, forth_number);
    
    if (first_number > second_number) then
    begin
        min_number := second_number;
        max_number := first_number;
    end
    else
    begin
        min_number := first_number;
        max_number := second_number;
    end;
    if (min_number > third_number) then
        min_number := third_number;
    if (min_number > forth_number) then
        min_number := forth_number;
    if (max_number < third_number) then
        max_number := third_number;
    if (max_number < forth_number) then
        max_number := forth_number;
    writeln('Max = ', max_number);
    writeln('Mix = ', min_number);
    
end.
Показать
6. insurgut 196 17.01.19 13:13 Сейчас в теме
(4) да как бы понятно, что на минимум нужно операций по аналогии добавить, я не об этом.
10. starik-2005 1959 17.01.19 13:35 Сейчас в теме +0.2 $m
(4) а зачем так много кода?
var min_num, max_num, ent_num : double;
begin
  writeln('Последовательно введите четыре числа, которые необходимо сравнить');

  readLn(ent_num);
  min_num := ent_num;
  max_num := ent_num;

  readLn(ent_num);
  min_num := min(ent_num, min_num) ;
  max_num := max(ent_num, max_num) ;

  readLn(ent_num);
  min_num := min(ent_num, min_num) ;
  max_num := max(ent_num, max_num) ;

  readLn(ent_num);
  min_num := min(ent_num, min_num) ;
  max_num := max(ent_num, max_num) ;

  writeln('Max = ', max_num);
  writeln('Mix = ', min_num);
end.

Показать
11. vasilev2015 1413 17.01.19 13:39 Сейчас в теме
(10) я между прочим, на публикацию вдохновился после вашей заметки о пузырке. : -)))
13. spacecraft 17.01.19 13:42 Сейчас в теме
(10) Ваш код вообще не скомпилится. min() и max() находятся в отдельной библиотеке, которую не факт, что можно использовать на ЕГЭ.
14. starik-2005 1959 17.01.19 13:48 Сейчас в теме
(13) можно заменить на "if ent_num > max_num then max_num := ent_num;"
var min_num, max_num, ent_num : double;
begin
  writeln('Последовательно введите четыре числа, которые необходимо сравнить');

  readLn(ent_num);
  min_num := ent_num;
  max_num := ent_num;

  readLn(ent_num);
  if ent_num < min_num then min_num := ent_num;
  if ent_num > max_num then max_num := ent_num;

  readLn(ent_num);
  if ent_num < min_num then min_num := ent_num;
  if ent_num > max_num then max_num := ent_num;

  readLn(ent_num);
  if ent_num < min_num then min_num := ent_num;
  if ent_num > max_num then max_num := ent_num;

  writeln('Max = ', max_num);
  writeln('Mix = ', min_num);
end.
Показать
15. spacecraft 17.01.19 13:50 Сейчас в теме
(14) и? Чем этот код лучше моего? Лишним if?
16. starik-2005 1959 17.01.19 13:51 Сейчас в теме
(15) отсутствием лишних переменных и читаемостью как минимум.
17. spacecraft 17.01.19 13:53 Сейчас в теме
(16) спорное утверждение. Куча readLn внутри когда не способствуют лучшей читаемости этого кода.
18. starik-2005 1959 17.01.19 13:57 Сейчас в теме
(17) каждому свое. Веток ветвления у Вас тоже 6, если считать блок "else". Блоки зачем-то, которые совершенно не нужны. Лишние переменные - это всегда минус баллы на олимпиадах. Но ведь главное, чтобы работало, да? А вот проверяющим ЕГЭ читаемость будет важнее.
45. vadim1011985 70 17.01.19 17:57 Сейчас в теме
(2)
По моему это самый простой и короткий способ искать мин и макс а вообще если есть встроенная функция max и min то тогда код получается еще короче т.е. сама функция не нужна

Function Max (a,b)
begin
If a>b then
return a
else
return b;
end;

Procedure FindMaxValue ()
var maxValue,a,b,c,d:int;
begin

writeln('Последовательно введите четыре числа, которые необходимо сравнить');
readln(a, b, c, d);

maxValue = Max (Мax(a,b),Мax(с,d));

end;
starik-2005; PowerBoy; +2 Ответить
46. starik-2005 1959 18.01.19 10:26 Сейчас в теме
(45) в идеале что-то такое получается:
var a,b,c,d : double;
begin
  writeln('Последовательно введите четыре числа, которые необходимо сравнить');
  readLn(a,b,c,d);
  writeLn('Max: ', max(max(a,b),max(c,d)));
  writeLn('Min: ', min(min(a,b),min(c,d)));
end.
48. roman77 108 18.01.19 16:38 Сейчас в теме
(1) В контрольных заданиях всё подробно расписано. В последней задаче за простое решение (перебором) дают 2 балла, за сложное 4 балла. Все методисты и здравомыслящие люди советуют решать на 2 балла, ибо при сложном решении есть высокая вероятность накосячить и не получить ни одного бала.
50. addinaq 20.01.19 16:06 Сейчас в теме
(1)
Попарное сравнение может
Перем Первая,Вторая,Третья,Четвертая

?(Первая>Вторая,ИскомоеПервойПары=Первая,ИскомоеПервойПары=Вторая);
?(Третья>Четвертая,ИскомоеВторойПары=Третья,ИскомоеВторойПары=Четвертая);
Максимум = ?(ИскомоеПервойПары>ИскомоеВторойПары,ИскомоеПервойПары,ИскомоеВторойПары);

?(Первая<Вторая,ИскомоеПервойПары=Первая,ИскомоеПервойПары=Вторая);
?(Третья<Четвертая,ИскомоеВторойПары=Третья,ИскомоеВторойПары=Четвертая);
Минимум = ?(ИскомоеПервойПары<ИскомоеВторойПары,ИскомоеПервойПары,ИскомоеВторойПары);
Показать
5. insurgut 196 17.01.19 13:10 Сейчас в теме
Задание 8 (на паскаль думаю сами интерпретируете):
	НачальноеЧисло = Формат(ТекущаяДата(), "ДФ=HHmmss");
	ГСЧ = Новый ГенераторСлучайныхЧисел(НачальноеЧисло);
	
	//генерация массива
	МассивЧисел = Новый Массив;
	РазмерМассива = 9;
	Сообщить("Массив:");
	Для Сч = 0 По РазмерМассива - 1 Цикл
		СлучайноеЧисло = ГСЧ.СлучайноеЧисло(0, 235959);
		МассивЧисел.Добавить(СлучайноеЧисло);
		Сообщить(СлучайноеЧисло);
	КонецЦикла;
	
	//поиск максимальных
	ПервоеМакс = 0;
	ВтороеМакс = 0;
	Для Сч = 0 По РазмерМассива - 1 Цикл
		Если МассивЧисел[Сч] > ПервоеМакс Тогда
			ВтороеМакс = ПервоеМакс;
			ПервоеМакс = МассивЧисел[Сч];
		КонецЕсли;
	КонецЦикла;
	Сообщить("Первое: " + ПервоеМакс);
	Сообщить("Второе: " + ВтороеМакс);
Показать
7. Man4kin 17.01.19 13:18 Сейчас в теме
(5) Без использования массивов и циклов же ?
8. insurgut 196 17.01.19 13:18 Сейчас в теме
(7) за однократный проход массива же?
9. vasilev2015 1413 17.01.19 13:33 Сейчас в теме
(5) Когда элемент МассивЧисел[Сч] сравниваем с ПервоеМакс и ВтороеМакс, то элемент может изменить ВтороеМакс или обе переменные, а здесь только одно условие.
12. insurgut 196 17.01.19 13:39 Сейчас в теме
(9) если честно, то ничего не понял :) элемент массива не сравнивается со вторым максимальным, только с первым. Второе максимальное сравнивать ни с чем не нужно.
21. vasilev2015 1413 17.01.19 14:13 Сейчас в теме
(12) из массива {2,1,5,4,3} нужно выбрать второй по-минимуму 2 или второй по-максимуму 4. Код из статьи мы проверяли.
22. insurgut 196 17.01.19 14:19 Сейчас в теме
(21) и все равно не пойму сути вашего замечания - что не так то? Алгоритм находит второе максимальное число в массиве (доработать под второе минимальное сложности не составит). Или вас смущает вывод сообщения о первом максимальном? Закомментируем его, так и быть. Если не нравится генерация массива - так это для проверки работоспособности. Можно задать фиксированным массив, суть не поменяется.
   
    //генерация массива
    РазмерМассива = 5;
    МассивЧисел = Новый Массив;
    МассивЧисел.Добавить(2);
    МассивЧисел.Добавить(1);
    МассивЧисел.Добавить(5);
    МассивЧисел.Добавить(4);
    МассивЧисел.Добавить(3);
    
    //поиск второго максимального числа
    ПервоеМакс = 0;
    ВтороеМакс = 0;
    Для Сч = 0 По РазмерМассива - 1 Цикл
        Если МассивЧисел[Сч] > ПервоеМакс Тогда
            ВтороеМакс = ПервоеМакс;
            ПервоеМакс = МассивЧисел[Сч];
        КонецЕсли;
    КонецЦикла;
    Сообщить("Второе: " + ВтороеМакс);
Показать
26. vasilev2015 1413 17.01.19 14:50 Сейчас в теме
(22) Мы разошлись в понимании "второй максимальный" я себе представлял, что среди всего массива выбрать максимум, убрать его из рассмотрения, выбрать еще раз максимум - это будет ответ. А Вы представляете, что максимум должен быть локальным.Проверю еще раз условия задачи. В любом случае, спасибо.
35. insurgut 196 17.01.19 16:24 Сейчас в теме
(26) все я понял, где собака зарыта :)
Исправленный код:
	НачальноеЧисло = Формат(ТекущаяДата(), "ДФ=HHmmss");
	ГСЧ = Новый ГенераторСлучайныхЧисел(НачальноеЧисло);
	
	//генерация массива
	МассивЧисел = Новый Массив;
	РазмерМассива = 9;
	Сообщить("Массив:");
	Для Сч = 0 По РазмерМассива - 1 Цикл
		СлучайноеЧисло = ГСЧ.СлучайноеЧисло(0, 235959);
		МассивЧисел.Добавить(СлучайноеЧисло);
		Сообщить(СлучайноеЧисло);
	КонецЦикла;
	
	//поиск максимальных
	ПервоеМакс = 0;
	ВтороеМакс = 0;
	Для Сч = 0 По РазмерМассива - 1 Цикл
		Если МассивЧисел[Сч] > ПервоеМакс Тогда
			ВтороеМакс = ПервоеМакс;
			ПервоеМакс = МассивЧисел[Сч];
		ИначеЕсли МассивЧисел[Сч] > ВтороеМакс Тогда
			ВтороеМакс = МассивЧисел[Сч];
		КонецЕсли;
	КонецЦикла;
	Сообщить("Первое: " + ПервоеМакс);
	Сообщить("Второе: " + ВтороеМакс);
Показать


Пример №1



Пример №2
39. vasilev2015 1413 17.01.19 16:36 Сейчас в теме
(35) да, у нас также получилось. Только мы не использовали, что числа неотрицательные, поэтому присваиваем не нули, а первые элементы.
41. insurgut 196 17.01.19 16:54 Сейчас в теме
(39) ну вместо 0 можно присвоит обоим переменным значение первого элемента массива, а сам цикл начать со второго элемента - результат будет тем же, а условий меньше. Ну и в самом цикле поиска в вашем примере на одно условие больше, можно обойтись всего двумя.
19. sergathome 17.01.19 14:01 Сейчас в теме
Оказывается, из двоичной системы счисления очень удобно переводить в восьмеричную. Каждая триада переходит в одну цифру.

Да, немногие помнют ужо линейку ДВК и славного её дитёныша БК-0010. Там оно изо всех щелей ;)
20. starik-2005 1959 17.01.19 14:01 Сейчас в теме
А вот по заветам Никлауса Вирта - процедурное программирование!
procedure minmax(min, max, ent : double)
begin
  readLn(ent);
  if ent > max them max := ent;
  if ent < min them min := ent;
end;

var min_num, max_num, ent_num : double;
begin
  writeln('Последовательно введите четыре числа, которые необходимо сравнить');

  readLn(ent_num);
  min_num := ent_num;
  max_num := ent_num;

  minmax(min_num, max_num, ent_num);
  minmax(min_num, max_num, ent_num);
  minmax(min_num, max_num, ent_num);

  writeln('Max = ', max_num);
  writeln('Mix = ', min_num);
end.
Показать
44. starik-2005 1959 17.01.19 17:51 Сейчас в теме
(20) кстати, рекурсия - это не цикл!

procedure minmax(i: integer; min, max, ent : double)
begin
  if i < 4 then begin
    readLn(ent);
    if (ent > max) or not i then max := ent;
    if (ent < min) or not i then min := ent;
    minmax(i + 1, min_num, max_num, ent_num);
  end 
  else begin
    writeln('Max = ', max);
    writeln('Mix = ', min);
  end;
end;

var min_num, max_num, ent_num : double;
begin
  writeln('Последовательно введите четыре числа, которые необходимо сравнить');
  minmax(0, min_num, max_num, ent_num);
end.
Показать
23. starik-2005 1959 17.01.19 14:19 Сейчас в теме
Кстати, по поводу квадратного уравнения, то эту задачу вроде бы все должны были в школе еще решать:
введите а, б, ц
д = б * б - 4 * а * ц
если д < 0 тогда Нет корней!
корень1 = (-б + корень(д)) / (2 * а)
если д > 0 тогда корень2 = (-б - корень(д)) / (2 * а)
24. starik-2005 1959 17.01.19 14:24 Сейчас в теме
Кстати, есть такой ресурс - codewars.com - там много интересных задачек.
27. vasilev2015 1413 17.01.19 14:51 Сейчас в теме
(24) у меня узкие интересы: нужно подготовить к ЕГЭ, но ресурс посмотрю.
25. vadim1011985 70 17.01.19 14:42 Сейчас в теме
Тут на инфостарте есть статья по сортировке массивов там есть "Гномья сортировка" которая за один цикл (без вложенных) сортирует массив , поэтому поиск 2-го максимума или минимума можно построить на ней , тогда 1, 2-ой элемент будут 2-мя минимумами , а последний и предпоследний 2-мя максимумами


4. Алгоритм "Гномья сортировка".

Алгоритм так странно назван благодаря голландскому ученому Дику Груну.

Гномья сортировка основана на технике, используемой обычным голландским садовым гномом (нидерл. tuinkabouter). Это метод, которым садовый гном сортирует линию цветочных горшков. По существу он смотрит на следующий и предыдущий садовые горшки: если они в правильном порядке, он шагает на один горшок вперёд, иначе он меняет их местами и шагает на один горшок назад. Граничные условия: если нет предыдущего горшка, он шагает вперёд; если нет следующего горшка, он закончил.
Дик Грун

Вот собственно и все описание алгоритма "Гномья сортировка". Что интересно, алгоритм не содержит вложенных циклов, а сортирует весь массив за один проход.



Функция ГномьяСортировка(Знач Массив)
    
    i = 1;
    j = 2;
    
    Пока i < Массив.Количество() Цикл // Сравнение < - Сортировка по возрастанию, > - по убыванию   
        
        Если Массив[i-1]  
            i = j;
            j = j + 1;
        Иначе
            Замена = Массив[i];
            Массив[i] = Массив[i - 1];
            Массив[i - 1] = Замена;            
            i = i - 1;
            Если i = 0 Тогда
                i = j;
                j = j + 1;
            КонецЕсли;            
        КонецЕсли;        
    КонецЦикла;    
    
    Возврат Массив;    
КонецФункции
Показать



Ссылка на статью
32. herfis 283 17.01.19 15:53 Сейчас в теме
(25)
сортирует весь массив за один проход

Очень лукавая формулировка. Цикл-то один, но "одним проходом" это назвать никак нельзя.
36. insurgut 196 17.01.19 16:30 Сейчас в теме
(25) мы алгоритмы сортировок в институте изучали :)
38. herfis 283 17.01.19 16:35 Сейчас в теме
(25) Слыхал что когда нужно быстро на коленке сообразить хоть какую-то сортировку, то сортировка Шелла хороший кандидат. Типа золотой середины между более эффективными но более сложными алгоритмами и более медленными "учебными" алгоритмами.
28. capitan 1274 17.01.19 14:57 Сейчас в теме
29. starik-2005 1959 17.01.19 15:27 Сейчас в теме
(28) 30 секунд, однако... Странные задачи.
30. capitan 1274 17.01.19 15:47 Сейчас в теме
(29)Это из серии загадок, на которые дети отвечают за пару секунд, а взрослые — за пару часов
давайте сложнее
31. Octopus 337 17.01.19 15:50 Сейчас в теме
34. capitan 1274 17.01.19 16:12 Сейчас в теме
(31)
(33)
Гугл в помощь ) Я тоже не решил
33. vasilev2015 1413 17.01.19 16:04 Сейчас в теме
37. insurgut 196 17.01.19 16:32 Сейчас в теме
40. SlavaKron 17.01.19 16:40 Сейчас в теме
(30) В массиве дат, отсортированном по убыванию.
42. herfis 283 17.01.19 17:14 Сейчас в теме
43. starik-2005 1959 17.01.19 17:18 Сейчас в теме
(30) сначала думал, что в календаре, оказалось, что в словаре. Ну тоже неплохо...
47. roman77 108 18.01.19 16:33 Сейчас в теме
А почему такая дискриминация - только сыновья? У меня дочка в прошлом году готовилась к информатике и ИкТ, успешно сдала. Не буду поддерживать :)
49. vasilev2015 1413 20.01.19 12:12 Сейчас в теме
(47) Исправил в статье https://infostart.ru/public/983886/. Вместо "Отец, Сын" вставил "Родитель, Ребенок".
Оставьте свое сообщение

См. также

Приватный блокчейн и 1С популярно 5

Статья no Нет файла Бесплатно (free) Практика программирования Блокчейн

Две предыдущие публикации на эту тему были сфокусированы преимущественно на технической стороне вопроса. Кроме того, их содержание оказалось понятным не каждому специалисту. В этой статье я постараюсь обяснить для всех и, что говорится, «на пальцах»: что такое приватный блокчейн, когда и зачем его следует применять и на что обратить внимание при использовании этой технологии в 1С.

02.09.2019    1463    mkalimulin    140       

Кодогенерация и метагенерация в 1С 24

Статья Программист Нет файла Бесплатно (free) Практика программирования Математика и алгоритмы Разработка

В своем докладе на конференции INFOSTART EVENT 2018 EDUCATION Дмитрий Белозеров рассказал о разработке инструмента, позволяющего программно работать с метаданными 1С и писать скрипты для выполнения тех же действий, которые выполняет разработчик в конфигураторе –  с какими сложностями и нюансами пришлось столкнуться, и что получилось в итоге.

26.08.2019    3946    kirovsbis    28       

Интеграция сценарного тестирования в процесс разработки 81

Статья Программист Нет файла Бесплатно (free) Практика программирования Разработка

Разработчик системы «Тестер» Дмитрий Решитко в своем докладе на конференции INFOSTART EVENT 2018 EDUCATION показывает, что процесс тестирования можно очень плотно интегрировать в процесс разработки, что внедрение тестирования – это возможность развития программиста как такового, позволяющая ему упорядочивать ход мыслей и оставаться «в фокусе». Навыки построения процесса кодирования на стыке с тестированием сокращают время на концентрацию, освобождают от страха перед изменениями и улучшают память разработчика.

08.07.2019    4363    grumagargler    7       

Управляй качеством кода 1С с помощью SonarQube 220

Статья Программист Нет файла Россия Бесплатно (free) Практика программирования Разработка

Управляй техническом долгом проектов 1С с помощью SonarQube. В статье рассматривается пример применения SonarQube при разработке.

07.07.2019    15890    olegtymko    191       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4721    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7230    m-rv    16       

Семнадцать мгновений весны 12

Статья no Нет файла Бесплатно (free) О жизни

Когда сдал ЕГЭ досрочно.

15.04.2019    2601    vasilev2015    4       

О времени и 1С 206

Статья Программист Нет файла Бесплатно (free) Практика программирования Разработка

Основы и особенности работы со временем в 1С. Как избавиться от боли при работе в разных часовых поясах. Что такое момент времени. И другое.

01.04.2019    15082    YPermitin    58       

Пример создания bridge (http api - tcp) для ККТ "Касса №1" ("К1-Ф") 5

Статья Системный администратор Программист Нет файла Россия Кассовые операции Бесплатно (free) Практика программирования Разработка ККМ

Пример создания bridge (http api - tcp) для ККТ "Касса №1" ("К1-Ф"). Данная статья будет полезна интеграторам, программистам, тем кто работает (интегрирует, разрабатывает) различное ТО либо железки. Версия и релиз технологической платформы не имеет значения.

17.03.2019    2932    dmarenin    0       

Быстрее чем INSERT! BULK-операции и примеры использования 112

Статья Системный администратор Программист Нет файла Бесплатно (free) Производительность и оптимизация (HighLoad) Практика программирования Разработка Внешние источники данных Перенос данных из 1C8 в 1C8

Microsoft SQL Server поддерживает так называемые BULK-операции, используемые для быстрого изменения больших объемов данных в базе. В статье пойдет речь о практических примерах их использования. Все примеры сделаны в контексте платформы 1С (а как иначе).

09.03.2019    9631    YPermitin    38       

Как писать понятные коммиты 67

Статья Программист Нет файла Россия Бесплатно (free) Практика программирования Разработка

Как писать сообщения коммитов так, чтобы потом не было мучительно больно.

06.03.2019    7789    Scorpion4eg    34       

Расширяем свой багаж 2

Статья Программист Нет файла Бесплатно (free) Практика программирования Разработка

Алгоритм решения возможной нетиповой задачи на собеседовании.

29.01.2019    3266    scientes    15       

Подготовка ребёнка* к ЕГЭ по информатике. Часть четвертая 4

Статья Программист Нет файла Бесплатно (free) Практика программирования Разработка

Решение систем логических уравнений повышенного уровня сложности.

25.01.2019    3033    vasilev2015    0       

Подготовка ребенка* к ЕГЭ по информатике. Часть вторая 2

Статья Программист Нет файла Бесплатно (free) Практика программирования

Примеры на Паскале. Если сам родитель* - поддержи ! Если сам водила - посигналь !

19.01.2019    3265    vasilev2015    0       

Быстрая отладка экранных форм документов и справочников 19

Статья Программист Нет файла Бесплатно (free) Практика программирования

Трюк элементарный и я думаю, что большинство моих коллег владеет им, но для тех, кто не знает, он может сэкономить большое количество времени.

18.12.2018    4560    milkers    19       

1С + asterisk (автоматический обзвон) часть 1 38

Статья Системный администратор Программист Нет файла Россия Бесплатно (free) Практика программирования WEB Телефония, SIP

Пример реализации автообзвона (с обработкой ответа на отвечающей стороне) с использованием ami asterisk. Данная статья может быть полезна программистам, интеграторам, администраторам. Версия и релиз технологической платформы не имеет значения.

29.11.2018    7174    dmarenin    9       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 125

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20684    ids79    40       

Развитие 1С программиста 50

Статья Программист Нет файла Бесплатно (free) Практика программирования Личная эффективность

Делюсь своим опытом и видением развития 1С программиста.

17.10.2018    13447    pashamak    62       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20328    tormozit    100       

Записки про metadata.js 53

Статья Программист Нет файла Бесплатно (free) Практика программирования

Отличительные особенности разработки на metadata.js

31.07.2018    9064    1c-intelligence    59       

Учебный курс. Повышение качества разработки. Ошибки программы 96

Статья Программист Нет файла Бесплатно (free) Практика программирования Математика и алгоритмы Рефакторинг и качество кода

Учебный курс по теории и практике программирования. Бесплатно. В виде структурированного текста. Лекции № 3,4,5. Эти лекции посвящены ошибкам программ, их классификации и способам исправления

10.07.2018    15715    Артано    90       

Автоматизируй это! 148

Статья Системный администратор Программист Нет файла Бесплатно (free) Практика программирования

Здравствуйте. Меня зовут Виталий Онянов. Я работаю в компании ФТО. Мы занимаемся внедрением и поддержкой ERP-систем, в том числе и на 1С. Сегодня я хотел бы поделиться нашим опытом автоматизации своих задач и рассказать о том, какие регламентные задания мы настраиваем на серверах наших клиентов. Возможно, кому-то покажется, что это совсем простые и очевидные вещи, но я в своей работе периодически вижу разработчиков, которые делают какие-то задачи руками изо дня в день, и мне бы хотелось донести до них мысль о том, что многие из этих задач можно и нужно автоматизировать.

02.07.2018    16056    Tavalik    12       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19183    olegtymko    43       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21076    m-rv    21       

Учебный курс. Повышение качества разработки. Вводная лекция, часть 2 49

Статья Программист Нет файла Бесплатно (free) Практика программирования Математика и алгоритмы

Учебный курс по теории и практике программирования. Бесплатно. В виде структурированного текста. Лекция №2. Эта лекция посвящена абстракциям, их свойствами и практическому применению в рамках классических парадигм программирования.

24.05.2018    10646    Артано    36       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    16839    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11249    Rustig    9       

Велостыли: Регламентные задания 15

Статья Программист Нет файла Россия Бесплатно (free) Практика программирования

Переделывая очередное «Костыльное» решение, в голову пришла мысль, собрать все странные решения в одну статью, чтобы была некая библиотека о том, как делать не надо (Навеяно вредными советами). Потом понял, что в одну статью не получится все записать, начну с регламентных заданий. Поясню, в данную статью попали примеры из жизни, которые так или иначе реализованы на механизме регламентных заданий, при этом совершенно не всегда этот подход в принципе оправдан.

09.05.2018    10205    dsdred    28       

Веб-разработка на 1Script. Глава 2 64

Статья Программист Нет файла Бесплатно (free) Практика программирования WEB

Продолжение учебника по веб-разработке с помощью фреймворка Oscript.Web. Структура приложения, основные объекты, URL-маршрутизация, универсальная консоль серверов 1С.

22.04.2018    12022    Evil Beaver    27       

Доброе программирование, или сказки для программистов 8

Статья Программист Нет файла Бесплатно (free) Практика программирования

Я попробовал составить список хорошего и доброго, что помогает читающему код жить легче. Возможно, остальные программисты меня поддержат))

03.03.2018    6164    Gladkov_Anton    9       

Минимализмы 3 350

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35378    ildarovich    44       

Веб-разработка на 1Script. Глава 1 250

Статья Программист Нет файла Бесплатно (free) Практика программирования

Разрабатывать веб-приложения должно быть просто. И для этого 1С-ник не должен страдать, изучая десятки и сотни побочных технологий. В конце прошлого года я анонсировал разработку движка веб-приложений на языке 1С. Я планирую выпустить серию статей, оформленных в виде книги, или серии блог-постов, в которых постепенно будут описаны методики разработки сайтов на нашем любимом языке программирования – 1С.

12.02.2018    25505    Evil Beaver    97       

Версионирование правил обмена в Git 64

Статья Программист Нет файла Windows Бесплатно (free) Практика программирования

Статья рассказывает о принципах работы скриптов, позволяющих применять систему контроля версий git и подход gitflow для версионирования правил обмена.

15.12.2017    12917    bforce    22