54-ФЗ: Онлайн-кассы для 1С 7.7 нетиповая

Публикация № 991465

Учет и отчетность - Кассовые операции

14
Подключение онлайн кассы к не типовой 1С 7.7 через драйвер атола v10.

Долго искал как подключить Атол 30Ф к 7.7 через драйвер версии 10. Все, что находил, было платно либо не понять, как использовать. В итоге решил сделать бесплатный шаблон. 

1. Качаем драйвер Атола с их сайта и устанавливаем.

2. В папке с установленным драйвером находим addin_fptr10_x86.dll и регистрируем его через regsvr32

3. Берем и встраиваем в Вашу программу шаблон.

Драйвер успешно работает на WindowsXP Home SP3.

Перем FR 

Процедура ОтветДрайвера(КомандаККМ)
    Result=FR.errorCode();
    ОшибкаПараметра=FR.errorDescription();
    Сообщить("Ответ "+Result+" Ошибка "+ОшибкаПараметра);
КонецПроцедуры


Процедура ПодключениеККМ()
   FR = СоздатьОбъект("AddIn.Fptr10"); 
                                                                                                   //LIBFPTR_MODEL_ATOL_AUTO
    FR.setSingleSetting(FR.LIBFPTR_SETTING_MODEL, строка(FR.LIBFPTR_MODEL_ATOL_30F));
    FR.setSingleSetting(FR.LIBFPTR_SETTING_PORT, строка(FR.LIBFPTR_PORT_COM));
    FR.setSingleSetting(FR.LIBFPTR_SETTING_COM_FILE, 1); //"COM"
    FR.applySingleSettings();
    
    Если FR.open()<>0 тогда //Соединение с ККТ 
        ОтветДрайвера("Подключение ККМ");
        СтатусВозврата(0);
        возврат;
    КонецЕсли;
    
    
    //Запрос параметров
    FR.setParam(FR.LIBFPTR_PARAM_DATA_TYPE, FR.LIBFPTR_DT_STATUS);
    FR.queryData();
                
    НомерКассира    = FR.getParamInt(FR.LIBFPTR_PARAM_OPERATOR_ID);
    состояниеСмены  = FR.getParamInt(FR.LIBFPTR_PARAM_SHIFT_STATE);
    ДатаВремя       = FR.getParamInt(FR.LIBFPTR_PARAM_DATE_TIME);
    РежимККТ        = FR.getParamInt(FR.LIBFPTR_PARAM_MODE);
    ПодрежимККТ     = FR.getParamInt(FR.LIBFPTR_PARAM_SUBMODE);
    НомерЧека        = FR.getParamInt(FR.LIBFPTR_PARAM_RECEIPT_NUMBER);
    НомерДокумента  = FR.getParamInt(FR.LIBFPTR_PARAM_DOCUMENT_NUMBER);
    
       FR.setParam(1021, СокрЛП(Пользователь));
    FR.operatorLogin();

    FR.openShift(); //Открыть смену

    FR.checkDocumentClosed();                
    
    ОтветДрайвера("Подключение ККМ");

КонецПроцедуры  


Процедура РаботаККМ()
    
        //Открыть чек
        FR.setParam(1021, СокрЛП(Пользователь));
        FR.operatorLogin();
        
        Если ВозвратныйЧек=1 Тогда
            FR.setParam(FR.LIBFPTR_PARAM_RECEIPT_TYPE, FR.LIBFPTR_RT_SELL_RETURN);
        Иначе
            FR.setParam(FR.LIBFPTR_PARAM_RECEIPT_TYPE, FR.LIBFPTR_RT_SELL);
        КонецЕсли;
        FR.openReceipt();         
        
        //Продажа
        FR.setParam(FR.LIBFPTR_PARAM_COMMODITY_NAME, ЛЕв(Имя,20));
        FR.setParam(FR.LIBFPTR_PARAM_PRICE, ЦенаПродажи);
        FR.setParam(FR.LIBFPTR_PARAM_QUANTITY, Колич);
        FR.setParam(FR.LIBFPTR_PARAM_TAX_TYPE, FR.LIBFPTR_TAX_NO );
        Если ПустоеЗначение(Маркировка)=0 Тогда
            FR.setParam(1162, СокрЛП(Маркировка));
        КонецЕсли;
        
        Если FR.registration() <> 0 тогда
            ОтветДрайвера("Продажа");
            Возврат;
        КонецЕсли;   
        
        
        //Закрыть чек
        Если ВозвратныйЧек=0 Тогда
            //Оплата
            FR.setParam(FR.LIBFPTR_PARAM_PAYMENT_TYPE, FR.LIBFPTR_PT_CASH);
            FR.setParam(FR.LIBFPTR_PARAM_PAYMENT_SUM, СуммаВКассу);
            FR.payment();
        КонецЕсли;
        
        FR.closeReceipt(); 
        
        
        //Z-отчет
            FR.setParam(1021, СокрЛП(Пользователь));
            //fptr.setParam(1203, '123456789047');
            FR.operatorLogin();
    
            FR.setParam(FR.LIBFPTR_PARAM_REPORT_TYPE, FR.LIBFPTR_RT_CLOSE_SHIFT);
            FR.report();

            FR.checkDocumentClosed();
            
            
        //X-отчет
            FR.setParam(1021, СокрЛП(Пользователь));
            //fptr.setParam(1203, '123456789047');
            FR.operatorLogin();
            
            
            FR.setParam(FR.LIBFPTR_PARAM_REPORT_TYPE, FR.LIBFPTR_RT_X);
            FR.report();

                
        //открыть ящик
        FR.openDrawer();
        
    
КонецПроцедуры

Все подробности о методах можно прочитать в документации к драйверу, примеры нужно смотреть для "делфи" с поправкой на синтаксис 1С 7.7

Во вложенном файле то же самое, это для тех, кто хочет отблагодарить.
 

14

Скачать файлы

Наименование Файл Версия Размер
54-ФЗ: Онлайн-кассы для 1С 7.7 нетиповая:
.ert 17,00Kb
29.01.19
9
.ert 17,00Kb 9 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. user940969 01.02.19 01:01 Сейчас в теме
Как же вовремя статья. Как раз накануне искал как 10-й драйвер Атола подключить. Однозначно плюс
2. monkbest 103 01.02.19 09:05 Сейчас в теме
Есть инфа 100%, что 10й драйвер не нужен, точнее нужен не всегда. Я могу кое-что не так сейчас написать, т.к. не автор драйверов, и это все гипотеза.

Сам поддерживаю 1С7.7 ТиС, который давно не обновлябелен. Цель мероприятия по установке 10ого драйвера в том, чтобы данные в ОФД приходили в новом формате, который не реализован в 8ом драйвере.

Драйвер Атол состоит из 2ух частей: драйвер и служба обмена с ОФД. Драйвер шлет команды в ККМ, а служба шлет данные в ОФД.
Драйвер позволяет работаьь в двух режимах: отправлять в XML формате целиком готовый документ в ККМ или последовательно посылать команды (открыть чек, продать товар 1, продать товар 2, установить скидку, закрыть чек, закрыть смену и т.д.)
В каждой версии драйверов своя dll`ка, для работы через объектную модель и объектная модель собственно разная. Т.е. не просто от версии к версии добавляются новые реквизиты и методы, а они в корне меняются. Обратной совместимости нет. Поэтому автор статьи изучил новую систему команд и реализовал её в 1Сном коде.

После обновления прошивки в ККМ (её делали те, кто обслуживают ККМ) на новый формат, служба EoU стала писать нонстопом ошибку. Видимо, из-за нового формата. Делать нечего, решил что надо ставить 10й драйвер и что-то кодить самому.

Я начал читать документацию по новой системе команд, новой компоненты. Но очень быстро, лень победила и я начал думать. И вот что придумал:

1. Я установил обе версии драйверов
2. Служба EoF запущено от 10й версии
3. COM объект юзаю старый от 8й
4. Обработка торгового оборудования осталась прежней

что нельзя:
нельзя выбить на ККМ новые операции т.к. в 8ом драйвере нет нужных свойств и методов. Всяки авансы, оплаты по банку от физ.лиц...
но в моем случае это и не надо
мне надо:
открыл смену
выбил чек наличными Nраз
закрыл смену

все работает, в офд уходит
5. victuan 3440 16.06.19 07:14 Сейчас в теме
(2) Вы не правы, ДТО8 поддерживает все новые теги, не хуже чем ДТО10.
Готовое решение по ссылке http://infostart.ru/public/603118/
23. phsin 172 01.08.19 18:37 Сейчас в теме
(5) О прекращении поддержки драйверов "АТОЛ: Драйвер ККТ с передачей данных в ОФД (54-ФЗ), 8.x" и "АТОЛ: Драйвер ККТ с передачей данных в ОФД (54-ФЗ), 9.x"
http://1c.ru/news/info.jsp?id=25026

О переходе на ДККТ 10 и прекращении развития и поддержки ДККТ 8 и 9
https://www.atol.ru/company/news/o-perekhode-na-dkkt-10-i-prekrashchenii-razvitiya-i-podderzhki-dkkt-8-i-9-/
3. user1167562 16.05.19 20:32 Сейчас в теме
При работе на 8й версии АТОЛ работает и отправляет, но неверно отправляет ставку НДС, они сменили порядок ставок.
Хорошо быстро обнаружили
4. Санта 11.06.19 10:42 Сейчас в теме
Добрый день! Подскажите пожалуйста по связке 7.7 ТИС и АТОЛ 10?
В Вашем варианте какую dll указывать в настройках торгового оборудования?
6. kalleka 47 24.06.19 13:45 Сейчас в теме
Вариант работает с новыми тегами, которые становятся обязательными с 1 июля?
7. Tarlich 78 02.07.19 21:02 Сейчас в теме
Прошу подсказать :
Тис 9.2 передает в ПечатьЧЕк() списокТоваров (ТаблицаЗначенй)
Данный код работает - все ок!!!
но мне надо добавить цикл что бы печатать товары ,
подскажите как ?
сделал :
Объект.openReceipt(); 		    
	СписокТоваров.ВыбратьСтроки();
	Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл 			 
  Объект.setParam(Объект.LIBFPTR_PARAM_COMMODITY_NAME,СокрЛП(СписокТоваров.ТовНаим));
			Объект.setParam(Объект.LIBFPTR_PARAM_PRICE, СписокТоваров.Цена);
			Объект.setParam(Объект.LIBFPTR_PARAM_QUANTITY, СписокТоваров.Количество);
			Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_NO );
	КонецЦикла;

Печатаеться один товар только .....
11. NikNIklas 09.07.19 11:35 Сейчас в теме
(7) в цикл добавить регистрацию строки Объект.registration();
12. Tarlich 78 09.07.19 11:48 Сейчас в теме
(11)
Объект.registration();

Вот весь мой код :

СписокТоваров.ВыбратьСтроки();
		
		Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл 		
			Объект.openReceipt(); 			
			//Продажа
			Объект.setParam(Объект.LIBFPTR_PARAM_COMMODITY_NAME,СокрЛП(СписокТоваров.ТовНаим));
			Объект.setParam(Объект.LIBFPTR_PARAM_PRICE, СписокТоваров.Цена);
			Объект.setParam(Объект.LIBFPTR_PARAM_QUANTITY, СписокТоваров.Количество);
			Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_NO );			
			Если Объект.registration() <> 0 тогда
				ОтветДрайвера("Продажа",Объект);
				рез = 1;
			КонецЕсли;   	
			//Закрыть чек
			Если ПризнВозврата=0 Тогда
				//Оплата
				Объект.setParam(Объект.LIBFPTR_PARAM_PAYMENT_TYPE, Объект.LIBFPTR_PT_CASH);
				Объект.setParam(Объект.LIBFPTR_PARAM_PAYMENT_SUM, СуммаЧека);
				Объект.payment();
			КонецЕсли;		
			Объект.closeReceipt();    			
		КонецЦикла;
Показать
13. NikNIklas 09.07.19 11:59 Сейчас в теме
(12)
Объект.openReceipt();
Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл
//Продажа
Объект.setParam(Объект.LIBFPTR_PARAM_COMMODITY_NAME,СокрЛП(СписокТоваров.ТовНаим));
Объект.setParam(Объект.LIBFPTR_PARAM_PRICE, СписокТоваров.Цена);
Объект.setParam(Объект.LIBFPTR_PARAM_QUANTITY, СписокТоваров.Количество);
Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_NO );
Если Объект.registration() <> 0 тогда
ОтветДрайвера("Продажа",Объект);
рез = 1;
КонецЕсли;
КонецЦикла; 
//Закрыть чек
Если ПризнВозврата=0 Тогда
//Оплата
Объект.setParam(Объект.LIBFPTR_PARAM_PAYMENT_TYPE, Объект.LIBFPTR_PT_CASH);
Объект.setParam(Объект.LIBFPTR_PARAM_PAYMENT_SUM, СуммаЧека);
Объект.payment();
КонецЕсли;
Объект.closeReceipt();
Показать
8. phsin 172 03.07.19 12:42 Сейчас в теме
Установил версию 10.5.0.0 ДТО
запускаю на win 7

ИмяКомпоненты = "addin_fptr10_x86.dll";
Если ЗагрузитьВнешнююКомпоненту(ИмяКомпоненты) <> 0  Тогда
	Попытка
		driver = СоздатьОбъект("AddIn.Fptr10");
	исключение
		Сообщить("Ошибка при создании объекта "+ИмяКомпоненты,"!");
	конецпопытки;
Иначе
	Сообщить("Ошибка загрузки внешней компоненты "+ИмяКомпоненты+"
	|"+ОписаниеОшибки(),"");
КонецЕсли;
Показать


получаю ошибку:

Ошибка при создании объекта из компоненты C:\1C\test\addin_fptr10_x86.dll (отсутствует интерфейс IInitDone)


можете выложить вашу версию драйвера addin_fptr10_x86.dll ?
14. NikNIklas 10.07.19 12:36 Сейчас в теме
(8) (9) получилось подключить?
21. z5515 4 01.08.19 07:17 Сейчас в теме
(8)(9)(14)

Долго маялся с "addin_fptr10_x86.dll (отсутствует интерфейс IInitDone)"

Потом дошло, ее не надо пытаться подключить как ВК, достаточно зарегистрировать через regsvr32,
и обращаться к объекту "FR = СоздатьОбъект("AddIn.Fptr10"); "
22. NikNIklas 01.08.19 10:01 Сейчас в теме
9. resonance 08.07.19 14:27 Сейчас в теме
( 8) Добрый день, подскажите - удалось ли подключить ФР? отсутствует интерфейс IInitDone Именно такую ошибку получаю
10. NikNIklas 09.07.19 11:34 Сейчас в теме
В настройках указывайте старую длл: FprnM1C.dll. В AddIn - Fptr10
15. resonance 11.07.19 12:58 Сейчас в теме
FprnM1C.dll - указывал и AddIn - Fptr10

ошибка все равно одна и та же - "Служба Frontol не запущена."...
16. victuan 3440 16.07.19 14:08 Сейчас в теме
Готовое решение с поддержкой ДТО8 и ДТО10 по ссылке http://expert.chistov.pro/public/603118/
17. NikNIklas 24.07.19 11:14 Сейчас в теме
1с 7.7 торговля, драйвер 10.5.0, касса по усб. С локального компа на скульной базе печатает влёт. Через РДП касса подключается, видна через параметры и проверку связи, но на печать не выдает ничего: на команду .open() - возвращает "-1" и ошибку "Порт недоступен". В чем может быть затык?.. дрова одинаковые возвращает .version() = 10.5.0.0 в обоих случаях. длл-ки лежат в \bin\, зарегены.. делаю без установки параметров .applySingleSettings()..
18. NikNIklas 25.07.19 09:35 Сейчас в теме
(17) а если указать какой порт подключать, то печатает и с сервера... Вопрос: как программно получить настройку в 7ке порта ККМ из параметров?
19. NikNIklas 29.07.19 15:27 Сейчас в теме
еще ситуация: ГТД и код страны передан в ККТ, в ОФД данные по чеку появились, а на самом чеке этих данных нет.. Лог кассы без ошибок. Это Атол 25Ф. При этом 22птк в тестовых режимах печатал всё.
20. NikNIklas 30.07.19 09:52 Сейчас в теме
24. phsin 172 02.08.19 14:12 Сейчас в теме
Стандартные драйвера подружить не удалось, пришлось делать COM обертку... https://infostart.ru/public/1102431/
Оставьте свое сообщение

См. также

1С 7.7: Обработка для печати чеков на ККМ ШТРИХ формата ФДД 1.05 1

Инструменты и обработки Программист Бухгалтер Пользователь Внешняя обработка (ert,epf) v7.7 1cv7.md Россия БУ Windows Кассовые операции Розничная торговля Абонемент ($m) ККМ

Обработка позволяет печатать чеки формата ФДД 1.05 на кассовом аппарате ШТРИХ. Проверялась на версиях драйвера 4.14.721 - 749.

1 стартмани

03.04.2019    2078    3    user872794    1       

Обработка обслуживания торгового оборудования. 1С: 7.7 ТиС 0

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ 1С7:ТиС Россия Кассовые операции Абонемент ($m) ККМ

Обработка обслуживания для 1с 7.7 ТиС. Версия драйвера ККТ Атол 8.16.5.9221 Обработка предназначена для корректной передачи СНО при пробитии чека.

1 стартмани

18.01.2019    5178    18    artmaks1988    47       

1С 7.7 ARCUS2 Эквайринговые Терминалы Ingenico (iPP320, iCT250 и т.п.) 1

Инструменты и обработки Системный администратор Программист Архив с данными v7.7 1cv7.md Россия Кассовые операции Розничная торговля Абонемент ($m) POS терминал

Использование внешней компоненты для терминалов Ingenico в 1С 7.7. Демо-база с функциями в глобальном модуле и обработкой, демонстрирующей возможности работы с терминалом. Глобальная функция управления терминалом подходит для любой базы данных, предназначенной для расчетов с клиентами. Тестировалась на конфигурациях: Торговля и склад 7.7, Бухгалтерия 7.7 и Упрощенное налогообложение 7.7.

1 стартмани

28.11.2018    3621    16    e-rogov    8       

Работа с пробитыми чеками по БД Атол 4

Инструменты и обработки Программист Архив с данными v7.7 1cv7.md Windows Кассовые операции Абонемент ($m) Разработка внешних компонент ККМ

Получение данных о пробитых чеках по ККМ Атол драйверов версии 8 на ОФД СБИС.

1 стартмани

13.07.2018    4827    1    pakko    7       

Поддержка Онлайн ККМ АТОЛ. Доработка ТиС 7.7 (Бюджетное решение) v 1.0 4

Инструменты и обработки Системный администратор Архив с данными v77::ОУ 1С7:ТиС Россия УУ Кассовые операции Абонемент ($m) ККМ

Релиз ТиС 7.70.987. Комплекс позволяет быстро и бюджетно подключить клиенту печать чеков на технике АТОЛ: АТОЛ 30Ф, АТОЛ 55Ф, АТОЛ 22Ф, АТОЛ 52Ф, АТОЛ 11Ф, АТОЛ 90Ф.

1 стартмани

09.07.2018    6425    6    zoeh    6       

54-ФЗ/Онлайн-кассы: Работа с фискальным регистратором на 1С: 7.7 0

Инструменты и обработки Программист Бухгалтер Архив с данными v7.7 Кассовые операции Розничная торговля Абонемент ($m) Фискальный регистратор

Конфигурация содержит минимальный функционал для работы с фискальными регистраторами на платформе 1С: 7.7. Если у Вас нет учетной системы, но необходимо соответствовать 54-ФЗ, с минимальными затратами, то эта конфигурация для Вас. Код полностью открыт и распространяется как есть.

10 стартмани

09.06.2018    5390    1    Atom74    0       

Бухгалтерская справка для 1Сv7.7 Бух 4.5 2

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух БУ Дебиторская и кредиторская задолженность Кассовые операции Абонемент ($m) Обработка документов

Внешняя обработка "Бухгалтерская справка" v0.1 (12.01.2018) Вводится на основании документа "Отгрузка товаров, продукции".

1 стартмани

12.01.2018    6513    kulkrise    10       

Загрузка в 1С 7.7 УСН 1.3 данных из ОФД о денежных поступлениях (чеках) 0

Инструменты и обработки Бухгалтер Архив с данными v77::БУ 1С7:Бух Россия БУ Кассовые операции Абонемент ($m) Обработка документов Загрузка и выгрузка в Excel

Если Ваша торговая точка (ККМ) отделена от 1С 7.7 УСН, а вносить поступление наличных за день в 1С:Бухгалтерию надо, то автоматизировать процесс оформления наличных в 1С:Бухгалтерию можно!

2 стартмани

02.12.2017    9627    5    ah7777777    2       

Учет кассы. 1C: 7.7 0

Отчеты и формы Бухгалтер Руководитель проекта Конфигурация (md, cf) v7.7 УУ Зарплата Кассовые операции Розничная торговля Абонемент ($m) Управление торговлей

Простенькая конфигурация на платформе 7.7 для ведения учета денежных средств, заработной платы.

1 стартмани

10.08.2017    7810    1    pafikus0880    0       

Оболочка для работы с последними драйверами ККМ АТОЛ для 1С 7.7, 8.1 18

Инструменты и обработки Системный администратор Программист Компонента, плагин (dll, vbs,..) v77::ОУ 1С7:ТиС Кассовые операции Абонемент ($m) Разработка внешних компонент ККМ

Внешняя компонента - оболочка для работы в среде 1С 7.7 или 1С 8.1 с последними версиями драйверов ККМ от АТОЛ. Поддерживаются драйвера x32 начиная с версии 9.11. Присутствует внешняя обработка для полноценной работы с данными драйверами (поддержка ревизий 2.0, 2.1, 2.2, поддержка протокола ОФД 1.0, 1.0.5, 1.1).

1 стартмани

09.08.2017    30345    269    asdfghgghjdhg    103       

54-ФЗ: Онлайн-касса (кассы). 1С 7.7 + Атол 55Ф ДТО8/10 4

Инструменты и обработки Программист Внешняя обработка (ert,epf) v7.7 1cv7.md БУ Кассовые операции Абонемент ($m) ККМ

Обработка ККМ-онлайн для нетиповой 1С:7.7 с печатью на несколько касс. Поддержка тегов 1227,1228. Поддержка версий драйверов ККТ: ДТО8, ДТО10 для Атол. Исходный код открыт.

1 стартмани

23.06.2017    15561    43    vakham    8       

Обработка подключения онлайн-кассы к 1С 7.7 (ПОЛУФАБРИКАТ) 9

Инструменты и обработки Программист Бухгалтер Архив с данными v7.7 1С7:Бух Россия БУ Кассовые операции Абонемент ($m) ККМ

Обработка обслуживания торгового оборудования для печати чеков ККМ. Протестирована на Конфигурации бухгалтерский учет (7.70.634) с кассой АТОЛ 30 Ф, Печать ПКО и РКО. Также работает на Торговля + Склад.

2 стартмани

31.05.2017    31256    113    Di_Denis    43       

Подключение Онлайн кассы Штрих М к 1С 7.7 5

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v7.7 1cv7.md Кассовые операции Розничная торговля Абонемент ($m) Разработка внешних компонент ККМ

Подключение онлайн кассы Штрих М к любой конфигурации 1С 7.7. Показаны основные приемы работы с драйвером. Обработка представляет из себя набор готовых функций для встраивания в свою конфигурацию: ИнициализироватьФР(); ПодключитьФР(); ОтключитьФР(); ОткрытьСмену(); ЗакрытьСмену(); НапечататьЧек(); АннулироватьЧек(); СнятьХОтчет().

1 стартмани

08.05.2017    19396    74    crimeait    2       

FR_Atol_Shtrih.exe печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54ФЗ поддержка изменений от 01/07/19). Для 1С (7.7 и:8 УФ, Обычных Формы) есть готовые обработки 68

Инструменты и обработки Системный администратор Программист Архив с данными v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Windows Кассовые операции Оптовая торговля Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

7 стартмани

11.04.2017    50884    173    ah7777777    473       

Свод по кассовым документам 1

Отчеты и формы Бухгалтер Руководитель проекта Внешний отчет (ert,erf) v77::ОУ 1С7:ТиС Россия УУ Кассовые операции Абонемент ($m) Бухгалтерские Управленческие

Отчет формирует сводные данные по документам кассы в различных комбинациях. Два уровня группировки.

1 стартмани

26.01.2017    6467    3    ionfox    0       

Печать кассовой книги для нескольких счетов учета 0

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::БУ 1С7:Бух 1С7:ПУБ Россия БУ Кассовые операции Абонемент ($m) Бухгалтерские

Если в организации касса ведется в разрезе нескольких субсчетов счета 50, то данная обработка позволяет печатать кассовую книгу отдельно на каждый субсчет.

1 стартмани

30.09.2016    5619    1    tany69    1       

Печать штрих-кодов из 1С: 7.7 Комплексная конфигурация 1

Инструменты и обработки Программист Бухгалтер Архив с данными v7.7 1С7:Комплекс 1С7:ТиС Windows Кассовые операции Абонемент ($m) Ценники Рабочее место

Для тех кто работает на 7 платформе, и не собирается с неё переходить. Стандартная печать этикеток по одной шт за раз совсем даже не интересна. Мне при внедрении штрих кодирования мне помогла обработка

1 стартмани

21.06.2016    18106    7    agent00mouse    5       

Печать документов для Казахстана из Российских конфигураций 1С:7.7 "Комплексная конфигурация ред. 4.5" и "Торговля и Склад ред. 9.2" 2

Отчеты и формы Бухгалтер Архив с данными v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Казахстан УУ Windows Кассовые операции Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Печатные формы документов

Печатные формы документов Республики Казахстан, адаптированные для 1С:Комплексная конфигурация ред.4.5. Формы утверждены приказом Министра финансов Республики Казахстан от 20 декабря 2012 года №562 (далее Приказ 562).

1 стартмани

20.05.2016    12501    2    aserg    1       

Обработка для 1С ТиС 9.2 для работы с ККМ Offline под РМК Штрих-М Кассир 1.*\2.*\5.* 3

Инструменты и обработки Системный администратор Руководитель проекта Архив с данными v77::ОУ 1С7:ТиС Россия Windows Кассовые операции Розничная торговля Абонемент ($m) ККМ

Обработки предназначены для 1С: Предприятие 7.7 типовой конфигурации Торговля и Склад 9.2. Сделано несколько существенных изменений по отношению к стандартной обработке Off_spos. И доработана обработка "Загрузка ККМ Off-Line".

1 стартмани

28.08.2015    24554    35    4       

Подключение фискального регистратора MG N707TS, MG-T777TL, MG-T787TL по http (TCP/IP) протоколу JSON 11

Инструменты и обработки Системный администратор Программист Архив с данными v7.7 v8 1cv8.cf 1cv7.md Украина Windows Кассовые операции Розничная торговля Абонемент ($m) Фискальный регистратор

Тестовая конфигурация и пример работы по общению с фискальным регистратором MG N707TS, MG-T787TL, MG-T777TL по HTTP протоколу командами в формате JSON. Обратите внимание, что аппарат может работать и классическим методом по RS232 - подробнее тут http://infostart.ru/public/317286/, но производитель уделяет больше внимания протоколу HTTP JSON (TCP/IP) Добавили еще обработку по работе с кассовым аппаратом MG-V545T по схожему принципу детальнее ... http://infostart.ru/public/530619/ Добавил обработку обслуживания для подключения торгового оборудования. Огромное спасибо ВСЕМ КТО ПОМОГ , участвовал в создании этой обработки.

1 стартмани

09.07.2015    33607    95    mar_a    23       

Пакетная печать расходных кассовых ордеров в Бухгалтерии 7.7 0

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Windows Кассовые операции Абонемент ($m) Пакетная печать

Внешняя обработка выводит на печать все расходные кассовые ордера за выбранный период.

1 стартмани

17.05.2015    7678    1    vv-adm    1       

Кассовая книга и архив книг для 1С 7.7 любой конфигурации 3

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v7.7 1cv7.md Россия БУ Windows Закрытие периода Кассовые операции ИП, ПБОЮЛ, КФХ Абонемент ($m) Бухгалтерские

Комплекс внешних обработок для удобного ведения в электронной форме кассовой книги формы №КО-4. Все функции редактирования кассовой книги, добавление записей инкассации, сквозная нумерация, печать приходных кассовых ордеров №КО-1 и расходных кассовых ордеров №КО-2. Возможность автоматического заполнения кассовой книги из журнала документов вашей ИБ (любой конфигурации).

5 стартмани

27.04.2015    29100    19    etmarket    11       

Изменение банковского счета в документах - 1С Бухгалтерия 7.7 0

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Windows Банковские операции Кассовые операции Абонемент ($m) Обработка документов

Иногда случается, что в справочнике дублируются записи. Это легко поправимо, если дублирующая запись не была использована в документах. В противном случае надо вручную выбирать во всех документах нужный элемент. А если количество документов тысячи - уйдет уйма времени... Данная обработка решает эту проблему! Просто выбрать старый счет (который планируем заменить) и новый (на который заменяем). Полезно.

1 стартмани

02.04.2015    7458    program345    9       

Подключение фискального регистратора Мини ФП54 через интернет бета 0

Инструменты и обработки Программист Архив с данными v7.7 1cv7.md Украина Windows Абонемент ($m) ККМ

В продолжении темы подключения фискальных регистраторов через интернет http://infostart.ru/public/91545/.

1 стартмани

08.12.2014    17956    7    assa    4       

Препроводительная ведомость (2018) для Бухгалтерии 4.5, УСН 1.3 7.7 0

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Windows Кассовые операции Абонемент ($m) Печатные формы документов

Это препроводительная ведомость с изменениями для 2018 года (ведомость, накладная и квитанция к сумке; добавлена возможность работы с купюрами 2000 и 200 руб). Сделана первоначально Yury1001 для ТиС http://infostart.ru/public/312283/ , нами доработана для Бухгалтерии 4.5,УСН 1.3 7.7.

2 стартмани

20.11.2014    6332    7    Ион    0       

Заявление на выдачу денег под отчет (внешняя печатная форма) 1

Отчеты и формы no Внешний отчет (ert,erf) v7.7 1С7:ПУБ Россия БУ Windows Кассовые операции Абонемент ($m) Печатные формы документов

Внешняя печатная форма "Заявления о выдачи денег под отчет" для документа "Расходно-кассовый ордер".

1 стартмани

17.06.2014    15981    21    Sadan32    1       

Печать чеков на Штрих-М-ФР-К в RDP (Удаленные филиалы) 5

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v77::ОУ 1С7:ТиС Россия Windows Кассовые операции Абонемент ($m) Печатные формы документов ККМ

Печать на Штрих-М-ФР-К через "Удаленный рабочий стол" RDP в филиалах. При печати через RDP в филиалах столкнулись с проблемой медленной печати и подключение Фискальных регистраторов к 1С. Эта обработка автоматически находит к какому порту подключен ФР и подключает его со всеми установленными настройками.

1 стартмани

28.02.2014    28716    63    Ronin    5       

Отчет о движении денежных средств в 1С 7.7 ТиС 0

Отчеты и формы Бизнес-аналитик Бухгалтер Пользователь Внешний отчет (ert,erf) v77::ОУ 1С7:ТиС УУ Windows Банковские операции Кассовые операции Абонемент ($m) Управленческие

Отчет объединяет и представляет в удобном виде движения денежных средств по кассам и расчетным счетам.

1 стартмани

05.02.2014    11059    49    sonic112    1       

"Заявление на выдачу подотчет" для РКО 0

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Windows Кассовые операции Абонемент ($m) Печатные формы документов

Внешняя печатная форма: Заявление на выдачу денежных средств подотчет (для 1С: Бухгалтерия 7.7)

1 стартмани

10.10.2013    7105    29    SotNick    1       

Выгрузка-загрузка касс, персонала и дисконта. 19

Инструменты и обработки no Внешняя обработка (ert,epf) v7.7 1С7:ТиС Розничная и сетевая торговля (FMCG) Розничная торговля Абонемент ($m) POS терминал ККМ Фискальный регистратор

Данная обработка совмещает в себе выгрузку-загрузку (поддерживает различные режимы, как с документа, так и подбором), выгрузка дисконтных карт и персонала.

1 стартмани

23.07.2013    19880    19    kodinsklpz    11       

Внешняя компонента для работы с ККМ Искра "Прим-07К" 5

Инструменты и обработки Системный администратор Программист Компонента, плагин (dll, vbs,..) v7.7 1cv7.md БУ Windows Кассовые операции Абонемент ($m) Разработка внешних компонент ККМ Фискальный регистратор

Бесплатная внешняя компонента для 1С7.7, позволяющая работать с фискальными регистраторами производства Искра, такими как ПРИМ-07К, ПРИМ-08ТК и пр.

1 стартмани

18.06.2013    19657    64    sandyanf    3       

Обработка автоматической разноски денег по Кассе\Банку для сетевых (и не только) контрагентов для ТиС 7.7 2

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::ОУ 1С7:ТиС Россия Windows Банковские операции Кассовые операции Абонемент ($m) Обработка документов Рабочее место

Обработка позволяет в несколько кликов разнести деньги (касса или банковская выписка) по контрагенту, папке контрагентов либо по сетевому контрагенту (анализ по ИНН). Предварительно формируется список долговых документов с указанием суммы долга.

1 стартмани

11.06.2013    8452    19    iDim    2