КД 2.0. Перенос документов 7.7 - 7.7. Передача параметра "Проведен"

21.12.11

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

1С:Конвертация данных 2.0. Решение проблемы проведения документов при переносе между базами 7.7

При использовании конфигурации "Конвертация данных 2.0" для переноса документов между базами 7.7 не переносится статус документа, а именно: "Проведен", "Помечен на удаление".

Все документы при переносе стандартным механизмом "садятся" непроведенными.

При использовании ПКС "Проведен" появляется ошибка "Не верное имя реквизита Документ.ХХХ.Проведен".

Для решения данной проблемы нам придется:

  1. Добавить код в процедуру ПКО "ПриВыгрузке":


УзелПараметра = DOMDocument.СоздатьУзел(1, "ЗначениеСтатуса", "");
УзелПараметра.УстановитьАтрибут("ИмяПараметра", "Статус");
Если
Источник.Проведен()=1 тогда
    
Статус = "Проведен";
ИначеЕсли
Источник.ПометкаУдаления()=1 тогда
    
Статус = "ПомеченНаУдаление";
Иначе
    
Статус = "НеПроведен";
КонецЕсли;
УзелПараметра.УстановитьАтрибут("ЗначениеПараметра", Статус);
Приемник.ДобавитьПодчиненный(УзелПараметра);

  1. "Подправить" модуль загрузки в процедуре "ЗагрузитьДокументV8()". В конце добавляем:


УзелСтатус
= Объект.ВыбратьУзел("ЗначениеСтатуса");

Статус      =   УзелСтатус.ПолучитьАтрибут("ЗначениеПараметра");

Если
Статус = "Проведен" Тогда
   Если
ОбъектБД.ПометкаУдаления() = 1 Тогда
        
ОбъектБД.СнятьПометкуУдаления();
   КонецЕсли;

   Попытка
       
ОбъектБД.Провести();
   Исключение
      
Сообщить(""+ОписаниеОшибки());
   КонецПопытки;

ИначеЕсли
Статус = "ПомеченНаУдаление"  Тогда
   
ОбъектБД.Удалить(0);
Иначе
   Если
ОбъектБД.Проведен()=1 Тогда
        
ОбъектБД.СделатьНеПроведенным();
   ИначеЕсли
ОбъектБД.ПометкаУдаления() =1 Тогда
        
ОбъектБД.СнятьПометкуУдаления();
   КонецЕсли;
КонецЕсли;

См. также

Файловый обмен (TXT, XML, DBF), FTP Учет документов Распознавание документов и образов Бухгалтер Пользователь Платформа 1С v7.7 Платформа 1С v8.3 Платформа 1C v8.2 Конфигурации 1cv8 Конфигурации 1cv7 Россия Платные (руб)

Программный комплекс способный распознавать сотни листов за раз любых сканированных(фото) документов (УПД, ТОРГ12, СФ, паспорт и пр.) и загружать их в любую 1С (БП3.0, УТ, КА, УНФ, УПП, 1С7.7 ТиС, ЗУП3 и пр.), а также формировать архив сканированных документов.<br> Робот применяет до 5 способов распознавания. Максимальное качество загрузки документов из бесплатных OCR. Работает без Интернета.

10800 руб.

13.10.2022    8118    1    12    

9

Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Программист Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Торговля и склад 7.7 1С:Бухгалтерия 1.6 1С:Упрощенное налогообложение 7.7 Россия Бухгалтерский учет Абонемент ($m)

Обмениваемся УПД (УКД) с различными контрагентами через СБИС. А чтобы загрузить УПД (УКД) из 7.7 в Сбис, используем данную обработку, которая создает файл в формате XML, который можно импортировать в систему электронного документооборота. Для конфигурации "Бухгалтерский учет" (тестировалась на релизе 7.70.663) Для конфигурации "Упрощенная система налогообложения" ( тестировалась на релизе 7.70.305) Для конфигурации "Торговля и Склад 7.7" (тестировалась на релизе 7.70.1007)

1 стартмани

31.07.2021    15636    222    AndKovalchuk    50    

18

Перенос данных 1C Программист Платформа 1С v7.7 Платформа 1С v8.3 Платформа 1C v8.2 1С:Управление торговлей 10 1С:Комплексная 7.7 Россия Управленческий учет Платные (руб)

Начните вести учет в УТ 10.3! Перенесите все свои данные в УТ 10.3 в любом месяце года и продолжите вести учет! Программа перенесёт любое количество баз с документами и остатками в больших количествах. Обработка выгрузки выполнит проверку исходных данных и сформирует отчет о найденных ошибках в справочниках и документах. Партии переносятся с себестоимостью. Штрихкоды номенклатуры загружаются. Цена переносится. Автор консультирует.

8400 руб.

17.03.2021    15743    5    13    

6

Зарплата Перенос данных 1C Программист Бухгалтер Бухгалтерский учет 7.7 Сложные периодические расчеты 1С:Бухгалтерия 7.7 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

Как известно, Бухгалтерия 7.7 не имеет штатной возможности для обмена с ЗУП 3.1. Данная разработка пригодится тем, кто перешел с ЗиК 2.3 на ЗУП 3.1, но вынужден по каким-то своим причинам оставаться на Бухгалтерии 7.7.

18000 руб.

29.09.2020    13680    2    0    

5

Файловый обмен (TXT, XML, DBF), FTP Перенос данных 1C Программист Платформа 1С v7.7 Платформа 1С v8.3 1С:Бухгалтерия 7.7 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Перенос данных из 1С:Бухгалтерия 7.7 в БП 3.0 | Продукт является развитием и исправлением ошибок стандартной обработки для выгрузки данных из 1С Бухгалтерии 7.7 в Бухгалтерию 3.0 | Предоставляем техподдержку | Обновляем на новые релизы 1С | Перенос из 7.7 является сложным, и на рынке сложно найти специалистов 1С по "семерке" - сотрудники помогут вам выполнить переход в рамках техподдержки предлагаемого переноса данных!

45650 руб.

26.05.2020    34574    10    70    

16

Перенос данных 1C Программист Платформа 1С v7.7 Платформа 1С v8.3 1С:Торговля и склад 7.7 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Обработка позволяет выгружать данные из ТиС 7.7 в конфигурации 8.3 для сдачи отчетности, для переноса данных при переходе на 8.3, для организации обмена внутри компании при использовании разных версий 1С в структурных подразделениях или формирования отгрузочных накладных для клиентов.

6000 руб.

18.05.2020    23200    59    39    

36

Перенос данных 1C Программист Платформа 1С v7.7 Платформа 1С v8.3 1С:Конвертация данных Бесплатно (free)

При переходе на новую версию 1С в период параллельной эксплуатации может возникнуть необходимость обратной конвертации данных (по правилам КД версии 2.1) из 1С:Предприятие 8.3 в 1С:Предприятие 7.7 для переноса данных из 1С:Предприятие 8.3 в 7.7. Сделать это поможет следующая инструкция по КД2 о том, как создать новую конвертацию из 8.3 в 7.7, сохранить модуль и правила загрузки данных, сделать загрузку данных. КД2.

17.10.2019    14559    ksnik    0    

16
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. fancy 35 21.12.11 07:33 Сейчас в теме
"1. Добавить код в процедуру ПКО "После загрузки":" - Может быть "После выгрузки" документа - я так понимаю добавляем подчиненный узел "ЗначениеСтатуса" в xml?
2. xazrad 15 21.12.11 09:53 Сейчас в теме
(1) Совершенно верно. только в ПКО "ПриВыгрузке". Исправил в публикации. Спасибо за замечание
3. Alav 13 21.12.11 11:49 Сейчас в теме
В принципе если совесть позволяет править конфигу и обмен будет постоянный, то можно добавить 2 общих реквизита Проведен и ПометкаУдаления. Тогда КД при переносе их автоматом будет заполнять и после загрузки уже можно анализировать их и делать телодвижения в документе.


Автору плюс однозначно, просто привел альтернативу решению автора
4. Boroda 90 21.12.11 18:51 Сейчас в теме
Интересно, надо попробовать. Автору спасибо.
5. fomix 33 22.12.11 12:51 Сейчас в теме
А что мешает использовать в обработчике "ПослеЗагрузки" ПКО любого документа волшебные слова "РежимЗаписи = "Проведение""????
9. Alav 13 24.12.11 11:26 Сейчас в теме
(5) если не ошибаюсь для 7-ки это не работает. Но в любом случае речь идет о передачи всех документов, а не только проведенных, поэтому так без условно проводить нельзя (например в источнике документ сняли с проведения или пометили на удаления, нужно в получателе сделать тоже самое, иначе данные будут расходиться, ведь мы уже выгрузили этот документ, так как он был проведен)
6. Модератор раздела 23.12.11 15:42 Сейчас в теме
Аналогичная разработка давно есть на ИС
http://infostart.ru/public/21069/
Детали уже особо не помню.
У автора сабжа юзается другой подход, верно?
7. xazrad 15 23.12.11 17:27 Сейчас в теме
(6) другой. как мне известно параметры при переносу из 7.7 в 7.7 не передаются а в http://infostart.ru/public/21069/ используются параметры
8. Модератор раздела 24.12.11 11:06 Сейчас в теме
(6) Параметры передать для 77 несложно. я в свое время как раз решал задачу проведения документов и решил проблему передачи параметров.
10. mig2k 27.12.11 11:27 Сейчас в теме
Однако, не работает:
Ошибка исполнения обработчика: ПКО_ПриВыгрузке_ПоступлениеТМЦ
- Поле агрегатного объекта не обнаружено (СоздатьУзел)
Говорит, у этого объекта нет такого метода:
УзелПараметра = DOMDocument.СоздатьУзел(1, "ЗначениеСтатуса", "");
11. xazrad 15 27.12.11 17:34 Сейчас в теме
(10) попробуй так
УзелПараметра = DOMDocument.createNode(1, "ЗначениеСтатуса", "");
УзелПараметра.setAttribute("ИмяПараметра", "Статус");
Если Источник.Проведен()=1 тогда
Статус = "Проведен";
ИначеЕсли Источник.ПометкаУдаления()=1 тогда
Статус = "ПомеченНаУдаление";
Иначе
Статус = "НеПроведен";
КонецЕсли;

УзелПараметра.setAttribute("ЗначениеПараметра", Статус);
Приемник.appendChild(УзелПараметра);
12. ChessCat 13.02.12 14:41 Сейчас в теме
Пара моментов

>2 "подправить" модуль загрузки в процедуре "ЗагрузитьДокументV8()"
В ПКО есть обработчики "При загрузке" и "После загрузки". При чем тут процедура "ЗагрузитьДокументV8()" если речь идет о конвертации между 7.7 и 7.7 ?

Момент второй. Бросается в глаза

Если ОбъектБД.ПометкаУдаления() = 1 Тогда
ОбъектБД.СнятьПометкуУдаления();
КонецЕсли;

По всей видимости же не ОбъектБД а Объект
13. K_Andrey 09.05.12 11:45 Сейчас в теме
Выдает ошибку при загрузке:

Статус = УзелСтатус.ПолучитьАтрибут("ЗначениеПараметра");
(2958)}: Значение не представляет агрегатный объект (ПолучитьАтрибут)
14. K_Andrey 09.05.12 12:36 Сейчас в теме
15. Vigor06 07.11.12 11:27 Сейчас в теме
Не получается подправить под конвертацию 8.2 УТ -> 7.7 Учет и отчетность предпринимателя
Во 2м шаге,как я правильно понял,меняем
	ЗаписатьОбъект(ОбъектБД);
	
	Если ПустоеЗначение(ПометкаУдаления) = 1 Тогда
		Если Объект.ПометкаУдаления() = 1 Тогда    ОбъектБД.СнятьПометкуУдаления();  КонецЕсли;
	Иначе
		Если Объект.ПометкаУдаления() = 0 Тогда    ОбъектБД.Удалить(0);  КонецЕсли;
	КонецЕсли

на
ЗаписатьОбъект(ОбъектБД);
УзелСтатус = Объект.ВыбратьУзел("ЗначениеСтатуса");
Статус      =   УзелСтатус.ПолучитьАтрибут("ЗначениеПараметра");

Если Статус = "Проведен" Тогда
   Если ОбъектБД.ПометкаУдаления() = 1 Тогда
        ОбъектБД.СнятьПометкуУдаления();
   КонецЕсли;

   Попытка
       ОбъектБД.Провести();
   Исключение
      Сообщить(""+ОписаниеОшибки());
   КонецПопытки;

ИначеЕсли Статус = "ПомеченНаУдаление"  Тогда
   ОбъектБД.Удалить(0);
Иначе
   Если ОбъектБД.Проведен()=1 Тогда
        ОбъектБД.СделатьНеПроведенным();
   ИначеЕсли ОбъектБД.ПометкаУдаления() =1 Тогда
        ОбъектБД.СнятьПометкуУдаления();
   КонецЕсли;
КонецЕсли;
Показать


А вот как правильно прописать в правилах конвертации шаг1 - ну никак не могу((
16. Nik777x 14.11.13 21:31 Сейчас в теме
(15) Vigor06, Также пытаюсь перенести документы из УТ 8.2 11.1 в Тис 7.7. Примеров переноса из 7.7 в 7.7 и из 8.2 в 8.2 достаточно, а как правильно описать из 8.2 в 7.7 пока не нашел. Vigor06 если разобрался подскажи как сделал.
17. Xershi 1504 27.11.14 15:18 Сейчас в теме
Как решить вопрос проведения документов в конвертации 8.2 -> 7.7 кто разобрался?
Оставьте свое сообщение