Перенос остатков по дисконтным картам (картам лояльности) в УТ 11

25.08.20

Учетные задачи - Оптовая торговля

Как перенести данные о накоплениях по дисконтным картам из других программ в УТ 11.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Перенос остатков по дисконтным картам (картам лояльности) в УТ 11:
.epf 8,59Kb
11
11
1 SM
Скачать Купить за 1 850 руб.

В данной статье хочу поделиться опытом переноса данных о накплениях по дисконтным картам из 1С 7.7 ТиС (Excel) в УТ 11.

Прежде всего, в 1С 7.7 ТиС нет стандартного функционала работы с накопительными картами, поэтому каждый дописывает конфигурацию как хочет. В итоге перенос данных проводился с помощью Excel, что делает данный метод более универсальным.

Столкнувшись с такой проблемой впервые, я полез в интернет в поисках ответа. Результат оказался не очень информативным:

Накопление производится не по карте а по партнеру.
Соответственно, нужно просто ввести данные о продажах за предыдущий период.
Продажи хранятся в регистре ВыручкаИСебестоимостьПродаж

Это можно сделать корректировкой регистров.

С уважением,
отдел тех. поддержки "1С"

1С:Предприятие 8.2 (8.2.17.153) "Управление торговлей ", редакция 11.0 (11.0.9.15)
Ситуация: был переход с «Управление Торговлей» редакция, 10.3 на «Управление Торговлей» редакция,11.0. Необходимо внести в «Управление Торговлей» редакция,11.0 накопленные суммы скидок по накопительным картам. Подскажите, как внести эти данные

Весь процесс можно разделить на несколько этапов:

  1. Создаение контрагентов (партнеров). На этом шаге я подробно останавливаться не буду т.к. контрагенты создаются либо при типовом переносе данных из одной базы в другую, либо универсальной обработкой. Важно, что у всех партнеров должна стоять галочка "Клиент", иначе не будет доступа к картам лояльности
  2. Создание карт лояльности. На данном шаге так же можно воспользоваться универсальной обработкой по загрузке данных в справочник
  3. Создание ключей аналитик. По номенклатуре создаем предварительно руками. По партнерам ключи создаются автоматически обработкой
  4. Создание и заполнение документа Корректировка регистров

 Основная сложность всего этого процесса заключается в том, что мы не можем воспользоваться универсальной обработкой по загрузке в табличную часть документа т.к. табличной частью документа Корректировка регистров является состав регистров, а дальше формируется динамическая таблица.
Поэтому мне пришлось написать небольшую обработку, которой я и выполняю 3 и 4 пункт инструкции.

&НаСервере
Процедура ВыполнитьЗагрузкуНаСервере()
	
	Док = Документы.КорректировкаРегистров.СоздатьДокумент();
	Док.Дата = ТекущаяДата();
	ДвиженияКорр = Док.Движения;
	
	СтрокаРег = док.ТаблицаРегистров.Добавить();
	СтрокаРег.Имя = Метаданные.РегистрыНакопления.ВыручкаИСебестоимостьПродаж.Имя;
	
	док.Записать();
	
	перемОрганизация = Справочники.Организации.НайтиПоНаименованию("Наше ИП");
	
	ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
	ТабДок = ОбработкаОбъект.ПолучитьМакет("Макет");
	Для текСтрока = 1 По ТабДок.ВысотаТаблицы Цикл
		текКлиент = ТабДок.Область(текСтрока,1).Текст;
		текСумма = ТабДок.Область(текСтрока,3).Текст;
		
		
		СтрокаЗапись = док.Движения.ВыручкаИСебестоимостьПродаж.Добавить();
		СтрокаЗапись.Период = Дата("2019", "01", "01");
		СтрокаЗапись.Активность = Истина;
		СтрокаЗапись.Регистратор = Док.Ссылка;
		СтрокаЗапись.АналитикаУчетаНоменклатуры = Справочники.КлючиАналитикиУчетаНоменклатуры.НайтиПоНаименованию("для регистра",Истина);
		
		//сначала поищем в регистре сведений
		Запрос = Новый Запрос;
		Запрос.Текст = 
			"ВЫБРАТЬ ПЕРВЫЕ 1
			|	АналитикаУчетаПоПартнерам.КлючАналитики КАК КлючАналитики
			|ИЗ
			|	РегистрСведений.АналитикаУчетаПоПартнерам КАК АналитикаУчетаПоПартнерам
			|ГДЕ
			|	АналитикаУчетаПоПартнерам.Партнер = &Партнер
			|	И АналитикаУчетаПоПартнерам.Организация = &Организация
			|	И АналитикаУчетаПоПартнерам.Контрагент = &Контрагент";
		
		Запрос.УстановитьПараметр("Контрагент", Справочники.Контрагенты.НайтиПоНаименованию(текКлиент));
		Запрос.УстановитьПараметр("Организация", Справочники.Организации.НайтиПоНаименованию("Наше ИП"));
		Запрос.УстановитьПараметр("Партнер", Справочники.Партнеры.НайтиПоНаименованию(текКлиент));
		
		РезультатЗапроса = Запрос.Выполнить();
		
		ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
		
		перемНашли = Ложь;
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
			перемКлюч = ВыборкаДетальныеЗаписи.КлючАналитики;
			перемНашли = Истина;
		КонецЦикла;

		Если перемНашли Тогда
			
		Иначе
			//надо поискать в справочнике ключей
			перемКлюч = Справочники.КлючиАналитикиУчетаПоПартнерам.НайтиПоНаименованию(текКлиент+"; "+перемОрганизация.Наименование+"; "+текКлиент);
			Если перемКлюч <> Справочники.КлючиАналитикиУчетаПоПартнерам.ПустаяСсылка() Тогда
				//у нас есть ключ в справочнике но нет в регистре
				//дальше нам надо эту запись закинуть и в регистр сведений
				НоваяЗапись = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьМенеджерЗаписи();
				НоваяЗапись.Партнер = Справочники.Партнеры.НайтиПоНаименованию(текКлиент);
				НоваяЗапись.Организация = перемОрганизация;
				НоваяЗапись.Контрагент = Справочники.Контрагенты.НайтиПоНаименованию(текКлиент);
				НоваяЗапись.КлючАналитики = перемКлюч;
				НоваяЗапись.Записать(Истина);				
			Иначе
				//создаем ключ аналитики
				НовыйСпр = Справочники.КлючиАналитикиУчетаПоПартнерам.СоздатьЭлемент();
				НовыйСпр.Организация = Справочники.Организации.НайтиПоНаименованию("Наше ИП");
				НовыйСпр.Контрагент = Справочники.Контрагенты.НайтиПоНаименованию(текКлиент);
				НовыйСпр.Партнер = Справочники.Партнеры.НайтиПоНаименованию(текКлиент);
				НовыйСпр.Наименование = текКлиент+"; "+НовыйСпр.Организация.Наименование+"; "+текКлиент;
				НовыйСпр.Записать();
				перемКлюч = НовыйСпр.Ссылка;
				
				//дальше нам надо эту запись закинуть и в регистр сведений
				НоваяЗапись = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьМенеджерЗаписи();
				НоваяЗапись.Партнер = Справочники.Партнеры.НайтиПоНаименованию(текКлиент);
				НоваяЗапись.Организация = перемОрганизация;
				НоваяЗапись.Контрагент = Справочники.Контрагенты.НайтиПоНаименованию(текКлиент);
				НоваяЗапись.КлючАналитики = перемКлюч;
				НоваяЗапись.Записать(Истина);
			КонецЕсли;
		КонецЕсли;
	
		СтрокаЗапись.АналитикаУчетаПоПартнерам = перемКлюч;
		СтрокаЗапись.ТипЗапасов = Перечисления.ТипыЗапасов.Товар;
		СтрокаЗапись.ВидЗапасов = Справочники.ВидыЗапасов.НайтиПоНаименованию("Собственный товар; Организация: Наше ИП");
		СтрокаЗапись.РазделУчета = Перечисления.РазделыУчетаСебестоимостиТоваров.ТоварыНаСкладах;
		СтрокаЗапись.СуммаВыручки = текСумма;
		СтрокаЗапись.СуммаВыручкиБезНДС = текСумма;
		СтрокаЗапись.ВалютаВзаиморасчетов = Справочники.Валюты.НайтиПоНаименованию("RUB");
		СтрокаЗапись.ВалютаДокумента = Справочники.Валюты.НайтиПоНаименованию("RUB");
		СтрокаЗапись.СуммаВВалютеВзаиморасчетов = текСумма;
		СтрокаЗапись.СуммаВВалютеДокумента = текСумма;
		СтрокаЗапись.СуммаВыручкиРегл = текСумма;
		СтрокаЗапись.СуммаВыручкиСНДСРегл = текСумма;
		СтрокаЗапись.ВидДеятельностиНДС = Перечисления.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС;
		СтрокаЗапись.ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.РеализацияКлиенту;
		СтрокаЗапись.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС;
		
	КонецЦикла;

	док.Записать();
	
КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьЗагрузку(Команда)
	ВыполнитьЗагрузкуНаСервере();
КонецПроцедуры

Ключ учета номенклатуры я предварительно создал в справочнике (Ключи аналитики учета номенклатуры)


Элементы в справочнике Ключи анатилики учета по партнерам и Регистре сведений Аналитика учета по партнерам у меня предварительно ищутся по скольку клиент уже работал в данной базе на момент загрузки данных.
Данные о накоплениях по картам лояльности скопированы в макет обработки

В заключении хочу сказать, что в процессе работы обращался к нескольким статьям в интернете по заполнению документа Корректировка регистров, но не все они содержали достоверную информацию.

Кроме этого, очень много времени было потрачено из-за того, что я создавал элемент справочника Ключи аналитики учета по партнерам, но не делал соответствующую запись в регистр сведений Аналитика учета по партнерам. Об этом тоже мало где говориться на просторах всемирной паутины. 

И не забудьте подставлять корректные суммы в ресурсы, если ваша тоговля проходит с НДС

Код обработки писал "на коленке", поэтому на оптимальность не претендую. Цель статьи заключается в том, что бы помочь систематизировать знания о работе карт лояльности в УТ и о процессе их загрузки через документ Корректировка регистров, и указать на некоторые подводные камни

УТ 11 Карты лояльности

См. также

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    93362    119    40    

210

Оптовая торговля Розничная торговля Обмен с ГосИС Бухгалтер Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    168473    755    364    

394

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    786910    4739    9507    

2812

Розничная торговля Маркетплейсы Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Платные (руб)

Модуль для интеграции 1С с сервисом СберМаркет/Купер. Предназначен для обмена данными из торговых точек розничных сетей из баз данных 1С в базы данных СберМаркет/Купер, для отображения информации по товарам, остаткам, ценам, заказам и статусам заказов. Позволяет оперативно начать работать с сервисом СберМаркет, существенно повысить продажи и лояльность клиентов.

35000 руб.

14.10.2022    8558    15    13    

10

Оптовая торговля Розничная торговля Обмен с ГосИС Программист Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

5000 руб.

18.03.2019    111702    28    114    

181

SALE! %

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 27000 руб.

24.04.2015    192345    140    241    

272
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. VCPro 248 07.03.19 11:27 Сейчас в теме
(0) В общем смысле перенос данных о накоплениях по дисконтным картам происходит из электронный таблицы. Поэтому нужно только придумать каким образом достать данные из вашей изначальной базы (например написать отчет)
2. duck 408 20.02.20 08:02 Сейчас в теме
Добрый день!
В идеале бы еще и обработку приложить, чтобы не собирать ее самому из кода:)
3. ir-ish-ka 22.07.20 19:20 Сейчас в теме
Добрый день!
Не знаю, была ли такая возможность на момент написания статьи.
В документах "Ввод начальных остатков" есть "Розничные продажи за прошлые периоды"
Как раз он и делает движения по регистру "Выручка и себестоимость продаж"
axae; muskul; Spacer; +3 Ответить
7. muskul 30.12.20 04:30 Сейчас в теме
(3)Когда ИТС реально пригодился
4. mrlakec 24.08.20 14:11 Сейчас в теме
А возможно оформить в виде обработки?
5. VCPro 248 25.08.20 04:50 Сейчас в теме
(4) прикрепил к публикации
6. mrlakec 16.10.20 16:42 Сейчас в теме
(5) Спасибо. А не подскажете, каким отчетом лучше достать данные из УТ 10.3?
8. VCPro 248 30.12.20 08:55 Сейчас в теме
(6) в УТ 10.3 должен быть отчет "Продажи по дисконтным картам"
9. axae 110 15.09.21 10:55 Сейчас в теме
А у нас в УТ11 есть типовой документ ввода начальных остатков "Розничные продажи за прошлые периоды", там это делается. Хотя коммерческие директора в шоке от образовавшейся выручки, которая к тому же без себестоимости. Всё-таки лучше бы в УТ11 отдельно хранились бы эти накопления...
Оставьте свое сообщение