Перенос остатков по дисконтным картам (картам лояльности) в УТ 11

Публикация № 1011494

Учет и отчетность - Оптовая торговля

УТ 11 Карты лояльности

Как перенести данные о накоплениях по дисконтным картам из других программ в УТ 11.

В данной статье хочу поделиться опытом переноса данных о накплениях по дисконтным картам из 1С 7.7 ТиС (Excel) в УТ 11.

Прежде всего, в 1С 7.7 ТиС нет стандартного функционала работы с накопительными картами, поэтому каждый дописывает конфигурацию как хочет. В итоге перенос данных проводился с помощью Excel, что делает данный метод более универсальным.

Столкнувшись с такой проблемой впервые, я полез в интернет в поисках ответа. Результат оказался не очень информативным:

Накопление производится не по карте а по партнеру.
Соответственно, нужно просто ввести данные о продажах за предыдущий период.
Продажи хранятся в регистре ВыручкаИСебестоимостьПродаж

Это можно сделать корректировкой регистров.

С уважением,
отдел тех. поддержки "1С"

1С:Предприятие 8.2 (8.2.17.153) "Управление торговлей ", редакция 11.0 (11.0.9.15)
Ситуация: был переход с «Управление Торговлей» редакция, 10.3 на «Управление Торговлей» редакция,11.0. Необходимо внести в «Управление Торговлей» редакция,11.0 накопленные суммы скидок по накопительным картам. Подскажите, как внести эти данные

Весь процесс можно разделить на несколько этапов:

  1. Создаение контрагентов (партнеров). На этом шаге я подробно останавливаться не буду т.к. контрагенты создаются либо при типовом переносе данных из одной базы в другую, либо универсальной обработкой. Важно, что у всех партнеров должна стоять галочка "Клиент", иначе не будет доступа к картам лояльности
  2. Создание карт лояльности. На данном шаге так же можно воспользоваться универсальной обработкой по загрузке данных в справочник
  3. Создание ключей аналитик. По номенклатуре создаем предварительно руками. По партнерам ключи создаются автоматически обработкой
  4. Создание и заполнение документа Корректировка регистров

 Основная сложность всего этого процесса заключается в том, что мы не можем воспользоваться универсальной обработкой по загрузке в табличную часть документа т.к. табличной частью документа Корректировка регистров является состав регистров, а дальше формируется динамическая таблица.
Поэтому мне пришлось написать небольшую обработку, которой я и выполняю 3 и 4 пункт инструкции.

&НаСервере
Процедура ВыполнитьЗагрузкуНаСервере()
	
	Док = Документы.КорректировкаРегистров.СоздатьДокумент();
	Док.Дата = ТекущаяДата();
	ДвиженияКорр = Док.Движения;
	
	СтрокаРег = док.ТаблицаРегистров.Добавить();
	СтрокаРег.Имя = Метаданные.РегистрыНакопления.ВыручкаИСебестоимостьПродаж.Имя;
	
	док.Записать();
	
	перемОрганизация = Справочники.Организации.НайтиПоНаименованию("Наше ИП");
	
	ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
	ТабДок = ОбработкаОбъект.ПолучитьМакет("Макет");
	Для текСтрока = 1 По ТабДок.ВысотаТаблицы Цикл
		текКлиент = ТабДок.Область(текСтрока,1).Текст;
		текСумма = ТабДок.Область(текСтрока,3).Текст;
		
		
		СтрокаЗапись = док.Движения.ВыручкаИСебестоимостьПродаж.Добавить();
		СтрокаЗапись.Период = Дата("2019", "01", "01");
		СтрокаЗапись.Активность = Истина;
		СтрокаЗапись.Регистратор = Док.Ссылка;
		СтрокаЗапись.АналитикаУчетаНоменклатуры = Справочники.КлючиАналитикиУчетаНоменклатуры.НайтиПоНаименованию("для регистра",Истина);
		
		//сначала поищем в регистре сведений
		Запрос = Новый Запрос;
		Запрос.Текст = 
			"ВЫБРАТЬ ПЕРВЫЕ 1
			|	АналитикаУчетаПоПартнерам.КлючАналитики КАК КлючАналитики
			|ИЗ
			|	РегистрСведений.АналитикаУчетаПоПартнерам КАК АналитикаУчетаПоПартнерам
			|ГДЕ
			|	АналитикаУчетаПоПартнерам.Партнер = &Партнер
			|	И АналитикаУчетаПоПартнерам.Организация = &Организация
			|	И АналитикаУчетаПоПартнерам.Контрагент = &Контрагент";
		
		Запрос.УстановитьПараметр("Контрагент", Справочники.Контрагенты.НайтиПоНаименованию(текКлиент));
		Запрос.УстановитьПараметр("Организация", Справочники.Организации.НайтиПоНаименованию("Наше ИП"));
		Запрос.УстановитьПараметр("Партнер", Справочники.Партнеры.НайтиПоНаименованию(текКлиент));
		
		РезультатЗапроса = Запрос.Выполнить();
		
		ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
		
		перемНашли = Ложь;
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
			перемКлюч = ВыборкаДетальныеЗаписи.КлючАналитики;
			перемНашли = Истина;
		КонецЦикла;

		Если перемНашли Тогда
			
		Иначе
			//надо поискать в справочнике ключей
			перемКлюч = Справочники.КлючиАналитикиУчетаПоПартнерам.НайтиПоНаименованию(текКлиент+"; "+перемОрганизация.Наименование+"; "+текКлиент);
			Если перемКлюч <> Справочники.КлючиАналитикиУчетаПоПартнерам.ПустаяСсылка() Тогда
				//у нас есть ключ в справочнике но нет в регистре
				//дальше нам надо эту запись закинуть и в регистр сведений
				НоваяЗапись = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьМенеджерЗаписи();
				НоваяЗапись.Партнер = Справочники.Партнеры.НайтиПоНаименованию(текКлиент);
				НоваяЗапись.Организация = перемОрганизация;
				НоваяЗапись.Контрагент = Справочники.Контрагенты.НайтиПоНаименованию(текКлиент);
				НоваяЗапись.КлючАналитики = перемКлюч;
				НоваяЗапись.Записать(Истина);				
			Иначе
				//создаем ключ аналитики
				НовыйСпр = Справочники.КлючиАналитикиУчетаПоПартнерам.СоздатьЭлемент();
				НовыйСпр.Организация = Справочники.Организации.НайтиПоНаименованию("Наше ИП");
				НовыйСпр.Контрагент = Справочники.Контрагенты.НайтиПоНаименованию(текКлиент);
				НовыйСпр.Партнер = Справочники.Партнеры.НайтиПоНаименованию(текКлиент);
				НовыйСпр.Наименование = текКлиент+"; "+НовыйСпр.Организация.Наименование+"; "+текКлиент;
				НовыйСпр.Записать();
				перемКлюч = НовыйСпр.Ссылка;
				
				//дальше нам надо эту запись закинуть и в регистр сведений
				НоваяЗапись = РегистрыСведений.АналитикаУчетаПоПартнерам.СоздатьМенеджерЗаписи();
				НоваяЗапись.Партнер = Справочники.Партнеры.НайтиПоНаименованию(текКлиент);
				НоваяЗапись.Организация = перемОрганизация;
				НоваяЗапись.Контрагент = Справочники.Контрагенты.НайтиПоНаименованию(текКлиент);
				НоваяЗапись.КлючАналитики = перемКлюч;
				НоваяЗапись.Записать(Истина);
			КонецЕсли;
		КонецЕсли;
	
		СтрокаЗапись.АналитикаУчетаПоПартнерам = перемКлюч;
		СтрокаЗапись.ТипЗапасов = Перечисления.ТипыЗапасов.Товар;
		СтрокаЗапись.ВидЗапасов = Справочники.ВидыЗапасов.НайтиПоНаименованию("Собственный товар; Организация: Наше ИП");
		СтрокаЗапись.РазделУчета = Перечисления.РазделыУчетаСебестоимостиТоваров.ТоварыНаСкладах;
		СтрокаЗапись.СуммаВыручки = текСумма;
		СтрокаЗапись.СуммаВыручкиБезНДС = текСумма;
		СтрокаЗапись.ВалютаВзаиморасчетов = Справочники.Валюты.НайтиПоНаименованию("RUB");
		СтрокаЗапись.ВалютаДокумента = Справочники.Валюты.НайтиПоНаименованию("RUB");
		СтрокаЗапись.СуммаВВалютеВзаиморасчетов = текСумма;
		СтрокаЗапись.СуммаВВалютеДокумента = текСумма;
		СтрокаЗапись.СуммаВыручкиРегл = текСумма;
		СтрокаЗапись.СуммаВыручкиСНДСРегл = текСумма;
		СтрокаЗапись.ВидДеятельностиНДС = Перечисления.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС;
		СтрокаЗапись.ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.РеализацияКлиенту;
		СтрокаЗапись.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС;
		
	КонецЦикла;

	док.Записать();
	
КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьЗагрузку(Команда)
	ВыполнитьЗагрузкуНаСервере();
КонецПроцедуры

Ключ учета номенклатуры я предварительно создал в справочнике (Ключи аналитики учета номенклатуры)


Элементы в справочнике Ключи анатилики учета по партнерам и Регистре сведений Аналитика учета по партнерам у меня предварительно ищутся по скольку клиент уже работал в данной базе на момент загрузки данных.
Данные о накоплениях по картам лояльности скопированы в макет обработки

В заключении хочу сказать, что в процессе работы обращался к нескольким статьям в интернете по заполнению документа Корректировка регистров, но не все они содержали достоверную информацию.

Кроме этого, очень много времени было потрачено из-за того, что я создавал элемент справочника Ключи аналитики учета по партнерам, но не делал соответствующую запись в регистр сведений Аналитика учета по партнерам. Об этом тоже мало где говориться на просторах всемирной паутины. 

И не забудьте подставлять корректные суммы в ресурсы, если ваша тоговля проходит с НДС

Код обработки писал "на коленке", поэтому на оптимальность не претендую. Цель статьи заключается в том, что бы помочь систематизировать знания о работе карт лояльности в УТ и о процессе их загрузки через документ Корректировка регистров, и указать на некоторые подводные камни

Скачать файлы

Наименование Файл Версия Размер
Перенос остатков по дисконтным картам (картам лояльности) в УТ 11:

.epf 8,59Kb
25.08.20
3
.epf 8,59Kb 3 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. VCPro 110 07.03.19 11:27 Сейчас в теме
(0) В общем смысле перенос данных о накоплениях по дисконтным картам происходит из электронный таблицы. Поэтому нужно только придумать каким образом достать данные из вашей изначальной базы (например написать отчет)
2. duck 291 20.02.20 08:02 Сейчас в теме
Добрый день!
В идеале бы еще и обработку приложить, чтобы не собирать ее самому из кода:)
3. ir-ish-ka 22.07.20 19:20 Сейчас в теме
Добрый день!
Не знаю, была ли такая возможность на момент написания статьи.
В документах "Ввод начальных остатков" есть "Розничные продажи за прошлые периоды"
Как раз он и делает движения по регистру "Выручка и себестоимость продаж"
4. mrlakec 24.08.20 14:11 Сейчас в теме
А возможно оформить в виде обработки?
5. VCPro 110 25.08.20 04:50 Сейчас в теме
(4) прикрепил к публикации
6. mrlakec 16.10.20 16:42 Сейчас в теме
(5) Спасибо. А не подскажете, каким отчетом лучше достать данные из УТ 10.3?
Оставьте свое сообщение

См. также

Проблема сопоставления товара при приемке маркированной продукции на примере обуви в конфигурации 1С:Розница

Оптовая торговля Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

В статье описывается проблема сопоставления товара при приемке товаров маркированной продукции применительно к типовым конфигурациям на примере 1С:Розница.

1 стартмани

16.11.2020    429    gzharkoj    0    

Работа с табачной продукцией в УТ 11.4

Оптовая торговля Розничная торговля v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Практическая работа с маркированным товаром - табачной продукцией (с изюминкой).

1 стартмани

28.09.2020    1077    zemskov    13    

Обход ошибки "Нет статуса" у акцизных марок при переходе в розницу с крепким алкоголем на остатках

Розничная торговля v8 Розница Россия УУ Абонемент ($m)

В связи с маркировкой табака и обуви приходится многих людей переводить на новую Розницу 2.3.3 и выше, но если человек имеет на остатках крепкий алкоголь, то при продаже такого товара вы увидите ошибку "Невозможно добавить алкогольную продукцию по причине: Статус: Нет статуса". В данной статье мы рассмотрим способ обхода данной проблемы, и импортируем марки из старой конфигурации.

1 стартмани

10.07.2020    1940    virusas    8    

Соответствие типов данных 1С:Предприятие 8.x в MS SQL 2008 Промо

Практика программирования Администрирование данных 1С Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Соответствие типов данных 1С:Предприятие 8.x и MS SQL 2008

1 стартмани

13.01.2013    22382    YPermitin    8    

1С:Розница и алкоголь: ускоряем РМК при переходе к оплате

Розничная торговля Рабочее место v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

При наличии в чеке акцизных марок алкогольной продукции наблюдаются некоторые зависания при переходе к оплате чека в 1С:Розница.

1 стартмани

29.01.2020    3827    RocKeR_13    30    

Автоматизация процесса формирования документов реализации в лизинговой компании

Бухгалтерия Оптовая торговля v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Лизинговым компаниям каждый месяц приходится формировать большое количество документов реализации в соответствии с графиком платежей, указанным в договоре. Ввиду того, что имеются все необходимые данные, процесс может быть автоматизирован.

1 стартмани

20.11.2019    2535    yurikmellon    4    

Сравнение скорости загрузки большого массива данных из табличного документа с помощью Microsoft EXCEL через COM и с помощью платформы 1С 8.х

Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Тестирование COM MS Excel на сервере 1С и нативное чтение табличных документов в 1С.

3 стартмани

08.09.2019    3680    nomad_irk    26    

Обмен с интернет-магазином на платформе DOCPART

WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Абонемент ($m)

В настоящее время существует множество платформ для создания интернет-магазинов. Удобные и не очень, платные или бесплатные. У каждого решения найдутся свои сторонники, но наличие оперативного обмена с учётной системой важно для любой платформы. В этой публикации мы рассмотрим одну из популярных платформ для создания интернет-магазина по продаже автозапчастей Docpart и организацию обмена данными с ней.

10 стартмани

04.07.2019    5038    Johny_v    18    

Печать чеков на Меркурии 119Ф USB по сети

Фискальный регистратор Кассовые операции Оптовая торговля Розничная торговля Кассовые операции Оптовая торговля Розничная торговля v8 1cv8.cf Россия НУ Абонемент ($m)

Стандартный драйвер Меркурия 119Ф usb не позволяет осуществлять печать на фискальный регистратор с другого компьютера, поэтому был сделан простейший http сервер, который транслирует post запросы в вызовы методов com-объекта.

1 стартмани

06.06.2019    5320    philya    6    

EGAIS Scan - приложение для ТСД

Терминал сбора данных Мобильная разработка Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 УТ10 УПП1 УТ11 КА2 Россия УУ Абонемент ($m)

Каждый, кто занимается торговлей алкогольной продукцией, сталкивался с проблемами сканирования акцизных марок и трудностями при взаимодействии с учетной системой 1С. Приложение EGAIS Scan - простое и оптимальное решение для выполнения быстрой приемки и отгрузки алкогольной продукции.

1 стартмани

17.04.2019    5424    MrChe    3    

Автоматическое уведомление клиентов по электронной почте в программе 1С: УВС

Email Документооборот и делопроизводство Оптовая торговля Документооборот и делопроизводство Оптовая торговля v8 1С:УВС Россия Абонемент ($m)

В данной статье предлагается внешняя обработка для конфигурации 1С: Управление ветеринарными сертификатами, выполняющая автоматическую рассылку писем по электронной почте клиентам компании, с целью уведомления о сформированных ветеринарно-сопроводительных документах.

1 стартмани

12.04.2019    4019    Астиг    0    

Подключение ТСД через MobileLogistics 8.Х на примере Opticon SMART и создание простого расширения для выгрузки остатков

Розничная торговля Терминал сбора данных Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

В статье рассмотрен процесс подключения терминала сбора данных в конфигурацию 1С:Розница редакции 2.2 при помощи драйвера "АТОЛ:Терминалы сбора данных MobileLogistics 8.Х" на примере ТСД Opticon SMART (CLK-3000) и написание расширения для корректной выгрузки остатков. Типовая обработка от 1С остатки не выгружает. Материал ориентирован на новичков в сфере подключения торгового оборудования / написании расширений.

1 стартмани

07.03.2019    17452    1c.pro.fun    21    

Раскрашенный log-файл без HTML и СМС (используем Форматированный документ в личных целях)

Практика программирования Оптовая торговля Оптовая торговля Разработка v8::ОУ УТ11 КА2 Россия УУ Абонемент ($m)

Иногда пользователям отдается на откуп загрузка каких то данных, результат загрузки которых желательно раскрасить если и не всеми цветами радуги, то хотя бы светофором. Один из вариантов – это использовать Форматированную строку. Следите за руками:

1 стартмани

08.02.2019    3222    kembrik    2    

Вывод веса и объема номенклатуры в УТ 11

Оптовая торговля Практика программирования Оптовая торговля v8 УТ11 Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Статья ориентирована на программиста и содержит пример реализации вывода веса и объема номенклатуры В ТЧ "Товары" документа "ЗаказКлиента" в УТ 11.4.

1 стартмани

03.12.2018    6019    triviumfan    10    

Подключение онлайн касс (ФЗ-54) к старой 1С конфигурации УТ 10.2. Описание и реализация проекта

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Статья предназначена в первую очередь начинающим 1С программистам, а также будет полезна знакомым с ИТ-спецификой управленцам, пред которыми встанет вопрос об интеграции новой онлайн кассы, работающей по ФЗ-54 со старой информационной системой. В статье изложен ряд возможных подходов к решению задачи и показана реализация оптимального в данном случае варианта. Здесь нет готового тиражного решения, с одной стороны это пример реализации как иллюстрация к тексту, а с другой это рабочая программа для случая описанного ниже и если ваш случай похож, то решение с минимальными затратами может быть адаптировано. Также я слегка приоткрыл «фрилансерскую кухню».

1 стартмани

28.11.2018    10678    Petr54-ru    20    

Альтернативный пересчет упаковок товаров в типовых конфигурациях

Практика программирования Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::ОУ УТ11 КА2 Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Рассмотрен вариант пересчета упаковок, при котором исходное количество товара не изменяется, а происходит пересчет упаковок друг относительно друга.

1 стартмани

24.11.2018    10684    gzharkoj    10    

Весы МАССА-К ВПМ 15.2 - Т1. Путеводитель по настройке и подключению. Интеграция в 1С:Розница

Весы Розничная торговля Розничная торговля v8 Розница Абонемент ($m)

Самая подробная инструкция по подключению, настройке и интеграции весов МАССА - К ВПМ 15.2 - Т1 в 1С:Розница.

2 стартмани

12.07.2018    34940    user594264_e.sitnik    29    

Работа с курьерами при продаже через интернет-магазин

Бухгалтерский учет Розничная торговля Розничная торговля v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Хочу рассказать о нашем опыте автоматизации работы с курьерами с помощью 1С Управление Торговлей 11. Как учитывать товар, выданный курьерским компаниям для доставки, и как видеть состояние взаиморасчетов с курьерками? Как учитывать продажи при доставке силами собственных курьеров, принимать оплату, и пробивать чеки ККМ.

1 стартмани

13.06.2018    16819    Kutuzov    7    

Вывод товаров в СКД как на весах в Ашане

Практика программирования Розничная торговля Розничная торговля v8::СКД 1cv8.cf Абонемент ($m)

Небольшая хитрость, которая позволяет выводить информацию на СКД плиткой.

2 стартмани

23.05.2018    14048    Kutuzov    14    

Как переходили с 7-ки на 8-ку. Пример небольшого розничного магазина

Перенос данных из 1С7.7 в 1C8.X Бухгалтерский учет Розничная торговля Ценообразование, анализ цен Розничная торговля Ценообразование, анализ цен v8 v77::ОУ 1С7:ТиС УТ11 Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Пример проекта из нашей практики - перевод учета в небольшом розничном магазине с 1С v7 Торговля и Склад на 1С v8 Управление Торговлей. Какими инструментами пользовались, какие вопросы возникали на проекте.

1 стартмани

15.05.2018    16178    Kutuzov    15    

Ошибка в бонусной системе в типовой УТ11

Адаптация типовых решений Розничная торговля Розничная торговля v8 v8::ОУ УТ11 УУ Абонемент ($m)

При проведении нескольких розничных возвратов по одному клиенту по одному отчету о розничных продажах расчет бонусных баллов в типовой конфигурации выполняется некорректно. В данной статье рассмотрено исправление этой ошибки.

1 стартмани

10.05.2018    11491    Kutuzov    0    

Yep Cart. Пишем интернет-магазин на http-сервисах OneScript

Оптовая торговля Розничная торговля OneScript v8 УУ Абонемент ($m)

В статье описана демонстрационная конфигурация, реализующая простейший интернет магазин на http-сервисах OneScript, интегрированный с 1С:Предприятие.

1 стартмани

16.04.2018    16712    blackhole321    33    

Настройка и подключение кассы АТОЛ в 1С 8.3 ффд 1.05

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 Розница БП3.0 УТ11 Россия Абонемент ($m)

Инструкция для подключения кассы по новому протоколу ффд 1.05.

1 стартмани

14.04.2018    136551    ZIGER666    156    

Организация обмена с базой филиала (розничного магазина) в торговой сети через XML (универсальный обмен)

Обмен через XML Перенос данных из 1C8 в 1C8 Розничная торговля Розничная торговля v8 КД УТ11 Розничная и сетевая торговля (FMCG) Абонемент ($m)

В статье по шагам рассматривается создание обмена между центральной базой и базами филиалов на базе конфигурации УТ 11. Для решения поставленной задачи было решено не использовать РИБ, т.к. требуется односторонний обмен ограниченным набором данных, к тому же по определенным условиям. Обмен реализован на основе типовой синхронизации на основе универсального обмена в формате EnterpriseData. Данная публикация может быть полезна внедренцам, которые работают с торговыми сетями, в том числе по модели франчайзинга.

1 стартмани

26.02.2018    37068    Kutuzov    18    

Препарирование xlsx файлов без MS Excel

Загрузка и выгрузка в Excel v8 1cv8.cf Россия Абонемент ($m)

Зоопарк офисных программ? WPS Office, MS Office, Open Office? В статье пойдет речь о том, как отредактировать XLSX файлы без создания COM-объектов.

1 стартмани

28.08.2017    16919    Сурикат    0    

Быстрое заполнение данными файла MS EXCEL

Практика программирования Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Процедура для 1С быстрого заполнения данными произвольного файла MS Excel. Источник данных - текст с разделителями.

1 стартмани

13.07.2017    12437    dusha0020    4    

Опыт интеграции 1С с системой Меркурий (Часть 5)

Внешние источники данных Интеграция Оптовая торговля Оптовая торговля v8::ОУ 1cv8.cf Сельское хозяйство и рыболовство Транспорт, автопарки, такси Оптовая торговля, дистрибуция, логистика Пищевая промышленность Россия БУ УУ Абонемент ($m)

Описывается опыт внедрения в 1С системы работы с ветеринарно-сопроводительными документами Меркурий. Интеграция еще в процессе и приветствуется обмен опытом.

1 стартмани

10.07.2017    59585    axxell    33    

Выбор значения из выпадающего списка с поиском и переходом к ячейке с таким значением в Excel

Практика программирования Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Поиск и переход к ячейке выполняется при помощи макроса. Макрос, как и сама книга, формируются программно в 1С.

1 стартмани

30.06.2017    18457    xrrg    0    

Практика создания заказной внешней печатной формы для УТ 11.3

Печатные формы документов Оптовая торговля Оптовая торговля v8 v8::ОУ УТ11 Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Внешняя печатная форма "Счёт на оплату" для конфигурации Управление торговлей, редакция 11.3

1 стартмани

09.05.2017    25538    zemskov    11    

Инвентаризация и корректировка остатков ЕГАИС в 1С: Управление небольшой фирмой (инструкция)

Бухгалтерский учет Розничная торговля Учет ТМЦ Розничная торговля Учет ТМЦ v8::ОУ УНФ Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

1С выпустило обновление конфигурации Управление небольшой фирмой(1.6.7.63), добавили удобный Помошник корректировки остатков ЕГАИС

1 стартмани

01.12.2016    15999    user635667    0    

Адресная система хранения на складе

Практика программирования Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 УУ Абонемент ($m)

Решение тестового задания. Разбор ошибок.

1 стартмани

22.10.2016    11227    vasvl123    6    

Руководство пользователя. УТ 10.3 Рабочее место кассира.

Пользователю системы Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 КА1 УТ10 Россия УУ Абонемент ($m)

Развернутая инструкция для работы пользователя в типовом интерфейсе кассира конфигурации 1С: Управление торговлей 10.3. Подробно с иллюстрациями описаны основные действия кассира.

1 стартмани

22.06.2016    36488    zhuravlev_as    5    

Сложные отчеты для управляемых форм с использованием СКД: просто. На примере отчета ABC анализ номенклатуры, клиентов для УТ11

Практика программирования Оптовая торговля Оптовая торговля v8::СКД УТ11 УУ Абонемент ($m)

Не очень часто, но все же, иногда приходится сталкиваться с необходимостью создания отчета, который очень сложно скомпоновать на "чистом" СКД, в этом случае альтернативой может являться следующая последовательность действий для получения итогового отчета: 1. при помощи одной схемы компоновки данных получить необходимую выборку данных; 2. запрограммировать (на языке 1С) некое преобразование этих данных; 3. при помощи другой схемы компоновки данных - произвести вывод необходимой информации в табличный документ. Как оказалось эта процедура не слишком сложная, хотя и немного запутанная.

1 стартмани

12.08.2013    61411    mxm2    21    

Конвертер Даты из числового формата Excel

Загрузка и выгрузка в Excel Универсальные функции v8 1cv8.cf Абонемент ($m)

Столкнувшись с проблемой загрузки в 1С из Excel Даты-Времени в числовом формате к удивлению не нашел нигде подобных формул. Может потому что они уж слишком банальны, а может потому что они "тайное знание посвященных". В общем, эта обработка пример конвертации Excel <=> 1C

1 стартмани

17.04.2013    18597    vova196    5