Исправление ошибки переноса стандартных вычетов по НДФЛ при конвертации данных ЗиК->ЗУП 2.5.45.3

24.01.12

Интеграция - Перенос данных 1C

При  конвертации данных штатными средствами  ЗУП 2.5.45.3, неверно переносится сведения о предоставленных вычетах по НДФЛ.

При выгрузке данных, обработкой v77exp.ert, которая идет в составе ЗУП 2.5.45.3, неверно выгружаются сведения о предоставленных вычетах по НДФЛ..

Кто не знает - эта обработка хранится в ЗУП в справочнике "Конвертации из информационных баз 1С:Предприятие 7.7" 

 

 

Ошибка закралась в функции ЗаполнитьТаблицуНДФЛПредоставленныеСтдВычетыФизЛиц()

 

Функция ЗаполнитьТаблицуНДФЛПредоставленныеСтдВычетыФизЛиц(
            ИсходящиеДанные = "", ВходящиеДанные = "", Источник = "", Приемник = "", ТипПриемника = "", Значение = "", Выражение = "",
            Пусто = "", ВыборкаДанных = "", Объект = "", КоллекцияОбъектов = "", ОбъектКоллекции = "", ИмяПКО = "", ИмяПКОВидСубконто = "",
            НомерПКО = "", НомерПКС = "", Правило = "", КлючВыгружаемыхДанных = "", НеЗапоминатьВыгруженные = "", НеЗамещатьОбъектПриЗагрузке = "",
            ВсеОбъектыВыгружены = "", ТолькоПолучитьУзелСсылки = "", РежимЗаписи = "", РежимПроведения = "", СтандартнаяОбработка = "",
            НеЗамещать = "", НеОчищать = "", УзелСсылки = "", УзелКоллекцииОбъектов = "", УзелОбъектаКоллекции = "", УзелСвойства = "",
            ВидСубконто = "", Субконто = "", Отказ = "")


    СписокФизлиц                    = ИсходящиеДанные;
    ДоходыВычетыНалогиСотрудников    = ВходящиеДанные;
    ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц = Источник;
    Год                                = Приемник;
    
    ВсегоСотров = СписокФизлиц.РазмерСписка();
    НомерРелизаИБ        = Число(СтрЗаменить(Константа.НомерРелиза, ".",""));
    
    Если ВсегоСотров > 0 Тогда
        
        БуферРазделов=СоздатьОбъект("СписокЗначений");
            
        Для СчСотров = 1 По ВсегоСотров  Цикл
            
            СтрокаИтоговойТаблицы = (СчСотров-1)*12;
            ФизЛицо = СписокФизлиц.ПолучитьЗначение(СчСотров);                             
            
            БуферРазделов.УдалитьВсе();
            ПоследнийМесяц = 0;
            
            // заполняем буферы
            Если (Год>=2011) и (НомерРелизаИБ >= 770318) Тогда
                
                ТаблицаВычетов = ПолучитьСписокСтандартныхВычетов(ФизЛицо,ДоходыВычетыНалогиСотрудников,СтрокаИтоговойТаблицы,Год, ПоследнийМесяц);  
                
    
                Если (ТаблицаВычетов.КоличествоСтрок() <> 0) Тогда
                    
                    Для СчМес = 1 По ПоследнийМесяц Цикл
                        
                        ПериодРегистрацииДохода        = Дата(Год,СчМес,1);
                        ПодразделениеОрганизации = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы+СчМес,"Подразделение");
                        МесяцНалоговогоПериода        = Дата(Год,СчМес,1);
                        
                        НомСтроки = "";
                        Если ТаблицаВычетов.НайтиЗначение(СчМес,НомСтроки,"Месяц")>0 Тогда
                            
                            Для СчСтрок = НомСтроки По ТаблицаВычетов.КоличествоСтрок() Цикл
                                ТаблицаВычетов.ПолучитьСтрокуПоНомеру(СчСтрок);//вот этой строки не хватает
                                Если ТаблицаВычетов.Месяц<>СчМес Тогда
                                    Прервать;
                                КонецЕсли;
                                
                                Если ТаблицаВычетов.СуммаВычета<>0 Тогда
                                    
                                    ПримененныйВычет            = ТаблицаВычетов.СуммаВычета;
                                    КодВычета                    = ТаблицаВычетов.КодВычета;
                                    ЗаполнитьТаблицуПредоставленныхВычетов(
                                    ФизЛицо,
                                    ПериодРегистрацииДохода,
                                    ПодразделениеОрганизации,
                                    МесяцНалоговогоПериода,
                                    КодВычета,
                                    ПримененныйВычет,
                                    ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);
                                    
                                КонецЕсли;
    
                            КонецЦикла;    
                            
                        КонецЕсли;
                        
                    КонецЦикла;
                    
                КонецЕсли;
                
            Иначе
                Если Год>=2009 Тогда
                    глЗаполнитьРазделыНК2009(ФизЛицо,"",Год,ДоходыВычетыНалогиСотрудников,СтрокаИтоговойТаблицы,БуферРазделов,БуферРазделов,БуферРазделов,БуферРазделов,БуферРазделов,ПоследнийМесяц);
                Иначе
                    глЗаполнитьРазделыНК2005(ФизЛицо,"",Год,ДоходыВычетыНалогиСотрудников,СтрокаИтоговойТаблицы,БуферРазделов,БуферРазделов,БуферРазделов,БуферРазделов,БуферРазделов,ПоследнийМесяц);
                КонецЕсли;
                
                Если (БуферРазделов.РазмерСписка() <> 0) Тогда
                    
                    Для СчМес = 1 По ПоследнийМесяц Цикл
                        
                        ПериодРегистрацииДохода        = Дата(Год,СчМес,1);
                        ПодразделениеОрганизации = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы+СчМес,"Подразделение");
                        МесяцНалоговогоПериода        = Дата(Год,СчМес,1);
                        
                        СчСтрок = ?(СтрДлина(СчМес)=1, "0"+СчМес, СчМес);
                        
                        
                        Если Год>=2009 Тогда
                            
                            Сумма103 = Число(Сокрлп(БуферРазделов.Получить("СВМес3" + СчСтрок)));
                            Если Сумма103<>0 Тогда
                                ПримененныйВычет            = Сумма103;
                                КодВычета                    = "103";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма104 = Число(Сокрлп(БуферРазделов.Получить("СВМес4" + СчСтрок)));
                            Если Сумма104<>0 Тогда
                                ПримененныйВычет            = Сумма104;
                                КодВычета                    = "104";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма105 = Число(Сокрлп(БуферРазделов.Получить("СВМес5" + СчСтрок)));
                            Если Сумма105<>0 Тогда
                                ПримененныйВычет            = Сумма105;
                                КодВычета                    = "105";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма108 = Число(Сокрлп(БуферРазделов.Получить("СВМес8" + СчСтрок)));
                            Если Сумма108<>0 Тогда
                                ПримененныйВычет            = Сумма108;
                                КодВычета                    = "108";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма109 = Число(Сокрлп(БуферРазделов.Получить("СВМес9" + СчСтрок)));
                            Если Сумма109<>0 Тогда
                                ПримененныйВычет            = Сумма109;
                                КодВычета                    = "109";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма110 = Число(Сокрлп(БуферРазделов.Получить("СВМес10" + СчСтрок)));
                            Если Сумма110<>0 Тогда
                                ПримененныйВычет            = Сумма110;
                                КодВычета                    = "110";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма111 = Число(Сокрлп(БуферРазделов.Получить("СВМес11" + СчСтрок)));
                            Если Сумма111<>0 Тогда
                                ПримененныйВычет            = Сумма111;
                                КодВычета                    = "111";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма112 = Число(Сокрлп(БуферРазделов.Получить("СВМес12" + СчСтрок)));
                            Если Сумма112<>0 Тогда
                                ПримененныйВычет            = Сумма112;
                                КодВычета                    = "112";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма113 = Число(Сокрлп(БуферРазделов.Получить("СВМес13" + СчСтрок)));
                            Если Сумма113<>0 Тогда
                                ПримененныйВычет            = Сумма113;
                                КодВычета                    = "113";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            
                        Иначе
                            
                            Сумма101 = Число(Сокрлп(БуферРазделов.Получить("СВМес1" + СчСтрок)));
                            Если Сумма101<>0 Тогда
                                ПримененныйВычет            = Сумма101;
                                КодВычета                    = "101";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма102 = Число(Сокрлп(БуферРазделов.Получить("СВМес2" + СчСтрок)));
                            Если Сумма102<>0 Тогда
                                ПримененныйВычет            = Сумма102;
                                КодВычета                    = "102";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма103 = Число(Сокрлп(БуферРазделов.Получить("СВМес3" + СчСтрок)));
                            Если Сумма103<>0 Тогда
                                ПримененныйВычет            = Сумма103;
                                КодВычета                    = "103";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма104 = Число(Сокрлп(БуферРазделов.Получить("СВМес4" + СчСтрок)));
                            Если Сумма104<>0 Тогда
                                ПримененныйВычет            = Сумма104;
                                КодВычета                    = "104";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма105 = Число(Сокрлп(БуферРазделов.Получить("СВМес5" + СчСтрок)));
                            Если Сумма105<>0 Тогда
                                ПримененныйВычет            = Сумма105;
                                КодВычета                    = "105";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма106 = Число(Сокрлп(БуферРазделов.Получить("СВМес6" + СчСтрок)));
                            Если Сумма106<>0 Тогда
                                ПримененныйВычет            = Сумма106;
                                КодВычета                    = "106";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма107 = Число(Сокрлп(БуферРазделов.Получить("СВМес7" + СчСтрок)));
                            Если Сумма107<>0 Тогда
                                ПримененныйВычет            = Сумма107;
                                КодВычета                    = "107";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            
                        КонецЕсли;
                        
                    КонецЦикла;
                    
                КонецЕсли;
                
            КонецЕсли;
            
        КонецЦикла;    
        
    КонецЕсли;


КонецФункции // ЗаполнитьТаблицуНДФЛПредоставленныеСтдВычетыФизЛиц()

См. также

SALE! 10%

Синхронизация и обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    136632    729    292    

393

Перенос данных из УПП 1.3 в ERP 2 / УТ 11 / КА 2. Переносятся документы, справочная информация и остатки

Перенос данных 1C Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос документов, начальных остатков и справочной информации из УПП 1.3 в ERP 2 | из УПП 1.3 в УТ 11 | из УПП в КА 2 | Правила конвертации (КД 2) в продаже с 2015 года, постоянно работаем над их развитием | Более 360 предприятий выполнили переход с использованием этого продукта! | Сэкономьте время - используйте готовое решение для перехода! | Позволяет перенести из УПП 1.3 в ERP / УТ 11 / КА 2 всю возможную информацию | В переносе есть фильтр по организации и множество других опциональных параметров выгрузки | Есть несколько алгоритмов выгрузки остатков на выбор

45650 руб.

04.08.2015    161330    361    269    

352

Перенос данных из БП 3.0 в УТ 11 / КА 2 / ERP 2. Переносятся начальные остатки, документы и справочники

Перенос данных 1C Системный администратор Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

В продаже с 2014г. | Воспользовались более 122 предприятий! | Перенос данных из БП 3.0 в УТ 11 | из БП 3.0 в КА 2 | из БП 3.0 в ERP | Сэкономьте свое время - используйте готовое решение для перехода! | Постоянно работаем над развитием переноса данных | Обновляем на новые релизы 1С | Есть фильтр выгрузки по организациям | Переносятся начальные остатки на выбранную дату, документы за период времени и вся возможная справочная информация | Перенос сделан на технологии КД 2 (правила конвертации данных)

45650 руб.

31.10.2014    233177    91    328    

299

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69494    166    141    

112

SALE! 10%

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 25200 руб.

23.07.2020    47487    203    64    

164

SALE! 10%

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 25200 руб.

15.12.2021    21070    138    38    

97

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

43450 руб.

03.12.2020    34805    83    58    

81

SALE! 10%

[ED2] Обмен УПП 1.3, КА 1.1, УТ 10.3 с EnterpriseData (универсальный формат обмена), обработка

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    183616    565    508    

509
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
0. Abzkrs 36 25.01.12 05:12 Сейчас в теме
При конвертации данных штатными средствами ЗУП 2.5.45.3, неверно переносится сведения о предоставленных вычетах по НДФЛ.

Перейти к публикации

1. Umos 25.01.12 05:12 Сейчас в теме
Молоток, чего тут скажешь
2. kis 25.01.12 14:39 Сейчас в теме
Умница!!!! У меня правда зарплата бюджетная, но судя по картинке косяк тот-же. Попробую поправлю. Но плюсик готова уже сейчас поставить.
3. kis 26.01.12 09:38 Сейчас в теме
В 7 зик у сотрудника два вычета на детей 114\108 и 115 с 01/06/2011. Поправила прцедуру конвертации. 115 код в документе "Перенос данных" встал правильно, а 114\108 вообще не перенесся. У меня 8 ЗикБУ (8-ка зарплата бюджет) релиз 1.0.35.1 (но по моему косяк с 34 релиза). Отпуска, больничные считаются правильно, но хочется чтобы все было красиво. Может еще где-то надо править?
4. Abzkrs 36 26.01.12 10:28 Сейчас в теме
(3) Так трудно сказать...
Есть еще не понятный для меня цикл в функции ПолучитьСписокСтандартныхВычетов()
Для чего оно надо, я так и не понял... но может оно именно и мешает?
в самом конце

	Для Сч =0 По КолСтрок-1 Цикл
		
		Ном = КолСтрок - Сч;
		ТаблицаВычетов.ПолучитьСтрокуПоНомеру(Ном);
		КодВычета = ТаблицаВычетов.КодВычета;
		СуммаВычета = ТаблицаВычетов.СуммаВычета;
		
		Если СуммаВычета<0 Тогда
			СписокВычетов.Установить(КодВычета,-СуммаВычета + Число(СписокВычетов.Получить(КодВычета)));
			ТаблицаВычетов.СуммаВычета = 0;
		Иначе
			СуммаВычетаЛишняя = Число(СписокВычетов.Получить(КодВычета));
			СуммаВычетаНовая = Макс(0,СуммаВычета-СуммаВычетаЛишняя);
			СуммаВычетаЛишняяНовая = Макс(0,СуммаВычетаЛишняя - СуммаВычета + СуммаВычетаНовая);
			ТаблицаВычетов.СуммаВычета = СуммаВычетаНовая;
			СписокВычетов.Установить(КодВычета,СуммаВычетаЛишняяНовая);


		КонецЕсли;  
		
		Если ТаблицаВычетов.СуммаВычета = 0 Тогда
			ТаблицаВычетов.УдалитьСтроку(Ном);    
		КонецЕсли;
		
	КонецЦикла; 
Показать
5. 1Cworking 368 28.01.12 08:31 Сейчас в теме
(3) Неправильная функция: Найти(КодВычета, "114\108"), надо:
Найти("114\108",КодВычета) или
Найти(КодВычета, "114") ИЛИ Найти(КодВычета, "114")

// Вычеты на детей
в этом месте замените код:

ИначеЕсли (Найти(КодВычета, "114\108") <> 0) ИЛИ (Найти(КодВычета, "115") <> 0) ИЛИ (Найти(КодВычета, "116") <> 0) ИЛИ (Найти(КодВычета, "117\109") <> 0)
ИЛИ (Найти(КодВычета, "118\110") <> 0) ИЛИ (Найти(КодВычета, "119") <> 0) ИЛИ (Найти(КодВычета, "120") <> 0) ИЛИ (Найти(КодВычета, "121\112") <> 0)
ИЛИ (Найти(КодВычета, "122\111") <> 0) ИЛИ (Найти(КодВычета, "123") <> 0) ИЛИ (Найти(КодВычета, "124") <> 0) ИЛИ (Найти(КодВычета, "125\113") <> 0) Тогда

на

ИначеЕсли (Найти(КодВычета, "114") <> 0) ИЛИ (Найти(КодВычета, "108") <> 0) ИЛИ (Найти(КодВычета, "115") <> 0) ИЛИ (Найти(КодВычета, "116") <> 0)
ИЛИ (Найти(КодВычета, "109") <> 0) ИЛИ (Найти(КодВычета, "117") <> 0)
ИЛИ (Найти(КодВычета, "118") <> 0) ИЛИ (Найти(КодВычета, "110") <> 0) ИЛИ (Найти(КодВычета, "119") <> 0) ИЛИ (Найти(КодВычета, "120") <> 0)
ИЛИ (Найти(КодВычета, "112") <> 0) ИЛИ (Найти(КодВычета, "121") <> 0) ИЛИ (Найти(КодВычета, "122") <> 0)ИЛИ (Найти(КодВычета, "111") <> 0)
ИЛИ (Найти(КодВычета, "123") <> 0) ИЛИ (Найти(КодВычета, "124") <> 0) ИЛИ (Найти(КодВычета, "125") <> 0) ИЛИ (Найти(КодВычета, "113") <> 0) Тогда
10. kis 12.02.12 23:45 Сейчас в теме
(5) 1Cworking, Поправила модуль как написано, переносит 108 и 114 вычеты в справочник вычетов и в документы переноса , их потом обработкой можно заменить на вычет 114/108 и удалить. Такой результат меня устраивает. Но мне пришлось снимать конфигурацию с поддержки. А как теперь вернуть замочек на место. Я в программировании не сильна. Мне с замочком спокойнее. Подскажите, пожалуйста.
11. 1Cworking 368 13.02.12 06:59 Сейчас в теме
(10) Есть справочник "Конвертации из информационных баз...". Из него можно получить обработку выгрузки из ЗиК и уже редактировать и использовать ее при выгрузке из ЗиК. При этом конфигурация не меняется и замочек на месте.
Вот обработка , которую я использовал V77ExpМоя318.ert. В ней добавлена возможность загружать только непом.на уд.( это для того, чтобы можно было выгружать/загружать частями).
Прикрепленные файлы:
V77ExpМоя318.ert
12. kis 13.02.12 10:06 Сейчас в теме
(11) 1Cworking, Я из 8 ЗикБУ выгражала V77Exp.ert, редактировала в конфигураторе 7 зик, снимала замочек с 8 ЗикБУ и опять загружала в справочник "Конвертации из информационных баз...". Из 7 Зик V77Exp.ert запускается, но там надо указать Имя файла правил. А где взять эти правила я не знаю. И как потом в 8-ку загрузить?
13. 1Cworking 368 13.02.12 17:34 Сейчас в теме
(12) правила выгружаются там же. Можете взять от сюда.
Прикрепленные файлы:
PrB.rar
14. kis 13.02.12 20:13 Сейчас в теме
(13) 1Cworking, Огромное спасибо !!! Нашла я правила в справочнике "Конвертации из информационных баз...". Выгрузила данные из 7 зик 321 в 8 ЗикБУ 35,2, все получилось. Только выгрузка через файл выполнялась раза в три быстрее. :)
6. econom1 28 30.01.12 17:28 Сейчас в теме
и для комплексной такая же фигня
спасибо!
7. пользователь 31.01.12 10:15
Сообщение было скрыто модератором.
...
8. Katarri 31.01.12 17:31 Сейчас в теме
Спасибо большое, очень помогли!))
9. pacas 9 02.02.12 12:50 Сейчас в теме
15. Prooa 39 19.03.12 04:24 Сейчас в теме
а если база уже перенесена как можно перегрузить именно эту информацию
16. kis 23.03.12 15:17 Сейчас в теме
17. Prooa 39 24.03.12 08:35 Сейчас в теме
(16) kis, это я сам уже сделал
18. samamoiloff 861 21.05.12 23:40 Сейчас в теме
Да, забавно. Еще в 2010 писал в (Изменения стандартных правил выгрузки перехода с ЗиК на ЗУП (вычеты НДФЛ на детей) про разные ошибочки, так этот вопрос и тянется, как Змей Горыныч трансформируясь и отращивая головы... :)
19. kurvik 16.11.12 17:36 Сейчас в теме
Хорошая обработка.А не то исправляли вручную.Будем использовать,Спасибо.
Оставьте свое сообщение