Исправление ошибки переноса стандартных вычетов по НДФЛ при конвертации данных ЗиК->ЗУП 2.5.45.3

Публикация № 105630

Разработка - Практика программирования

При  конвертации данных штатными средствами  ЗУП 2.5.45.3, неверно переносится сведения о предоставленных вычетах по НДФЛ.

При выгрузке данных, обработкой v77exp.ert, которая идет в составе ЗУП 2.5.45.3, неверно выгружаются сведения о предоставленных вычетах по НДФЛ..

Кто не знает - эта обработка хранится в ЗУП в справочнике "Конвертации из информационных баз 1С:Предприятие 7.7" 

 

 

Ошибка закралась в функции ЗаполнитьТаблицуНДФЛПредоставленныеСтдВычетыФизЛиц()

 

Функция ЗаполнитьТаблицуНДФЛПредоставленныеСтдВычетыФизЛиц(
            ИсходящиеДанные = "", ВходящиеДанные = "", Источник = "", Приемник = "", ТипПриемника = "", Значение = "", Выражение = "",
            Пусто = "", ВыборкаДанных = "", Объект = "", КоллекцияОбъектов = "", ОбъектКоллекции = "", ИмяПКО = "", ИмяПКОВидСубконто = "",
            НомерПКО = "", НомерПКС = "", Правило = "", КлючВыгружаемыхДанных = "", НеЗапоминатьВыгруженные = "", НеЗамещатьОбъектПриЗагрузке = "",
            ВсеОбъектыВыгружены = "", ТолькоПолучитьУзелСсылки = "", РежимЗаписи = "", РежимПроведения = "", СтандартнаяОбработка = "",
            НеЗамещать = "", НеОчищать = "", УзелСсылки = "", УзелКоллекцииОбъектов = "", УзелОбъектаКоллекции = "", УзелСвойства = "",
            ВидСубконто = "", Субконто = "", Отказ = "")


    СписокФизлиц                    = ИсходящиеДанные;
    ДоходыВычетыНалогиСотрудников    = ВходящиеДанные;
    ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц = Источник;
    Год                                = Приемник;
    
    ВсегоСотров = СписокФизлиц.РазмерСписка();
    НомерРелизаИБ        = Число(СтрЗаменить(Константа.НомерРелиза, ".",""));
    
    Если ВсегоСотров > 0 Тогда
        
        БуферРазделов=СоздатьОбъект("СписокЗначений");
            
        Для СчСотров = 1 По ВсегоСотров  Цикл
            
            СтрокаИтоговойТаблицы = (СчСотров-1)*12;
            ФизЛицо = СписокФизлиц.ПолучитьЗначение(СчСотров);                             
            
            БуферРазделов.УдалитьВсе();
            ПоследнийМесяц = 0;
            
            // заполняем буферы
            Если (Год>=2011) и (НомерРелизаИБ >= 770318) Тогда
                
                ТаблицаВычетов = ПолучитьСписокСтандартныхВычетов(ФизЛицо,ДоходыВычетыНалогиСотрудников,СтрокаИтоговойТаблицы,Год, ПоследнийМесяц);  
                
    
                Если (ТаблицаВычетов.КоличествоСтрок() <> 0) Тогда
                    
                    Для СчМес = 1 По ПоследнийМесяц Цикл
                        
                        ПериодРегистрацииДохода        = Дата(Год,СчМес,1);
                        ПодразделениеОрганизации = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы+СчМес,"Подразделение");
                        МесяцНалоговогоПериода        = Дата(Год,СчМес,1);
                        
                        НомСтроки = "";
                        Если ТаблицаВычетов.НайтиЗначение(СчМес,НомСтроки,"Месяц")>0 Тогда
                            
                            Для СчСтрок = НомСтроки По ТаблицаВычетов.КоличествоСтрок() Цикл
                                ТаблицаВычетов.ПолучитьСтрокуПоНомеру(СчСтрок);//вот этой строки не хватает
                                Если ТаблицаВычетов.Месяц<>СчМес Тогда
                                    Прервать;
                                КонецЕсли;
                                
                                Если ТаблицаВычетов.СуммаВычета<>0 Тогда
                                    
                                    ПримененныйВычет            = ТаблицаВычетов.СуммаВычета;
                                    КодВычета                    = ТаблицаВычетов.КодВычета;
                                    ЗаполнитьТаблицуПредоставленныхВычетов(
                                    ФизЛицо,
                                    ПериодРегистрацииДохода,
                                    ПодразделениеОрганизации,
                                    МесяцНалоговогоПериода,
                                    КодВычета,
                                    ПримененныйВычет,
                                    ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);
                                    
                                КонецЕсли;
    
                            КонецЦикла;    
                            
                        КонецЕсли;
                        
                    КонецЦикла;
                    
                КонецЕсли;
                
            Иначе
                Если Год>=2009 Тогда
                    глЗаполнитьРазделыНК2009(ФизЛицо,"",Год,ДоходыВычетыНалогиСотрудников,СтрокаИтоговойТаблицы,БуферРазделов,БуферРазделов,БуферРазделов,БуферРазделов,БуферРазделов,ПоследнийМесяц);
                Иначе
                    глЗаполнитьРазделыНК2005(ФизЛицо,"",Год,ДоходыВычетыНалогиСотрудников,СтрокаИтоговойТаблицы,БуферРазделов,БуферРазделов,БуферРазделов,БуферРазделов,БуферРазделов,ПоследнийМесяц);
                КонецЕсли;
                
                Если (БуферРазделов.РазмерСписка() <> 0) Тогда
                    
                    Для СчМес = 1 По ПоследнийМесяц Цикл
                        
                        ПериодРегистрацииДохода        = Дата(Год,СчМес,1);
                        ПодразделениеОрганизации = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы+СчМес,"Подразделение");
                        МесяцНалоговогоПериода        = Дата(Год,СчМес,1);
                        
                        СчСтрок = ?(СтрДлина(СчМес)=1, "0"+СчМес, СчМес);
                        
                        
                        Если Год>=2009 Тогда
                            
                            Сумма103 = Число(Сокрлп(БуферРазделов.Получить("СВМес3" + СчСтрок)));
                            Если Сумма103<>0 Тогда
                                ПримененныйВычет            = Сумма103;
                                КодВычета                    = "103";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма104 = Число(Сокрлп(БуферРазделов.Получить("СВМес4" + СчСтрок)));
                            Если Сумма104<>0 Тогда
                                ПримененныйВычет            = Сумма104;
                                КодВычета                    = "104";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма105 = Число(Сокрлп(БуферРазделов.Получить("СВМес5" + СчСтрок)));
                            Если Сумма105<>0 Тогда
                                ПримененныйВычет            = Сумма105;
                                КодВычета                    = "105";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма108 = Число(Сокрлп(БуферРазделов.Получить("СВМес8" + СчСтрок)));
                            Если Сумма108<>0 Тогда
                                ПримененныйВычет            = Сумма108;
                                КодВычета                    = "108";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма109 = Число(Сокрлп(БуферРазделов.Получить("СВМес9" + СчСтрок)));
                            Если Сумма109<>0 Тогда
                                ПримененныйВычет            = Сумма109;
                                КодВычета                    = "109";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма110 = Число(Сокрлп(БуферРазделов.Получить("СВМес10" + СчСтрок)));
                            Если Сумма110<>0 Тогда
                                ПримененныйВычет            = Сумма110;
                                КодВычета                    = "110";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма111 = Число(Сокрлп(БуферРазделов.Получить("СВМес11" + СчСтрок)));
                            Если Сумма111<>0 Тогда
                                ПримененныйВычет            = Сумма111;
                                КодВычета                    = "111";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма112 = Число(Сокрлп(БуферРазделов.Получить("СВМес12" + СчСтрок)));
                            Если Сумма112<>0 Тогда
                                ПримененныйВычет            = Сумма112;
                                КодВычета                    = "112";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма113 = Число(Сокрлп(БуферРазделов.Получить("СВМес13" + СчСтрок)));
                            Если Сумма113<>0 Тогда
                                ПримененныйВычет            = Сумма113;
                                КодВычета                    = "113";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            
                        Иначе
                            
                            Сумма101 = Число(Сокрлп(БуферРазделов.Получить("СВМес1" + СчСтрок)));
                            Если Сумма101<>0 Тогда
                                ПримененныйВычет            = Сумма101;
                                КодВычета                    = "101";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма102 = Число(Сокрлп(БуферРазделов.Получить("СВМес2" + СчСтрок)));
                            Если Сумма102<>0 Тогда
                                ПримененныйВычет            = Сумма102;
                                КодВычета                    = "102";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма103 = Число(Сокрлп(БуферРазделов.Получить("СВМес3" + СчСтрок)));
                            Если Сумма103<>0 Тогда
                                ПримененныйВычет            = Сумма103;
                                КодВычета                    = "103";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма104 = Число(Сокрлп(БуферРазделов.Получить("СВМес4" + СчСтрок)));
                            Если Сумма104<>0 Тогда
                                ПримененныйВычет            = Сумма104;
                                КодВычета                    = "104";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма105 = Число(Сокрлп(БуферРазделов.Получить("СВМес5" + СчСтрок)));
                            Если Сумма105<>0 Тогда
                                ПримененныйВычет            = Сумма105;
                                КодВычета                    = "105";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма106 = Число(Сокрлп(БуферРазделов.Получить("СВМес6" + СчСтрок)));
                            Если Сумма106<>0 Тогда
                                ПримененныйВычет            = Сумма106;
                                КодВычета                    = "106";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            Сумма107 = Число(Сокрлп(БуферРазделов.Получить("СВМес7" + СчСтрок)));
                            Если Сумма107<>0 Тогда
                                ПримененныйВычет            = Сумма107;
                                КодВычета                    = "107";
                                ЗаполнитьТаблицуПредоставленныхВычетов(
                                ФизЛицо,
                                ПериодРегистрацииДохода,
                                ПодразделениеОрганизации,
                                МесяцНалоговогоПериода,
                                КодВычета,
                                ПримененныйВычет,
                                ТаблицаНДФЛПредоставленныеСтандартныеВычетыФизЛиц);    
                            КонецЕсли;
                            
                            
                        КонецЕсли;
                        
                    КонецЦикла;
                    
                КонецЕсли;
                
            КонецЕсли;
            
        КонецЦикла;    
        
    КонецЕсли;


КонецФункции // ЗаполнитьТаблицуНДФЛПредоставленныеСтдВычетыФизЛиц()

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
0. Abzkrs 36 25.01.12 05:12 Сейчас в теме
При конвертации данных штатными средствами ЗУП 2.5.45.3, неверно переносится сведения о предоставленных вычетах по НДФЛ.

Перейти к публикации

1. Umos 25.01.12 05:12 Сейчас в теме
Молоток, чего тут скажешь
2. kis 25.01.12 14:39 Сейчас в теме
Умница!!!! У меня правда зарплата бюджетная, но судя по картинке косяк тот-же. Попробую поправлю. Но плюсик готова уже сейчас поставить.
3. kis 26.01.12 09:38 Сейчас в теме
В 7 зик у сотрудника два вычета на детей 114\108 и 115 с 01/06/2011. Поправила прцедуру конвертации. 115 код в документе "Перенос данных" встал правильно, а 114\108 вообще не перенесся. У меня 8 ЗикБУ (8-ка зарплата бюджет) релиз 1.0.35.1 (но по моему косяк с 34 релиза). Отпуска, больничные считаются правильно, но хочется чтобы все было красиво. Может еще где-то надо править?
4. Abzkrs 36 26.01.12 10:28 Сейчас в теме
(3) Так трудно сказать...
Есть еще не понятный для меня цикл в функции ПолучитьСписокСтандартныхВычетов()
Для чего оно надо, я так и не понял... но может оно именно и мешает?
в самом конце

	Для Сч =0 По КолСтрок-1 Цикл
		
		Ном = КолСтрок - Сч;
		ТаблицаВычетов.ПолучитьСтрокуПоНомеру(Ном);
		КодВычета = ТаблицаВычетов.КодВычета;
		СуммаВычета = ТаблицаВычетов.СуммаВычета;
		
		Если СуммаВычета<0 Тогда
			СписокВычетов.Установить(КодВычета,-СуммаВычета + Число(СписокВычетов.Получить(КодВычета)));
			ТаблицаВычетов.СуммаВычета = 0;
		Иначе
			СуммаВычетаЛишняя = Число(СписокВычетов.Получить(КодВычета));
			СуммаВычетаНовая = Макс(0,СуммаВычета-СуммаВычетаЛишняя);
			СуммаВычетаЛишняяНовая = Макс(0,СуммаВычетаЛишняя - СуммаВычета + СуммаВычетаНовая);
			ТаблицаВычетов.СуммаВычета = СуммаВычетаНовая;
			СписокВычетов.Установить(КодВычета,СуммаВычетаЛишняяНовая);


		КонецЕсли;  
		
		Если ТаблицаВычетов.СуммаВычета = 0 Тогда
			ТаблицаВычетов.УдалитьСтроку(Ном);    
		КонецЕсли;
		
	КонецЦикла; 
Показать
5. 1Cworking 368 28.01.12 08:31 Сейчас в теме
(3) Неправильная функция: Найти(КодВычета, "114\108"), надо:
Найти("114\108",КодВычета) или
Найти(КодВычета, "114") ИЛИ Найти(КодВычета, "114")

// Вычеты на детей
в этом месте замените код:

ИначеЕсли (Найти(КодВычета, "114\108") <> 0) ИЛИ (Найти(КодВычета, "115") <> 0) ИЛИ (Найти(КодВычета, "116") <> 0) ИЛИ (Найти(КодВычета, "117\109") <> 0)
ИЛИ (Найти(КодВычета, "118\110") <> 0) ИЛИ (Найти(КодВычета, "119") <> 0) ИЛИ (Найти(КодВычета, "120") <> 0) ИЛИ (Найти(КодВычета, "121\112") <> 0)
ИЛИ (Найти(КодВычета, "122\111") <> 0) ИЛИ (Найти(КодВычета, "123") <> 0) ИЛИ (Найти(КодВычета, "124") <> 0) ИЛИ (Найти(КодВычета, "125\113") <> 0) Тогда

на

ИначеЕсли (Найти(КодВычета, "114") <> 0) ИЛИ (Найти(КодВычета, "108") <> 0) ИЛИ (Найти(КодВычета, "115") <> 0) ИЛИ (Найти(КодВычета, "116") <> 0)
ИЛИ (Найти(КодВычета, "109") <> 0) ИЛИ (Найти(КодВычета, "117") <> 0)
ИЛИ (Найти(КодВычета, "118") <> 0) ИЛИ (Найти(КодВычета, "110") <> 0) ИЛИ (Найти(КодВычета, "119") <> 0) ИЛИ (Найти(КодВычета, "120") <> 0)
ИЛИ (Найти(КодВычета, "112") <> 0) ИЛИ (Найти(КодВычета, "121") <> 0) ИЛИ (Найти(КодВычета, "122") <> 0)ИЛИ (Найти(КодВычета, "111") <> 0)
ИЛИ (Найти(КодВычета, "123") <> 0) ИЛИ (Найти(КодВычета, "124") <> 0) ИЛИ (Найти(КодВычета, "125") <> 0) ИЛИ (Найти(КодВычета, "113") <> 0) Тогда
10. kis 12.02.12 23:45 Сейчас в теме
(5) 1Cworking, Поправила модуль как написано, переносит 108 и 114 вычеты в справочник вычетов и в документы переноса , их потом обработкой можно заменить на вычет 114/108 и удалить. Такой результат меня устраивает. Но мне пришлось снимать конфигурацию с поддержки. А как теперь вернуть замочек на место. Я в программировании не сильна. Мне с замочком спокойнее. Подскажите, пожалуйста.
11. 1Cworking 368 13.02.12 06:59 Сейчас в теме
(10) Есть справочник "Конвертации из информационных баз...". Из него можно получить обработку выгрузки из ЗиК и уже редактировать и использовать ее при выгрузке из ЗиК. При этом конфигурация не меняется и замочек на месте.
Вот обработка , которую я использовал V77ExpМоя318.ert. В ней добавлена возможность загружать только непом.на уд.( это для того, чтобы можно было выгружать/загружать частями).
Прикрепленные файлы:
V77ExpМоя318.ert
12. kis 13.02.12 10:06 Сейчас в теме
(11) 1Cworking, Я из 8 ЗикБУ выгражала V77Exp.ert, редактировала в конфигураторе 7 зик, снимала замочек с 8 ЗикБУ и опять загружала в справочник "Конвертации из информационных баз...". Из 7 Зик V77Exp.ert запускается, но там надо указать Имя файла правил. А где взять эти правила я не знаю. И как потом в 8-ку загрузить?
13. 1Cworking 368 13.02.12 17:34 Сейчас в теме
(12) правила выгружаются там же. Можете взять от сюда.
Прикрепленные файлы:
PrB.rar
14. kis 13.02.12 20:13 Сейчас в теме
(13) 1Cworking, Огромное спасибо !!! Нашла я правила в справочнике "Конвертации из информационных баз...". Выгрузила данные из 7 зик 321 в 8 ЗикБУ 35,2, все получилось. Только выгрузка через файл выполнялась раза в три быстрее. :)
6. econom1 28 30.01.12 17:28 Сейчас в теме
и для комплексной такая же фигня
спасибо!
8. Katarri 31.01.12 17:31 Сейчас в теме
Спасибо большое, очень помогли!))
9. pacas 51 02.02.12 12:50 Сейчас в теме
15. Prooa 51 19.03.12 04:24 Сейчас в теме
а если база уже перенесена как можно перегрузить именно эту информацию
16. kis 23.03.12 15:17 Сейчас в теме
17. Prooa 51 24.03.12 08:35 Сейчас в теме
(16) kis, это я сам уже сделал
18. samamoiloff 858 21.05.12 23:40 Сейчас в теме
Да, забавно. Еще в 2010 писал в (Изменения стандартных правил выгрузки перехода с ЗиК на ЗУП (вычеты НДФЛ на детей) про разные ошибочки, так этот вопрос и тянется, как Змей Горыныч трансформируясь и отращивая головы... :)
19. kurvik 16.11.12 17:36 Сейчас в теме
Хорошая обработка.А не то исправляли вручную.Будем использовать,Спасибо.
Оставьте свое сообщение

См. также

Программная работа с настройками СКД

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    8889    ids79    26       

Время учиться: до 3 апреля скидки на курсы до 40%! Промо

Для тех, кто решил провести самоизоляцию с пользой, Инфостарт запускает акцию «Время учиться». С 30 марта до 3 апреля 2020 года наши курсы и видеозаписи докладов INFOSTART EVENT 2019 INCEPTION продаются со скидкой!

[СКД] Программное создание схемы компоновки данных

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    10130    John_d    22       

Последовательности событий. Шпаргалка

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    6736    kuzyara    33       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

30 задач. Странных и не очень

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    10701    YPermitin    72       

DevOps для 1С. Онлайн-курс проходит с 16 апреля по 11 июня 2020 года. Промо

Данный онлайн-курс предусматривает изучение процессов DevOps, их применение при разработке на платформе 1С. В результате прохождения онлайн-курса вы сможете: настроить ПО необходимое для проведения проверок и тестирования, создавать сценарии тестирования и объединять их в комплексные процессы, создавать скрипты для автоматизации процессов DevOps.

12000 рублей

Агрегатные функции СКД, о которых мало кто знает

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    30333    ids79    50       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Три костыля. Сказ про фокусы в коде

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    18747    YPermitin    80       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Отслеживание выполнения фонового задания

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    21384    ids79    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    42008    ids79    36       

Базовый курс для начинающих 1С-программистов. Онлайн-интенсив со 2 июня по 2 июля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500-9500 рублей

Фоновое выполнение кода в 1С - это просто

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    21488    avalakh    21       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    33056    ids79    11       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    22967    ids79    27       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Регистры сведений. За кулисами

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    17390    YPermitin    12       

"Меньше копипаста!", или как Вася универсальную процедуру писал

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    14089    SeiOkami    49       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Создание отчетов с помощью СКД - основные понятия и элементы

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    35856    ids79    17       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Производительность и оптимизация (HighLoad)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    18736    dmurk    144       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Регистры накопления. Структура хранения в базе данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    30810    YPermitin    30       

Выполнение внешней обработки в фоновом задании

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    20022    Eret1k    23       

Онлайн-курс «Автоматизация процессов управления МТО: методика сбора и формализации требований» с 1 апреля по 13 мая 2020 года. Промо

Цель курса - повысить полноту и качество сбора и формализации требований к автоматизации процессов управления материально-техническим обеспечением. Курс основан на процессном подходе, позволяет в полном объеме выявить и учесть все факторы, влияющие на специфику процессов управления МТО. Участники курса получают теоретические знания в области организации процессов управления МТО и готовый инструментарий для сбора и формализации требований по автоматизации этих процессов (шаблоны, опросники, модели).

40000 рублей

Выгрузка документа по условию

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    11320    m-rv    2       

Как прикрутить ГУИД к регистру сведений

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    14644    m-rv    16       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

О расширениях замолвите слово...

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    25838    ellavs    125       

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    20550    ellavs    83