Шпаргалка (БСП). Добавление в новый документ механизма печати дополнительных печатных форм

Публикация № 1132897 10.10.19

Разработка - БСП (Библиотека стандартных подсистем)

БСП печать кнопка механизм печатные формы

Постоянно приходится вспоминать, как добавить механизм печати (БСП) в новый документ. Поэтому решил написать шпаргалку.

1. В форму документа добавить процедуры:

 
			// СтандартныеПодсистемы.Печать 
&НаКлиенте 
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда) 
	УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект); 
КонецПроцедуры 
// Конец СтандартныеПодсистемы.Печать 
// СтандартныеПодсистемы.ПодключаемыеКоманды 
&НаКлиенте 
Процедура Подключаемый_ВыполнитьКоманду(Команда) 
	ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект); 
КонецПроцедуры 
&НаСервере 
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат) 
	ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Объект, Результат); 
КонецПроцедуры 
&НаКлиенте 
Процедура Подключаемый_ОбновитьКоманды() 
	ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект); 
КонецПроцедуры 
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
		

 

2. Добавить в события формы документа:

 
			&НаКлиенте 
Процедура ПриОткрытии(Отказ) 
	// СтандартныеПодсистемы.ПодключаемыеКоманды 
	ПодключаемыеКомандыКлиент.НачатьОбновлениеКоманд(ЭтотОбъект); 
	// Конец СтандартныеПодсистемы.ПодключаемыеКоманды 
КонецПроцедуры 
&НаСервере 
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) 
	// СтандартныеПодсистемы.ПодключаемыеКоманды 
	ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект); 
	// Конец СтандартныеПодсистемы.ПодключаемыеКоманды 
КонецПроцедуры 
&НаСервере 
Процедура ПриЧтенииНаСервере(ТекущийОбъект) 
	// СтандартныеПодсистемы.ПодключаемыеКоманды 
	ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект); 
	// Конец СтандартныеПодсистемы.ПодключаемыеКоманды 
КонецПроцедуры 
		

 

3. В модуль менеджера нового документа 

 
			#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда 
#Область Печать

// Заполняет список команд печати.
// 
// Параметры:
//   КомандыПечати - ТаблицаЗначений - состав полей см. в функции УправлениеПечатью.СоздатьКоллекциюКомандПечати
//
Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт
	
КонецПроцедуры

// Сформировать печатные формы объектов
//
// ВХОДЯЩИЕ:
//   ИменаМакетов    - Строка    - Имена макетов, перечисленные через запятую
//   МассивОбъектов  - Массив    - Массив ссылок на объекты которые нужно распечатать
//   ПараметрыПечати - Структура - Структура дополнительных параметров печати
//
// ИСХОДЯЩИЕ:
//   КоллекцияПечатныхФорм - Таблица значений - Сформированные табличные документы
//   ПараметрыВывода       - Структура        - Параметры сформированных табличных документов
//
Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
	ФормированиеПечатныхФорм.ЗаполнитьПараметрыОтправки(ПараметрыВывода.ПараметрыОтправки, МассивОбъектов, КоллекцияПечатныхФорм);
	
КонецПроцедуры

Функция ДоступныеДляШаблоновПечатныеФормы() Экспорт
	
	МассивДоступныхПечатныхФорм = Новый Массив;
	
	Возврат МассивДоступныхПечатныхФорм

КонецФункции

#КонецОбласти 
#КонецЕсли

		

 

4. В общий модуль УправлениеПечатьюПереопределяемый в процедуру ПриОпределенииОбъектовСКомандамиПечати добавить строчку.

 
			Процедура ПриОпределенииОбъектовСКомандамиПечати(СписокОбъектов) Экспорт 
	СписокОбъектов.Добавить(Документы.НовыйДокумент); 
КонецПроцедуры
		

 

5. В модуль дополнительной печатной формы добавить процедуры

 
			#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда 
#Область ПрограммныйИнтерфейс 

Функция СведенияОВнешнейОбработке() Экспорт 
	СведенияОВнешнейОбработке = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.3.1.73"); 
	СведенияОВнешнейОбработке.Вставить("Вид", ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма()); 
	СведенияОВнешнейОбработке.Вставить("Назначение", ПолучитьНазначениеОбработки()); 
	СведенияОВнешнейОбработке.Вставить("Наименование", "Новый документ"); 
	СведенияОВнешнейОбработке.Вставить("Версия", "1.0"); 
	СведенияОВнешнейОбработке.Вставить("Информация", "Новый документ"); 
	СведенияОВнешнейОбработке.Вставить("БезопасныйРежим", Ложь); 
	СформироватьСписокКоманд(СведенияОВнешнейОбработке.Команды); 
	Возврат СведенияОВнешнейОбработке; 
КонецФункции 

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт 
	ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "НовыйДокумент"); 
	Если ПечатнаяФорма <> Неопределено Тогда 
		ПечатнаяФорма.ТабличныйДокумент = СформироватьПечатнуюФорму(МассивОбъектов); 
		ПечатнаяФорма.СинонимМакета = НСтр("ru = 'Новый документ'"); 
	КонецЕсли; 
КонецПроцедуры 

#КонецОбласти 
Функция СформироватьПечатнуюФорму(МассивОбъектов) Экспорт 
	Док = МассивОбъектов[0]; 
	//Тут заполняем печатную форму 
	//Макет = ПолучитьМакет("Макет"); 
	//ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок"); 
	//ТабличныйДокумент.Вывести(ОбластьЗаголовок); 
	ТабличныйДокумент = Новый ТабличныйДокумент; 
	Возврат ТабличныйДокумент; 
КонецФункции 
#Область СлужебныеПроцедурыИФункции 

Функция ПолучитьНазначениеОбработки() 
	Результат = Новый Массив; 
	Результат.Добавить("Документ.НовыйДокумент"); 
	Возврат Результат; 
КонецФункции 

Функция ПолучитьСтруктуруТаблицыКоманд() 
	Результат = Новый ТаблицаЗначений; 
	Результат.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка")); 
	Результат.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); 
	Результат.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); 
	Результат.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево")); 
	Результат.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка")); 
	Возврат Результат; 
КонецФункции 

Процедура ДобавитьКоманду(Команды, Идентификатор, Представление, Использование, ПоказыватьОповещение = Ложь, Модификатор = Неопределено) 
	НоваяКоманда = Команды.Добавить(); 
	НоваяКоманда.Идентификатор = Идентификатор; 
	НоваяКоманда.Представление = Представление; 
	НоваяКоманда.Использование = Использование; 
	НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение; 
	НоваяКоманда.Модификатор = Модификатор; 
КонецПроцедуры 

Процедура СформироватьСписокКоманд(Команды) 
	ДобавитьКоманду(Команды, "НовыйДокумент", "Новый документ", ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода(), Истина); 
КонецПроцедуры 

#КонецОбласти 
#КонецЕсли
		

 

6. В форму списка документа добавить процедуры:

 
			&НаСервере 
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	// СтандартныеПодсистемы.Печать 
	УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма, Элементы.ПодменюПечать); 
	// Конец СтандартныеПодсистемы.Печать 
КонецПроцедуры 

#Область ОбработчикиКомандФормы 
// СтандартныеПодсистемы.Печать 
&НаКлиенте 
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда) 
	УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Элементы.Список); 
КонецПроцедуры 
// Конец СтандартныеПодсистемы.Печать 
&НаКлиенте 
Процедура Подключаемый_ВыполнитьПереопределяемуюКоманду(Команда) 
	СобытияФормКлиент.ВыполнитьПереопределяемуюКоманду(ЭтаФорма, Команда); 
КонецПроцедуры 
#КонецОбласти 

// СтандартныеПодсистемы.ПодключаемыеКоманды 
&НаКлиенте 
Процедура Подключаемый_ВыполнитьКоманду(Команда) 
	ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Элементы.Список); 
КонецПроцедуры 
&НаСервере 
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат) 
	ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Элементы.Список, Результат); 
КонецПроцедуры 
&НаКлиенте 
Процедура Подключаемый_ОбновитьКоманды() 
	ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Элементы.Список); 
КонецПроцедуры 
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
		

Добавить в командную панель ПодменюПечать:

ПоложениеКоманднойПанели поставить Верх

В списке обязательно должна присутствовать Ссылка

Тестировал на:

1С:Предприятие 8.3 (8.3.13.1644)

1С:Комплексная автоматизация 2 (2.4.6.207)

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. MSK_Step 22 10.10.19 15:15 Сейчас в теме
класс, надо такие же сделать на версионирование, дату запрета редактирования и другие полезные фишки
rpgshnik; myoker; 2711640; Светлый ум; DrAku1a; Sergafan10; +6 Ответить
2. Sergafan10 10.10.19 15:18 Сейчас в теме
(1) с версионированием каждый раз велосипед изобретать приходится))
6. John_d 4393 11.10.19 10:34 Сейчас в теме
(1) Версионирование
1. Добавить Новый объект в Подписки на события "ЗаписатьВерсиюДокумента"
2. Добавить Новый объект в Определяемые типы "ВерсионируемыеДанные"
3. В режиме предприятия настроить хранение данных:
Администрирование -> Общие настройки -> История изменений -> Настройки хранения
В списке объектов найти новый объект и поставить напротив него "При записи"
echo77; smit1c; olo_lo4; Yan_Malyakov; Риник; AgeevVG; fight1c; glorry; +8 Ответить
8. MSK_Step 22 11.10.19 11:50 Сейчас в теме
(6) Вы забыли про код в форме при создание на сервере
// СтандартныеПодсистемы.ВерсионированиеОбъектов
ВерсионированиеОбъектов.ПриСозданииНаСервере(ЭтотОбъект);
// Конец СтандартныеПодсистемы.ВерсионированиеОбъектов

и другие нюансы, про которые незнаете и надо внимательно читать на ИТС

Как для этого такие "Подсказки" помогают, когда ночью уже голова не соображает, то такие пошаговые выручают, так как зачем это все помнить
13. Риник 13 23.01.20 13:35 Сейчас в теме
3. dock 44 10.10.19 19:11 Сейчас в теме
Для идеальности не хватает только указания версии БСП....
Автору огромный плюс!
Alex_1066; Риник; +2 Ответить
4. ColaKola 14 10.10.19 22:05 Сейчас в теме
чем вас не устроила ссылка на официальную документацию в избранном?
Casey1984; dhurricane; aegoncharov; Labotamy; Йожкин Кот; Sashares; asupsam; +7 3 Ответить
5. Labotamy 10.10.19 22:21 Сейчас в теме
ИТС не предлагать?
Casey1984; Sashares; +2 Ответить
7. MSK_Step 22 11.10.19 11:43 Сейчас в теме
(5)ахаха, вы сравнили, тут все четко разложено, там надо вникать. Я уверен на 100%, что вы у себя при разработке нового документа забиваете на все версионирования, даты запрета, рлс потому что неохота лезть на итс))
nekit_rdx; milov.aleksey; +2 1 Ответить
10. Labotamy 11.10.19 13:30 Сейчас в теме
Не увидел указания под какую версию БСП этот "склерозник"?
Дмитрий74Чел; aegoncharov; +2 Ответить
11. wolfsoft 2424 14.10.19 07:59 Сейчас в теме
Как уже писали в комментариях, вам для каждой версии БСП придётся писать отдельные шпаргалки.
14. AlX0id 13.02.20 09:50 Сейчас в теме
(11)
Если бы авторы БСП хоть чуть-чуть думали головой о последствиях изменений в оной - пришлось бы реже, чем для каждой. Но де-факто да.
12. grayskin 1 20.11.19 10:18 Сейчас в теме
Не забыть еще в Свойствах Формы События Процедуры прописать
Прикрепленные файлы:
15. echo77 1705 25.10.20 11:26 Сейчас в теме
(0) Я один вижу весь код в одну строку?
16. V1V 112 30.10.20 09:22 Сейчас в теме
да, код в одну строку.
возможно автор просто так код пишет )))
v.merkulov; +1 Ответить
17. vissarion249 08.12.20 04:37 Сейчас в теме
(16) Просто он на лету обфусцирует код
18. R_o_n_n_y 64 27.03.21 15:48 Сейчас в теме
В новой БСП можно сократить код подключения обработки, достаточно:
Функция СведенияОВнешнейОбработке() Экспорт

Процедуры/функции ПолучитьСтруктуруТаблицыКоманд(); ДобавитьКоманду(); СформироватьСписокКоманд(Команды) не нужны
19. Jungle Murzik 08.05.21 15:32 Сейчас в теме
Еще можно было бы дать ссылку на ИТС: https://its.1c.ru/db/bsp22doc#content:219:1
Там, кстати, написано, почему не обязательно, чтобы в списке присутствовала Ссылка
20. Romyl01 37 16.10.21 12:53 Сейчас в теме
21. lesv 35 25.11.21 13:24 Сейчас в теме
22. jan-pechka 356 06.04.22 10:19 Сейчас в теме
Автор забыл, что если это внешняя печатная форма из документа, то нужно этот новый документ зарегистрировать в ОпределяемыеТипы "ОбъектСДополнительнымиКомандами"
!!!! и после этого запустить обр-ку из БСП "ОбновлениеВспомогательныхДанных"
!!! и еще очень важно на форме создать реквизит "ПараметрыПодключаемыхКоманд" с типом Произвольный.

п.с. а вот с запуском БСП-шной обработки "ОбновлениеВспомогательныхДанных" в переписанных конфигурациях (особенно если в ней множество собственных ролей) - может быть облом....А ведь по задумке 1с-ников именно эта обработка должна прописать в справочник "ОбъектыМетаданных" наш новый документ.
п.с.2. у меня данная обработка не сработала, в справочник "ОбъектыМетаданных" записала через перезапуск 1с с параметрами "/C ЗапуститьОбновлениеИнформационнойБазы" , читаю справочник, вижу зарегистрированный самописный документ, но его нету в справочнике "ДополнительныеОтчетыИОбработки"-> "НазначениеОбъекта" (это чтобы запустить Печатную форму через внешнюю обработку из документа-как 2-й вариант).....хотя я же зарегистрировала этот док. в ОпределяемыеТипы "ОбъектСДополнительнымиКомандами"....заколдованный круг!

Вывод: отвертеться не получится и придется ремонтировать/искать ошибки в БСП, к-й вшит в конфигурацию....
свою проблему пытаюсь решить здесь: https://forum.infostart.ru/forum29/topic279679/#message2809276
23. jan-pechka 356 06.04.22 13:19 Сейчас в теме
"// СтандартныеПодсистемы.Печать
&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект);
КонецПроцедуры "


на моей БСП 3.0.1.428 в конфигураторе у типовых документов стоит:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	//УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма);
	// СтандартныеПодсистемы.ПодключаемыеКоманды
	ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
	// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
	
	
	// СтандартныеПодсистемы.ВерсионированиеОбъектов
	ВерсионированиеОбъектов.ПриСозданииНаСервере(ЭтотОбъект);
	// Конец СтандартныеПодсистемы.ВерсионированиеОбъектов
	
	Если Параметры.Ключ.Пустая() Тогда
		ПодготовитьФормуНаСервере();
	КонецЕсли;
	
	// ИнтернетПоддержкаПользователей.Новости.КонтекстныеНовости_ПриСозданииНаСервере
	ИдентификаторыСобытийПриОткрытии = "ПриОткрытии";
	ОбработкаНовостейПереопределяемый.КонтекстныеНовости_ПриСозданииНаСервере(
		ЭтаФорма,
		"БП.Документ.Инвентаризация",
		"ФормаДокумента",
		НСтр("ru='Новости: Инвентаризация'"),
		ИдентификаторыСобытийПриОткрытии
	);
	// Конец ИнтернетПоддержкаПользователей.Новости.КонтекстныеНовости_ПриСозданииНаСервере
	
	ДополнительныеОтчетыИОбработки.ПриСозданииНаСервере(ЭтотОбъект);
	//
КонецПроцедуры
Показать


т.е. //УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма); - устаревшая.............

может кто знает: где искать коды под конкретные версии БСП?....................
24. newvideo 01.07.22 15:01 Сейчас в теме
в типовых на форме списка нет никаких ссылок и печать работает, ссылка на форме не всегда нужна
25. ryapa 21.10.22 09:52 Сейчас в теме
ПоложениеКоманднойПанели поставить Верх

Огромное спасибо!!! Вынырнул в полнейшем отчаянии из многочасового спагетти-трипа по БСП, и случайно наткнулся на эту статью.
26. mrKHrom 17.02.23 16:50 Сейчас в теме
Оставьте свое сообщение

См. также

Использование типовых возможностей 1С и их расширение. Часть 1

Инструкции пользователю БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Инструкция пользователю системы 1С:Предприятие по способам использования и расширения возможностей типовых конфигураций и их практической реализации.

29.10.2022    5024    ixijixi    7    

54

Система контроля ведения учета [БСП]

Универсальные функции Механизмы типовых конфигураций БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В данном материале рассмотрим типовой алгоритм подсистемы контроля учета БСП в конфигурациях на примерах.

18.07.2022    4652    quazare    8    

91

Оценка производительности с помощью БСП

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В данной статье будут рассмотрены базовые возможности подсистемы "Оценка производительности" в библиотеке стандартных подсистем.

30.06.2022    3849    quazare    8    

53

1СПАРК РИСКИ. Сервис оценки благонадежности контрагентов. Промо

СПАРК помогает предотвратить мошенничество со стороны компаний и предпринимателей, благодаря актуальным сведениям о компаниях и системе выявления факторов риска.Сервис позволяет управлять налоговыми рисками и комплексно оценивать благонадежность контрагентов.

Разработка конфигурации на основе Библиотеки стандартных подсистем 3.1.6.245

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Россия Бесплатно (free)

С применением БСП становится возможной быстрая разработка новых конфигураций с уже готовой базовой функциональностью, также БСП позволит достичь большей стандартизации конфигураций. В данной статье кратко разберем внедрение БСП 3.1.6.245 на пустую конфигурацию.

06.06.2022    4920    user1432326    5    

25

Базовые принципы работы с регламентными заданиями подсистем БСП

Универсальные функции БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В очередной публикации рассмотрим некоторые базовые приемы работы с регламентными заданиями в рамках библиотеки стандартных подсистем

22.05.2022    7381    quazare    24    

52

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Шаблоны сообщений пользователю - подсистема БСП

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Управленческий учет Бесплатно (free)

В данной небольшой статье рассмотрим практические примеры создания шаблонов сообщений пользователю и их отправки с помощью типового функционала библиотеки стандартных подсистем.

15.05.2022    7355    quazare    5    

95

Еще раз о дополнительных реквизитах и дополнительных сведениях

Адаптация типовых решений БСП (Библиотека стандартных подсистем) Механизмы типовых конфигураций Платформа 1С v8.3 Конфигурации 1cv8 Россия Бесплатно (free)

Дополнительные реквизиты и сведения существуют давно. Задумка очень хорошая. Суть этих механизмов понятна всем. По этому поводу написано много. Что тут можно сказать нового? Однако бес, как всегда, в деталях. Как создавали реквизиты в объектах типовых конфигураций, так и продолжаем это делать. Почему это происходит? За всех сказать не могу. Могу рассуждать только на своем примере. Являясь убежденным практиком, одно могу сказать вполне определенно. Если что-то на практике недостаточно удобно, то останется оно главным образом в теории... Если не приложить немного усилий.

11.05.2022    8399    user1374747    19    

48

Модули общего назначения - готовые полезные функции и процедуры конфигураций на БСП

Универсальные функции БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В данной статье я рассматриваю несколько полезных "классических" функций и процедур для работы с данными, которые уже встроены в БСП и готовы к использованию.

25.04.2022    8955    quazare    11    

125

Правила регистрации объектов 1С:БСП

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Здравствуйте, коллеги! В статье рассмотрим работу с правилами регистрации объектов в библиотеке стандартных подсистем 1С.

20.04.2022    8378    Koder_Line    11    

30

Многопоточный режим выполнения процедуры с помощью методов БСП - примеры разработки

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В данной статья я рассмотрю примеры использования выполнения функций и процедур в многопоточном режиме, используя возможности Библиотеки стандартных подсистем (БСП).

01.04.2022    6484    quazare    14    

115

Видеокурс-практикум: как подготовить и написать ТЗ, ЗНР, ЧТЗ. Промо

В курсе обобщен опыт работы аналитика на проектах в течение пяти лет, в нескольких фирмах. Подходы к написанию документов унифицированы и по возможности не привязаны к конфигурациям 1С.

3 500 рублей

Необычное решение для хранения настроек внешней обработки

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 1С:Комплексная автоматизация 2.х Россия Бесплатно (free)

При написании внешней обработки, например для импорта данных из сторонней базы данных используя HTTP-сервисы, необходимо сохранять настройки соединения с HTTP. Подсказали оригинальный способ сохранения настроек с БД. При использовании "ХранилищеОбщихНастроек" все сильно зависит от прав пользователя. Чтобы читать настройки, сохраненные другим пользователем, необходимы права: "АдминистрированиеДанных". Как-то не хочется раздавать всем пользователям права администратора. Помогает БСП.

25.03.2022    1301    AlexeyRaevsky    7    

5

Получение контактной информации из отбора

Адаптация типовых решений Универсальные функции БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Универсальная функция получения контактной информации из отбора компоновки данных. Весь код в статье.

25.03.2022    1724    ixijixi    0    

11

Стандартные подсистемы БСП - параметры работы клиента и возможности диалогов

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В данной небольшой статье рассмотрим обработку параметров работы клиента и режим диалога (выбора вопроса) модулей "стандартные подсистемы" БСП.

22.03.2022    5475    quazare    10    

79

Полезный код для программистов 1С (часть 3). Подготовка печатных форм + подсистема Управление печатью (БСП)

БСП (Библиотека стандартных подсистем) Универсальные функции Платформа 1С v8.3 Бесплатно (free)

Мы все любим 1С, не так ли? Вот дает 1С прекрасный механизм возможности модификации макетов печатных форм в БСП. А из всех рекомендаций это получение макета и заполнение параметров областей. И вы спросите: "А что не так... ты печатные формы накодить не можешь без указаний сверху?". Да вот в том то и дело, что я могу все. А вот пользователям от такого механизма пользы 0, если из всех доступных изменений остаются только шрифты, да текст произвольный накинуть. А ведь можно больше, надо только соблюдать несколько правил при подготовке печатных форм...

07.03.2022    8722    vandalsvq    0    

56

Распознавание и загрузка документов в 1С Промо

Универсальная программа-обработка для распознавания любых сканов или фото первичных документов в 1С (счета-фактуры, УПД, ТТН, акты и тд). Точность распознания до 98%.

от 11 рублей

Как поженить типовой RLS и новый документ

БСП (Библиотека стандартных подсистем) Роли и права Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Создание доступа на уровне записей (RLS) для нового документа средствами библиотеки стандартных подсистем (БСП).

02.02.2022    3001    serg61    4    

30

Управление доступом - как быстро доработать RLS (БСП)

БСП (Библиотека стандартных подсистем) Роли и права Платформа 1С v8.3 Управление правами Конфигурации 1cv8 Бесплатно (free)

Ранее в своей статье - https://infostart.ru/1c/articles/1535498/, подробно описывал по процессу доработки производительного RLS. Для оперативной доработки RLS может потребоваться значительного времени разбора процесса RLS. Для таких случае 1С в своей поставки БСП разработала удобный помощник для доработки производительного RLS (данная доработка не требует глубокого понимания RLS). Как я увидел, многие не знакомы с данной обработкой, поэтому в данной статье хочу рассказать про данную обработку и её возможности.

31.01.2022    5959    Shining_ninja    4    

83

Использование отчетов в конфигурациях на базе БСП 3.1.5 на примере 1С: Комплексная автоматизация 2.4

Работа с интерфейсом БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Библиотека стандартных подсистем (БСП) постоянно развивается. Разработчики типовых конфигураций постепенно будут переходить на новую версию Библиотеки 3.1.5. Например, пользователи 1С: Комплексная автоматизация (КА) уже заметили некоторые интерфейсные изменения в новой редакции 2.5. При этом не все изменения очевидны. В частности, изменился интерфейс формирования и настройки отчетов. Для тех, кто при пользовании типовыми отчетами умеет больше, чем простое нажатие кнопки Сформировать, будет полезным ознакомиться с основными изменениями.

20.12.2021    1443    Sergey1CSpb    5    

6

Подключение функционала "Присоединенные файлы" для нового объекта (БСП)

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Управляемые формы 1С:Бухгалтерия 3.0 Россия Бесплатно (free)

Данная статья поможет добавить "скрепку", т.е. возможность пользоваться функционалом БСП для присоединения файлов к любому документу.

24.11.2021    17457    kalyuzhnyyp    29    

59

Профили управления доступом к объектам в любой конфигурации на БСП

БСП (Библиотека стандартных подсистем) Роли и права Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В данной статье рассмотрим механизмы стандартного управления профилями доступа к объектам в любой типовой конфигурации, в основе которой лежит БСП.

17.11.2021    6173    quazare    5    

100

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Журнал регистрации - основные методы работы через БСП

Журнал регистрации БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В данной небольшой статье я привожу практические примеры работы с журналом регистрации средствами и методами библиотеки стандартных подсистем.

11.11.2021    15666    quazare    15    

83

Базовые приемы работы с кластером 1С при помощи БСП

Администрирование СУБД БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В данной публикации я рассматриваю базовые приемы работы с кластером серверных баз 1С, используя типовые типовые возможности библиотеки стандартных подсистем (БСП).

26.10.2021    5943    quazare    7    

101

Подключение нового справочника к подсистемам БСП (дополнительные реквизиты, файлы, запрет редактирования)

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Россия Бесплатно (free)

В данной статье я привожу пример подключения нового справочника к подсистемам БСП. Статья будет применима как к самописным конфигурациям на базе БСП, так и к типовым УТ, ERP, БП и прочим конфигурациям на базе БСП.

17.08.2021    6077    maraty    15    

58

Запуск Wscript.Shell и Shell.Application. Заметки

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Бесплатно (free)

Некоторые примечания по работе с запуском приложений.

10.08.2021    9208    Yashazz    0    

19

Префиксация объектов - полезный типовой функционал БСП

Универсальные функции БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Россия Бухгалтерский учет Управленческий учет Бесплатно (free)

В данной публикации предлагаю рассмотреть основные типовые возможности библиотеки стандартных подсистем (БСП), касаемые префиксации объектов конфигураций.

21.06.2021    10140    quazare    4    

61

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Обзор полезных методов БСП 3.1.4. Часть 2

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Бесплатно (free)

Библиотека стандартных подсистем (далее - БСП) является частью любой типовой конфигурации, поэтому умение применять готовые процедуры и функции повышает качество разработки и избавляет от написания лишнего кода. К сожалению, не у всех есть время и упорство овладеть всей документацией, поэтому я собрал воедино наиболее популярный функционал.

27.04.2021    30718    rayastar    8    

309

Обзор полезных методов БСП 3.1.4

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Библиотека стандартных подсистем (далее - БСП) является частью любой типовой конфигурации, поэтому умение применять готовые процедуры и функции повышает качество разработки и избавляет от написания лишнего кода. К сожалению, не у всех есть время и упорство овладеть всей документацией, поэтому я собрал воедино наиболее популярный функционал.

25.03.2021    82508    rayastar    56    

888

Печать макета MS Word в любом документе с помощью БСП

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В данной статье рассмотрим типовой функционал вывода на печать макетов печатных форм MS Word (*.docx) для любого документа конфигурации, основанной на библиотеке стандартных подсистем. Вариант клиент-серверный.

23.02.2021    13809    quazare    20    

110

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Базовое понимание внедрения механизма печати в любом документе конфигурации на БСП

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Россия Бесплатно (free)

В данной статье рассмотрим базовое применение методов вывода на печать макетов печатных форм с помощью БСП любых типовых или собственных документов.

17.02.2021    20432    quazare    20    

141

Генерация штрихкодов с помощью БСП для программистов

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Россия Управленческий учет Бесплатно (free)

В данной публикации рассмотрим базовый функционал библиотеки стандартных подсистем (БСП) формирования штрихкодов для вывода на печать.

09.01.2021    21621    quazare    25    

108

Асинхронное выполнение длительных операций

БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Россия Бесплатно (free)

Демонстрация использования функционала БСП для выполнения длительных операций. Механизм может быть полезен, например, при загрузке/выгрузке больших объемов данных.

28.12.2020    2954    prog_mayskiyse    8    

20

Сохранение настроек

Универсальные функции БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Делюсь еще одним не самым очевидным способом хранения настроек в базах на БСП без доработки конфигурации. Весь код в статье.

22.11.2020    9068    ixijixi    8    

66