Шпаргалка (БСП). Добавление в новый документ механизма печати дополнительных печатных форм

Публикация № 1132897

Разработка - Печать

БСП печать кнопка механизм печатные формы

101
Постоянно приходится вспоминать, как добавить механизм печати (БСП) в новый документ. Поэтому решил написать шпаргалку.

1. В форму документа добавить процедуры:

 
// СтандартныеПодсистемы.Печать
&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)	
	УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект);	
КонецПроцедуры 
// Конец СтандартныеПодсистемы.Печать

// СтандартныеПодсистемы.ПодключаемыеКоманды
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
	ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
	ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Объект, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
	ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды

 

2. Добавить в события формы документа:

 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
	// СтандартныеПодсистемы.ПодключаемыеКоманды
	ПодключаемыеКомандыКлиент.НачатьОбновлениеКоманд(ЭтотОбъект);
	// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
КонецПроцедуры
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	// СтандартныеПодсистемы.ПодключаемыеКоманды
	ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
	// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
КонецПроцедуры
&НаСервере
Процедура ПриЧтенииНаСервере(ТекущийОбъект)
	// СтандартныеПодсистемы.ПодключаемыеКоманды
	ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
	// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
КонецПроцедуры

 

3. В модуль менеджера нового документа 

 
#Область Печать

// Заполняет список команд печати.
// 
// Параметры:
//   КомандыПечати - ТаблицаЗначений - состав полей см. в функции УправлениеПечатью.СоздатьКоллекциюКомандПечати
//
Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт
	
КонецПроцедуры

// Сформировать печатные формы объектов
//
// ВХОДЯЩИЕ:
//   ИменаМакетов    - Строка    - Имена макетов, перечисленные через запятую
//   МассивОбъектов  - Массив    - Массив ссылок на объекты которые нужно распечатать
//   ПараметрыПечати - Структура - Структура дополнительных параметров печати
//
// ИСХОДЯЩИЕ:
//   КоллекцияПечатныхФорм - Таблица значений - Сформированные табличные документы
//   ПараметрыВывода       - Структура        - Параметры сформированных табличных документов
//
Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
	ФормированиеПечатныхФорм.ЗаполнитьПараметрыОтправки(ПараметрыВывода.ПараметрыОтправки, МассивОбъектов, КоллекцияПечатныхФорм);
	
КонецПроцедуры

Функция ДоступныеДляШаблоновПечатныеФормы() Экспорт
	
	МассивДоступныхПечатныхФорм = Новый Массив;
	
	Возврат МассивДоступныхПечатныхФорм

КонецФункции

#КонецОбласти

 

4. В общий модуль УправлениеПечатьюПереопределяемый в процедуру ПриОпределенииОбъектовСКомандамиПечати добавить строчку.

 
Процедура ПриОпределенииОбъектовСКомандамиПечати(СписокОбъектов) Экспорт
	
	СписокОбъектов.Добавить(Документы.НовыйДокумент);
	
КонецПроцедуры

 

5. В модуль дополнительной печатной формы добавить процедуры

 
#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда
	
#Область ПрограммныйИнтерфейс

Функция СведенияОВнешнейОбработке() Экспорт
	
	СведенияОВнешнейОбработке = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.3.1.73");
	СведенияОВнешнейОбработке.Вставить("Вид", ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма());
	СведенияОВнешнейОбработке.Вставить("Назначение", ПолучитьНазначениеОбработки());
	СведенияОВнешнейОбработке.Вставить("Наименование", "Новый документ");
	СведенияОВнешнейОбработке.Вставить("Версия", "1.0");
	СведенияОВнешнейОбработке.Вставить("Информация", "Новый документ");
	СведенияОВнешнейОбработке.Вставить("БезопасныйРежим", Ложь);
	СформироватьСписокКоманд(СведенияОВнешнейОбработке.Команды);
	
	Возврат СведенияОВнешнейОбработке;
	
КонецФункции

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
	ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "НовыйДокумент");
	
	Если ПечатнаяФорма <> Неопределено Тогда
		ПечатнаяФорма.ТабличныйДокумент = СформироватьПечатнуюФорму(МассивОбъектов);
		ПечатнаяФорма.СинонимМакета = НСтр("ru = 'Новый документ'");
	КонецЕсли;
	
КонецПроцедуры

#КонецОбласти

Функция СформироватьПечатнуюФорму(МассивОбъектов) Экспорт
	
	Док = МассивОбъектов[0];
	
	//Тут заполняем печатную форму
	//Макет				=  ПолучитьМакет("Макет");
	//ОбластьЗаголовок	= Макет.ПолучитьОбласть("Заголовок");
	//ТабличныйДокумент.Вывести(ОбластьЗаголовок);
	
	ТабличныйДокумент	= Новый ТабличныйДокумент;	
	Возврат ТабличныйДокумент;
	
КонецФункции

#Область СлужебныеПроцедурыИФункции

Функция ПолучитьНазначениеОбработки()
	
	Результат = Новый Массив;
	
	Результат.Добавить("Документ.НовыйДокумент");
	
	Возврат Результат;
	
КонецФункции

Функция ПолучитьСтруктуруТаблицыКоманд()
	
	Результат = Новый ТаблицаЗначений;
	
	Результат.Колонки.Добавить("Представление",			Новый ОписаниеТипов("Строка"));
	Результат.Колонки.Добавить("Идентификатор",			Новый ОписаниеТипов("Строка"));
	Результат.Колонки.Добавить("Использование",			Новый ОписаниеТипов("Строка"));
	Результат.Колонки.Добавить("ПоказыватьОповещение",	Новый ОписаниеТипов("Булево"));
	Результат.Колонки.Добавить("Модификатор",			Новый ОписаниеТипов("Строка"));
	
	Возврат Результат;
	
КонецФункции

Процедура ДобавитьКоманду(Команды, Идентификатор, Представление, Использование, ПоказыватьОповещение = Ложь, Модификатор = Неопределено)
	
	НоваяКоманда = Команды.Добавить();
	
	НоваяКоманда.Идентификатор			= Идентификатор;
	НоваяКоманда.Представление			= Представление;
	НоваяКоманда.Использование			= Использование;
	НоваяКоманда.ПоказыватьОповещение	= ПоказыватьОповещение;
	НоваяКоманда.Модификатор			= Модификатор;
	
КонецПроцедуры

Процедура СформироватьСписокКоманд(Команды)
	
	ДобавитьКоманду(Команды, "НовыйДокумент", "Новый документ", ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода(), Истина);
	
КонецПроцедуры

#КонецОбласти

#КонецЕсли

 

Тестировал на:

1С:Предприятие 8.3 (8.3.13.1644)

1С:Комплексная автоматизация 2 (2.4.6.207)

101

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. MSK_Step 19 10.10.19 15:15 Сейчас в теме
класс, надо такие же сделать на версионирование, дату запрета редактирования и другие полезные фишки
Светлый ум; DrAku1a; Sergafan10; +3 Ответить
2. Sergafan10 10.10.19 15:18 Сейчас в теме
(1) с версионированием каждый раз велосипед изобретать приходится))
6. John_d 672 11.10.19 10:34 Сейчас в теме
(1) Версионирование
1. Добавить Новый объект в Подписки на события "ЗаписатьВерсиюДокумента"
2. Добавить Новый объект в Определяемые типы "ВерсионируемыеДанные"
3. В режиме предприятия настроить хранение данных:
Администрирование -> Общие настройки -> История изменений -> Настройки хранения
В списке объектов найти новый объект и поставить напротив него "При записи"
fight1c; glorry; +2 Ответить
8. MSK_Step 19 11.10.19 11:50 Сейчас в теме
(6) Вы забыли про код в форме при создание на сервере
// СтандартныеПодсистемы.ВерсионированиеОбъектов
ВерсионированиеОбъектов.ПриСозданииНаСервере(ЭтотОбъект);
// Конец СтандартныеПодсистемы.ВерсионированиеОбъектов

и другие нюансы, про которые незнаете и надо внимательно читать на ИТС

Как для этого такие "Подсказки" помогают, когда ночью уже голова не соображает, то такие пошаговые выручают, так как зачем это все помнить
3. dock 35 10.10.19 19:11 Сейчас в теме
Для идеальности не хватает только указания версии БСП....
Автору огромный плюс!
4. ColaKola 14 10.10.19 22:05 Сейчас в теме
чем вас не устроила ссылка на официальную документацию в избранном?
aegoncharov; Labotamy; Йожкин Кот; Sashares; asupsam; +5 3 Ответить
5. Labotamy 10.10.19 22:21 Сейчас в теме
ИТС не предлагать?
Sashares; +1 Ответить
7. MSK_Step 19 11.10.19 11:43 Сейчас в теме
(5)ахаха, вы сравнили, тут все четко разложено, там надо вникать. Я уверен на 100%, что вы у себя при разработке нового документа забиваете на все версионирования, даты запрета, рлс потому что неохота лезть на итс))
10. Labotamy 11.10.19 13:30 Сейчас в теме
Не увидел указания под какую версию БСП этот "склерозник"?
aegoncharov; +1 Ответить
11. wolfsoft 2420 14.10.19 07:59 Сейчас в теме
Как уже писали в комментариях, вам для каждой версии БСП придётся писать отдельные шпаргалки.
Оставьте свое сообщение

См. также

Реализация команды печати "Библиотека стандартных подсистем", редакция 3.1 (3.1.1.151) 4

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) БСП (Библиотека стандартных подсистем)

В новом релизе "БСП" произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

12.10.2019    523    paulis    4       

От чего можно отказаться при разработке расширений 1С 73

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Расширения

Разработка расширений 1С и оптимизация через механизм БСП: Дополнительные отчеты и обработки.

23.09.2019    4674    independ    23       

Подсистема "Варианты отчетов". Используете ли Вы ее правильно? 208

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом БСП (Библиотека стандартных подсистем)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    13667    YPermitin    49       

Подсистема БСП «Управление доступом», основные объекты и регистры 104

Статья Программист Нет файла v8 v8::УФ v8::Права 1cv8.cf Бесплатно (free) БСП (Библиотека стандартных подсистем) Роли и права

Основные принципы работы подсистемы «Управление доступом» из состава БСП. Виды доступа, ограничение доступа на уровне записей. Описание основных объектов и регистров, используемых подсистемой.

23.05.2019    7583    ids79    8       

Универсальная Форма для внешней печатной формы документа 9

Статья Программист Стажер Нет файла v8 1cv8.cf Бесплатно (free) Печатные формы документов

Универсальная форма вызова процедуры "Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыПечати)", чтобы каждый раз не изобретать велосипед! Реализация протестирована на 1С 8.3.12.1714 (x64).

10.05.2019    2790    Eret1k    4       

Реализация интерактивного редактирования макета Microsoft WORD из 1С для пользователя 9

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Печатные формы документов Практика программирования Разработка

Пользователь сам сможет редактировать макет Microsoft Word и в последствии использовать его для печати документа, справочника и т.д. Реализация протестирована на 1С 8.3.12.1714 (x64).

23.04.2019    2387    Eret1k    6       

Добавление отчетов в типовые конфигурации 1С 200

Статья Программист Нет файла v8::УФ v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Описание различных способов добавления общих и контекстных отчетов в конфигурации 1С, построенные на базе БСП. Основные моменты и нюансы.

07.03.2019    22669    ids79    32       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 162

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    15072    ids79    9       

Сдача 2-НДФЛ за 2018 год из конфигурации Зарплата и Управление Персоналом, редакция 2.5 (2.5.130.2) 22

Статья Бухгалтер Нет файла v8 v8::СПР ЗУП2.5 Россия БУ Windows Зарплата НДФЛ Бесплатно (free) Регламентированная отчетность

В статье я пошагово описал процесс сдачи отчётности из 1С ЗУП редакции 2.5 через программу "Налогоплательщик ЮЛ". Весь процесс я разбил на 5 шагов, подробно и с картинками описал каждый шаг.

05.01.2019    17177    busa_nn    23       

Макеты печатных форм в руках пользователей (обычные формы) 15

Статья Программист Нет файла v8 Россия Бесплатно (free) Универсальные печатные формы Практика программирования

Как частично избавить себя от низкопрофильного труда по правке печатных форм. Для конфигураций на основе БСП, конечно, не актуально, но для нетиповых вполне. Ну и как в помощь начинающим. У меня реализовано для печати различных "согласие на обработку персональных данных","согласие на медицинские вмешательства", различных анкет. Удобно для печатных форм, которые часто по тем или иным причинам меняются. Чтоб не дергать программиста, пусть пользователи рисуют макеты самостоятельно.

01.11.2018    4593    fromlion    3       

Пакетная печать в строго заданном порядке 6

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Пакетная печать

В силу различных особенностей ПО, ОС, драйверов и т.д. порядок печати документов не всегда совпадает с порядком их отправки на печать. Данный метод позволяет всегда получать на выходе нужный порядок документов.

19.09.2018    5255    crazycat    17       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46322    bugtester    43       

БСП. Настраиваемый комплект документов. Внешние печатные формы 96

Статья Программист Нет файла v8::СПР v8::УФ ЗУП3.x Бесплатно (free) Печатные формы документов

В демо-конфигурации "БСП" есть пример реализации механизма "Настраиваемый комплект документов", использующий встроенные печатные формы. Эта статья - развитие темы в сторону использования в своей обработке других внешних печатных форм.

09.06.2017    18316    WhiteOwl    12       

Фоновое формирование отчета СКД на УФ средствами БСП 81

Статья Программист Нет файла v8::УФ v8::СКД Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем)

В узких кругах широко известна проблема, когда штатное фоновое формирование отчета СКД на управляемых формах перестает работать при выполнении нештатной компоновки (переопределении события ПриКомпоновкеРезультата). В этом случае клиент ожидает ответа сервера и сеанс 1С "висит", что жутко неудобно при формировании затратных по времени отчетов. Также нет возможности прервать такое выполнение. Когда мириться с этим стало тяжело, стал искать решения, но почему-то подходящего готового рецепта не нашел. Если плохо искал, значит, будет еще один в копилку.

16.05.2017    22713    herfis    7       

Библиотека стандартных подсистем (Механизм БСП) 74

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем)

Конфигурации в 1С пишутся для пользователей и по их «правилам» (клиент всегда прав), поэтому в основном все конфигурации разные, но достаточно часто в них используются одни и те же объекты, которые незначительно отличаются друг от друга. Действительно, сложно представить конфигурацию, где не фигурировали бы такие сущности как номенклатура, контрагенты, пользователи, валюта. И некоторые задачи являются типичными: возможность базового разграничения прав, работа с электронной почтой, задачи пользователям и т.д. Но...!

03.03.2017    50950    V.Stavinsky    21       

Кубик-рубик для деклараций 11 и 12 по данным 1С.Розница, ЕГАИС и других программ и источников. (Сбор/разбор деклараций на части и их анализ) 17

Статья Бухгалтер Нет файла v8::ОУ Розница Россия БУ УУ Windows Розничная торговля Бесплатно (free) Регламентированная отчетность Бухгалтерский учет

Рассмотрены самые сложные ситуации(даже когда все данные утеряны). Алкогольные декларации 11 и 12 по данным 1С.Розница и других программ и источников.(Сбор/разбор деклараций на части и их анализ). "Приготовление" деклараций с учетом заданных/требующихся входных/выходных параметров. Рассматриваем самые сложные(изначально кажущиеся безвыходными) ситуации. Подходит тем, кто окончательно запутался в связи с введением ЕГАИСа в розничное звено.

09.12.2016    18682    liginrambler    7       

Используем механизмы обмена данными БСП для произвольного обмена 147

Статья Программист Нет файла v8 Бесплатно (free) Универсальные функции Внешние источники данных БСП (Библиотека стандартных подсистем)

Механизм БСП заточен на обмен XML по правилам обмена. Чтобы использовать его для любого другого обмена, коих в мире немало, требуются доработки. В статье описан вариант, как из положения выйти.

23.08.2016    27570    Патриот    22       

Как устроена регламентированная отчетность в 1С 252

Статья Программист Нет файла v8 1cv8.cf Россия БУ Windows Бесплатно (free) Практика программирования Регламентированная отчетность

Регламентированная отчетность - это универсальный механизм конфигураций 1С. Принцип её работы во всех конфигурациях идентичен, различаются только источники данных для заполнения. Поэтому, раз познакомившись, Вы сможете использовать эти знания в любых конфигурациях.

30.11.2015    58289    mrXoxot    28       

Отладка конвертации данных 2.1 в конфигурациях, построенных на БСП 2.1 (БП 3.0, УТ 11 etc.) 48

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Распределенная БД (УРИБ, УРБД) Обмен через XML БСП (Библиотека стандартных подсистем)

Отладка процесса выгрузки/загрузки данных при проведении синхронизации в новых конфигурациях 1С может вызвать (у меня вызвала) некоторые затруднения. О них и пойдёт речь.

29.10.2015    31485    NittenRenegade    16       

Обмен при помощи Библиотеки Стандартных Подсистем (БСП) конфигурации ЗУП 2.5 10

Статья Программист Нет файла v8 ЗУП2.5 Бесплатно (free) Перенос данных из 1C8 в 1C8 БСП (Библиотека стандартных подсистем)

Как организовать автообмен данными из базы Зарплата и Управление Персоналом 2.5? Очень просто. Кодирование нужно лишь для одной команды - всего несколько строчек кода.

17.07.2015    12005    sml    4       

Идея: визуальный редактор или альтернативная печать ценников, этикеток, штрих-кодов 42

Статья Программист Нет файла v8 Розница Розничная и сетевая торговля (FMCG) Windows Розничная торговля Бесплатно (free) Ценники

Идея : создание визуального редактора (актуальный предварительный просмотр) для конечного пользователя , а не программиста !

24.06.2015    25941    Tatitutu    17       

Изменение настроек программы 1С для выгрузки отчета п-4 в орган статистики 15

Статья Бухгалтер Нет файла v8 ЗУП2.5 Россия БУ Windows Зарплата Бесплатно (free) Регламентированная отчетность

В данной публикации рассматривается ответ на вопрос: Как изменить формат выгрузки, если из Росстата пришел ответ "Отчет заполнен с использованием старой версии шаблона"?

12.02.2015    23973    vesh    8       

Авторегистрация внешних отчётов/обработок средствами БСП 60

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Администрирование данных 1С Универсальные функции

Вы сделали клиенту красивую печатную форму, или доп.обработку, или заполнение таб.части; но надо ещё зарегистрировать её. Клиенту это не всегда объяснишь, дистанционно не всегда сделаешь. А дальше её ещё обновлять каждый раз... Предлагаю код, который исключительно штатным образом "сделает всё сам".

11.02.2015    20324    Yashazz    14       

БСП: добавление нового провайдера SMS 52

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) SMS рассылки

Небольшая статья о том, как добавить нового провайдера SMS на примере конфигурации "Управление торговлей 11", используя библиотеку стандартных подсистем (БСП)

26.11.2014    18272    pbazeliuk    5       

Использование подсистемы "Управление доступом" из состава БСП версии 2.2+ 226

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

В статье описана последовательность манипуляций с подсистемой "Управление доступом" из библиотеки стандартных подсистем "1С" (БСП), результатом которых является реализация возможности настройки ограничения доступа к данным на уровне записей таблиц базы данных (RLS), применяя в качестве разграничителя доступа (критерия ограничения) любой из справочников конфигурации. Данная статья полезна для разработчиков, которые имеют дело либо с одной из типовых конфигураций "1С" (таких как "Бухгалтерия предприятие 3.0" или "Управление торговлей 11"), либо собираются внедрять (или дорабатывать) указанную выше подсистему в какую-либо другую конфигурацию.

18.11.2014    56742    Bassgood    81       

УТ 11.1 Знак рубля на ценнике, шрифтом, без конфигуратора 19

Статья no Нет файла v8 УТ10 БУ Розничная торговля Бесплатно (free) Ценники

Банк России 11 декабря 2013 года утвердил графическое обозначение рубля (символ рубля) в виде прописной буквы «Р» кириллического алфавита, дополненной в нижней части горизонтальной чертой.

16.06.2014    27597    Yury1001    9       

Подход к организации печати одного макета документа из обычной и управляемой форм документа (интерфейс Такси) 32

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Универсальные печатные формы Печатные формы документов Математика и алгоритмы

В статье описывается подход к реализации печати одного макета из управляемой и обычной формы документа. Описанная методика близка к преподаваемой в учебных центрах 1С.

10.10.2013    34404    RailMen    9       

Печать ценников в УТ 3.0 для Украины 13

Статья Программист Нет файла v8 УТ10 Украина Windows Розничная торговля Бесплатно (free) Ценники

Если вы хотите, чтобы ценники в вашем магазине были красивыми и аккуратными, обращали на себя внимание клиентов, занимали минимум времени и усилий для печати и настройки, то функционал печати ценников в «1С: Управление торговлей для Украины 3.0» именно для вас.

01.02.2013    20856    aharechko    3       

Видео. Автозаполняемые шаблоны документов в «1С:Документооборот 8» 16

Статья Программист Нет файла v8 ДО Windows Бесплатно (free) Печатные формы документов

В этом видеокурсе будет рассмотрен пример подготовки автозаполняемых шаблонов документов в «1С:Документооборот». Автозаполняемые шаблоны могут существенно сократить время пользователей на подготовку печатных форм типовых документов за счет автоматического создания файлов с уже подставленными данными из карточки документа.

13.11.2012    19143    ИТ-Терминал    3       

Подписанты - "Указание в первичных документах подписывающих лиц" 7

Статья Системный администратор Программист Нет файла v8 КА1 УПП1 БУ НУ УУ Бесплатно (free) Печатные формы документов

Хотелось бы обратить внимание, добавленный функционал. УПП Версия 1.3.29 и КА Версия 1.1.25 Указание в первичных документах подписывающих лиц, т.е. кто подписывает, на основании чего.

01.10.2012    25783    Константин С.    6       

Решение: Универсальный счет с логотипом, печатью и отправкой в формате PDF 22

Отчеты и формы Бухгалтер Пользователь Архив с данными v8 КА1 УТ10 Россия Оптовая торговля Бесплатно (free) Печатные формы документов

Внешняя печатная форма счета для Комплексная автоматизация, редакция 1.1 и Управление торговлей, редакция 10.3 с использованием дополнительного регистра сведений ЛоготипыИПечатиОрганизаций и возможностью оправки по email как PDF-вложение

08.08.2012    16048    260    Abadonna    11       

Сканируем без сканера или MXL to JPG 137

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Печатные формы документов Внешние источники данных Универсальные функции

Хотите конвертировать документы в формат изображения менее чем за минуту, не имея сканера? Тогда эта статья для вас.

24.05.2012    29770    shakmaev    47       

Простой способ экономии бумаги при работе с типовыми конфигурациями на примере "Бухгалтерии предприятия" 2.0 33

Статья Программист Нет файла v8 БП2.0 Россия Бесплатно (free) Печатные формы документов

Предлагается простая альтернатива разработке дополнительных печатных форм, если стоит задача разместить на одном листе 2 экземпляра печатной формы

09.05.2012    14817    mrd2008    11       

Начисление НДС с полученных авансов в «1С:Бухгалтерия 8 ред. 2.0». Исправляем ошибки, уменьшаем налог. 88

Статья Бухгалтер Нет файла v8 КА1 БП2.0 УПП1 Россия НУ Дебиторская и кредиторская задолженность НДС Бесплатно (free) Регламентированная отчетность Бухгалтерские Налоговые

Два дня назад закончилась очередная отчетная компания по НДС. Пришлось исправлять много ошибок в учете, составлять много деклараций. Как всегда, большинство ошибок бухгалтеров связано с неправильным начислением НДС с полученных авансов.

23.04.2012    113336    SergeyMordvin    6       

Регистрация внешней формы регламентированного отчета 20

Статья Бухгалтер Нет файла v8 1cv8.cf Россия БУ Закрытие периода Бесплатно (free) Регламентированная отчетность

В данной статье описана процедура регистрации внешней формы регламентированного отчета. И хотя описание данной процедуры имеется как в сопроводительных текстовых документах, поставляемых вместе с внешними формами, так и во встроенной справке (которую можно вызвать из элемента справочника "Регламентированные отчеты"), тем не менее для некоторых пользователей лучше когда всё описано по шагам и с картинками.

03.04.2012    32115    q_i    17       

Косяк или нюанс в документе "Справка 2-НДФЛ для передачи в ИФНС" (ЗУП 2.5.46.1) 8

Статья Программист Нет файла v8 ЗУП2.5 Россия Зарплата Бесплатно (free) Справки Практика программирования

В Документе "Справка 2-НДФЛ для передачи в ИФНС" при отгуленном отпуске больше, чем нужно и последующем увольнении проставляется доход 2012 со знаком минус. Контур такой отчёт не принимает. Необходимо, чтобы этот минус учитывался в последнем месяце начислений по коду 2012.

20.03.2012    12376    VitaliyTokarev    4       

Печать на больничных бланках 19

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 УПП1 Управление персоналом (HRM) Бесплатно (free) Печатные формы документов Внешние источники данных

Печатная форма для печати на больничных листках с использованием "OpenOffice Writer". Применяется для УПП. Печатается из документа "Начисление по больничному листу", либо как внешняя обработка.

09.08.2011    9258    153    ialex2008    19       

Печатная форма КМ-3 для Управления торговлей 10.3 12

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 УТ10 Кассовые операции Бесплатно (free) Печатные формы документов

Внешняя печатная форма Акта возврата денежных сумм для Управления торговлей 10.3, подключается к Расходному кассовому ордеру

16.06.2011    6075    205    warbird88    4       

Форма МП-сп статистика Росстат 12

Инструменты и обработки Бухгалтер Внешний отчет (ert,erf) v8 БП2.0 Бесплатно (free) Универсальные печатные формы Загрузка и выгрузка в Excel Статистические

Регламентная форма статистики МП-сп для Росстата под 1С:Бухгалтерия 1.6.23-30 и Бухгалтерия 2.0.18-19 на платформах 8.1 и 8.2. Заполняет, выводит печатную форму. Возможности отправки в электронном виде (XML-файл для Такском Спринтер) пока нет.

31.03.2011    45057    261    milov.aleksey    5