Доработки объектов метаданных и форм (только кодом) с помощью расширений на примере типовых конфигураций: 1C:ERP Управление предприятием 2.4 и 1С:Альфа-Авто: Автосалон+Автосервис+Автозапчасти КОРП 6

Публикация № 1187949 01.02.20

Приемы и методы разработки

расширения Альфа-Авто 6 ERP 2.4 доработки.

В этой статье хочу поделиться своим опытом внесения доработок в типовые конфигурации, с минимальными вложениями при последующих обновлениях.

   Начиная с версии 8.3.6.1977 в платформе 1С появился новый механизм адаптации прикладных решений - механизм расширений, подробности тут: https://wonderland.v8.1c.ru/blog/rasshireniya/. По сегодняшний день механизм успешно развивается и открывает новые возможности для адаптации типовых решений. 

   В процессе применения расширений, именно в части доработок типовых и отраслевых решений, я определил для себя некоторые правила:

  1. Новые объекты метаданных (далее МД) и новые реквизиты типовых объектов МД рекомендую добавлять в основную конфигурацию, не нужно спешить и добавлять сразу все в расширение, ниже описание причин.
    • Новые объекты и новые реквизиты это прежде всего хранение данных, расширение в этом плане имеет ряд недостатков, его можно удалить и даже в пользовательском режиме, появляется риск потери данных, а это ценно прежде всего для заказчика и ответственность понесет разработчик.
    • Бывают случаи когда сам вендор ставит ограничения на новые объекты МД в расширении. Например в конфигурации "Альфа-Авто" пока есть возможность добавления в расширения новых объектов следующих типов: отчеты, обработки, подсистемы. Если попытаться выйти за эти рамки то программа будет выдавать ошибку при следующем обновлении о том что идентификатор не найден в справочнике "идентификаторов объектов расширений", потому что просто не сможет его там создать.
  2. Как можно меньше заимствовать типовых объектов, реквизитов в расширение, только в самых необходимых случаях, если что-то лишнее добавилось в процессе заимствования формы рекомендую удалять их из расширения. Все это необходимо для более быстрого обновления основной конфигурации, например до обновления реквизит объекта имел прямую ссылку на тот или иной тип, а после обновления его типизировали через определяемый тип и таких реквизитов может быть много, придется править расширение, чем больше привязка расширения к основной конфигурации тем, скорее всего, сложнее и дольше придется обновлять основную конфигурацию.
  3. Модифицируем формы в большинстве случаев кодом. 

   Пример доработок в конфигурации "1С:Альфа-Авто: Автосалон+Автосервис+Автозапчасти КОРП. Редакция 6". Данная методика применялась на платформе версии 8.3.16.1148, версия конфигурации 6.0.16.03.

   Добавления в основной конфигурации. Для нового объекта МД пишем имя Префикс_ИмяОбъекта (например справочник Доработка_МойНовыйСправочник) синоним пишем привычное название. 

   По аналогии если добавляем новый реквизит в типовой объект или табличную часть Префикс_ИмяРеквизита (например Доработка_МойНовыйРеквизит) синоним пишем привычное название.

   Если добавляем новую табличную часть, то достаточно назвать по правилу Префикс_ИмяТабличнойЧасти , а подчиненные реквизиты можно оставить без префикса.

   Включаем наши новые объекты в свою, новую подсистему так же названную по правилу Префикс_ИмяПодсистемы, подсистема будет служебной для отбора новых объектов, соответственно в командный интерфейс конфигурации не включаем. Префикс необходим для того чтобы разработчик не тратил время на лишний анализ по новым объектам и реквизитам.

   Примеры модификации форм элементов и групп справочников, пока то что зафиксировал, проходит через процедуру ниже. В конфигурации "Альфа-Авто" есть общий модуль "УправлениеСвойствами" его нужно заимствовать в ваше расширение и внести нужные изменения после процедуры "ПриСозданииНаСервере", пример кода:

 

Саму процедуру "СоздатьЭлементФормы" я разместил в новом модуле расширения.

 
 

   Примеры модификации форм списка регистров сведений и справочников, форм записи регистров сведений, пока то что зафиксировал, проходит через процедуру ниже. Общий модуль "УправлениеДиалогомСервер" его нужно заимствовать в ваше расширение и внести нужные изменения после процедуры "ДобавитьРеквизитыФормы", пример кода:

 

    Для того чтобы прописать необходимые события на созданные элементы на форме нужно будет заимствовать форму в расширении, лишние элементы удалить из расширения и в самой форме прописать событие, в моей процедуре "СоздатьЭлементФормы" имя события собирается здесь:

 

На форме это будет выглядеть примерно так:

 

   Пример программной доработки форм в конфигурации 1C:ERP Управление предприятием 2 (2.4.11.93) платформа 8.3.16.1148.

   Заимствуем в расширение общий модуль "МодификацияКонфигурацииПереопределяемый", там перехватываем процедуру "ПриСозданииНаСервере" и после описываем наши доработки. Пример кода:

 

   Сами процедуры по добавлению элементов на форму можно так же вывести в "ВашОбщийМодульВРасширении", с галками сервер, вызов сервера.

   Пример кода ниже:

 

 

Функция ДобавитьЭлементВКоллекциюЭлементовФормы(ЭлементыФормы, Параметры, Родитель = Неопределено) Экспорт
	
	Перем ИмяЭлемента, ТипЭлемента; 
	
	Если НЕ ТипЗнч(Параметры) = Тип("Структура") Тогда
		ВызватьИсключение "Параметры элемента формы не заданы!";	
	КонецЕсли;
	
	Если НЕ Параметры.Свойство("Имя", ИмяЭлемента) Тогда
		ВызватьИсключение "Имя элемента формы не задано!";	
	КонецЕсли;
	
	Если НЕ Параметры.Свойство("ТипЭлемента", ТипЭлемента) Тогда
		ВызватьИсключение "Тип элемента формы не задан!";	
	КонецЕсли;
	
	Если НЕ Родитель = Неопределено Тогда
		Если ТипЗнч(Родитель) <> Тип("ГруппаФормы") 
			И	 ТипЗнч(Родитель) <> Тип("ТаблицаФормы") 
			И	 ТипЗнч(Родитель) <> Тип("УправляемаяФорма") Тогда
			ВызватьИсключение "Родитель должен иметь один из перечисленных типов: ГруппаФормы; ТаблицаФормы; УправляемаяФорма.";	 
		КонецЕсли;	
	КонецЕсли;
	
	ЭлементФормы = ЭлементыФормы.Добавить(ИмяЭлемента, ТипЭлемента, Родитель);	
	ЗаполнитьЗначенияСвойств(ЭлементФормы, Параметры);
	Возврат ЭлементФормы;	
	
КонецФункции

Функция СформироватьПараметрыЭлементов(ТипЭлементов) Экспорт
	
	СтруктураЭлементов=Новый Структура;
	
	СтруктураЭлементов.Вставить("Имя",);	
	СтруктураЭлементов.Вставить("Видимость",	Истина);
	
	Если ТипЭлементов="КолонкиТЗ" Тогда
		СтруктураЭлементов.Вставить("ПутьКДанным", );	
		СтруктураЭлементов.Вставить("ПутьКДаннымПодвала", );	
		СтруктураЭлементов.Вставить("Подсказка",);
		СтруктураЭлементов.Вставить("ПодсказкаВвода",);
		СтруктураЭлементов.Вставить("Заголовок",);
		СтруктураЭлементов.Вставить("Вид",ВидПоляФормы.ПолеВвода);
		СтруктураЭлементов.Вставить("ТипЭлемента",  Тип("ПолеФормы"));
		СтруктураЭлементов.Вставить("ЦветТекста",Новый Цвет(22,39,121));
		СтруктураЭлементов.Вставить("КнопкаОчистки",Истина);
		СтруктураЭлементов.Вставить("КнопкаОткрытия",Истина);
		СтруктураЭлементов.Вставить("КнопкаВыбора",Истина);
		СтруктураЭлементов.Вставить("КнопкаВыпадающегоСписка",Истина);
		СтруктураЭлементов.Вставить("КнопкаСоздания",Ложь);
		
		СтруктураЭлементов.Вставить("БыстрыйВыбор",Ложь);
		СтруктураЭлементов.Вставить("ИсторияВыбораПриВводе",ИсторияВыбораПриВводе.Авто);
		СтруктураЭлементов.Вставить("ОтображениеКнопкиВыбора",ОтображениеКнопкиВыбора.ОтображатьВПолеВвода);
		СтруктураЭлементов.Вставить("АвтоМаксимальнаяВысота",Истина);
		СтруктураЭлементов.Вставить("ОтображатьВШапке",Истина);
		СтруктураЭлементов.Вставить("ОтображатьВПодвале",Ложь);
		СтруктураЭлементов.Вставить("РежимРедактирования",РежимРедактированияКолонки.Непосредственно);
		СтруктураЭлементов.Вставить("АктивизироватьПоУмолчанию",Истина);
		СтруктураЭлементов.Вставить("ТолькоПросмотр",	Ложь);
	
	ИначеЕсли ТипЭлементов="Кнопка" Тогда
		СтруктураЭлементов.Вставить("ТипЭлемента",  Тип("КнопкаФормы"));
		СтруктураЭлементов.Вставить("Вид",ВидКнопкиФормы.ОбычнаяКнопка);
		СтруктураЭлементов.Вставить("АвтоМаксимальнаяВысота",	Истина);
		СтруктураЭлементов.Вставить("АвтоМаксимальнаяШирина",	Истина);
		СтруктураЭлементов.Вставить("АктивизироватьПоУмолчанию",	Ложь);
		СтруктураЭлементов.Вставить("Высота",	0);
		СтруктураЭлементов.Вставить("ВысотаЗаголовка",	0);
		СтруктураЭлементов.Вставить("Доступность",	Истина);
		СтруктураЭлементов.Вставить("Заголовок",);
		СтруктураЭлементов.Вставить("ИмяКоманды",	);
		//СтруктураЭлементов.Вставить("Картинка",);
		СтруктураЭлементов.Вставить("КнопкаПоУмолчанию",	Ложь);
		СтруктураЭлементов.Вставить("МаксимальнаяВысота",	0);
		СтруктураЭлементов.Вставить("МаксимальнаяШирина",	0);
		//СтруктураЭлементов.Вставить("Отображение",ОтображениеКнопки.Картинка);
		СтруктураЭлементов.Вставить("Отображение",ОтображениеКнопки.Авто);
		СтруктураЭлементов.Вставить("ОтображениеПодсказки",	ОтображениеПодсказки.Всплывающая);
		СтруктураЭлементов.Вставить("Пометка",	Ложь);
		СтруктураЭлементов.Вставить("РастягиватьПоВертикали",	Ложь);
		СтруктураЭлементов.Вставить("РастягиватьПоГоризонтали",	Ложь);
		СтруктураЭлементов.Вставить("Ширина",	0);
		
	ИначеЕсли ТипЭлементов="ПолеФормы" Тогда 
		СтруктураЭлементов.Вставить("ПутьКДанным", );	
		СтруктураЭлементов.Вставить("ТипЭлемента",  Тип("ПолеФормы"));
		СтруктураЭлементов.Вставить("Заголовок",);
		СтруктураЭлементов.Вставить("ПоложениеЗаголовка",ПоложениеЗаголовкаЭлементаФормы.Лево);
		СтруктураЭлементов.Вставить("Видимость",Истина);
		СтруктураЭлементов.Вставить("ТолькоПросмотр",Истина);
		СтруктураЭлементов.Вставить("РастягиватьПоВертикали", Ложь);
		СтруктураЭлементов.Вставить("ПропускатьПриВводе",	Истина);
		СтруктураЭлементов.Вставить("Вид", ВидПоляФормы.ПолеВвода);
	//	СтруктураЭлементов.Вставить("ЦветТекстаЗаголовка", Новый Цвет(22,39,121));
	
	ИначеЕсли ТипЭлементов="ГоризонтальнаяГруппа" Тогда	
		СтруктураЭлементов.Вставить("Вид",ВидГруппыФормы.ОбычнаяГруппа);
		СтруктураЭлементов.Вставить("Имя",);
		СтруктураЭлементов.Вставить("Заголовок",);
		СтруктураЭлементов.Вставить("ТипЭлемента",  Тип("ГруппаФормы"));
		СтруктураЭлементов.Вставить("Группировка", ГруппировкаПодчиненныхЭлементовФормы.Горизонтальная);
		СтруктураЭлементов.Вставить("ОтображатьЗаголовок",Ложь);
		СтруктураЭлементов.Вставить("Отображение",ОтображениеОбычнойГруппы.Нет);
		//СтруктураЭлементов.Вставить("Высота", 4);
		
	ИначеЕсли ТипЭлементов="ВертикальнаяГруппа" Тогда	
		СтруктураЭлементов.Вставить("Вид",ВидГруппыФормы.ОбычнаяГруппа);
		СтруктураЭлементов.Вставить("Имя",);
		СтруктураЭлементов.Вставить("Заголовок",);
		СтруктураЭлементов.Вставить("ТипЭлемента",  Тип("ГруппаФормы"));
		СтруктураЭлементов.Вставить("Группировка", ГруппировкаПодчиненныхЭлементовФормы.Вертикальная);
		СтруктураЭлементов.Вставить("ОтображатьЗаголовок",Ложь);
		СтруктураЭлементов.Вставить("Отображение",ОтображениеОбычнойГруппы.Нет);
		//СтруктураЭлементов.Вставить("Высота", 4);
	
	КонецЕсли;	
	
	Возврат СтруктураЭлементов;
	
КонецФункции

 

   Выводы: расширение это удобный механизм если его использовать правильно, с помощью расширений вы можете ускорить обновление в части изменения форм, однако новые объекты метаданных, реквизиты и табличные части лучше пока хранить в основной конфигурации.

 

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. omut 02.02.20 20:02 Сейчас в теме
Какое отношение содержание статьи имеет к заголовку? В Альфе куча специфических моментов, на которые следует обращать внимание при доработке. Но автор рассказывает о тривиальных способах доработки с помощью расширений, не имеющих отношения к конкретной конфигурации!
Red1; promagent; leonidol; YurySigolaev; +4 Ответить
2. improg 02.02.20 20:07 Сейчас в теме
(1)Здравствуйте, специфика в том что добавление элементов на формы в "Альфа-Авто" идет через модули "УправлениеСвойствами" и "УправлениеДиалогомСервер", по остальному просто описал общий механизм доработок через расширения.
3. improg 02.02.20 20:12 Сейчас в теме
(1)+ перехватываем там типовую форму и дорабатываем программно.
8. improg 21.04.20 11:35 Сейчас в теме
(1) Изначально статья писалась с целью показать данный прием в Альфа-Авто и все таки соглашусь тут больше описание о доработках с помощью расширений, поправил заголовок + добавил описание как такое же можно проделать в ERP 2.4. Спасибо за комментарий.
4. Pixar0000 06.02.20 00:21 Сейчас в теме
не понятно к чему статья... а это "полёт" мысли
Данная методика применялась на платформе версии 8.3.16.1063, версия конфигурации 6.0.16.03. Позже вышла информация от поставщика о рекомендуемой версии платформы 8.3.14.1779, прошу обратить на это внимание.
5. improg 06.02.20 08:15 Сейчас в теме
(4) А что непонятного? Вроде все расписано как внести доработки в Альфу с помощью расширения с наименьшими затратами.
6. improg 06.02.20 08:19 Сейчас в теме
(4) имеется в виду оформление типовых форм если в объектах уже есть доработки по структуре. Показал модули, процедуры через которые это делается, привел примеры, оформил максимально просто без заморочек.
7. пользователь 16.04.20 11:00
Сообщение было скрыто модератором.
...
Оставьте свое сообщение

См. также

Аналог PIVOT в запросе 1С (как выполнить транспонирование таблицы в запросе 1С) Промо

Практика программирования v8 Бесплатно (free)

В статье показывается простой метод реализации аналога оператора PIVOT в запросе 1С без использования соединений.

12.12.2020    4687    Eugen-S    23    

Обзор полезных методов БСП 3.1.4. Часть 2

БСП (Библиотека стандартных подсистем) v8 Бесплатно (free)

Библиотека стандартных подсистем (далее - БСП) является частью любой типовой конфигурации, поэтому умение применять готовые процедуры и функции повышает качество разработки и избавляет от написания лишнего кода. К сожалению, не у всех есть время и упорство овладеть всей документацией, поэтому я собрал воедино наиболее популярный функционал.

27.04.2021    16678    rayastar    7    

Обзор полезных методов БСП 3.1.4

БСП (Библиотека стандартных подсистем) Практика программирования v8 1cv8.cf Бесплатно (free)

Библиотека стандартных подсистем (далее - БСП) является частью любой типовой конфигурации, поэтому умение применять готовые процедуры и функции повышает качество разработки и избавляет от написания лишнего кода. К сожалению, не у всех есть время и упорство овладеть всей документацией, поэтому я собрал воедино наиболее популярный функционал.

25.03.2021    42633    rayastar    51    

Звуковое управление в 1С 8.3

Практика программирования v8 1cv8.cf Бесплатно (free)

В данной статье описано создание библиотеки для звукового управления (выполнение команд голосом) для платформы 1С 8.3. Задача была поставлена так, чтобы модуль функционировал непосредственно на клиенте 1С, осуществляя управление формами, и взаимодействовал с интерфейсом.

16.03.2021    7317    velemir    33    

Использование классов .Net в 1С для новичков Промо

Разработка внешних компонент Универсальные функции Практика программирования v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    86014    Serginio    116    

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    9056    comol    31    

Полезные функции БСП (Часть 2)

БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

Список полезных функций из состава Библиотеки стандартных подсистем 3.1.

10.03.2020    21164    user5300    20    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    67042    ids79    27    

Как я начал администрировать сервер 1С: Предприятие 8.3 с телефона Промо

Инструменты администратора БД Мобильная разработка v8 Бесплатно (free)

Развитие инструментов управления кластером серверов 1С:Предприятие 8.3.

14.04.2017    67801    user700211_a.straltsou    30    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    44339    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    36071    kuzyara    38    

Шпаргалка (БСП). Добавление в новый документ механизма печати дополнительных печатных форм

Печатные формы БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Постоянно приходится вспоминать, как добавить механизм печати (БСП) в новый документ. Поэтому решил написать шпаргалку.

10.10.2019    30997    John_d    21    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    41214    unichkin    74    

Полезные процедуры и функции для программиста

Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    40086    HostHost    41    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    53782    Yashazz    56    

[Шпаргалка] Программное создание элементов формы

Работа с интерфейсом Практика программирования v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    104808    rpgshnik    77    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    36283    tormozit    106    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    78882    ids79    56    

Отслеживание выполнения фонового задания

Универсальные функции Инструментарий разработчика Практика программирования v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    45589    ids79    22    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    155188    ids79    75    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    82972    tormozit    131    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    61703    avalakh    27    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    107330    ids79    17    

Обработчики событий при записи объектов. Зачем и что за чем?

Математика и алгоритмы v8 Бесплатно (free)

Программисту, имеющему немного опыта на платформе 1С 8.3, бывает сложно разобраться: ПередЗаписью, ПриЗаписи, ПослеЗаписи, на сервере, на клиенте, в модуле формы, в модуле объекта.... Эта шпаргалка была создана в процессе обучения и реального опыта с целью разложить всё по полочкам, чтобы было четкое понимание в каком случае какой обработчик нужно использовать и в какой последовательности они запускаются при записи и проведении документов. Данная статья будет полезна в большей степени начинающим разработчикам. Но и опытным позволит освежить информацию, упорядочить её.

25.07.2019    115166    AlbinaAAA    49    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    54631    tormozit    51    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    48962    ids79    27    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    22643    SeiOkami    53    

Создание отчетов с помощью СКД - основные понятия и элементы

Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    77133    ids79    28    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    51429    tormozit    74    

Подсистема "Варианты отчетов". Используете ли Вы ее правильно?

Работа с интерфейсом БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    56826    YPermitin    55    

Регистры накопления. Структура хранения в базе данных

Инструментарий разработчика Практика программирования v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    64738    YPermitin    31    

Выгрузка документа по условию

Инструментарий разработчика Практика программирования v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    18085    m-rv    3    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    37221    m-rv    23    

Как прикрутить ГУИД к регистру сведений

Перенос данных из 1C8 в 1C8 Инструментарий разработчика Практика программирования v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    23428    m-rv    18    

О расширениях замолвите слово...

Инструментарий разработчика Практика программирования v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    42930    ellavs    131    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    32199    ellavs    90    

Трюки с внешними источниками данных

Инструментарий разработчика Практика программирования v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    41530    YPermitin    53    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

БСП (Библиотека стандартных подсистем) Роли и права Практика программирования v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    66366    ids79    11    

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке

Универсальные функции Зарплата Управление персоналом (HRM) Зарплата Кадровый учет v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Бесплатно (free)

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    149042    GeterX    136    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    45244    ids79    46    

Git + 1С. Часть 1. Как подключиться к команде разработки и начать использовать Git

Инструментарий разработчика Методология v8 1cv8.cf Бесплатно (free)

Первая статья из цикла инструкций по работе с Git в 1С-разработке. Рассмотрим, как настроить рабочее место, как получить свою "копию" проекта для разработки и приступить к полезным действиям. Все примеры будут изложены в рамках трёх практических кейсов: 1. Моя команда дорабатывает типовую конфигурацию, использует приватный репозиторий на BitBucket, в котором версионируются внешние отчеты/обработки, расширения конфигураций и правила обмена; 2. Я участвую в стартап-команде, которая разрабатывает свою конфигурацию с использованием Git и GitLab; 3. Я принимаю участие в развитии OpenSource-продукта на GitHub как заинтересованный разработчик (контрибьютор).

18.10.2018    94027    stas_ganiev    86    

Произвольный код в фоновом режиме

Практика программирования v8 1cv8.cf Бесплатно (free)

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    34134    zarankony    42    

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C

Математика и алгоритмы Практика программирования v8 Россия Бесплатно (free)

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    49005    Rain88    49    

Тестер: частые вопросы

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    31637    grumagargler    31    

Работаем с дополнительными реквизитами на форме

Практика программирования v8 Бесплатно (free)

Пара полезных процедур для работы с дополнительными реквизитами на форме. Далее в статье: 1. Как называются дополнительные реквизиты на форме и в какой момент они появляются на форме? 2. Как проверить до записи корректность заполнения пользователем дополнительного реквизита? 3. Как заполнить значение дополнительного реквизита по другому событию и обновить данные на форме? 4. Как расположить дополнительный реквизит в указанном месте на форме?

15.07.2018    53678    papche    59    

Повышаем эффективность разработки правил обмена

Практика программирования v8 КД Бесплатно (free)

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    30314    olegtymko    48