Доработки объектов метаданных и форм (только кодом) с помощью расширений на примере типовых конфигураций: 1C:ERP Управление предприятием 2.4 и 1С:Альфа-Авто: Автосалон+Автосервис+Автозапчасти КОРП 6

Публикация № 1187949

Разработка - Практика программирования

расширения Альфа-Авто 6 ERP 2.4 доработки.

В этой статье хочу поделиться своим опытом внесения доработок в типовые конфигурации, с минимальными вложениями при последующих обновлениях.

   Начиная с версии 8.3.6.1977 в платформе 1С появился новый механизм адаптации прикладных решений - механизм расширений, подробности тут: https://wonderland.v8.1c.ru/blog/rasshireniya/. По сегодняшний день механизм успешно развивается и открывает новые возможности для адаптации типовых решений. 

   В процессе применения расширений, именно в части доработок типовых и отраслевых решений, я определил для себя некоторые правила:

  1. Новые объекты метаданных (далее МД) и новые реквизиты типовых объектов МД рекомендую добавлять в основную конфигурацию, не нужно спешить и добавлять сразу все в расширение, ниже описание причин.
    • Новые объекты и новые реквизиты это прежде всего хранение данных, расширение в этом плане имеет ряд недостатков, его можно удалить и даже в пользовательском режиме, появляется риск потери данных, а это ценно прежде всего для заказчика и ответственность понесет разработчик.
    • Бывают случаи когда сам вендор ставит ограничения на новые объекты МД в расширении. Например в конфигурации "Альфа-Авто" пока есть возможность добавления в расширения новых объектов следующих типов: отчеты, обработки, подсистемы. Если попытаться выйти за эти рамки то программа будет выдавать ошибку при следующем обновлении о том что идентификатор не найден в справочнике "идентификаторов объектов расширений", потому что просто не сможет его там создать.
  2. Как можно меньше заимствовать типовых объектов, реквизитов в расширение, только в самых необходимых случаях, если что-то лишнее добавилось в процессе заимствования формы рекомендую удалять их из расширения. Все это необходимо для более быстрого обновления основной конфигурации, например до обновления реквизит объекта имел прямую ссылку на тот или иной тип, а после обновления его типизировали через определяемый тип и таких реквизитов может быть много, придется править расширение, чем больше привязка расширения к основной конфигурации тем, скорее всего, сложнее и дольше придется обновлять основную конфигурацию.
  3. Модифицируем формы в большинстве случаев кодом. 

   Пример доработок в конфигурации "1С:Альфа-Авто: Автосалон+Автосервис+Автозапчасти КОРП. Редакция 6". Данная методика применялась на платформе версии 8.3.16.1148, версия конфигурации 6.0.16.03.

   Добавления в основной конфигурации. Для нового объекта МД пишем имя Префикс_ИмяОбъекта (например справочник Доработка_МойНовыйСправочник) синоним пишем привычное название. 

   По аналогии если добавляем новый реквизит в типовой объект или табличную часть Префикс_ИмяРеквизита (например Доработка_МойНовыйРеквизит) синоним пишем привычное название.

   Если добавляем новую табличную часть, то достаточно назвать по правилу Префикс_ИмяТабличнойЧасти , а подчиненные реквизиты можно оставить без префикса.

   Включаем наши новые объекты в свою, новую подсистему так же названную по правилу Префикс_ИмяПодсистемы, подсистема будет служебной для отбора новых объектов, соответственно в командный интерфейс конфигурации не включаем. Префикс необходим для того чтобы разработчик не тратил время на лишний анализ по новым объектам и реквизитам.

   Примеры модификации форм элементов и групп справочников, пока то что зафиксировал, проходит через процедуру ниже. В конфигурации "Альфа-Авто" есть общий модуль "УправлениеСвойствами" его нужно заимствовать в ваше расширение и внести нужные изменения после процедуры "ПриСозданииНаСервере", пример кода:

 

Саму процедуру "СоздатьЭлементФормы" я разместил в новом модуле расширения.

 
 

   Примеры модификации форм списка регистров сведений и справочников, форм записи регистров сведений, пока то что зафиксировал, проходит через процедуру ниже. Общий модуль "УправлениеДиалогомСервер" его нужно заимствовать в ваше расширение и внести нужные изменения после процедуры "ДобавитьРеквизитыФормы", пример кода:

 

    Для того чтобы прописать необходимые события на созданные элементы на форме нужно будет заимствовать форму в расширении, лишние элементы удалить из расширения и в самой форме прописать событие, в моей процедуре "СоздатьЭлементФормы" имя события собирается здесь:

 

На форме это будет выглядеть примерно так:

 

   Пример программной доработки форм в конфигурации 1C:ERP Управление предприятием 2 (2.4.11.93) платформа 8.3.16.1148.

   Заимствуем в расширение общий модуль "МодификацияКонфигурацииПереопределяемый", там перехватываем процедуру "ПриСозданииНаСервере" и после описываем наши доработки. Пример кода:

 

   Сами процедуры по добавлению элементов на форму можно так же вывести в "ВашОбщийМодульВРасширении", с галками сервер, вызов сервера.

   Пример кода ниже:

 

 

Функция ДобавитьЭлементВКоллекциюЭлементовФормы(ЭлементыФормы, Параметры, Родитель = Неопределено) Экспорт
	
	Перем ИмяЭлемента, ТипЭлемента; 
	
	Если НЕ ТипЗнч(Параметры) = Тип("Структура") Тогда
		ВызватьИсключение "Параметры элемента формы не заданы!";	
	КонецЕсли;
	
	Если НЕ Параметры.Свойство("Имя", ИмяЭлемента) Тогда
		ВызватьИсключение "Имя элемента формы не задано!";	
	КонецЕсли;
	
	Если НЕ Параметры.Свойство("ТипЭлемента", ТипЭлемента) Тогда
		ВызватьИсключение "Тип элемента формы не задан!";	
	КонецЕсли;
	
	Если НЕ Родитель = Неопределено Тогда
		Если ТипЗнч(Родитель) <> Тип("ГруппаФормы") 
			И	 ТипЗнч(Родитель) <> Тип("ТаблицаФормы") 
			И	 ТипЗнч(Родитель) <> Тип("УправляемаяФорма") Тогда
			ВызватьИсключение "Родитель должен иметь один из перечисленных типов: ГруппаФормы; ТаблицаФормы; УправляемаяФорма.";	 
		КонецЕсли;	
	КонецЕсли;
	
	ЭлементФормы = ЭлементыФормы.Добавить(ИмяЭлемента, ТипЭлемента, Родитель);	
	ЗаполнитьЗначенияСвойств(ЭлементФормы, Параметры);
	Возврат ЭлементФормы;	
	
КонецФункции

Функция СформироватьПараметрыЭлементов(ТипЭлементов) Экспорт
	
	СтруктураЭлементов=Новый Структура;
	
	СтруктураЭлементов.Вставить("Имя",);	
	СтруктураЭлементов.Вставить("Видимость",	Истина);
	
	Если ТипЭлементов="КолонкиТЗ" Тогда
		СтруктураЭлементов.Вставить("ПутьКДанным", );	
		СтруктураЭлементов.Вставить("ПутьКДаннымПодвала", );	
		СтруктураЭлементов.Вставить("Подсказка",);
		СтруктураЭлементов.Вставить("ПодсказкаВвода",);
		СтруктураЭлементов.Вставить("Заголовок",);
		СтруктураЭлементов.Вставить("Вид",ВидПоляФормы.ПолеВвода);
		СтруктураЭлементов.Вставить("ТипЭлемента",  Тип("ПолеФормы"));
		СтруктураЭлементов.Вставить("ЦветТекста",Новый Цвет(22,39,121));
		СтруктураЭлементов.Вставить("КнопкаОчистки",Истина);
		СтруктураЭлементов.Вставить("КнопкаОткрытия",Истина);
		СтруктураЭлементов.Вставить("КнопкаВыбора",Истина);
		СтруктураЭлементов.Вставить("КнопкаВыпадающегоСписка",Истина);
		СтруктураЭлементов.Вставить("КнопкаСоздания",Ложь);
		
		СтруктураЭлементов.Вставить("БыстрыйВыбор",Ложь);
		СтруктураЭлементов.Вставить("ИсторияВыбораПриВводе",ИсторияВыбораПриВводе.Авто);
		СтруктураЭлементов.Вставить("ОтображениеКнопкиВыбора",ОтображениеКнопкиВыбора.ОтображатьВПолеВвода);
		СтруктураЭлементов.Вставить("АвтоМаксимальнаяВысота",Истина);
		СтруктураЭлементов.Вставить("ОтображатьВШапке",Истина);
		СтруктураЭлементов.Вставить("ОтображатьВПодвале",Ложь);
		СтруктураЭлементов.Вставить("РежимРедактирования",РежимРедактированияКолонки.Непосредственно);
		СтруктураЭлементов.Вставить("АктивизироватьПоУмолчанию",Истина);
		СтруктураЭлементов.Вставить("ТолькоПросмотр",	Ложь);
	
	ИначеЕсли ТипЭлементов="Кнопка" Тогда
		СтруктураЭлементов.Вставить("ТипЭлемента",  Тип("КнопкаФормы"));
		СтруктураЭлементов.Вставить("Вид",ВидКнопкиФормы.ОбычнаяКнопка);
		СтруктураЭлементов.Вставить("АвтоМаксимальнаяВысота",	Истина);
		СтруктураЭлементов.Вставить("АвтоМаксимальнаяШирина",	Истина);
		СтруктураЭлементов.Вставить("АктивизироватьПоУмолчанию",	Ложь);
		СтруктураЭлементов.Вставить("Высота",	0);
		СтруктураЭлементов.Вставить("ВысотаЗаголовка",	0);
		СтруктураЭлементов.Вставить("Доступность",	Истина);
		СтруктураЭлементов.Вставить("Заголовок",);
		СтруктураЭлементов.Вставить("ИмяКоманды",	);
		//СтруктураЭлементов.Вставить("Картинка",);
		СтруктураЭлементов.Вставить("КнопкаПоУмолчанию",	Ложь);
		СтруктураЭлементов.Вставить("МаксимальнаяВысота",	0);
		СтруктураЭлементов.Вставить("МаксимальнаяШирина",	0);
		//СтруктураЭлементов.Вставить("Отображение",ОтображениеКнопки.Картинка);
		СтруктураЭлементов.Вставить("Отображение",ОтображениеКнопки.Авто);
		СтруктураЭлементов.Вставить("ОтображениеПодсказки",	ОтображениеПодсказки.Всплывающая);
		СтруктураЭлементов.Вставить("Пометка",	Ложь);
		СтруктураЭлементов.Вставить("РастягиватьПоВертикали",	Ложь);
		СтруктураЭлементов.Вставить("РастягиватьПоГоризонтали",	Ложь);
		СтруктураЭлементов.Вставить("Ширина",	0);
		
	ИначеЕсли ТипЭлементов="ПолеФормы" Тогда 
		СтруктураЭлементов.Вставить("ПутьКДанным", );	
		СтруктураЭлементов.Вставить("ТипЭлемента",  Тип("ПолеФормы"));
		СтруктураЭлементов.Вставить("Заголовок",);
		СтруктураЭлементов.Вставить("ПоложениеЗаголовка",ПоложениеЗаголовкаЭлементаФормы.Лево);
		СтруктураЭлементов.Вставить("Видимость",Истина);
		СтруктураЭлементов.Вставить("ТолькоПросмотр",Истина);
		СтруктураЭлементов.Вставить("РастягиватьПоВертикали", Ложь);
		СтруктураЭлементов.Вставить("ПропускатьПриВводе",	Истина);
		СтруктураЭлементов.Вставить("Вид", ВидПоляФормы.ПолеВвода);
	//	СтруктураЭлементов.Вставить("ЦветТекстаЗаголовка", Новый Цвет(22,39,121));
	
	ИначеЕсли ТипЭлементов="ГоризонтальнаяГруппа" Тогда	
		СтруктураЭлементов.Вставить("Вид",ВидГруппыФормы.ОбычнаяГруппа);
		СтруктураЭлементов.Вставить("Имя",);
		СтруктураЭлементов.Вставить("Заголовок",);
		СтруктураЭлементов.Вставить("ТипЭлемента",  Тип("ГруппаФормы"));
		СтруктураЭлементов.Вставить("Группировка", ГруппировкаПодчиненныхЭлементовФормы.Горизонтальная);
		СтруктураЭлементов.Вставить("ОтображатьЗаголовок",Ложь);
		СтруктураЭлементов.Вставить("Отображение",ОтображениеОбычнойГруппы.Нет);
		//СтруктураЭлементов.Вставить("Высота", 4);
		
	ИначеЕсли ТипЭлементов="ВертикальнаяГруппа" Тогда	
		СтруктураЭлементов.Вставить("Вид",ВидГруппыФормы.ОбычнаяГруппа);
		СтруктураЭлементов.Вставить("Имя",);
		СтруктураЭлементов.Вставить("Заголовок",);
		СтруктураЭлементов.Вставить("ТипЭлемента",  Тип("ГруппаФормы"));
		СтруктураЭлементов.Вставить("Группировка", ГруппировкаПодчиненныхЭлементовФормы.Вертикальная);
		СтруктураЭлементов.Вставить("ОтображатьЗаголовок",Ложь);
		СтруктураЭлементов.Вставить("Отображение",ОтображениеОбычнойГруппы.Нет);
		//СтруктураЭлементов.Вставить("Высота", 4);
	
	КонецЕсли;	
	
	Возврат СтруктураЭлементов;
	
КонецФункции

 

   Выводы: расширение это удобный механизм если его использовать правильно, с помощью расширений вы можете ускорить обновление в части изменения форм, однако новые объекты метаданных, реквизиты и табличные части лучше пока хранить в основной конфигурации.

 

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. omut 02.02.20 20:02 Сейчас в теме
Какое отношение содержание статьи имеет к заголовку? В Альфе куча специфических моментов, на которые следует обращать внимание при доработке. Но автор рассказывает о тривиальных способах доработки с помощью расширений, не имеющих отношения к конкретной конфигурации!
Red1; promagent; leonidol; YurySigolaev; +4 Ответить
2. байт 100 02.02.20 20:07 Сейчас в теме
(1)Здравствуйте, специфика в том что добавление элементов на формы в "Альфа-Авто" идет через модули "УправлениеСвойствами" и "УправлениеДиалогомСервер", по остальному просто описал общий механизм доработок через расширения.
3. байт 100 02.02.20 20:12 Сейчас в теме
(1)+ перехватываем там типовую форму и дорабатываем программно.
8. байт 100 21.04.20 11:35 Сейчас в теме
(1) Изначально статья писалась с целью показать данный прием в Альфа-Авто и все таки соглашусь тут больше описание о доработках с помощью расширений, поправил заголовок + добавил описание как такое же можно проделать в ERP 2.4. Спасибо за комментарий.
4. Pixar0000 06.02.20 00:21 Сейчас в теме
не понятно к чему статья... а это "полёт" мысли
Данная методика применялась на платформе версии 8.3.16.1063, версия конфигурации 6.0.16.03. Позже вышла информация от поставщика о рекомендуемой версии платформы 8.3.14.1779, прошу обратить на это внимание.
5. байт 100 06.02.20 08:15 Сейчас в теме
(4) А что непонятного? Вроде все расписано как внести доработки в Альфу с помощью расширения с наименьшими затратами.
6. байт 100 06.02.20 08:19 Сейчас в теме
(4) имеется в виду оформление типовых форм если в объектах уже есть доработки по структуре. Показал модули, процедуры через которые это делается, привел примеры, оформил максимально просто без заморочек.
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37314    unichkin    74    

Конвертация расширения cfe в конфигурацию сf руками

Расширения v8 1cv8.cf Бесплатно (free)

Как быстро преобразовать расширение в конфигурацию (для дальнейшего переноса в основную конфигурацию, например).

18.03.2020    5920    wtlz    30    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    26132    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    23416    John_d    22    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30186    tormozit    100    

Последовательности событий. Шпаргалка

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    17954    kuzyara    33    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    16931    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8336    Sibars    19    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    77948    tormozit    131    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    32907    Yashazz    50    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    11740    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    49304    rpgshnik    63    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    48320    tormozit    41    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    48985    ids79    54    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    28160    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    25412    YPermitin    80    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    44733    tormozit    74    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    31319    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    81137    ids79    49    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    34972    avalakh    22    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16045    m-rv    2    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    23617    json    13    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    59073    ids79    11    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    35636    ids79    27    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20221    m-rv    17    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    25961    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19613    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    46146    ids79    17    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    30568    m-rv    21    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    52194    ids79    25    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    24977    dmurk    145    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    42800    YPermitin    30    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28228    itriot11    34    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    35282    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27355    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    31294    YPermitin    53    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76323    Serginio    108    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    38983    Смешной 1С    28    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    21905    Vladimir Litvinenko    27    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    34679    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    39323    ids79    9    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29204    grumagargler    28    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    26782    ids79    31    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    41402    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    36932    ids79    42    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    52625    m-rv    61    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    47287    Unk92    25