Доработки в отраслевой конфигурации "1С:Альфа-Авто: Автосалон+Автосервис+Автозапчасти КОРП. Редакция 6", в простых примерах

Публикация № 1187949

Разработка - Практика программирования

расширения Альфа-Авто

В этой статье хочу поделиться своим опытом внесения доработок и изменений в конфигурацию "1С:Альфа-Авто: Автосалон+Автосервис+Автозапчасти КОРП. Редакция 6" (далее Альфа-Авто) от фирмы 1С:Рарус, как это сделать так, чтобы следующие обновления конфигурации производились быстрее и проще.

   Данная методика применялась на платформе версии 8.3.16.1063, версия конфигурации 6.0.16.03. Позже вышла информация от поставщика о рекомендуемой версии платформы 8.3.14.1779, прошу обратить на это внимание.

   Начиная с версии 8.3.6.1977 в платформе 1С появился новый механизм адаптации прикладных решений - механизм расширений, подробности тут: https://wonderland.v8.1c.ru/blog/rasshireniya/. По сегодняшний день механизм успешно развивается и открывает новые возможности для адаптации типовых решений. 

   В процессе применения расширений, именно в части доработок типовых и отраслевых решений, я определил для себя некоторые правила:

  1. Новые объекты метаданных (далее МД) и новые реквизиты типовых объектов МД рекомендую добавлять в основную конфигурацию, не нужно спешить и добавлять сразу все в расширение, ниже описание причин.
    • Новые объекты и новые реквизиты это прежде всего хранение данных, расширение в этом плане имеет ряд недостатков, его можно удалить и даже в пользовательском режиме, появляется риск потери данных, а это ценно прежде всего для заказчика и ответственность понесет разработчик.
    • В самой конфигурации "Альфа-Авто" пока есть возможность добавления в расширения новых объектов следующих типов: отчеты, обработки, подсистемы. Если попытаться выйти за эти рамки то программа будет выдавать ошибку при следующем обновлении о том что идентификатор не найден в справочнике "идентификаторов объектов расширений", потому что просто не сможет его там создать.
  2. Как можно меньше заимствовать типовых объектов, реквизитов в расширение, только в самых необходимых случаях, если что-то лишнее добавилось в процессе заимствования формы рекомендую удалять их из расширения. Все это необходимо для более быстрого обновления основной конфигурации, например до обновления реквизит объекта имел прямую ссылку на тот или иной тип, а после обновления его типизировали через определяемый тип и таких реквизитов может быть много, придется править расширение, чем больше привязка расширения к основной конфигурации тем, скорее всего, сложнее и дольше придется обновлять основную конфигурацию.
  3. Модифицируем формы в большинстве случаев кодом. 

   Примеры добавления в основной конфигурации. Для нового объекта МД пишем имя Префикс_ИмяОбъекта (например справочник Доработка_МойНовыйСправочник) синоним пишем привычное название. 

   По аналогии если добавляем новый реквизит в типовой объект или табличную часть Префикс_ИмяРеквизита (например Доработка_МойНовыйРеквизит) синоним пишем привычное название.

   Если добавляем новую табличную часть, то достаточно назвать по правилу Префикс_ИмяТабличнойЧасти , а подчиненные реквизиты можно оставить без префикса.

   Включаем наши новые объекты в свою, новую подсистему так же названную по правилу Префикс_ИмяПодсистемы, подсистема будет служебной для отбора новых объектов, соответственно в командный интерфейс конфигурации не включаем. Префикс необходим для того чтобы разработчик не тратил время на лишний анализ по новым объектам и реквизитам.

   Примеры модификации форм элементов и групп справочников, пока то что зафиксировал, проходит через процедуру ниже. В конфигурации "Альфа-Авто" есть общий модуль "УправлениеСвойствами" его нужно заимствовать в ваше расширение и внести нужные изменения после процедуры "ПриСозданииНаСервере", пример кода:

&После("ПриСозданииНаСервере")
Процедура Расш_ПриСозданииНаСервере(Форма, ДополнительныеПараметры = Неопределено)

	Попытка
		
		Если Форма.ИмяФормы = "Справочник.Автомобили.Форма.ФормаЭлемента" Тогда	
			                      
			ДопСвойства = Новый Структура;
			Владелец = Форма.Элементы.ГруппаШапка;
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "Доработка_МойРеквизит1", "Мой реквизит 1", Владелец, 
												Тип("ПолеФормы"), "Объект.Доработка_МойРеквизит1, ВидПоляФормы.ПолеФлажка, ДопСвойства);
			
			ДопСвойства = Новый Структура;
			ДопСвойства.Вставить("ШрифтЗаголовка", Новый Шрифт(,,Истина));
			Владелец = Форма.Элементы.Страницы.ПодчиненныеЭлементы.СтраницаОсновные;
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "Доработка_МойРеквизит2", "Мой реквизит 2", Владелец, 
												Тип("ПолеФормы"), "Объект.Доработка_МойРеквизит2", ВидПоляФормы.ПолеФлажка, ДопСвойства);
			
			Владелец = Форма.Элементы.Страницы;
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "МояСтраница1", "Моя страница 1", Владелец, Тип("ГруппаФормы"));
			
			Владелец = Форма.Элементы.Страницы.ПодчиненныеЭлементы.МояСтраница1;
			ДопСвойства = Новый Структура;
			ДопСвойства.Вставить("ПоложениеЗаголовка", ПоложениеЗаголовкаЭлементаФормы.Нет);
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "Доработка_МояТабличнаяЧасть1", "Моя табличная часть 1", Владелец, 
												Тип("ТаблицаФормы"), "Объект.МояТабличнаяЧасть1", ВидПоляФормы.ПолеВвода, ДопСвойства);
			
		КонецЕсли;
											
	Исключение
		
		ЗаписьЖурналаРегистрации("Ошибка создания элемента на форме в расширении", УровеньЖурналаРегистрации.Ошибка,,,ОписаниеОшибки());
		
	КонецПопытки;
	
КонецПроцедуры

Саму процедуру "СоздатьЭлементФормы" я разместил в новом модуле расширения.

#Область Создание_элементов_на_форме

Процедура СоздатьЭлементФормы(Форма, ИмяКоманды, Заголовок, Владелец, Тип, ПутьКДанным = "", ВидПоля = Неопределено, ДопСвойства = Неопределено) Экспорт 
	
	СлужебныеИмена = Новый Массив;
	СлужебныеИмена.Добавить("КлючСтроки");
	СлужебныеИмена.Добавить("ИсходныйНомерСтроки");
	ШрифтЗаголовка = Новый Шрифт(,,Ложь,Ложь,Ложь,Ложь);
	ПоложениеЗаголовка = ПоложениеЗаголовкаЭлементаФормы.Авто;
	Если ДопСвойства <> Неопределено и ДопСвойства.Свойство("ШрифтЗаголовка") Тогда
		ДопСвойства.Свойство("ШрифтЗаголовка", ШрифтЗаголовка);
	КонецЕсли;
	Если ДопСвойства <> Неопределено и ДопСвойства.Свойство("ПоложениеЗаголовка") Тогда
		ДопСвойства.Свойство("ПоложениеЗаголовка", ПоложениеЗаголовка);
	КонецЕсли;
	Если Тип = Тип("КнопкаФормы") Тогда
		НоваяКоманда = Форма.Команды.Добавить(ИмяКоманды);
		НоваяКоманда.Заголовок = Заголовок;
		НоваяКоманда.Действие = ИмяКоманды;
		
		Элемент = Форма.Элементы.Добавить(ИмяКоманды, Тип, Владелец);
		Элемент.Вид = ВидКнопкиФормы.КнопкаКоманднойПанели;
		Элемент.Заголовок = Заголовок;
		Элемент.ИмяКоманды = ИмяКоманды;
		Элемент.ШрифтЗаголовка = ШрифтЗаголовка;
		Элемент.ПоложениеЗаголовка = ПоложениеЗаголовка;
	ИначеЕсли Тип = Тип("ПолеФормы") Тогда
		Элемент = Форма.Элементы.Добавить(ИмяКоманды, Тип, Владелец);
		Элемент.Вид = ВидПоля;
		Элемент.Заголовок = Заголовок;
		Элемент.ПутьКДанным = ПутьКДанным;
		Элемент.ШрифтЗаголовка = ШрифтЗаголовка;
		Элемент.ПоложениеЗаголовка = ПоложениеЗаголовка;
		Элемент.УстановитьДействие("ПриИзменении", ИмяКоманды + "ПриИзменении");
	ИначеЕсли Тип = Тип("ГруппаФормы") Тогда
		Элемент = Форма.Элементы.Добавить(ИмяКоманды, Тип, Владелец);
		Элемент.Вид = ВидГруппыФормы.Страница;
		Элемент.Заголовок = Заголовок;
		Элемент.ШрифтЗаголовка = ШрифтЗаголовка;
	ИначеЕсли Тип = Тип("ТаблицаФормы") Тогда
		Таблица = Форма.РеквизитФормыВЗначение(ПутьКДанным).Выгрузить();
		ПрефиксКолонки = СтрЗаменить(ПутьКДанным, "Объект.", "");
		Элемент = Форма.Элементы.Добавить(ИмяКоманды, Тип, Владелец);
		Элемент.Заголовок = Заголовок;
		Элемент.ПутьКДанным = ПутьКДанным;
		Элемент.ШрифтЗаголовка = ШрифтЗаголовка;
		Элемент.ПоложениеЗаголовка = ПоложениеЗаголовка;
		Элемент.УстановитьДействие("ПриОкончанииРедактирования", ИмяКоманды + "ПриОкончанииРедактирования");
		Элемент.УстановитьДействие("ПриАктивизацииСтроки", ИмяКоманды + "ПриАктивизацииСтроки");
		Для Каждого Ст ИЗ Таблица.Колонки Цикл
			Если СлужебныеИмена.Найти(Ст.Имя) <> Неопределено Тогда
				Продолжить;
			КонецЕсли;
			ИмяКолонки = ПрефиксКолонки + Ст.Имя;
			ИмяКоманды = ИмяКолонки + "НачалоВыбора";
			ИмяКомандыПриИзменении = ИмяКолонки + "ПриИзменении";
			Колонка = Форма.Элементы.Добавить(ИмяКолонки, Тип("ПолеФормы"), Элемент);
			Колонка.Вид = ВидПоля;
			Колонка.ПутьКДанным = ПутьКДанным + "." + Ст.Имя;
			Колонка.Заголовок = ПолучитьЗаголовок(Ст.Имя);
			Колонка.УстановитьДействие("НачалоВыбора",ИмяКоманды);
			Колонка.УстановитьДействие("ПриИзменении",ИмяКомандыПриИзменении);
    		КонецЦикла;
	КонецЕсли;
	
КонецПроцедуры

Функция ПолучитьЗаголовок(Исходная)
	
	Конечная=Лев(Исходная,1);
	Для Индекс=2 по СтрДлина(Исходная) цикл
		Символ=Сред(Исходная,Индекс,1);
		Конечная=Конечная+?(ВРег(Символ)=Символ," "+НРег(Символ),Символ);
	КонецЦикла;
	
	Возврат Конечная;
	
КонецФункции	

#КонецОбласти

 

   Примеры модификации форм списка регистров сведений и справочников, форм записи регистров сведений, пока то что зафиксировал, проходит через процедуру ниже. Общий модуль "УправлениеДиалогомСервер" его нужно заимствовать в ваше расширение и внести нужные изменения после процедуры "ДобавитьРеквизитыФормы", пример кода:

&После("ДобавитьРеквизитыФормы")
Процедура Расш_ДобавитьРеквизитыФормы(Форма, Реквизиты)
	
	Попытка
		
		НовыеРеквизиты = Новый Массив;
		Если Форма.ИмяФормы = "РегистрСведений.НоменклатураПрименяемость.Форма.ФормаСписка" Тогда	
			
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "МойРеквизит1", "Мой реквизит 1", Форма.Элементы.Список, 
												Тип("ПолеФормы"), "Список.МойРеквизит1", ВидПоляФормы.ПолеВвода);
			
		ИначеЕсли Форма.ИмяФормы = "РегистрСведений.НоменклатураПрименяемость.Форма.ФормаЗаписи" Тогда	
			
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "МойРеквизит2", "Мой реквизит 2", Форма, 
												Тип("ПолеФормы"), "Запись.МойРеквизит2", ВидПоляФормы.ПолеВвода);
			
			
		ИначеЕсли Форма.ИмяФормы = "Справочник.Автомобили.Форма.ФормаСписка" Тогда	
			
			НовыйРеквизит = Новый РеквизитФормы("Доработка_МойРеквизит3",Новый ОписаниеТипов("СправочникСсылка.МойСправочник1"),,"Мой реквизит 3"); 
			НовыеРеквизиты.Добавить(НовыйРеквизит);
			Форма.ИзменитьРеквизиты(НовыеРеквизиты);
			Владелец = Форма.Элементы.СпискиСОтборами.ПодчиненныеЭлементы.БыстрыеОтборы;
			ДопСвойства = Новый Структура;
			ДопСвойства.Вставить("ПоложениеЗаголовка", ПоложениеЗаголовкаЭлементаФормы.Верх);
			УчетЯчеекСервер.СоздатьЭлементФормы(Форма, "Доработка_МойРеквизит3", "Мой реквизит 3", Владелец, 
												Тип("ПолеФормы"), "Доработка_МойРеквизит3", ВидПоляФормы.ПолеВвода, ДопСвойства);
			
		КонецЕсли;
		
	Исключение
		
		ЗаписьЖурналаРегистрации("Ошибка создания элемента на форме в расширении", УровеньЖурналаРегистрации.Ошибка,,,ОписаниеОшибки());
		
	КонецПопытки;
	
КонецПроцедуры

   

   Для того чтобы прописать необходимые события на созданные элементы на форме нужно будет заимствовать форму в расширении, лишние элементы удалить из расширения и в самой форме прописать событие, в моей процедуре "СоздатьЭлементФормы" имя события собирается здесь:

На форме это будет выглядеть примерно так:

 

   Выводы: расширение это удобный механизм если его использовать правильно, с помощью расширений вы можете ускорить обновление в части изменения форм, однако новые объекты метаданных, реквизиты и табличные части лучше пока хранить в основной конфигурации.

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. omut 02.02.20 20:02 Сейчас в теме
Какое отношение содержание статьи имеет к заголовку? В Альфе куча специфических моментов, на которые следует обращать внимание при доработке. Но автор рассказывает о тривиальных способах доработки с помощью расширений, не имеющих отношения к конкретной конфигурации!
promagent; leonidol; YurySigolaev; +3 Ответить
2. байт 28 02.02.20 20:07 Сейчас в теме
(1)Здравствуйте, специфика в том что добавление элементов на формы в "Альфа-Авто" идет через модули "УправлениеСвойствами" и "УправлениеДиалогомСервер", по остальному просто описал общий механизм доработок через расширения.
3. байт 28 02.02.20 20:12 Сейчас в теме
(1)+ перехватываем там типовую форму и дорабатываем программно.
4. Pixar0000 06.02.20 00:21 Сейчас в теме
не понятно к чему статья... а это "полёт" мысли
Данная методика применялась на платформе версии 8.3.16.1063, версия конфигурации 6.0.16.03. Позже вышла информация от поставщика о рекомендуемой версии платформы 8.3.14.1779, прошу обратить на это внимание.
5. байт 28 06.02.20 08:15 Сейчас в теме
(4) А что непонятного? Вроде все расписано как внести доработки в Альфу с помощью расширения с наименьшими затратами.
6. байт 28 06.02.20 08:19 Сейчас в теме
(4) имеется в виду оформление типовых форм если в объектах уже есть доработки по структуре. Показал модули, процедуры через которые это делается, привел примеры, оформил максимально просто без заморочек.
Оставьте свое сообщение

См. также

Программная работа с настройками СКД

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    9418    ids79    26       

Онлайн-интенсив "1C:Предприятие для программистов: Бухгалтерские задачи" с 22 июня по 8 июля 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для решения задач бухгалтерского учета. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Бухгалтерия” и прочих прикладных решений, в которых реализованы соответствующие механизмы для автоматизации бухгалтерских задач.

4900 рублей

[СКД] Программное создание схемы компоновки данных

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    10974    John_d    22       

Последовательности событий. Шпаргалка

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    6991    kuzyara    33       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

30 задач. Странных и не очень

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    10881    YPermitin    72       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Агрегатные функции СКД, о которых мало кто знает

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    31022    ids79    50       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Три костыля. Сказ про фокусы в коде

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    19285    YPermitin    80       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Отслеживание выполнения фонового задания

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    22089    ids79    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    43413    ids79    36       

Лучшие программы за март Промо

Инфостарт подготовил ТОП-25 самых продаваемых и популярных программ за март 2020 года. При формировании перечня учитывали аналитику продаж и запросы клиентов за месяц.

Фоновое выполнение кода в 1С - это просто

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    22065    avalakh    21       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    34040    ids79    11       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    23660    ids79    27       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Регистры сведений. За кулисами

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    18080    YPermitin    13       

"Меньше копипаста!", или как Вася универсальную процедуру писал

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    14666    SeiOkami    49       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 20 апреля по 15 мая 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Создание отчетов с помощью СКД - основные понятия и элементы

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    36576    ids79    17       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Производительность и оптимизация (HighLoad)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    19068    dmurk    144       

Базовый курс для начинающих 1С-программистов. Онлайн-интенсив со 2 июня по 2 июля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500-9500 рублей

Регистры накопления. Структура хранения в базе данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    31552    YPermitin    30       

Выполнение внешней обработки в фоновом задании

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    20688    Eret1k    23       

Екатеринбург.Online: Голосование продолжается Промо

Продолжается голосование за доклады на INFOSTART MEETUP Екатеринбург.Online! Лучшие из них попадут в окончательную программу онлайн-митапа! Присоединяйтесь к голосованию и покупайте билеты - 3 000 рублей за 8 часов продуктивной пятницы!

3000

Выгрузка документа по условию

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    11893    m-rv    2       

Как прикрутить ГУИД к регистру сведений

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    15283    m-rv    16       

DevOps для 1С. Онлайн-курс проходит с 16 апреля по 11 июня 2020 года. Промо

Данный онлайн-курс предусматривает изучение процессов DevOps, их применение при разработке на платформе 1С. В результате прохождения онлайн-курса вы сможете: настроить ПО необходимое для проведения проверок и тестирования, создавать сценарии тестирования и объединять их в комплексные процессы, создавать скрипты для автоматизации процессов DevOps.

12000 рублей

О расширениях замолвите слово...

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    26171    ellavs    125       

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    20969    ellavs    83