Возможности работы со строками при помощи БСП, которые должен знать каждый программист

Публикация № 1260173

Разработка - Практика программирования

БСП работа со стоками

Переходим на следующий уровень работы со строками, уходим от типовых возможностей платформы. Узнаем, как применить функционал БСП конфигурации.

Давайте перейдем уже на новый уровень работы со строками и уйдем от типовых скудных возможностей платформы.

В данном кратком обзоре, я приведу несколько мега-удобных "полезняшек" и "ускоряшек" работы со строками, используя функционал библиотеки стандартных подсистем (БСП), которые я использую повсеместно в своей практике. В обзоре приведу не все функции и возможности, а только самые полезные с моей точки зрения.

Пора все-таки отказываться от использования только типовых функций платформы.

 

Определение версии БСП

Первым шагом определим, включена ли библиотека стандартных подсистем в вашу конфигурацию, а так же ее версию.

Для этого напишем такой небольшой код во внешней обработке:

// Создаем кнопочку "Команда 1" на УФ

&НаКлиенте
Процедура Команда1(Команда)
    ПоказатьВерсиюБСП();
КонецПроцедуры

&НаСервере
Процедура ПоказатьВерсиюБСП()

 МояСтрока = "Версия библиотеки: %1";
 Сообщить(СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(МояСтрока,СтандартныеПодсистемыСервер.ВерсияБиблиотеки()));

КонецПроцедуры

В мою конфигурацию включена версия БСП 3.0.3.130. Могу использовать функционал работы со строками этой полезной библиотеки.

 

Полезные функции работы со строками с примерами

Указанные функции выполняются как на клиенте, так и на сервере. Условно обозначим их как функция 1 .... функция 14. Всего я выделяю 14 основных и интересных функций. На каждую функцию привожу пример использования и описание типа возвращаемого значения.

 

Функция 1.

РазложитьСтрокуВМассивПодстрок(МояСтрока, Разделитель, ПропускатьПустыеСтроки, СокращатьНепечатаемыеСимволы)

Тип возвращаемого значения: Массив

 

Данная функция раскладывает строку в массив (аналог СтрЗаменить с применением Символы.ПС). Пример использования на клиенте:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "Иванов И.И.;г.Новокузнецк;Специалист 1С;01.05.1975";
// Разделитель ";", 
Итог = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(МояСтрока,";",Истина,Истина);
Сообщить(Итог[0]); //Иванов И.И. 

КонецПроцедуры

Возвращает массив "Итог" с элементами, по разделителю ";" (в данном случае), плюс к этому сокращает непечатаемые символы.

 

Функция 2.

ПодставитьПараметрыВСтроку(ШаблонСтроки,Параметр1, .....  ,Параметр9)

Тип возвращаемого значения: Строка

 

Еще одна очень удобная функция, которая позволяет вставить до 9 параметров вашу строку. Работает так:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "Иванов И.И.;%1;Специалист 1С;%2";
Итог = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(МояСтрока,"г.Новокузнецк","01.01.1975");
Сообщить(Итог); //Иванов И.И.;г.Новокузнецк;Специалист 1С;01.01.1975

КонецПроцедуры

Вместо %1 .... %9 - подставляем значения и получаем необходимую строку

 

Функция 3.

ВставитьПараметрыВСтроку(ШаблонСтроки, Параметры)

Тип возвращаемого значения: Строка

 

Более расширенная версия предыдущей функции, позволяющее использовать любое количество параметров в строке, предварительно создав структуру для шаблона строки. Более универсальная:

&НаКлиенте
Процедура Команда1(Команда)

СтруктураПараметров = Новый Структура("Фамилия, Квалификация", "Иванов И.И.", "Специалист 1с");
МояСтрока = "[Фамилия] подтвердил свою квалификацию сертификатом [Квалификация].";
Итог = СтроковыеФункцииКлиентСервер.ВставитьПараметрыВСтроку(МояСтрока, СтруктураПараметров);
Сообщить(Итог); //Иванов И.И. подтвердил свою квалификацию сертификатом Специалист 1с.

КонецПроцедуры

Параметры заключаем в квадратные скобочки в шаблоне строки "МояСтрока".

 

Функция 4.

ПараметрыИзСтроки(Знач СтрокаПараметров, ";")

Тип возвращаемого значения: Структура

 

Не очень универсальная функция, но сгодиться если доставать из строки какое значение, равное чему-то. Например, удобно применяется при разборе каких-то массивов текстовых структур:

&НаКлиенте
Процедура Команда1(Команда)
	
		
	МояСтрока = "ИНН=4567435676, КПП=554554545, ТЕЛ=5454455, ПОЧТА=mail@mail.ru ";
	
	Итог = СтроковыеФункцииКлиентСервер.ПараметрыИзСтроки(МояСтрока,",");

	Сообщить(Итог.ИНН); //4567435676
	Сообщить(Итог.КПП); //554554545
	Сообщить(Итог.ТЕЛ); //5454455
	Сообщить(Итог.ПОЧТА); //mail@mail.ru
	
КонецПроцедуры

Удобно, но данную функцию я не особо часто использовал. Но, нужно знать про нее. Сэкономит время, если что!

В коде у меня стоит разделитель ",".

 

Функция 5.

РазложитьСтрокуВМассивСлов(Знач Значение, РазделителиСлов = Неопределено)

Тип возвращаемого значения: Массив

 

Еще одна интересная функция, которая позволит разделить вам строку, используя несколько разделителей одновременно. Очень удобно, работает вот так:

&НаКлиенте
Процедура Команда1(Команда)
	
		
	МояСтрока = "ИНН=4567435676, КПП=554554545;ТЕЛ=5454455;ПОЧТА=mail@mail.ru ";
	
	Итог = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивСлов(МояСтрока,",;");

	Сообщить(Итог[0]); //ИНН=4567435676
	Сообщить(Итог[1]); //КПП=554554545
	Сообщить(Итог[2]); //ТЕЛ=5454455
	Сообщить(Итог[3]); //ПОЧТА=mail@mail.ru
	
КонецПроцедуры

Я одновременно использую два разделителя - это запятая и точка с запятой.

 

Функция 6.

ТолькоЛатиницаВСтроке(СтрокаПроверки, УчитыватьРазделителиСлов, ДопустимыеСимволы = "")

Тип возвращаемого значения: Булево

 

Функция, позволяющая проверить на корректность заполнения какой-нибудь строки. Возможно использовать допустимые символы.

&НаКлиенте
Процедура Команда1(Команда)
		
	МояСтрока = "Ivanova Marina, Ж";
	
	Итог = СтроковыеФункцииКлиентСервер.ТолькоЛатиницаВСтроке(МояСтрока, Ложь, "Ж");

	Сообщить(Итог);  // Да
	
КонецПроцедуры

В примере будет возврат Истины, поскольку пол, буква "Ж" - добавлен в допустимые символы. Все просто.

 

Функция 7.

СократитьДвойныеКавычки(Знач Значение)

Тип возвращаемого значения: Строка

 

Удобная функция, которая удалит двойные кавычки в начале и конце строки.

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = """Привет всем. Данная строка будет выведена без ""двойных"" кавычек""";
Итог = СтроковыеФункцииКлиентСервер.СократитьДвойныеКавычки(МояСтрока);
Сообщить(Итог); //Привет всем. Данная строка будет выведена без "двойных" кавычек

КонецПроцедуры

Функция такая

Функция СократитьДвойныеКавычки(Знач Значение) Экспорт
	
	Пока СтрНачинаетсяС(Значение, """") Цикл
		Значение = Сред(Значение, 2); 
	КонецЦикла; 
	
	Пока СтрЗаканчиваетсяНа(Значение, """") Цикл
		Значение = Лев(Значение, СтрДлина(Значение) - 1);
	КонецЦикла;
	
	Возврат Значение;
	
КонецФункции

 

 

Функция 8.

ЭтоУникальныйИдентификатор(Знач Значение)

Тип возвращаемого значения: Булево

 

Проверка, является ли значение уникальным идентификатором. Использует маску-шаблон:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "sfsdf-sdfsd-sfsff";
Итог = СтроковыеФункцииКлиентСервер.ЭтоУникальныйИдентификатор(МояСтрока);
Сообщить(Итог); //Нет (Ложь) 

КонецПроцедуры

 

Функция 9.

ДополнитьСтроку(Значение, ДлинаСтроки, Символ = "0", Режим = "Слева")

Тип возвращаемого значения: Строка

 

Добивает строку слева или справа до определенной длины заданными символами. Вот так:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "427380";
Итог = СтроковыеФункцииКлиентСервер.ДополнитьСтроку(МояСтрока, 12, 0, "Слева");
Сообщить(Итог); //000000427380 

КонецПроцедуры

Не нужно заморачиваться с типовым функционалом платформы Лев(), Прав().

 

Функция 10.

ПреобразоватьЧислоВРимскуюНотацию(АрабскоеЧисло, ИспользоватьКириллицу = Истина)

Тип возвращаемого значения: Строка

 

Функция преобразовывает арабские цифры (обычные) в римские. Используя кириллицу - римское число будет выведено "русскими" буквами:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = 59;
Итог = СтроковыеФункцииКлиентСервер.ПреобразоватьЧислоВРимскуюНотацию(МояСтрока);
Сообщить(Итог); //Л1Х

КонецПроцедуры

 

Функция 11.

ПреобразоватьЧислоВАрабскуюНотацию(РимскоеЧисло, ИспользоватьКириллицу = Истина)

Тип возвращаемого значения: Число

 

Обратная процедура преобразования в арабские цифры. Здесь, опять используем кириллицу, римское число перед обработкой заключили в кавычки:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "Л1Х";
Итог = СтроковыеФункцииКлиентСервер.ПреобразоватьЧислоВАрабскуюНотацию(МояСтрока);
Сообщить(Итог); //59 

КонецПроцедуры

 

Функция 12.

СтрокаЛатиницей(Знач Значение)

Тип возвращаемого значения: Строка

 

Очень полезная функция, позволяющая перекодировать строку в латиницу, не городя огород:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "Иванов Иван Иванович. Привет всем!";
Итог = СтроковыеФункцииКлиентСервер.СтрокаЛатиницей(МояСтрока);
Сообщить(Итог); //Ivanov Ivan Ivanovich. Privet vsem!

КонецПроцедуры 

 

Функция 13.

СтрокаВДату(Знач Значение)

Тип возвращаемого значения: Дата

 

Также мега-полезная функция:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "04.07.2020";
Итог = СтроковыеФункцииКлиентСервер.СтрокаВДату(МояСтрока);
Сообщить(Итог); //04.07.2020 0:00:00 // Тип - Дата

КонецПроцедуры

 

Функция 14.

СтрокаВЧисло(Знач Значение)

Тип возвращаемого значения: Число

 

Данная функция так же капитально избавляет от "головной боли" и придумывания "велосипедов":

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "000 1 256 888.55";
Итог = СтроковыеФункцииКлиентСервер.СтрокаВЧисло(МояСтрока);
Сообщить(Итог); //1 256 888,55 // Тип - Число

КонецПроцедуры

Преобразовывает в тип число, даже удаляет "лидирующие нули" и "видит" пробелы.

 

В статье привел наиболее часто используемые мной функции работы со строками, значительно ускоряющие написание доработок или обработок для конфигурации, основанных на библиотеке стандартных подсистем.

Я привел описание 14 удобных функций библиотеки стандартных подсистем работы со строками, использование которых значительно ускорит процесс разработки, вот они:

 

1. РазложитьСтрокуВМассивПодстрок(МояСтрока, Разделитель, ПропускатьПустыеСтроки, СокращатьНепечатаемыеСимволы)

2. ПодставитьПараметрыВСтроку(ШаблонСтроки,Параметр1, .....  ,Параметр9)

3. ВставитьПараметрыВСтроку(ШаблонСтроки, Параметры)

4. ПараметрыИзСтроки(СтрокаПараметров, Разделитель)

5. РазложитьСтрокуВМассивСлов(Значение, РазделителиСлов)

6. ТолькоЛатиницаВСтроке(СтрокаПроверки, УчитыватьРазделителиСлов, ДопустимыеСимволы = "")

7. СократитьДвойныеКавычки(Значение)

8. ЭтоУникальныйИдентификатор(Значение)

9. ДополнитьСтроку(Значение, ДлинаСтроки, Символ = "0", Режим = "Слева")

10. ПреобразоватьЧислоВРимскуюНотацию(АрабскоеЧисло, ИспользоватьКириллицу = Истина)

11. ПреобразоватьЧислоВАрабскуюНотацию(РимскоеЧисло, ИспользоватьКириллицу = Истина)

12. СтрокаЛатиницей(Значение)

13. СтрокаВДату(Значение)

14. СтрокаВЧисло(Значение)

 

Конечно, в БСП есть еще несколько функций для удобства работы со строками, но они в основном максимально-приближены к типовым функциям платформы.

Данный небольшой обзор 14 функций написан, используя версию БСП 3.0.3.130. Версия платформы 1С Предприятия 8.3.16.1063. Спасибо за внимание!

 

П.С. Старайтесь использовать БСП, не изобретайте велосипеды! Все уже придумано за вас!

Так же прошу ознакомиться с моей статьей Полезные встроенные функции для работы с печатными формами и не только на УТ 11.4 и БП 3.0

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. tormozit 6225 05.07.20 08:34 Сейчас в теме
Пример для функции СократитьДвойныеКавычки некорректный. Функция в данном примере возвращает такую же строку, которую получает на вход. Эта функция удаляет двойные кавычки только в начале и конце строки. Поэтому строка-параметр подобрана некорректно.
Такой пример будет корректным

МояСтрока = """Привет всем. Данная строка будет выведена без двойных кавычек""";
Итог = СтроковыеФункцииКлиентСервер.СократитьДвойныеКавычки(МояСтрока);
Сообщить(Итог);
milov.aleksey; quazare; ardn; +3 Ответить
5. quazare 883 05.07.20 11:05 Сейчас в теме
(1) спасибо за корректировку. поправил описание и пример.
2. twiny 13 05.07.20 08:45 Сейчас в теме
А ф2 это та же самая СтрШаблон только с ограничением?
6. quazare 883 05.07.20 11:13 Сейчас в теме
(2) СтрШаблон "живет" на < 8.3.6 или в совместимости < 8.3.6

эта функция основана на СтрЗаменить (9 раз.....)
33. ilya2184 62 13.07.20 09:28 Сейчас в теме
(6) АПК говорит что в СтрШаблон там ещё косяк какой-то с локализацией строк. Рекомендуют функции БСП
3. ardn 223 05.07.20 09:25 Сейчас в теме
За популяризацию БСП однозначный плюс.

Но за грязный код в самом начале статьи (получение текста для сообщения версии БСП) - минус. Дело даже не в том, что не стоит использовать конкатенацию строк, вы же пишете о строковых функциях, используйте шаблон.
7. quazare 883 05.07.20 11:21 Сейчас в теме
(3) верно замечено! приведено в соответствие представленному материалу!
8. EvgeniuXP 05.07.20 11:55 Сейчас в теме
(3)тогда ее не в начало статьи а в конец :) а то смотрю на функцию БСП как баран на новые ворота :)))) статью еще не прочитал - а тут сразу удар ногой по голове :)
9. quazare 883 05.07.20 12:02 Сейчас в теме
(8) да просто копи-пасть для начала - потом понравится удобство - вникнешь в суть функций)
4. Vanch90 05.07.20 09:42 Сейчас в теме
Гы, используешь бсп функции, через год бсп обновляется, переименовывает модуль или функции устаревают..
Классика
lsg45; milov.aleksey; SuhoffGV; Yashazz; +4 Ответить
10. quazare 883 05.07.20 16:11 Сейчас в теме
(4) да нет, в бсп старые функции оставляют (с пометкой комментарием, "устарело"). строковые функции - это вообще "фундамент"
13. Rustig 1664 06.07.20 09:32 Сейчас в теме
(11) обоснуйте ограничение
14. zeegin 91 06.07.20 10:16 Сейчас в теме
(13) Стандарта не достаточно? 0_о
17. Rustig 1664 06.07.20 14:50 Сейчас в теме
(14) нет, так как стандарт причину не раскрывает
16. dock 43 06.07.20 14:33 Сейчас в теме
(13) привел ссылку на стандарт 1С #std418
обоснуйте ограничение

совершенно не понятна суть вопроса: обосновать использование стандарта или обосновать сам стандарт ?
- использовать или не использовать стандарты 1С, Ваше личное дело.
- сам стандарт не могу обосновать, я не являюсь автором. Но предполагаю, что всё дело в клиент-серверном взаимодействии и переходе на управляемые формы ;)

Но да, моя ошибка: я явно не указал, что это ссылка на стандарт 1С.

З.Ы. Сама статья интересная и полезная, но вот только применение "Сообщить()" немного портит впечатление: при "призыве" использовать БСП я ожидал и "призыв" соблюдать стандарты ...
18. Rustig 1664 06.07.20 14:52 Сейчас в теме
(16) в чем суть ограничения - "Не использовать Сообщить()" ?
в БСП много чего включили - городить огород зачем?
19. dock 43 06.07.20 15:15 Сейчас в теме
(18)
метод Сообщить() появился в версии 8.0, когда не было четкого разделения между клиентом и сервером.
Объект СообщениеПользователю - с версии 8.2, когда было введено четкое разделение клиента и сервера и, соответственно, управляемые формы. Этот объект расширяет возможности взаимодействия с пользователем и должен более корректно отрабатываться механизмами платформы в управляемых формах на всех видах клиентов (тонкий, веб)

в чем суть ограничения: использовать актуальные механизмы платформы.

в БСП много чего включили - городить огород зачем?

Это уже платформенные механизмы, к БСП не имеет отношения.
milov.aleksey; +1 Ответить
20. Rustig 1664 06.07.20 15:27 Сейчас в теме
(19) ну ясно, пока что черный ящик
Объет Новый СообщениеПользователю для вывода использует метод Сообщить()
Понятно, что у объекта это собственный метод и как он реализован - неизвестно....
Раньше использовали метод Сообщить()....
В чем их отличие пока непонятно
23. Yashazz 3636 07.07.20 08:21 Сейчас в теме
(20) Дофига в чём. Во-первых, они по-разному преобразуют сложные платформенные типы, имеют разный максимальный размер выводимых строк и всплывающих подсказок, и по-разному их показывают; во-вторых, различным образом кэшируются и жрут память, в третьих, объекты сообщений пользователям можно выгрести в массив, а сообщённое нельзя... Много чего.
21. Rustig 1664 06.07.20 15:28 Сейчас в теме
(19) собственно , программа 1с ошибку не выдает при использовании старого метода Сообщить()....
22. Rustig 1664 06.07.20 15:35 Сейчас в теме
(19) возможно, для веб-клиента есть разница... не проверял
12. muskul 06.07.20 08:49 Сейчас в теме
Ох помню строка в дату мне крови попила.
15. Shmell 317 06.07.20 10:19 Сейчас в теме
СтрокаВДату - не знал. Спасибо.
24. Yashazz 3636 07.07.20 08:23 Сейчас в теме
Давно сделал собственную аналогичную библиотеку, в которой уверен на все 100%. А вот в поделках БСП быть уверенным нельзя. После того, как из-за "внезапной" перетасовки кода в БСП у нас накрылся большой серьёзный проект, я БСП стараюсь по мере возможности игнорировать. И вам советую - меньше неожиданных граблей будет.
25. nixel 998 07.07.20 09:53 Сейчас в теме
(24)
После того, как из-за "внезапной" перетасовки кода в БСП у нас накрылся большой серьёзный проект


вы либо использовали служебный программный интерфейс, либо устаревшие процедуры и функции. СПИ может меняться когда угодно, его совместимость не гарантируется, он на то и служебный, чтобы его кто попало не дергал. устаревшие процедуры и функции висят в коде бсп годами, давая время на плановую миграцию. вызов устаревших методов без проблем ловится стат анализаторами.
26. Rustig 1664 07.07.20 11:44 Сейчас в теме
(25) разработчики БСП как-то оповещают сообщество, что они изменили процедуры? мониторить документацию - большой труд.... а написать свою библиотеку вполне нормальный ход.
27. nixel 998 07.07.20 11:45 Сейчас в теме
(26) да, в чейнджлогах. там же, где описаны *обязательные* действия по переходу на новую версию библиотеки.
28. Rustig 1664 07.07.20 11:51 Сейчас в теме
(27) вы сами мониторите чейнджлог?
29. nixel 998 07.07.20 11:52 Сейчас в теме
(28) да. накатывать обновление корневой библиотеки без проверки изменения требований по ее внедрению и тестирования считаю несколько безответственным)
30. Rustig 1664 07.07.20 12:00 Сейчас в теме
(29) спасибо за ваш комментарий) я многое не знал - про СПИ например, да и многое чего, с чем не сталкивался. Но я больше придерживаюсь мнения Якова, чем вашего. К сожалению, относиться к БСП надо именно с осторожностью и с той долей ответственности, как вы подразумеваете.)) ок, вопросов нет
31. Yashazz 3636 07.07.20 14:21 Сейчас в теме
(25) я даже спец.конфу написал, чтобы эти изменения мониторить по факту, а не по их описаниям... но это было после. И использовался именно программный интерфейс. Просто вдруг бац, и новое поколение БСП выкатили. И всё переделывать за те же деньги и в те же сроки.
35. biimmap 104 20.07.20 20:43 Сейчас в теме
(24) Вот тут Вы совсем не правы! Конечно при обновлении нужно проверять актуальность программного интерфейса, который был использован.
Это один из этапов обновления конфигурации! Здесь большой вопрос к человеку, который делал обновление.
По своему опыту скажу что часто возникает ситуация когда просто некуда вставить написанное ранее. Приходится думать и быстро работать))) Но избегать нельзя!
Я жутко против велосипедов! Не нужно писать лишний код!
32. user848614 09.07.20 23:46 Сейчас в теме
Есть платформенный метод СтрРазделить. Он вроде как работает так же как функции 1и 5. И есть обратный ему СтрСоединить. Или у них есть какие то минусы по сравнению с БСПешными?
34. user612295_death4321 17.07.20 15:37 Сейчас в теме
(32) у СтрРазделить точно было какое то отличие от БСПшного. Вроде разделял только до первого разделителя. БСПшный в этом плане работал более ожидаемо.
36. MishaD 14 21.07.20 09:37 Сейчас в теме
(32)СтрРазделить делит по каждому символу в разделителе, а РазложитьСтрокуВМассивПодстрок по всему разделителю. То есть строку "Один; Два Три" в случае разделителя "; " СтрРазделить разделит на 3 подстроки(Один,Два,Три), а РазложитьСтрокуВМассивПодстрок на 2 подстроки(Один, Два Три).

Однако СтрРазделить работает на порядок шустрее, так что при возможности лучше её использовать.
Оставьте свое сообщение

См. также

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions Промо

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    4287    comol    22    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    10767    quazare    33    

Типовые методы конфигурации "Зарплата и управление персоналом", которые пригодятся каждому ЗУП программисту и не только

Практика программирования v8 ЗУП3.x Россия Бесплатно (free)

В данном обзоре дам описание полезных встроенных функций и процедур в конфигурации "Зарплата и управление персоналом 3.1".

19.07.2020    4194    quazare    7    

Доступность ролей пользователей в конфигурации

Роли и права v8 v8::Права v8::СКД 1cv8.cf Россия Абонемент ($m)

В данной публикации представлен небольшой отчет, который позволит определить доступность ролей пользователей в конфигурации.

1 стартмани

12.07.2020    3006    7    quazare    0    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    38422    unichkin    74    

Полезные встроенные функции для работы с печатными формами и не только на УТ 11.4 и БП 3.0 (сравнение)

Универсальные функции v8 БП3.0 УТ11 Россия Бесплатно (free)

В данном обзоре приведу примеры встроенных используемых функций для работы с печатными формами на примерах конфигураций Управление торговлей 11.4 и Бухгалтерия 3.0.

10.07.2020    4403    quazare    5    

Форма выбора (подбор) в управляемых формах

Практика программирования v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

Разбор небольших примеров того, как правильно открывать форму выбора (подбора) в управляемых формах, не прибегая к модальным окнам.

08.05.2020    35086    user5300    16    

Полезные функции БСП (Часть 2)

БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

Список полезных функций из состава Библиотеки стандартных подсистем 3.1.

10.03.2020    14816    user5300    19    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    32013    tormozit    104    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    38771    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    30369    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    23107    kuzyara    38    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    79270    tormozit    131    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    18775    YPermitin    60    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    9810    Sibars    19    

Шпаргалка (БСП). Добавление в новый документ механизма печати дополнительных печатных форм

Печать БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Постоянно приходится вспоминать, как добавить механизм печати (БСП) в новый документ. Поэтому решил написать шпаргалку.

10.10.2019    21579    John_d    17    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    50014    tormozit    48    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    33084    HostHost    41    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    39965    Yashazz    50    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    14503    budidich    28    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    46680    tormozit    74    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    66663    rpgshnik    68    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    58016    ids79    55    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    33122    YPermitin    24    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16413    m-rv    2    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    27019    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    35152    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    106230    ids79    63    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20940    m-rv    17    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    43734    avalakh    26    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    29030    json    15    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    75470    ids79    14    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    32255    m-rv    21    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    39814    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    28276    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    20383    SeiOkami    50    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28830    itriot11    34    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    58830    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    60229    ids79    26    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    26993    dmurk    146    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    78332    Serginio    113    

Подсистема "Варианты отчетов". Используете ли Вы ее правильно?

Работа с интерфейсом БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    46661    YPermitin    52    

Подсистема БСП «Управление доступом», основные объекты и регистры

БСП (Библиотека стандартных подсистем) Роли и права v8 v8::УФ v8::Права 1cv8.cf Бесплатно (free)

Основные принципы работы подсистемы «Управление доступом» из состава БСП. Виды доступа, ограничение доступа на уровне записей. Описание основных объектов и регистров, используемых подсистемой.

23.05.2019    25355    ids79    9    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    49457    YPermitin    30    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    37323    ids79    40    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    37793    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    28573    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    34394    YPermitin    53    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    30113    grumagargler    31    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    48235    Смешной 1С    30