Возможности работы со строками при помощи БСП, которые должен знать каждый программист

22.03.22

Разработка - БСП (Библиотека стандартных подсистем)

Переходим на следующий уровень работы со строками, уходим от типовых возможностей платформы. Узнаем, как применить функционал БСП конфигурации.

Давайте перейдем уже на новый уровень работы со строками и уйдем от типовых скудных возможностей платформы.

В данном кратком обзоре, я приведу несколько мега-удобных "полезняшек" и "ускоряшек" работы со строками, используя функционал библиотеки стандартных подсистем (БСП), которые я использую повсеместно в своей практике. В обзоре приведу не все функции и возможности, а только самые полезные с моей точки зрения.

Пора все-таки отказываться от использования только типовых функций платформы.

 

Определение версии БСП

Первым шагом определим, включена ли библиотека стандартных подсистем в вашу конфигурацию, а так же ее версию.

Для этого напишем такой небольшой код во внешней обработке:

// Создаем кнопочку "Команда 1" на УФ

&НаКлиенте
Процедура Команда1(Команда)
    ПоказатьВерсиюБСП();
КонецПроцедуры

&НаСервере
Процедура ПоказатьВерсиюБСП()

 МояСтрока = "Версия библиотеки: %1";
 Сообщить(СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(МояСтрока,СтандартныеПодсистемыСервер.ВерсияБиблиотеки()));

КонецПроцедуры

В мою конфигурацию включена версия БСП 3.0.3.130. Могу использовать функционал работы со строками этой полезной библиотеки.

 

Полезные функции работы со строками с примерами

Указанные функции выполняются как на клиенте, так и на сервере. Условно обозначим их как функция 1 .... функция 14. Всего я выделяю 14 основных и интересных функций. На каждую функцию привожу пример использования и описание типа возвращаемого значения.

 

Функция 1.

РазложитьСтрокуВМассивПодстрок(МояСтрока, Разделитель, ПропускатьПустыеСтроки, СокращатьНепечатаемыеСимволы)

Тип возвращаемого значения: Массив

 

Данная функция раскладывает строку в массив (аналог СтрЗаменить с применением Символы.ПС). Пример использования на клиенте:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "Иванов И.И.;г.Новокузнецк;Специалист 1С;01.05.1975";
// Разделитель ";", 
Итог = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(МояСтрока,";",Истина,Истина);
Сообщить(Итог[0]); //Иванов И.И. 

КонецПроцедуры

Возвращает массив "Итог" с элементами, по разделителю ";" (в данном случае), плюс к этому сокращает непечатаемые символы.

 

Функция 2.

ПодставитьПараметрыВСтроку(ШаблонСтроки,Параметр1, .....  ,Параметр9)

Тип возвращаемого значения: Строка

 

Еще одна очень удобная функция, которая позволяет вставить до 9 параметров вашу строку. Работает так:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "Иванов И.И.;%1;Специалист 1С;%2";
Итог = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(МояСтрока,"г.Новокузнецк","01.01.1975");
Сообщить(Итог); //Иванов И.И.;г.Новокузнецк;Специалист 1С;01.01.1975

КонецПроцедуры

Вместо %1 .... %9 - подставляем значения и получаем необходимую строку

 

Функция 3.

ВставитьПараметрыВСтроку(ШаблонСтроки, Параметры)

Тип возвращаемого значения: Строка

 

Более расширенная версия предыдущей функции, позволяющее использовать любое количество параметров в строке, предварительно создав структуру для шаблона строки. Более универсальная:

&НаКлиенте
Процедура Команда1(Команда)

СтруктураПараметров = Новый Структура("Фамилия, Квалификация", "Иванов И.И.", "Специалист 1с");
МояСтрока = "[Фамилия] подтвердил свою квалификацию сертификатом [Квалификация].";
Итог = СтроковыеФункцииКлиентСервер.ВставитьПараметрыВСтроку(МояСтрока, СтруктураПараметров);
Сообщить(Итог); //Иванов И.И. подтвердил свою квалификацию сертификатом Специалист 1с.

КонецПроцедуры

Параметры заключаем в квадратные скобочки в шаблоне строки "МояСтрока".

 

Функция 4.

ПараметрыИзСтроки(Знач СтрокаПараметров, ";")

Тип возвращаемого значения: Структура

 

Не очень универсальная функция, но сгодиться если доставать из строки какое значение, равное чему-то. Например, удобно применяется при разборе каких-то массивов текстовых структур:

&НаКлиенте
Процедура Команда1(Команда)
	
		
	МояСтрока = "ИНН=4567435676, КПП=554554545, ТЕЛ=5454455, ПОЧТА=mail@mail.ru ";
	
	Итог = СтроковыеФункцииКлиентСервер.ПараметрыИзСтроки(МояСтрока,",");

	Сообщить(Итог.ИНН); //4567435676
	Сообщить(Итог.КПП); //554554545
	Сообщить(Итог.ТЕЛ); //5454455
	Сообщить(Итог.ПОЧТА); //mail@mail.ru
	
КонецПроцедуры

Удобно, но данную функцию я не особо часто использовал. Но, нужно знать про нее. Сэкономит время, если что!

В коде у меня стоит разделитель ",".

 

Функция 5.

РазложитьСтрокуВМассивСлов(Знач Значение, РазделителиСлов = Неопределено)

Тип возвращаемого значения: Массив

 

Еще одна интересная функция, которая позволит разделить вам строку, используя несколько разделителей одновременно. Очень удобно, работает вот так:

&НаКлиенте
Процедура Команда1(Команда)
	
		
	МояСтрока = "ИНН=4567435676, КПП=554554545;ТЕЛ=5454455;ПОЧТА=mail@mail.ru ";
	
	Итог = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивСлов(МояСтрока,",;");

	Сообщить(Итог[0]); //ИНН=4567435676
	Сообщить(Итог[1]); //КПП=554554545
	Сообщить(Итог[2]); //ТЕЛ=5454455
	Сообщить(Итог[3]); //ПОЧТА=mail@mail.ru
	
КонецПроцедуры

Я одновременно использую два разделителя - это запятая и точка с запятой.

 

Функция 6.

ТолькоЛатиницаВСтроке(СтрокаПроверки, УчитыватьРазделителиСлов, ДопустимыеСимволы = "")

Тип возвращаемого значения: Булево

 

Функция, позволяющая проверить на корректность заполнения какой-нибудь строки. Возможно использовать допустимые символы.

&НаКлиенте
Процедура Команда1(Команда)
		
	МояСтрока = "Ivanova Marina, Ж";
	
	Итог = СтроковыеФункцииКлиентСервер.ТолькоЛатиницаВСтроке(МояСтрока, Ложь, "Ж");

	Сообщить(Итог);  // Да
	
КонецПроцедуры

В примере будет возврат Истины, поскольку пол, буква "Ж" - добавлен в допустимые символы. Все просто.

 

Функция 7.

СократитьДвойныеКавычки(Знач Значение)

Тип возвращаемого значения: Строка

 

Удобная функция, которая удалит двойные кавычки в начале и конце строки.

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = """Привет всем. Данная строка будет выведена без ""двойных"" кавычек""";
Итог = СтроковыеФункцииКлиентСервер.СократитьДвойныеКавычки(МояСтрока);
Сообщить(Итог); //Привет всем. Данная строка будет выведена без "двойных" кавычек

КонецПроцедуры

Функция такая

Функция СократитьДвойныеКавычки(Знач Значение) Экспорт
	
	Пока СтрНачинаетсяС(Значение, """") Цикл
		Значение = Сред(Значение, 2); 
	КонецЦикла; 
	
	Пока СтрЗаканчиваетсяНа(Значение, """") Цикл
		Значение = Лев(Значение, СтрДлина(Значение) - 1);
	КонецЦикла;
	
	Возврат Значение;
	
КонецФункции

 

 

Функция 8.

ЭтоУникальныйИдентификатор(Знач Значение)

Тип возвращаемого значения: Булево

 

Проверка, является ли значение уникальным идентификатором. Использует маску-шаблон:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "sfsdf-sdfsd-sfsff";
Итог = СтроковыеФункцииКлиентСервер.ЭтоУникальныйИдентификатор(МояСтрока);
Сообщить(Итог); //Нет (Ложь) 

КонецПроцедуры

 

Функция 9.

ДополнитьСтроку(Значение, ДлинаСтроки, Символ = "0", Режим = "Слева")

Тип возвращаемого значения: Строка

 

Добивает строку слева или справа до определенной длины заданными символами. Вот так:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "427380";
Итог = СтроковыеФункцииКлиентСервер.ДополнитьСтроку(МояСтрока, 12, 0, "Слева");
Сообщить(Итог); //000000427380 

КонецПроцедуры

Не нужно заморачиваться с типовым функционалом платформы Лев(), Прав().

 

Функция 10.

ПреобразоватьЧислоВРимскуюНотацию(АрабскоеЧисло, ИспользоватьКириллицу = Истина)

Тип возвращаемого значения: Строка

 

Функция преобразовывает арабские цифры (обычные) в римские. Используя кириллицу - римское число будет выведено "русскими" буквами:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = 59;
Итог = СтроковыеФункцииКлиентСервер.ПреобразоватьЧислоВРимскуюНотацию(МояСтрока);
Сообщить(Итог); //Л1Х

КонецПроцедуры

 

Функция 11.

ПреобразоватьЧислоВАрабскуюНотацию(РимскоеЧисло, ИспользоватьКириллицу = Истина)

Тип возвращаемого значения: Число

 

Обратная процедура преобразования в арабские цифры. Здесь, опять используем кириллицу, римское число перед обработкой заключили в кавычки:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "Л1Х";
Итог = СтроковыеФункцииКлиентСервер.ПреобразоватьЧислоВАрабскуюНотацию(МояСтрока);
Сообщить(Итог); //59 

КонецПроцедуры

 

Функция 12.

СтрокаЛатиницей(Знач Значение)

Тип возвращаемого значения: Строка

 

Очень полезная функция, позволяющая перекодировать строку в латиницу, не городя огород:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "Иванов Иван Иванович. Привет всем!";
Итог = СтроковыеФункцииКлиентСервер.СтрокаЛатиницей(МояСтрока);
Сообщить(Итог); //Ivanov Ivan Ivanovich. Privet vsem!

КонецПроцедуры 

 

Функция 13.

СтрокаВДату(Знач Значение)

Тип возвращаемого значения: Дата

 

Также мега-полезная функция:

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "04.07.2020";
Итог = СтроковыеФункцииКлиентСервер.СтрокаВДату(МояСтрока);
Сообщить(Итог); //04.07.2020 0:00:00 // Тип - Дата

КонецПроцедуры

 

Функция 14.

СтрокаВЧисло(Знач Значение)

Тип возвращаемого значения: Число

 

Данная функция так же капитально избавляет от "головной боли" и придумывания "велосипедов":

&НаКлиенте
Процедура Команда1(Команда)

МояСтрока = "000 1 256 888.55";
Итог = СтроковыеФункцииКлиентСервер.СтрокаВЧисло(МояСтрока);
Сообщить(Итог); //1 256 888,55 // Тип - Число

КонецПроцедуры

Преобразовывает в тип число, даже удаляет "лидирующие нули" и "видит" пробелы.

 

В статье привел наиболее часто используемые мной функции работы со строками, значительно ускоряющие написание доработок или обработок для конфигурации, основанных на библиотеке стандартных подсистем.

Я привел описание 14 удобных функций библиотеки стандартных подсистем работы со строками, использование которых значительно ускорит процесс разработки, вот они:

 

1. РазложитьСтрокуВМассивПодстрок(МояСтрока, Разделитель, ПропускатьПустыеСтроки, СокращатьНепечатаемыеСимволы)

2. ПодставитьПараметрыВСтроку(ШаблонСтроки,Параметр1, .....  ,Параметр9)

3. ВставитьПараметрыВСтроку(ШаблонСтроки, Параметры)

4. ПараметрыИзСтроки(СтрокаПараметров, Разделитель)

5. РазложитьСтрокуВМассивСлов(Значение, РазделителиСлов)

6. ТолькоЛатиницаВСтроке(СтрокаПроверки, УчитыватьРазделителиСлов, ДопустимыеСимволы = "")

7. СократитьДвойныеКавычки(Значение)

8. ЭтоУникальныйИдентификатор(Значение)

9. ДополнитьСтроку(Значение, ДлинаСтроки, Символ = "0", Режим = "Слева")

10. ПреобразоватьЧислоВРимскуюНотацию(АрабскоеЧисло, ИспользоватьКириллицу = Истина)

11. ПреобразоватьЧислоВАрабскуюНотацию(РимскоеЧисло, ИспользоватьКириллицу = Истина)

12. СтрокаЛатиницей(Значение)

13. СтрокаВДату(Значение)

14. СтрокаВЧисло(Значение)

 

Конечно, в БСП есть еще несколько функций для удобства работы со строками, но они в основном максимально-приближены к типовым функциям платформы.

Данный небольшой обзор 14 функций написан, используя версию БСП 3.0.3.130. Версия платформы 1С Предприятия 8.3.16.1063. Спасибо за внимание!

 

Если вам интересен мой практический подход и информация, которую вы сможете реально использовать, если у вас есть желание, чтобы данный комплекс статей наполнялся практическими материалы для программистов - я не откажусь от поддержки как данной статьи, так и всего комплекса статей в целом.

 

П.С. Старайтесь использовать БСП, не изобретайте велосипеды! Все уже придумано за вас!

Так же прошу ознакомиться с моей статьей Полезные встроенные функции для работы с печатными формами и не только на УТ 11.4 и БП 3.0

БСП работа со стоками

См. также

Шаблон многопоточного выполнения фонового задания

Инструментарий разработчика БСП (Библиотека стандартных подсистем) Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Пример шаблона для многопоточного выполнения фонового задания на основе БСП. Шаблоны сделаны для процедуры и функции.

2 стартмани

03.05.2024    1017    16    Hitcher    3    

10

Создать на основании - своя кнопка (БСП). Проблема двух подменю Создать на основании

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2849    dimanich70    8    

15

Заполнение поля адреса в своей обработке [БСП]

Механизмы платформы 1С БСП (Библиотека стандартных подсистем) Программист Стажер Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Небольшая шпаргалка по функциям БСП касательно адреса. Так скажем, еще один способ помимо https://infostart.ru/1c/articles/1060970/

12.02.2024    1012    FilippovRI    0    

17

Расширяем возможности дополнительных обработок и настраиваем их отладку

БСП (Библиотека стандартных подсистем) Механизмы типовых конфигураций Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Уже не одна веб-страница исписана знаниями о дополнительных обработках, как создать, как подключить. Есть масса вариантов, как их можно отладить. Я разобрался в кишках работы библиотеки и покажу, как можно расширить возможности дополнительных отчетов, а также покажу удобный способ отладки.

07.02.2024    3131    YA_418728146    11    

51

1С:БСП Дополнительные реквизиты и сведения

БСП (Библиотека стандартных подсистем) Программист Платформа 1С v8.3 Бесплатно (free)

В этой статье расскажем об архитектуре, использовании и особенностях реализации подсистемы «Свойства» из инструментария разработчика «1С:Библиотека стандартных подсистем» (1С: БСП).

19.01.2024    9287    PROSTO-1C    5    

48
Отзывы
38. quazare 3706 20.04.22 06:41 Сейчас в теме
Всем желающим скачать разные примеры работы с БСП - можете на моем телеграмм канале
NicolasCage; +1 Ответить
Остальные комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. tormozit 7176 05.07.20 08:34 Сейчас в теме
Пример для функции СократитьДвойныеКавычки некорректный. Функция в данном примере возвращает такую же строку, которую получает на вход. Эта функция удаляет двойные кавычки только в начале и конце строки. Поэтому строка-параметр подобрана некорректно.
Такой пример будет корректным

МояСтрока = """Привет всем. Данная строка будет выведена без двойных кавычек""";
Итог = СтроковыеФункцииКлиентСервер.СократитьДвойныеКавычки(МояСтрока);
Сообщить(Итог);
CratosX; milov.aleksey; quazare; ardn; +4 Ответить
5. quazare 3706 05.07.20 11:05 Сейчас в теме
(1) спасибо за корректировку. поправил описание и пример.
2. twiny 15 05.07.20 08:45 Сейчас в теме
А ф2 это та же самая СтрШаблон только с ограничением?
6. quazare 3706 05.07.20 11:13 Сейчас в теме
(2) СтрШаблон "живет" на < 8.3.6 или в совместимости < 8.3.6

эта функция основана на СтрЗаменить (9 раз.....)
33. ilya2184 62 13.07.20 09:28 Сейчас в теме
(6) АПК говорит что в СтрШаблон там ещё косяк какой-то с локализацией строк. Рекомендуют функции БСП
44. Риник 13 01.02.23 15:07 Сейчас в теме
(6) Наверное не < 8.3.6, а > 8.3.6?

СП: Доступен, начиная с версии 8.3.6 (в режиме совместимости с версией 8.3.5 и последующими).
3. ardn 628 05.07.20 09:25 Сейчас в теме
За популяризацию БСП однозначный плюс.

Но за грязный код в самом начале статьи (получение текста для сообщения версии БСП) - минус. Дело даже не в том, что не стоит использовать конкатенацию строк, вы же пишете о строковых функциях, используйте шаблон.
user720385; Bazil; +2 Ответить
7. quazare 3706 05.07.20 11:21 Сейчас в теме
(3) верно замечено! приведено в соответствие представленному материалу!
8. EvgeniuXP 05.07.20 11:55 Сейчас в теме
(3)тогда ее не в начало статьи а в конец :) а то смотрю на функцию БСП как баран на новые ворота :)))) статью еще не прочитал - а тут сразу удар ногой по голове :)
9. quazare 3706 05.07.20 12:02 Сейчас в теме
(8) да просто копи-пасть для начала - потом понравится удобство - вникнешь в суть функций)
4. Vanch90 05.07.20 09:42 Сейчас в теме
Гы, используешь бсп функции, через год бсп обновляется, переименовывает модуль или функции устаревают..
Классика
Evg-Lylyk; CratosX; 1giga; lsg45; milov.aleksey; SuhoffGV; Yashazz; +7 Ответить
10. quazare 3706 05.07.20 16:11 Сейчас в теме
(4) да нет, в бсп старые функции оставляют (с пометкой комментарием, "устарело"). строковые функции - это вообще "фундамент"
Evg-Lylyk; Риник; +2 Ответить
39. fatman78 17 24.06.22 22:20 Сейчас в теме
(4) Теперь за этим следит плагин валидации в EDT. Он начинает сообщать о потенциальных проблемах в будущем уже при появлении в описаниях процедур и функций БСП ключевого слова "устарело".
Риник; +1 Ответить
41. quazare 3706 25.06.22 06:35 Сейчас в теме
(39) хорошо, не знал об этом
13. RustIG 1675 06.07.20 09:32 Сейчас в теме
(11) обоснуйте ограничение
14. zeegin 116 06.07.20 10:16 Сейчас в теме
(13) Стандарта не достаточно? 0_о
Риник; +1 Ответить
17. RustIG 1675 06.07.20 14:50 Сейчас в теме
(14) нет, так как стандарт причину не раскрывает
16. dock 44 06.07.20 14:33 Сейчас в теме
(13) привел ссылку на стандарт 1С #std418
обоснуйте ограничение

совершенно не понятна суть вопроса: обосновать использование стандарта или обосновать сам стандарт ?
- использовать или не использовать стандарты 1С, Ваше личное дело.
- сам стандарт не могу обосновать, я не являюсь автором. Но предполагаю, что всё дело в клиент-серверном взаимодействии и переходе на управляемые формы ;)

Но да, моя ошибка: я явно не указал, что это ссылка на стандарт 1С.

З.Ы. Сама статья интересная и полезная, но вот только применение "Сообщить()" немного портит впечатление: при "призыве" использовать БСП я ожидал и "призыв" соблюдать стандарты ...
Риник; +1 Ответить
18. RustIG 1675 06.07.20 14:52 Сейчас в теме
(16) в чем суть ограничения - "Не использовать Сообщить()" ?
в БСП много чего включили - городить огород зачем?
19. dock 44 06.07.20 15:15 Сейчас в теме
(18)
метод Сообщить() появился в версии 8.0, когда не было четкого разделения между клиентом и сервером.
Объект СообщениеПользователю - с версии 8.2, когда было введено четкое разделение клиента и сервера и, соответственно, управляемые формы. Этот объект расширяет возможности взаимодействия с пользователем и должен более корректно отрабатываться механизмами платформы в управляемых формах на всех видах клиентов (тонкий, веб)

в чем суть ограничения: использовать актуальные механизмы платформы.

в БСП много чего включили - городить огород зачем?

Это уже платформенные механизмы, к БСП не имеет отношения.
Риник; milov.aleksey; +2 Ответить
20. RustIG 1675 06.07.20 15:27 Сейчас в теме
(19) ну ясно, пока что черный ящик
Объет Новый СообщениеПользователю для вывода использует метод Сообщить()
Понятно, что у объекта это собственный метод и как он реализован - неизвестно....
Раньше использовали метод Сообщить()....
В чем их отличие пока непонятно
23. Yashazz 4752 07.07.20 08:21 Сейчас в теме
(20) Дофига в чём. Во-первых, они по-разному преобразуют сложные платформенные типы, имеют разный максимальный размер выводимых строк и всплывающих подсказок, и по-разному их показывают; во-вторых, различным образом кэшируются и жрут память, в третьих, объекты сообщений пользователям можно выгрести в массив, а сообщённое нельзя... Много чего.
CratosX; Риник; +2 Ответить
21. RustIG 1675 06.07.20 15:28 Сейчас в теме
(19) собственно , программа 1с ошибку не выдает при использовании старого метода Сообщить()....
22. RustIG 1675 06.07.20 15:35 Сейчас в теме
(19) возможно, для веб-клиента есть разница... не проверял
12. muskul 06.07.20 08:49 Сейчас в теме
Ох помню строка в дату мне крови попила.
15. Shmell 538 06.07.20 10:19 Сейчас в теме
СтрокаВДату - не знал. Спасибо.
24. Yashazz 4752 07.07.20 08:23 Сейчас в теме
Давно сделал собственную аналогичную библиотеку, в которой уверен на все 100%. А вот в поделках БСП быть уверенным нельзя. После того, как из-за "внезапной" перетасовки кода в БСП у нас накрылся большой серьёзный проект, я БСП стараюсь по мере возможности игнорировать. И вам советую - меньше неожиданных граблей будет.
1giga; RustIG; +2 Ответить
25. nixel 1418 07.07.20 09:53 Сейчас в теме
(24)
После того, как из-за "внезапной" перетасовки кода в БСП у нас накрылся большой серьёзный проект


вы либо использовали служебный программный интерфейс, либо устаревшие процедуры и функции. СПИ может меняться когда угодно, его совместимость не гарантируется, он на то и служебный, чтобы его кто попало не дергал. устаревшие процедуры и функции висят в коде бсп годами, давая время на плановую миграцию. вызов устаревших методов без проблем ловится стат анализаторами.
Риник; Поручик; fatman78; RustIG; +4 Ответить
26. RustIG 1675 07.07.20 11:44 Сейчас в теме
(25) разработчики БСП как-то оповещают сообщество, что они изменили процедуры? мониторить документацию - большой труд.... а написать свою библиотеку вполне нормальный ход.
27. nixel 1418 07.07.20 11:45 Сейчас в теме
(26) да, в чейнджлогах. там же, где описаны *обязательные* действия по переходу на новую версию библиотеки.
Риник; +1 Ответить
28. RustIG 1675 07.07.20 11:51 Сейчас в теме
(27) вы сами мониторите чейнджлог?
29. nixel 1418 07.07.20 11:52 Сейчас в теме
(28) да. накатывать обновление корневой библиотеки без проверки изменения требований по ее внедрению и тестирования считаю несколько безответственным)
Риник; +1 Ответить
30. RustIG 1675 07.07.20 12:00 Сейчас в теме
(29) спасибо за ваш комментарий) я многое не знал - про СПИ например, да и многое чего, с чем не сталкивался. Но я больше придерживаюсь мнения Якова, чем вашего. К сожалению, относиться к БСП надо именно с осторожностью и с той долей ответственности, как вы подразумеваете.)) ок, вопросов нет
31. Yashazz 4752 07.07.20 14:21 Сейчас в теме
(25) я даже спец.конфу написал, чтобы эти изменения мониторить по факту, а не по их описаниям... но это было после. И использовался именно программный интерфейс. Просто вдруг бац, и новое поколение БСП выкатили. И всё переделывать за те же деньги и в те же сроки.
40. fatman78 17 24.06.22 22:32 Сейчас в теме
(31) Все намного проще стало. Сейчас удобно мониторить "изнутри" все изменения БСП через Git. Добрые люди давно выкладывают обновления БСП на регулярной основе. https://github.com/1c-syntax/ssl_3_1
35. biimmap 1946 20.07.20 20:43 Сейчас в теме
(24) Вот тут Вы совсем не правы! Конечно при обновлении нужно проверять актуальность программного интерфейса, который был использован.
Это один из этапов обновления конфигурации! Здесь большой вопрос к человеку, который делал обновление.
По своему опыту скажу что часто возникает ситуация когда просто некуда вставить написанное ранее. Приходится думать и быстро работать))) Но избегать нельзя!
Я жутко против велосипедов! Не нужно писать лишний код!
32. user848614 09.07.20 23:46 Сейчас в теме
Есть платформенный метод СтрРазделить. Он вроде как работает так же как функции 1и 5. И есть обратный ему СтрСоединить. Или у них есть какие то минусы по сравнению с БСПешными?
34. user612295_death4321 17.07.20 15:37 Сейчас в теме
(32) у СтрРазделить точно было какое то отличие от БСПшного. Вроде разделял только до первого разделителя. БСПшный в этом плане работал более ожидаемо.
36. MishaD 14 21.07.20 09:37 Сейчас в теме
(32)СтрРазделить делит по каждому символу в разделителе, а РазложитьСтрокуВМассивПодстрок по всему разделителю. То есть строку "Один; Два Три" в случае разделителя "; " СтрРазделить разделит на 3 подстроки(Один,Два,Три), а РазложитьСтрокуВМассивПодстрок на 2 подстроки(Один, Два Три).

Однако СтрРазделить работает на порядок шустрее, так что при возможности лучше её использовать.
37. AnryMc 849 01.03.21 12:24 Сейчас в теме
Как полный склеротик постоянно ищу "подходящие" функции в типовых конфигурациях и мне навряд ли поможет их список...

З.Ы. А если еще учесть что в БСП периодически что нибудь меняется...
Поручик; +1 Ответить
38. quazare 3706 20.04.22 06:41 Сейчас в теме
Всем желающим скачать разные примеры работы с БСП - можете на моем телеграмм канале
NicolasCage; +1 Ответить
42. Mark72 19.07.22 17:28 Сейчас в теме
Спасибо, добавил в шаблоны кода
43. 1giga 31.10.22 09:22 Сейчас в теме
часть функций (1,4,5) были написаны когда ещё не было стрРазделить (появилась с 8.3.6 в 2015г). И зачем "держать в голове" эти три функции (или более) если в платформе есть уже одна. И лично у меня от БСП просто истерика - вместо изучения механизмов платформы приходиться изучать кучи неОптимально именованного кода - сами наименования модулей типа "СтроковыеФункцииКлиентСервер" - это уже технически не читабельно. С точки зрения гуманитария может быть и да, но мозг не воспринимает такие длинные наименования.
porese; Риник; +2 Ответить
Оставьте свое сообщение