Отображение и редактирование в дереве большого количества настроек/параметров/опций программы, конфигурации, документа, справочника - без программного создания элементов формы

Публикация № 1342958

Разработка - Практика программирования

Очень много реквизитов (настроечные опции, параметры) у справочника или документа, и их все необходимо разместить на управляемую форму - лень! Хочется - добавил в метаданные и всё! В публикации отличное, простое и олдскульное решение с открытым кодом, научимся работать с ДанныеФормыДерево, ДеревомЗначений, сделаем быстрый поиск, создадим универсальный инструмент.

При разработке различных конфигураций мы у себя в команде часто сталкиваемся с необходимостью простого и быстрого размещения большого количества реквизитов метаданных (справочников, документов) на форму, обычно это касается различных настроечных опций или параметров. Конечно, можно вручную их разместить на форму или программно (динамически) создать элементы управляемой формы, но это все варианты, которые загромождают форму, усложняют пользовательскую работу с ней. А главное зачем, если решение давно было придумано - размещение реквизитов в виде дерева (TreeView). Дерево позволяет структурировать параметры/опции/настройки/реквизиты, удобно с ними работать. А ещё будет так - добавил в метаданные реквизит и он уже сразу доступен в 1С:Предприятие для редактирования/просмотра пользователю/администратору. 

 

Как же подобное организовано в типовых? Например, в типовой Розница, редакция 2.3 для подобного используется - ПланВидовХарактеристик: НастройкиПользователей, Справочник: Пользователей и регистр сведений: НастройкиПользователей. Там это обусловлено тем, что необходимо для пересечения Магазин, Пользователь определить его настройки. Однако, в случае, если у Вас настройки только для пользователя или только для магазина, то смысла использовать ПВХ нет, оно только усложняет запросы (в предлагаемом решении вся информация хранится в одном справочнике/документе, следовательно и запрос выполняется только к одной таблице). 
 

Итак, сразу покажем результат универсального механизма из нашей подсистемы EDIbot (быстрое создание реактивных веб приложений/B2B-порталов/сайтов/Dashboard), который достигнем кодом публикации:

 

Рассмотрим по шагам, как такое Вам сделать в конфигурации:

1. Вы как обычно создаете/добавляете реквизиты метаданных к Вашему объекту, НО в стандартном поле "Комментарий" указываете Имя группы реквизита. Причем для создания подгрупп имя группы можно указать с точкой,  например, "Общие.Масштабирование", вот пример:

 

2. Далее, добавляем Дерево значений в реквизиты формы и размещаем его на форме

 

3. Заполняем наше дерево на клиенте, в процедуре при открытии:

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	ЗаполнитьДеревоПараметров(_ВебАппСеанса.ПолучитьСписокРеквизитовДереваПараметров("Справочники._ВебАппСтраницы"));

КонецПроцедуры

 

4. Как видно, мы передаем нашей функции по заполнению реквизиты для построения дерева, опишем эту функцию: ПолучитьСписокРеквизитовДереваПараметров и как раз именно здесь мы будем использовать наш комментарий к реквизиту метаданных как структуру дерева (группы/подгруппы).

Функция ПолучитьСписокРеквизитовДереваПараметров(ИмяМД) экспорт
	
	Реквизиты = Новый Структура();
	
	МД = Вычислить("Метаданные."+ИмяМД);
	
	Для Каждого Реквизит Из МД.Реквизиты Цикл
		
		Если ПустаяСтрока(Реквизит.Комментарий) Тогда
			Продолжить;
		КонецЕсли;
		
		Реквизиты.Вставить(Реквизит.Имя, Новый Структура("Группа, ИмяПараметра, Представление, Подсказка, Тип", Реквизит.Комментарий, Реквизит.Имя, Реквизит.Синоним, Реквизит.Подсказка, Реквизит.Тип));
	КонецЦикла;
	
	Возврат Реквизиты;
КонецФункции

 

5. Теперь все готово, чтобы описать нашу процедуру по заполнению дерева:

&НаКлиенте
Процедура ЗаполнитьДеревоПараметров(Реквизиты)
	
	ИндексДереваПараметров = Новый Соответствие();
	
	ДеревоПараметров = ДеревоПараметровФорма.ПолучитьЭлементы();
	ДеревоПараметров.Очистить();
	
	Для Каждого Элемент Из Реквизиты Цикл
		
		Реквизит = Элемент.Значение;
		
		Если ПустаяСтрока(Реквизит.Группа) Тогда
			Продолжить;
		КонецЕсли;
		
		ДобавитьПараметрВДерево(ДеревоПараметров, Реквизит);
	
	КонецЦикла;
	
КонецПроцедуры	

 

&НаКлиенте
Функция ДобавитьПараметрВДерево(ДеревоПараметров, Реквизит)
	
	МассивСвойств = СтрРазделить(Реквизит.Группа, ".");
	
	ГруппаДерева = ДеревоПараметров;
	Для Ном=0 По МассивСвойств.Количество()-1 Цикл
		
		ИмяГруппы = МассивСвойств[Ном];
		
		СтрокаДерева = ИндексДереваПараметров.Получить(ИмяГруппы);
		
		Если СтрокаДерева=Неопределено Тогда
			
			СтрокаДерева = ГруппаДерева.Добавить();
			
			СтрокаДерева.ИмяПараметра	= ИмяГруппы;
			СтрокаДерева.Представление 	= ИмяГруппы;
			СтрокаДерева.ЭтоГруппа		= Истина;
			
			ИндексДереваПараметров.Вставить(ИмяГруппы, СтрокаДерева);
			
		КонецЕсли;	
		
		ГруппаДерева = СтрокаДерева.ПолучитьЭлементы();		
	КонецЦикла;	
	
	НоваяСтрока = ГруппаДерева.Добавить();
	
	ЗаполнитьЗначенияСвойств(НоваяСтрока, Реквизит);
	
	НоваяСтрока.ЗначениеПараметра 	= Объект[Реквизит.ИмяПараметра];
	
	ИндексДереваПараметров.Вставить(Реквизит.ИмяПараметра, НоваяСтрока);

	Возврат НоваяСтрока;
КонецФункции

Известно, что объект типа ДанныеФормыДерево не имеет функции Найти или НайтиСтроки, а обход дерева дорогостоящая операция, поэтому в функции ДобавитьПараметрВДерево мы используем индексацию строк дерева формы по параметру (добавляем в соответствие ИндексДереваПараметров соответствие строки дерева имени параметра). 

 

Итак, мы с Вами сделали вывод всех наших реквизитов на управляемую форму, у которых заполнено поле "Комментарий" (т.е. реквизит отнесен к какой-либо группе дерева настроек).

 

Теперь возникает вопрос, а как редактировать особо сложные реквизиты, как сделать сохранение реквизитов в базу данных?

Для сохранения изменений, сделанных на форме, в объект мы с Вами добавим обработку события ПриИзменении значения параметра:

&НаКлиенте
Процедура ДеревоПараметровФормаЗначениеПараметраПриИзменении(Элемент)
	
	СтрокаТЧ = Элементы.ДеревоПараметровФорма.ТекущиеДанные;
	
	Если СтрокаТЧ=Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	Объект[СтрокаТЧ.ИмяПараметра] = СтрокаТЧ.ЗначениеПараметра;
		
	Если СтрокаТЧ.ИмяПараметра="РабочийКаталог" Тогда
		
		ОбновитьПовторноИспользуемыеЗначения();
		
		Записать();
		
	ИначеЕсли СтрокаТЧ.ИмяПараметра="СпособМасштабирования" И СтрокаТЧ.ЗначениеПараметра="font-size" Тогда			
		
		УстановитьЗначениеПараметра("ЦельМасштабирования", "");		
		
	КонецЕсли;

КонецПроцедуры

 

Как видно, в процедуре мы устанавливаем ЦельМасштабирования, равное пустому значению при значении СпособМасштабирования="font-size" с помощью функции УстановитьЗначениеПараметра, вот ее код:

&НаКлиенте
Процедура УстановитьЗначениеПараметра(ИмяПараметра, ЗначениеПараметра)
		
	СтрокаДерева = ИндексДереваПараметров.Получить(ИмяПараметра);
	
	Если СтрокаДерева=Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	СтрокаДерева.ЗначениеПараметра 	= ЗначениеПараметра;
	Объект[ИмяПараметра] 			= ЗначениеПараметра;

КонецПроцедуры	

Обратите внимание, как это было реализовано: здесь мы опять использовали быстрый поиск строки дерева формы по имени параметра.

 

А для обработки каких-то специфических реквизитов, например, выбор каталога добавляем обработку события НачалоВыбора

&НаКлиенте
Процедура ДеревоПараметровФормаЗначениеПараметраНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
	
	СтрокаТЧ = Элементы.ДеревоПараметровФорма.ТекущиеДанные;
	
	Если СтрокаТЧ=Неопределено Тогда
		Возврат;
	КонецЕсли;

	Если СтрокаТЧ.ИмяПараметра="РабочийКаталог" Тогда
		
		ВыборКаталога(Элемент, СтрокаТЧ.ИмяПараметра);		
		
	КонецЕсли;
	
КонецПроцедуры

 

Однако, бывает, что нужно решить еще одну задачку - ограничить те типы, которые пользователь может выбирать при редактировании значения параметра. 

Например, выбор из определенного списка или ограничение доступности изменения реквизитов при определенных условиях.

Будем реализовывать это с помощью обработки события ПередНачаломИзменения:

&НаКлиенте
Процедура ДеревоПараметровФормаПередНачаломИзменения(Элемент, Отказ)
	
	СтрокаТЧ = Элементы.ДеревоПараметровФорма.ТекущиеДанные;
	
	Если СтрокаТЧ=Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	Если НЕ Элемент.ТекущийЭлемент.Имя="ДеревоПараметровФормаЗначениеПараметра" Тогда		
		
		Отказ = Истина;
		
		Возврат;
	КонецЕсли;	

	Реквизиты = _ВебАппСеанса.ПолучитьСписокРеквизитовДереваПараметров("Справочники._ВебАппСтраницы");
	Элемент.ТекущийЭлемент.ОграничениеТипа = Реквизиты[СтрокаТЧ.ИмяПараметра].Тип; 
	
	Элемент.ТекущийЭлемент.РежимВыбораИзСписка 	= Ложь;
	Элемент.ТекущийЭлемент.КнопкаВыбора		   	= Истина;
	
	Элемент.ТекущийЭлемент.СписокВыбора.Очистить();		
	
	Если СтрокаТЧ.ИмяПараметра="СпособМасштабирования" Тогда
		
		Элемент.ТекущийЭлемент.РежимВыбораИзСписка = Истина;
	
		Элемент.ТекущийЭлемент.СписокВыбора.Добавить("scale");
		Элемент.ТекущийЭлемент.СписокВыбора.Добавить("font-size");
		
	ИначеЕсли СтрокаТЧ.ИмяПараметра="ЦельМасштабирования" Тогда	
		
		Отказ = НЕ (Объект.СпособМасштабирования="scale");		
		
	ИначеЕсли СтрокаТЧ.ИмяПараметра="Актуальность" Тогда	
		
		Отказ = Истина;
		
	ИначеЕсли СтрокаТЧ.ИмяПараметра="ВывестиНаРабочийСтол" Тогда	
		
		Элемент.ТекущийЭлемент.РежимВыбораИзСписка = Истина;
		_ОбщегоНазначенияКлиентСервер.СкопироватьСписок(Элемент.ТекущийЭлемент.СписокВыбора, _ВебАппДанныеСеанса.СписокСтраницРабочегоСтола());
		
	КонецЕсли;
		
КонецПроцедуры

 

Ну вот теперь точно всё - мы сделали универсальный механизм для вывода любого количества реквизитов метаданных с автоматической их группировкой, возможностью редактирования, а также сложной обработкой их зависимостей между собой. 

 

Надеюсь, моя публикация была Вам полезна и сэкономит Ваше время, ссылка на все публикации SizovE.

Подписывайтесь на мой канал (наверху), будет много интересного бесплатного контента :)

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Cyberhawk 126 03.01.21 17:37 Сейчас в теме
Чем это все лучше предопределенных элементов ПВХ? Древовидная структура из коробки, возможность ограничивать типы каждого элемента - все это вроде и там есть.
2. SizovE 159 03.01.21 18:54 Сейчас в теме
(1) Если как Вы предлагаете, то чтобы организовать, например, настройки пользователей (в типовой именно так) делается отдельный регистр, который хранит значения настроек этого пользователя и чтобы вывести дерево типовая использует тоже некий алгоритм его заполнения.
Иными словами используется такая структура - Справочник Пользователи, ПВХ, РегистрСведений. А тут все хранится в одном месте (справочнике Пользователи). В чем плюс моего решения? - В обращениях из запросов, Вы делаете запрос, который обращается к одной таблице и сразу оттуда получает нужное. Да и если честно прозрачнее с точки зрения кода, по крайне мере мне ) Гляньте их модули в типовой Рознице например, как организовано заполнение ФормаНастроекПользователя регистра сведений НастройкиПользователей - тиражировать в свой код такое не сильно хочется )

А ещё как оно бывает: Есть некий справочник, в котором было 5 реквизитов опций, сначала добавляешь их на форму, потом клиент просит еще парочку опцией, потом еще парочку, и тут уже на ПВХ переходить не комильфо, а вот внедрить подобный инструмент за пару минут отличное решение
3. Cyberhawk 126 03.01.21 19:06 Сейчас в теме
(2)
чтобы вывести дерево типовая использует тоже некий алгоритм его заполнения. Иными словами используется такая структура - Справочник Пользователи, ПВХ, РегистрСведений
Я про один ПВХ, без какого-либо кода и форм. В статье предлагается добавлять реквизиты в метаданные и иерархию по заполненным в комментарии значениям выстраивать и обмазывать отрисовку прикладным кодом, а в случае с ПВХ добавление предопределенных происходит сразу в нужную папку (нужную иерархию) и никаких форм и код можно не писать.
4. SizovE 159 03.01.21 19:29 Сейчас в теме
(3) Возможно, я плохо описал зачем это всё )
Я думал, что эта фраза позволяет понять, чем ПВХ не подходит -
Очень много реквизитов (настроечные опции, параметры) у справочника или документа, и их все необходимо разместить на управляемую форму - лень!

Добавлю в статью, чем не подходит ПВХ для этой задачи.
5. user1503726 03.01.21 20:24 Сейчас в теме
Это похоже на подсистемы конфигуратора, только в любом месте, где захотите, в интерфейсе.
Можно в любом справочнике/документе по любому текстовому полю организовать еще одну(2-3..) иерархии и выбирать какая нужна в конкретный момент.
6. SizovE 159 03.01.21 23:12 Сейчас в теме
Оставьте свое сообщение

См. также

Звуковое управление в 1С 8.3 Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

В данной статье описано создание библиотеки для звукового управления (выполнение команд голосом) для платформы 1С 8.3. Задача была поставлена так, чтобы модуль функционировал непосредственно на клиенте 1С, осуществляя управление формами, и взаимодействовал с интерфейсом.

16.03.2021    2760    velemir    30    

Полезные примеры СКД, ч.2

Практика программирования v8 v8::СКД Бесплатно (free)

Еще несколько примеров решения задач в СКД.

06.04.2021    3168    Neti    7    

Обзор полезных методов БСП 3.1.4

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Библиотека стандартных подсистем (далее - БСП) является частью любой типовой конфигурации, поэтому умение применять готовые процедуры и функции повышает качество разработки и избавляет от написания лишнего кода. К сожалению, не у всех есть время и упорство овладеть всей документацией, поэтому я собрал воедино наиболее популярный функционал.

25.03.2021    12077    rayastar    45    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    12627    quazare    34    

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions Промо

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    5162    comol    31    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    43561    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    32692    John_d    22    

СКД. Шаг 3. Используем макеты для оформления отчета

Работа с интерфейсом v8 v8::СКД 1cv8.cf Бесплатно (free)

В данной публикации рассмотрим базовый подход к использованию собственных макетов в СКД на примере формирования небольшого отчета.

13.01.2020    23404    aximo    14    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    38881    unichkin    74    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    25167    kuzyara    38    

Сходство Джаро - Винклера. Нечеткое сравнение строк

Универсальные функции v8 Россия Бесплатно (free)

В области информатики и статистики сходство Джаро - Винклера представляет собой меру схожести строк для измерения расстояния между двумя последовательностями символов. В публикации рассмотрены некоторые особенности алгоритма, и представлен вариант его реализации на языке 1С.

25.12.2019    7735    brooho    19    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    19665    YPermitin    60    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    32657    tormozit    105    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    10250    Sibars    19    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    34317    HostHost    41    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    42792    Yashazz    50    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    79761    tormozit    131    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    73082    rpgshnik    70    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    61404    ids79    55    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    34963    YPermitin    25    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    50687    tormozit    49    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    27590    YPermitin    81    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    37977    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    115218    ids79    69    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    47543    tormozit    74    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    47009    avalakh    26    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    31471    json    15    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    81684    ids79    14    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16622    m-rv    2    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    41421    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    29340    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    20647    SeiOkami    50    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    21233    m-rv    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    63105    ids79    26    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    27778    dmurk    146    

Подсистема "Варианты отчетов". Используете ли Вы ее правильно?

Работа с интерфейсом БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    48724    YPermitin    53    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    33031    m-rv    22    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    52000    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    38837    ellavs    127    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    29039    ellavs    90    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    29028    itriot11    34    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    35676    YPermitin    53    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    24983    Vladimir Litvinenko    28    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    48809    ids79    11    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    79107    Serginio    113    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    29728    ids79    31    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    47325    ids79    81    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    38688    ids79    40