Установка запрета продажи алкоголя в рознице

22.12.20

Учетные задачи - Розничная торговля

Простой способ установки и снятия запрета на продажу алкогольной продукции.

В нашем регионе действует запрет на продажу алкогольной продукции с 22-00 до 08-00, но тем не менее несколько моих клиентов были привлечены к ответственности за продажу алкогольной продукции именно в это время. При этом использовалось ПО: 1С Розница, Фронтол xPOS, и был установлен запрет на продажу штатным способом - через механизм маркетинговых акций. Но тем не менее он не сработал. Причина проста, запрет работает только в момент добавления товара в чек, и в Фронтол xPOS - кроме этого, при переходе в режим оплаты. Продавец регистрирует товар, считывая штрихкод и акцизную марку до 22-00, но закрывает и пробивает чек позже. Суммы штрафов значительны, и сама ситуация очень неприятна для всех ее участников: владельца бизнеса, продавца и ит-специалиста.

Первоначально я планировал в 1С Рознице, используя механизм расширений, сделать доработку, которая в момент пробития чека проверяла бы наличие алкопродукции и отменяла закрытие. Но этот способ не подходит к базовой версии 1С Розницы и Фронтол xPos. 

Решение оказалось простым - это принудительная остановка служб УТМ до наступления времени запрета, например в 21:57 и запуск в 8:02. Я создал 2 скрипта, один останавливает службы, другой стартует и прописал задания в планировщик Windows.

Примеры скриптов для УТМ Windows, использовал VBS, чтобы для пользователей ПЭВМ, где установлены УТМ не выводилось консольных окон. Для УТМ Linux , я думаю сделать аналогичное решение будет несложно.

 
start_utm.vbs
 
 
stop_utm.vbs

Кроме этих скриптов прилагается bat-файл создания в планировщике Windows заданий по запуску этих скриптов

 
create_task_utm.bat 

Нюанс - запрет сработает только на алкоголь с акцизными марками, и второе при закрытии чека - у продавца на экране будет ошибка связи с  УТМ ЕГАИС. Но это лучше, чем быть оштрафованным, и потом пытаться доказать, что продажа была неумышленной.

Всем удачи, успехов в розничной торговле.

См. также

1С:Управление торговлей 8

Управление розничной торговлей (RMS) Торговля Типовые решения Оптовая торговля Розничная торговля Управление складом и логистикой (WMS) Торговля и логистика Платформа 1С v8.3 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

"1С:Управление торговлей 8" — это современный инструмент для повышения эффективности бизнеса торгового предприятия. "1С:Управление торговлей 8" позволяет в комплексе автоматизировать задачи оперативного и управленческого учета, анализа и планирования торговых операций, обеспечивая тем самым эффективное управление современным торговым предприятием.

26700 руб.

17.02.2016    90487    194    0    

158

SALE! 15%

Автоматический заказ поставщику в 1С: загрузка прайсов и анализ цен поставщиков для УТ 10.3, УТ 11, КА2, УНФ, УПП, ERP, Розница 2

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

33529 28500 руб.

21.04.2017    84901    71    38    

150

ЕГАИС++. Опт, производство, импорт

Оптовая торговля Розничная торговля Обмен с ГосИС Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

7800 руб.

15.12.2015    161842    608    361    

377

Конфигурация "Весовая ред. 3.0" для Платформы 8.3

Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Логистика, склад и ТМЦ Торговля и логистика Платформа 1С v8.3 Сельское хозяйство и рыболовство Строительство Горнодобывающая промышленность Розничная и сетевая торговля (FMCG) Транспорт, автопарки, такси Оптовая торговля, дистрибуция, логистика Лесное и деревообрабатывающее хозяйство Управленческий учет Платные (руб)

Позволяет автоматизировать процесс взвешивания ТМЦ в организациях, осуществляющих приемку и отгрузку различным транспортом, для ведения складского учета и контроля остатков на складах. Конфигурация позволяет фиксировать вес вручную, напрямую с весов, а также управлять дополнительным оборудованием и контролировать движение транспорта.

30000 руб.

24.03.2015    118416    50    111    

124

Бонусная система для УТ 10.3

Управление взаимоотношениями с клиентами (CRM) Оптовая торговля Розничная торговля Платформа 1С v8.3 Оперативный учет Управляемые формы 1С:Управление торговлей 10 1С:Розница 2 Россия Управленческий учет Платные (руб)

Подсистема призвана упростить и автоматизировать процесс расчета и начисления бонусов покупателей. ОБНОВЛЕНИЕ ОТ 20.06.2022 г. Работает с конфигурациями 1С:УТ 10.3, 1С:Розница. Механизм реализован в начале 2013г. и работает до сих пор с постоянными совершенствованиями.

30000 руб.

02.11.2015    106753    206    87    

171

Обмен с системой ЦРПТ (Универсальная конфигурация ХамелеонЦРПТ + маркировка табака, обуви, одежды, лекарств, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин)

Оптовая торговля Розничная торговля Обмен с ГосИС Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте нам вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, мы накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

104000 руб.

18.03.2019    108293    28    112    

176

Загрузка номенклатуры из Excel в УТ11, КА 2, ERP 2, Розница 2. Дополнительные реквизиты и сведения, характеристики, картинки, цены, остатки

Загрузка и выгрузка в Excel Розничная торговля Логистика, склад и ТМЦ Ценообразование, анализ цен Прайсы Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Управленческий учет Платные (руб)

Загрузка из файлов xls, xlsx, ods, csv, mxl в УТ11, КА 2, ERP 2, Розница 2. Задействованы все возможности конфигурации - заполнение реквизитов номенклатуры, дополнительных реквизитов и сведений, характеристики, доп.реквизиты и сведения характеристик. Дополнительные обработки для расширения возможностей.

9460 руб.

29.10.2014    203902    568    521    

404
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. coolseo 76 22.12.20 11:15 Сейчас в теме
Здравствуйте, да эта проблема стоит "остро".
Прилагаю свой вариант, который можно подключить через планировщик :

startutm.cmd:
NET START Transport

stoputm.cmd:
net stop Transport
Прикрепленные файлы:
startutm.cmd
stoputm.cmd
2. ivanov_alex 86 22.12.20 12:52 Сейчас в теме
УТМ имеет свойство запускаться сам по себе, так что остановка не вариант
Было бы умнее закрывать чек,но после закрытия смены формировать акт списания с марками, которые напикали за ночь
Есть ли чтото подобное для Розницы?
3. independ 1468 22.12.20 14:04 Сейчас в теме
(2) имеется в виду ночной режим работы розничного магазина? Мне кажется акт списания не очень подходящий документ для этой ситуации. Если установить признак реализация в данном акте, рано или поздно могут возникнуть вопросы, а почему не чек продажи. Это хорошо для общепита. Списывать с признаком: потери, порча и проч - возможно, но в разумных пределах.
Toooryyy; +1 Ответить
5. ivanov_alex 86 22.12.20 14:14 Сейчас в теме
(3)Да, именно так
А вопросов как раз таки не будет, т.к. сам главный по егаис говорил на конференции что его удивляет, что в общепите алкоголь списывается чеками а не актами списания, то есть изначально так и планировалось
6. ivanov_alex 86 22.12.20 14:28 Сейчас в теме
(3)А для не общепита реализован механизм пробития чеков при закрытии смены
Но там есть несколько нюансов:
1. УТМ запущен,пикаем марки в РМК далее нажимаем пробить(нал или безнал)
вот как раз в этот момент розница не должна давать отправить чек в егаис, а должна просто провести его. Создается чек с признаком проведен и выбранной формой оплаты, без статуса отложен и пробит. В этом случае обработка закрытие смены сформирует список таких чеков с галками и достаточно нажать кнопку пробить и они улетают в егаис кучей,кассиру по сути надо нажать две кнопки чтобы закрыть смену а не одну, тут ничего страшного нет
2.если же отложить чек без выбора формы оплаты, то потом запутаешься где нал где безнал, записывать в тетрадку точно не вариант
4. viplelik 32 22.12.20 14:08 Сейчас в теме
Причина проста, запрет работает только в момент добавления товара в чек

и еще:
При выборе способа оплаты в 2.3.6.27 проверяется время запрета. (если время началось, не дает пробить чек)
Но если способ оплаты уже выбран время не проверяется.
7. tross 22.12.20 18:59 Сейчас в теме
Дмитрий, как вариант скрипты могут подойти, но бывает ошибка времени на компьютере пользователя. Нарывались на это при расхождении в 15 минут (продавец смотрит время по компу, а не по часам). При таки раскладах нужно выставлять обновление времени через интернет по интернету с интервалом в 30-60 минут, и соответственно устанавливать время в ККТ по системному времени компа с расхождением не более 1 минуты.
Это мое мнение.
8. independ 1468 22.12.20 19:37 Сейчас в теме
(7) если есть интернет, синхронизацию времени настроить можно, и также прописать ее в планировщике, использую утилитку cmdtime3.exe, уже не помню с каких времен, запуск скриптом vbs
Set WshShell = CreateObject("WScript.Shell")
WshShell.Run "cmdtime3.exe /q sync 0.pool.ntp.org /M:9999999", 0, false
16. Umka23 12 11.01.21 00:42 Сейчас в теме
(7)У ККТ время устанавливается только в состоянии "Смена закрыта"
stepanusinsk; +1 Ответить
9. ivanov_alex 86 23.12.20 07:10 Сейчас в теме
У вас не останавливается javaw
А это значит утм вскоре запустится, именно этот процесс стартует сначала апдейтер, потом транспорт
10. ivanov_alex 86 23.12.20 14:17 Сейчас в теме
Короче для Розницы
в процедуру Процедура ПечатьЧека_ПослеОткрытияЧека
вместо
Если ДополнительныеПараметры.ЕстьАлкогольнаяПродукцияЕГАИС Тогда
....
КонецЕсли

вставить код

Если ДополнительныеПараметры.ЕстьАлкогольнаяПродукцияЕГАИС Тогда
		ТекЧас = Час(ТекущаяДата());
		Если ТекЧас <8 и ТекЧас >= 23 Тогда
			ВыполнитьОбработкуОповещения(ПараметрыВыполнения.ОповещениеПродолжения, ПараметрыВыполнения);

//Лалалала, это ночь, детка.

иначе
	
		ПараметрыОперации = Новый Структура;
		ПараметрыОперации.Вставить("НомерСмены"   , НомерСмены);
		ПараметрыОперации.Вставить("НомерЧека"    , НомерЧека);
		ПараметрыОперации.Вставить("СерийныйНомер", ШапкаЧека.СерийныйНомер);
		
		ИнтеграцияЕГАИСКлиент.ПередатьНемедленно(
			ДополнительныеПараметры.ЧекККМСсылка,
			ПредопределенноеЗначение("Перечисление.ДальнейшиеДействияПоВзаимодействиюЕГАИС.ПередайтеДанные"),
			ПараметрыОперации,
			Новый ОписаниеОповещения("ПослеПередачиЧекаЕГАИС", ЭтотОбъект, ПараметрыВыполнения));
		 КонецЕсли; 
	Иначе
		ВыполнитьОбработкуОповещения(ПараметрыВыполнения.ОповещениеПродолжения, ПараметрыВыполнения);
	КонецЕсли;
Показать
independ; +1 Ответить
11. viplelik 32 23.12.20 20:41 Сейчас в теме
(10) Либо использовать время запрета маркетинговой акции
на примере 2.3.6.27 с контролем кода
&НаКлиенте
&ИзменениеИКонтроль("ПечатьЧека_ПослеОткрытияЧека")
Процедура ЗП_ПечатьЧека_ПослеОткрытияЧека(ПараметрыВыполнения, ДополнительныеПараметры)

	ШапкаЧека = ПараметрыВыполнения.ВходныеПараметры;

	НомерСмены = СтроковыеФункцииКлиентСервер.СтрокаВЧисло(ПараметрыВыполнения.НомерСмены);
	Если НомерСмены = 0 Тогда
		НомерСмены = 1;
	КонецЕсли;

	НомерЧека = СтроковыеФункцииКлиентСервер.СтрокаВЧисло(ПараметрыВыполнения.НомерЧека);
	Если НомерЧека = 0 Тогда
		НомерЧека = 1;
	КонецЕсли;

	ШапкаЧека.НомерСмены = НомерСмены;
	ШапкаЧека.НомерЧека = НомерЧека;

	Если ПараметрыВыполнения.Свойство("ЗаводскойНомерФН") И ЗначениеЗаполнено(ПараметрыВыполнения.ЗаводскойНомерФН) Тогда
		ШапкаЧека.СерийныйНомер = ПараметрыВыполнения.ЗаводскойНомерФН;
	КонецЕсли;

	Если ДополнительныеПараметры.ЕстьАлкогольнаяПродукцияЕГАИС Тогда
		
		#Вставка
		Если ПроверитьЗапрет() Тогда
			ТекстЗапретаПродаж = "Время продаж алкогольной продукции истекло";
			ОбщегоНазначенияРТКлиент.ВывестиИнформациюДляРМКУправляемой(НСтр("ru = 'Запрет продаж.'"), ТекстЗапретаПродаж);
		Иначе	
		#КонецВставки
			ПараметрыОперации = Новый Структура;
			ПараметрыОперации.Вставить("НомерСмены"   , НомерСмены);
			ПараметрыОперации.Вставить("НомерЧека"    , НомерЧека);
			ПараметрыОперации.Вставить("СерийныйНомер", ШапкаЧека.СерийныйНомер);
			
			ИнтеграцияЕГАИСКлиент.ПередатьНемедленно(
			ДополнительныеПараметры.ЧекККМСсылка,
			ПредопределенноеЗначение("Перечисление.ДальнейшиеДействияПоВзаимодействиюЕГАИС.ПередайтеДанные"),
			ПараметрыОперации,
			Новый ОписаниеОповещения("ПослеПередачиЧекаЕГАИС", ЭтотОбъект, ПараметрыВыполнения));
		#Вставка
		КонецЕсли;
		#КонецВставки
		
	Иначе
		ВыполнитьОбработкуОповещения(ПараметрыВыполнения.ОповещениеПродолжения, ПараметрыВыполнения);
	КонецЕсли;
КонецПроцедуры

&НаСервере
Функция ПроверитьЗапрет()
		СтрокаОшибки = "";
		ТекущаяДатаСеанса = ТекущаяДатаСеанса();
		Отказ = Ложь;
		СкидкиНаценкиСерверПереопределяемый.ПроверитьЗапретРозничнойПродажиТаблицыТоваров(Объект, "Товары", Отказ, СтрокаОшибки, ТекущаяДатаСеанса, Ложь);
		Возврат Отказ;
КонецФункции
Показать
Прикрепленные файлы:
ЗапретПродажЕГАИС.cfe
yaguarrr; independ; ivanov_alex; +3 Ответить
12. ivanov_alex 86 24.12.20 06:20 Сейчас в теме
(11)это нужна маркетинговая акция или сформированный сегмент по алкашке
13. viplelik 32 24.12.20 12:26 Сейчас в теме
(12) маркетинговая акция с установленным сегментом номенклатуры и типом скидки - Запретить розничную продажу
14. viplelik 32 24.12.20 15:27 Сейчас в теме
(11) Решил переделать. Не нравиться мне в этом коде то что, проверка идет уже после создания чека и нет обработки возврата оплаты по карте.

Тут проверка идет до создания чека. И можно контролировать не только алкогольную продукцию я любую указанную в сегменте.
&НаСервере
Функция ПроверитьЗапрет()
		СтрокаОшибки = "";
		ТекущаяДатаСеанса = ТекущаяДатаСеанса();
		ЗапретУстановлен = Ложь;
		СкидкиНаценкиСерверПереопределяемый.ПроверитьЗапретРозничнойПродажиТаблицыТоваров(Объект, "Товары", ЗапретУстановлен, СтрокаОшибки, ТекущаяДатаСеанса, Ложь);
		Возврат ЗапретУстановлен;
КонецФункции

&НаКлиенте
&ИзменениеИКонтроль("СоздатьЧеки")
Процедура ЗП_СоздатьЧеки(Отказ, Печать)

	Перем Ответ;

	Ответ = "";

	#Вставка
	Если ПроверитьЗапрет() Тогда
		Отказ = Истина;
		ОбработатьОтказОтОплаты();
		ТекстЗапретаПродаж = "Время продаж указанной продукции истекло!";
		ОбщегоНазначенияРТКлиент.ВывестиИнформациюДляРМКУправляемой(НСтр("ru = 'Запрет продаж.'"), ТекстЗапретаПродаж);
		Если ДанныеОтправленыВБанк Тогда 
			ОбработатьОшибочноеПробитиеЧека();
		КонецЕсли;
		Возврат;
	КонецЕсли;
	#КонецВставки
	Если Объект.ВидОперации = ПредопределенноеЗначение("Перечисление.ВидыОперацийЧекККМ.Возврат") Тогда
		ПроверитьЧтоНетОплатыПодарочнымСертификатом("Оплата", Отказ, Ответ, Истина);
		Если Отказ Тогда
			ОбработатьОтказОтОплаты();
			ОбщегоНазначенияРТКлиент.ВывестиИнформациюДляРМКУправляемой(НСтр("ru = 'Ошибка возврат товара'"), Ответ);
			Возврат;
		КонецЕсли;
	Иначе
		ПроверитьДвиженияСерийныхНомеровДляПогашения(Отказ, Ответ, ОбщегоНазначенияКлиент.ДатаСеанса());
		Если Отказ Тогда
			ОбработатьОтказОтОплаты();
			ОбщегоНазначенияРТКлиент.ВывестиИнформациюДляРМКУправляемой(
			НСтр("ru = 'Ошибки погашения подарочных сертификатов'"), Ответ);
			Если ДанныеОтправленыВБанк Тогда 
				ОбработатьОшибочноеПробитиеЧека();
			КонецЕсли;
			Возврат;
		КонецЕсли;
	КонецЕсли;

	ПечатьПакетаДокументовВозврат = (Объект.ВидОперации = ПредопределенноеЗначение("Перечисление.ВидыОперацийЧекККМ.Возврат")
	И ИспользоватьНастройкуРМК И НаборПравИНастроек.ПриВозвратеРаспечатыватьПакетДокументов);

	МассивСсылокЧеков = Новый Массив;

	Если ТабличноеПолеЧеков.Количество() > 1 Тогда

		ПараметрыОперации = Новый Структура();
		ПараметрыОперации.Вставить("ПечатьПакетаДокументовВозврат", ПечатьПакетаДокументовВозврат);
		ПараметрыОперации.Вставить("Отказ", Отказ);
		ПараметрыОперации.Вставить("Печать", Печать);
		ПараметрыОперации.Вставить("МассивСсылокЧеков", МассивСсылокЧеков); 
		ПараметрыОперации.Вставить("ПерваяОрганизация", Истина); 
		ПараметрыОперации.Вставить("ЧекККМСсылка", Неопределено);
		ПараметрыОперации.Вставить("ТабличноеПолеЧеков", ТабличноеПолеЧеков); 
		ПараметрыОперации.Вставить("КоличествоЧеков", ТабличноеПолеЧеков.Количество()); 
		ПараметрыОперации.Вставить("ТекущийЧек", 0); 

		ЭтотОбъект.Доступность = Ложь;
		ПробитьЧекККМСложныйСлучайЗавершение(Неопределено, ПараметрыОперации);

	Иначе
		// Простой случай
		ПараметрыОперации = Новый Структура();
		ПараметрыОперации.Вставить("ПечатьПакетаДокументовВозврат", ПечатьПакетаДокументовВозврат);
		ПараметрыОперации.Вставить("Отказ", Отказ);
		ПараметрыОперации.Вставить("Печать", Печать);
		ПараметрыИнформации = ОбщегоНазначенияРТКлиентСервер.ВыводимаяВРМКИнформация();

		ЧекККМСсылка = ЗаписатьЧекККМПоВсемДанным(ТабличноеПолеЧеков[0].Организация, ПараметрыОперации, ПараметрыИнформации);
		ТабличноеПолеЧеков[0].ЧекККМСсылка = ЧекККМСсылка;
		Если ПараметрыОперации.Отказ Тогда
			Отказ = ПараметрыОперации.Отказ;
			ОбщегоНазначенияРТКлиент.ОткрытьФормуИнформацииДляРМКУправляемой(ПараметрыИнформации);
			Если ДанныеОтправленыВБанк Тогда 
				ОбработатьОшибочноеПробитиеЧека();
			КонецЕсли;
			Возврат;
		КонецЕсли;

		СтатусЧекаККМ = ПредопределенноеЗначение("Перечисление.СтатусыЧековККМ.ПустаяСсылка");

		ПараметрыЗаполненияЧекаККМ = Новый Структура;

		ПараметрыОперации.Вставить("ЧекККМСсылка", ЧекККМСсылка);
		ПараметрыОперации.Вставить("МассивСсылокЧеков", МассивСсылокЧеков); 

		ЭтотОбъект.Доступность = Ложь;
		Оповещение = Новый ОписаниеОповещения("ПробитьЧекККМПростойСлучайЗавершение", ЭтотОбъект, ПараметрыОперации);
		ПробитьЧекККМ(Оповещение, ЧекККМСсылка, ТабличноеПолеЧеков[0].КассаККМ, ПараметрыЗаполненияЧекаККМ);

	КонецЕсли;

	Отказ = ПараметрыОперации.Отказ;
КонецПроцедуры
Показать
Прикрепленные файлы:
ЗапретПродажПриПробитииЧеки.cfe
yaguarrr; user932078; independ; +3 Ответить
15. DimchK 30.12.20 08:43 Сейчас в теме
А может быть начинать сканировать набираемый чек после 22:00?
Если чё не программист.
17. user932078 01.03.21 11:24 Сейчас в теме
(14) Хорошая обработка у Вас получилась, но после обновления на последние версии 1С Розница ПРОФ (2.3.7.19 - 2.3.7.22) не хочет работать. Можно ли доработать для последних версий 1С Розницы? Платформа стоит 8.3.16.1224
Прикрепленные файлы:
18. viplelik 32 02.03.21 12:01 Сейчас в теме
(17) Подправил. Проверьте эту.
Прикрепленные файлы:
ЗапретПродажПриПробитииЧека_1_1.cfe
user932078; +1 Ответить
19. user932078 22.03.21 09:59 Сейчас в теме
(18) Обработка работает, спасибо. Но есть небольшое "но" по сравнению с предыдущей версией обработки. В прошлой версии в режиме РМК при сканировании акцизной марки появлялось сообщение и марка не добавлялась в поле продажи, а в данной версии тоже появляется сообщение о запрете, но алкоголь добавляется в поле продажи (без цены и остатка). То есть у продавца остается возможность закрыть сообщение, подставить цену и пробить чек в запрещенное для продажи время (на практике уже было такое и приходило письмо из соответствующих органов). Продавцы часто не читают появляющиеся сообщения и просто их закрывают. Если есть возможность как то доработать, чтобы при сканировании в запрещенное время алкоголь вообще не добавлялся?
20. viplelik 32 22.03.21 14:19 Сейчас в теме
(19) предполагаю что патчи не все установлены.
Если без этого расширения, проверить добавление алкоголя во время запрета продаж, будет ли добавляться в список продаж (без цены и остатка)? Если да, то накатить патчи либо ждать их.
21. viplelik 32 22.03.21 15:38 Сейчас в теме
(19) протестировал. Да есть такая проблема, но она от разработчика. И кстати в любом случае продать её кассир не сможет. Не пропустит.

То есть у продавца остается возможность закрыть сообщение, подставить цену и пробить чек в запрещенное для продажи время (на практике уже было такое и приходило письмо из соответствующих органов).

Интересно как так получилось?

У меня не получилось продать.
22. user932078 23.03.21 11:20 Сейчас в теме
(21) Продажа была не сейчас, а в 2020 году, на какой то из версий 2.3.3.ХХ. Никаких расширений не было установлено. Была стандартная настройка запрета продажи по времени. Сейчас когда установил Ваше доработанное расширение и решил его проверить, то товар добавился в поле продажи и появилось окно запрета (так же было и без Вашего расширения). Вот я и подумал что оно работает как запрет в 1С. Если дальше не пропускает продажу, то это как раз то что нужно! Завтра проверю лично.
23. user932078 24.03.21 18:38 Сейчас в теме
(21) Проверил, запрет работает. Срабатывает при выборе оплаты. Большое спасибо, давно искал такую обработку.
24. Toooryyy 16.05.21 22:04 Сейчас в теме
Хорошая обработка!
Оставьте свое сообщение