Установка запрета продажи алкоголя в рознице

Публикация № 1349071

Учет и отчетность - Розничная торговля

Простой способ установки и снятия запрета на продажу алкогольной продукции.

В нашем регионе действует запрет на продажу алкогольной продукции с 22-00 до 08-00, но тем не менее несколько моих клиентов были привлечены к ответственности за продажу алкогольной продукции именно в это время. При этом использовалось ПО: 1С Розница, Фронтол xPOS, и был установлен запрет на продажу штатным способом - через механизм маркетинговых акций. Но тем не менее он не сработал. Причина проста, запрет работает только в момент добавления товара в чек, и в Фронтол xPOS - кроме этого, при переходе в режим оплаты. Продавец регистрирует товар, считывая штрихкод и акцизную марку до 22-00, но закрывает и пробивает чек позже. Суммы штрафов значительны, и сама ситуация очень неприятна для всех ее участников: владельца бизнеса, продавца и ит-специалиста.

Первоначально я планировал в 1С Рознице, используя механизм расширений, сделать доработку, которая в момент пробития чека проверяла бы наличие алкопродукции и отменяла закрытие. Но этот способ не подходит к базовой версии 1С Розницы и Фронтол xPos. 

Решение оказалось простым - это принудительная остановка служб УТМ до наступления времени запрета, например в 21:57 и запуск в 8:02. Я создал 2 скрипта, один останавливает службы, другой стартует и прописал задания в планировщик Windows.

Примеры скриптов для УТМ Windows, использовал VBS, чтобы для пользователей ПЭВМ, где установлены УТМ не выводилось консольных окон. Для УТМ Linux , я думаю сделать аналогичное решение будет несложно.

 
start_utm.vbs
 
 
stop_utm.vbs

Кроме этих скриптов прилагается bat-файл создания в планировщике Windows заданий по запуску этих скриптов

 
create_task_utm.bat 

Нюанс - запрет сработает только на алкоголь с акцизными марками, и второе при закрытии чека - у продавца на экране будет ошибка связи с  УТМ ЕГАИС. Но это лучше, чем быть оштрафованным, и потом пытаться доказать, что продажа была неумышленной.

Всем удачи, успехов в розничной торговле.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. coolseo 77 22.12.20 11:15 Сейчас в теме
Здравствуйте, да эта проблема стоит "остро".
Прилагаю свой вариант, который можно подключить через планировщик :

startutm.cmd:
NET START Transport

stoputm.cmd:
net stop Transport
Прикрепленные файлы:
startutm.cmd
stoputm.cmd
2. ivanov_alex 48 22.12.20 12:52 Сейчас в теме
УТМ имеет свойство запускаться сам по себе, так что остановка не вариант
Было бы умнее закрывать чек,но после закрытия смены формировать акт списания с марками, которые напикали за ночь
Есть ли чтото подобное для Розницы?
3. independ 1215 22.12.20 14:04 Сейчас в теме
(2) имеется в виду ночной режим работы розничного магазина? Мне кажется акт списания не очень подходящий документ для этой ситуации. Если установить признак реализация в данном акте, рано или поздно могут возникнуть вопросы, а почему не чек продажи. Это хорошо для общепита. Списывать с признаком: потери, порча и проч - возможно, но в разумных пределах.
5. ivanov_alex 48 22.12.20 14:14 Сейчас в теме
(3)Да, именно так
А вопросов как раз таки не будет, т.к. сам главный по егаис говорил на конференции что его удивляет, что в общепите алкоголь списывается чеками а не актами списания, то есть изначально так и планировалось
6. ivanov_alex 48 22.12.20 14:28 Сейчас в теме
(3)А для не общепита реализован механизм пробития чеков при закрытии смены
Но там есть несколько нюансов:
1. УТМ запущен,пикаем марки в РМК далее нажимаем пробить(нал или безнал)
вот как раз в этот момент розница не должна давать отправить чек в егаис, а должна просто провести его. Создается чек с признаком проведен и выбранной формой оплаты, без статуса отложен и пробит. В этом случае обработка закрытие смены сформирует список таких чеков с галками и достаточно нажать кнопку пробить и они улетают в егаис кучей,кассиру по сути надо нажать две кнопки чтобы закрыть смену а не одну, тут ничего страшного нет
2.если же отложить чек без выбора формы оплаты, то потом запутаешься где нал где безнал, записывать в тетрадку точно не вариант
4. viplelik 22 22.12.20 14:08 Сейчас в теме
Причина проста, запрет работает только в момент добавления товара в чек

и еще:
При выборе способа оплаты в 2.3.6.27 проверяется время запрета. (если время началось, не дает пробить чек)
Но если способ оплаты уже выбран время не проверяется.
7. tross 22.12.20 18:59 Сейчас в теме
Дмитрий, как вариант скрипты могут подойти, но бывает ошибка времени на компьютере пользователя. Нарывались на это при расхождении в 15 минут (продавец смотрит время по компу, а не по часам). При таки раскладах нужно выставлять обновление времени через интернет по интернету с интервалом в 30-60 минут, и соответственно устанавливать время в ККТ по системному времени компа с расхождением не более 1 минуты.
Это мое мнение.
8. independ 1215 22.12.20 19:37 Сейчас в теме
(7) если есть интернет, синхронизацию времени настроить можно, и также прописать ее в планировщике, использую утилитку cmdtime3.exe, уже не помню с каких времен, запуск скриптом vbs
Set WshShell = CreateObject("WScript.Shell")
WshShell.Run "cmdtime3.exe /q sync 0.pool.ntp.org /M:9999999", 0, false
16. Umka23 10 11.01.21 00:42 Сейчас в теме
(7)У ККТ время устанавливается только в состоянии "Смена закрыта"
9. ivanov_alex 48 23.12.20 07:10 Сейчас в теме
У вас не останавливается javaw
А это значит утм вскоре запустится, именно этот процесс стартует сначала апдейтер, потом транспорт
10. ivanov_alex 48 23.12.20 14:17 Сейчас в теме
Короче для Розницы
в процедуру Процедура ПечатьЧека_ПослеОткрытияЧека
вместо
Если ДополнительныеПараметры.ЕстьАлкогольнаяПродукцияЕГАИС Тогда
....
КонецЕсли

вставить код

Если ДополнительныеПараметры.ЕстьАлкогольнаяПродукцияЕГАИС Тогда
		ТекЧас = Час(ТекущаяДата());
		Если ТекЧас <8 и ТекЧас >= 23 Тогда
			ВыполнитьОбработкуОповещения(ПараметрыВыполнения.ОповещениеПродолжения, ПараметрыВыполнения);

//Лалалала, это ночь, детка.

иначе
	
		ПараметрыОперации = Новый Структура;
		ПараметрыОперации.Вставить("НомерСмены"   , НомерСмены);
		ПараметрыОперации.Вставить("НомерЧека"    , НомерЧека);
		ПараметрыОперации.Вставить("СерийныйНомер", ШапкаЧека.СерийныйНомер);
		
		ИнтеграцияЕГАИСКлиент.ПередатьНемедленно(
			ДополнительныеПараметры.ЧекККМСсылка,
			ПредопределенноеЗначение("Перечисление.ДальнейшиеДействияПоВзаимодействиюЕГАИС.ПередайтеДанные"),
			ПараметрыОперации,
			Новый ОписаниеОповещения("ПослеПередачиЧекаЕГАИС", ЭтотОбъект, ПараметрыВыполнения));
		 КонецЕсли; 
	Иначе
		ВыполнитьОбработкуОповещения(ПараметрыВыполнения.ОповещениеПродолжения, ПараметрыВыполнения);
	КонецЕсли;
Показать
independ; +1 Ответить
11. viplelik 22 23.12.20 20:41 Сейчас в теме
(10) Либо использовать время запрета маркетинговой акции
на примере 2.3.6.27 с контролем кода
&НаКлиенте
&ИзменениеИКонтроль("ПечатьЧека_ПослеОткрытияЧека")
Процедура ЗП_ПечатьЧека_ПослеОткрытияЧека(ПараметрыВыполнения, ДополнительныеПараметры)

	ШапкаЧека = ПараметрыВыполнения.ВходныеПараметры;

	НомерСмены = СтроковыеФункцииКлиентСервер.СтрокаВЧисло(ПараметрыВыполнения.НомерСмены);
	Если НомерСмены = 0 Тогда
		НомерСмены = 1;
	КонецЕсли;

	НомерЧека = СтроковыеФункцииКлиентСервер.СтрокаВЧисло(ПараметрыВыполнения.НомерЧека);
	Если НомерЧека = 0 Тогда
		НомерЧека = 1;
	КонецЕсли;

	ШапкаЧека.НомерСмены = НомерСмены;
	ШапкаЧека.НомерЧека = НомерЧека;

	Если ПараметрыВыполнения.Свойство("ЗаводскойНомерФН") И ЗначениеЗаполнено(ПараметрыВыполнения.ЗаводскойНомерФН) Тогда
		ШапкаЧека.СерийныйНомер = ПараметрыВыполнения.ЗаводскойНомерФН;
	КонецЕсли;

	Если ДополнительныеПараметры.ЕстьАлкогольнаяПродукцияЕГАИС Тогда
		
		#Вставка
		Если ПроверитьЗапрет() Тогда
			ТекстЗапретаПродаж = "Время продаж алкогольной продукции истекло";
			ОбщегоНазначенияРТКлиент.ВывестиИнформациюДляРМКУправляемой(НСтр("ru = 'Запрет продаж.'"), ТекстЗапретаПродаж);
		Иначе	
		#КонецВставки
			ПараметрыОперации = Новый Структура;
			ПараметрыОперации.Вставить("НомерСмены"   , НомерСмены);
			ПараметрыОперации.Вставить("НомерЧека"    , НомерЧека);
			ПараметрыОперации.Вставить("СерийныйНомер", ШапкаЧека.СерийныйНомер);
			
			ИнтеграцияЕГАИСКлиент.ПередатьНемедленно(
			ДополнительныеПараметры.ЧекККМСсылка,
			ПредопределенноеЗначение("Перечисление.ДальнейшиеДействияПоВзаимодействиюЕГАИС.ПередайтеДанные"),
			ПараметрыОперации,
			Новый ОписаниеОповещения("ПослеПередачиЧекаЕГАИС", ЭтотОбъект, ПараметрыВыполнения));
		#Вставка
		КонецЕсли;
		#КонецВставки
		
	Иначе
		ВыполнитьОбработкуОповещения(ПараметрыВыполнения.ОповещениеПродолжения, ПараметрыВыполнения);
	КонецЕсли;
КонецПроцедуры

&НаСервере
Функция ПроверитьЗапрет()
		СтрокаОшибки = "";
		ТекущаяДатаСеанса = ТекущаяДатаСеанса();
		Отказ = Ложь;
		СкидкиНаценкиСерверПереопределяемый.ПроверитьЗапретРозничнойПродажиТаблицыТоваров(Объект, "Товары", Отказ, СтрокаОшибки, ТекущаяДатаСеанса, Ложь);
		Возврат Отказ;
КонецФункции
Показать
Прикрепленные файлы:
ЗапретПродажЕГАИС.cfe
independ; ivanov_alex; +2 Ответить
12. ivanov_alex 48 24.12.20 06:20 Сейчас в теме
(11)это нужна маркетинговая акция или сформированный сегмент по алкашке
13. viplelik 22 24.12.20 12:26 Сейчас в теме
(12) маркетинговая акция с установленным сегментом номенклатуры и типом скидки - Запретить розничную продажу
14. viplelik 22 24.12.20 15:27 Сейчас в теме
(11) Решил переделать. Не нравиться мне в этом коде то что, проверка идет уже после создания чека и нет обработки возврата оплаты по карте.

Тут проверка идет до создания чека. И можно контролировать не только алкогольную продукцию я любую указанную в сегменте.
&НаСервере
Функция ПроверитьЗапрет()
		СтрокаОшибки = "";
		ТекущаяДатаСеанса = ТекущаяДатаСеанса();
		ЗапретУстановлен = Ложь;
		СкидкиНаценкиСерверПереопределяемый.ПроверитьЗапретРозничнойПродажиТаблицыТоваров(Объект, "Товары", ЗапретУстановлен, СтрокаОшибки, ТекущаяДатаСеанса, Ложь);
		Возврат ЗапретУстановлен;
КонецФункции

&НаКлиенте
&ИзменениеИКонтроль("СоздатьЧеки")
Процедура ЗП_СоздатьЧеки(Отказ, Печать)

	Перем Ответ;

	Ответ = "";

	#Вставка
	Если ПроверитьЗапрет() Тогда
		Отказ = Истина;
		ОбработатьОтказОтОплаты();
		ТекстЗапретаПродаж = "Время продаж указанной продукции истекло!";
		ОбщегоНазначенияРТКлиент.ВывестиИнформациюДляРМКУправляемой(НСтр("ru = 'Запрет продаж.'"), ТекстЗапретаПродаж);
		Если ДанныеОтправленыВБанк Тогда 
			ОбработатьОшибочноеПробитиеЧека();
		КонецЕсли;
		Возврат;
	КонецЕсли;
	#КонецВставки
	Если Объект.ВидОперации = ПредопределенноеЗначение("Перечисление.ВидыОперацийЧекККМ.Возврат") Тогда
		ПроверитьЧтоНетОплатыПодарочнымСертификатом("Оплата", Отказ, Ответ, Истина);
		Если Отказ Тогда
			ОбработатьОтказОтОплаты();
			ОбщегоНазначенияРТКлиент.ВывестиИнформациюДляРМКУправляемой(НСтр("ru = 'Ошибка возврат товара'"), Ответ);
			Возврат;
		КонецЕсли;
	Иначе
		ПроверитьДвиженияСерийныхНомеровДляПогашения(Отказ, Ответ, ОбщегоНазначенияКлиент.ДатаСеанса());
		Если Отказ Тогда
			ОбработатьОтказОтОплаты();
			ОбщегоНазначенияРТКлиент.ВывестиИнформациюДляРМКУправляемой(
			НСтр("ru = 'Ошибки погашения подарочных сертификатов'"), Ответ);
			Если ДанныеОтправленыВБанк Тогда 
				ОбработатьОшибочноеПробитиеЧека();
			КонецЕсли;
			Возврат;
		КонецЕсли;
	КонецЕсли;

	ПечатьПакетаДокументовВозврат = (Объект.ВидОперации = ПредопределенноеЗначение("Перечисление.ВидыОперацийЧекККМ.Возврат")
	И ИспользоватьНастройкуРМК И НаборПравИНастроек.ПриВозвратеРаспечатыватьПакетДокументов);

	МассивСсылокЧеков = Новый Массив;

	Если ТабличноеПолеЧеков.Количество() > 1 Тогда

		ПараметрыОперации = Новый Структура();
		ПараметрыОперации.Вставить("ПечатьПакетаДокументовВозврат", ПечатьПакетаДокументовВозврат);
		ПараметрыОперации.Вставить("Отказ", Отказ);
		ПараметрыОперации.Вставить("Печать", Печать);
		ПараметрыОперации.Вставить("МассивСсылокЧеков", МассивСсылокЧеков); 
		ПараметрыОперации.Вставить("ПерваяОрганизация", Истина); 
		ПараметрыОперации.Вставить("ЧекККМСсылка", Неопределено);
		ПараметрыОперации.Вставить("ТабличноеПолеЧеков", ТабличноеПолеЧеков); 
		ПараметрыОперации.Вставить("КоличествоЧеков", ТабличноеПолеЧеков.Количество()); 
		ПараметрыОперации.Вставить("ТекущийЧек", 0); 

		ЭтотОбъект.Доступность = Ложь;
		ПробитьЧекККМСложныйСлучайЗавершение(Неопределено, ПараметрыОперации);

	Иначе
		// Простой случай
		ПараметрыОперации = Новый Структура();
		ПараметрыОперации.Вставить("ПечатьПакетаДокументовВозврат", ПечатьПакетаДокументовВозврат);
		ПараметрыОперации.Вставить("Отказ", Отказ);
		ПараметрыОперации.Вставить("Печать", Печать);
		ПараметрыИнформации = ОбщегоНазначенияРТКлиентСервер.ВыводимаяВРМКИнформация();

		ЧекККМСсылка = ЗаписатьЧекККМПоВсемДанным(ТабличноеПолеЧеков[0].Организация, ПараметрыОперации, ПараметрыИнформации);
		ТабличноеПолеЧеков[0].ЧекККМСсылка = ЧекККМСсылка;
		Если ПараметрыОперации.Отказ Тогда
			Отказ = ПараметрыОперации.Отказ;
			ОбщегоНазначенияРТКлиент.ОткрытьФормуИнформацииДляРМКУправляемой(ПараметрыИнформации);
			Если ДанныеОтправленыВБанк Тогда 
				ОбработатьОшибочноеПробитиеЧека();
			КонецЕсли;
			Возврат;
		КонецЕсли;

		СтатусЧекаККМ = ПредопределенноеЗначение("Перечисление.СтатусыЧековККМ.ПустаяСсылка");

		ПараметрыЗаполненияЧекаККМ = Новый Структура;

		ПараметрыОперации.Вставить("ЧекККМСсылка", ЧекККМСсылка);
		ПараметрыОперации.Вставить("МассивСсылокЧеков", МассивСсылокЧеков); 

		ЭтотОбъект.Доступность = Ложь;
		Оповещение = Новый ОписаниеОповещения("ПробитьЧекККМПростойСлучайЗавершение", ЭтотОбъект, ПараметрыОперации);
		ПробитьЧекККМ(Оповещение, ЧекККМСсылка, ТабличноеПолеЧеков[0].КассаККМ, ПараметрыЗаполненияЧекаККМ);

	КонецЕсли;

	Отказ = ПараметрыОперации.Отказ;
КонецПроцедуры
Показать
Прикрепленные файлы:
ЗапретПродажПриПробитииЧеки.cfe
user932078; independ; +2 Ответить
15. DimchK 30.12.20 08:43 Сейчас в теме
А может быть начинать сканировать набираемый чек после 22:00?
Если чё не программист.
17. user932078 01.03.21 11:24 Сейчас в теме
(14) Хорошая обработка у Вас получилась, но после обновления на последние версии 1С Розница ПРОФ (2.3.7.19 - 2.3.7.22) не хочет работать. Можно ли доработать для последних версий 1С Розницы? Платформа стоит 8.3.16.1224
Прикрепленные файлы:
18. viplelik 22 02.03.21 12:01 Сейчас в теме
(17) Подправил. Проверьте эту.
Прикрепленные файлы:
ЗапретПродажПриПробитииЧека_1_1.cfe
user932078; +1 Ответить
19. user932078 22.03.21 09:59 Сейчас в теме
(18) Обработка работает, спасибо. Но есть небольшое "но" по сравнению с предыдущей версией обработки. В прошлой версии в режиме РМК при сканировании акцизной марки появлялось сообщение и марка не добавлялась в поле продажи, а в данной версии тоже появляется сообщение о запрете, но алкоголь добавляется в поле продажи (без цены и остатка). То есть у продавца остается возможность закрыть сообщение, подставить цену и пробить чек в запрещенное для продажи время (на практике уже было такое и приходило письмо из соответствующих органов). Продавцы часто не читают появляющиеся сообщения и просто их закрывают. Если есть возможность как то доработать, чтобы при сканировании в запрещенное время алкоголь вообще не добавлялся?
20. viplelik 22 22.03.21 14:19 Сейчас в теме
(19) предполагаю что патчи не все установлены.
Если без этого расширения, проверить добавление алкоголя во время запрета продаж, будет ли добавляться в список продаж (без цены и остатка)? Если да, то накатить патчи либо ждать их.
21. viplelik 22 22.03.21 15:38 Сейчас в теме
(19) протестировал. Да есть такая проблема, но она от разработчика. И кстати в любом случае продать её кассир не сможет. Не пропустит.

То есть у продавца остается возможность закрыть сообщение, подставить цену и пробить чек в запрещенное для продажи время (на практике уже было такое и приходило письмо из соответствующих органов).

Интересно как так получилось?

У меня не получилось продать.
22. user932078 23.03.21 11:20 Сейчас в теме
(21) Продажа была не сейчас, а в 2020 году, на какой то из версий 2.3.3.ХХ. Никаких расширений не было установлено. Была стандартная настройка запрета продажи по времени. Сейчас когда установил Ваше доработанное расширение и решил его проверить, то товар добавился в поле продажи и появилось окно запрета (так же было и без Вашего расширения). Вот я и подумал что оно работает как запрет в 1С. Если дальше не пропускает продажу, то это как раз то что нужно! Завтра проверю лично.
23. user932078 24.03.21 18:38 Сейчас в теме
(21) Проверил, запрет работает. Срабатывает при выборе оплаты. Большое спасибо, давно искал такую обработку.
Оставьте свое сообщение

См. также

Кубик-рубик для деклараций 11 и 12 по данным 1С.Розница, ЕГАИС и других программ и источников. (Сбор/разбор деклараций на части и их анализ) Промо

Регламентированная отчетность Бухгалтерский учет Розничная торговля Розничная торговля v8::ОУ Розница Россия БУ УУ Бесплатно (free)

Рассмотрены самые сложные ситуации(даже когда все данные утеряны). Алкогольные декларации 11 и 12 по данным 1С.Розница и других программ и источников.(Сбор/разбор деклараций на части и их анализ). "Приготовление" деклараций с учетом заданных/требующихся входных/выходных параметров. Рассматриваем самые сложные(изначально кажущиеся безвыходными) ситуации. Подходит тем, кто окончательно запутался в связи с введением ЕГАИСа в розничное звено.

09.12.2016    22774    liginrambler    7    

УТМ 4.x на Атол-HUB20

Розничная торговля ККМ Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бесплатно (free)

В январе 2021 года компания АТОЛ прекратила развитие проекта «HUB-УТМ». На сайте появилась прошивка для Атол-Hub20 с возможностью установки УТМ 4.x , но УТМ не стартует. Дело, похоже, в том, что в пакете УТМ драйверы Рутокена и Java предназначены для 32х битной системы, а сборка Armbian 64х битная. Запускаем УТМ4 путем подмены бинарников и библиотек Java и библиотеки PKCS#11.

06.04.2021    362    Drowsy    5    

Бонусная система. Разработка, внедрение

Управление взаимоотношениями с клиентами (СRM) Розничная торговля v8 УТ10 УУ Бесплатно (free)

Задача: необходимо запрограммировать механизм начисления бонусов не в день покупки товаров, а только по истечении 14 дней.

02.04.2021    493    Rustig    18    

Отчет по чекам в 1С

Кассовые операции Розничная торговля v8 1cv8.cf Россия УУ Бесплатно (free)

Отчет по чекам в 1С нужен для вывода информации по чекам и представлен в типовых конфигурациях 1С в разрезе Магазина, Кассы ККМ, Кассира, с отборами по Периоду построения, магазину, онлайн кассе ККМ и кассиру.

01.04.2021    367    Koder_Line    0    

Автоматизация магазина на Oracle Apex. Обзор аналога 1С Промо

Интеграция Розничная торговля Розничная торговля Бесплатно (free)

Как известно 1С - лидер в автоматизации учета в постсоветском пространстве. Есть ли достойные альтернативы (не дорогие, с возможностью конфигурирования, простые) ? Однозначно да ! Предлагаю Вашему вниманию обзор "буржуйской" технологии Oracle Apex

17.05.2013    60589    avhrst    295    

Продажи без дублей по маркам. Сведение остатков в магазинах с остатками в ЕГАИС. Декларации по Форме 11 и Форме 12 по данным 1С.Розница 2.2 и др. программ и источников. Промо

Бухгалтерский учет Розничная торговля Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия БУ УУ Бесплатно (free)

Для выбора интересующего пункта используйте нажатие кнопок меню(внизу публикации) 1) Сводим остатки алкоголя в ЕГАИС без остановки продаж в магазинах. 2) Включаем онлайн-контроль дублей марок при продажах. 3) Алкогольные декларации по Форме 11 и Форме 12 по данным 1С.Розница 2.2 и других программ и источников.(Сбор/разбор деклараций на части и их анализ). "Приготовление" деклараций с учетом заданных/требующихся входных/выходных параметров. Рассматриваем самые сложные ситуации. Подходит тем кто окончательно запутался в связи с введением ЕГАИСа в розничное звено.

18.11.2016    33272    liginrambler    12    

Маркировка лекарственных препаратов. Часть вторая "Регистраторы выбытия"

Розничная торговля v8 1cv8.cf Фармацевтика, аптеки Россия УУ Бесплатно (free)

Данная статья является второй статьей в цикле, посвященном маркировке лекарственных препаратов. В данной статья я постараюсь поделиться собственным опытом работы с РВ, описанием работы с АПИ (для разработчиков), интересные моменты выявленные в ходе эксплуатации и уделить часть статьи пользователям, а именно ошибочным ситуациям и что с ними делать.

02.11.2020    5344    IssakN    38    

Модуль логиста: как обычная доработка стала тиражным решением

Управление взаимоотношениями с клиентами (СRM) Монитор заказов Розничная торговля Управление услугами и сервисом v8::ОУ 1cv8.cf УУ Бесплатно (free)

Путь развития продукта, который из доработки для устранения проблем одного клиента превратился в полноценное тиражное решение, успешно справляющиеся со всеми актуальными задачами служб доставки.

18.08.2020    2380    RAU IT    2    

Загрузка данных из Algoritm-S в конфигурацию "Бухгалтерия предприятия 3.0 (3.0.79.21) "

Розничная торговля Внешние источники данных v8 БП3.0 Розничная и сетевая торговля (FMCG) Фармацевтика, аптеки Россия Бесплатно (free)

В статье представлен шаблон обработки для загрузки некоторых данных из программы Algoritm-S в конфигурацию "Бухгалтерия предприятия 3.0 (3.0.79.21)

04.08.2020    1455    RPGrigorev    0    

Страсти по эквайрингу. Раздельный учёт УСН + ЕНВД (1С:Розница)

Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) НУ ЕНВД УСН Бесплатно (free)

- Зачем статья? - Больше для себя, чтобы не забыть, как всё это делала. Долго искала. Есть по частям. Если кому-то будет полезна – хорошо. - О чём же? - Как учесть поступления на расчетный счет от торгового эквайринга при розничных продажах в АТТ при совмещении налоговых режимов (УСН+ЕНВД, схема с УСН+патент будет такая же) в 1С: Предприятие 3.0.

15.07.2020    3896    MARIYA156    20    

Если ККМ Атол + 1С Розница тормозит при печати чеков по сети, или экономим на покупке ККТ и ФР

Розничная торговля Адаптация типовых решений ККМ v8 Розница УТ11 Россия Бесплатно (free)

Очень медленная работа с ККТ по Tcp/ip или Как заставить две клиентских Розницы 1С печатать чеки на одной кассе ККТ онлайн Предыстория и чем все закончилось.

01.07.2020    4700    lepihin    10    

Маркировка лекарственных препаратов. Часть первая "Быстрая интеграция"

Интеграция Розничная торговля v8 1cv8.cf Фармацевтика, аптеки Россия УУ Бесплатно (free)

Данный цикл будет посвящен маркировке лекарственных препаратов (далее ЛП), нюансам работы с "1С: Библиотека интеграции с МДЛП", доступной для скачивания на сайте ИТС, методиками работы с регистраторами выбытия, и проблемам, с которыми пришлось столкнуться при интеграции. Эта статья будет представлять из себя краткую инструкцию, что делать, когда маркировка уже близко и необходимо быстро внедрить ее. Надеюсь, она станет подспорьем в данной задаче. Будут приведены рекомендации, как в короткие сроки с минимально необходимой функциональностью и минимумом чтения документации произвести интеграцию библиотеки МДЛП и выполнить начальные настройки. Также будут даны рекомендации по быстрым, но важным, на мой взгляд, доработкам.

23.06.2020    7469    IssakN    32    

Интеркампани в УТ 3.0 для Украины Промо

Комиссионная торговля Оптовая торговля Розничная торговля Бухгалтерский учет Комиссионная торговля Оптовая торговля Розничная торговля v8 УТ10 Украина УУ Бесплатно (free)

Вот, вот уже скоро выйдет долгожданная конфигурация «Управление торговлей для Украины» третьей редакции. Одной из фишек, которую ждут пользователи версии 2.3, является интеркампани, которую и будем обсуждать в нижележащей статье. Господа, кому интересно - прошу под кат.

31.01.2013    25048    akomar    10    

Как разрешить продажу по нулевой цене, или 100%-ная скидка. Простые примеры (КА 2.4, а также ERP 2.2 и УТ 11.4)

Практика программирования Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 ERP2 УТ11 КА2 Россия УУ Бесплатно (free)

Акции, бонусы, подарки, бесплатные буклеты... Это ограничено 1С и НК, но это очень хочется иметь в управленческой базе. При этом не хочется снимать программу с поддержки. Легко.

06.05.2020    5589    ne_en    18    

Видеоаналитика в магазинах. Маркетинговый тренд или необходимость в новом цифровом мире?

Розничная торговля Розничная и сетевая торговля (FMCG) УУ Бесплатно (free)

Видеоаналитика – это интеллектуальный анализ видеопотока с камер при помощи методов компьютерного зрения. Как применять систему видеоаналитики для повышения эффективности торгового предприятия, в своем докладе на конференции Infostart Event 2019 Inception рассказал директор по развитию CVizi Алексей Осипов.

20.04.2020    3890    osipov_cvizi    3    

Сложное ранжирование клиентов по классам Промо

Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля Управленческие Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля v8 УТ10 Россия УУ Бесплатно (free)

Пример реализации усложненной ABC-классификации клиентов. Данная статья написана для конфигурации "1С: Управление торговлей, ред. 10.3", но, я думаю, предложенный метод подойдет и для других конфигураций, имеющих механизм ABC-классификации.

28.03.2012    23782    charushkin    9    

Переход на поштучный учет алкогольной продукции, оклеенной старыми марками. Почему необходима одноразовая постановка старых марок на баланс в пределах одной Справки А?

Оптовая торговля Розничная торговля Рестораны, кафе и фаст-фуд Пищевая промышленность Россия БУ УУ Акцизы Бесплатно (free)

В целях полного перехода на поштучный учет алкогольной продукции в ЕГАИС, Росалкогольрегулирование сообщает, что с 01.07.2020 учет оборота всей маркируемой алкогольной продукции будет возможен только в поштучном режиме. Какие проблемы ожидают программистов и пользователей, если выполнять операцию регистрации старых марок частями?

16.04.2020    4684    EvgeTrofi    19    

Программирование в Штрих-М Кассир 5

Практика программирования Розничная торговля v8 1cv8.cf Бесплатно (free)

Методы и свойства для программирования в Штрих-М Кассир 5.

13.03.2020    3935    Ignatov_mu    2    

Маркировка товаров. Что важно знать?

Оптовая торговля Розничная торговля Россия Бесплатно (free)

В последнее время всё большее внимание уделяется вопросу организации маркировки товаров. Связано это преимущественно с тем, что всё большее количество товаров требует наличие обязательной маркировки. В этой публикации мы обсудим вопрос обязательной маркировки, грядущие изменения в этом вопросе со стороны законодательства и технологии, которые используются сегодня.

26.02.2020    3895    VachKirp    4    

Как продавать маркируемый товар (обувь) из 1С:Розница + сканер для маркировки

Розничная торговля Сканер штрих-кода v8 Розница Розничная и сетевая торговля (FMCG) Россия Бесплатно (free)

Маркировка обуви в нашей стране началась с 1 июля 2019 года. Но если в 2019м году от участников рынка требовалось только зарегистрироваться в системе «Честный знак», то теперь уже совсем не за горами дата, когда необходимо будет в обязательном порядке передавать данные о проданных единицах обуви. По графику этот судный день назначен на 1 марта 2020 года. Как все знают, русский человек всегда надеется на лучшее (или на авось, кому как нравится), надеется что правительство передумает. Сейчас в сети ходит информация о возможных сроках переноса судного дня на 1 июля, или, даже, 1 сентября 2020 года, это лишь отсрочки, но никак не отмена обязательной маркировки. В дополнении ко всему вышесказанному надо отметить, что самая популярная программа для розничной торговли, а именно 1С:Розница, как и ее пользователи не смогла заранее подготовиться к нововведениям. Обновление, в котором система стала работать более-менее корректно, вышло лишь 6 февраля 2020 года (менее чем за месяц до судного дня)

22.02.2020    6267    VCPro    10    

Маркировка обуви и других нетабачных и немолочных категорий товаров. Без паники

Оптовая торговля Розничная торговля Россия УУ Бесплатно (free)

Тезисно. Для тех, кто с этим связан. Разбираемся вместе. Добавлен раздел для разработчика

08.02.2020    45913    Rustig    142    

Про маркировку обуви БЕЗ подробностей и чётких инструкций для небольшого розничного магазина - мнение НЕ эксперта :-)

Розничная торговля Розничная и сетевая торговля (FMCG) Россия Бесплатно (free)

Наша организация импортёр обуви, клиенты есть разные и крупные типа wildberries и небольшие розничные магазины ИП на пару сотрудников. Вот для небольших розничных магазинов я и написал эту статью, при этом у нас всё сделано "по серьёзному", а пишу я про то, чем ни разу не пользовался :-)

28.01.2020    8549    Mx00    58    

Одна ККТ для розничного магазина и Интернет-сайта

Розничная торговля ККМ v8 Россия Бесплатно (free)

Опыт использования одной онлайн-кассы для приема платежей в розничном магазине и на Интернет-сайте: технические подробности.

23.01.2020    7732    sivin-alexey    15    

Создание номенклатуры в 1С: Розница 8. Ювелирный магазин

Пользователю системы Бухгалтерский учет Розничная торговля Розничная торговля v8 Розница Ювелирная промышленность и торговля Россия УУ Бесплатно (free)

Создание номенклатуры в Розница 8. Ювелирный магазин, редакция 2.2 (2.2.13.11) с использованием правил именования номенклатуры.

02.09.2019    8928    StAn1988    0    

ЕГАИС от А до Я

Пользователю системы Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля Россия БУ Акцизы Бесплатно (free)

Данная статья описывает не очевидное и не документированное поведение ЕГАИС. То, чего нет в документации по УТМ.

28.08.2019    31761    goleaff2006    19    

Решение проблем с сетевым ключом защиты для Штрих-М: Торговое предприятие 5

Администрирование данных 1С Розничная торговля Розничная торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Россия УУ Бесплатно (free)

Штрих-М: Торговое предприятие 5 имеет свой ключ защиты, который проверяет сразу после запуска базы. Если вы увидели сообщение "ключ не найден", материал в этой статье может помочь решить вашу проблему.

21.08.2019    9969    Van2507    7    

Вывод отчетов из Штрих-М Торговое предприятие 5 на кассовое ПО Кассир 5 через веб-сервис

Розничная торговля WEB Розничная торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Россия УУ Бесплатно (free)

Универсальный механизм вывода отчетов товароучетной системы Штрих-М Торговое предприятие в кассовое ПО Кассир 5 посредством веб-сервиса.

14.08.2019    7052    Van2507    1    

Маркировка табака. Формирование тега 1162 "код товара" для передачи в ККТ и ОФД

Практика программирования Розничная торговля Розничная торговля Разработка v8 1cv8.cf Розничная и сетевая торговля (FMCG) Россия Бесплатно (free)

С 01.07.2019 стартует новый этап маркировки сигарет. Теперь в кассе обязательно надо будет считывать марку с пачек табака, если она там есть. Считывать и передавать в ОФД через тег 1162 в онлайн-кассе. А как сформировать данные этого тега? Не все так просто...

27.06.2019    16212    kirlog    59    

Система питания в офисе: как совместить вендинговые автоматы, 1С, облачную кассу и веб-технологии

Интеграция Розничная торговля Розничная торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Россия УУ Бесплатно (free)

В начале 2019 года тенденция развития автоматов питания в России привела к появлению проекта нового формата питания на работе — МикроМаркета “Го!Поедим”. Потребовалось создать новый формат зоны питания сотрудников: интегрировать в офисные кухни полноценные МикроМаркеты с бесконтактной оплатой, кофе-машинами, лаунж-зоной. Если правильно совместить вендинговые автоматы, облачную кассу, 1С и веб-технологии, то в результате будут не только сытые сотрудники, но и корректная работа всей системы офисного питания.

22.06.2019    7070    antonovintervolga    6    

1С и компьютерное зрение: новый подход к контролю за ассортиментом магазина

Розничная торговля Внешние источники данных Розничная торговля v8 1С:Франчайзи, автоматизация бизнеса УУ Бесплатно (free)

Машинное зрение в магазинах и 1С. Как поднять эффективность торгового предприятия (магазин. кафе, шоурум и т.д.) с совершенно неожиданной стороны? Как получить реальные демографические данные покупателей и, самое главное, как это использовать в повседневной работе магазина? Как можно расширить привычные ABC и XYZ анализ, добавив в них пласт данных о трафике и демографии покупателей? Что необходимо для 1С, чтобы использовать данные видеоанализа людского трафика?

20.06.2019    9382    osipov_cvizi    16    

Сжатие данных в мобильном приложении 1С:Предприятие

Мобильная разработка Розничная торговля Розничная торговля v8 v8::Mobile 1cv8.cf УУ Бесплатно (free)

Эту небольшую статью я планировал опубликовать у себя на сайте, чтобы такие любители мобильного приложения от 1С:Предприятие, как я, могли использовать её без дополнительно потраченных двух дней на поиски вариантов написания алгоритма. Во-первых, хотел сказать, что я небольшой разработчик, который начинал делать свои первые шаги ещё на заре правления "Семерки". Новая платформа версии 8 была как глоток свежего воздуха - бодрящий и легко воспринимаемый организмом. Я был очень удивлен, да что сказать, до сих пор удивляюсь как элементарные вещи можно делать на 1С, и как это стремно делается на других языках программирования. Во-вторых, обилие разнообразных интерпретаций платформы позволяет развернуться на все 360 градусов, захватив своими проектами, наверное, любые ветки бизнеса. Так вот, о небольшом нюансе работы с новой мобильной платформой я и хотел рассказать... Сам додумался, так сказать.

27.05.2019    14285    yarsort    27    

Рассрочка в Рознице 2.2

Практика программирования Розничная торговля Розничная торговля Разработка v8 Розница УУ Бесплатно (free)

Добавляем Рассрочку в документ "Отчет о розничных продажах" в конфигурации "Розница для Беларуси, редакция 2.2."

15.04.2019    4662    borlog    0    

Редактирование документа "Поступление товара" на поступление алкогольной продукции в 1С: Розница ЕГАИС

Обработка документов Розничная торговля Пользователю системы Розничная торговля v8::ОУ Розница Розничная и сетевая торговля (FMCG) Россия Бесплатно (free)

Редактирование табличной части документа "Поступление товара", введенного на основании товарно-транспортной накладной ЕГАИС с использованием групповой обработки реквизитов.

05.04.2019    6595    PitMal    2    

Оформление простых розничных продаж и возвратов в УТ 10.3.50.2 и некоторые особенности этого процесса

Бухгалтерский учет Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Россия УУ Бесплатно (free)

В данной короткой статье я хотел осветить наиболее простые случаи оформления розничных продаж и последующих возможных возвратов товаров в 1С УТ 10.3.50.2 с использованием фискального регистратора от фирмы Штрих М. Без сомнения тема является более глубокой т.к. есть ещё оптовые продажи, продажи в кредит, авансы. Рад буду если кто то дополнит моё повествование. Нацелено оно на старших и рядовых кассиров. Небольших торговых предприятий занимающихся розничной торговлей. Хотел бы что бы данная статья была со временем дополнена всеми нюансами оформления продаж и освещением использования всего набора инструментов онлайн касс, ОФД и ИФНС в современной торговле.

03.04.2019    13274    Umka23    9    

AltLinux + ККТ Атол 30Ф (55Ф) + сканер штрих-кода

Администрирование данных 1С ККМ Сканер штрих-кода Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 Розница Россия Бесплатно (free)

Описание опыта настройки контура AltLinux + платформа 1С 8.3 + Розница 2.2 базовая + сканер штрих-кода + ККТ 30Ф (55Ф).

14.02.2019    6723    Ceboo    4    

Расширение конструктора мобильного рабочего места для варианта "клиент 1С+RDP" (для любых wi-fi терминалов). Экосистема решений Simple WMS

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Универсальные функции Мобильная разработка Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8::УФ УУ Бесплатно (free)

Развитие проекта «Конструктор мобильного клиента на Android» https://infostart.ru/public/976636/ для устройств не на Андроиде (работающих в режиме RDP). В отличие от варианта Android работа на терминалах происходит в режиме 1С:Предприятие через RDP а конфигурации мобильных клиентов полностью совместимы для обоих версий. Т.е. конфигурация единая, создается один раз и ее может читать как Android -устройство, так и 1С-клиент на RDP без необходимости какой либо переделки.

05.02.2019    13667    informa1555    10    

Весы Штрих-СЛИМ, Штрих-ПРИНТ и 1С: Розница 2.2.11.ХХ

Весы Розничная торговля Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия Бесплатно (free)

Как установить драйвер весов по протоколу POS2 или драйвер ШТРИХ-М:Весы с печатью этикеток ШТРИХ-ПРИНТ на Windows 7 и выше.

29.01.2019    16975    Newdjeen    13