Сжатие фотографий физических лиц в ЗУП 3.1

06.09.22

Задачи пользователя - Адаптация типовых решений

Сжатие фотографий физических лиц при загрузке, плюс обработка уже загруженных фото.

С покупкой нового фотоаппарата отделу кадров, неожиданно начала разрастаться база ЗУП. Пришлось сделать небольшую доработку для сжатия загружаемых фотографий физических лиц.

В расширение добавить общий модуль "КадровыйУчетРасширенный"

Код модуля расширения:

&ИзменениеИКонтроль("ЗаписатьФотографию")
Процедура КОРВ_ЗаписатьФотографию(ФизическоеЛицо, АдресФотографии)

    МенеджерЗаписи = РегистрыСведений.ФотографииФизическихЛиц.СоздатьМенеджерЗаписи();
    МенеджерЗаписи.ФизическоеЛицо = ФизическоеЛицо;

    Если Не ЗначениеЗаполнено(АдресФотографии) Тогда
        МенеджерЗаписи.Удалить();
        Возврат;
    КонецЕсли;

    #Удаление
    МенеджерЗаписи.Фотография = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(АдресФотографии));
    #КонецУдаления
    #Вставка
    Карт = Новый Картинка(ПолучитьИзВременногоХранилища(АдресФотографии)); 
    
    СжатаяФотография = Новый ОбрабатываемаяКартинка(Карт);
    
    //Параметры обработки фотографии
    СжатаяФотография.УстановитьФормат(ФорматКартинки.JPEG);
    СжатаяФотография.УстановитьГлубинуЦвета(ГлубинаЦвета.БитНаПиксел24);
    СжатаяФотография.УстановитьРазмер(600, 800);
    СжатаяФотография.УстановитьПлотность(600);
 
    МенеджерЗаписи.Фотография = Новый ХранилищеЗначения(СжатаяФотография.ПолучитьКартинку().ПолучитьДвоичныеДанные());
    #КонецВставки
    МенеджерЗаписи.Записать(); 

КонецПроцедуры

 

Также прилагаю код внешней обработки для сжатия всех фотографий физ. лиц.

Запрос = Новый Запрос;
Запрос.Текст = 
	"ВЫБРАТЬ
	|	ФотографииФизическихЛиц.ФизическоеЛицо КАК ФизическоеЛицо,
	|	ФотографииФизическихЛиц.Фотография КАК Фотография
	|ИЗ
	|	РегистрСведений.ФотографииФизическихЛиц КАК ФотографииФизическихЛиц";
	РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл 

	Карт = Новый Картинка(ВыборкаДетальныеЗаписи.Фотография.Получить()); 
	
	СжатаяФотография = Новый ОбрабатываемаяКартинка(Карт);
	
	СжатаяФотография.УстановитьФормат(ФорматКартинки.JPEG);
	СжатаяФотография.УстановитьГлубинуЦвета(ГлубинаЦвета.БитНаПиксел24);
	СжатаяФотография.УстановитьРазмер(600, 800);
	СжатаяФотография.УстановитьПлотность(600);
	
	СжатаяКартинка = СжатаяФотография.ПолучитьКартинку();		
	
	МенеджерЗаписи = РегистрыСведений.ФотографииФизическихЛиц.СоздатьМенеджерЗаписи(); 
	
	МенеджерЗаписи.ФизическоеЛицо = ВыборкаДетальныеЗаписи.ФизическоеЛицо; 
	МенеджерЗаписи.Фотография     = Новый ХранилищеЗначения(СжатаяКартинка.ПолучитьДвоичныеДанные()); 
	
	МенеджерЗаписи.Записать(Истина); 
	
КонецЦикла;

 

Протестировано в ЗУП 3.1.23.63, 1С:Предприятие 8.3 (8.3.20.1674).

Фотография изображение сжатие размер фото картинка

См. также

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    5116    11    5    

20

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3496    8    0    

26

Адаптация типовых решений Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4699    dimanich70    15    

20

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    3441    dimanich70    8    

15

Адаптация типовых решений Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2737    21    avmartynov    14    

53

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2821    43    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. RustIG 1719 06.09.22 16:31 Сейчас в теме
(0) а что за объект Новый ОбрабатываемаяКартинка() ?
в какой версии платформы он появился?
2. dmpas 418 06.09.22 17:12 Сейчас в теме
(1) Синтаксис-Помощник говорит:
Использование в версии:
Доступен, начиная с версии 8.3.14.


Хотя я тоже раньше не встречал, не доводилось.
3. RustIG 1719 06.09.22 20:13 Сейчас в теме
(2) в типовых конфигурациях нет подобного функционала, на Инфостарт в явном виде вроде впервые об этом написано.
стал искать упоминание "в неявном виде" и вот результат:
1) Статья про СКД вариант сентябрь 2019 года
2) форум - читаю редко - март 2021 года
3) Статья - прошла незамеченной в сообществе - хотя тема как раз про новый объект платформы - https://infostart.ru/public/1501195/
4) Комментарий к статье - сентябрь 2021 года
4. dmpas 418 06.09.22 21:55 Сейчас в теме
(3)
ОбрабатываемаяКартинка


тем не менее функционал с 14 платформы. И судя по статье работает, а мы тут всё ImageMagick таскаем.

https://its.1c.ru/db/v8314doc#bookmark:dev:TI000002118
5. efin 06.09.22 22:01 Сейчас в теме
(4) да, давно уже используем. Ждем подобный элемент формы, поскольку ту же обрезку crop интерактивно в веб-клиенте выполнять нечем. Старый глючный способ на js в последних платформах не работает.
Оставьте свое сообщение