Решение проблемы с временем 23:59:59 в последний день месяца при неоперативном проведении документов в 1С

31.05.24

Задачи пользователя - Адаптация типовых решений

В статье представлена простейшая процедура, позволяющая решить проблемы, возникающие при неоперативном проведении документов в 1С для определенных типов, когда время проведения устанавливается на 23:59:59 в последний день месяца и мешает закрытию месяца. Узнайте, как настроить собственное время проведения для более точного и корректного учета.

Наверное, многие сталкиваются с тем, что после окончания отчетного периода бухгалтеры создают документы, часто датированные последним днем месяца. Время в этих документах автоматически устанавливается системой и может быть 23:59:59. В последний день периода множество документов оказывается с временем 23:59:59, что приводит к накладкам.

Регламентные документы должны идти в конце дня, а влияющие на них — предшествовать им. Нарушение этого порядка, например, если документ реализации по ставке 0% идет после "Подтверждения нулевой ставки НДС", приводит к тому, что часть входного НДС не принимается к зачету.

После неоднократного ручного изменения времени в документах было решено автоматизировать этот процесс. Теперь, при определенных условиях, документы будут автоматически проводиться в 23:00:00. Однако, вы можете настроить любое удобное для вас время проведения.

Для этого нам понадобиться сделать несколько простых действий, а именно :

1. В ДополнительныйМодуль добавляем процедуру (название процедуры можете сделать свое)

Процедура ОграничиваемВремяНеоперативногоПроведенияДокумента23часами(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
	
	Если РежимЗаписи = РежимЗаписиДокумента.Проведение И РежимПроведения = РежимПроведенияДокумента.Неоперативный Тогда
		Если Источник.Дата = КонецМесяца(Источник.Дата) Тогда
            Источник.Дата = Источник.Дата - ((60 * 60) - 1);
		КонецЕсли;
	КонецЕсли;	
	
КонецПроцедуры

2. В конфигураторе 1С в раздел "Подписки на события" создайте новое событие с названием "НеоперативноеВремя23ДляДокументов", выбрав название, которое понятно отражает его цель.



 

3. Настраиваем событие под наши документы, используя составной тип в свойствах источника. При записи этих документов будет автоматически применяться нужное время.




4. В свойствах где "Событие" выбираем "ПередЗаписью". В этом случае наша процедура будет выполняться при записи выбранных типов документов.

5. В обработчик указываем нашу процедуру в дополнительном модуле - ДополнительныйМодуль.ОграничиваемВремяНеоперативногоПроведенияДокумента23часами



 

На этом все, теперь при записи нужных типов документов у нас будет срабатывать событие, которое проверяет, что документ проводится в последний день месяца, неоперативно, и в нем установлено системой время 23:59:59, которое автоматически будет изменено на 23:00:00.

Надеюсь, эта статья поможет кому-то избежать неудобств, связанных с необходимостью ручной коррекции времени документов каждый месяц, что может причинять беспокойство бухгалтерам.

23:59:59 последний день месяца отчетность закрытие месяца время проведение документов

См. также

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4974    11    5    

20

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3348    6    0    

24

Каждому менеджеру нужен свой Excel

Адаптация типовых решений Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4536    dimanich70    15    

20

Создать на основании - своя кнопка (БСП). Проблема двух подменю Создать на основании

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2844    dimanich70    8    

15

Доработка отчета "Связанные документы" (структура подчиненности) для вывода объектов из любого расширения

Адаптация типовых решений Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2387    20    avmartynov    14    

44

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2626    40    progmaster    8    

4
Оставьте свое сообщение