Добавление команд печати в свои документы в Бухгалтерии 3.0

Публикация № 237013 02.12.13

Приемы и методы разработки - Работа с интерфейсом

Данная публикация может быть вам полезна, если вы хотите сделать своим нетиповым документам в Бухгалтерии 3.0 универсализированную печать (не затрагивая типовые объекты). Эта статья подойдет для любой конфигурации на основе БСП, так как использует возможности ее подсистемы "Печать"

В Бухгалтерии 2.0 была очень удобная типовая процедура

УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер,
					  Заголовок, НепосредственнаяПечать, Ссылка, ИмяМакета) 

Она помогала вывести ваш печатный документ в универсальное окно печати, где вы выбирали количество копий, вариант сохранения и тому подобное

Сейчас, переходя с 2.0 на 3.0, я стал искать аналог этой процедуры и не нашел. Но это к лучшему, потому что я нашел еще более универсальный механизм. Он опирается на механизмы подсистемы "Печать" БСП (БСП - это основа всех современных конфигураций фирмы 1С). Нужно добавить несколько функций в два модуля: Модуль менеджера и Модуль формы. Пусть у нас есть нетиповой документ Приказ, и у него есть два макета и две формы. 

Для каждого из двух макетов у нас подготовлены функции СформироватьАкт(Ссылка) и СформироватьПриказ(Ссылка), возвращающие табличные документы, которые нам нужно будет красиво выводить на печать. Хочется, не прилагая больших усилий, добиться следующего результата: чтобы в каждой из двух форм этого документа в командной панели была кнопка-подменю Печать, в которой был бы список из наших печатных форм.

     

Откроем форму ФормаДокумента, и создадим обработчик ПриСозданииНаСервере. Скопируем в модуль формы следующий код:

&НаСервере 
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
		
	УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма)	
	
КонецПроцедуры 

&НаКлиенте 
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
	
	УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект)
	
КонецПроцедуры  

 

Теперь откроем Модуль менеджера и скопируем туда следующий код:

Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт 

	КомандаПечати = КомандыПечати.Добавить();
	КомандаПечати.Идентификатор = "Акт";
	КомандаПечати.Представление = "Дополнительный акт";
	КомандаПечати.Обработчик    = "УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати";
	КомандаПечати.СписокФорм    = "ФормаСписка,ФормаДокумента";
	
	КомандаПечати = КомандыПечати.Добавить();
	КомандаПечати.Идентификатор = "Приказ";
	КомандаПечати.Представление = "Приказ";
	КомандаПечати.Обработчик    = "УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати";
	КомандаПечати.СписокФорм    = "ФормаСписка,ФормаДокумента";
	
КонецПроцедуры 

Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт 	
	
	ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "Акт") Тогда
 		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "Акт", "Акт", 
			СформироватьНесколькоАктов(МассивОбъектов),"Документ.Приказ.Акт");
	КонецЕсли;
	
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "Приказ") Тогда
 		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "Приказ", "Приказ", 
			СформироватьНесколькоПриказов(МассивОбъектов),"Документ.Приказ.Приказ");
	КонецЕсли;
	
КонецПроцедуры 

Функция   СформироватьНесколькоАктов(МассивОбъектов)
	
	ТабДокумент = Новый ТабличныйДокумент;
	Для каждого Ссылка из МассивОбъектов Цикл
		ТабДокументОбъекта = СформироватьАкт(Ссылка); 
		Если ТабДокумент.ВысотаТаблицы > 0 И ТабДокументОбъекта.ВысотаТаблицы > 0 Тогда 
			ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц()
		КонецЕсли;
		ТабДокумент.Вывести(ТабДокументОбъекта)
	КонецЦикла;

	Возврат ТабДокумент

КонецФункции 

Функция   СформироватьНесколькоПриказов(МассивОбъектов)
	
	ТабДокумент = Новый ТабличныйДокумент;
	Для каждого Ссылка из МассивОбъектов Цикл
		ТабДокументОбъекта = СформироватьПриказ(Ссылка); 
		Если ТабДокумент.ВысотаТаблицы > 0 И ТабДокументОбъекта.ВысотаТаблицы > 0 Тогда 
			ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц()
		КонецЕсли;
		ТабДокумент.Вывести(ТабДокументОбъекта)
	КонецЦикла;

	Возврат ТабДокумент

КонецФункции 

Функция  СформироватьАкт(Ссылка)

	ТабДокумент = Новый ТабличныйДокумент; 
	// подготовка ТабДокумента
	Возврат ТабДокумент 

КонецФункции 

Функция   СформироватьПриказ(Ссылка)
	
    ТабДокумент = Новый ТабличныйДокумент;
    // подготовка ТабДокумента 
    Возврат ТабДокумент 

КонецФункции 

Все готово, в форме документа у нас теперь программно будут добавляться кнопки печати. Чтобы они появились и в форме списка, проделайте с ней тоже самое (создайте обработчик ПриСозданииНаСервере и скопируйте код в Модуль формы ФормаСписка, в Модуле менеджера уже ничего менять не надо). Единственное отличие в третьем параметре функции ВыполнитьПодключаемуюКомандуПечати: вместо Объект нужно написать Элементы.Список. Также у этого списка обязательно должна быть колонка Ссылка, пусть даже невидимая. 

Результат всего этого выглядит так:

 

Форма документа

 

Форма списка

 

Универсальное окно печати в Бухгалтерии 3.0

 

P.S. Если при открытии информационной базы появится такое окно, то просто выполните то, что там написано, это нормально

подробнее о подсистеме "Печать" на ИТС:  https://its.1c.ru/db/bspdoc#content:219:hdoc

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. paybaseme 14 02.12.13 13:09 Сейчас в теме
Самое интересное в предлагаемой Вами методике, осталось за кадром: если в форме списка выделить НЕСКОЛЬКО элементов (в вашем случае, приказов), то как же тогда будут напечатаны все Ваши документы, ежели Вы пишите:

Ссылка = МассивОбъектов[0];


Для одного объекта и будет напечатано.

Полагаю, Вам нужно заглянуть в БСП.
2. nick-max 240 02.12.13 16:26 Сейчас в теме
(1) paybaseme,

Понятно, что где-то реализованы целые блоки и фреймворки для управления печатью. Эта статья только для Бухгалтерии 3.0, она полностью опирается на функционал этой конфигурации.

Да, из кода понятно, что если выделить шифтом несколько строк с документами, то можно напечатать их пакетно. Но для меня это ненужная функция. Однако, спасибо, что обратили на это внимание, может кому-то будет полезно)
3. paybaseme 14 02.12.13 17:47 Сейчас в теме
(2)

Понятно, что где-то реализованы целые блоки и фреймворки для управления печатью. Эта статья только для Бухгалтерии 3.0, она полностью опирается на функционал этой конфигурации.


Я ключевую неточность у Вас подчеркнул. В БП 3.0 портирована подсистема "Печать". Механизм печати, в части касающейся Вашей статьи, одинаков для конфигураций, где данная подсистема уже внедрена. Т.е. "фреймворк" печати (в вашей терминологии), уже встроен в БП 3.0. И говорить, что Ваша статья "опирается на функционал этой конфигурации." видимо, не совсем, точно. Ваша статья опирается на использование типовой подсистемы "Печать" из БСП.

Все выше сказанное, не в критику, а в уточнение :)
ivnik; keln; ccapt; swimdog; borzyj; Prog1CZUP31; Bukaska; Makushimo; +8 Ответить
4. nick-max 240 03.12.13 11:00 Сейчас в теме
(3) paybaseme,

Спасибо за уточнение
Значит эта статья кросс-конфигурационная)
20. Bukaska 138 19.12.13 14:35 Сейчас в теме
(2) Вот теперь спасибо! Правда вперед ИТС под рукой был)))) есть другой вопрос, по части внешних печатных форм для самодельных документов. Эти все дела по вашей публикации я сделала, потом отлаживаю сейчас родной макет самодельного документа.. но вот Внешнюю печатную форму не зарегить, выскакивает ошибка: Тип не определен.ДокументСсылка.ИмяДокумента.. В Общую команду составного типа добавила свой док, но все равно видать что-то где-то не хватает... Благо что хоть родной макет отлаживается))))
23. mie24 2 09.01.14 09:26 Сейчас в теме
(20) Bukaska, Чтобы к новому документу иметь возможность подключить ВПФ необходимо этот документ указать в списке Типов параметров Общей команды "ДополнительныеОтчетыИОбработкиПечатныеФормы", а лучше подстраховаться и указать новый(ые) документ(ы) и в других Общих командах "ДополнительныеОтчетыИОбработкиОтчеты", "ДополнительныеОтчетыИОбработкиЗаполнениеОбъекта", "ДополнительныеОтчетыИОбработкиСозданиеСвязанныхОбъектов".
Далее необходимо в Модуле формы (Документа и Списка) нового документа необходимо создать процедуру ПриСозданииНаСервере:
&
НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
		// СтандартныеПодсистемы.Печать
	УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма);
	// Конец СтандартныеПодсистемы.Печать
	
	// ДополнительныеОтчетыИОбработки
	ДополнительныеОтчетыИОбработки.ПриСозданииНаСервере(ЭтаФорма);
	// Конец ДополнительныеОтчетыИОбработки
	
	Если Параметры.Ключ.Пустая() Тогда
		ПодготовитьФормуНаСервере();
	КонецЕсли;

КонецПроцедуры
Показать

Кажется этого должно быть достаточно.

Только нужно еще проверить на форме на панели (Вид - ГруппаКнопок и Источник - Форма) появилась ли кнопка Печать с выпадающим меню "ДополнительныеПечатныеФормы"
freeek; insurgut; BiTwaR; Sherdrada; +4 Ответить
10. Bukaska 138 10.12.13 17:25 Сейчас в теме
(1) paybaseme, Я думаю множественная печать и Без БСП реализуется, если глянуть в типовую..
Для этого даже с самодельными печатными формами вместо ссылки на объект, делаем
Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов)
А в самом запросе:
...
ГДЕ
НужноеПоле.Ссылка В(&МассивОбъектов)


И переменную результата запроса Шапка прокрутить в цикле и усе.. и все будет ОК))))
Это как раз если внешнюю печатную форму встраивать через доп.Отчеты и обработки))))
11. paybaseme 14 10.12.13 20:45 Сейчас в теме
(10) Bukaska,
Я думаю множественная печать и Без БСП реализуется, если глянуть в типовую..


Все таки, по внимательнее перечитайте (3). Если Вы гляните в типовую БП 3.0, то все о чем Вы написали, НЕ ИМЕЕТ СМЫСЛА без внедренной подсистемы "Печать". Поэтому, Ваши думы о том, что множественная печать реализуется БЕЗ БСП, могут существовать в контексте Ваших исключительных рассуждений и дум :) А если глубже копнуть, то выяснится, что ваш алгоритм - это типовая методика, которую можно было увидеть в БСП версии 1.0.7.5 от 05.08.2010, в то время как БП 3.0 зарелизилась с версии 3.0.9.4 от 28.04.2012. Т.е., тот алгоритм, который Вы описали, опирается на обвяз, который уже был представлен в демо БСП практически за 2 года, до первого релиза БП 3.0

Это как раз если внешнюю печатную форму встраивать через доп.Отчеты и обработки


А это, в свою очередь, еще одна подсистема БСП под названием "Дополнительные отчеты и обработки", которая также портирована в БП 3.0

Итоги моего поста какие? :)
12. Bukaska 138 10.12.13 21:45 Сейчас в теме
(11) paybaseme, Я сказала именно про множественную печать, что не нужно так глубоко копать для привязки ВПФ к документу)))
Вопрос в том, как по вашей методике согласно публикации сделать так, чтобы работала множественная печать.А то нулевой индекс строки правильно ребята подметили, - это печать одного документа, как будто из бух 2.0 печатаем)
13. paybaseme 14 10.12.13 22:53 Сейчас в теме
(12) Bukaska,
не нужно так глубоко копать для привязки ВПФ к документу


Как раз таки нужно, ибо если не копать, тогда сложится мнение как у вас и у вашего коллеги: что оно якобы как-то само там живет, в типовой, своей жизнью.

Надо за правило взять, если что-то по печати, доп.отчетам и обработкам, ролям и прочему не понятно - то первое что надо делать, это не пытаться раскуривать самому, а скачать демо БСП, той редакции, которая сейчас в типовой, и посмотреть примеры.

Пожалуйста! Всегда Ваш, Кэп.

:)
14. Bukaska 138 10.12.13 23:19 Сейчас в теме
(13) paybaseme, БСП недоступна ни по учетке учебной версии, ни по комплекту разраба вроде как.. Это только франям..)))
Если бы оно везде на ресурсах валялось.. другой бы разговор)))
Лучше подскажите как в типовой найти версию БСП, и где посмотреть справку о функционале БСП.
15. paybaseme 14 11.12.13 09:35 Сейчас в теме
(14) Bukaska,
Прикрепленные файлы:
16. Bukaska 138 11.12.13 09:57 Сейчас в теме
(15) paybaseme, Спасибо! А как в типовой бух 3.0 выйти на эту справку?
17. paybaseme 14 11.12.13 10:17 Сейчас в теме
(16) Bukaska,
А как в типовой бух 3.0 выйти на эту справку?

1. Версия подсистем - РС
2. Справка по подсистемам БСП - никак. Только на ИТС.
18. Bukaska 138 11.12.13 10:19 Сейчас в теме
(17) paybaseme, ну вот.. опять двадцать пять((( жаль.. Ладно.. может меня когда-нить и допустят до ИТС)))
19. paybaseme 14 11.12.13 11:25 Сейчас в теме
(18) Bukaska,

может меня когда-нить и допустят до ИТС


Если у Вас ваше скромное чувство собственного "я" позволит себя допустить до ИТС, то для этого нужно сделать всего лишь четыре шага:

1. Зарегать новый e-mail
2. Открыть http://its.1c.ru/test-drive/
3. Получить доступ к ИТС по е-mail из п.1 на 7 дней
4. Через 7 дней, выполнить в п.1

Пожалуйста! Всегда Ваш, Кэп.
Suslik_Johns; SunShinne; +2 Ответить
5. Saifa 31 08.12.13 19:03 Сейчас в теме
Статья мне пригодилась, спасибо!
6. nixel 1251 08.12.13 19:32 Сейчас в теме
В БП 3.0 помимо подсистемы "Печать" встроена подсистема "Дополнительные отчеты и обработки", которая позволяет вообще без внесения изменений в конфигурацию добавлять произвольные команды печати и обработок в документы. Единственное требование от конфигурации - наличие документа/справочника в определенной подписке. Если этого нет, то контроллировать изменение одной/двух подписок намного проще, чем модулей объекта и менеджера. Сама же печать располагается во внешней обработке, которая имеет в своем модуле информацию для подключения к какому-либо документу, и все это дело настраивается в пользовательском режиме.
Как уже писалось выше, почитайте документацию по новой БСП, там правда много интересного :)
Prog1CZUP31; +1 Ответить
7. AleksSF 205 10.12.13 09:44 Сейчас в теме
А через команды документа и конструкторы не пробовали. Там все автоматом размещается и на форму документа и на форму списка. В БП 3.0 как и во всех управляемых приложениях ко многим вещам другой подход. И лучше как следует изучить новую конфигурацию, а затем переносить свои изменения. Иначе получиться изобретение велосипеда.
8. nick-max 240 10.12.13 10:19 Сейчас в теме
(7) AleksSF,

Пробовал, конечно, с этого и начал. Но такая печать просто формирует и открывает табличный документ, а мне требовалось, чтобы он открывался в форме с кнопкой "Печать", количеством экземпляров, возможностью сохранить
9. AleksSF 205 10.12.13 15:55 Сейчас в теме
(8)
В принципе Ваш способ имеет право жить, если в конфигурацию добавляешь свои Документы. Но для стандартных документов все же лучше использовать Дополнительные внешние печатные формы. Они добавляются с таким-же функционалом. Но при обновлениях ничего не будет пропадать и для последователей более прозрачно. Поэтому +.
21. oleg212 03.01.14 11:16 Сейчас в теме
22. SoulCast 33 04.01.14 00:15 Сейчас в теме
Спасибо, сделал по этой схеме несколько печатных форм в новых документах. Как раз в процессе переход на БП 3.0 )) А есть идеи как передать в процедуру печати дополнительные параметры?
24. nick-max 240 09.01.14 12:38 Сейчас в теме
(22) SoulCast,

а для чего это может быть нужно? то есть, какой например может быть доп. параметр, и почему его нельзя получить уже внутри процедуры типа СформироватьАкт?
25. SoulCast 33 09.01.14 19:21 Сейчас в теме
(24) например получить текущую строку табличной части. У меня были печатные формы, которые получали данные по выбранной строке.
26. Dima69 34 07.03.14 10:05 Сейчас в теме
27. Dima69 34 07.03.14 10:09 Сейчас в теме
Да чуть не забыл, а не подскажите какие стандартные процедуры
ставят значок Дб-Кр (при ручной корректировки операции) в списке документов
28. nick-max 240 07.03.14 10:30 Сейчас в теме
(27) Dima69,

для выведения на форму кнопки ДтКт нужно добавить свой документ в общую команду ПоказатьДвиженияДокумента.
Но с точки зрения доработки типовой конфигурации с минимальными изменениями в типовых объектах лучше всего скопировать эту общую команду, назвать ПоказатьДвиженияМоегоДокумента и указывать в ней только свои документы. Тогда при обновлении кнопка ДтКт точно не слетит
29. Dima69 34 19.03.14 20:49 Сейчас в теме
Спасибо за ответ, но я имел в виду не кнопку ДтКт,
а значок ДтКт левее документа, операция которого отредактированна вручную, рядом
с зеленой галкой проведенного документа
30. sudmorsh 57 02.08.14 19:51 Сейчас в теме
Спасибо за статью очень пригодилась
31. Prog1CZUP31 20.08.14 08:03 Сейчас в теме
Интересная статья про печать в БП 3.0 с использованием стандартных механизмов. Но, может быть, даже для новых нетиповых документов использовать внешние печатные формы если нужно оперативно (не выгоняя пользователей) исправить ошибку при печати?
Печатную форму сделать проще чем копаться в механизмах печати новых релизов? Постоянно ведь корректировать конфигурацию будет затруднительно? Особенно если новых документов много.
32. Astafan 11.11.14 08:15 Сейчас в теме
Спасибо за статью, очень пригодилась.
Но есть один вопрос: Создал в типовой конфигурации новый документ. Чтобы использовать механизм подключаемых печатных форм нужно редактировать команду "ДополнительныеОтчетыИОбработкиПечатныеФормы". НО при обновлении изменения слетят. Как правильно поступить в данном случае?
33. ekaterinaeon 17 28.11.14 08:53 Сейчас в теме
Нашла эту статью как раз в тот момент, когда больше всего была нужна) и помогло! спасибо!
34. helox 04.12.14 15:23 Сейчас в теме
В процедуре Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт 

	КомандаПечати = КомандыПечати.Добавить();
	КомандаПечати.Идентификатор = "Акт";
	КомандаПечати.Представление = "Дополнительный акт";
	КомандаПечати.Обработчик    = "УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати";
	КомандаПечати.СписокФорм    = "ФормаСписка,ФормаДокумента"; 

в списке форм должны быть наименования форм используемых при печати, добавил форму "ФормаДокументаУФ" - и долго гадал почему не появилась кнопочка печати!!
DarkUser; +1 Ответить
35. ronhard 29.01.15 17:52 Сейчас в теме
Также у этого списка обязательно должна быть колонка Ссылка, пусть даже невидимая
В конфигураторе на форме у колонки "Ссылка" должна стоять галочка "Использовать всегда", иначе невидимая колонка работать не будет, а только если она видимая.
A.Kurilov; bird21; PoZiTiFFF; cleaner_it; +4 Ответить
50. den_vrn 10 19.06.19 11:12 Сейчас в теме
(35)
"Использовать всегда"


не могу найти где эта галочка блин ....
36. ui69 41 11.02.15 13:50 Сейчас в теме
Спасибо, помогла данная статья. Создавал новый документ в БП 3.0 с двумя печатными формами.
37. Baser 5 12.02.16 09:07 Сейчас в теме
А можете ссылку дать, как это более правильно делать? Я уже который день пытаюсь понять, как свою печать через БСП пустить, а не по старинке, через команды; везде методики для использования во внешних печатных формах

Ну, вот почему так... как вопрос задал, так сразу и нашел... спасибо всем :)
http://its.1c.ru/db/bspdoc#content:219:1:issogl2_%D1%80%D0%B0%D0%B7%D1%80%D0%B0%D0%B1%D0%BE%D1%82%D0%­BA%D0%B0_%D0%BF%D1%80%D0%BE%D1%86%D0%B5%D0%B4%D1%83%D1%80%D1­%8B_%D0%BF%D0%B5%D1%87%D0%B0%D1%82%D1%8C
38. user590836_zhan_chick 08.07.16 14:24 Сейчас в теме
Теперь у меня программно добавились 2 лишние кнопки печати, которые мне не нужны. Помимо тех что созданы на форме вручную. Вопрос: как мне их убрать?
39. zmx 25.07.16 00:29 Сейчас в теме
В форме списка документа в процедуре ВыполнитьПодключаемуюКомандуПечати нужно поставить условие выполнения печати только, если документ проведен. Почему здесь не виден реквизит проведения документа?

Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)

Объект=Элементы.Список.ТекущаяСтрока;
Если Объект.Проведен = Ложь Тогда
Сообщить("Документ не проведен !!! Печать не возможна");
Возврат;
КонецЕсли;

УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Элементы.Список);
КонецПроцедуры

Спасибо заранее!
40. nick-max 240 25.09.16 03:24 Сейчас в теме
(39) zmx,

думаю, тут лучше использовать Элементы.Список.ТекущиеДанные.Ссылка.Проведен, при условии, что в список выведена колонка Ссылка. Но я бы такие проверки перенес внутрь функций типа СформироватьПриказ
41. Perk0n 13 31.07.17 11:12 Сейчас в теме
Be aware.. в новой БСП поменяли принцип подключения своих команд. Статью бы немного дополнить, так как в данном виде она утратила свою актуальность.

Вместо методов из "СтандартныеПодсистемы.Печать"

&НаКлиенте 
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)	
	УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект)	
КонецПроцедуры  


Следует использовать методы из "СтандартныеПодсистемы.ПодключаемыеКоманды"
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
	ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры
42. slauter77 20 06.10.17 10:17 Сейчас в теме
Спасибо за предупреждение! (41)
От себя добавлю, что например в Бух КОРП 3.0.52.39 нужно в модуле: "ОбщийМодуль.УправлениеПечатьюПереопределяемый"

в процедуру:
 Процедура ПриОпределенииОбъектовСКомандамиПечати(СписокОбъектов) Экспорт 


добавить строку типа:
СписокОбъектов.Добавить(Документы.ИмяВашегоДокумента)


тогда, с учетом изменений описанных Вами, печать заработает!

(просто сам долго копался с этим)
mlv84; rmarkovych; insurgut; EMelihoff; lina_00; k0pai; ye_s; 777Ferz777; +8 Ответить
43. 777Ferz777 8 17.10.17 08:59 Сейчас в теме
С новыми обновами, новые веянья
Вызовы вида:
// СтандартныеПодсистемы.Печать
&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтотОбъект, Объект);
КонецПроцедуры
// Конец СтандартныеПодсистемы.Печать


следует заменить вызовами:

// СтандартныеПодсистемы.ПодключаемыеКоманды
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, <ОбъектИлиТаблицаФормы>);
КонецПроцедуры
 
&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, <ОбъектИлиТаблицаФормы>, Результат);
КонецПроцедуры
 
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
Показать


более подробно читайте здесь http://downloads.v8.1c.ru/content/SSL/2_4_3_84/change.htm
44. nadjushka 19 28.03.18 10:10 Сейчас в теме
Добавление команд печати в Бухгалтерии 3.0 после релиза 3.0.52.35

http://1c-soft.it-terminal.ru/public/674880/
45. bds22 20 07.04.18 18:17 Сейчас в теме
в бухгалтерии корп 3.0 мне для того, чтобы появилась возможность печати в моем документе, пришлось в общем модуле "Управление печатью переопределяемый"
в эту процедуру добавить свой документ
Процедура ПриОпределенииОбъектовСКомандамиПечати(СписокОбъектов) Экспорт

там такие строки
СписокОбъектов.Добавить(Документы.ПоступлениеТоваровУслуг);
	СписокОбъектов.Добавить(Документы.ПринятиеКУчетуНМА);
	СписокОбъектов.Добавить(Документы.ПринятиеКУчетуОС);
	СписокОбъектов.Добавить(Документы.ПриходныйКассовыйОрдер);
	СписокОбъектов.Добавить(Документы.РаспределениеНДС);
	СписокОбъектов.Добавить(Документы.РасходныйКассовыйОрдер);

и так далее - все документы
rmarkovych; Артём74; CatZero; +3 Ответить
46. CatZero 12.04.18 06:57 Сейчас в теме
49. vis_tmp 31 18.04.19 19:47 Сейчас в теме
(45) А в самом документе что нужно добавить?
47. liric 26.09.18 17:28 Сейчас в теме
А если я хочу просто напечатать документ в своей самописанной конфе где нет никаких БСП и конструкторы печати теперь не работают. Что делать?
48. newvideo 27.01.19 13:52 Сейчас в теме
УНФ 1.6.5. БСП 2.3.1.53
в модуле УправлениеПечатьюСлужебныйКлиент
в процедуре ВыполнитьПодключаемуюКомандуПечатиПодготовкаОбъектовПечати
вываливается:

{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(125)}: Ошибка компиляции при вычислении выражения или выполнении фрагмента кода Результат = Вычислить(Обработчик);
по причине:
{(1,1)}: Переменная не определена (УправлениеПечатьюБПКлиент)
<<?>>УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати(ОписаниеКоманды)

Менял в Модуле Менеджера Документа
УправлениеПечатьюБПКлиент на УправлениеПечатьюКлиент и также на
Подключаемый_ВыполнитьКомандуПечати
всёравно ошибки, куда же копать?
51. XelOla 17 06.09.19 15:49 Сейчас в теме
(48) вы разобрались?
ТОже не могу для УНФ вывести
52. newvideo 06.09.19 21:00 Сейчас в теме
(51) давно это было, помню только что разобрался, а что именно сделал к сожалению уже не вспомню) Но конфигурация под рукой, могу сказать что где есть)
53. insurgut 202 08.04.20 16:13 Сейчас в теме
54. Djo82 72 15.05.20 10:19 Сейчас в теме
Если это КА 1.1 например, то печать можно вывести через свойства команды
Прикрепленные файлы:
55. Denic_01 34 02.06.20 18:08 Сейчас в теме
Добавьте в статью прям жирным шрифтом
что если не прописать объект в методе

Процедура ПриОпределенииОбъектовСКомандамиПечати(СписокОбъектов) Экспорт 


модуля УправлениеПечатьюПереопределяемый

ничего работать не будет !!!
delsoft; SanchoD; Rusel; 111c; ulen; +5 Ответить
Оставьте свое сообщение

См. также

[Общий модуль] Динамическое формирование интерфейса Промо

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Библиотека готовых функций для разработки интерфейса формы и размещения на нём элементов формы с помощью программного кода.

28.08.2020    18734    rpgshnik    82    

Программная работа с упаковками и единицами измерения в КА 2.4

Адаптация типовых решений v8 КА2 УУ Бесплатно (free)

Несколько методов для быстрой адаптации типовых механизмов упаковок и единиц измерения в КА 2.4.

02.06.2022    933    Rustig    3    

Еще раз о дополнительных реквизитах и дополнительных сведениях

Адаптация типовых решений БСП (Библиотека стандартных подсистем) Механизмы типовых конфигураций v8 1cv8.cf Россия Бесплатно (free)

Дополнительные реквизиты и сведения существуют давно. Задумка очень хорошая. Суть этих механизмов понятна всем. По этому поводу написано много. Что тут можно сказать нового? Однако бес, как всегда, в деталях. Как создавали реквизиты в объектах типовых конфигураций, так и продолжаем это делать. Почему это происходит? За всех сказать не могу. Могу рассуждать только на своем примере. Являясь убежденным практиком, одно могу сказать вполне определенно. Если что-то на практике недостаточно удобно, то останется оно главным образом в теории... Если не приложить немного усилий.

11.05.2022    2442    user1374747    7    

Допиливаем типовой отчет "Связанные документы" (структура подчиненности) так, чтобы он видел документы из расширения конфигурации

Адаптация типовых решений v8 ERP2 Россия Бесплатно (free)

Наконец-то мы перешли на платформу 1С 8.3.20 и смогли отказаться от режима совместимости в 1С ЕРП. Это позволило нам окончательно закрыть вопрос о перемещении ВСЕХ добавленных объектов из самой конфигурации в её расширение.  Одним из камней преткновения на пути к переезду, был вопрос работы типового отчета "связанные документы".  Ну что же, давайте вместе его решим.

02.05.2022    2529    dima_home    14    

Строим графы средствами 1С (без GraphViz) Промо

Работа с интерфейсом v8 Бесплатно (free)

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    26746    slozhenikin_com    20    

Пример доработки проведения в ERP 2.5 по одному регистру накопления

Адаптация типовых решений v8 ERP2 Бесплатно (free)

В дополнение к публикации № 1343740 показан быстрый способ встраивания в механизмы конфигурации проведения существующего документа "ПриобретениеТоваровУслуг" по добавленному новому регистру накопления "АТХ_ПартииНоменклатурыДляРемонтовТверь_НД". Пример реализован на 1С:ERP Управление предприятием 2 (2.5.7.390).

27.04.2022    952    vsasav    5    

Программный интерфейс для доработки форм

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Реализовал простой способ программного создания новых элементов, команд и реквизитов на форме.

25.11.2021    4778    AtamanovYS    19    

Как сделать сотрудникам детей

Адаптация типовых решений v8 Бесплатно (free)

За этим провокационным заголовком скрывается небольшая задача, которая, однако, вызвала некоторую дискуссию в кулуарах на последней конференции. Как хранить список детей сотрудников - в табличной части справочника или в регистре сведений?

28.10.2021    2647    Alxby    50    

Распределение расходов пропорционально продажам Промо

Бюджетирование и планирование Учет доходов и расходов Адаптация типовых решений v8 v8::ОУ УТ10 УУ Бесплатно (free)

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    19419    Rustig    9    

[ПОТРАЧЕНО] Динамическая таблица формы

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

История одной разработки в далеком 2020 году.

15.10.2021    4204    rpgshnik    47    

Программно свернуть/развернуть узел динамического списка (с основной таблицей). Жирная точка над всеми "i".

Работа с интерфейсом Универсальные функции v8 Бесплатно (free)

Какой пользователь не мечтал поменьше тыркать кнопкой? Особенно в малюсенькие +/- в "древесных" динамических списках. Если вас тоже озадачили, чтобы, при выборе узла дерева сами развернулись все его вложенные элементы , а при выборе другого узла - так же автоматом свернулась ранее развернутая ветка (причем эти узлы могут находится в разных "отношениях" друг с другом)... То вам - сюда.

08.10.2021    2242    e-9    13    

Как читать чужой код? Часть 4. Программный интерфейс. Исправление чужих доработок

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Во всех вакансиях есть требование - умение читать чужой код. Но ни на одних курсах специально этому не учат. Чтобы устранить это противоречие, пишу данную статью. Рассмотрю случаи, в которых нам необходимо разбирать чужой код, поймём, чей код мы пытаемся разобрать, зачем и, главное, как. В статье описан личный опыт длиною в 18 лет начиная с версии платформы 7.7. Статья будет большой, набираемся терпения). Статья содержит в себе описание сценариев разбора кода, т.е. набор шагов. В статье не получится показать это на практике. Для этого планирую сделать онлайн или оффлайн курс, где на примерах будет показан разбор незнакомого кода. Статья разбита на 4 публикации для удобства изучения.

20.09.2021    2510    biimmap    7    

Перевод интерфейса конфигурации с использованием программы 1С:Переводчик Промо

Работа с интерфейсом v8 Бесплатно (free)

Перевод текстов интерфейсов конфигураций без использования технологии памяти переводов приводит к рассогласованности терминологии, когда один и тот же объект в конфигурации в разных меню может называться по-разному. Решить эту проблему можно используя программу 1С:Переводчик.

09.02.2015    45758    boogie    21    

Внедрение адресного хранения на 1С:КА 2.4. Часть 1. Теоретическая. Мотивационная

Склад и ТМЦ Рабочее место Адаптация типовых решений v8 ERP2 УТ11 КА2 УУ Бесплатно (free)

Внедрение адресного хранения на КА2.4: начало процесса и акценты. Теоретическая часть. Местами мотивационная.

12.08.2021    5976    Rustig    217    

Изменение размера картинок "на лету" с помощью NGINX

Работа с интерфейсом v8 Бесплатно (free)

Пример использования nginx и image_filter для сжатия картинок.

26.05.2021    2350    malikov_pro    21    

Исправление ошибки работы с RLS в обработке "Диадок стандартный модуль"

Адаптация типовых решений v8 1cv8.cf Бесплатно (free)

У пользователя стоят ограничения RLS на документе "РеализацияТоваровУслуг" по подразделению(пользователь видит документы только по своему подразделению). Обработка "Диадок стандартный модуль" выдает в таком случае ошибку, потому что пытается показать пользователю все документы без учета RLS.

11.05.2021    2875    John_d    13    

Старые обработки в новом (Управляемом) интерфейсе Промо

Работа с интерфейсом v8 v8::УФ Бесплатно (free)

Многие разработчики привыкли использовать какие-либо обработки, разработанные для приложений с обычным интерфейсом. Но они не работают в приложениях на управляемых формах. Как вариант, эту обработку можно включить в состав конфигурации, указать в свойствах конфигурации, что возможно использование обычных форм

12.08.2016    61436    valerasv    7    

Динамический список и поиск... неприятностей

Работа с интерфейсом v8 Бесплатно (free)

Страх и ненависть в поиске по динамическому списку, или "Кое-что о неоптимальном отборе".

17.03.2021    6816    Yashazz    37    

Регламентные задания: коротко и ясно о детальных расписаниях

Адаптация типовых решений v8 Бесплатно (free)

Как программно создать регламентное задание и добавить детальные расписания для него.

04.03.2021    8554    user1502278    5    

Пример работы с диаграммой Ганта в 1С

Работа с интерфейсом v8 Бесплатно (free)

Пример работы с очень нужным и важным, по моему мнению, объектом в 1С «Диаграммой Ганта».

24.02.2021    8226    JIEX@    3    

Исправление ошибок в типовых релизах 1С: УТ 10.3 и Розница 1.0 при отражении продаж в ЕГАИС Промо

Адаптация типовых решений v8 УТ10 Бесплатно (free)

При продаже алкогольной продукции в программах Управление торговлей и Розница возникают ошибки. В статье разберем причины ошибок и способ их решения.

05.06.2016    40950    @lexandr    21    

Использование отчета как печатной формы документа

Адаптация типовых решений v8 1cv8.cf Бесплатно (free)

Пользователь попросил создать новый отчёт, но чтобы была возможность его распечатать из документа (в таком случае отчёт должен формироваться по этому документу), плюс при печати из документа должен быть заголовок и подвал с подписями. Однако, вид у внешней обработки может быть либо "Дополнительный отчет", либо "Печатная форма" (может быть ещё "Отчет" - для документа, но это тоже "либо" и задача была использовать типовой механизм формирования печатных форм). Чтобы не делать, по сути, два одинаковых отчёта, напрашивается мысль создать отдельно отчёт и печатную форму, но печатная форма должна вызывать формирование отчёта. В данной публикации представлен один из способов такой реализации.

20.02.2021    5448    ltfriend    6    

Пример создания кадрового отчета для ЗУП 3.1

Адаптация типовых решений v8 v8::СПР ЗУП3.x Россия Бесплатно (free)

Пример создания отчёта "Изменение графиков работы" для ЗУП 3.1 с использованием механизма представлений и объекта СхемаЗапроса.

22.12.2020    3245    vazelin    0    

Программное условное оформление динамического списка, раскраска строк списка по цветам справочника или любым другим условиям (условное оформление)

Работа с интерфейсом v8 v8::УФ 1cv8.cf Бесплатно (free)

Большое количество динамических списков на форме, большое количество условий, долгое интерактивное добавление условий, оформление по значению элементов справочников - всё это не позволяет использовать интерактивный режим назначения условного оформления динамического списка. В публикации с открытым кодом детально разберем программное решение назначения условного оформления, создадим универсальную функцию для оформления списка.

30.11.2020    9473    SizovE    4    

Идея или как сохранить ЦВЕТ, ШРИФТ, ОФОРМЛЕНИЕ пользователя Промо

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Простой и оригинальный способ сохранять ЦВЕТОВУЮ СХЕМУ и ОФОРМЛЕНИЕ пользователей. Как сохранить ЦВЕТ

22.06.2015    25195    Tatitutu    12    

[mobile] Переносим HTML интерфейс на 1С

Работа с интерфейсом Мобильная разработка v8 v8::Mobile 1cv8.cf Бесплатно (free)

Разберем методы переноса HTML интерфейса на 1С на примере реализации нижнего меню для мобильного приложения. Сравним методы между собой. Данные методы можно применять не только для мобильной разработки, но и для веб-клиента и т.д

02.11.2020    10681    leobrn    82    

Быстрая кодогенерация программной доработки форм

Работа с интерфейсом v8 Бесплатно (free)

Данная статья является описанием идеи по быстрому получению кода для программной доработки форм. А также приглашением к участию в реализации данной идеи (даже звездочке на гите буду рад).

12.10.2020    2591    huxuxuya    29    

Рендеринг элементов управляемого интерфейса

Работа с интерфейсом v8 v8::УФ Россия Бесплатно (free)

Реализация отображения всего состояния формы проще, чем работа по изменениям. Однако использование идеи разделения алгоритмов на программные слои MVC и построения реактивных систем позволяет получить не только простые и масштабируемые решения, но и производительные интерфейсы. Рассмотрим примеры таких реализаций на основе использования фреймворка «Управление состоянием»: Информационная надпись, Заголовок формы, Свертываемая группа, Отключаемые панели.

22.09.2020    4280    kalyaka    5    

Хранение и редактирование дополнительных параметров в регламентированном отчете. Для начинающих. Промо

Работа с интерфейсом v8 БП2.0 УПП1 БУ Бесплатно (free)

Для начинающих. Как редактировать дополнительные параметры регламентированного отчета, изменив только модуль формы и модуль объекта. Как сохранить дополнительные параметры в данных отчета.

22.01.2014    21303    KapasMordorov    4    

Переопределение представления ссылочного значения

Работа с интерфейсом v8 Бесплатно (free)

Переопределение представления ссылочного значения

17.09.2020    6880    sam441    15    

Если ККМ Атол + 1С Розница тормозит при печати чеков по сети, или экономим на покупке ККТ и ФР

Розничная торговля Адаптация типовых решений ККМ v8 Розница УТ11 Россия Бесплатно (free)

Очень медленная работа с ККТ по Tcp/ip или Как заставить две клиентских Розницы 1С печатать чеки на одной кассе ККТ онлайн Предыстория и чем все закончилось.

01.07.2020    7630    lepihin    11    

Простой способ добавить факсимильную подпись и печать в печатную форму

Адаптация типовых решений v8 1cv8.cf Бесплатно (free)

Актуальная задача добавить факсимильную печать и подпись в печатную форму.

08.04.2020    49851    John_d    17    

Стандартные доработки. Штрихкодирование документов. Промо

Адаптация типовых решений v8 1cv8.cf Россия Бесплатно (free)

Эта статья описывает процесс доработки типовых 1С конфигураций, для добавления функционала штрихкодирования документов и быстрого их поиска по штрихкоду. Метод работает для управляемых и неуправляемых печатных форм.

14.12.2010    71594    milkers    62    

Ввод на основании в пакетном режиме

Адаптация типовых решений v8 1cv8.cf Бесплатно (free)

Была поставлена задача сделать ввод на основании в пакетном режиме. В списке документов пользователь выделяет несколько документов и нажимает кнопочку Ввести на основании. После этого создаются документы на основании выделенных документов.

16.03.2020    3415    John_d    9    

Форма выбора для реквизита с составным типом данных

Работа с интерфейсом v8 Бесплатно (free)

Возник вопрос: как открыть форму выбора для реквизита, имеющего составной тип данных, да еще и отображаемый в виде надписи?

11.03.2020    7821    rule_2    4    

Treemapping — способ визуализации данных древовидной структуры. Карта-схема дерева

Математика и алгоритмы Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Предлагается ознакомиться с редким способом графического представления иерархических данных. Приводится алгоритм формирования и пример реализации.

18.02.2020    7273    randomus    20    

Выборочное списание партий товаров в "Управление торговлей" редакции 10 Промо

Склад и ТМЦ Адаптация типовых решений v8 УТ10 Россия УУ Бесплатно (free)

Реализация выборочного списания партий товаров в "Управление торговлей" редакции 10

01.10.2011    46902    GreenLab    35    

[Шпаргалка] Предустановка типа для составного реквизита

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Для реквизита составного типа необходимо ограничить список выбора типов.

18.02.2020    7753    rpgshnik    6    

СКД. Шаг 3. Используем макеты для оформления отчета

Работа с интерфейсом v8 v8::СКД 1cv8.cf Бесплатно (free)

В данной публикации рассмотрим базовый подход к использованию собственных макетов в СКД на примере формирования небольшого отчета.

13.01.2020    49662    aximo    21    

Добавление собственного поля и состояния в настройки доступности по состоянию в 1С:Документооборот

Работа с интерфейсом v8 ДО Бесплатно (free)

В данной публикации я хочу описать процесс добавления собственного поля и состояния в функционал настройки доступности по состоянию в 1С:Документооборот.

30.12.2019    7682    pavelpribytkin96    2    

Программное генерирование кнопочек для удобного управления уровнями группировки в отчетах (версия 2a). Промо

Работа с интерфейсом v8 1cv8.cf Россия Бесплатно (free)

В табличных документах 1С 8 имеется отличная возможность использования группировок, но управление уровнями группировок через контекстное меню не очень удобное. В своих отчетах для управления уровнями группировок я использую маленькие кнопочки на поле табличного документа - это намного удобнее и быстрее, чем через контекстное меню.

09.04.2011    47878    mtv:)    75    

Добавление собственного виджета в 1С:Документооборот

Работа с интерфейсом v8 ДО Бесплатно (free)

В данной публикации я хочу описать процесс добавления собственного виджета для функционала отсутствий в 1С документооборот.

14.12.2019    6709    pavelpribytkin96    2    

[СКД] Вывод картинки в результат любого отчета на СКД

Работа с интерфейсом v8 v8::СКД 1cv8.cf Бесплатно (free)

Если у вас в справочнике Номенклатура (или другом справочнике) заполнена картинка, то ее можно легко вывести для наглядности отчета.

09.12.2019    13979    John_d    17    

Лайфхаки 1С. Настройка списков (Часть 3)

Работа с интерфейсом v8 Бесплатно (free)

Новая порция лайфхаков по работе с интерфейсом 1С. На этот раз разбираем работу со списками - учимся их упорядочивать, сортировать, создавать новые и перемещать старые. Это очень полезное дополнение к уже имеющимся знаниям по интерфейсу 1С.

03.12.2019    25730    VachKirp    14    

Хитрости компоновки данных: программное формирование заголовков отчета и колонок без использования макетов. Промо

Работа с интерфейсом v8 1cv8.cf Россия Бесплатно (free)

Хитрости компоновки данных: программное формирование заголовков отчета и колонок без использования макетов. Очень часто необходимо программно сформировать заголовок отчета, например добавить туда наименование валюты, в которой формируется отчет. Можно использовать макеты, но во многих случаях это не оправданно.

27.07.2012    33532    milkers    9    

В новой платформе пропала кнопка "Печать". Имитируем БСП

Работа с интерфейсом v8 Россия Бесплатно (free)

"Приятным" сюрпризом для многих пользователей 1С стало то, что при обновлении платформы (начиная с 8.3.15) полностью поменялся интерфейс. Можно долго спорить о целесообразности этого новшества, но самым главным минусом стало то, что пропали стандартные кнопки на панели инструментов. Разработчики предполагают повсеместное использование БСП, но что делать тем, кто давно и успешно использует самописные конфигурации, в которых формирование печатной формы происходит по ТабДок.Показать(), и не желает их "утяжелять"? Добавим общую форму с нужными нам кнопками.

03.12.2019    10969    Vlan    44    

Как быстро выгрузить / загрузить внешние отчеты и обработки

Адаптация типовых решений v8 1cv8.cf Бесплатно (free)

Немного о массовой выгрузке и загрузке внешних отчетов и обработок.

12.11.2019    11399    YPermitin    18    

Управляемые формы. Изменение формы списка или формы объекта без внесения изменений в типовые формы (без использования расширений)

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Вносим изменения в типовые формы объектов (документы, справочники, журналы, обработки, общие формы). Не снимая с поддержки эти формы. Создаем программно элементы из общего модуля. Для примера рассмотрю добавление колонки "Скрепка" в форму списка документа. Если к документу привязан файл, то в списке в новой колонке должна отображаться "скрепка".

12.11.2019    17820    John_d    25    

Отрицательные страховые взносы Промо

Механизмы типовых конфигураций Запросы Адаптация типовых решений v8 ЗКБУ Бесплатно (free)

Иногда возникает необходимость рассчитать страховые взносы с отрицательной базы, но типовая зарплата сделать этого не позволяет. Предлагаю пример изменения запросов на релизе ЗКБУ 1.0.47.2 и всё будет считаться. Проверено на больших бюджетных организациях.

30.10.2012    12582    Nowa    25    

ELK. Время изумительных историй!

Журнал регистрации Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Всем привет! Сегодня хочу рассказать вам несколько полезных историй про то как нам помог Elastic search в связке с Kibana. Про сам Elastic рассказывать не буду, уже все давным давно описали и до меня. Все обычно говорят что это полезно, это классно. В то же время, очень мало кто рассказывает про практические ситуации: когда и как помог Elastic. Итак, начнем.

31.10.2019    10316    slozhenikin_com    28    

Создание асинхронных виджетов

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Описание нескольких способов создания асинхронных виджетов для 1С:Предприятия. Рассматриваются способы с использованием HTTP-сервисов и фоновых заданий.

16.10.2019    15346    YPermitin    19    

Формы. Трудности программной работы

Работа с интерфейсом v8 v8::УФ 1cv8.cf Бесплатно (free)

Рассматриваем основные подводные камни, с которыми приходится сталкиваться при программной работе с формами, а также способы обхода самых частых проблем.

06.10.2019    13846    YPermitin    31