Добавление команд печати в свои документы в Бухгалтерии 3.0

Публикация № 237013

Разработка - Практика программирования

110
Данная публикация может быть вам полезна, если вы хотите сделать своим нетиповым документам в Бухгалтерии 3.0 универсализированную печать (не затрагивая типовые объекты). Эта статья подойдет для любой конфигурации на основе БСП, так как использует возможности ее подсистемы "Печать"

В Бухгалтерии 2.0 была очень удобная типовая процедура

УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер,
					  Заголовок, НепосредственнаяПечать, Ссылка, ИмяМакета) 

Она помогала вывести ваш печатный документ в универсальное окно печати, где вы выбирали количество копий, вариант сохранения и тому подобное

Сейчас, переходя с 2.0 на 3.0, я стал искать аналог этой процедуры и не нашел. Но это к лучшему, потому что я нашел еще более универсальный механизм. Он опирается на механизмы подсистемы "Печать" БСП (БСП - это основа всех современных конфигураций фирмы 1С). Нужно добавить несколько функций в два модуля: Модуль менеджера и Модуль формы. Пусть у нас есть нетиповой документ Приказ, и у него есть два макета и две формы. 

Для каждого из двух макетов у нас подготовлены функции СформироватьАкт(Ссылка) и СформироватьПриказ(Ссылка), возвращающие табличные документы, которые нам нужно будет красиво выводить на печать. Хочется, не прилагая больших усилий, добиться следующего результата: чтобы в каждой из двух форм этого документа в командной панели была кнопка-подменю Печать, в которой был бы список из наших печатных форм.

     

Откроем форму ФормаДокумента, и создадим обработчик ПриСозданииНаСервере. Скопируем в модуль формы следующий код:

&НаСервере 
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
		
	УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма)	
	
КонецПроцедуры 

&НаКлиенте 
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
	
	УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект)
	
КонецПроцедуры  

 

Теперь откроем Модуль менеджера и скопируем туда следующий код:

Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт 

	КомандаПечати = КомандыПечати.Добавить();
	КомандаПечати.Идентификатор = "Акт";
	КомандаПечати.Представление = "Дополнительный акт";
	КомандаПечати.Обработчик    = "УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати";
	КомандаПечати.СписокФорм    = "ФормаСписка,ФормаДокумента";
	
	КомандаПечати = КомандыПечати.Добавить();
	КомандаПечати.Идентификатор = "Приказ";
	КомандаПечати.Представление = "Приказ";
	КомандаПечати.Обработчик    = "УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати";
	КомандаПечати.СписокФорм    = "ФормаСписка,ФормаДокумента";
	
КонецПроцедуры 

Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт 	
	
	ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "Акт") Тогда
 		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "Акт", "Акт", 
			СформироватьНесколькоАктов(МассивОбъектов),"Документ.Приказ.Акт");
	КонецЕсли;
	
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "Приказ") Тогда
 		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "Приказ", "Приказ", 
			СформироватьНесколькоПриказов(МассивОбъектов),"Документ.Приказ.Приказ");
	КонецЕсли;
	
КонецПроцедуры 

Функция   СформироватьНесколькоАктов(МассивОбъектов)
	
	ТабДокумент = Новый ТабличныйДокумент;
	Для каждого Ссылка из МассивОбъектов Цикл
		ТабДокументОбъекта = СформироватьАкт(Ссылка); 
		Если ТабДокумент.ВысотаТаблицы > 0 И ТабДокументОбъекта.ВысотаТаблицы > 0 Тогда 
			ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц()
		КонецЕсли;
		ТабДокумент.Вывести(ТабДокументОбъекта)
	КонецЦикла;

	Возврат ТабДокумент

КонецФункции 

Функция   СформироватьНесколькоПриказов(МассивОбъектов)
	
	ТабДокумент = Новый ТабличныйДокумент;
	Для каждого Ссылка из МассивОбъектов Цикл
		ТабДокументОбъекта = СформироватьПриказ(Ссылка); 
		Если ТабДокумент.ВысотаТаблицы > 0 И ТабДокументОбъекта.ВысотаТаблицы > 0 Тогда 
			ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц()
		КонецЕсли;
		ТабДокумент.Вывести(ТабДокументОбъекта)
	КонецЦикла;

	Возврат ТабДокумент

КонецФункции 

Функция  СформироватьАкт(Ссылка)

	ТабДокумент = Новый ТабличныйДокумент; 
	// подготовка ТабДокумента
	Возврат ТабДокумент 

КонецФункции 

Функция   СформироватьПриказ(Ссылка)
	
    ТабДокумент = Новый ТабличныйДокумент;
    // подготовка ТабДокумента 
    Возврат ТабДокумент 

КонецФункции 

Все готово, в форме документа у нас теперь программно будут добавляться кнопки печати. Чтобы они появились и в форме списка, проделайте с ней тоже самое (создайте обработчик ПриСозданииНаСервере и скопируйте код в Модуль формы ФормаСписка, в Модуле менеджера уже ничего менять не надо). Единственное отличие в третьем параметре функции ВыполнитьПодключаемуюКомандуПечати: вместо Объект нужно написать Элементы.Список. Также у этого списка обязательно должна быть колонка Ссылка, пусть даже невидимая. 

Результат всего этого выглядит так:

 

Форма документа

 

Форма списка

 

Универсальное окно печати в Бухгалтерии 3.0

 

P.S. Если при открытии информационной базы появится такое окно, то просто выполните то, что там написано, это нормально

подробнее о подсистеме "Печать" на ИТС:  https://its.1c.ru/db/bspdoc#content:219:hdoc

110

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. paybaseme 21 02.12.13 13:09 Сейчас в теме
Самое интересное в предлагаемой Вами методике, осталось за кадром: если в форме списка выделить НЕСКОЛЬКО элементов (в вашем случае, приказов), то как же тогда будут напечатаны все Ваши документы, ежели Вы пишите:

Ссылка = МассивОбъектов[0];


Для одного объекта и будет напечатано.

Полагаю, Вам нужно заглянуть в БСП.
2. nick-max 219 02.12.13 16:26 Сейчас в теме
(1) paybaseme,

Понятно, что где-то реализованы целые блоки и фреймворки для управления печатью. Эта статья только для Бухгалтерии 3.0, она полностью опирается на функционал этой конфигурации.

Да, из кода понятно, что если выделить шифтом несколько строк с документами, то можно напечатать их пакетно. Но для меня это ненужная функция. Однако, спасибо, что обратили на это внимание, может кому-то будет полезно)
3. paybaseme 21 02.12.13 17:47 Сейчас в теме
(2)

Понятно, что где-то реализованы целые блоки и фреймворки для управления печатью. Эта статья только для Бухгалтерии 3.0, она полностью опирается на функционал этой конфигурации.


Я ключевую неточность у Вас подчеркнул. В БП 3.0 портирована подсистема "Печать". Механизм печати, в части касающейся Вашей статьи, одинаков для конфигураций, где данная подсистема уже внедрена. Т.е. "фреймворк" печати (в вашей терминологии), уже встроен в БП 3.0. И говорить, что Ваша статья "опирается на функционал этой конфигурации." видимо, не совсем, точно. Ваша статья опирается на использование типовой подсистемы "Печать" из БСП.

Все выше сказанное, не в критику, а в уточнение :)
swimdog; borzyj; jobkostya1c8; Bukaska; Makushimo; +5 Ответить
4. nick-max 219 03.12.13 11:00 Сейчас в теме
(3) paybaseme,

Спасибо за уточнение
Значит эта статья кросс-конфигурационная)
20. Bukaska 130 19.12.13 14:35 Сейчас в теме
(2) Вот теперь спасибо! Правда вперед ИТС под рукой был)))) есть другой вопрос, по части внешних печатных форм для самодельных документов. Эти все дела по вашей публикации я сделала, потом отлаживаю сейчас родной макет самодельного документа.. но вот Внешнюю печатную форму не зарегить, выскакивает ошибка: Тип не определен.ДокументСсылка.ИмяДокумента.. В Общую команду составного типа добавила свой док, но все равно видать что-то где-то не хватает... Благо что хоть родной макет отлаживается))))
23. mie24 2 09.01.14 09:26 Сейчас в теме
(20) Bukaska, Чтобы к новому документу иметь возможность подключить ВПФ необходимо этот документ указать в списке Типов параметров Общей команды "ДополнительныеОтчетыИОбработкиПечатныеФормы", а лучше подстраховаться и указать новый(ые) документ(ы) и в других Общих командах "ДополнительныеОтчетыИОбработкиОтчеты", "ДополнительныеОтчетыИОбработкиЗаполнениеОбъекта", "ДополнительныеОтчетыИОбработкиСозданиеСвязанныхОбъектов".
Далее необходимо в Модуле формы (Документа и Списка) нового документа необходимо создать процедуру ПриСозданииНаСервере:
&
НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
		// СтандартныеПодсистемы.Печать
	УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма);
	// Конец СтандартныеПодсистемы.Печать
	
	// ДополнительныеОтчетыИОбработки
	ДополнительныеОтчетыИОбработки.ПриСозданииНаСервере(ЭтаФорма);
	// Конец ДополнительныеОтчетыИОбработки
	
	Если Параметры.Ключ.Пустая() Тогда
		ПодготовитьФормуНаСервере();
	КонецЕсли;

КонецПроцедуры
Показать

Кажется этого должно быть достаточно.

Только нужно еще проверить на форме на панели (Вид - ГруппаКнопок и Источник - Форма) появилась ли кнопка Печать с выпадающим меню "ДополнительныеПечатныеФормы"
insurgut; BiTwaR; Sherdrada; +3 Ответить
10. Bukaska 130 10.12.13 17:25 Сейчас в теме
(1) paybaseme, Я думаю множественная печать и Без БСП реализуется, если глянуть в типовую..
Для этого даже с самодельными печатными формами вместо ссылки на объект, делаем
Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов)
А в самом запросе:
...
ГДЕ
НужноеПоле.Ссылка В(&МассивОбъектов)


И переменную результата запроса Шапка прокрутить в цикле и усе.. и все будет ОК))))
Это как раз если внешнюю печатную форму встраивать через доп.Отчеты и обработки))))
11. paybaseme 21 10.12.13 20:45 Сейчас в теме
(10) Bukaska,
Я думаю множественная печать и Без БСП реализуется, если глянуть в типовую..


Все таки, по внимательнее перечитайте (3). Если Вы гляните в типовую БП 3.0, то все о чем Вы написали, НЕ ИМЕЕТ СМЫСЛА без внедренной подсистемы "Печать". Поэтому, Ваши думы о том, что множественная печать реализуется БЕЗ БСП, могут существовать в контексте Ваших исключительных рассуждений и дум :) А если глубже копнуть, то выяснится, что ваш алгоритм - это типовая методика, которую можно было увидеть в БСП версии 1.0.7.5 от 05.08.2010, в то время как БП 3.0 зарелизилась с версии 3.0.9.4 от 28.04.2012. Т.е., тот алгоритм, который Вы описали, опирается на обвяз, который уже был представлен в демо БСП практически за 2 года, до первого релиза БП 3.0

Это как раз если внешнюю печатную форму встраивать через доп.Отчеты и обработки


А это, в свою очередь, еще одна подсистема БСП под названием "Дополнительные отчеты и обработки", которая также портирована в БП 3.0

Итоги моего поста какие? :)
12. Bukaska 130 10.12.13 21:45 Сейчас в теме
(11) paybaseme, Я сказала именно про множественную печать, что не нужно так глубоко копать для привязки ВПФ к документу)))
Вопрос в том, как по вашей методике согласно публикации сделать так, чтобы работала множественная печать.А то нулевой индекс строки правильно ребята подметили, - это печать одного документа, как будто из бух 2.0 печатаем)
13. paybaseme 21 10.12.13 22:53 Сейчас в теме
(12) Bukaska,
не нужно так глубоко копать для привязки ВПФ к документу


Как раз таки нужно, ибо если не копать, тогда сложится мнение как у вас и у вашего коллеги: что оно якобы как-то само там живет, в типовой, своей жизнью.

Надо за правило взять, если что-то по печати, доп.отчетам и обработкам, ролям и прочему не понятно - то первое что надо делать, это не пытаться раскуривать самому, а скачать демо БСП, той редакции, которая сейчас в типовой, и посмотреть примеры.

Пожалуйста! Всегда Ваш, Кэп.

:)
14. Bukaska 130 10.12.13 23:19 Сейчас в теме
(13) paybaseme, БСП недоступна ни по учетке учебной версии, ни по комплекту разраба вроде как.. Это только франям..)))
Если бы оно везде на ресурсах валялось.. другой бы разговор)))
Лучше подскажите как в типовой найти версию БСП, и где посмотреть справку о функционале БСП.
15. paybaseme 21 11.12.13 09:35 Сейчас в теме
(14) Bukaska,
Прикрепленные файлы:
16. Bukaska 130 11.12.13 09:57 Сейчас в теме
(15) paybaseme, Спасибо! А как в типовой бух 3.0 выйти на эту справку?
17. paybaseme 21 11.12.13 10:17 Сейчас в теме
(16) Bukaska,
А как в типовой бух 3.0 выйти на эту справку?

1. Версия подсистем - РС
2. Справка по подсистемам БСП - никак. Только на ИТС.
18. Bukaska 130 11.12.13 10:19 Сейчас в теме
(17) paybaseme, ну вот.. опять двадцать пять((( жаль.. Ладно.. может меня когда-нить и допустят до ИТС)))
19. paybaseme 21 11.12.13 11:25 Сейчас в теме
(18) Bukaska,

может меня когда-нить и допустят до ИТС


Если у Вас ваше скромное чувство собственного "я" позволит себя допустить до ИТС, то для этого нужно сделать всего лишь четыре шага:

1. Зарегать новый e-mail
2. Открыть http://its.1c.ru/test-drive/
3. Получить доступ к ИТС по е-mail из п.1 на 7 дней
4. Через 7 дней, выполнить в п.1

Пожалуйста! Всегда Ваш, Кэп.
SunShinne; +1 Ответить
5. Saifa 30 08.12.13 19:03 Сейчас в теме
Статья мне пригодилась, спасибо!
6. nixel 796 08.12.13 19:32 Сейчас в теме
В БП 3.0 помимо подсистемы "Печать" встроена подсистема "Дополнительные отчеты и обработки", которая позволяет вообще без внесения изменений в конфигурацию добавлять произвольные команды печати и обработок в документы. Единственное требование от конфигурации - наличие документа/справочника в определенной подписке. Если этого нет, то контроллировать изменение одной/двух подписок намного проще, чем модулей объекта и менеджера. Сама же печать располагается во внешней обработке, которая имеет в своем модуле информацию для подключения к какому-либо документу, и все это дело настраивается в пользовательском режиме.
Как уже писалось выше, почитайте документацию по новой БСП, там правда много интересного :)
jobkostya1c8; +1 Ответить
7. AleksSF 184 10.12.13 09:44 Сейчас в теме
А через команды документа и конструкторы не пробовали. Там все автоматом размещается и на форму документа и на форму списка. В БП 3.0 как и во всех управляемых приложениях ко многим вещам другой подход. И лучше как следует изучить новую конфигурацию, а затем переносить свои изменения. Иначе получиться изобретение велосипеда.
8. nick-max 219 10.12.13 10:19 Сейчас в теме
(7) AleksSF,

Пробовал, конечно, с этого и начал. Но такая печать просто формирует и открывает табличный документ, а мне требовалось, чтобы он открывался в форме с кнопкой "Печать", количеством экземпляров, возможностью сохранить
9. AleksSF 184 10.12.13 15:55 Сейчас в теме
(8)
В принципе Ваш способ имеет право жить, если в конфигурацию добавляешь свои Документы. Но для стандартных документов все же лучше использовать Дополнительные внешние печатные формы. Они добавляются с таким-же функционалом. Но при обновлениях ничего не будет пропадать и для последователей более прозрачно. Поэтому +.
21. oleg212 03.01.14 11:16 Сейчас в теме
22. SoulCast 32 04.01.14 00:15 Сейчас в теме
Спасибо, сделал по этой схеме несколько печатных форм в новых документах. Как раз в процессе переход на БП 3.0 )) А есть идеи как передать в процедуру печати дополнительные параметры?
24. nick-max 219 09.01.14 12:38 Сейчас в теме
(22) SoulCast,

а для чего это может быть нужно? то есть, какой например может быть доп. параметр, и почему его нельзя получить уже внутри процедуры типа СформироватьАкт?
25. SoulCast 32 09.01.14 19:21 Сейчас в теме
(24) например получить текущую строку табличной части. У меня были печатные формы, которые получали данные по выбранной строке.
26. Dima69 9 07.03.14 10:05 Сейчас в теме
27. Dima69 9 07.03.14 10:09 Сейчас в теме
Да чуть не забыл, а не подскажите какие стандартные процедуры
ставят значок Дб-Кр (при ручной корректировки операции) в списке документов
28. nick-max 219 07.03.14 10:30 Сейчас в теме
(27) Dima69,

для выведения на форму кнопки ДтКт нужно добавить свой документ в общую команду ПоказатьДвиженияДокумента.
Но с точки зрения доработки типовой конфигурации с минимальными изменениями в типовых объектах лучше всего скопировать эту общую команду, назвать ПоказатьДвиженияМоегоДокумента и указывать в ней только свои документы. Тогда при обновлении кнопка ДтКт точно не слетит
29. Dima69 9 19.03.14 20:49 Сейчас в теме
Спасибо за ответ, но я имел в виду не кнопку ДтКт,
а значок ДтКт левее документа, операция которого отредактированна вручную, рядом
с зеленой галкой проведенного документа
30. sudmorsh 55 02.08.14 19:51 Сейчас в теме
Спасибо за статью очень пригодилась
31. jobkostya1c8 20.08.14 08:03 Сейчас в теме
Интересная статья про печать в БП 3.0 с использованием стандартных механизмов. Но, может быть, даже для новых нетиповых документов использовать внешние печатные формы если нужно оперативно (не выгоняя пользователей) исправить ошибку при печати?
Печатную форму сделать проще чем копаться в механизмах печати новых релизов? Постоянно ведь корректировать конфигурацию будет затруднительно? Особенно если новых документов много.
32. Astafan 11.11.14 08:15 Сейчас в теме
Спасибо за статью, очень пригодилась.
Но есть один вопрос: Создал в типовой конфигурации новый документ. Чтобы использовать механизм подключаемых печатных форм нужно редактировать команду "ДополнительныеОтчетыИОбработкиПечатныеФормы". НО при обновлении изменения слетят. Как правильно поступить в данном случае?
33. ekaterinaeon 25 28.11.14 08:53 Сейчас в теме
Нашла эту статью как раз в тот момент, когда больше всего была нужна) и помогло! спасибо!
34. helox 04.12.14 15:23 Сейчас в теме
В процедуре Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт 

	КомандаПечати = КомандыПечати.Добавить();
	КомандаПечати.Идентификатор = "Акт";
	КомандаПечати.Представление = "Дополнительный акт";
	КомандаПечати.Обработчик    = "УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати";
	КомандаПечати.СписокФорм    = "ФормаСписка,ФормаДокумента"; 

в списке форм должны быть наименования форм используемых при печати, добавил форму "ФормаДокументаУФ" - и долго гадал почему не появилась кнопочка печати!!
DarkUser; +1 Ответить
35. ronhard 29.01.15 17:52 Сейчас в теме
Также у этого списка обязательно должна быть колонка Ссылка, пусть даже невидимая
В конфигураторе на форме у колонки "Ссылка" должна стоять галочка "Использовать всегда", иначе невидимая колонка работать не будет, а только если она видимая.
A.Kurilov; bird21; PoZiTiFFF; cleaner_it; +4 Ответить
50. den_vrn 7 19.06.19 11:12 Сейчас в теме
(35)
"Использовать всегда"


не могу найти где эта галочка блин ....
36. ui69 41 11.02.15 13:50 Сейчас в теме
Спасибо, помогла данная статья. Создавал новый документ в БП 3.0 с двумя печатными формами.
37. Baser 5 12.02.16 09:07 Сейчас в теме
А можете ссылку дать, как это более правильно делать? Я уже который день пытаюсь понять, как свою печать через БСП пустить, а не по старинке, через команды; везде методики для использования во внешних печатных формах

Ну, вот почему так... как вопрос задал, так сразу и нашел... спасибо всем :)
http://its.1c.ru/db/bspdoc#content:219:1:issogl2_%D1%80%D0%B0%D0%B7%D1%80%D0%B0%D0%B1%D0%BE%D1%82%D0%­BA%D0%B0_%D0%BF%D1%80%D0%BE%D1%86%D0%B5%D0%B4%D1%83%D1%80%D1­%8B_%D0%BF%D0%B5%D1%87%D0%B0%D1%82%D1%8C
38. user590836_zhan_chick 08.07.16 14:24 Сейчас в теме
Теперь у меня программно добавились 2 лишние кнопки печати, которые мне не нужны. Помимо тех что созданы на форме вручную. Вопрос: как мне их убрать?
39. zmx 25.07.16 00:29 Сейчас в теме
В форме списка документа в процедуре ВыполнитьПодключаемуюКомандуПечати нужно поставить условие выполнения печати только, если документ проведен. Почему здесь не виден реквизит проведения документа?

Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)

Объект=Элементы.Список.ТекущаяСтрока;
Если Объект.Проведен = Ложь Тогда
Сообщить("Документ не проведен !!! Печать не возможна");
Возврат;
КонецЕсли;

УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Элементы.Список);
КонецПроцедуры

Спасибо заранее!
40. nick-max 219 25.09.16 03:24 Сейчас в теме
(39) zmx,

думаю, тут лучше использовать Элементы.Список.ТекущиеДанные.Ссылка.Проведен, при условии, что в список выведена колонка Ссылка. Но я бы такие проверки перенес внутрь функций типа СформироватьПриказ
41. Perk0n 13 31.07.17 11:12 Сейчас в теме
Be aware.. в новой БСП поменяли принцип подключения своих команд. Статью бы немного дополнить, так как в данном виде она утратила свою актуальность.

Вместо методов из "СтандартныеПодсистемы.Печать"

&НаКлиенте 
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)	
	УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект)	
КонецПроцедуры  


Следует использовать методы из "СтандартныеПодсистемы.ПодключаемыеКоманды"
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
	ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры
42. slauter77 19 06.10.17 10:17 Сейчас в теме
Спасибо за предупреждение! (41)
От себя добавлю, что например в Бух КОРП 3.0.52.39 нужно в модуле: "ОбщийМодуль.УправлениеПечатьюПереопределяемый"

в процедуру:
 Процедура ПриОпределенииОбъектовСКомандамиПечати(СписокОбъектов) Экспорт 


добавить строку типа:
СписокОбъектов.Добавить(Документы.ИмяВашегоДокумента)


тогда, с учетом изменений описанных Вами, печать заработает!

(просто сам долго копался с этим)
rmarkovych; insurgut; EMelihoff; lina_00; k0pai; ye_s; 777Ferz777; +7 Ответить
43. 777Ferz777 8 17.10.17 08:59 Сейчас в теме
С новыми обновами, новые веянья
Вызовы вида:
// СтандартныеПодсистемы.Печать
&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтотОбъект, Объект);
КонецПроцедуры
// Конец СтандартныеПодсистемы.Печать


следует заменить вызовами:

// СтандартныеПодсистемы.ПодключаемыеКоманды
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, <ОбъектИлиТаблицаФормы>);
КонецПроцедуры
 
&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, <ОбъектИлиТаблицаФормы>, Результат);
КонецПроцедуры
 
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды
Показать


более подробно читайте здесь http://downloads.v8.1c.ru/content/SSL/2_4_3_84/change.htm
44. nadjushka 19 28.03.18 10:10 Сейчас в теме
Добавление команд печати в Бухгалтерии 3.0 после релиза 3.0.52.35

http://1c-soft.it-terminal.ru/public/674880/
45. bds22 14 07.04.18 18:17 Сейчас в теме
в бухгалтерии корп 3.0 мне для того, чтобы появилась возможность печати в моем документе, пришлось в общем модуле "Управление печатью переопределяемый"
в эту процедуру добавить свой документ
Процедура ПриОпределенииОбъектовСКомандамиПечати(СписокОбъектов) Экспорт

там такие строки
СписокОбъектов.Добавить(Документы.ПоступлениеТоваровУслуг);
	СписокОбъектов.Добавить(Документы.ПринятиеКУчетуНМА);
	СписокОбъектов.Добавить(Документы.ПринятиеКУчетуОС);
	СписокОбъектов.Добавить(Документы.ПриходныйКассовыйОрдер);
	СписокОбъектов.Добавить(Документы.РаспределениеНДС);
	СписокОбъектов.Добавить(Документы.РасходныйКассовыйОрдер);

и так далее - все документы
rmarkovych; Артём74; CatZero; +3 Ответить
46. CatZero 12.04.18 06:57 Сейчас в теме
49. vis_tmp 29 18.04.19 19:47 Сейчас в теме
(45) А в самом документе что нужно добавить?
47. liric 26.09.18 17:28 Сейчас в теме
А если я хочу просто напечатать документ в своей самописанной конфе где нет никаких БСП и конструкторы печати теперь не работают. Что делать?
48. newvideo 27.01.19 13:52 Сейчас в теме
УНФ 1.6.5. БСП 2.3.1.53
в модуле УправлениеПечатьюСлужебныйКлиент
в процедуре ВыполнитьПодключаемуюКомандуПечатиПодготовкаОбъектовПечати
вываливается:

{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(125)}: Ошибка компиляции при вычислении выражения или выполнении фрагмента кода Результат = Вычислить(Обработчик);
по причине:
{(1,1)}: Переменная не определена (УправлениеПечатьюБПКлиент)
<<?>>УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати(ОписаниеКоманды)

Менял в Модуле Менеджера Документа
УправлениеПечатьюБПКлиент на УправлениеПечатьюКлиент и также на
Подключаемый_ВыполнитьКомандуПечати
всёравно ошибки, куда же копать?
51. XelOla 15 06.09.19 15:49 Сейчас в теме
(48) вы разобрались?
ТОже не могу для УНФ вывести
52. newvideo 06.09.19 21:00 Сейчас в теме
(51) давно это было, помню только что разобрался, а что именно сделал к сожалению уже не вспомню) Но конфигурация под рукой, могу сказать что где есть)
Оставьте свое сообщение

См. также

Агрегатные функции СКД, о которых мало кто знает 316

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    9732    ids79    42       

Отслеживание выполнения фонового задания 133

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    8072    ids79    14       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 241

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    10133    ids79    24       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 126

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    9096    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 134

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования Разработка

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    8550    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 170

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    6153    SeiOkami    48       

Создание отчетов с помощью СКД - основные понятия и элементы 192

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    17215    ids79    16       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 176

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    11432    dmurk    134       

Подсистема "Варианты отчетов". Используете ли Вы ее правильно? 208

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом БСП (Библиотека стандартных подсистем)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    14040    YPermitin    49       

Регистры накопления. Структура хранения в базе данных 174

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    17103    YPermitin    27       

Выполнение внешней обработки в фоновом задании 147

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    9714    Eret1k    22       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4746    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7264    m-rv    16       

О расширениях замолвите слово... 192

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    16237    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 200

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    12618    ellavs    83       

Трюки с внешними источниками данных 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    12732    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 162

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    15315    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12615    ids79    27       

Новый подход к обмену данными EnterpriseData 203

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    21265    ids79    72       

Программное заполнение пользовательских параметров и отборов СКД 135

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    19454    Unk92    18       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 126

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20719    ids79    40       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20362    tormozit    100       

Произвольный код в фоновом режиме 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    14496    nikita0832    41       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 144

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    21104    Rain88    42       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19220    olegtymko    43       

Введение в механизм представлений в ЗУП ред. 3 152

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    24238    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21104    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    16887    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11273    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 126

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    24216    avfed@rambler.ru    19       

Минимализмы 3 350

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35434    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 108

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25755    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21247    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 720

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    137140    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    22600    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 66

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    20976    unichkin    17       

Разбираемся с настройками компоновки данных 159

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    23944    json    9       

Работа с Excel 288

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24517    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46602    bugtester    43       

Отказ от работы с временными файлами при работе с двоичными данными или Потоки как простая замена ADODB.Stream и временным файлам 127

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

В платформе начиная с версии 3.8.9 (как я понял по документации) появился расширенный функционал средств работы с двоичными данными. Если раньше простой и очевидный способ преобразования данных строился на использовании временных файлов, то теперь благодаря новым средствам можно уйти от их использования.

12.09.2017    18152    vardeg    31       

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере 125

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    34128    tormozit    72       

Ускоряем 1С: модули с повторным использованием возвращаемых значений 136

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    43014    m-rv    60       

Как просто запомнить алгоритм программного вывода в СКД 205

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования

Порой нужно быстро вывести на экран таблицу значений, используя СКД \ получить данные отчета в таблицу значений.. Несмотря на очевидность алгоритма - раньше мне проще было загуглить программный вывод, благо эта инфа есть везде. Но постепенно понял как его можно быстро вспомнить, и лишний раз ничего не искать. Конечно эта статья не для Гуру :) Но я думаю - что любой неопытный в СКД программист сделает для себя небольшое открытие...

01.09.2017    41417    unichkin    15       

Как формируется GUID? 462

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

"Коллеги, есть идеи, как получить последнюю созданную характеристику? Реквизиты полностью идентичны(код, наименование, и т.п.)."(c) "Насколько я знаю, ссылка не обеспечивает последовательность, а только уникальность."(c) "Я сделал по Максимум(Ссылка). Но, чета, мне кажется, это неправильно."(c) "Слышал что в ГУИд содержится как раз время создания и по всей логике вещей сортировка по ссылке должна сортировать по моменту создания объекта"(c) Сколько раз вы слышали такие фразы? На удивление я не обнаружил информации по этой теме, пришлось разбираться самому...

16.06.2017    52167    kuzyara    55