Перевод отчетов на иностранный язык

Публикация № 238484

Разработка - Практика программирования

Перевод английский english иностранный

Как с минимальными доработками получить отчетность на иностранном языке в любой конфигурации 1С.

Иногда бывает необходимо быстро "перевести" ряд отчетов системы на иностранный язык.
Например, для клиентов или для сотрудников-экспатов.

Классический пример - перевод ОСВ или отчета о финансовых результатах.

Можно пойти по пути добавления в основные справочники конфигурации дополнительных реквизитов, создания дублей макетов с шапками на иностранном языке и т.п.

Далеко не все специалисты 1С знают, что если для конфигурации указано несколько языков, то макеты можно делать мультиязычными, выбирая текст и формат ячейки для каждого языка - свой. При формировании отчета достаточно указать код языка для выводимой области - и отчет сформируется на нужном языке. 

В 8.3 можно переопределить представление справочников и документов, этим тоже можно пользоваться.

Я предлагаю еще один простой метод - перевод готовых табличных документов с использованием словаря.

Добавляем в конфигурацию регистр сведений Словарь с измерением Термин и ресурсом Перевод и пишем процедуру общего модуля, обрабатывающую любой табличный документ. Теперь нам достаточно лишь вставить в модуль отчета вызов процедуры. Причем можно даже не менять форму отчета - достаточно сделать отдельный параметр сеанса, форму для его изменения и анализ этого параметра в процедуре перевода.

В моем примере предполагается, что в один из справочников НСИ (Контрагенты) все-таки  добавили реквизит НаименованиеИностранное, остальной перевод идет по Словарю.  Можно доработать процедуру для рекурсивного или циклического перевода сложных строк, пока проверка выполняется один раз. Для каждой строки из областей табличного документа в словаре ищется подходящая подстрока максимальной длины и осуществляется замена.

Пример написан для толстого клиента. В нем вызывается форма индикатора из конфигурации (замените на свою, если необходимо). Код написан неоптимально, но думаю, понятно.

Вот код:

// Транслирует табличный документ на другой язык при помощи словаря

Процедура ПеревестиТабличныйДокумент(ТД) Экспорт

	
	кс=ТД.ВысотаТаблицы;
	кк=ТД.ШиринаТаблицы;
	
	/// вызовем индикатор
	ФИ=ПолучитьОбщуюФорму("ФормаИндикатора");
	ФИ.МаксимальноеЗначение=кс*кк;
	ФИ.НадписьСостоянияИндикатораОбщая="Перевод отчета на английский язык";
	Фи.Открыть();

	ФИ.НадписьСостоянияИндикатораТекущая="Выбираю иностранные наименования контрагентов...";
	ЗапросИностранныхНаименований=Новый Запрос("ВЫБРАТЬ
	                                           |	Контрагенты.Наименование КАК Наименование,
	                                           |	0 КАК ДлинаТекста,
	                                           |	Контрагенты.НаименованиеИностранное,
	                                           |	Контрагенты.НаименованиеПолное КАК НаименованиеПолное
	                                           |ПОМЕСТИТЬ ИностранныеНаименования
	                                           |ИЗ
	                                           |	Справочник.Контрагенты КАК Контрагенты
	                                           |ГДЕ
	                                           |	Контрагенты.НаименованиеИностранное ПОДОБНО ""%[0-z]%""
	                                           |
	                                           |ИНДЕКСИРОВАТЬ ПО
	                                           |	Наименование,
	                                           |	НаименованиеПолное");
											   
    	МВТ=Новый МенеджерВременныхТаблиц;
	ЗапросИностранныхНаименований.МенеджерВременныхТаблиц=МВТ;
	ЗапросИностранныхНаименований.Выполнить();										   
	
	Запрос=Новый Запрос("ВЫБРАТЬ
	                    |	Словарь.Перевод,
	                    |	Словарь.Термин КАК Термин
	                    |ПОМЕСТИТЬ ВесьСловарь
	                    |ИЗ
	                    |	РегистрСведений.Словарь КАК Словарь
	                    |
	                    |ИНДЕКСИРОВАТЬ ПО
	                    |	Термин");
	Запрос.МенеджерВременныхТаблиц=МВТ;					
	Запрос.Выполнить();
	
	Запрос.Текст="ВЫБРАТЬ
	                    |	Словарь.Перевод,
	                    |	0 КАК ДлинаТекста,
	                    |	Словарь.Термин
	                    |ИЗ
	                    |	ВесьСловарь КАК Словарь
	                    |ГДЕ
	                    |	&Термин ПОДОБНО ""%"" + Словарь.Термин + ""%""";
						
	
						
	ЗапросСинонима=Новый Запрос("
						|ВЫБРАТЬ
	                    |	Словарь.НаименованиеИностранное как Перевод,
	                    |	0 КАК ДлинаТекста,
	                    |	Словарь.НаименованиеПолное как Термин
	                    |ИЗ
	                    |	ИностранныеНаименования КАК Словарь
	                    |ГДЕ
	                    |	&Термин ПОДОБНО ""%"" + Словарь.НаименованиеПолное + ""%""
			    |   И Словарь.НаименованиеПолное ПОДОБНО ""%[0-я]%""
	   		    |ОБЪЕДИНИТЬ ВСЕ
			    |ВЫБРАТЬ
	                    |	Словарь.НаименованиеИностранное как Перевод,
	                    |	0 КАК ДлинаТекста,
	                    |	Словарь.Наименование как Термин
	                    |ИЗ
	                    |	ИностранныеНаименования КАК Словарь
	                    |ГДЕ
	                    |	&Термин ПОДОБНО ""%"" + Словарь.Наименование + ""%""");
						
	ЗапросСинонима.МенеджерВременныхТаблиц=МВТ;					
						
	ФИ.НадписьСостоянияИндикатораТекущая="";				
	Для ы=1 По кс Цикл
		Для к=1 По кк Цикл
			
		//проверим на объединение
		Область = ТД.Область(ы, к);
		Если Область.Право > Область.Лево ИЛИ Область.Низ > Область.Верх Тогда
			Обл=ТД.Область(ы,к,Область.Низ,Область.Право);			
		Иначе	
			Обл=ТД.Область(ы,к,ы,к);
		КонецЕсли;	
		
		Термин=СокрЛП(Обл.Текст);
		мСодержитсяЗначение=Ложь;
		
		Если Обл.СодержитЗначение И ТипЗнч(Обл.Значение)=Тип("Строка")
			И ЗначениеЗаполнено(Обл.Значение) Тогда
			
			мСодержитсяЗначение=Истина;
			Термин= СокрЛП(Обл.Значение) ;
		КонецЕсли;	
		
		Если НЕ ЗначениеЗаполнено(Термин) ИЛИ (Обл.СодержитЗначение И НЕ мСодержитсяЗначение) Тогда
			Продолжить;
		КонецЕсли;	
		
		ФИ.ЗначениеИндикатора=((ы-1)*кк)+к;		
		
		Если ЗначениеЗаполнено(Термин) Тогда
			// пример замены отчетной даты в отчетности РСБУ:
			  Если Найти(Термин,"На ")>0 ИЛИ Найти(Термин,"на ")>0 Тогда
			     Для ю=-25 По 12 Цикл
			      ОтчетнаяДата=КонецМесяца(ДобавитьМесяц(НачалоГода(ТекущаяДата()),ю)); 
			      СтрокаОтчетнойДаты=Формат(ОтчетнаяДата,"ДЛФ=DD");
			      СтрокаОтчетнойДаты=СтрЗаменить(СтрокаОтчетнойДаты,Символы.НПП," "); 
			      Если Найти(Термин2,СтрокаОтчетнойДаты )>0 Тогда
			       Если НЕ мСодержитсяЗначение Тогда
				     Обл.Текст=СтрЗаменить(Термин2, "На ", "As at "); 
				     Обл.Текст=СтрЗаменить(Обл.Текст, "на ", "as at ");
				     Обл.Текст=СтрЗаменить(Обл.Текст, СтрокаОтчетнойДаты ,Формат(ОтчетнаяДата,"Л=en; ДЛФ=DD"));       Иначе        Обл.Значение=СтрЗаменить(Термин2, "На ", "As at ");        Обл.Значение=СтрЗаменить(Обл.Значение, "на ", "as at ");        Обл.Значение=СтрЗаменить(Обл.Значение, СтрокаОтчетнойДаты,Формат(ОтчетнаяДата,"Л=en; ДЛФ=DD"));              
				КонецЕсли;
			       Прервать; 
			     КонецЕсли;
		  	    КонецЦикла;
	            	КонецЕсли;  
			
			// Проверим по таблице иностранных наименований
			ЗапросСинонима.УстановитьПараметр("Термин",Термин);
			Результаты=ЗапросСинонима.Выполнить().Выгрузить();
			Для Каждого р ИЗ Результаты Цикл
				р.ДлинаТекста=СтрДлина(СокрЛП(р.Перевод));
			КонецЦикла;	
			Результаты.Сортировать("ДлинаТекста Убыв");
			
			Если Результаты.Количество()>0 Тогда
				Перевод=СокрЛП(Результаты[0].Перевод);
				ФИ.НадписьСостоянияИндикатораТекущая=Термин+"->"+Перевод;
				
				Если НЕ мСодержитсяЗначение Тогда
					Обл.Текст=СтрЗаменить(Обл.Текст,Результаты[0].Термин,Перевод);
				Иначе
					Обл.Значение=СтрЗаменить(Обл.Значение,Результаты[0].Термин,Перевод);
				КонецЕсли;	
			КонецЕсли;	
			Термин=СокрЛП(Обл.Текст);
			
			// Проверим по СЛОВАРЮ
			Запрос.УстановитьПараметр("Термин",Термин);
			Результаты=Запрос.Выполнить().Выгрузить();
			Для Каждого р ИЗ Результаты Цикл
				р.ДлинаТекста=СтрДлина(СокрЛП(р.Перевод));
			КонецЦикла;	
			Результаты.Сортировать("ДлинаТекста Убыв");
			
			Если Результаты.Количество()>0 Тогда
				Перевод=СокрЛП(Результаты[0].Перевод);
				ФИ.НадписьСостоянияИндикатораТекущая=Термин+"->"+Перевод;
				Если НЕ мСодержитсяЗначение Тогда
					Обл.Текст=СтрЗаменить(Обл.Текст,Результаты[0].Термин,Перевод);
				Иначе
					Обл.Значение=СтрЗаменить(Обл.Значение,Результаты[0].Термин,Перевод);
				КонецЕсли;	
			КонецЕсли;	
			
			
        КонецЕсли;

		Фи.Обновить();
		КонецЦикла;
	КонецЦикла;	
    ФИ.Закрыть();
	МВТ.Закрыть();	

КонецПроцедуры	
 
 
 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Vladimir Litvinenko 28.11.13 07:40 Сейчас в теме
Интересное решение для простых случаев перевода, когда перевод фразы не зависит от контекста. Ну а если будет зависеть, то достаточно добавить в регистр "Словарь" еще одно измерение - "Контекст". Постобработка табличных документов часто позволяет делать интересные вещи проще, чем другие методы.
2. vtolga 82 04.12.13 09:51 Сейчас в теме
делали что-то подобное, но словарь лежал просто в exel файле (конфигурация типовая)
3. poyson 04.12.13 10:54 Сейчас в теме
Известная проблема. В данном контексте отличное решение.
4. Rad90210 13 05.12.13 12:10 Сейчас в теме
В догонку: http://infostart.ru/public/150952/
Ребят, есть реально кто-нить который в 1С вставлял иероглифы?
5. Rad90210 13 05.12.13 12:12 Сейчас в теме
Кста - дорабатывал конфу чтобы первичное заполнение перевода в 1С сразу тянулось с Яндекса (или Гугла). Экономит время :)
Эх... Где же подписка на событие при открытии ...
6. mzelensky 53 25.12.13 08:35 Сейчас в теме
Я делал чуть более продвинутый вариант (в плане использования словарей).

В результате вот пример документа заполненного автоматически на 3 языках (Русский, Английский, Персидский)
Прикрепленные файлы:
7. DAnry 7 26.12.13 23:06 Сейчас в теме
Интересное решение достаточно актуальной проблемы. У нас в Украине еще много типовых конфигураций только с одним русским языком интерфейса. Пора наводить порядок.
8. oleg212 03.01.14 00:37 Сейчас в теме
Интересное решение, спасибо за код
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37788    unichkin    74    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    7856    quazare    33    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    30599    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    26437    John_d    22    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30975    tormozit    100    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    20124    kuzyara    33    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    17662    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8792    Sibars    19    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    78491    tormozit    131    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    30872    HostHost    40    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    35631    Yashazz    50    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    12681    budidich    28    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    49042    tormozit    42    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    55418    rpgshnik    63    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    52523    ids79    54    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    30096    YPermitin    24    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    45468    tormozit    74    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    26045    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    32773    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    91090    ids79    51    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16203    m-rv    2    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    38526    avalakh    25    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    25636    json    15    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    65362    ids79    12    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20578    m-rv    17    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    37318    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    26915    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19954    SeiOkami    50    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    31302    m-rv    21    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    51031    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    55409    ids79    25    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    25915    dmurk    146    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28499    itriot11    34    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    45279    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    36214    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27847    ellavs    90    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    77139    Serginio    110    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    32326    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    42308    Смешной 1С    30    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    22845    Vladimir Litvinenko    27    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    35689    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    41970    ids79    9    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29587    grumagargler    28    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    27666    ids79    31    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    42827    ids79    72    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    53529    m-rv    61    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    38207    ids79    42    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    50779    Unk92    25