Перевод отчетов на иностранный язык

Публикация № 238484

Разработка - Практика программирования

Перевод английский english иностранный

10
Как с минимальными доработками получить отчетность на иностранном языке в любой конфигурации 1С.

Иногда бывает необходимо быстро "перевести" ряд отчетов системы на иностранный язык.
Например, для клиентов или для сотрудников-экспатов.

Классический пример - перевод ОСВ или отчета о финансовых результатах.

Можно пойти по пути добавления в основные справочники конфигурации дополнительных реквизитов, создания дублей макетов с шапками на иностранном языке и т.п.

Далеко не все специалисты 1С знают, что если для конфигурации указано несколько языков, то макеты можно делать мультиязычными, выбирая текст и формат ячейки для каждого языка - свой. При формировании отчета достаточно указать код языка для выводимой области - и отчет сформируется на нужном языке. 

В 8.3 можно переопределить представление справочников и документов, этим тоже можно пользоваться.

Я предлагаю еще один простой метод - перевод готовых табличных документов с использованием словаря.

Добавляем в конфигурацию регистр сведений Словарь с измерением Термин и ресурсом Перевод и пишем процедуру общего модуля, обрабатывающую любой табличный документ. Теперь нам достаточно лишь вставить в модуль отчета вызов процедуры. Причем можно даже не менять форму отчета - достаточно сделать отдельный параметр сеанса, форму для его изменения и анализ этого параметра в процедуре перевода.

В моем примере предполагается, что в один из справочников НСИ (Контрагенты) все-таки  добавили реквизит НаименованиеИностранное, остальной перевод идет по Словарю.  Можно доработать процедуру для рекурсивного или циклического перевода сложных строк, пока проверка выполняется один раз. Для каждой строки из областей табличного документа в словаре ищется подходящая подстрока максимальной длины и осуществляется замена.

Пример написан для толстого клиента. В нем вызывается форма индикатора из конфигурации (замените на свою, если необходимо). Код написан неоптимально, но думаю, понятно.

Вот код:

// Транслирует табличный документ на другой язык при помощи словаря

Процедура ПеревестиТабличныйДокумент(ТД) Экспорт

	
	кс=ТД.ВысотаТаблицы;
	кк=ТД.ШиринаТаблицы;
	
	/// вызовем индикатор
	ФИ=ПолучитьОбщуюФорму("ФормаИндикатора");
	ФИ.МаксимальноеЗначение=кс*кк;
	ФИ.НадписьСостоянияИндикатораОбщая="Перевод отчета на английский язык";
	Фи.Открыть();

	ФИ.НадписьСостоянияИндикатораТекущая="Выбираю иностранные наименования контрагентов...";
	ЗапросИностранныхНаименований=Новый Запрос("ВЫБРАТЬ
	                                           |	Контрагенты.Наименование КАК Наименование,
	                                           |	0 КАК ДлинаТекста,
	                                           |	Контрагенты.НаименованиеИностранное,
	                                           |	Контрагенты.НаименованиеПолное КАК НаименованиеПолное
	                                           |ПОМЕСТИТЬ ИностранныеНаименования
	                                           |ИЗ
	                                           |	Справочник.Контрагенты КАК Контрагенты
	                                           |ГДЕ
	                                           |	Контрагенты.НаименованиеИностранное ПОДОБНО ""%[0-z]%""
	                                           |
	                                           |ИНДЕКСИРОВАТЬ ПО
	                                           |	Наименование,
	                                           |	НаименованиеПолное");
											   
    	МВТ=Новый МенеджерВременныхТаблиц;
	ЗапросИностранныхНаименований.МенеджерВременныхТаблиц=МВТ;
	ЗапросИностранныхНаименований.Выполнить();										   
	
	Запрос=Новый Запрос("ВЫБРАТЬ
	                    |	Словарь.Перевод,
	                    |	Словарь.Термин КАК Термин
	                    |ПОМЕСТИТЬ ВесьСловарь
	                    |ИЗ
	                    |	РегистрСведений.Словарь КАК Словарь
	                    |
	                    |ИНДЕКСИРОВАТЬ ПО
	                    |	Термин");
	Запрос.МенеджерВременныхТаблиц=МВТ;					
	Запрос.Выполнить();
	
	Запрос.Текст="ВЫБРАТЬ
	                    |	Словарь.Перевод,
	                    |	0 КАК ДлинаТекста,
	                    |	Словарь.Термин
	                    |ИЗ
	                    |	ВесьСловарь КАК Словарь
	                    |ГДЕ
	                    |	&Термин ПОДОБНО ""%"" + Словарь.Термин + ""%""";
						
	
						
	ЗапросСинонима=Новый Запрос("
						|ВЫБРАТЬ
	                    |	Словарь.НаименованиеИностранное как Перевод,
	                    |	0 КАК ДлинаТекста,
	                    |	Словарь.НаименованиеПолное как Термин
	                    |ИЗ
	                    |	ИностранныеНаименования КАК Словарь
	                    |ГДЕ
	                    |	&Термин ПОДОБНО ""%"" + Словарь.НаименованиеПолное + ""%""
			    |   И Словарь.НаименованиеПолное ПОДОБНО ""%[0-я]%""
	   		    |ОБЪЕДИНИТЬ ВСЕ
			    |ВЫБРАТЬ
	                    |	Словарь.НаименованиеИностранное как Перевод,
	                    |	0 КАК ДлинаТекста,
	                    |	Словарь.Наименование как Термин
	                    |ИЗ
	                    |	ИностранныеНаименования КАК Словарь
	                    |ГДЕ
	                    |	&Термин ПОДОБНО ""%"" + Словарь.Наименование + ""%""");
						
	ЗапросСинонима.МенеджерВременныхТаблиц=МВТ;					
						
	ФИ.НадписьСостоянияИндикатораТекущая="";				
	Для ы=1 По кс Цикл
		Для к=1 По кк Цикл
			
		//проверим на объединение
		Область = ТД.Область(ы, к);
		Если Область.Право > Область.Лево ИЛИ Область.Низ > Область.Верх Тогда
			Обл=ТД.Область(ы,к,Область.Низ,Область.Право);			
		Иначе	
			Обл=ТД.Область(ы,к,ы,к);
		КонецЕсли;	
		
		Термин=СокрЛП(Обл.Текст);
		мСодержитсяЗначение=Ложь;
		
		Если Обл.СодержитЗначение И ТипЗнч(Обл.Значение)=Тип("Строка")
			И ЗначениеЗаполнено(Обл.Значение) Тогда
			
			мСодержитсяЗначение=Истина;
			Термин= СокрЛП(Обл.Значение) ;
		КонецЕсли;	
		
		Если НЕ ЗначениеЗаполнено(Термин) ИЛИ (Обл.СодержитЗначение И НЕ мСодержитсяЗначение) Тогда
			Продолжить;
		КонецЕсли;	
		
		ФИ.ЗначениеИндикатора=((ы-1)*кк)+к;		
		
		Если ЗначениеЗаполнено(Термин) Тогда
			// пример замены отчетной даты в отчетности РСБУ:
			  Если Найти(Термин,"На ")>0 ИЛИ Найти(Термин,"на ")>0 Тогда
			     Для ю=-25 По 12 Цикл
			      ОтчетнаяДата=КонецМесяца(ДобавитьМесяц(НачалоГода(ТекущаяДата()),ю)); 
			      СтрокаОтчетнойДаты=Формат(ОтчетнаяДата,"ДЛФ=DD");
			      СтрокаОтчетнойДаты=СтрЗаменить(СтрокаОтчетнойДаты,Символы.НПП," "); 
			      Если Найти(Термин2,СтрокаОтчетнойДаты )>0 Тогда
			       Если НЕ мСодержитсяЗначение Тогда
				     Обл.Текст=СтрЗаменить(Термин2, "На ", "As at "); 
				     Обл.Текст=СтрЗаменить(Обл.Текст, "на ", "as at ");
				     Обл.Текст=СтрЗаменить(Обл.Текст, СтрокаОтчетнойДаты ,Формат(ОтчетнаяДата,"Л=en; ДЛФ=DD"));       Иначе        Обл.Значение=СтрЗаменить(Термин2, "На ", "As at ");        Обл.Значение=СтрЗаменить(Обл.Значение, "на ", "as at ");        Обл.Значение=СтрЗаменить(Обл.Значение, СтрокаОтчетнойДаты,Формат(ОтчетнаяДата,"Л=en; ДЛФ=DD"));              
				КонецЕсли;
			       Прервать; 
			     КонецЕсли;
		  	    КонецЦикла;
	            	КонецЕсли;  
			
			// Проверим по таблице иностранных наименований
			ЗапросСинонима.УстановитьПараметр("Термин",Термин);
			Результаты=ЗапросСинонима.Выполнить().Выгрузить();
			Для Каждого р ИЗ Результаты Цикл
				р.ДлинаТекста=СтрДлина(СокрЛП(р.Перевод));
			КонецЦикла;	
			Результаты.Сортировать("ДлинаТекста Убыв");
			
			Если Результаты.Количество()>0 Тогда
				Перевод=СокрЛП(Результаты[0].Перевод);
				ФИ.НадписьСостоянияИндикатораТекущая=Термин+"->"+Перевод;
				
				Если НЕ мСодержитсяЗначение Тогда
					Обл.Текст=СтрЗаменить(Обл.Текст,Результаты[0].Термин,Перевод);
				Иначе
					Обл.Значение=СтрЗаменить(Обл.Значение,Результаты[0].Термин,Перевод);
				КонецЕсли;	
			КонецЕсли;	
			Термин=СокрЛП(Обл.Текст);
			
			// Проверим по СЛОВАРЮ
			Запрос.УстановитьПараметр("Термин",Термин);
			Результаты=Запрос.Выполнить().Выгрузить();
			Для Каждого р ИЗ Результаты Цикл
				р.ДлинаТекста=СтрДлина(СокрЛП(р.Перевод));
			КонецЦикла;	
			Результаты.Сортировать("ДлинаТекста Убыв");
			
			Если Результаты.Количество()>0 Тогда
				Перевод=СокрЛП(Результаты[0].Перевод);
				ФИ.НадписьСостоянияИндикатораТекущая=Термин+"->"+Перевод;
				Если НЕ мСодержитсяЗначение Тогда
					Обл.Текст=СтрЗаменить(Обл.Текст,Результаты[0].Термин,Перевод);
				Иначе
					Обл.Значение=СтрЗаменить(Обл.Значение,Результаты[0].Термин,Перевод);
				КонецЕсли;	
			КонецЕсли;	
			
			
        КонецЕсли;

		Фи.Обновить();
		КонецЦикла;
	КонецЦикла;	
    ФИ.Закрыть();
	МВТ.Закрыть();	

КонецПроцедуры	
 
 
 
10

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Vladimir Litvinenko 28.11.13 07:40 Сейчас в теме
Интересное решение для простых случаев перевода, когда перевод фразы не зависит от контекста. Ну а если будет зависеть, то достаточно добавить в регистр "Словарь" еще одно измерение - "Контекст". Постобработка табличных документов часто позволяет делать интересные вещи проще, чем другие методы.
2. vtolga 79 04.12.13 09:51 Сейчас в теме
делали что-то подобное, но словарь лежал просто в exel файле (конфигурация типовая)
3. poyson 04.12.13 10:54 Сейчас в теме
Известная проблема. В данном контексте отличное решение.
4. Rad90210 13 05.12.13 12:10 Сейчас в теме
В догонку: http://infostart.ru/public/150952/
Ребят, есть реально кто-нить который в 1С вставлял иероглифы?
5. Rad90210 13 05.12.13 12:12 Сейчас в теме
Кста - дорабатывал конфу чтобы первичное заполнение перевода в 1С сразу тянулось с Яндекса (или Гугла). Экономит время :)
Эх... Где же подписка на событие при открытии ...
6. mzelensky 52 25.12.13 08:35 Сейчас в теме
Я делал чуть более продвинутый вариант (в плане использования словарей).

В результате вот пример документа заполненного автоматически на 3 языках (Русский, Английский, Персидский)
Прикрепленные файлы:
7. DAnry 6 26.12.13 23:06 Сейчас в теме
Интересное решение достаточно актуальной проблемы. У нас в Украине еще много типовых конфигураций только с одним русским языком интерфейса. Пора наводить порядок.
8. oleg212 03.01.14 00:37 Сейчас в теме
Интересное решение, спасибо за код
Оставьте свое сообщение

См. также

Агрегатные функции СКД, о которых мало кто знает 315

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    9570    ids79    42       

Три костыля. Сказ про фокусы в коде 121

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    7602    YPermitin    67       

Отслеживание выполнения фонового задания 133

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    7949    ids79    14       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 240

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    9932    ids79    22       

Фоновое выполнение кода в 1С - это просто 117

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    9619    avalakh    21       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 126

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    8947    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 134

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования Разработка

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    8421    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 170

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    6120    SeiOkami    48       

Создание отчетов с помощью СКД - основные понятия и элементы 190

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    17052    ids79    16       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 175

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    11347    dmurk    134       

Регистры накопления. Структура хранения в базе данных 174

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    17003    YPermitin    27       

Выполнение внешней обработки в фоновом задании 147

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    9623    Eret1k    22       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4704    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7211    m-rv    16       

О расширениях замолвите слово... 192

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    16145    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 200

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    12548    ellavs    83       

Трюки с внешними источниками данных 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    12667    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 162

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    15205    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12538    ids79    27       

Новый подход к обмену данными EnterpriseData 202

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    21119    ids79    72       

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации 117

Статья Программист Нет файла v8 v8::УФ БП3.0 УТ11 Россия Windows Бесплатно (free) Практика программирования Обмен через XML

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    18680    ids79    20       

Программное заполнение пользовательских параметров и отборов СКД 135

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    19284    Unk92    18       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 125

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20652    ids79    40       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20300    tormozit    100       

Произвольный код в фоновом режиме 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    14438    nikita0832    41       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 144

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    20992    Rain88    42       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19157    olegtymko    43       

Введение в механизм представлений в ЗУП ред. 3 152

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    24169    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21063    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    16825    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11234    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 126

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    24081    avfed@rambler.ru    19       

Минимализмы 3 350

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35347    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 108

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25718    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21210    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 718

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    136790    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    22538    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 65

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    20938    unichkin    17       

Разбираемся с настройками компоновки данных 159

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    23892    json    9       

Работа с Excel 287

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24392    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46452    bugtester    43       

Отказ от работы с временными файлами при работе с двоичными данными или Потоки как простая замена ADODB.Stream и временным файлам 126

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

В платформе начиная с версии 3.8.9 (как я понял по документации) появился расширенный функционал средств работы с двоичными данными. Если раньше простой и очевидный способ преобразования данных строился на использовании временных файлов, то теперь благодаря новым средствам можно уйти от их использования.

12.09.2017    18100    vardeg    31