Переводчик конфигурации (диалоговые формы)

Публикация № 150952

Учет и отчетность - Производство готовой продукции (работ, услуг)

13
Попытки перевести типовую конфигурацию малой кровью. По возможности с сохранением поддержки.

Собственно получил задачу: перевести типовую УТ на КИТАЙСКИЙ (английский). Собственно - результат работы - то что получилось ниже. В файлах ничего выкладывать не буду - если кому интересно перевести конфу на английский - дочитает до конца.

Коротко - алгоритм такой: ПриОткрытии() - перебирать все реквизиты Формы и подставлять значения ПЕРЕВЕДЁННЫЕ.

Еще что стоит отметить - не пинайте сильно - таки первая публикация.

 

Итак: Общий модуль ПереводАнгл:

Функция УстановитьНадписиФормыАнгл(ДокументОбъект="", ФормаДокумента) Экспорт 	
	Если ПараметрыСеанса.ТекущийПользователь.Язык =0 тогда // естественно флаг язык - в спр.пользователи 
		Возврат Истина 	
	КонецЕсли;
	Попытка
		ФормаДокумента.Заголовок=ПереводАнгл.ПереводимЭлемент(ФормаДокумента.Заголовок);
	Исключение
	КонецПопытки;
	Попытка
		Для каждого элемент из ФормаДокумента.ЭлементыФормы цикл 			
			Если СокрЛП(Элемент)="Надпись" тогда
				Элемент.Заголовок=ПереводАнгл.ПереводимЭлемент(Элемент.Заголовок);
			КонецЕсли;
			Если СокрЛП(Элемент)="РамкаГруппы" тогда 
				Элемент.Заголовок=ПереводАнгл.ПереводимЭлемент(Элемент.Заголовок);
			КонецЕсли;
			Если СокрЛП(Элемент)="Кнопка" тогда 	
				ЧтоПолучилось = Элемент.Заголовок;
				ЧтоПолучилось = ПереводАнгл.ПереводимЭлемент(Элемент.Заголовок);
				Элемент.Заголовок = ЧтоПолучилось;
			КонецЕсли;
			Если СокрЛП(Элемент)="КоманднаяПанель" тогда 	
				Для Каждого Кнопка из Элемент.Кнопки Цикл 	
					ЧтоПолучилось = Кнопка.Текст;
					ЧтоПолучилось = ПереводАнгл.ПереводимЭлемент(Кнопка.Текст);
					Кнопка.Подсказка = ЧтоПолучилось;
					Кнопка.Пояснение = ЧтоПолучилось;
					Кнопка.Текст = ЧтоПолучилось;
					Для Каждого Кнопа из Кнопка.Кнопки Цикл 
						ЧтоПолучилось = Кнопа.Текст;
						ЧтоПолучилось = ПереводАнгл.ПереводимЭлемент(Кнопа.Текст);
						Кнопа.Подсказка = ЧтоПолучилось;
						Кнопа.Пояснение = ЧтоПолучилось;
						Кнопа.Текст = ЧтоПолучилось;
					КонецЦИкла;
				КонецЦикла;
			КонецЕсли;
			Если СокрЛП(Элемент)="Панель" тогда 
				Для Каждого страница из Элемент.Страницы Цикл 
					страница.Заголовок = ПереводАнгл.ПереводимЭлемент(страница.Заголовок);
				КонецЦикла;
			ИначеЕсли СокрЛП(Элемент)="ТабличноеПоле" тогда 
				Для каждого колонка из Элемент.Колонки цикл 	
					Колонка.ТекстШапки = ПереводАнгл.ПереводимЭлемент(Колонка.ТекстШапки);
				КонецЦикла;
			ИначеЕсли СОкрЛП(Элемент)="Флажок" тогда 		
				Элемент.Заголовок = ПереводАнгл.ПереводимЭлемент(Элемент.Заголовок);
			КонецЕсли;
		КонецЦикла;
	Исключение
	КонецПопытки;
	Попытка
		Для Каждого КолонкаСправочника из ФормаДокумента.ЭлементыФормы.СправочникСписок.Колонки Цикл
			КолонкаСправочника.ТекстШапки = ПереводАнгл.ПереводимЭлемент(КолонкаСправочника.ТекстШапки);
		КонецЦикла;
	Исключение
	КонецПопытки;
	Попытка
		Для Каждого панель из ФормаДокумента.ЭлементыФормы.ПанельФормы.Страницы Цикл
			панель.Заголовок = ПереводАнгл.ПереводимЭлемент(панель.Заголовок);
		КонецЦикла;
	Исключение 
	КонецПопытки;
	Попытка
		Для каждого кнопка из ФормаДокумента.ЭлементыФормы.ДействияФормы.Кнопки Цикл
			кнопка.Текст=ПереводАнгл.ПереводимЭлемент(кнопка.Текст);
			Если Лев(кнопка.Имя,8)="Действие" тогда
				ЧтоПолучилось=кнопка.Текст;
				ЧтоПолучилось = ПереводАнгл.ПереводимЭлемент(кнопка.Текст);
				кнопка.Текст=ЧтоПолучилось;
				кнопка.Пояснение=ЧтоПолучилось;
			КонецЕсли;
		КонецЦикла;
	Исключение
	КонецПопытки;
	Попытка
		Для каждого кнопка из ФормаДокумента.ЭлементыФормы.ОсновныеДействияФормы.Кнопки Цикл
			Если Лев(кнопка.Имя,8)="Действие" тогда 
				кнопка.Текст=ПереводАнгл.ПереводимЭлемент(кнопка.Текст);
			КонецЕсли;
		КонецЦикла;
	Исключение
	КонецПопытки;
	Попытка
		Для каждого колонка из ФормаДокумента.ЭлементыФормы.ДокументСписок.Колонки Цикл
			Колонка.ТекстШапки = ПереводАнгл.ПереводимЭлемент(Колонка.ТекстШапки); 
		КонецЦИкла;
	Исключение
	КонецПопытки;
	Возврат истина;
КонецФункции 

//В СИСТЕМЕ ДОЛЖЕН БЫТЬ СПРАВОЧНИК ПЕРЕВОД, ГДЕ НАИМЕНОВАНИЕ - ЧТО НУЖНО ПЕРЕВЕСТИ, 
//А СТРОКОВЫЙ РЕКВИЗИТ АнглПеревод В НЕМ - ПЕРЕВОД. 
Функция ПереводимЭлемент(Объект) Экспорт 
	Результат = Объект;
	Если Объект="" тогда
	Иначе
		ССылкаЗаголовка=(Справочники.Перевод.НайтиПоНаименованию(Лев(СОкрЛП(Объект),100))) ;
		Если ССылкаЗаголовка = Справочники.Перевод.ПустаяСсылка() тогда
			Если (ПараметрыСеанса.ТекущийПользователь.ВводитПеревод =1) и //ФЛАГ ЧТО ТЕКУЩИЙ ПОЛЬЗОВАТЕЛЬ - ПЕРЕВОДЧИК
				((Число(КодСимвола(Объект))>100)) тогда//ПОПЫТКА ВЫКИНУТЬ АНГЛИЙСКИЕ НАДПИСИ (И СПЕЦСИМВОЛЫ) 
				//ДАБЫ ИХ НЕ ПЕРЕВОДИТЬ
				Сообщить(СОкрЛП(Объект)); //ДЛЯ СПИСКА ЧТО НУЖНО ПЕРЕВОДИТЬ.
			КонецЕсли;
		Иначе
			Результат = ССылкаЗаголовка.АнглПеревод;
		КонецЕсли;
	КонецЕсли;
	Возврат Результат;
КонецФункции 

//ПОПЫТКА ЧЕРЕЗ СПРАВОЧНИК ПЕРЕВОД - ПЕРЕВЕСТИ ИНТЕРАКТИВНЫЕ ПРОЦЕДУРЫ И ФУНКЦИИ 
Функция АнглВопрос(перем1="",перем2="",перем3="",перем4="",перем5="",перем6="") Экспорт
	Если ПараметрыСеанса.ТекущийПользователь.Язык = 0 тогда
		Если перем3=""тогда
			результат = Вопрос(перем1,перем2)
		ИначеЕсли перем4 = "" тогда
			результат = Вопрос(перем1,перем2,перем3);
		ИначеЕсли перем5 = "" тогда
			результат = Вопрос(перем1,перем2,перем3,перем4);
		ИначеЕсли перем6 = "" тогда
			результат = Вопрос(перем1,перем2,перем3,перем4,перем5);
		Иначе
			результат = Вопрос(перем1,перем2,перем3,перем4,перем5,перем6);
		КонецЕсли;
	Иначе
		ТекстВОпроса=ПереводАнгл.ПереводимЭлемент(перем1);
		Если перем3="" тогда
			результат = Вопрос(ТекстВОпроса,перем2)
		ИначеЕсли перем4 = "" тогда
			результат = Вопрос(ТекстВОпроса,перем2,перем3);
		ИначеЕсли перем5 = "" тогда
			результат = Вопрос(ТекстВОпроса,перем2,перем3,перем4);
		ИначеЕсли перем6 = "" тогда
			результат = Вопрос(ТекстВОпроса,перем2,перем3,перем4,перем5);
		Иначе
			результат = Вопрос(ТекстВОпроса,перем2,перем3,перем4,перем5,перем6);
		КонецЕсли;
	КонецЕсли;
	ВОзврат результат;
КонецФункции 

Функция АнглСообщить(перем1="",перем2="") Экспорт 	результат="";
	Если ПараметрыСеанса.ТекущийПользователь.Язык = 0 тогда
		Если перем2="" тогда
			Сообщить(Перем1);
		Иначе
			Сообщить(Перем1,Перем2);
		КонецЕсли;
	Иначе
		ТекстСообщения=ПереводАнгл.ПереводимЭлемент(Перем1);
		Если перем2=""тогда
			Сообщить(ТекстСообщения);
		Иначе
			Сообщить(ТекстСообщения,Перем2);
		КонецЕсли;
	КонецЕсли;
	ВОзврат результат;
КонецФункции

Функция АнглПредупреждение(перем1="",перем2="",перем3="") Экспорт
	результат="";
	Если ПараметрыСеанса.ТекущийПользователь.Язык = 0 тогда
		Если перем2=""тогда
			Предупреждение(Перем1);
		ИначеЕсли перем3="" тогда
			Предупреждение(Перем1,Перем2);
		Иначе
			Предупреждение(Перем1,Перем2,Перем3);
		КонецЕсли;
	Иначе
		ТекстСообщения=ПереводАнгл.ПереводимЭлемент(Перем1);
		Если перем2="" тогда
			Предупреждение(ТекстСообщения);
		ИначеЕсли перем3="" тогда
			Предупреждение(ТекстСообщения,Перем2);
		Иначе
			Предупреждение(ТекстСообщения,Перем2,Перем3);
		КонецЕсли;
	КонецЕсли;
	ВОзврат результат;
КонецФункции

 

И собственно самое интересное:

ДЛЯ ПЕРЕВОДА ФОРМЫ (ЛЮБОЙ): 

В ПриОткрытии() необходимых для перевода форм дописать:

ПереводАнгл.УстановитьНадписиФормыАнгл(, ЭтаФорма);

ДЛЯ ПЕРЕВОДА СООБЩЕНИЙ, ПРЕДУПРЕЖДЕНИЙ, ВОПРОСОВ:

НУЖНО ПО КОНФИГУРАЦИИ СДЕЛАТЬ ГЛОБАЛЬНУЮ ЗАМЕНУ:

Сообщить("    на    ПереводАнгл.АнглСообщить("

Вопрос("    на    ПереводАнгл.АнглВопрос("

Предупреждение("    на   ПереводАнгл.АнглПредупреждение("

По факту в одной из конфигураций пришлось допилить функцию ЧтототамВОПРОС() по факту замены.

А далее - вручаем  ключи от перевода (флаги Язык и ВводитПеревод)- пользователю 1С и кратко инструктируем.

Собственно все.

Не нужно писать про ОбновлениеОтображения() - Действительно не вписывается в "перевести в конфигурацию за пол часа." Вообще типовые это что-то.

 

Если кто дочитал до конца, и есть мысли по поводу - есть пара вопросов.

1. Хочу научить конфу не английскому, а китайскому. Подскажите что нить по вопросу кодировок. (хочу в диалоговую форму

вставить иероглиф).

2. Решить вопрос со связанной информацией (кнопочка перейти) - вообще подобным методом возможно?

 

 

13

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Serj1C 477 11.09.12 07:18 Сейчас в теме
Что-то подобное (с перебором элементов на форме) делал в своей http://infostart.ru/public/123258/
Изначально тоже хотел перевести на болгарский, например, но потом решил остановиться на транслитерации.
Rad90210; +1 Ответить
2. Rad90210 13 11.09.12 21:22 Сейчас в теме
Как бы на модуль глянуть? можно на gala1442@gmail.com ?
Вообще, хочу на базе идеи, сделать конечный продукт. Очень хочу китайский ... Только блин кодировки...
3. www2000 55 12.09.12 11:09 Сейчас в теме
Можете использовать следующую бесплатную разукрашку
Rad90210; +1 Ответить
4. kostia.ck 59 13.09.12 16:18 Сейчас в теме
Да, идея неплохая, автору плюс.
Хочется только чтобы выборка значений справочника перевода вызывалась один раз - перебор элементов формы проходит быстрее чем поиск нужного справочника.

P.S. При большой загруженности сервера 1С (китайцев много) форма будет тупить при открытии что будет наводить тоску на конечных пользователей. Правильнее будет править синонимы на нужном языке. Отличный способ описывается в статье Редактирование текстов интерфейса … - быстро и обходится малой кровью. Переведутся все кроме стандартных текстов. Пример перевода стандартных текстов можно посмотреть в статье Локализация стандартных текстов интерфейсов.
Rad90210; +1 Ответить
8. Rad90210 13 20.09.12 18:02 Сейчас в теме
(4) kostia.ck, ***Хочется только чтобы выборка значений справочника перевода вызывалась один раз*** - как показывает практика - перевод нужен больше для того чтобы он БЫЛ. И теоретически пользователь англоязычный мог бы зайти и ВСЕ очень быстро ПРОВЕРИТЬ. На практике - если туда кто-то и заходит - то 1 раз в пол года, и то случайно. Приехать в другую страну, и там работать? Достаточно того, что теоретически возможность проверить работу местных сотрудников есть - этого оказалось достаточно.
Да, действительно, можно и кешировать необходимое в временной тз, для ускорения работы.
Как только станет вопрос в необходимости - этим без проблем займусь. Но судя по сказанному выше - вероятно это никому не нужно )).
Кстати - для отчетов, основанных на УниверсальномОтчете - перевести заголовки - дело тоже 5 минут. Причем используя тот же алгоритм.
А по надписям на кнопках, особенно програмно генерируемых - так у меня - вообще самый красивый вариант ))
5. AlexO 128 13.09.12 16:27 Сейчас в теме
Сергей Радченко - родственник Максима Радченко?
6. Rad90210 13 16.09.12 23:09 Сейчас в теме
7. babnik1990 20.09.12 15:18 Сейчас в теме
Добрый день! Нужна Ваша помощь, мне нужно перевести конфу Документооборот на английский, хотелось бы посоветоваться. Очень буду благодарен если свяжитесь со мной (babiy_m_v@mail.ru), нужна помощь.
9. Rad90210 13 20.09.12 18:03 Сейчас в теме
Ребят, есть реально кто-нить который в 1С вставлял иероглифы? Реально интересно : полетит - не полетит ?..
Оставьте свое сообщение

См. также

Работа с отчетами 1С для "чайников" часть 2 13

Статья Пользователь Нет файла v8 БП3.0 Россия Бесплатно (free) Бухгалтерский учет Оборотно-сальдовая ведомость, Анализ счета

Статья предназначена для начинающих пользователей 1С. Отчеты в 1С представляют собой довольно мощный инструмент, который можно легко настроить под свои потребности. Типовые настройки, это просто шаблон, который можно существенно улучшить.

28.10.2019    4113    LipinA4    0       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Бюджетирование - объект автоматизации. Часть 1. Актуальное из практики 45

Статья Программист Бизнес-аналитик Бухгалтер Пользователь Нет файла v8 Россия Госбюджет УУ Финансовый учет и бюджетирование (FRP) Бесплатно (free) Бухгалтерский учет

Первая из серии статей по автоматизации бюджетирования. В ней описаны актуальные вопросы и задачи, подходы и методы решения. Чтобы максимально попасть темами следующих статей в список актуальных вопросов и задач, мы проводим исследование, для чего прилагаем анкету. Как заполнить анкету и получить за это бонус, описано в конце статьи.

12.08.2019    4089    Serg_Tangatarov    12       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Расчеты с поставщиками и покупателями в КА 2.4.6, УТ 11.4.6, ЕРП 2.4.6 69

Статья Программист Бизнес-аналитик Бухгалтер Нет файла v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Дебиторская и кредиторская задолженность Бесплатно (free) Бухгалтерский учет

Новый режим расчетов с поставщиками и покупателями «Онлайн». Ведение планируемой и фактической задолженности. Порядок зачета документов. Различные варианты детализации расчетов. Выявленные ошибки режима «Онлайн».

30.04.2019    14278    ids79    19       

Как настроить правильную техподдержку (helpdesk, service desk на коленке) 39

Статья Программист Бизнес-аналитик Руководитель проекта Нет файла v8 УУ Управление взаимоотношениями с клиентами (СRM) Документооборот и делопроизводство Монитор заказов Учет рабочего времени Бесплатно (free) Управление услугами и сервисом

Эта статья будет полезна для компаний, которые оказывают техническую поддержку своим пользователям - внешним или внутренним клиентам. В статье я расскажу, как оказываем поддержку мы, как выстроили этот бизнес-процесс, что контролируем и на что обращаем внимание в работе. Вы можете использовать наш опыт при построении собственной системы поддержки или обратиться к нам за помощью за построением такой системы, будем рады помочь. В статье формируется основной набор правил, которые мы сформировали при настройке системы для себя, а так же небольшие примеры того, как мы эти правила применяем.

24.04.2019    9238    siddy    0       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

[Обзор. История внедрения] КИНТ: Управление санаторием - модуль "Питание" 21

Статья Программист Пользователь Нет файла v8 1cv8.cf Здравоохранение, медицина, стоматология Гостиничный бизнес Рестораны, кафе и фаст-фуд Пищевая промышленность Бесплатно (free) Бухгалтерский учет

История одного внедрения прикладного решения "КИНТ:Управление санаторием" - модуль "Питание". Обзор возможностей и резюме после использования функционала на практике.

22.03.2019    4403    rpgshnik    21       

Автоматизация отчета об исполнении гособоронзаказа (по Постановлению правительства №543) в программе 1С:ERP Управление предприятием 2 6

Статья Бухгалтер Нет файла v8 ERP2 Машиностроение и приборостроение Россия БУ Бесплатно (free) Бухгалтерский учет

В данной статье Пикурен Вера - эксперт ВЦ Раздолье по автоматизации предприятий ОПК - расскажет о некоторых методических решениях, применяемых для автоматического заполнения Отчета об исполнении государственного оборонного заказа (ГОЗ) в соответствии с Постановлением правительства №543 в программе 1С:ERP. Подробности можно посмотреть в вебинаре https://infostart.ru/webinars/1013708/

06.03.2019    7047    1СERP    5       

Очный семинар по регулярному менеджменту Александра Фридмана "Вы или Хаос", 12 декабря 2019 г. , Санкт-Петербург Промо

Семинар по регулярному менеджменту от Александра Фридмана для собственников, первых лиц и топов. Технология управленческого планирования, комплексного управления временем и другими ресурсами, выполнением поручений, делами, информацией, контактами (встречи-звонки-почта).

от 11000 до 29000 рублей

Автоматизация отчета об исполнении гособоронзаказа (по Постановлению правительства №543) в программе 1С:Управление производственным предприятием 8 9

Статья Бухгалтер Нет файла v8 УПП1 Государственные, бюджетные структуры Россия БУ Бесплатно (free) Бухгалтерский учет

В данной статье Пикурен Вера - эксперт ВЦ Раздолье по автоматизации предприятий ОПК - расскажет о некоторых методических решениях, применяемых для автоматического заполнения Отчета об исполнении государственного оборонного заказа (ГОЗ) в соответствии с Постановлением правительства №543 в программе 1С:Управление производственным предприятием 8. Подробности можно посмотреть в вебинаре https://infostart.ru/webinars/1005164/

21.02.2019    8190    1СERP    9       

Принципы проектирования справочников номенклатуры в 1С: Управление Предприятием 2 (ERP 2.4.6) 73

Статья Программист Пользователь Нет файла v8 ERP2 Россия Бесплатно (free) Управление бизнес-процессами (BPM) Бухгалтерский учет Пользователю системы

Принципы системного подхода к проектированию справочников номенклатуры в 1С: Управление Предприятием 2 (ERP 2.4.6) или как избежать замусоривания.

13.02.2019    12652    roman72    20       

С 2020 года сервис «Продление поддержки конфигурации 1С:УПП» подорожает вдвое Промо

Успейте продлить поддержку УПП до повышения цен! Фирма «1С» предупредила об изменении цен на сервис «Продление поддержки конфигурации "1С:Управление производственным предприятием"». С 1 января 2020 года сервис подорожает в два раза.

Ещё раз о суммировании группировок в СКД 62

Статья Программист Нет файла v8 v8::СКД 1cv8.cf УУ Производство готовой продукции (работ, услуг) Бесплатно (free) Практика программирования Разработка

Начинающие специалисты, создающие отчеты в СКД, часто сталкиваются с вопросом о суммировании результатов группировок. Столкнувшись с такой задачей, я понял, что часто проблемы возникают от неправильного понимания самой задачи, а также недопонимания действия механизмов платформы. В приведенной ниже статье попробуем с этим разобраться.

11.02.2019    7921    Dioneo    17       

Переход на "Зарплату и управление персоналом 3.1" 35

Статья Программист Бухгалтер Пользователь Нет файла v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Управление персоналом (HRM) Бесплатно (free) Интеграция Пользователю системы Бухгалтерский учет

Сменила я тут работу и уже после того, как я приступила к исполнению обязанностей, мой новый начальник мне призналась, что выбор пал на меня только из-за того, что я знаю программу. Справедливости ради, эта уверенность была основана только на том, что я прошла тестирование, включающее только основные операции кадрового делопроизводства. Так или иначе, а работодатель попал в точку, нанимая меня в надежде, что я решу проблему: нужно перейти «с 8.2 на 8.3». Ничего сложного, скажет большинство, я тоже так говорю, но ситуация осложнялась некоторым количеством предшественников, которые уже «нафеячили» в программах до меня. Взять и сделать все заново мне не разрешили, так что пришлось исходить из того, что есть, и именно это дало пищу для размышлений и, в конце концов, привело к написанию этих рекомендаций. Если перед Вами стоит задача перехода с ЗУП 2.5 на ЗУП 3.1, я попробую облегчить Вам жизнь этой статьей.

01.02.2019    8081    VKuser24804875    33       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Ошибка №3 внедрения "Бюджетирования" в 1С:ERP2 и 1С:КА2: использование статей бюджетов вместо нефинансовых показателей 12

Статья Бизнес-аналитик Нет файла v8 ERP2 КА2 УУ Финансовый учет и бюджетирование (FRP) Бесплатно (free) Бухгалтерский учет

В планировании часто встает вопрос ввода цен для расчета тех или иных статей бюджетирования. На проектах мы видим, что для таких целей в 1C:КА 2 и 1C:ERP 2 иногда применяют статьи бюджетов вместо нефинансовых показателей. Это ведет к ряду ошибок и неудобств для пользователей.

14.01.2019    4545    SergeyN    4       

Сложные схемы поступления товаров в УТ 11.4, КА 2.4, ЕРП 2.4 51

Статья Программист Бизнес-аналитик Нет файла v8 v8::УФ ERP2 УТ11 КА2 БУ УУ Учет ТМЦ Бесплатно (free) Бухгалтерский учет Управленческий учет (прочее)

Поступление товаров по схеме «Товары в пути», поступление неотфактурованного товара, настройки системы учета, новые объекты конфигурации, последовательность ввода документов, движения по регистрам накопления

31.12.2018    18189    ids79    33       

Онлайн-курс "Технология выполнения проектов ERP-класса – процессный подход". Третий поток. Курс проходит с 21 января по 18 марта 2020 года. Промо

Курс разработан Внедренческим центром «Раздолье». Курс предназначен для подготовки аналитиков, архитекторов и руководителей проектов автоматизации процессов управления с использованием комплексных ИТ-систем (1С:ERP, 1С:УХ, 1С:КА, 1С:УТ). В основе курса лежит методика применения процессного подхода.

9000 рублей

Партионный учет товаров в конфигурациях УТ, КА, ЕРП 163

Статья Программист Бизнес-аналитик Бухгалтер Нет файла v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Учет ТМЦ Бесплатно (free) Управленческий учет (прочее) Бухгалтерский учет

История развития, особенности реализации в текущих версиях ЕРП 2.4, КА 2.4, УТ 11.4, методы оценки стоимости запасов, примеры расчета стоимости списания

08.12.2018    27175    ids79    53       

Учет товаров по сериям в типовых конфигурациях УТ 11.4, КА 2.4, ЕРП 2.4 138

Статья Программист Бухгалтер Нет файла v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Учет ТМЦ Бесплатно (free) Бухгалтерский учет Управленческий учет (прочее)

Возможности и настройки подсистемы серийного учета, отражение данных по сериям в регистрах и отчетах системы, выявленные нюансы

02.12.2018    27427    ids79    106       

Онлайн-интенсив "Бизнес-процессы для подготовки к экзамену 1С:Специалист по платформе" 12 декабря 2019 г. Промо

На интенсиве будут рассмотрены все теоретические вопросы, связанные с устройством механизма бизнес-процессов – это необходимо для успешной сдачи экзамена 1С:Специалист по платформе. Также, в качестве практического примера, будет решена задача, аналогичная экзаменационной.

777 рублей

Обзор блока адресного хранения в программах 1С: УТ, ERP и КА 36

Статья Бизнес-аналитик Руководитель проекта Нет файла v8 ERP2 УТ11 КА2 Россия УУ Учет ТМЦ Бесплатно (free) Управление бизнес-процессами (BPM) Бухгалтерский учет

В статье мы подробно расскажем вам, как реализовано адресное хранение в типовых решениях 1С:Управление торговлей, 1С:ERP и 1С:Комплексная автоматизация.

29.11.2018    13657    alis112358    23       

Интеркампани, особенности учета в конфигурациях УТ 11.4, КА 2.4, ЕРП 2.4 87

Статья Программист Бизнес-аналитик Нет файла v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Учет ТМЦ Бесплатно (free) Бухгалтерский учет Управленческий учет (прочее)

Старая и новая методики учета «Интеркампани», недостатки применения старой методики, преимущества и особенности новой, выявленные нюансы.

21.11.2018    23092    ids79    76       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Контроль отрицательных остатков в конфигурациях: УТ 11.4, КА 2.4, ЕРП 2.4 125

Статья Программист Бизнес-аналитик Руководитель проекта Нет файла v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Учет ТМЦ Бесплатно (free) Бухгалтерский учет Управленческий учет (прочее)

Подробный разбор всех присутствующих в конфигурациях УТ 11, КА 2, ЕРП 2 вариантов контроля отрицательных остатков: по организациям, складам, оперативный контроль

08.11.2018    28589    ids79    70       

Перенос данных БП 3.0 => УТ 11 / КА 2 / ERP 2 (ЕРП) (перенос остатков, документов и справочной информации из "1С:Бухгалтерия предприятия 8", ред.3.0). Обновлено до БП 3.0.73.х, УТ 11.4.10.х, КА 2.4.10.х., ERP 2.4.10.х! Промо

Переносятся документы за выбранный период, справочная информация и остатки по счетам бух. учета в программу УТ 11 / КА 2 / ЕРП 2 (ERP). Переносятся все возможные виды операций ввода остатков на нужную дату. Есть отбор по периоду переноса документов и фильтр по организации, доступен выбор даты ввода остатков. Если нужно переносить что-то дополнительно, то обычно бесплатно добавляем это в перенос . Смотрите видеодемонстрацию со звуком - советами по переносу и рекомендациями настройки программ.

29700 руб.

Дивный новый мир: краткий обзор основных отличий BAS ERP от УПП 12

Статья no Нет файла v8 УПП1 ERP2 Украина Бесплатно (free) Пользователю системы Бухгалтерский учет

Краткий обзор нововведений и основных отличий конфигурации 1С:BAS ERP от предшественника в лице 1С:УПП, а также некоторых общих отличий конфигураций на управляемых формах от обычных.

06.11.2018    5616    JohnGalt    14       

Ограничения и недостатки производственного учёта в 1С: УНФ 40

Статья no Нет файла v8 УНФ УУ Производство готовой продукции (работ, услуг) Бесплатно (free) Управление бизнес-процессами (BPM) Бухгалтерский учет Производство

У любого программного продукта (и не только программного, да и не только у продукта) существуют свои сильные и слабые стороны. О многих сильных сторонах 1С: УНФ (Управление нашей фирмой) я писал и снимал обучающие видеоролики. Мне действительно нравится данная программа в силу сочетания функциональности и простоты учёта. Но давайте объективно коснёмся недостатков 1С: УНФ при внедрении на производственных предприятиях. Но сначала про…

30.10.2018    13779    Gavrik    22       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.127.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Настройка схемы "Интеркампани" в связке УТ 11.4 - БП 3.0 24

Статья Бухгалтер Пользователь Руководитель проекта Нет файла v8 v8::ОУ УТ11 БУ УУ Бесплатно (free) Пользователю системы Бухгалтерский учет

Настройка и использование схемы "Интеркампани" в связке "Управление торговлей 11.4" и "Бухгалтерия предприятия 3.0".

26.07.2018    21279    WhiteOwl    3       

Ошибка №1 внедрения "Бюджетирования" в 1С:ERP2 и 1С:КА2: настройка статей бюджетов и статей ДДС 1-в-1 56

Статья Бизнес-аналитик Бухгалтер Нет файла v8 ERP2 КА2 Россия УУ Windows Финансовый учет и бюджетирование (FRP) Бесплатно (free) Пользователю системы Бухгалтерский учет

В цикле статей я хочу поделиться ошибками во внедрении подсистемы «Бюджетирование», которые мне приходится исправлять после коллег на реальных проектах, и лучшими приемами по автоматизации бюджетирования на 1С:ERP 2 и 1C:КА 2. Сегодня поговорим и о самой распространенной ошибке – настройке статей бюджетов 1-в-1 к справочнику «Статьи ДДС».

13.06.2018    20910    SergeyN    69       

Перенос документов, остатков и справочников КА 1.1 => КА 2 / УТ 11. Обновлено до КА 2.4.10.х и УТ 11.4.10.х! Промо

Более 130 компаний выполнили переход на КА 2 или УТ 11 с помощью нашей разработки! Позволяет перенести не только остатки и справочники (как типовая обработка), но и документы за нужный период времени. Предоставляем техподдержку, оперативно исправляем замечания, выпускаем обновления при выходе новых релизов программ 1С. Вы можете проверить разработку до покупки: сделаем бесплатный тестовый перенос из вашей базы КА 1.1 и предоставим доступ к базе-результату через веб-клиент!

29700 руб.

Объединение организаций в ЗГУ (ЗУП) 3.1 при реорганизации (слияние, присоединение) 14

Статья Бухгалтер Нет файла v8 ЗКГУ3.0 ЗУП3.x Россия БУ Зарплата Бесплатно (free) Бухгалтерский учет

Несколько организаций(А, Б, В …) в одной базе, которые объединяются в новую организацию(Н) слиянием. Перевод в новую организацию должен быть без увольнения/приема, с сохранением данных для среднего заработка. 1С в почему-то не предоставила такой возможности. Есть обработка «Перевод к другому работодателю», но этим «документом не предполагается полноценное оформление переводов сотрудников в связи с реорганизацией (слиянием, присоединением, выделением, разделением, преобразованием) предприятия». На просторах интернета натолкнулся на идею что можно осуществлять перевод между организациями, являющимися филиалами и головной организацией. Четкого алгоритма действий тоже не нашел, поэтому пришлось экспериментировать. Чтобы облегчить другим работу, решил опубликовать алгоритм действий к которому я пришел.

21.05.2018    13315    as7bs    14       

Автоматизация для "полевых" сотрудников (тех, кто не работает в офисе) 42

Статья Программист Руководитель проекта Нет файла v8 1cv8.cf 1С:Франчайзи, автоматизация бизнеса УУ Учет рабочего времени Бесплатно (free) Управление бизнес-процессами (BPM)

Статья о том, как подходить к автоматизации процессов, где должны действовать сотрудники «в поле» - торговые представители, сервис-инженеры и т.д. На что стоит обратить внимание для таких видов бизнес-процессов

24.01.2018    12773    siddy    0