УТ 10.3. Автоматическая подстановка почты контрагента при отправке печатной формы документа на электронную почту

14.05.16

Задачи пользователя - Адаптация типовых решений

Возникла необходимость в автоматической подстановке почты контрагента при отправке печатных форм документов на электронную почту. Каждый раз искать и выбирать очень долго.

Решение:

1.  В ОбщиеФормы.ПечатьДокументов меняем строку 

УправлениеОтчетами.ОтправитьДокументПоЭлектроннойПочте(ЭлементыФормы.ПолеТабличногоДокумента, Заголовок);

На

УправлениеОтчетами.ОтправитьДокументПоЭлектроннойПочте(ЭлементыФормы.ПолеТабличногоДокумента, Заголовок,ЭтаФорма.ОбъектПечати);

2.  В ОбщиеМодули.УправлениеОтчетами меняем

Процедура ОтправитьДокументПоЭлектроннойПочте(Документ, ИмяФайлаВложения = "") Экспорт

   Если НЕ Константы.ИспользованиеВстроенногоПочтовогоКлиента.Получить() Тогда
     ОбщегоНазначения.СообщитьОбОшибке("Отправлять документы по электронной почте можно только из встроенного почтового к     лиента.
     |В настоящее время в настройках параметров учета установлено использование основного почтового клиента операционной      системы.");
     Предупреждение("Операция не выполнена");
     Возврат;
   КонецЕсли;

   ФормаОтправкиДокумента = ПолучитьОбщуюФорму("НастройкаОтправкиОтчета");
   ФормаОтправкиДокумента.Отчет = Документ;
   ФормаОтправкиДокумента.ИмяФайлаВложения = СтрЗаменить(ИмяФайлаВложения, ".", " ");
   ФормаОтправкиДокумента.ТемаСообщения = ИмяФайлаВложения;
   ФормаОтправкиДокумента.ОткрытьМодально(); 
КонецПроцедуры 

На

Процедура ОтправитьДокументПоЭлектроннойПочте(Документ, ИмяФайлаВложения = "",ОбъектПечати = Неопределено) Экспорт
   Если НЕ Константы.ИспользованиеВстроенногоПочтовогоКлиента.Получить() Тогда
      ОбщегоНазначения.СообщитьОбОшибке("Отправлять документы по электронной почте можно только из встроенного почтового       клиента.
      |В настоящее время в настройках параметров учета установлено использование основного почтового клиента операционной      системы.");
      Предупреждение("Операция не выполнена");
      Возврат;
   КонецЕсли;

   ФормаОтправкиДокумента = ПолучитьОбщуюФорму("НастройкаОтправкиОтчета");
   ФормаОтправкиДокумента.ОбъектПечати = ОбъектПечати;
   ФормаОтправкиДокумента.Отчет = Документ;
   ФормаОтправкиДокумента.ИмяФайлаВложения = СтрЗаменить(ИмяФайлаВложения, ".", " "); 
   ФормаОтправкиДокумента.ТемаСообщения = ИмяФайлаВложения;
   ФормаОтправкиДокумента.ОткрытьМодально();
КонецПроцедуры

3.  В ОбщиеФормы.НастройкаОтправкиОтчета добавляем реквизит ОбъектПечати с составным типом -  СправочникСсылка, ДокументСсылка

 

4. В  ОбщиеФормы.НастройкаОтправкиОтчета в начало процедуры

ОсновныеДействияФормыOK

 после строки 

СтруктураНовогоПисьма = Новый Структура;

добавляем код

Если (ЭтаФорма.ОбъектПечати <> Неопределено) И (ЭтаФорма.ОбъектПечати.Метаданные().Реквизиты.Найти("Контрагент") <> Неопределено) Тогда
    СписокКому = Новый СписокЗначений;
    Адрес = УправлениеЭлектроннойПочтой.ОпределитьАдресПолучателя(ЭтаФорма.ОбъектПечати.Контрагент);
    Если НЕ ПустаяСтрока(Адрес) Тогда
       СписокКому.Добавить(Адрес,Строка(ЭтаФорма.ОбъектПечати.Контрагент.Наименование));
    КонецЕсли;
    СтруктураНовогоПисьма.Вставить("Кому", СписокКому);
КонецЕсли;

 

Вот и все. Теперь при отправке документов на почту автоматически подставляется почта контрагента. 

почта контрагент УТ10 автоматическая

См. также

"Акты сверки +" Групповая подготовка и рассылка актов сверки для Бухгалтерии 3.0.

Взаиморасчеты Email рассылки Акт сверки Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Платные (руб)

Внешняя обработка для Бухгалтерии 3.0 - позволяет автоматически формировать документы «Акт сверки расчетов» с контрагентами за выбранный период с последующей фоновой отправкой на почту контрагента.

3000 руб.

25.11.2020    22722    186    7    

167

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4862    10    5    

19

Рассылки из 1С через Email, SMS, Telegram - Директ Маркетинг

Управление взаимоотношениями с клиентами (CRM) Мессенджеры и боты SMS рассылки Email рассылки Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Управленческий учет Платные (руб)

Полный набор инструментов для качественных транзакционных и маркетинговых Email, SMS, Telegram рассылок из 1С. Даже простые уведомления об оплате счетов способны существенно упростить сбор дебиторской задолженности. Применение всех возможностей прямого маркетинга выводит коммуникацию с клиентами, уровень сервиса и лояльность на новый уровень.

7788 руб.

07.04.2014    84457    43    193    

129

Автоматическая рассылка отчетов из 1С: Управление торговлей 10.3 и 1С:УПП по электронной почте

Email рассылки Оптовая торговля Бизнес-аналитик Бухгалтер Пользователь Руководитель проекта Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление производственным предприятием Управленческий учет Платные (руб)

Многим сотрудникам предприятия требуется актуальная и достоверная информация для принятия верных управленческих решений. Получить данную информацию можно при помощи отчетов, существующих в конфигурации «1С: Управление торговлей 10.3» или «1С:УПП». Но не всегда у пользователей есть время, возможность и/или желание формировать отчеты непосредственно в системе. Намного привычней и удобней получать готовые отчеты на электронную почту, не открывая 1С.

12000 руб.

16.04.2014    84731    100    91    

94

Массовая рассылка печатных форм любых документов по электронной почте, в Telegram, в каталог или том

Email рассылки Программист Пользователь Платформа 1С v8.3 Конфигурации 1cv8 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Зарплата и Управление Персоналом 3.x Платные (руб)

Решение для массовой рассылки печатных форм (в том числе и дополнительных) любых документов, и произвольных файлов. Рассылка возможна посредством электронной почты, Telegram и файловой системы. Рассылка пакета документов. Добавление факсимильных печати и подписи. Произвольные шаблоны HTML/Simple text с автозаполнением любыми полями документа. Любые форматы файлов. Упаковка вложений в архив. Транслитерация имен файлов. Разбиение рассылки на произвольные порции. Обход спам-фильтров. Журналирование рассылок.

3600 руб.

30.06.2022    9401    65    89    

28

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3238    5    0    

22
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. user1365563 22.10.22 09:40 Сейчас в теме
Добрый день. Нужна такая же, автоматическую подстановка почты контрагента при отправке печатной формы, только для другой конфигурации. Возможно сделать для нас?
Оставьте свое сообщение