Автоматическое отражение в регламентированном учете при проведении документа в КА 2.0

16.07.16

Задачи пользователя - Адаптация типовых решений

У многих, кто начал работать в КА редакции 2, возник вопрос - почему документы не формируют проводки. Оказалось, что провести документ теперь недостаточно. Нужно еще выполнить отдельную операцию по отражению документа в регламентированном учете. Это можно сделать из формы просмотра проводок, либо из меню Регламентированный учет -> Отражение документов в регл. учете

Обновлено 21.07.

 Да. В КА предусмотрена возможность настроить отражение документов в РУ по расписанию (через регламентное задание). Но это не всегда удобно.

Есть другое решение.

Вариант 1.

Необходимо в общий модуль МодификацияКонфигурацииПереопределяемый в процедуру ПослеЗаписиНаСервере добавить код

	//автоматическое отражение в Регл. учете
	Если ПараметрыЗаписи.Свойство("РежимЗаписи") Тогда
		
		Если ПараметрыЗаписи.РежимЗаписи = РежимЗаписиДокумента.Проведение 
			И Метаданные.Обработки.ОтражениеДокументовВРеглУчете.Команды.ПроводкиРеглУчета.ТипПараметраКоманды.СодержитТип(ТипЗнч(ТекущийОбъект.Ссылка))
		Тогда
		
			//если документ может быть отражен в РУ нужно еще проверить, что по нему есть запись в регистре в статусе "К отражению"
			мЗаписи = РегистрыСведений.ОтражениеДокументовВРеглУчете.СоздатьНаборЗаписей();
			мЗаписи.Отбор.Регистратор.Установить(ТекущийОбъект.Ссылка);
			мЗаписи.Прочитать();
			Для каждого мЗапись Из мЗаписи Цикл
			
				//есть запись, проверим статус
				Если мЗапись.Статус = Перечисления.СтатусыОтраженияДокументовВРеглУчете.КОтражениюВРеглУчете Тогда
					
					СтруктураРеквизиты = Новый Структура("Ссылка, Дата, Организация", ТекущийОбъект.Ссылка, ТекущийОбъект.Дата, Неопределено);
					РеглУчетПроведениеСервер.ОтразитьДокумент(СтруктураРеквизиты, Истина);
					
				КонецЕсли;
				
				Прервать;
			
			КонецЦикла;
			
		КонецЕсли;
		
	КонецЕсли;

В результате, после проведения документа будет "как бы нажата" кнопка "Отразить в регл. учете".

К плюсам данного решения можно отнести то, что хоть и вносятся изменения в код, но они делаются в специально отведенном для этого месте. Т.е. проблем с дальнейшим обновлением возникнуть не должно.

К минусам - предложенное решение будет работать только при проведении из формы документа.

Вариант 2.

Создать подписку на событие "ОбработкаПроведения" для документов и в процедуру обработчик добавить код

Процедура ОбработкаПроведения(Источник, Отказ, РежимПроведения) Экспорт
	
	//автоматическое отражение в Регл. учете
	Если Метаданные.Обработки.ОтражениеДокументовВРеглУчете.Команды.ПроводкиРеглУчета.ТипПараметраКоманды.СодержитТип(ТипЗнч(Источник.Ссылка)) Тогда
		
		//если документ может быть отражен в РУ нужно еще проверить, что по нему есть запись в регистре в статусе "К отражению"
		мЗаписи = РегистрыСведений.ОтражениеДокументовВРеглУчете.СоздатьНаборЗаписей();
		мЗаписи.Отбор.Регистратор.Установить(Источник.Ссылка);
		мЗаписи.Прочитать();
		Для каждого мЗапись Из мЗаписи Цикл
			
			//есть запись, проверим статус
			Если мЗапись.Статус = Перечисления.СтатусыОтраженияДокументовВРеглУчете.КОтражениюВРеглУчете Тогда
				
				СтруктураРеквизиты = Новый Структура("Ссылка, Дата, Организация", Источник.Ссылка, Источник.Дата, Неопределено);
				РеглУчетПроведениеСервер.ОтразитьДокумент(СтруктураРеквизиты, Истина);
				
			КонецЕсли;
			
			Прервать;
			
		КонецЦикла;
		
		
	КонецЕсли;
	
КонецПроцедуры

Нужна подписка именно на "ОбработкаПроведения" из-за того, что регистрация документа к отражению в регл. учете выполняется при проведении документа.

Плюсы - работает независимо от места вызова

Минусы - нужно больше изменений в коде. Создать общий модуль, прописать в нем процедуру обработчик, создать подписку и привязать обработчик к событию.

Замечание. Для документа "Счет фактура полученный" вариант с подпиской на событие не работает. Кто знает почему - напшите в комментариях.

Критика приветствуется ))

Комплексная автоматизация 2.0 КА 2.0 отражение в регламентированном учете

См. также

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4843    10    5    

19

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3224    5    0    

22

Каждому менеджеру нужен свой Excel

Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4285    dimanich70    15    

18

Создать на основании - своя кнопка (БСП). Проблема двух подменю Создать на основании

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2318    dimanich70    8    

14

Доработка отчета "Связанные документы" (структура подчиненности) для вывода объектов из любого расширения

Адаптация типовых решений Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2253    19    avmartynov    14    

44

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2465    32    progmaster    8    

4
Вознаграждение за ответ
Показать полностью
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. alexdm 20.07.16 11:12 Сейчас в теме
А не лучше подписку на событие сделать свою ? Тогда ведь и программное проведение будет работать...
h00k; roofless; +2 Ответить
2. roofless 23 20.07.16 16:33 Сейчас в теме
(1) alexdm, вот это верное решение)
3. Dem1urg 388 21.07.16 17:32 Сейчас в теме
Публикацию обновил.
Добавил вариант с подпиской на события.
Но оказалось что он тоже имеет свои ограничения.
У меня на КА 2.0.3.143 для документа "Счет-фактура полученный" при вызове из подписки документ в РУ все равно не отражается. А вот при вызове из ПослеЗаписиНаСервере все работает.
4. пользователь 09.12.16 08:35
Сообщение было скрыто модератором.
...
5. chehlov 11 09.12.16 08:36 Сейчас в теме
Замечание. Для документа "Счет фактура полученный" вариант с подпиской на событие не работает. Кто знает почему - напишите в комментариях.


это была ошибка 1С и ее исправили (сам не проверил еще):

Ошибка 00-00101305
Код ошибки: 00-00101305
Статус: Исправлена в выпущенной версии Зарегистрирована: 25.11.2016
Исправлена: "1С:ERP Управление предприятием 2.0", версия 2.2.2.113

Описание:

Не выполнялось отражение документов в учете НДС во время актуализации проводок при открытии формы.

Способ исправления:

Выполнять проверку оффлайн расчетов безусловно: в модуле формы "ПроводкиРегламентированногоУчета" обработки "ОтражениеДокументовВРеглУчете" в строке 1592 прописать: "ПараметрыОбработки = Новый Структура("РеквизитыДокумента, ВыполнитьПересчеты", СтруктураРеквизиты, Истина);"
6. Dem1urg 388 09.12.16 23:02 Сейчас в теме
(5) Спасибо за информацию.
Вообще КА получилась очень "тяжелая". И по скорости работы, и по скорости разработки под неё.
7. mamba 28 25.09.17 13:47 Сейчас в теме
8. Salinarius 06.09.18 15:12 Сейчас в теме
Спасибо большое за публикацию.
9. WellMaster 104 21.01.19 16:14 Сейчас в теме
Это не решит проблему помеченных на удаление документов. Если РЕГ проводки уже были, они остаются.
Например, если пометка на удаление прилетела из узла РИБ.
10. Olegpc1 20.03.19 16:45 Сейчас в теме
Спасибо, очень бухгалтера были довольны
11. Radiy 6 03.02.21 23:43 Сейчас в теме
12. qazaz2 17 30.08.21 20:45 Сейчас в теме
Приветствую,

Автору спс за идею.

А вот если негодяй бухгалтер проводит документ не из формы документа а из журнала как быть?
13. user1857401 18.01.23 10:56 Сейчас в теме
Что то не хочет сейчас работать. Пишет "несоответствие типов".
14. gosizo 38 22.05.23 16:34 Сейчас в теме
(13) То же столкнулся, нужно брать второй параметр Истина из РеглУчетПроведениеСервер.ОтразитьДокумент
15. gosizo 38 23.05.23 07:58 Сейчас в теме
Оставьте свое сообщение