Устранение ошибки "При открытии формы регламентированного отчета произошла ошибка." при открытии регламентированной отчётности в Бухгалтерии 3

Публикация № 551954

Разработка - Адаптация типовых решений

ошибка регламентированная отчетность отчетность бухгалтерия

Устраняем ошибку "При открытии формы регламентированного отчета произошла ошибка.", релиз 3.0.44.124.

Выполним всего 2 шага:

1. В модуле формы Отчет.РегламентированныйОтчетБухОтчетность.ФормаОтчета2011Кв4, процедура ОбновитьСоставДополнительныхСтрокИзСохраненныхДанных, в ней есть строки:
Для Каждого СтрокаУровня1 Из СохраненныйСоставДопстрокБаланса.Строки Цикл
	Для Каждого СтрокаУровня2 Из СтрокаУровня1.Строки Цикл
		ИмяОбластиДопСтроки = СтрокаУровня2.ИмяОбластиДопСтроки;
		НайденнаяСтрока = РегламентированнаяОтчетностьКлиентСервер.НайтиЭлементВДанныхФормыДерево(ЭтаФорма[СоставДополнительныхСтрок.СтруктураСоставов.Баланс].ПолучитьЭлементы(), "ИмяОбластиДопСтроки", ИмяОбластиДопСтроки);
		Если НайденнаяСтрока <> Неопределено Тогда
			НайденнаяСтрока.ВключатьВОтчет = СтрокаУровня2.ВключатьВОтчет;
		КонецЕсли;
	КонецЦикла;
КонецЦикла;

нужно заменить:

НайденнаяСтрока = РегламентированнаяОтчетностьКлиентСервер.НайтиЭлементВДанныхФормыДерево(ЭтаФорма[СоставДополнительныхСтрок.СтруктураСоставов.Баланс].ПолучитьЭлементы(), "ИмяОбластиДопСтроки", ИмяОбластиДопСтроки);

на

НайденнаяСтрока = РегламентированнаяОтчетностьКлиентСервер.НайтиЭлементВДанныхФормыДерево(ДеревоНастроекБаланс.Строки, "ИмяОбластиДопСтроки", ИмяОбластиДопСтроки);

2. В общем модуле РегламентированнаяОтчетностьКлиентСервер, функция НайтиЭлементВДанныхФормыДерево, в ней строки

Если ЭлементДерева.ПолучитьЭлементы().Количество() > 0 Тогда
			
	РезультатПоиска = НайтиЭлементВДанныхФормыДерево(ЭлементДерева.ПолучитьЭлементы(), ИмяКолонки, ИскомоеЗначение);
	
	Если НЕ РезультатПоиска = Неопределено Тогда
		Возврат РезультатПоиска;
	КонецЕсли;
	
КонецЕсли;

заменить на

Если ТипЗнч(ЭлементДерева) = Тип("СтрокаДереваЗначений") Тогда
	
	
	Если ЭлементДерева.Строки.Количество() > 0 Тогда
		
		РезультатПоиска = НайтиЭлементВДанныхФормыДерево(ЭлементДерева.Строки, ИмяКолонки, ИскомоеЗначение);
		
		Если НЕ РезультатПоиска = Неопределено Тогда
			Возврат РезультатПоиска;
		КонецЕсли;
		
	КонецЕсли;
	
Иначе

	Если ЭлементДерева.ПолучитьЭлементы().Количество() > 0 Тогда
		
		РезультатПоиска = НайтиЭлементВДанныхФормыДерево(ЭлементДерева.ПолучитьЭлементы(), ИмяКолонки, ИскомоеЗначение);
		
		Если НЕ РезультатПоиска = Неопределено Тогда
			Возврат РезультатПоиска;
		КонецЕсли;
		
	КонецЕсли;
	
КонецЕсли;

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. МимохожийОднако 130 05.10.16 08:05 Сейчас в теме
Стесняюсь спросить, как устранить подобную ошибку, если она возникла в базовой версии?
2. VladC# 63 06.10.16 07:00 Сейчас в теме
(1) МимохожийОднако, боюсь что в базовой это не возможно, здесь один вариант - ждать обновления с исправлениями от 1С.
3. clev 28 28.07.20 18:17 Сейчас в теме
Возникла такая же ошибка при открытии формы "Статистика: Форма 22-ЖКХ (жилище)".

Проблема была в непроинициализированном параметре ЭтотОбъект.СтруктураРеквизитовФормы.ФлажокОтклАвтоРасчет

Добавил в расширение (в модуль формы отчета РегламентированныйОтчетСтатистикаФорма22ЖКХжилище) код:

&НаСервере
&Перед("УстановитьЗащитуИЦветФонаОбластейАвторассчитываемыхПоказате­лей")
Процедура rss_УстановитьЗащитуИЦветФонаОбластейАвторассчитываемыхПоказ­ателей()
	Если ЭтотОбъект.СтруктураРеквизитовФормы.ФлажокОтклАвтоРасчет = Неопределено Тогда
		ЭтотОбъект.СтруктураРеквизитовФормы.ФлажокОтклАвтоРасчет = Ложь;
	КонецЕсли;;
КонецПроцедуры


ошибка пропала.
4. znarul02 06.08.20 08:32 Сейчас в теме
а где именно, в какой области добавлял?
6. clev 28 11.08.20 17:56 Сейчас в теме
(4) Написал же, в модуле формы отчета РегламентированныйОтчетСтатистикаФорма22ЖКХжилище нашел процедуру, в которой возникала ошибка, она называется "УстановитьЗащитуИЦветФонаОбластейАвторассчитываемыхПоказате­­лей".
Эту процедуру добавил в свое расширение, с инструкцией "Перед", см. код. в (3)
(5) не понял, скрин чего нужно сделать?
чем-то надо помочь?
5. znarul02 06.08.20 08:35 Сейчас в теме
(3)можно скрин пожалуйста
Оставьте свое сообщение

См. также

Исправление ошибок в типовых релизах 1С: УТ 10.3 и Розница 1.0 при отражении продаж в ЕГАИС Промо

Адаптация типовых решений v8 УТ10 Бесплатно (free)

При продаже алкогольной продукции в программах Управление торговлей и Розница возникают ошибки. В статье разберем причины ошибок и способ их решения.

05.06.2016    38736    @lexandr    21    

Полный перевод кода УНФ 1.6 на английский язык с помощью обучаемой системы машинного перевода

Локализация решений v8 УНФ Бесплатно (free)

"Лёгким движением руки русский код превращается..." - Новый подход к переводу конфигураций.

19.10.2020    2672    vanjushkin    68    

Нюансы создания конфигураций на нескольких языках

Локализация решений v8 1cv8.cf Бесплатно (free)

Рассмотрим на примере ERP WE различные нюансы при реализации решений на нескольких языках.

25.07.2020    1295    Flashill    4    

Если ККМ Атол + 1С Розница тормозит при печати чеков по сети, или экономим на покупке ККТ и ФР

Розничная торговля Адаптация типовых решений ККМ v8 Розница УТ11 Россия Бесплатно (free)

Очень медленная работа с ККТ по Tcp/ip или Как заставить две клиентских Розницы 1С печатать чеки на одной кассе ККТ онлайн Предыстория и чем все закончилось.

01.07.2020    2995    lepihin    7    

Управление сложностью при доработке типовых конфигураций

Адаптация типовых решений v8 Бесплатно (free)

Описан пример доработки типовой конфигурации 1С:ERP Управление предприятием с помощью подсистемы Модель объекта.

17.04.2020    1873    vadim1980    0    

Локализация интерфейсов конфигураций. Практика и инструментарий 1Ci

Работа с интерфейсом Локализация решений v8 Бесплатно (free)

В последнее время компания 1С International все увереннее заявляет о себе на международном рынке. Но для успешного продвижения в этом направлении необходима локализация интерфейсов конфигураций 1С. О том, как выглядит процесс перевода, какие инструменты для этого есть, где брать переводчиков и как проверять их работу, на конференции Infostart Event 2018 Education рассказал руководитель группы локализации компании 1Ci Сергей Поликарпов.

05.11.2019    5244    user1069006    1    

"Прелести" БСП. Часть 1 - Дополнительные реквизиты / сведения

Адаптация типовых решений v8 1cv8.cf Бесплатно (free)

История небольшого расследования - сломались дополнительные реквизиты, или как НЕ НАДО использовать УИД в программном коде.

04.07.2019    12755    Enigma    31    

Итеративная ошибка почтового сервиса в 1С "Комплексная автоматизация" 2.4.8

Адаптация типовых решений v8 КА2 Россия Бесплатно (free)

После обновления на релиз 2.4.8.79 возникла конфликтная ситуация на уровне генерального директора, а именно: клиенты, которым отправлялись письма из 1С, начали регулярно получать одни и те же письма, то есть что-то вроде вирусной атаки (многократная отправка одного и того же письма).

02.07.2019    4043    pas    4    

Исправление КОСГУ в проводках по денежным обязательствам (в части сумм по счету 210.Р2). БГУ 1, релиз 1.0.56.10

Практика программирования Адаптация типовых решений Разработка v8 БГУ Государственные, бюджетные структуры Россия Госбюджет Бесплатно (free)

БГУ 1 релиз 1.0.56.10: исправление КОСГУ в проводках по денежным обязательствам (в части сумм по счету 210.Р2). Запрос для модуля документа "МЗ_Покупка".

11.04.2019    3882    pavel_vrn    0    

Не открывается оборотно-сальдовая ведомость или "variable not found in subplan target lists"

Адаптация типовых решений Оборотно-сальдовая ведомость, Анализ счета Оборотно-сальдовая ведомость, Анализ счета v8 v8::БУ УПП1 БУ Бесплатно (free)

При попытке открыть Оборотно-сальдовую ведомость программа выдает ошибку "Ошибка СУБД: ERROR: variable not found in subplan target lists" и либо закрывается, либо ее нужно перезапускать. Описан частный случай решения проблемы.

02.04.2019    6609    Max777    9    

Подключение дополнительных обработок - Розница для Украины

Адаптация типовых решений v8 1cv8.cf Украина Бесплатно (free)

Внешние подключаемые обработки - замечательный механизм! Но почему же он не работает для простых пользователей?

22.03.2019    4144    kaliuzhnyi    9    

Неверный расчет СЗВ-СТАЖ. ЗУП 3.1

Адаптация типовых решений Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ ФОМС, ПФ, ФСС Бесплатно (free)

При заполнении отчета СЗВ-СТАЖ на последних релизах ЗУП (ошибка не исправлена и в релизе 3.1.9.107) выявлены ошибки при расчете периодов, а также неверное выделение стажа ДЛОТПУСК.

01.03.2019    7688    dbachinsky    2    

Устранение некоторых ошибок, обнаруженных в модуле Обмена с ВЕТИС (ФГИС Меркурий)

WEB Адаптация типовых решений v8 БП3.0 Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность Россия Бесплатно (free)

Устранение ошибок, обнаруженных в модуле Обмена с ВЕТИС (ФГИС Меркурий) в конфигурации Бухгалтерия предприятия, редакция 3.0 (3.0.67.67).

08.02.2019    8436    aks    4    

Исправление отрицательных остатков по организациям в УТ 11.4, КА 2.4, ЕРП 2.4. Интеркампани, механизм формирования резервов

Практика программирования Адаптация типовых решений Учет ТМЦ Учет ТМЦ v8 v8::УФ ERP2 УТ11 КА2 УУ Бесплатно (free)

Подробно рассмотрены два способа исправления отрицательных остатков по организациям без использования подсистемы Интеркампани и с использованием. Описан механизм формирования резервов на уровне процедур общего модуля. Доработки механизма и исправление ошибок.

29.01.2019    31187    ids79    35    

Пропал фокус (активность) элемента формы, ошибка при переходе на платформу 1С:Предприятие 8.3 (8.3.12.1790)

Адаптация типовых решений v8 1cv8.cf Бесплатно (free)

После перехода на платформу 8.3.12.1790 обнаружилась проблема. При подборе товара в форме подбора номенклатуры на поле ввода количество пропал фокус (активность).

09.01.2019    8274    rhtr    21    

Некорректно заполняются значения по умолчанию при создании документа. 1С: УТ

Адаптация типовых решений v8 v8::ОУ УТ11 Россия Бесплатно (free)

Столкнулся у клиента с такой проблемой: при смене банковского счета организации, 1С настойчиво подставляет в документы, при их создании, старый счет.

21.11.2018    6968    yupi71    11    

Разные хм... неожиданности при работе с УТ 11 и платформой

Практика программирования Адаптация типовых решений v8 v8::ОУ УТ11 УУ Бесплатно (free)

По мере обнаружения буду писать сюда тонкости работы с УТ 11 и платформой, больше для себя, но, может, кому-то еще пригодится... Для нескольких вопросов предложены варианты обхода.

09.08.2018    18037    Kutuzov    30    

ЗУП 3.1: долгое открытие ряда документов (больничный, отпуск, командировка), начиная с релиза 3.1.6.6 - исправление ошибки с кодом 30161250

Адаптация типовых решений Зарплата Зарплата v8 v8::СПР ЗУП3.x Россия БУ УУ Бесплатно (free)

В релизе 3.1.6.6 разработчиками была допущена ошибка, заключающаяся в написании крайне неоптимального запроса к базе данных. Конкретно на моей базе, где учет ведется всего пару месяцев, запрос выполнялся около 10 секунд, что уже напрягало. В данной публикации я укажу на расположение данного запроса и выложу текст нового запроса, опубликованного разработчиками в версии для тестирования 3.1.7.67.

21.06.2018    9037    Bene_Valete    12    

Ошибка печати чека на ККМ Атол FPrint22. ПоследующаяОплата (Кредит) вместо Электронными. Розница 2

Адаптация типовых решений ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 Розница Россия Бесплатно (free)

При печати чека на FPrint22 неожиданно выяснилось, что вместо Электронными (пробивали по платежной карте) в чеке вставало на вид оплат ПоследущаяОплата (Кредит).

22.01.2018    28536    ah7777777    15    

Ошибка "Запись не верна! Набор записей, принадлежащий менеджеру, должен содержать ровно 1 запись" в Альфа-Авто 5 и методы ее устранения

Адаптация типовых решений v8 1cv8.cf Автомобили, автосервисы Россия Бесплатно (free)

Сегодня посреди рабочего дня база отказалась впускать пользователей. При попытке запуска вываливалась ошибка "Запись не верна! Набор записей, принадлежащий менеджеру, должен содержать ровно 1 запись". При этом активные сеансы работали без проблем. Саму ошибку можно было увидеть не всегда, чаще всего она пряталась за баннером с машинками.

28.12.2017    12696    MrsMastersan    7    

Исправление ошибки типового релиза ЗУП 2.5.118.1 в регламентированном отчёте "Расчет по страховым взносам"

Зарплата Практика программирования Адаптация типовых решений Зарплата v8::СПР ЗУП2.5 Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

В ЗУП 2.5.118.1 ошибка в регламентированном отчёте "Расчет по страховым взносам" за 1 квартал 2017. Коротко об ошибке: В отчёт не попадают сотрудники, уволенные до 2017 года, а попадать они обязаны,т.к. начисления по ним очень часто встречаются, например "Сохраняемый заработок на время трудоустройства" - это как раз выплата уже после увольнения сотрудника.

21.04.2017    19343    human_new    12    

Ошибка при заполнении строки 070 раздела 1 формы 6-НДФЛ

Зарплата Практика программирования Адаптация типовых решений Зарплата v8::БУ КА1 Россия НУ НДФЛ Бесплатно (free)

Комплексная автоматизация, редакция 1.1 (1.1.82.1). Возможно, в ЗУП 2.5.114.1 присутствует также. После очередного обновления КА, бухгалтер по заработной плате пожаловался на неправильное заполнение 070 строки раздела 1 отчета 6-НДФЛ.

08.02.2017    15889    dima_home    3    

Ошибка 2-НДФЛ ЗУП (3.0.25.150) {ОбщийМодуль.ЗарплатаКадры.Модуль(5279)}: Индекс находится за границами массива

Практика программирования Адаптация типовых решений Зарплата Зарплата v8 ЗУП3.x Россия БУ НДФЛ Бесплатно (free)

Ошибка при выполнении обработчика - 'ПриЗаписи' по причине: {ОбщийМодуль.ЗарплатаКадры.Модуль(5279)}: Индекс находится за границами массива ИмяПоля = УзелФормата.ДочерниеУзлы[3].ТекстовоеСодержимое;

01.02.2017    20021    sergey512    3    

Ошибка при загрузке курсов валют. Комплексная автоматизация 2.2 (ошибка в типовой)

Практика программирования Адаптация типовых решений v8::ОУ КА2 Россия Бесплатно (free)

При вызове обработки "Загрузить курсы валют" в конфигурации "Комплексная автоматизация 2.2" рел. 2.2.2.157 программа выдавала ошибку

17.01.2017    16458    serg1c    7    

Проблемы web-клиента 1С: Предприятие. Исправляем ошибку в 1С: Договорчики 8

Практика программирования Адаптация типовых решений v8 1cv8.cf Бесплатно (free)

Описывается способ обхода ошибки, возникающей в web-клиенте при программном изменении видимости элементов формы в процессе записи и закрытия. Ошибка была выявлена в типовой конфигурации 1С: Договорчики 8, но, вполне вероятно, может встречаться и в иных ситуациях. Предложен способ обхода с использованием механизма расширений 1С: Предприятие 8.3, что позволяет не вносить изменения в типовую конфигурацию.

06.07.2016    17858    Sergey1CSpb    3    

Розница 8. Аптека, поиск номенклатуры по штрихкоду

Практика программирования Адаптация типовых решений v8 Розница Фармацевтика, аптеки Бесплатно (free)

В конфигурации Розница 8. Аптека, редакция 2.1 (2.1.9.12) возникает ситуация, когда при чтении штрихкода выводится вся номенклатура, у которой совпадает прочтенный штрихкод независимо от остатков на текущем складе рабочего места, что при недостаточном контроле со стороны кассира приводит к списанию номенклатуры с другого склада. Для избежания данной ситуации предлагается в запрос типовой конфигурации добавлять условия по складу и положительным остаткам с изменением типовой конфигурации.

30.06.2016    14264    its_33    3    

Ошибка в выгрузке из УТ 11 в БП 3.0, правила УТ-БП (11.1.10.131, 3.0.42.1, v.1-4)

Перенос данных из 1C8 в 1C8 Адаптация типовых решений v8 КД БП3.0 УТ11 Бесплатно (free)

Переливка Заказа клиента из УТ (правила УТ-БП (11.1.10.131, 3.0.42.1, v.1-4)) происходит вместе со свойствами ГлавныйБухгалтер, Руководитель.

05.11.2015    24710    oleg21592    6    

Признание отложенного налогового обязательства по налогу на прибыль

Бухгалтерский учет Адаптация типовых решений v8 УПП1 Россия БУ НУ Налог на прибыль Бесплатно (free)

В статье рассмотрена ошибка, возникающая при исчислении отложенного налогового обязательства документом «Расчеты по налогу на прибыль»

21.04.2015    21774    el-le    4    

Отказ от модальности. Баг в типовых конфигурациях

Адаптация типовых решений v8 1cv8.cf Бесплатно (free)

Не буду расписывать про сам отказ от модальности. Думаю если Вы это читаете, то уже знаете о чем речь. Дело в том, что при рефакторинге некоторых обработок я столкнулся с багом, который, как мне кажется есть почти во всех типовых конфигурациях.

25.09.2014    16138    alm_ilya    20    

После обновления Бухгалтерии предприятия 3.0 возникает ошибка "Ошибка преобразования данных XDTO:"

Адаптация типовых решений v8 БП2.0 Бесплатно (free)

После обновления Бухгалтерия предприятия 3.0 возникает ошибка: {ОбщийМодуль.СтандартныеПодсистемыКлиентПовтИсп.Модуль(56)}: Ошибка при вызове метода контекста (ПараметрыРаботыКлиентаПриЗапуске) ПараметрыКлиента = СтандартныеПодсистемыВызовСервера.ПараметрыРаботыКлиентаПриЗапуске(Параметры); по причине: Ошибка при вызове серверного метода. по причине: Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа. по причине: Ошибка преобразования данных XDTO: НачалоСвойства: {http://v8.1c.ru/8.2/managed-application/modules}cli Форма: Элемент Тип: {http://v8.1c.ru/8.1/data/core}FixedStructure Способы решения проблемы.

16.07.2014    60971    bird21    9    

Контроль уникальности счетов фактур выданных в УТ 11.0.9.8

Адаптация типовых решений Розничная торговля Розничная торговля v8 УТ10 БУ Бесплатно (free)

Работая с управленческим учетом часто приходится заниматься обменом данными с регламентированным учетом. Данная ошибка возникла по воле производителя типовой конфигурации УТ 11.0.9.8. А именно отсутствует контроль уникальности номеров документа "Счет-фактура выданный".

20.06.2014    16915    zekrus    4    

Ошибка в документе "Отражение зарплаты в управленческом учете"

Адаптация типовых решений Зарплата Бухгалтерский учет Зарплата v8 УПП1 Россия Бесплатно (free)

Имеем: типовая Управление производственным предприятием, редакция 1.3 (1.3.31.1). При заполнении неверно заполнились данные по страховым взносам.

05.04.2013    9734    pss1985    0    

Очень долгое обновление типовой БП с релиза 2.0.41.х. Простой способ лечения.

Администрирование данных 1С Адаптация типовых решений v8 БП2.0 Аудит и бухгалтерские услуги, юриспруденция Россия БУ Бесплатно (free)

При обновлении типовой бухгалтерии с релиза 2.0.41.x до предпоследнего на сей день релиза 2.0.42.6 запускается обработка «ОбновлениеИнформационнойБазы» и происходит обработка документов...и в зависимости от разного рода причин, длиться она может достаточно долго (от минут - до часов)

19.12.2012    28747    Новиков    51