Устранение ошибки "При открытии формы регламентированного отчета произошла ошибка." при открытии регламентированной отчётности в Бухгалтерии 3

29.09.16

Задачи пользователя - Адаптация типовых решений

Устраняем ошибку "При открытии формы регламентированного отчета произошла ошибка.", релиз 3.0.44.124.

Выполним всего 2 шага:

1. В модуле формы Отчет.РегламентированныйОтчетБухОтчетность.ФормаОтчета2011Кв4, процедура ОбновитьСоставДополнительныхСтрокИзСохраненныхДанных, в ней есть строки:
Для Каждого СтрокаУровня1 Из СохраненныйСоставДопстрокБаланса.Строки Цикл
	Для Каждого СтрокаУровня2 Из СтрокаУровня1.Строки Цикл
		ИмяОбластиДопСтроки = СтрокаУровня2.ИмяОбластиДопСтроки;
		НайденнаяСтрока = РегламентированнаяОтчетностьКлиентСервер.НайтиЭлементВДанныхФормыДерево(ЭтаФорма[СоставДополнительныхСтрок.СтруктураСоставов.Баланс].ПолучитьЭлементы(), "ИмяОбластиДопСтроки", ИмяОбластиДопСтроки);
		Если НайденнаяСтрока <> Неопределено Тогда
			НайденнаяСтрока.ВключатьВОтчет = СтрокаУровня2.ВключатьВОтчет;
		КонецЕсли;
	КонецЦикла;
КонецЦикла;

нужно заменить:

НайденнаяСтрока = РегламентированнаяОтчетностьКлиентСервер.НайтиЭлементВДанныхФормыДерево(ЭтаФорма[СоставДополнительныхСтрок.СтруктураСоставов.Баланс].ПолучитьЭлементы(), "ИмяОбластиДопСтроки", ИмяОбластиДопСтроки);

на

НайденнаяСтрока = РегламентированнаяОтчетностьКлиентСервер.НайтиЭлементВДанныхФормыДерево(ДеревоНастроекБаланс.Строки, "ИмяОбластиДопСтроки", ИмяОбластиДопСтроки);

2. В общем модуле РегламентированнаяОтчетностьКлиентСервер, функция НайтиЭлементВДанныхФормыДерево, в ней строки

Если ЭлементДерева.ПолучитьЭлементы().Количество() > 0 Тогда
			
	РезультатПоиска = НайтиЭлементВДанныхФормыДерево(ЭлементДерева.ПолучитьЭлементы(), ИмяКолонки, ИскомоеЗначение);
	
	Если НЕ РезультатПоиска = Неопределено Тогда
		Возврат РезультатПоиска;
	КонецЕсли;
	
КонецЕсли;

заменить на

Если ТипЗнч(ЭлементДерева) = Тип("СтрокаДереваЗначений") Тогда
	
	
	Если ЭлементДерева.Строки.Количество() > 0 Тогда
		
		РезультатПоиска = НайтиЭлементВДанныхФормыДерево(ЭлементДерева.Строки, ИмяКолонки, ИскомоеЗначение);
		
		Если НЕ РезультатПоиска = Неопределено Тогда
			Возврат РезультатПоиска;
		КонецЕсли;
		
	КонецЕсли;
	
Иначе

	Если ЭлементДерева.ПолучитьЭлементы().Количество() > 0 Тогда
		
		РезультатПоиска = НайтиЭлементВДанныхФормыДерево(ЭлементДерева.ПолучитьЭлементы(), ИмяКолонки, ИскомоеЗначение);
		
		Если НЕ РезультатПоиска = Неопределено Тогда
			Возврат РезультатПоиска;
		КонецЕсли;
		
	КонецЕсли;
	
КонецЕсли;

ошибка регламентированная отчетность отчетность бухгалтерия

См. также

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    5137    11    5    

20

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3517    8    0    

27

Адаптация типовых решений Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4709    dimanich70    15    

20

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    3551    dimanich70    8    

16

Адаптация типовых решений Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2774    21    avmartynov    14    

53

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2850    43    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. МимохожийОднако 142 05.10.16 08:05 Сейчас в теме
Стесняюсь спросить, как устранить подобную ошибку, если она возникла в базовой версии?
2. VladC# 64 06.10.16 07:00 Сейчас в теме
(1) МимохожийОднако, боюсь что в базовой это не возможно, здесь один вариант - ждать обновления с исправлениями от 1С.
3. clev 6 28.07.20 18:17 Сейчас в теме
Возникла такая же ошибка при открытии формы "Статистика: Форма 22-ЖКХ (жилище)".

Проблема была в непроинициализированном параметре ЭтотОбъект.СтруктураРеквизитовФормы.ФлажокОтклАвтоРасчет

Добавил в расширение (в модуль формы отчета РегламентированныйОтчетСтатистикаФорма22ЖКХжилище) код:

&НаСервере
&Перед("УстановитьЗащитуИЦветФонаОбластейАвторассчитываемыхПоказате­лей")
Процедура rss_УстановитьЗащитуИЦветФонаОбластейАвторассчитываемыхПоказ­ателей()
	Если ЭтотОбъект.СтруктураРеквизитовФормы.ФлажокОтклАвтоРасчет = Неопределено Тогда
		ЭтотОбъект.СтруктураРеквизитовФормы.ФлажокОтклАвтоРасчет = Ложь;
	КонецЕсли;;
КонецПроцедуры


ошибка пропала.
4. znarul02 06.08.20 08:32 Сейчас в теме
а где именно, в какой области добавлял?
6. clev 6 11.08.20 17:56 Сейчас в теме
(4) Написал же, в модуле формы отчета РегламентированныйОтчетСтатистикаФорма22ЖКХжилище нашел процедуру, в которой возникала ошибка, она называется "УстановитьЗащитуИЦветФонаОбластейАвторассчитываемыхПоказате­­лей".
Эту процедуру добавил в свое расширение, с инструкцией "Перед", см. код. в (3)
(5) не понял, скрин чего нужно сделать?
чем-то надо помочь?
5. znarul02 06.08.20 08:35 Сейчас в теме
(3)можно скрин пожалуйста
7. user1710709 30.06.22 11:58 Сейчас в теме
здравствуйте. Бухгалтерия предприятия, редакция 3.0 (3.0.115.15) , возникла подобная ошибка. Решение такое же, как выше описали?
Прикрепленные файлы:
8. Angel_itself 14.07.22 10:01 Сейчас в теме
(7)Точно такая же ошибка Бухгалтерия предприятия, редакция 3.0 (3.0.115.15) после переезда с 2.0, что делать не знаем, бухгалтера клюют (((
10. tristan 28.09.22 15:11 Сейчас в теме
У меня сегодня не открылась Бухгалтерская отчетность за 2021 год по одной организации. Бухгалтерия предприятия вер. 3.0.121.23. Ошибка такая же. Добавил расширение конфигурации типа исправление. Заменил две процедуры в РегламентированныйОтчетБухОтчетность:ФормаОтчета2019Кв1.

&НаКлиентеНаСервереБезКонтекста
&Вместо("УстановитьЗначениеПоказателя")
Процедура Испр_БухОтчетУстановитьЗначениеПоказателя(РазмещениеДанных, ИмяПоказателя, ЗначениеПоказателя)
Если ТипЗнч(РазмещениеДанных) = Тип("ТабличныйДокумент") Тогда
РазмещениеДанных.Области[ИмяПоказателя].Значение = ЗначениеПоказателя;
Иначе
Если РазмещениеДанных.Свойство(ИмяПоказателя) Тогда
РазмещениеДанных[ИмяПоказателя] = ЗначениеПоказателя;
КонецЕсли;
КонецЕсли;
КонецПроцедуры

&НаКлиентеНаСервереБезКонтекста
&Вместо("ПоказательОтчета")
Функция Испр_БухОтчетПоказательОтчета(Форма, РазмещениеДанных, ИмяПоказателя)
ЗначениеПоказателя = 0;

Если ТипЗнч(РазмещениеДанных) = Тип("ТабличныйДокумент") Тогда
ЗначениеПоказателя = РазмещениеДанных.Области[ИмяПоказателя].Значение;
Иначе
Если РазмещениеДанных.Свойство(ИмяПоказателя) Тогда
ЗначениеПоказателя = РазмещениеДанных[ИмяПоказателя];
Иначе
ЗначениеПоказателя =0;
КонецЕсли;
КонецЕсли;

Возврат ЗначениеПоказателя;
КонецФункции
Оставьте свое сообщение