Вывод ФИО физлиц в форму перехода по страницам регламентированного отчета "Расчет по страховым взносам"

25.05.17

Задачи пользователя - Адаптация типовых решений

Вывод ФИО физлиц в форму перехода по страницам регламентированного отчета "Расчет по страховым взносам"

Доработка сделана на конфигурации Управление производственным предприятием, редакция 1.3 (1.3.90.2).

В разделе 3 регламентированного отчета "Расчет по страховым взносам" при переходе по страницам отчета выводятся только номера листов:

Доработка выводит ФИО физлиц в эту же форму.

В форму "ФормаСпискаДопСтраниц" обработки "ОбщиеОбъектыРегламентированнойОтчетности" добавляем колонку "Физлицо" с типом Строка и делаем ее невидимой:

В общий модуль "РегламентированнаяОтчетность" в процедуру "роОткрытьФормуСпискаДопСтраниц" между строками "ФормаВыбораДопСтраницы.НачальноеЗначениеВыбора = СтруктураДанных;" и "ВыбранноеЗначение = ФормаВыбораДопСтраницы.ОткрытьМодально();" вставляем следующий код:

	ФормаВыбораДопСтраницы.ЭлементыФормы.ТаблицаДопСтраниц.Колонки.Физлицо.Видимость = Истина;
		
	Если ТаблицаСтраницРаздела.Колонки.Найти("Физлицо") = Неопределено Тогда
		ТаблицаСтраницРаздела.Колонки.Добавить("Физлицо");
	КонецЕсли; 
	
	Для каждого Строка Из ТаблицаСтраницРаздела Цикл
		Строка.Физлицо = Строка.Данные.П000310008001 + " " +
						 Строка.Данные.П000310009001 + " " + 
						 Строка.Данные.П000310010001;
	КонецЦикла; 

Должно получиться вот так:

Обновляем конфигурацию базы данных. Результат:

Расчет по страховым взносам Раздел 3

См. также

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4862    10    5    

19

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3238    5    0    

22

Каждому менеджеру нужен свой Excel

Адаптация типовых решений Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4326    dimanich70    15    

18

Создать на основании - своя кнопка (БСП). Проблема двух подменю Создать на основании

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2378    dimanich70    8    

14

Доработка отчета "Связанные документы" (структура подчиненности) для вывода объектов из любого расширения

Адаптация типовых решений Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2274    19    avmartynov    14    

44

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2478    34    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. BoneD 615 25.05.17 16:07 Сейчас в теме
В ЗУП 2.5 сделал похожее (расчётчики жаловались на сложность поиска), но я только заменил надпись "Лист № хх" на "ФИО, хххх г.р." наподобие ЗУП 3.1.
В этой самой процедуре после строки
НомерСтраницы = НомерСтраницы + 1;

добавил
Если СтрокаТаблицы.Данные.Свойство("П000310008001") И ИмяСтраницы = "Раздел3" Тогда
    СтрокаТаблицы.Представление = СтрокаТаблицы.Данные.П000310008001 + " " + СтрокаТаблицы.Данные.П000310009001 + " " + СтрокаТаблицы.Данные.П000310010001 + ", " + Формат(СтрокаТаблицы.Данные.П000310011001, "ДЛФ=D") + " г.р.";
КонецЕсли;
Оставьте свое сообщение