Планировщик 1С. Настройка расписания повторяющихся событий и перемещение элементов мышью

Публикация № 661739

Разработка - Практика программирования

БСП задачи календарь планировщик

Для самописной конфигурации на базе БСП была разработана обработка "Календарь", в которой используется планировщик 1С. В публикации пойдёт речь о реализации с его помощью некоторых задач, таких как перетаскивание элементов календаря мышью или настройка повторения событий по расписанию.

В нашем "Календаре" отображаются стандартные "Задачи исполнителя" и элементы собственного справочника "События".

На основании справочника "События" можно стартовать бизнес-процессы, кроме того, для них доступна настройка повторения по расписанию. Нужно отметить, что повторяются события только в календаре, новые элементы справочника при этом не создаются. А вот бизнес-процессы на основании этих виртуальных повторяемых событий должны создаваться вполне реальные, с реальными датами. Рассмотрим пример реализации данной задачи.

Справочник "События" выглядит следующим образом:

Форма:

В режиме "Предприятие":

Расписание - реквизит формы с типом значения "Произвольный". При его редактировании свойства расписания записываются в реквизиты события, а при создании формы события - наооборот.

&НаКлиенте
Процедура ПослеИзмененияРасписания(РасписаниеРезультат, ДополнительныеПараметры) Экспорт
	
	Если РасписаниеРезультат <> Неопределено Тогда
		
		Модифицированность = Истина;
		Расписание = РасписаниеРезультат;
				
		ЗаполнитьЗначенияСвойств(Объект, Расписание);	
		
		//дни недели
		Объект.ПовторениеПоДнямНедели.Очистить();
		Для Каждого Элемент из Расписание.ДниНедели Цикл
			Строка = Объект.ПовторениеПоДнямНедели.Добавить();
			Строка.День = Элемент;
		КонецЦикла;		
		
		//месяцы
		Объект.ПовторениеПоМесяцам.Очистить();
		Для Каждого Элемент из Расписание.Месяцы Цикл
			Строка = Объект.ПовторениеПоМесяцам.Добавить();
			Строка.Месяц = Элемент;
		КонецЦикла;		
		
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура РасписаниеНажатие(Элемент, СтандартнаяОбработка)
	
	СтандартнаяОбработка = ложь;
	
	Обработчик = Новый ОписаниеОповещения("ПослеИзмененияРасписания", ЭтотОбъект);
	ДиалогРасписания = Новый ДиалогРасписанияЭлементаПланировщика(?(НЕ ТипЗнч(Расписание) = Тип("РасписаниеЭлементаПланировщика"), Новый РасписаниеЭлементаПланировщика, Расписание));
	ДиалогРасписания.Показать(Обработчик);
	
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьРасписание()
	
	Элементы.Расписание.Видимость = Объект.Повторять;
	
	Если Объект.Повторять Тогда
		
		Расписание = Новый РасписаниеЭлементаПланировщика;
		ЗаполнитьЗначенияСвойств(Расписание, Объект);
		Расписание.ДниНедели = Объект.ПовторениеПоДнямНедели.Выгрузить().ВыгрузитьКолонку("День");
		Расписание.Месяцы = Объект.ПовторениеПоМесяцам.Выгрузить().ВыгрузитьКолонку("Месяц");	
		
		Если Расписание.ПериодЛет=0 И Расписание.ПериодМесяцев=0 И Расписание.ПериодНедель=0 И Расписание.ПериодПовтораДней=0 Тогда
			Расписание = "настроить расписание...";
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

При заполнении календаря расписание элементов заполняется сходным образом:

//{Заполняем текст запроса по событиям}

Выборка = Запрос.Выполнить().Выбрать();
	
ДанныеКалендаря.Элементы.Очистить();
	
Пока Выборка.Следующий() Цикл

    Элемент = ДанныеКалендаря.Элементы.Добавить(НачалоДня(Выборка.ДатаНачала), КонецДня(Выборка.ДатаОкончания));			
    Элемент.Текст = Выборка.Наименование;
		
  	Элемент.Значение = Выборка.Ссылка;						
	
  	Если Выборка.Ссылка.Повторять Тогда
    	Элемент.Расписание = Новый РасписаниеЭлементаПланировщика;
	    ЗаполнитьЗначенияСвойств(Элемент.Расписание, Выборка.Ссылка);
	    Элемент.Расписание.ДниНедели = Объект.ПовторениеПоДнямНедели.Выгрузить().ВыгрузитьКолонку("День");
	    Элемент.Расписание.Месяцы = Объект.ПовторениеПоМесяцам.Выгрузить().ВыгрузитьКолонку("Месяц");					
   	КонецЕсли;

КонецЦикла;

Планировщик 1С обрабатывает элементы с заполненным расписанием следующим образом: на каждый период повтора создаётся элемент планировщика с датами начала и окончания, соответствующими периоду повтора, и значением единственного реального элемента, который мы добавили при обходе выборки.

Выглядит это так:

Обработка "ПередНачаломРедактирования" элемента планировщика у нас нестандартная и вызывает открытие формы задачи/события в зависимости от типа значения. Но какой бы элемент из повторяющихся мы не открывали, даты начала и окончания в форме будут исходные, в данном случае 18.08.2017 и 19.08.2017. 

Значит, из календаря будем открывать форму с параметрами, и обрабатывать их при создании на сервере.

&НаСервере
Функция ПолучитьПараметрыФормыСобытия(Событие, Начало, Конец)
	
	ПараметрыФормы = Новый Структура("Ключ, ПовторяемыйЭлемент, ДатаНачалаЭлементаПовторения, ДатаОкончанияЭлементаПовторения", Событие, Событие.Повторять, Начало, Конец);
	
	Возврат ПараметрыФормы;
	
КонецФункции

&НаКлиенте
Процедура ДанныеКалендаряПередНачаломРедактирования(Элемент, НовыйЭлемент, СтандартнаяОбработка)
	
	СтандартнаяОбработка = ложь;	
	
	Если НЕ НовыйЭлемент Тогда
		
		ВыбранныйЭлемент = Элемент.ВыделенныеЭлементы[0];
		ЗначениеЭлемента = ВыбранныйЭлемент.Значение;
		
		Если ТипЗнч(ЗначениеЭлемента) = Тип("ЗадачаСсылка.ЗадачаИсполнителя") Тогда
			ПоказатьЗначение(,ЗначениеЭлемента);
		ИначеЕсли ТипЗнч(ЗначениеЭлемента) = Тип("СправочникСсылка.События") Тогда
			ПараметрыФормы = ПолучитьПараметрыФормыСобытия(ЗначениеЭлемента, ВыбранныйЭлемент.Начало, ВыбранныйЭлемент.Конец);
			ОткрытьФорму("Справочник.События.ФормаОбъекта", ПараметрыФормы);
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

Обработчик при создании формы события:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	ЗаполнитьРасписание();
	
	ДатаНачалаЭлементаПовторения = Параметры.ДатаНачалаЭлементаПовторения;
	ДатаОкончанияЭлементаПовторения = Параметры.ДатаОкончанияЭлементаПовторения;
	ПовторяемыйЭлемент = Параметры.ПовторяемыйЭлемент;

КонецПроцедуры

Если присмотреться, на размещённом в начале статьи скриншоте с формой события по два элемента с заголовками "Дата начала" и "Дата окончания". В зависимости от того, повторяемый это элемент или основной, видны либо реальные "Дата начала" и "Дата окончания", либо реквизиты формы "Дата начала элемента повторения" и "Дата окончания элемента повторения".

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	Элементы.ДатаНачала.Видимость = НЕ ПовторяемыйЭлемент;
	Элементы.ДатаНачалаЭлементаПовторения.Видимость = ПовторяемыйЭлемент;
	
	Элементы.ДатаОкончания.Видимость = НЕ ПовторяемыйЭлемент;
	Элементы.ДатаОкончанияЭлементаПовторения.Видимость = ПовторяемыйЭлемент;
	
	Элементы.ФормаКоманднаяПанель.ПодчиненныеЭлементы["ФормаСоздатьНаОсновании"].Видимость = НЕ ПовторяемыйЭлемент;
	Элементы.ФормаГруппаСоздатьНаОсновании.Видимость = ПовторяемыйЭлемент;
	
КонецПроцедуры

Стандартный ввод на основании для повторяемых элементов тоже пришлось переписать:

&НаКлиенте
Процедура ВводНаОсновании(Команда)
	
	Основание = Новый Структура("Ссылка, Начало, Конец", Объект.Ссылка, ДатаНачалаЭлементаПовторения, ДатаОкончанияЭлементаПовторения);
	ПараметрыФормы = Новый Структура("Основание", Основание);
	ОткрытьФорму("БизнесПроцесс.СложноеЗадание.ФормаОбъекта", ПараметрыФормы);
	
КонецПроцедуры

Разумеется, все запущенные на основании повторяемых элементов бизнес-процессы будут подчинены единственному реальному событию.

А теперь о реализации так полюбившейся пользователям функции - перемещения элементов календаря мышкой с сохранением изменений. Планировщик позволяет перемещать элементы и изменять их границы мышью "из коробки". При этом у элементов планировщика меняются даты начала и окончания. Осталось только записать их в реальные объекты.

&НаКлиенте
Процедура ДанныеКалендаряПриОкончанииРедактирования(Элемент, НовыйЭлемент, ОтменаРедактирования)
	
	Для Каждого ВыделенныйЭлемент Из Элемент.ВыделенныеЭлементы Цикл
		ОбновитьДатыЗаписиКалендаря(ВыделенныйЭлемент.Значение, ВыделенныйЭлемент.Начало, ВыделенныйЭлемент.Конец);
	КонецЦикла;
		
КонецПроцедуры

&НаСервере
Процедура ОбновитьДатыЗаписиКалендаря(ЗаписьКалендаря, ДатаНачала, ДатаОкончания)
	
	ЗаписьКалендаряОбъект = ЗаписьКалендаря.ПолучитьОбъект();
	
	Если ТипЗнч(ЗаписьКалендаря) = Тип("СправочникСсылка.События") Тогда
		
		ЗаписьКалендаряОбъект.ДатаНачала = ДатаНачала;
		ЗаписьКалендаряОбъект.ДатаОкончания = ДатаОкончания;		
		
	ИначеЕсли ТипЗнч(ЗаписьКалендаря) = Тип("ЗадачаСсылка.ЗадачаИсполнителя") Тогда
		
		Если ЗначениеЗаполнено(ЗаписьКалендаряОбъект.ДатаПринятияКИсполнению) Тогда
			ЗаписьКалендаряОбъект.ДатаПринятияКИсполнению = ДатаНачала;
		ИначеЕсли ЗначениеЗаполнено(ЗаписьКалендаряОбъект.ДатаНачала) Тогда
			ЗаписьКалендаряОбъект.ДатаНачала = ДатаНачала;
		Иначе
			ЗаписьКалендаряОбъект.Дата = ДатаНачала;
		КонецЕсли;
			
		ЗаписьКалендаряОбъект.СрокИсполнения = ДатаОкончания;
		
	КонецЕсли;		
	
	ЗаписьКалендаряОбъект.Записать();
			
КонецПроцедуры

Удобно выделять элементы планировщика разных видов цветом. У элемента есть свойства "ЦветФона", "ЦветТекста" и "ЦветРамки". В зависимости от тех или иных условий можно выбирать какие угодно их сочетания. Планировщик сам позаботится о том, чтобы элементы остались видимыми. В нашей конфигурации задачи, не принятые к исполнению, выделяются одним цветом, принятые - другим, а для каждого события цвет выбирается пользователем и сохраняется в справочнике в реквизите типа "ХранилищеЗначений". При заполнении планировщика данными цвет события устанавливается так:

//получим цвет события
СобытиеОбъект = Выборка.Ссылка.ПолучитьОбъект();
СохранённыйЦвет = СобытиеОбъект.Цвет.Получить();
Если Не СохранённыйЦвет = неопределено Тогда
	ЦветСобытия = СохранённыйЦвет;
Иначе
	ЦветСобытия = ЦветаСтиля.СобытиеКалендаря;
КонецЕсли;	
Элемент.ЦветФона = ЦветСобытия;	

Вот и всё самое интересное, что мне удалось выяснить в процессе работы с планировщиком. Возможно, кому-нибудь эта информация будет полезна.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. user878162 20.06.18 11:10 Сейчас в теме
Добрый день.
Подскажите пожалуйста, а как реализовали сам запуск по расписанию процессов? Именно с учетом периодичности. Как определяете что наступило время выполнить нужное действие?

Разбираюсь с подобной задачей, планировщик просто отрисовывает элементы с установленной периодичностью, но у него нет методов для проверки входит ли конкретная дата в этот диапазон. Подскажите в какую сторону смотреть и как проверить принадлежность определенной даты периодичности установленной в задании. Надеюсь понятно сформулировал :-)
2. WhiteOwl 363 20.06.18 17:27 Сейчас в теме
(1) а это уже совершенно другая история))) При завершении бизнес-процесса смотрим в его расписание и вручную анализируем - если повтор по дням, то ищем следующий подходящий день, если еженедельно - то через неделю и т.п. Определив дату, стартуем следующий бизнес процесс. Подробностей я, к сожалению, уже не помню. Можно посмотреть как реализован типовой повтор регламентных заданий. Также, возможно, что-то подобное есть в конфигурации "Документооборот" от 1С.
nlvhome; user878162; +2 Ответить
3. user878162 21.06.18 04:41 Сейчас в теме
4. mrcamomile 45 13.12.18 17:45 Сейчас в теме
(1) Можно вот так выкрутиться

РасписаниеЭП - расписание элемента планировщика
Функция ПолучитьДатыПоРасписанию(Знач ДатаНачала, Знач ДатаОкончания, РасписаниеЭП = Неопределено) Экспорт 
	
	Результат = Новый Массив;
	
	ДатаМаксимум = '21000101';
	ДатаНачала = НачалоДня(ДатаНачала);
	ДатаОкончания = НачалоДня(ДатаОкончания);
	Результат.Добавить(ДатаНачала);
	
	Если РасписаниеЭП = Неопределено Тогда 
		Возврат Результат;
	КонецЕсли;
		
	РРЗ = Новый РасписаниеРегламентногоЗадания;
	ЗаполнитьЗначенияСвойств(РРЗ, РасписаниеЭП);
	ДатаНачалаПоследнегоЗапуска = Результат[0];
	Пока 
		(ДатаОкончания = '00010101' И ДатаНачала < ДатаМаксимум)
		ИЛИ (ДатаОкончания > '00010101' И ДатаНачала < ДатаОкончания)
	Цикл
		ДатаНачала = ДатаНачала + 86400;
		ТребуетсяВыполнение = РРЗ.ТребуетсяВыполнение(ДатаНачала, ДатаНачалаПоследнегоЗапуска);
		Если ТребуетсяВыполнение Тогда
			Результат.Добавить(ДатаНачала);
			ДатаНачалаПоследнегоЗапуска = ДатаНачала;
		КонецЕсли;
	КонецЦикла; 
	
	Возврат Результат;
	
КонецФункции
Показать
5. mrcamomile 45 13.12.18 18:09 Сейчас в теме
(4) вот отличия между "РасписаниеРегламентногоЗадания" / "РасписаниеЭлементаПланировщика"
Прикрепленные файлы:
6. TheDemonHrono 24.02.19 19:50 Сейчас в теме
А как скачать, чтобы посмотреть по ближе?
7. WhiteOwl 363 24.02.19 21:56 Сейчас в теме
(6) к сожалению, никак. Это часть нетиповой конфигурации.
9. Adept 21.01.20 09:35 Сейчас в теме
А можешь показать код переключения представлений День/Неделя/Месяц?
Оставьте свое сообщение

См. также

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions Промо

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    4348    comol    22    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    10863    quazare    33    

Форма выбора (подбор) в управляемых формах

Практика программирования v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

Разбор небольших примеров того, как правильно открывать форму выбора (подбора) в управляемых формах, не прибегая к модальным окнам.

08.05.2020    35499    user5300    16    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    39073    ids79    26    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    38445    unichkin    74    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    30500    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    23208    kuzyara    38    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    18806    YPermitin    60    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    32044    tormozit    104    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    9838    Sibars    19    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    33155    HostHost    41    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    40129    Yashazz    50    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    79293    tormozit    131    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    14568    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    67072    rpgshnik    68    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    58191    ids79    55    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    50052    tormozit    48    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    33197    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    27050    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    35239    ids79    16    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    46727    tormozit    74    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    106745    ids79    63    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    43915    avalakh    26    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    29148    json    15    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16420    m-rv    2    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    75834    ids79    14    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    39904    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    28332    YPermitin    14    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20955    m-rv    17    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    20404    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    59119    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    60373    ids79    26    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    32296    m-rv    21    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    27019    dmurk    146    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    49624    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    37829    ellavs    126    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28840    itriot11    34    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    28602    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    34471    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    48443    Смешной 1С    31    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    78366    Serginio    113    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    24135    Vladimir Litvinenko    28    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    37382    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    46306    ids79    11    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    28971    ids79    31    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    30130    grumagargler    31    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    45713    ids79    75