Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35)

Публикация № 674880

Разработка - Печать - Печатные формы документов

БСП 2.4.3 БСП 2.3.6 релиз Бухгалтерии 3.0.52.35 команды печати механизм печати печатные формы Бухгалтерия 3.0 БП 3.0 самописный документ свой документ новый документ нетиповой документ.

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

В статье //infostart.ru/public/237013/ пользователя nick max  рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6.
В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков.
Рассмотрим их.

1. В процедуре ПриСозданииНаСервере изменился код с:

&НаСервере 
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) 
         УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма, Элементы.ГруппаПечать)
КонецПроцедуры 

на:

&НаСервере 
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
           // СтандартныеПодсистемы.ПодключаемыеКоманды
           ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
           // Конец СтандартныеПодсистемы.ПодключаемыеКоманды
КонецПроцедуры

Замечание: Подменю ГруппаПечать на форме теперь не нужно создавать и передавать в параметр.

2. В Форме Документа вместо процедуры

&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
          УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект)
КонецПроцедуры  

теперь целых три:

// СтандартныеПодсистемы.ПодключаемыеКоманды
&НаКлиенте 
Процедура Подключаемый_ВыполнитьКоманду(Команда)
          ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры 

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
          ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Объект, Результат);
КонецПроцедуры 

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
          ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
КонецПроцедуры 
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды

 

а в Формы Списка вместо:

(помним, что Объект заменяется на Элементы.Список)

&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
         УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Элементы.Список)
КонецПроцедуры

будет четыре:

&НаСервере
Процедура НастройкиДинамическогоСписка()
         Отчеты.РеестрДокументов.НастройкиДинамическогоСписка(ЭтотОбъект);
КонецПроцедуры

// СтандартныеПодсистемы.ПодключаемыеКоманды
&НаКлиенте 
Процедура Подключаемый_ВыполнитьКоманду(Команда)
         Если Команда.Имя = "ПодменюПечатьОбычное_Реестр" Тогда 
             НастройкиДинамическогоСписка();
         КонецЕсли;
         ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Элементы.Список);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
          ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Элементы.Список, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
          ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Элементы.Список);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды

 

3. И то, чего нет в указанной статье:

В общем модуле УправлениеПечатьюПереопределяемый, в процедуре ПриОпределенииОбъектовСКомандамиПечати  нужно добавить свои созданные документы, для которых нужна печать:

Процедура ПриОпределенииОбъектовСКомандамиПечати(СписокОбъектов) Экспорт
               ....
               СписокОбъектов.Добавить(Документы.ФормированиеЗаписейРаздела7ДекларацииНДС);
               ////////////////////Свои документы
               СписокОбъектов.Добавить(Документы.МойДокумент1);
               СписокОбъектов.Добавить(Документы.МойДокумент2);
               ....
КонецПроцедуры 

 

В Модуле Менеджера всё остается без изменений.

(для полноты приведен урезанный код примера Модуля Менеджера из указанной статьи //infostart.ru/public/237013/ )

Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт 
                  КомандаПечати = КомандыПечати.Добавить();
                  КомандаПечати.Идентификатор = "Акт";
                  КомандаПечати.Представление = "Дополнительный акт";
                  КомандаПечати.Обработчик    = "УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати";
                  КомандаПечати.СписокФорм    = "ФормаСписка,ФормаДокумента";
КонецПроцедуры 

Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт 
                ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;
                Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "Акт") Тогда  УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "Акт", "Акт",
                               СформироватьНесколькоАктов(МассивОбъектов),"Документ.Приказ.Акт");
                КонецЕсли;
КонецПроцедуры 

Функция   СформироватьНесколькоАктов(МассивОбъектов)
            ТабДокумент = Новый ТабличныйДокумент;
            Для каждого Ссылка из МассивОбъектов Цикл
                       ТабДокументОбъекта = СформироватьАкт(Ссылка);
                       Если ТабДокумент.ВысотаТаблицы > 0 И ТабДокументОбъекта.ВысотаТаблицы > 0 Тогда 
                                   ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц()
                       КонецЕсли;
                       ТабДокумент.Вывести(ТабДокументОбъекта)
           КонецЦикла;
           Возврат ТабДокумент
КонецФункции 

Функция  СформироватьАкт(Ссылка)
             ТабДокумент = Новый ТабличныйДокумент;
             // подготовка ТабДокумента
             Возврат ТабДокумент
КонецФункции 

 

 

Специальные предложения

Лучшие комментарии
2. Vladimir Litvinenko 18.09.17 13:42 Сейчас в теме
Насколько понимаю эта информация относится в целом к БСП 2.4.3 https://its.1c.ru/db/bsp243doc#content:9323:hdoc , не только к Бухгалтерии 3.0.52.35. А значит справедлива для предстоящих обновлений всех типовых конфигураций. Сравните с документацией по БСП 2.3.6 https://its.1c.ru/db/bsp23doc#content:1728:hdoc.

Было бы хорошо изменить заголовок публикации. Тема касается большего количества пользователей, чем может заинтересовать заголовок.
Остальные комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. dkonakov 8 18.09.17 13:07 Сейчас в теме
Спасибо, очень вовремя написанная статья!
2. Vladimir Litvinenko 18.09.17 13:42 Сейчас в теме
Насколько понимаю эта информация относится в целом к БСП 2.4.3 https://its.1c.ru/db/bsp243doc#content:9323:hdoc , не только к Бухгалтерии 3.0.52.35. А значит справедлива для предстоящих обновлений всех типовых конфигураций. Сравните с документацией по БСП 2.3.6 https://its.1c.ru/db/bsp23doc#content:1728:hdoc.

Было бы хорошо изменить заголовок публикации. Тема касается большего количества пользователей, чем может заинтересовать заголовок.
3. dkonakov 8 18.09.17 13:47 Сейчас в теме
(2) Первыми столкнулись именно пользователи БП 3.0.
4. and_r 18.09.17 20:13 Сейчас в теме
Большое спасибо за статью! Уже голову сломал как вернуть печать, все сделал кроме общего модуля
Death_eye; portal2011; +2 Ответить
5. Бубузяка 62 20.09.17 09:14 Сейчас в теме
1. Что касается БП 3.0, то эта статья для тех кто не знает, что это можно прочитать в файле "UpdateSSLhtm" в каталоге, куда устанавливается БСП 2.4. Скачайте БСП 2.4 и получите порядок обновления этой подсистемы и прочих, которые поменялись в 2.4. К тому же 1С поставляет обработку, которая модифицирует код старой версии БСП в объектах, подключенных к БСП при внедрении.

2. Порядок внедрения БСП изложен в документации https://its.1c.ru/db/bsp244doc/ в картинках и кусках кода для вставки, если делать по шагам, то проблем не возникает.
Death_eye; Vyacheslav_Kochnev; user705522_constantin_h; berezdetsky; h00k; the1; +6 Ответить
6. vicmos 42 25.09.17 23:16 Сейчас в теме
Большое спасибо за помощь!!!!!!!!
7. shumvlesu 26.09.17 17:34 Сейчас в теме
&НаКлиенте 
Процедура Подключаемый_ВыполнитьКоманду(Команда)
         Если Команда.Имя = "ПодменюПечатьОбычное_Реестр" Тогда 
             НастройкиДинамическогоСписка();
         КонецЕсли;
         ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Элементы.Список);
КонецПроцедуры


У меня ругалось на ВыполнитьКоманду пока не глянул в параметры этой процедуры. Элементы.Список должен содержать поле - Ссылка. Версия БСП - 2.4.2.25
Светлый ум; CepeLLlka; LosevI; LomayaZakat; +4 Ответить
8. Korolev 49 28.09.17 10:17 Сейчас в теме
Благодарю за публикацию. Пригодилась! :)
9. l2qweit 28.09.17 15:09 Сейчас в теме
Огромное человеческое спасибо !!! особенно за.

В общем модуле УправлениеПечатьюПереопределяемый, в процедуре ПриОпределенииОбъектовСКомандамиПечати нужно добавить свои созданные документы, для которых нужна печать:
Death_eye; Genda; +2 Ответить
10. nipil 03.10.17 18:32 Сейчас в теме
Есть косяк именно в бухгалтерии 3.0.52.*.
Для подключенных "Дополнительных отчетов и обработок" в "ФормеСписка" для документов пропала кнопка - "Отчеты...".
Причем в БСП все нормально работает.
Глубоко не копал. Тестовую конфигурацию вылечил:

...."Включить возможность изменения"
Документы.ПлатежныеПоручения.ФормаСписка
ГруппаКоманднаяПанель добавил ПодменюПечать.

Сейчас пытаюсь написать дополнительную обработку которая по кнопке "Печать " восстановит кнопку "Отчеты...". (Опять зубы через задницу лечить...)
11. nipil 04.10.17 19:22 Сейчас в теме
Решил расширением конфигурации.
Общий модуль - Подключаемые команды
&После("ВывестиКоманды")
Процедура рПП_ВывестиКоманды(Форма, Команды, ПараметрыРазмещения)
	Если Форма.Имяформы = "Документ.ПлатежноеПоручение.Форма.ФормаСписка" Тогда
		// Сменим родителя ПодменюОтчеты
			ЭлементПодменюОтчеты = Форма.Элементы.Найти("ПодменюОтчеты");
			ЭлементГруппаКоманднаяПанель = Форма.Элементы.Найти("ГруппаКоманднаяПанель");
			Форма.Элементы.Переместить(ЭлементПодменюОтчеты,ЭлементГруппаКоманднаяПанель);
	КонецЕсли;
КонецПроцедуры
Показать
12. Dunda 48 06.10.17 15:16 Сейчас в теме
ОООООООО спасибо огромное! Методом тыка нашла лишние процедуры, теперь по вашей статье попробую до конца доделать
13. Alex_1974 26 09.10.17 13:28 Сейчас в теме
Присоединяюсь к благодарившим, очень вовремя, просто спасли!!!
14. iiceberg 89 18.10.17 10:18 Сейчас в теме
Добавлю свои 5 копеек.
Когда добавляете (переписываете) под БСП 2.4 свои объекты, по мимо действий указанных в статье, по крайней мере для ERP 2.4, необходимо проделать еще несколько манипуляций, что бы вся эта магия от 1С версии 2.4 заработала.
А конкретно надо сделать следующее:
Для Добавления команд Отчеты, ввод на основании надо указать БСП, что для этого объекта надо использовать механизм "стандартных подсистем". Делаем следующее:
- для отчетов: Общий модуль "ВариантыОтчетовПереопределяемый" процедура "ОпределитьОбъектыСКомандамиОтчетов" добавляем свой объект в массив.

- для Ввода на основании: Общий модуль "СозданиеНаОснованииПереопределяемый" процедура "ПриОпределенииОбъектовСКомандамиСозданияНаОсновании" добавляем свой объект в массив.

для печати, заполнения и проч. видимо тоже есть процедуры, но я их не искал и не использовал из-за ненадобности (пока еще) =).

надеюсь сэкономил полчаса работы.
programmer_87; sandra; bugtester; +3 Ответить
15. agent00mouse 206 26.10.17 10:02 Сейчас в теме
Обе статьи актуальны, т.к. есть и самописаные конфы, созданные ещё во времена динозавров.
16. Shaldryn 01.11.17 12:16 Сейчас в теме
Статья пригодилась, спасибо, как раз делали переход с КА 2.2 на 2.4
правда я так понял команда печати для формы регистра сведений это не прокатит, там идет сравнение типов, на этом все и рушится, по старой схеме раньше работало все...
17. serg0776 22 16.11.17 10:16 Сейчас в теме
т.е. при следующем обновлении эта процедура затрется ПриОпределенииОбъектовСКомандамиПечати
И так отслеживать это постоянно.
19. aldan 19 22.11.17 14:46 Сейчас в теме
(17) Меня тоже это печалит. Уже несколько раз добавлял свои документы после обновления. Не возникло идей, каким образом можно избавиться от редактирования "ПриОпределенииОбъектовСКомандамиПечати" чтобы после обновления не пропадали печатные печатные формы в "своих" документах?
18. serg0776 22 16.11.17 10:29 Сейчас в теме
Такое ощущение, что студенты писали код
Как будто нельзя через Метаданные это сделать!
Супер универсальность.
т.е. если завтра у разработчиков будет новый объект, и если они забыли про этот модуль то печати не будет в этом объекте. КЛАСС.

Функция УниверсальнаяСтруктураОписанияОбъектовПодключаемыхКоманд() Экспорт
	
	//:::Справочники
	ИменаСправочников = Новый Массив;
	ИменаСправочников.Добавить("Банки");
	ИменаСправочников.Добавить("БанковскиеСчета");
	ИменаСправочников.Добавить("ВидыНалогов");
	ИменаСправочников.Добавить("ВидыСкидокНаценок");
	ИменаСправочников.Добавить("ВидыЦен");
	ИменаСправочников.Добавить("ВидыЦенКонтрагентов");
	ИменаСправочников.Добавить("ВнеоборотныеАктивы");
	ИменаСправочников.Добавить("ДоговорыКонтрагентов");
	ИменаСправочников.Добавить("Кассы");
	ИменаСправочников.Добавить("КассыККМ");
	ИменаСправочников.Добавить("Комиссии");
	ИменаСправочников.Добавить("КлючевыеРесурсы");
	ИменаСправочников.Добавить("КонтактныеЛица");
	ИменаСправочников.Добавить("Контрагенты");
	ИменаСправочников.Добавить("НаправленияДеятельности");
	ИменаСправочников.Добавить("Номенклатура");
	ИменаСправочников.Добавить("КатегорииНоменклатуры");
	ИменаСправочников.Добавить("НомераГТД");
	ИменаСправочников.Добавить("Организации");
	ИменаСправочников.Добавить("ПартииНоменклатуры");
	ИменаСправочников.Добавить("СценарииПланирования");
	ИменаСправочников.Добавить("ПравилаОбменаСПодключаемымОборудованиемOffline");
	ИменаСправочников.Добавить("Проекты");
	ИменаСправочников.Добавить("Сотрудники");
	ИменаСправочников.Добавить("Спецификации");
	ИменаСправочников.Добавить("СтатьиДвиженияДенежныхСредств");
	ИменаСправочников.Добавить("СтруктурныеЕдиницы");
	ИменаСправочников.Добавить("ФизическиеЛица");
	ИменаСправочников.Добавить("ХарактеристикиНоменклатуры");
	ИменаСправочников.Добавить("Ячейки");
	
	//:::Документы
	ИменаДокументов = Новый Массив;
	ИменаДокументов.Добавить("АвансовыйОтчет");
	ИменаДокументов.Добавить("АктВыполненныхРабот");
	ИменаДокументов.Добавить("АмортизацияВА");
	ИменаДокументов.Добавить("Бюджет");
	ИменаДокументов.Добавить("ВводНачальныхОстатков");
	ИменаДокументов.Добавить("Взаимозачет");
	ИменаДокументов.Добавить("ВыработкаВА");
	ИменаДокументов.Добавить("Доверенность");
	ИменаДокументов.Добавить("ДополнительныеРасходы");
	ИменаДокументов.Добавить("ЗаданиеНаРаботу");
	ИменаДокументов.Добавить("ЗаказНаПроизводство");
	ИменаДокументов.Добавить("ЗаказПокупателя");
	ИменаДокументов.Добавить("ЗаказПоставщику");
	ИменаДокументов.Добавить("ЗакрытиеМесяца");
	ИменаДокументов.Добавить("ИзменениеПараметровВА");
	ИменаДокументов.Добавить("ИнвентаризацияЗапасов");
	ИменаДокументов.Добавить("КадровоеПеремещение");
	ИменаДокументов.Добавить("КорректировкаРеализации");
	ИменаДокументов.Добавить("КорректировкаРегистров");
	ИменаДокументов.Добавить("МаршрутныйЛист");
	ИменаДокументов.Добавить("НачислениеЗарплаты");
	ИменаДокументов.Добавить("НачислениеНалогов");
	ИменаДокументов.Добавить("НачисленияПоКредитамИЗаймам");
	ИменаДокументов.Добавить("Операция");
	ИменаДокументов.Добавить("ОперацияПоПлатежнымКартам");
	ИменаДокументов.Добавить("ОприходованиеЗапасов");
	ИменаДокументов.Добавить("ОтчетКомиссионера");
	ИменаДокументов.Добавить("ОтчетКомитенту");
	ИменаДокументов.Добавить("ОтчетОПереработке");
	ИменаДокументов.Добавить("ОтчетОРозничныхПродажах");
	ИменаДокументов.Добавить("ОтчетПереработчика");
	ИменаДокументов.Добавить("ПередачаВА");
	ИменаДокументов.Добавить("ПеремещениеДС");
	ИменаДокументов.Добавить("ПеремещениеДСПлан");
	ИменаДокументов.Добавить("ПеремещениеЗапасов");
	ИменаДокументов.Добавить("ПеремещениеПоЯчейкам");
	ИменаДокументов.Добавить("ПереоценкаВРозницеСуммовойУчет");
	ИменаДокументов.Добавить("ПересортицаЗапасов");
	ИменаДокументов.Добавить("ПланПродаж");
	ИменаДокументов.Добавить("ПлатежнаяВедомость");
	ИменаДокументов.Добавить("ПлатежноеПоручение");
	ИменаДокументов.Добавить("ПоступлениеВКассу");
	ИменаДокументов.Добавить("ПоступлениеДСПлан");
	ИменаДокументов.Добавить("ПоступлениеНаСчет");
	ИменаДокументов.Добавить("ПриемИПередачаВРемонт");
	ИменаДокументов.Добавить("ПриемНаРаботу");
	ИменаДокументов.Добавить("ПринятиеКУчетуВА");
	ИменаДокументов.Добавить("ПриходнаяНакладная");
	ИменаДокументов.Добавить("ПриходныйОрдер");
	ИменаДокументов.Добавить("ПрочиеРасходы");
	ИменаДокументов.Добавить("РаспределениеЗатрат");
	ИменаДокументов.Добавить("РасходДСПлан");
	ИменаДокументов.Добавить("РасходИзКассы");
	ИменаДокументов.Добавить("РасходнаяНакладная");
	ИменаДокументов.Добавить("РасходныйОрдер");
	ИменаДокументов.Добавить("РасходСоСчета");
	ИменаДокументов.Добавить("РезервированиеЗапасов");
	ИменаДокументов.Добавить("СборкаЗапасов");
	ИменаДокументов.Добавить("СведенияОЗастрахованныхЛицахСЗВ_М");
	ИменаДокументов.Добавить("СверкаВзаиморасчетов");
	ИменаДокументов.Добавить("СдельныйНаряд");
	ИменаДокументов.Добавить("Событие");
	ИменаДокументов.Добавить("СписаниеВА");
	ИменаДокументов.Добавить("СписаниеЗапасов");
	ИменаДокументов.Добавить("СправкаНДФЛ");
	ИменаДокументов.Добавить("СчетНаОплату");
	ИменаДокументов.Добавить("СчетНаОплатуПоставщика");
	ИменаДокументов.Добавить("СчетФактура");
	ИменаДокументов.Добавить("СчетФактураПолученный");
	ИменаДокументов.Добавить("Табель");
	ИменаДокументов.Добавить("Увольнение");
	ИменаДокументов.Добавить("УчетВремени");
	ИменаДокументов.Добавить("ЧекККМ");
	ИменаДокументов.Добавить("ЧекККМВозврат");
	
	СтруктураОписания = Новый Структура;
	СтруктураОписания.Вставить("Справочники", ИменаСправочников);
	СтруктураОписания.Вставить("Документы", ИменаДокументов);
	
	Возврат СтруктураОписания;
	
КонецФункции 
Показать
45. MikeI 90 12.12.19 14:31 Сейчас в теме
(18) Класс - это очень емко. У меня только не цензурная лексика.
20. kosikov_oleg 27.11.17 10:59 Сейчас в теме
Спасибо! Очень своевременно.
21. user705522_constantin_h 27 27.11.17 11:53 Сейчас в теме
Спасибо! Хорошая статья.
22. yase 24.12.17 16:34 Сейчас в теме
Спасибо. Добавлю еще неочевидный момент:
в форме списка в динамическом списке ОБЯЗАТЕЛЬНО должна быть Ссылка (писали выше). Но если ее видимость отключить в пользовательском режиме (или в конфигураторе - не важно), то печать перестает работать.
Выход: в настройках поля включить флаг "Использовать всегда".
Вот цитата с итс:
Внимание. Поле Ссылка динамического списка формы должно быть доступно в обработчике команды. Для этого необходимо в свойствах поля Ссылка, вложенного в реквизит формы типа ДинамическийСписок, включить флажок Использовать всегда.
Suslik_Johns; CepeLLlka; Boyborodin; Thalt; LomayaZakat; +5 Ответить
48. Suslik_Johns 30.12.19 13:40 Сейчас в теме
(22) Спасибо! Вы меня спасли!
23. Saifa 30 20.02.18 13:49 Сейчас в теме
Вот это да! Сутки промучилась, прежде чем нашла пилюлю... Слов нет. Спасибо вам!
Suslik_Johns; +1 Ответить
24. sandra 25.02.18 15:16 Сейчас в теме
Спасибо! Я тоже несколько часов убила, пока нашла в чем дело. А надо было сначала статьи от умных людей почитать))
В итоге от добавления команд печати средствами БСП решила отказаться - перспектива при каждом обновлении восстанавливать затертый код не радует(((
newvideo; +1 Ответить
25. arshanskiyav 9 09.03.18 21:03 Сейчас в теме
Делаю расширение со своим док-ом, из-за этого момента чуть не забросил мысль о расширении.
Скрытый текст
26. nysysimara 25 10.05.18 13:42 Сейчас в теме
спасибо за подробное описание
27. demetrius2003 31 23.06.18 15:55 Сейчас в теме
Что то я не понимаю. Разве никто не наткнулся на нескладушки? Статья нихрена не универсальная! В УТ (11.4.1.273), к примеру, нет УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати!
КомандаПечати.Обработчик    = "УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати";

Не будет работать! Более того, в УправлениеПечатьюУТКлиент нет ничего похожего на ВыполнитьКомандуПечати! Т. е. как быть в случае с УТ вообще непонятно! Не работает эта херня в УТ!
newvideo; +1 Ответить
29. LosevI 15.08.18 09:18 Сейчас в теме
(27) Да, в УТ это не работает, такого общего модул, конечно же, нет.
А если пользоваться "УправлениеПечатьюКлиент.ВыполнитьКомандуПечати", то выдает уже другую ошибку:
Обращение к процедуре объекта как к функции (ВыполнитьКомандуПечати)
Вообщем, как адаптировать для УТ пока не разобрался. У вас нашлось решение?
43. TimoninD 02.10.19 05:12 Сейчас в теме
(29) Если убрать обработчик "КомандаПечати.Обработчик = "УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати" "
, то в УТ все будет работать.
Suslik_Johns; +1 Ответить
28. ПрестарелыйЗаяц 28.06.18 22:01 Сейчас в теме
У меня все работает, чего там у тебя не работает непонятно. Автору респект.
30. kiyamov 2 23.08.18 16:20 Сейчас в теме
ЗУП 3.1. Ни в какую не появляется кнопка "Печать" в справочнике "Справки физических лиц". Делаю через расширение. Добавил в ПриОпределенииОбъектовСКомандамиПечати СписокОбъектов.Добавить(Справочники.СправкиФизическихЛиц). Прописал в ПриСозданииНаСервере ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект). Толку нет. Кнопка не пояляется. Что я делаю не так?
31. oksimisis 20.09.18 03:28 Сейчас в теме
Спасибо большущее! Сутки голову ломаю, найти не могла где собака порылась.
32. BadMadJohn 33 16.10.18 22:02 Сейчас в теме
Спасибо большое. Чутье подсказывало, что где-то теперь нужно указывать документы в которых должны подключаться команды, думал в каком-то регистре сведений. Хорошо что есть гугл, который по запросу "команды печати 1с БСП" вывел прямиком на вашу статью. Не пришлось долго искать.
33. Геннадьевич 15 17.10.18 13:28 Сейчас в теме
Спасибо. Очень полезно.
Как сделать добавление под кнопку "Печать" внешних печатных форм добавленных в базу?
34. scarabey2006 12 21.11.18 10:31 Сейчас в теме
Спасибо, пригодилось, не получилось пока с журналом документов и формой списка, ругается по всякому, буду разбираться
35. natik_82 21.12.18 08:09 Сейчас в теме
Отличная статья! Очень помогла!!!
36. user619273_alevtina 27.12.18 12:04 Сейчас в теме
Спасибо! Во время, очень помогло.
37. user619273_alevtina 27.12.18 12:05 Сейчас в теме
Спасибо! Очень помогли. Очень вовремя увидела вашу статью.
38. demetrius2003 31 11.01.19 13:08 Сейчас в теме
Апну немного тему! Граждане! Общего описания этого загадошного механизма нет ни у кого? УТ так и не работает данный вариант. Более того! В самой УТ в разных доках реализовано это по разному! И от релиза к релизу ботва эта меняется со скоростью света! Может кто описать процесс? В общих чертах?
39. newvideo 27.01.19 14:22 Сейчас в теме
во всех статьях в сети УправлениеПечатьюБПКлиент

В УНФ 1.6.5. БСП 2.3.1.53
в модуле УправлениеПечатьюСлужебныйКлиент
в процедуре ВыполнитьПодключаемуюКомандуПечатиПодготовкаОбъектовПечати
вываливается:

{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(125)}: Ошибка компиляции при вычислении выражения или выполнении фрагмента кода Результат = Вычислить(Обработчик);
по причине:
{(1,1)}: Переменная не определена (УправлениеПечатьюБПКлиент)
<<?>>УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати(ОписаниеКоманды)

Менял в Модуле Менеджера Документа
УправлениеПечатьюБПКлиент на УправлениеПечатьюКлиент и также на
Подключаемый_ВыполнитьКомандуПечати
всёравно ошибки, куда же копать?

БПКлиент только в Бух и работает, кто-нибудь нашел решение для других конфигураций?
40. newvideo 27.01.19 14:28 Сейчас в теме
Уточню в УНФ 1.6.5. БСП 2.3.2.53
Глянул в отладчике какой параметр у КомандаПечати.Обработчик в стандартной печати, оказывается никакого нет.
Поэтому указал КомандаПечати.Обработчик = "";
Заработало
Suslik_Johns; +1 Ответить
41. selez-a 16 21.05.19 08:53 Сейчас в теме
Спасибо автору. Сэкономил уйму времени.
42. Sergynia 2 08.06.19 00:32 Сейчас в теме
44. Alani 15.11.19 16:04 Сейчас в теме
Благодарю!!! Тоже намучилась с этой кнопкой печати при обновлении. "3. И то, чего нет в указанной статье:" помогло, поскольку остальное я уже на сто раз проверила.
46. нинас 27.12.19 11:08 Сейчас в теме
Спасибо за статью. И мне помогло
47. Suslik_Johns 30.12.19 13:39 Сейчас в теме
Вдруг кто-то тоже мучается - напишу о своем)

Кнопка печати в форме документа была и работала.
В форме списка была, но не активна.

Решилось так:
Кнопка стала активна после добавления:
в модуле менеджера:
Процедура ДобавитьКомандыПечати(КомандыПечати)
строчки:
КомандаПечати.СписокФорм = "ФормаСписка,ФормаДокумента"; (не было этой строчки вообще)

Но все же при нажатии не работала, Вылезала ошибка:
"Команда не может быть выполнена для указанного объекта".

Решение следующее:
В форме списка документа добавила еще одно поле - поле Ссылка. После этого печать заработала (вдруг кому еще пригодится)!
Прочитала об этом выше в комментариях:
http://forum.infostart.ru/forum8/topic178004/message1903429/#message1903429

Спасибо всем за помощь!)
49. z_serg_v 520 06.02.20 13:24 Сейчас в теме
БП 3.0.75.70
Создал расширение:Расш_1 добавил 2 общих модуля в расширение и добавил в общие модули старые процедуры ПриСозданииНаСервере(.......


ОбщиеМодули.УправлениеПечатью
// Устарела. Следует использовать ПодключаемыеКоманды.ПриСозданииНаСервере.
// Размещает команды печати на форме.
//
// Параметры:
//   Форма                            - УправляемаяФорма - форма, в которой необходимо разместить подменю Печать.
//   МестоРазмещенияКомандПоУмолчанию - ЭлементФормы - группа, в которую необходимо разместить подменю Печать,
//                                                     по умолчанию размещается в командную панель формы.
//   ОбъектыПечати                    - Массив - список объектов метаданных, для которых необходимо сформировать
//                                               объединенное подменю Печать.
Процедура ПриСозданииНаСервере(Форма, МестоРазмещенияКомандПоУмолчанию = Неопределено, ОбъектыПечати = Неопределено) Экспорт
	ПараметрыРазмещения = ПодключаемыеКоманды.ПараметрыРазмещения();
	Если ТипЗнч(МестоРазмещенияКомандПоУмолчанию) = Тип("ГруппаФормы") Тогда
		Если МестоРазмещенияКомандПоУмолчанию.Вид = ВидГруппыФормы.Подменю
			Или МестоРазмещенияКомандПоУмолчанию.Заголовок = НСтр("ru = 'Печать'")
			Или МестоРазмещенияКомандПоУмолчанию.Имя = "ПодменюПечать" Тогда
			Родитель = МестоРазмещенияКомандПоУмолчанию.Родитель;
			Если ТипЗнч(Родитель) = Тип("ГруппаФормы") Тогда
				ПараметрыРазмещения.КоманднаяПанель = Родитель;
			КонецЕсли;
		Иначе
			ПараметрыРазмещения.КоманднаяПанель = МестоРазмещенияКомандПоУмолчанию;
		КонецЕсли;
	КонецЕсли;
	Если ТипЗнч(ОбъектыПечати) = Тип("Массив") Тогда
		ПараметрыРазмещения.Источники = ОбъектыПечати;
	КонецЕсли;
	ПодключаемыеКоманды.ПриСозданииНаСервере(Форма, ПараметрыРазмещения);
КонецПроцедуры


ОбщиеМодули.ДополнительныеОтчетыИОбработки

// Устарела. Следует использовать ПодключаемыеКоманды.ПриСозданииНаСервере.
//
// Параметры:
//   Форма - УправляемаяФорма - Форма.
//   ТипФормы - Строка - Тип формы.
//
Процедура ПриСозданииНаСервере(Форма, ТипФормы = Неопределено) Экспорт
	Возврат;
КонецПроцедуры
Показать


Тоже заработало
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    36753    unichkin    46    

Полезные функции БСП (Часть 2)

БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

Список полезных функций из состава Библиотеки стандартных подсистем 3.1.

10.03.2020    10533    user5300    15    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    21649    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    20314    John_d    22    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    29240    tormozit    100    

Последовательности событий. Шпаргалка

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    15151    kuzyara    33    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    16189    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    7814    Sibars    19    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    77163    tormozit    131    

Шпаргалка (БСП). Добавление в новый документ механизма печати дополнительных печатных форм

Печать БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Постоянно приходится вспоминать, как добавить механизм печати (БСП) в новый документ. Поэтому решил написать шпаргалку.

10.10.2019    15870    John_d    14    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    29968    Yashazz    46    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    43242    rpgshnik    63    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    47449    tormozit    40    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    44988    ids79    54    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    26000    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    24783    YPermitin    80    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    43694    tormozit    74    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    29954    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    71187    ids79    49    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    31299    avalakh    22    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    15836    m-rv    2    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    21392    json    13    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    52723    ids79    11    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    33615    ids79    27    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    19815    m-rv    17    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    25053    YPermitin    13    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19260    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    41192    ids79    17    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    29914    m-rv    21    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    48559    ids79    25    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    23895    dmurk    144    

Подсистема "Варианты отчетов". Используете ли Вы ее правильно?

Работа с интерфейсом БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    39081    YPermitin    52    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    27978    itriot11    34    

Подсистема БСП «Управление доступом», основные объекты и регистры

БСП (Библиотека стандартных подсистем) Роли и права v8 v8::УФ v8::Права 1cv8.cf Бесплатно (free)

Основные принципы работы подсистемы «Управление доступом» из состава БСП. Виды доступа, ограничение доступа на уровне записей. Описание основных объектов и регистров, используемых подсистемой.

23.05.2019    20643    ids79    9    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    40229    YPermitin    30    

Выполнение внешней обработки в фоновом задании

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    28298    Eret1k    23    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    75390    Serginio    108    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    34062    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    26459    ellavs    88    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    30274    YPermitin    53    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    33605    ids79    40    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    35733    Смешной 1С    27    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    20875    Vladimir Litvinenko    27    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    28833    grumagargler    28    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    36600    ids79    9    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    25676    ids79    31    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    51715    m-rv    61    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    39395    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    35759    ids79    40