Настройка заполнения дополнительных полей в ТОРГ-12 и счетах-фактурах ЭДО 1С-Такском УПП 1.3 (на примере ЭДО с ПАО "Татнефть имени Д.В. Шашина")

17.04.19

Функциональные - Документооборот и делопроизводство (СЭД)

Как настроить заполнение доп. полей в формате ФНС 5.01 для счета-фактуры и Торг-12.

Однажды в наш отдел прилетела задача: наладить ЭДО с ПАО "Татнефть" с минимумом вложений по соглашению ЭДО, предусматривающему обязательное заполнение доп полей в счетах-фактурах и товарных накладных (номер договора, код подразделения получателя, ГУИД документа и т.д.). 

Задача достаточно простая, но есть несколько нюансов, на которые стоит обратить внимание, чтобы не терять понапрасну время.

Далее написано для УПП 1.3.106.1 и платформы 8.2.19.130

Решение:

  1.  Подключить 1С-Такском - система ЭДО, встроенная в большинство типовых конфигураций 1С 8, обратившись к обслуживающему партнеру. Буквально в течение часа специалист франчайзи  подключил услугу, настроил ключи ЭЦП, форматы отправки, послал приглашения контрагенту. Бесплатно 100 документов в месяц при подписке ИТС Проф. Подробности на оф сайте https://portal.1c.ru/applications/8.
     
  2. Обязательно проверьте правильность заполнения данных в справочнике "Контрагенты", "Договоры контрагентов"
    • Обновите КЛАДР, справочник банков (Устаревшее название банка в торг - отказ)
    • Контактная информация должна быть заполнена и заполнена по классификатору адресов (российский адрес был заполнен как зарубежный - неизвестный код страны - отказ)
    • У контрагента должен быть заведен банковский счет и он должен быть помечен как "Основной" (банковские реквизиты не попадали в торг-12 без пометки счета "Основным" - отказ)
       
  3. Суть обмена - создается файл xml, подписывается и средствами оператора ЭДО передается контрагенту, который его подписывает и тем принимает к учету.
    В УПП этот файл создается как:
    • в процедуре СформироватьХМЛФайл общего модуля ЭлектронныеДокументыСлужебный определяется по ключу функция, для каждого вида электронного документа своя. Нас интересуют
      • для ТОРГ-12  (формат 551 приказа ФНС) - ЭлектронныеДокументыВнутренний.СформироватьПередачаТоваровПродавец
      • для счета-фактуры - ЭлектронныеДокументыВнутренний.СформироватьИнформациюПродавца
    • В этих функциях происходит заполнение ДереваЗначений данными документа-источника и вызов одноименной функции с добавлением xml (ЭлектронныеДокументыВнутренний.СформироватьПередачаТоваровПродавецXML и т.д.), которая уже и формирует сам xml файл на основе переданного дерева значений.
  4. Таким образом нам остается только перед вызовом функции СформироватьПередачаТоваровПродавецXML дополнить ДеревоЗначений своими реквизитами. Все заполняемые доп. поля должны быть проверены на непустое значение (проблемы при отправке - несоответствие формату ФНС)
    • Для ТОРГ-12 узел дерева называется "ДопДанные.Подписанные" и новые строки в него добавляются функцией ДобавитьЗначениеВДерево или ВставитьЗначениеВДерево. Отличия в том, что ВставитьЗначениеВДерево проверяет наличие узла дерева по имени и меняет его значение, если найдено, если не найдено - создает новый узел, а ДобавитьЗначениеВДерево без проверок добавляет новый узел в дерево.
    • Для счета-фактуры - "ДопДанныеСчетаФактуры.ТекстоваяИнформация" и узлы добавляются функцией ОбщегоНазначенияЭД.ДобавитьЗаписьВТаблицуДерева.
       

В качестве примера привожу код по заполнению дополнительных полей, обязательных при ЭДО с ПАО "Татнефть им. Шашина Д.В.".  Здесь доп поля используются для автоматических процессов согласования и доставки документа до адресата (http://1c-edo.ru/reviews/2601/). Передаются номер договора, дата договора, код подразделения (храним в свойствах контрагента), уникальный идентификатор документа -он используется для связи счета-фактуры и ТОРГ-12 и должен совпадать для одного комплекта документов.

 
Код общего модуля mokЭДОТатнефть:
Процедура ДобавитьДопПоляВТОРГ12Татнефть(СтрокаДерева, СсылкаНаОбъект) Экспорт;
	
	Если Не (СсылкаНаОбъект.Контрагент = ygЗначенияНепредопределенныхОбъектов.ПолучитьЗначениеПоИдентификатору("КонтрагентТатнефть")) Тогда
		Возврат;	
    КонецЕсли;

		Попытка
		//Обязательные доп поля	
			Номер_Договора = Лев(СсылкаНаОбъект.ДоговорКонтрагента.Номер, 200);
			Дата_Договора = Лев(Формат(СсылкаНаОбъект.ДоговорКонтрагента.Дата, "ДФ=dd.MM.yyyy"), 200); 
			
			ИдентификаторСвойстваПодразделениеПолучателя = ygЗначенияНепредопределенныхОбъектов.ПолучитьЗначениеПоИдентификатору("ТатнефтьСвойствоПодразделение");
			Подразделение_получатель = YgМодульПривилегированный.ПолучитьЗначениеСвойстваОбъекта(СсылкаНаОбъект.Грузополучатель, ИдентификаторСвойстваПодразделениеПолучателя);
			
			ИдентификаторДокументаОснования = Строка(СсылкаНаОбъект.УникальныйИдентификатор());

		Исключение
		   Сообщить("Обратись в ОИТ");
		   Сообщить(ОписаниеОшибки());
	    КонецПопытки;
		
		Если НЕ ЗначениеЗаполнено(Номер_Договора) Тогда
			ВызватьИсключение "Не заполнен номер договора в документе ";
		КонецЕсли;
		
		Если НЕ ЗначениеЗаполнено(Дата_Договора) Тогда
			ВызватьИсключение "Не заполнена дата договора в документе ";
		КонецЕсли;
		
		Если НЕ ЗначениеЗаполнено(Подразделение_получатель) Тогда
			ВызватьИсключение "Не заполнен код структурного подразделения Татнефти";
		КонецЕсли;

		ДобавитьЗначениеВДерево(СтрокаДерева,	"ДопДанные.Подписанные.Номер_договора", 					Номер_Договора);
		ДобавитьЗначениеВДерево(СтрокаДерева,	"ДопДанные.Подписанные.Дата_договора", 						Дата_Договора);
		ДобавитьЗначениеВДерево(СтрокаДерева,	"ДопДанные.Подписанные.Подразделение_получатель", 			Подразделение_получатель);
        ВставитьЗначениеВДерево(СтрокаДерева, 	"ДопДанные.Подписанные.ИдентификаторДокументаОснования", 	ИдентификаторДокументаОснования)
	
КонецПроцедуры

Процедура ДобавитьЗначениеВДерево(ДеревоДанных, ИмяРеквизита, ЗначениеРеквизита)
	
	НовСтрока = ДеревоДанных.Строки.Добавить();
	НомерУровня = СтрЧислоВхождений(ИмяРеквизита, ".") + 1;
	НовСтрока.ПолныйПуть = ИмяРеквизита;
	НовСтрока["Уровень" + НомерУровня] = ОбщегоНазначенияЭД.НазваниеКолонки(ИмяРеквизита);
	НовСтрока.Значение = ЗначениеРеквизита;

КонецПроцедуры

Процедура ВставитьЗначениеВДерево(ДеревоДанных, ИмяРеквизита, ЗначениеРеквизита)
	
	НовСтрока = ДеревоДанных.Строки.Найти(ИмяРеквизита, "ПолныйПуть", Истина);
	Если НовСтрока = Неопределено Тогда
		НовСтрока = ДеревоДанных.Строки.Добавить();
		НомерУровня = СтрЧислоВхождений(ИмяРеквизита, ".") + 1;
		НовСтрока.ПолныйПуть = ИмяРеквизита;
		НовСтрока["Уровень" + НомерУровня] = ОбщегоНазначенияЭД.НазваниеКолонки(ИмяРеквизита);
	КонецЕсли;
	НовСтрока.Значение = ЗначениеРеквизита;

КонецПроцедуры

Процедура ДобавитьДопПоляВСЧФТатнефть(ДеревоДанных, ТекстоваяИнформация, СсылкаНаОбъект) Экспорт;
	
	Если Не (СсылкаНаОбъект.Контрагент = ygЗначенияНепредопределенныхОбъектов.ПолучитьЗначениеПоИдентификатору("КонтрагентТатнефть")) Тогда
		Возврат;	
    КонецЕсли;

	Попытка
		//Обязательные доп поля	
		Номер_Договора = Лев(СсылкаНаОбъект.ДоговорКонтрагента.Номер, 200);
		Дата_Договора = Лев(Формат(СсылкаНаОбъект.ДоговорКонтрагента.Дата, "ДФ=dd.MM.yyyy"), 200); 
		
		ИдентификаторСвойстваПодразделениеПолучателя = ygЗначенияНепредопределенныхОбъектов.ПолучитьЗначениеПоИдентификатору("ТатнефтьСвойствоПодразделение");
		Подразделение_получатель = YgМодульПривилегированный.ПолучитьЗначениеСвойстваОбъекта(СсылкаНаОбъект.ДокументОснование.Грузополучатель, ИдентификаторСвойстваПодразделениеПолучателя);

		ДокументОснование =  СсылкаНаОбъект.ДокументыОснования[0].ДокументОснование;
		ИдентификаторДокументаОснованияСчф = Строка(ДокументОснование.УникальныйИдентификатор());
		
		Исключение
		   Сообщить("Обратись в ОИТ");		   
		   Сообщить(ОписаниеОшибки());
		   ВызватьИсключение "Fatal error";
	    КонецПопытки;

		Если НЕ ЗначениеЗаполнено(Номер_Договора) Тогда
			ВызватьИсключение "Не заполнен номер договора в документе ";
		КонецЕсли;
		
		Если НЕ ЗначениеЗаполнено(Дата_Договора) Тогда
			ВызватьИсключение "Не заполнена дата договора в документе ";
		КонецЕсли;
		
		Если НЕ ЗначениеЗаполнено(Подразделение_получатель) Тогда
			ВызватьИсключение "Не заполнен код структурного подразделения Татнефти";
		КонецЕсли;
		                                                                                                                               
		Если НЕ ЗначениеЗаполнено(ИдентификаторДокументаОснованияСчф) Тогда
			ВызватьИсключение "Не существующий документ";
		КонецЕсли;
		
		НоваяСтрока = ТекстоваяИнформация.Добавить();
		НоваяСтрока.Идентификатор = "Номер_договора";
		НоваяСтрока.Значение = Номер_Договора;
		ОбщегоНазначенияЭД.ДобавитьЗаписьВТаблицуДерева(ДеревоДанных, НоваяСтрока, "ДопДанныеСчетаФактуры.ТекстоваяИнформация");

		НоваяСтрока = ТекстоваяИнформация.Добавить();
		НоваяСтрока.Идентификатор = "Дата_договора";
		НоваяСтрока.Значение = Дата_Договора;
		ОбщегоНазначенияЭД.ДобавитьЗаписьВТаблицуДерева(ДеревоДанных, НоваяСтрока, "ДопДанныеСчетаФактуры.ТекстоваяИнформация");

		НоваяСтрока = ТекстоваяИнформация.Добавить();
		НоваяСтрока.Идентификатор = "ИдентификаторДокументаОснования";
		НоваяСтрока.Значение = ИдентификаторДокументаОснованияСчф;
		ОбщегоНазначенияЭД.ДобавитьЗаписьВТаблицуДерева(ДеревоДанных, НоваяСтрока, "ДопДанныеСчетаФактуры.ТекстоваяИнформация");

		НоваяСтрока = ТекстоваяИнформация.Добавить();
		НоваяСтрока.Идентификатор = "Подразделение_получатель";
		НоваяСтрока.Значение = Подразделение_получатель;
		ОбщегоНазначенияЭД.ДобавитьЗаписьВТаблицуДерева(ДеревоДанных, НоваяСтрока, "ДопДанныеСчетаФактуры.ТекстоваяИнформация");

КонецПроцедуры


 

Вызываем соответствующие процедуры в функциях прямо перед формированием xml файла

  • В функции ЭлектронныеДокументыВнутренний.СформироватьПередачаТоваровПродавец

     

    //............................................
    //Мы заполняем доп поля
    mokЭДОТатнефть.ДобавитьДопПоляВТОРГ12Татнефть(СтрокаДопДанных, СсылкаНаОбъект);
    //Здесь формируется файл xml	
    Если СформироватьПередачаТоваровПродавецCML(ДеревоДанных) И ПризнакЭД Тогда
    
    .......

     

  • В функции ЭлектронныеДокументыВнутренний.СформироватьИнформациюПродавца

     

     
    //............................................
    .....
    //Перед формированием файла добавляем свои доп поля	
    mokЭДОТатнефть.ДобавитьДопПоляВСЧФТатнефть(ДеревоДанных, ТекстоваяИнформация, СсылкаНаОбъект);
    
    //Тут на основе ДеревоДанных формируется xml
    РезультатФормирования = СформироватьИнформациюПродавцаXML(ДеревоДанных);
    .......
    

    UPD 17.04.2019

  • В УПП, начиная с версии 1.3.117.1 внесены изменения в модуль ЭлектронныеДокументыВнутренний
    Теперь для заполнения доп полей в Счет-фактуре нужно внести изменения в процедуры
    СформироватьИнформациюПродавца_5_01 и СформироватьИнформациюПродавца_2019

ЭДО Татнефть ТОРГ12 счет-фактура доп поля 1С-Такском

См. также

Документооборот и делопроизводство (СЭД) Типовые Бухгалтер Пользователь Руководитель проекта Платформа 1С v8.3 Управленческий учет Платные (руб)

Организуйте правильный оборот документов на вашем предприятии в 1С. Ведение учета и хранения документов. Управление потоками документации между подразделениями. Работа с договорами в компании. Автоматизация процессов подготовки, согласования и подписания документов. Сократите время и объем ошибок с 1С:ДО!

48500 руб.

19.02.2016    107728    108    5    

89

Внешние источники данных Программист Бизнес-аналитик Пользователь Платформа 1С v8.3 Управляемые формы Анализ и прогнозирование Конфигурации 1cv8 Узбекистан Беларусь Кыргызстан Молдова Россия Казахстан Платные (руб)

Готовое решение для автоматической выгрузки данных из 1С 8.3 в базу данных ClickHouse, PostgreSQL или Microsoft SQL для работы с данными 1С в BI-системах. «Экстрактор данных 1С в BI» работает со всеми типовыми и нестандартными конфигурациями 1С 8.3 и упрощает работу бизнес-аналитиков. Благодаря этому решению, специалистам не требуется быть программистами, чтобы легко получать данные из 1С в вашей BI-системе.

15.11.2022    16011    15    SQV0    48    

34

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    137487    756    292    

400

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    47992    208    64    

170

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69860    172    143    

113

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    184185    570    509    

514

Документооборот и делопроизводство (СЭД) Платформа 1С v8.3 Платные (руб)

"1С:Архив" – это универсальная система, обеспечивающая надежное долговременное хранение документов с гарантией юридической значимости на неограниченный срок. "1С:Архив" разработан на основе нормативно-правовых актов по архивному делу, поддерживает операции хранения документов – от попадания в архив до уничтожения – и не имеет ограничений на объем хранимых данных. "1С:Архив" сопровождается методологической поддержкой в виде организационных документов по хранению, входящих в состав "Комплекта нормативных документов" к "Методике управления документами и совместной работой", разработанной специалистами фирмы "1С". Использование "1С:Архива" позволяет организовать единое хранилище всех бумажных и электронных документов из разных информационных систем, вести архивный учет в соответствии с требованиями Росархива и снизить нагрузку на учетные системы. Продукт подходит для малых, средних, крупных предприятий и учреждений любых отраслей.

90000 руб.

24.10.2022    5109    6    1    

6

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.228.x) и БП 3.0 (3.0.154.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21473    139    40    

98
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. пользователь 25.04.18 08:27
Сообщение было скрыто модератором.
...
2. khabibullin.tu 95 25.04.18 17:15 Сейчас в теме
Как раз нужно сделать обмен с Татнефтью, спасибо тебе !
3. ojleg 12 25.04.18 19:22 Сейчас в теме
(2) да не за что) сам просидел почти две недели, пока пытался с Диадоком это провернуть и привел в соответствие справочники. С такскомом оказалось все проще. Проверь данные в своих справочниках - по пункту 2, а лучше в Татнефть запроси. Очень неприятно, когда возвращают документы из-за запятых, а чтобы исправить ЭД нужно кучу телодвижений совершить.
4. khabibullin.tu 95 25.04.18 23:22 Сейчас в теме
(3) Учту обязательно !) Вы случайно не в Альметьевске находитесь ?
5. ojleg 12 26.04.18 04:59 Сейчас в теме
6. twiny 15 08.05.18 00:40 Сейчас в теме
во-во, в тему) благодарю, тоже собрался писать уже, правда для БП3

как бы вам СМ подкинуть за работу вашу
7. ojleg 12 08.05.18 05:26 Сейчас в теме
(6)Damir, рад был помочь.
Публикация сделана в формате бесплатной статьи специально. Задача простая, код не универсальный.
8. serq82 8 12.09.18 12:51 Сейчас в теме
а что в модулях ygЗначенияНепредопределенныхОбъектов и YgМодульПривилегированный?
9. ojleg 12 12.09.18 19:31 Сейчас в теме
(8)
ygЗначенияНепредопределенныхОбъектов

Вы, наверняка, сталкивались с тем, что нужно обратиться в коде к не предопределенным элементам.
НайтиПоКоду("000000001") и т. д. А это вызывает проблемы при изменениях, особенно когда используется в нескольких местах.
Мы сделали регистр сведений с измерением типа Строка и Ресурсом - Любая Ссылка.
И обращаемся к этому регистру когда нужно получить не предопределенное значение.
В этом модуле только одна функция, которая работает с этим регистром.


(8)
YgМодульПривилегированный

Общий модуль с признаком привилегированный. Используется для разных целей.
10. twiny 15 12.09.18 22:29 Сейчас в теме
(9)
Мы сделали регистр сведений с измерением типа Строка и Ресурсом - Любая Ссылка.
И обращаемся к этому регистру когда нужно получить не предопределенное значение.
В этом модуле только одна функция, которая работает с этим регистром.


Есть более "стабильный" способ. Где-то здесь подсмотрел. Это когда вместо РС создается справочник с одним реквизитом "Значение" - любого типа. А в предопределенных элементах этого справочника уже создаете нужный элемент и ссылаетесь на него. Получается что-то вроде Справочник.ПредопределенныеНастройки.ОсновнойПокупатель, а значение у него уже устанавливаете (инициализируете) какое нужно.
11. ojleg 12 13.09.18 08:47 Сейчас в теме
(10) В коде выглядит красивее, но добавление предопределенного элемента - это нединамическое обновление вроде, да?
Мы выбирали сознательно РС. Доступ на редактирование и просмотр есть только у полных прав, на чтение у всех. Так что пользователи удалить/изменить не смогут.
12. serq82 8 13.09.18 15:04 Сейчас в теме
вообщем доработал. а как проверить xml? или пока приглашение не кинешь не получится?
13. ojleg 12 17.09.18 14:55 Сейчас в теме
(12)
вообщем доработал. а как проверить xml? или пока приглашение не кинешь не получится?

К сожалению, не знаю. Настраивал уже после принятия приглашения.
14. serq82 8 19.09.18 12:57 Сейчас в теме
добрый день.не пойму такую ситуацию.есть головная организация. есть подразделения НГДУ. если я делаю реализацию товаров и услуг от НГДУ.то мне надо отправлять приглашение на каждое НГДУ? или делать от головной, но тогда акты сверки как в бухгалтерии вести?
15. ojleg 12 19.09.18 14:29 Сейчас в теме
(14)
добрый день.не пойму такую ситуацию.есть головная организация. есть подразделения НГДУ. если я делаю реализацию товаров и услуг от НГДУ.то мне надо отправлять приглашение на каждое НГДУ? или делать от головной, но тогда акты сверки как в бухгалтерии вести?

Если документы будет выставлять каждое НГДУ, то, скорей всего, нужно от каждого будет приглашаться.
Вы можете уточнить эти моменты или у своего партнера по ИТС, или в техподдержке Такскома.
16. serq82 8 19.09.18 16:01 Сейчас в теме
(15)как я понял нет.даже если ты в 1с контрагента ставишь НГДУ, то формировать хмл надо головную организацию с указанием кода подразделения
17. ojleg 12 20.09.18 07:23 Сейчас в теме
(16) НГДУ - это ваши подразделения или Татнефти?
Мы выставляем документы только на контрагента Татнефть, но в грузополучателе указываем подразделения. Соглашение у нас только одно с Татнефтью.
18. serq82 8 20.09.18 11:48 Сейчас в теме
(17)да НГДУ это подразделение. у нас услуги.поэтому грузополучателя не укажешь
20. twiny 15 20.09.18 15:31 Сейчас в теме
(18) приглашение высылается на контрагента с конкретным ИНН и КПП. У разных подразделений, как правило разные КПП. Если у ТН есть свои подразделения, которые "прячутся" под одним КПП, то они как раз маршрутизацию добавили через дополнительные поля, про которые, как раз данная статья.
У себя в базе вы можете внести хоть сколько контрагентов с одинаковым инн+кпп, но обмен вы сможете вести только по одному из них.
19. twiny 15 20.09.18 15:27 Сейчас в теме
Дополнение
В статье не указано, как добавить поля для акта об оказанных услугах.
Можно использовать ту же процедуру ДобавитьДопПоляВТОРГ12Татнефть, но вызов ее нужно добавить добавить примерно так:

ДобавитьДопПоляВТОРГ12Татнефть(СтрокаДопДанных, СсылкаНаОбъект);
Если СформироватьПередачаРаботИсполнительCML(ДеревоДанных) И ПризнакЭД Тогда
21. twiny 15 25.09.18 16:10 Сейчас в теме
Может кому интересно, оформили подобный функционал расширением. Теперь доступно в БП3 стандартных конфигурациях. Подробности в личке
22. user1067408 11.10.18 22:46 Сейчас в теме
(21) Можно в личку данные по расширению для БП? А то второй день голову ломаю как это реализовать. Заранее спасибо.
23. serq82 8 19.10.18 10:16 Сейчас в теме
(21)а для клиент эдо подойдет?
24. chel-new 22.10.18 19:38 Сейчас в теме
(21) присоединяюсь к (22) , можно пример расширения в личку? а то снимать с поддержки бухню из-за Татнефти не хочется. Буду очень признательна.
25. user975499 23.10.18 12:07 Сейчас в теме
(21) присоединяюсь к (22 и 24) , можно пример расширения в личку? Заранее благодарю
26. twiny 15 23.10.18 12:08 Сейчас в теме
(25)
Может кому интересно, оформили подобный функционал расширением. Теперь доступно в БП3 стандартных конфигурациях. Подробности в личке
28. mpvfaq 26.10.18 12:19 Сейчас в теме
(26) Присоединяюсь к (22, 24 и 25), можно и мне пример в личку? Премного благодарен.
30. interservis-sc 07.12.18 09:19 Сейчас в теме
(26) меня интересует внешняя обработка для БУХ 3.0 как вам написать, почему то в личку не пишет!
31. twiny 15 08.12.18 00:08 Сейчас в теме
29. Stein1C 14.11.18 15:46 Сейчас в теме
(21) Присоединяюсь, можно и мне пример расширения? Заранее благодарю!
34. user1179625 18.03.19 13:50 Сейчас в теме
(21) Добрый день! А можно и нам в личку расширение? Также пытаемся наладить ЭДО с Татнефтью - не могут пустить документ по своему маршруту, т.к. произвольные документы не имеют номера договора, т.е. в файле xml значение договора контрагента указывается ПоУмолчанию"
44. jbi2010 11.02.20 16:16 Сейчас в теме
Если возможно, можно и мне пример расширения? Спасибо!
27. mpvfaq 26.10.18 12:16 Сейчас в теме
Присоединяюсь к (22, 24 и 25), можно и мне пример в личку? Премного благодарен.
32. user1110785 14.12.18 21:41 Сейчас в теме
Нашей организации нужно настроить доп поля. Своего программиста нет. Кто поможет?
33. user1068614 16.01.19 14:19 Сейчас в теме
(32)
Функционал по созданию доп полей реализован в БЭД 1.5.1.
Ожидайте обновление вашего прикладного решения
35. MGreg 32 31.03.19 09:45 Сейчас в теме
Тут некоторые дилетанты пытаются продать три функции на языке 1с для БП 3.0 по ЭДО с Татнефть за 15 000 руб.. Позор. Кому надо пришлю бесплатно, но только бухгалтерам.
36. Азамат 10.04.19 17:34 Сейчас в теме
(35) Доброго дня.
Полностью согласен.
Прошу прислать мне -начинающему этот весёлый квест.
37. MGreg 32 11.04.19 13:15 Сейчас в теме
(36)Увы нет, я написал, только бухгалтеру, по звонку.
38. cherva 97 27.05.19 17:14 Сейчас в теме
Мы имеем УПП 120 релиз , но платформа 8.2.19.106 и пока в силу технологических причин мы не можем перейти на 8.2.19.130. Поэтому у нас нет выхода из УПП в Интернет. В качестве временной меры было решено выгружать из УПП XML а затем подписывать и отсылать в Татнефть уже в Такскоме. Однако найти модуль где можно просто выгрузить документы и как то с ним работать мы не смогли. Не могли бы вы нам помочь? Может быть у вас есть обработка для выгрузки в XML документов для Татнефти?
39. YUGPK 28.05.19 08:23 Сейчас в теме
(38) Сами файлы именно как файл формируются в процедуре СформироватьПрисоединенныеФайлы общего модуля ЭлектронныеДокументыСлужебный. А заполнение в СформироватьХМЛФайлыДокументов этого же модуля
40. isstas 29.05.19 12:55 Сейчас в теме
У меня есть вопрос по последнему абзацу статьи:
"В УПП, начиная с версии 1.3.117.1 внесены изменения в модуль ЭлектронныеДокументыВнутренний
Теперь для заполнения доп полей в Счет-фактуре нужно внести изменения в процедуры
СформироватьИнформациюПродавца_5_01 и СформироватьИнформациюПродавца_2019"
У нас версия 1.3.120.1 я нашел эти процедуры, но мне непонятно где и как в них вставить доп. поля по номеру договора, дате договора, коду подразделения. Прошу привести пример, так как не получится просто перенести код из выгрузки в ЭД Торг12.
Спасибо!
41. YUGPK 29.05.19 15:15 Сейчас в теме
(40) @isstas, до версии 1.117 нужно было вставлять код

//Перед формированием файла добавляем свои доп поля	
mokЭДОТатнефть.ДобавитьДопПоляВСЧФТатнефть(ДеревоДанных, ТекстоваяИнформация, СсылкаНаОбъект);

//Вот эту строчку нужно найти в процедуре и перед ней поставить заполнение доп полей \\
РезультатФормирования = СформироватьИнформациюПродавцаXML(ДеревоДанных);


После эту процедуру разбили на две в обновлении. Нужно в каждой из них найти ту же строчку
РезультатФормирования = СформироватьИнформациюПродавцаXML(ДеревоДанных);

и перед ней так же вставить код формирования доп полей
42. isstas 31.05.19 11:43 Сейчас в теме
Спасибо. Я нашел строчку РезультатФормирования =
У меня есть вопросы:
я вставляю перед этой строчкой операторы:
ВставитьЗначениеВДерево(ДеревоДанных,"ДопДанные.Подписанные.Номер_договора", Номер_Договора);
ВставитьЗначениеВДерево(ДеревоДанных,"ДопДанные.Подписанные.Дата_договора",Дата_Договора);
ВставитьЗначениеВДерево(ДеревоДанных,"ДопДанные.Подписанные.Подразделение_получатель", Подразделение_получатель);
ВставитьЗначениеВДерево(ДеревоДанных,"ДопДанные.Подписанные.ИдентификаторДокументаОснования", 	ИдентификаторДокументаОснования)

перед этим определяю переменные Номер_Договора и т.д.
через СсылкаНаОбъект.
вопрос: СсылкаНаОбъект - это ссылка на счет-фактуру или на реализацию?
и еще, правильно ли я определяю параметр "ДопДанные.подписанные.Номер_договора", ведь это параметры реализации, а не счет-фактуры, может быть нужно в начале процедуры добавлять другие
параметры типа
СтруктураЭД.Вставить("...")?
43. nico2 20 01.07.19 14:11 Сейчас в теме
Выложил решение для Бухгалтерии 3.0 https://infostart.ru/public/1085934/
45. пользователь 02.04.20 16:57
Сообщение было скрыто модератором.
...
Оставьте свое сообщение