Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть ІІІ: Регистры сведений

Публикация № 837106

Разработка - Обмен данными 1С - Перенос данных из 1C8 в 1C8

обмен OData регистр сведений Open Data Protocol универсальный обмен

Часть III публикаций об универсальном обмен через REST интерфейс OData - обмен регистрами сведений

 

ПРЕДЫДУЩАЯ ЧАСТЬ. ЧАСТЬ ІІ. ДОКУМЕНТЫ

 

Если Вы уже знакомы с сериями об обмене справочниками и обмене документами, то уже догадываетесь/знаете, как мы "будем строить" наш обмен.

Перечислим процедуры и функции, которыми мы воспользуемся из предыдущих частей:

Функция ПолучитьКаналСвязиССерверомСбораДаних() // не изменится в этой статье, см. Часть І. Справочники
Функция НормализироватьКОбмену(ЭтотРеквизит) // не изменится в этой статье, , см. Часть І. Справочники
Функция СоединенияССерверомСбораДанныхУстановлено() Экспорт // не изменится в этой статье, , см. Часть І. Справочники
Процедура ОтправитьНаСерверСбораДанных(СсылкаИсточник, DELETE = Ложь, ТипОбъекта = 0, // не изменится в этой статье, см. Часть ІІ. Документы
БезКопии = Ложь, ОписаниеРеквизитовОтправки = Неопределено) Экспорт

 

Итак, для начала, в модуль набора записей регистра сведений в процедуру ПриЗаписи мы вставим следующее:

Если ОбменССерверомСбораДанных.СоединенияССерверомСбораДанныхУстановлено() Тогда // если база "подключена" к серверу
   Если ЭтотОбъект.Количество() Тогда // и если есть что передавать (ЭтотОбъект - это набор записей регистра)
      ОбменССерверомСбораДанных.ОтправитьНаСерверСбораДанных(ЭтотОбъект,, 3); // 3 - значит это регистр сведений
   КонецЕсли;	
КонецЕсли;

 

Далле через процедуру ОтправитьНаСерверСбораДанных мы попадем соответственно в такую функцию "доставки" записей регистра на сервер сбора данных (главную в этой статье):

 
 Функция РегистрСведенийДоставленоУспешно(НаборЗаписей, DELETE, Тень = Ложь)

 

Функция РегистрСведенийДоставленоУспешно(НаборЗаписей, DELETE, Тень = Ложь)
	
	Связь = ПолучитьКаналСвязиССерверомСбораДаних(); // служебное - см. Часть І. Справочники
	
	ИмяРегистра = НаборЗаписей.Метаданные().Имя;
	Если Тень Тогда
		ИмяРегистра = СтрЗаменить(ИмяРегистра,"_с_","");
	КонецЕсли;
			
	АдресРесурса = "/" + Связь.Порт + "/odata/standard.odata/InformationRegister_" + ИмяРегистра;
	
	Соединение = Новый HTTPСоединение(Связь.Сервер);		
	
	ЗаголовокHTTP = Новый Соответствие(); 
	
	ТекстШапкиЗапроса = "<?xml version=""1.0"" encoding=""UTF-8""?>	
	|<entry xmlns=""http://www.w3.org/2005/Atom""	
	|       xmlns:d=""http://schemas.microsoft.com/ado/2007/08/dataservices""	
	|        xmlns:m=""http://schemas.microsoft.com/ado/2007/08/dataservices/metadata""	
	|        xmlns:georss=""http://www.georss.org/georss"" 
	|        xmlns:gml=""http://www.opengis.net/gml""> 
	|<category term=""StandardODATA.InformationRegister_" + ИмяРегистра + """ scheme=""http://schemas.microsoft.com/ado/2007/08/dataservices/scheme""/> 	
	|<title type=""text""/> 	
	|<content type=""application/xml""> 	
	|<m:properties xmlns:d=""http://schemas.microsoft.com/ado/2007/08/dataservices"" xmlns:m=""http://schemas.microsoft.com/ado/2007/08/dataservices/metadata"">"; 
	
    // каждая запись будет доставляться отдельно
	Для Каждого кЗапись Из НаборЗаписей Цикл
		
		Если Константы.СерверСбораДанныхОфлайн.Получить() И (НЕ Тень) Тогда
			//СоздатьТеневуюКопиюРегистраСведенийДляОтложеннойОправки(НаборЗаписей, кЗапись); // отложенная отправка
			Продолжить;
		КонецЕсли;
		
		// чтобы успешно доставить запись сначала очистим данные по ключевым полям
		хАдресРесурса = АдресРесурса;	
		
		хСписокСтандартов = СоздатьОписанияОбязательнихРеквизитовРегистраСведений(НаборЗаписей, кЗапись);  // новое служебное - смотри далее
		хСписокИзмерений = СоздатьОписанияЗаписиРегистра(НаборЗаписей, кЗапись, "Измерения"); // новое служебное - смотри далее
		
		Если хСписокСтандартов.Количество() ИЛИ хСписокИзмерений.Количество() Тогда
			хАдресРесурса = хАдресРесурса + "(";
			
			Итератор = 1;
			Для Каждого хОписаниеРеквизита ИЗ хСписокСтандартов Цикл
				хАдресРесурса = хАдресРесурса + хОписаниеРеквизита.Ключ + "='" + хОписаниеРеквизита.Значение + "'" + ?(Итератор = хСписокСтандартов.Количество() + хСписокИзмерений.Количество(),"",",");
				Итератор = Итератор + 1;
			КонецЦикла;		
			
			Для Каждого хОписаниеИземерения ИЗ хСписокИзмерений Цикл
				хАдресРесурса = хАдресРесурса + хОписаниеИземерения.Ключ + "='" + хОписаниеИземерения.Значение + "'" + ?(Итератор = хСписокСтандартов.Количество() + хСписокИзмерений.Количество(),"",",");
				Итератор = Итератор + 1;
			КонецЦикла;		
			
			хАдресРесурса = хАдресРесурса + ")";
			
		КонецЕсли;
		
		Попытка
			хСоединение = Новый HTTPСоединение(Связь.Сервер);			
			хЗапрос = Новый HTTPЗапрос(хАдресРесурса);
			хОтвет = хСоединение.ВызватьHTTPМетод("DELETE", хЗапрос);
		Исключение
		КонецПопытки;
        
        // следовательно, "предыдущая" запись удалена, если она была
        // создаем новую
		
		ТекстЗапроса = ТекстШапкиЗапроса;
		
		// соответствие стандартных реквизитов
		Для Каждого ОписаниеРеквизита ИЗ хСписокСтандартов Цикл  // были описаны выше
			ТекстЗапроса = ТекстЗапроса + "
			|         <d:" + ОписаниеРеквизита.Ключ + ">" + СокрЛП(ОписаниеРеквизита.Значение) + "</d:" + ОписаниеРеквизита.Ключ + ">";	
		КонецЦикла;	
		
		// соответствие Измерений
		Для Каждого ОписаниеИзмерения ИЗ хСписокИзмерений Цикл // были описаны выше
			ТекстЗапроса = ТекстЗапроса + "
			|         <d:" + ОписаниеИзмерения.Ключ + ">" + СокрЛП(ОписаниеИзмерения.Значение) + "</d:" + ОписаниеИзмерения.Ключ + ">";	
		КонецЦикла;	
		
		// соответствие Ресурсов
		ОписаниеРесурсов = СоздатьОписанияЗаписиРегистра(НаборЗаписей, кЗапись, "Ресурсы");
		Для Каждого ОписаниеРесурса ИЗ ОписаниеРесурсов Цикл
			ТекстЗапроса = ТекстЗапроса + "
			|         <d:" + ОписаниеРесурса.Ключ + ">" + СокрЛП(ОписаниеРесурса.Значение) + "</d:" + ОписаниеРесурса.Ключ + ">";	
		КонецЦикла;
		
		// соответствие Реквизитов
		ОписаниеРеквизитов = СоздатьОписанияЗаписиРегистра(НаборЗаписей, кЗапись, "Реквизиты");
		Для Каждого ОписаниеРеквизита ИЗ ОписаниеРеквизитов Цикл
			ТекстЗапроса = ТекстЗапроса + "
			|         <d:" + ОписаниеРеквизита.Ключ + ">" + СокрЛП(ОписаниеРеквизита.Значение) + "</d:" + ОписаниеРеквизита.Ключ + ">";	
		КонецЦикла;	
		
		ТекстЗапроса = ТекстЗапроса + "	
		|      </m:properties>	
		|   </content>	
		|</entry>";
		
		Попытка
			Запрос = Новый HTTPЗапрос(АдресРесурса, ЗаголовокHTTP); 
	
			Запрос.УстановитьТелоИзСтроки(ТекстЗапроса);
			
			Ответ = Соединение.ВызватьHTTPМетод("POST", Запрос);
		Исключение
		КонецПопытки;
		
		Если Ответ.КодСостояния <> 200 Тогда
			Если НЕ Тень Тогда 
				//СоздатьТеневуюКопиюРегистраСведенийДляОтложеннойОправки(НаборЗаписей, кЗапись);  // отложенная отправка
			КонецЕсли;	
		Иначе
			Если Тень Тогда // если это отложена доставка
				НаборЗаписей.Очистить();
				НаборЗаписей.Записать(Истина);
			КонецЕсли;	
		КонецЕсли;	
	КонецЦикла;
   	
КонецФункции

 

 

Список необходимых функций обозначенных комментарием "новое служебное":

 
 Функция СоздатьОписанияОбязательнихРеквизитовРегистраСведений(НаборЗаписей, этаЗапись)
 
 Функция СоздатьОписанияЗаписиРегистра(НаборЗаписей, ЭтаЗапись, КоллекцияМетаданныхКОписанию)

Вот и все - единственный нюанс передачи регистров, перед тем как передать запись надо подготовить под нее место - удалить уже существующую на сервере (если она есть).

 

<<< В части IV (последней)  опишем конвертацию "на ходу" по протоколу OData >>>

 

Спасибо, что дочитали до конца! :)

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. izidakg 160 15.01.19 14:06 Сейчас в теме
3. V.Stavinsky 230 29.01.19 18:16 Сейчас в теме
(2) к сожалению (или к счастью) конвертирование на ходу на нашем проекте не понадобилось, поэтому пока конкретной идеи как ее реализовать нет. но фундаментом было получать правила конвертации из хранилищ (регистров), и соответственно транслировать одни объекты в другие
5. kirillkr 28 08.09.20 10:05 Сейчас в теме
(3) можете выложить пример запроса для записи в любой из регистров: Сведений подчиненный регистратору, Накоплений или Бухгалтерский?
4. e-9 21 09.04.19 13:52 Сейчас в теме
Плюсанул все три статьи - и позаимствовал куски кода, спасибо!
...Расширил у себя границы применения - ограничение "между идентичными конфигурациями" снимается достаточно простой доработкой: передаем (например, в структуре) все необходимые для формирования тела и заголовка запроса данные (такие как GUID, наименование объекта конфигурации базы-корреспондента, наименования и значения реквизитов для заполнения).
JulianK; V.Stavinsky; acanta; +3 Ответить
Оставьте свое сообщение

См. также

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20221    m-rv    17    

Конвертация данных 2. Использование подключаемых обработок в правилах обмена. Конвертация дерева значений

Обмен данными 1С Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Разработка правил обмена с использованием подключаемых обработок. В качестве примера рассмотрена реальная задача конвертации дерева значений.

15.06.2020    3230    Drivingblind    8    

Конвертация данных 2.1. Методика переноса остатков

Перенос данных из 1C8 в 1C8 v8 1cv8.cf УУ Бесплатно (free)

В данной статье я приведу пример использования базовой методики конвертации данных для переноса остатков из одной информационной базы в другую.

12.06.2020    4957    aximo    17    

Механизм XDTO

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

Попытка понять механизм XDTO и его неочевидные аспекты. Научиться выполнять обмены между различными конфигурациями без оглядки на реализацию в типовых.

12.05.2020    5230    totchaz    4    

Повышаем эффективность разработки правил обмена Промо

Практика программирования Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    28331    olegtymko    47    

Механизмы проведения документов при обмене по универсальному формату

Перенос данных из 1C8 в 1C8 БСП (Библиотека стандартных подсистем) v8 Бесплатно (free)

Как проводятся документы при обмене по универсальному формату. Пример доработки типовых правил обмена с переносом состояния документа: проведен/не поведен/пометка удаления.

04.03.2020    4758    partizand    6    

Односторонний обмен ЗУП и БП

Перенос данных из 1C8 в 1C8 v8 БП3.0 ЗУП3.x Россия Бесплатно (free)

Односторонний обмен из ЗУП в БУХ

29.02.2020    5089    VAAngelov    14    

Автоматический обмен при появлении файла, по регламентному заданию создаёт файл выгрузки, даже если файл загрузки не появлялся

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Бесплатно (free)

Заметил, что "Автоматический обмен при появлении файла" каждый раз создаёт файл выгрузки данных, даже если файл для загрузки данных не появлялся. Данный код проверит, что файл появился, только после чего создаст файл выгрузки данных.

20.02.2020    2817    wau8824ru    4    

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть І: Справочники Промо

Перенос данных из 1C8 в 1C8 v8 Бесплатно (free)

Сейчас все чаще интеграции различных конфигураций проектируются через HTTP-сервисы - они и работают быстрее, и "войти" в режим отладки гораздо проще, тем самым обойдя "черный ящик" универсального обмена через xml, например. Более года назад я начал работать в компании, в которой разработчики работали с конфигурациями 1С в режиме совместимости еще 8.2.16 (менять режим совместимости в типичных базах мы не хотели) - а как Вы наверное знаете, если интересовались HTTP-сервисами в 1С, их использование в режиме совместимости 8.3.4 и ниже недопустимо - и здесь я уже не надеялся на разработку и использование HTTP-сервисов. Но позже меня заинтересовал такой "сервис" как REST интерфейс OData, так как его можно использовать не меняя режим совместимости конфигурации - именно он и стал для меня идеальным вариантом решения "нетривиальных" задач.

11.05.2018    23139    V.Stavinsky    11    

Бесшовная интеграция через обмен по правилам - миссия выполнима

Практика программирования Интеграция Перенос данных из 1C8 в 1C8 v8 ДО ERP2 Бесплатно (free)

При организации работы с договорами в ERP 2, с помощью бесшовной интеграции с Документооборотом, «типовой» методикой является создание договоров в ЕРП. После создания договора в ЕРП, пользователь «отправляет» договор в ДО по бесшовной интеграции. На практике, весьма часто пользователи хотят видеть обратную схему: вводить договоры в ДО и при этом получать их в ЕРП без «лишних телодвижений». Или даже вводить их независимо в обеих системах – так, чтобы потом «стыковать» по каким-то определенным правилам.

24.01.2020    5003    e-9    2    

Конвертация ставок НДС: из Перечисления в Справочник (правила обмена в конвертации 2.0)

Перенос данных из 1C8 в 1C8 v8 КД Россия НДС Бесплатно (free)

При написании правил обмена между "более старой" и "более новой" конфигурациями можно столкнуться с тем, что в одной конфигурации ставки НДС - это перечисление, а в другой - справочник (или наоборот, но мой пример именно из перечисления в справочник). Ситуация несложная, но нестандартная, поэтому выкладываю работающий пример, может, кому пригодится.

09.11.2019    6572    vikulinamari    1    

Настройка синхронизации между конфигурациями Бухгалтерия для Беларуси 2.1 и Управление торговлей для Беларуси 3.4

Перенос данных из 1C8 в 1C8 v8 БП3.0 УТ11 Беларусь Бесплатно (free)

Пошаговое описание настройки типового обмена между конфигурациями Бухгалтерия для Беларуси 2.1 и Управление торговлей для Беларуси 3.4

21.10.2019    7790    Olesia_Matusevich    1    

Взаимодействие между базами 1С через COM Промо

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

Рассмотрено много особенностей взаимодействия между базами 1С по COM технологии

10.08.2015    151194    tormozit    65    

Объединение организаций в ЗУП при реорганизации с переносом данных из ЗУП 2.5 в ЗУП 3.1

Зарплата Управление персоналом (HRM) Перенос данных из 1C8 в 1C8 v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Бесплатно (free)

В этой статье описан опыт объединения 2-х организаций при реорганизации в ЗУП 3.1 с переносом данных одной организации из ЗУП 2.5 (релизы баз более или менее свежие, но не самые последние на момент перехода, примерно двух- и трехмесячной давности). За основу было взято решение из этой статьи https://infostart.ru/public/833658/, в которой описан алгоритм решения задачи, за что автору статьи огромная благодарность! Здесь же даны некоторые комментарии и пояснения к алгоритму переноса и объединения, описаны выявленные мною ошибки. Также приведена небольшая инструкция по использованию обработки ирПодборИОбработкаОбъектовБД — она будет полезна для пользователей — «не программистов», впервые работающих в не управляемых формах.

09.10.2019    7864    Neti    2    

EnterpriseData: простой способ защиты данных в базе получателя при одностороннем обмене

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

Очень часто бухгалтеры ругаются, когда уже отраженные документы в бухгалтерском учета меняются сотрудниками.

04.10.2019    7105    handscenter    12    

Дозагрузка измененных данных при помощи КД2

Практика программирования Перенос данных из 1C8 в 1C8 v8 Россия Бесплатно (free)

Иногда во время каких-то регламентных действий по обслуживанию базы(например, при обновлении измененной базы на много релизов) требуется обеспечить бесперебойность работы пользователей. Если конфигурации баз до и после идентичны, то тут сам Бог велел воспользоваться обработкой "ВыгрузкаЗагрузкаДанныхXML", либо такой же но с отбором(на Инфостарте есть такая). Но что если конфигурации баз различаются/значительно различаются? Ниже опишу, как вышел из положения я.

12.09.2019    4895    al_zzz    2    

Использование инструментов разработчика для отладки обменов КД 2.0 Промо

Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Пара трюков, благодаря которым жить становится намного проще...

05.05.2017    27539    unichkin    3    

Конвертация Данных. Нюансы использования конструкции "НеЗамещатьОбъект = Истина" в обработчике события "ПриЗагрузке"

Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

У конвертации данных есть «особенности», которые «пьют кровь» программистов. Эта статья про очередную обнаруженную «особенность».

10.09.2019    9936    ivanek    21    

Обмен данными через Web Сервисы

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Бесплатно (free)

Ознакомительная статья о том, как загружать\выгружать данные с одной базы в другую, используя Web Сервисы.

02.09.2019    23111    user5300    42    

Выгрузка и загрузка документов с движениями

Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Возникла задача перенести документы с движениями, но подменив организацию. Наткнулся на проблему с выгрузкой движений, опишу свой опыт.

02.09.2019    7263    human_new    9    

Приемы обработки больших данных в 1С Промо

Универсальные обработки Математика и алгоритмы Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

Рассказ об эффективных приемах организации обработок больших объемов данных на платформе 1С

07.08.2015    67057    tormozit    27    

EnterpriseData – часть 3. Загрузка данных, идентификация объектов

Практика программирования Математика и алгоритмы Перенос данных из 1C8 в 1C8 Разработка v8 v8::УФ 1cv8.cf Бесплатно (free)

Основные этапы загрузки данных через EnterpriseData. Идентификация объектов загружаемых полностью и по ссылке. Приведены схемы процессов загрузки данных. Описание основных операций и обработчиков. Перечень процедур БСП, используемых при загрузке данных, структура «КомпонентыОбмена».

22.08.2019    14887    ids79    8    

Перенос дополнительных реквизитов в Конвертации данных 2.0

Перенос данных из 1C8 в 1C8 v8 КД Россия УУ Бесплатно (free)

Пример написания правил обмена (КД 2.0) для переноса дополнительных реквизитов справочника "Номенклатура", в том числе перенос ПВХ с разными типами значений.

13.08.2019    11494    vikulinamari    7    

Синхронизация данных между 1С: ЗУП 3.1 и Бухгалтерией 3.0 через файл

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Бесплатно (free)

Публикация описывает последовательность синхронизации данных между 1С: ЗУП 3.1 и Бухгалтерией 3.0 через файл.

23.04.2019    13777    saveliev    6    

Настройка типового обмена данными между: 1С: Предприятие Бухгалтерия ред. 3.0 (БП 3.0) и 1С: Управление торговлей ред. 10.3 (УТ 10.3). Промо

Перенос данных из 1C8 в 1C8 v8 УТ10 Россия Бесплатно (free)

В этой статье я опишу, как настраивается типовой обмен данными между БП 3.0 и УТ 10.3.

29.01.2014    267390    arr    53    

Полезные приемы при работе с Конвертацией данных 2.1. Логирование, интерактивное управление, дозаполнение и постпроведение документов

Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Некоторые полезные приемы для КД 2.1, которые могут пригодиться как при доработке типовых правил, так и самописных.

22.04.2019    9837    maks_20    9    

Работа с ComОбъектом 1С 8.2; 8.3

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Бесплатно (free)

Определение типов и значений через COM соединение между конфигурациями.

15.04.2019    21472    vik070777    12    

Обмен данными между УПП 1.3.64.х и БП 3.0 по расписанию через Универсальный обмен данными + План обмена

Обмен через XML Перенос данных из 1C8 в 1C8 v8 УПП1 Россия Бесплатно (free)

Описание доработки конфигурации УПП 1.3.64.х для выполнения обмена данными по расписанию в БП 3.0. через обработку Универсальный Обмен Данными XML и План Обмена.

09.04.2019    7282    mrcamomile    15    

Отладка правил обмена 7.7, 8 Промо

Перенос данных из 1С7.7 в 1C8.X Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Отладка правил обмена всегда была для меня больной темой, пока наконец-то не разобрался. В интернете мало тем, посвященных этому, поэтому решил написать небольшую инструкцию по этому поводу. Очень надеюсь, что она будет кому-то полезна. С радостью выслушаю недочеты.

29.10.2013    51487    pyrkin_vanya    70    

RabbitMQ + Конвертация Данных 3.0

Внешние источники данных Обмен через XML Интеграция Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Предлагаем ознакомиться с хронологией проекта, проследить ход мыслей от снятия потребностей до реализации, и решить, удалось ли проектной команде найти оптимальное архитектурное решение под конкретный кейс заказчика путем совмещения двух известных, но до сих пор не пересекавшихся технологий, и получилось ли сложить плюсы и устранить минусы каждой из них.

21.03.2019    26279    barelpro    82    

Конвертация данных 2.1: поиск по условию

Перенос данных из 1C8 в 1C8 v8 КД ERP2 Бесплатно (free)

Задача. При обмене документами "Реализация товаров и услуг", поиск контрагента осуществлять по полям "ИНН", "КПП". Если вид договора с комиссионером, то поиск осуществлять по полям "ИНН", "КПП", "Наименование".

15.01.2019    15743    wowik    13    

Заметки КД 2.1: Как передать файл, динамически создаваемый в источнике, в справочник присоединенных файлов приемника

Перенос данных из 1C8 в 1C8 v8 КД Россия Бесплатно (free)

В БП 3.0 есть документ "Книга Продаж Для Передачи В ЭлектронномВиде" из которого выгружается XML файл. Задача: Нужно из БП 3.0 посредством правил обмена, вместе с документом книга продаж сформировать и перенести XML файл в базу приемник. В приемнике файл будет храниться в справочнике "Книга Продаж Присоединенные Файлы".

10.10.2018    9944    Viktor_Ermakov    6    

Обмен по расписанию типовыми средствами. Промо

Распределенная БД (УРИБ, УРБД) Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Бесплатно (free)

Часто перед интеграторами стоит задача организовать автообмен (по расписанию или при наступлении какого-либо события) данными между различными конфигурациями. В этой статье я попробую изложить простую инструкцию, как это можно сделать средствами, заложенными в типовые конфигурации 1С (ЗУП, БП, УПП и т.д.). Для обмена используется подсистема "Обмен данными" из БСП

20.06.2012    102747    kser87    52    

Практические рекомендации по настройке бесшовной интеграции 1С:ERP и 1С:Документооборот КОРП

Перенос данных из 1C8 в 1C8 v8::Бизнес-процессы ERP2 Россия Бесплатно (free)

В настоящей статье мы пошагово рассмотрим, как настроить бесшовную интеграцию 1С:Документооброт КОРП (1С:ДО) с 1С:ERP.

28.09.2018    20140    Aprsoft    12    

Планы обмена 1С

Перенос данных из 1C8 в 1C8 Интеграция v8 Бесплатно (free)

В статье - мастер-классе Дмитрий Жичкин рассказывает, для чего нужны планы обмена 1С и какие задачи они решают. Он подробно описывает физическую структуру планов обмена и механизмов регистрации изменений, рассматривает основные проблемы, возникающие при выгрузке изменений и предлагает методы их решения.

10.09.2018    58886    zhichkin    31    

Конвертация 2.0. Обмен данными между справочниками по сопоставлению артикулов с помощью регистра сведений (пример).

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Бесплатно (free)

Пример обмена данными между справочниками по сопоставлению артикулов с помощью регистра сведений

27.08.2018    9504    Lyubogradov.P    1    

Заготовка для загрузки файлов по ftp Промо

WEB Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

3 процедуры и 1 макет

03.06.2013    30446    anig99    6    

Альтернатива переноса ТЗ в конвертации данных 2.1

Практика программирования Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Здравствуйте уважаемые. Решил выложить альтернативный способ переноса данных в конвертации данных из источника к приемнику, с последующим сбором их в ТЗ в месте ПослеЗагрузки. Т.е.можно готовый перенесенный объект доработать либо создать что-то еще на базе данных. Метод сам разработан с учетом простого понимания Конвертации без использования всех её многочисленных тонкостей и сложностей. В примере рассматривается перенос Операции. И вот еще что. Я не привожу тут готовое решение, я всего лишь показываю концепцию того, как можно делать в КД. Без использования глобальных переменных.

20.08.2018    6911    dinopopyys    6    

Конвертация 2.0. Перенос независимого справочника в подчиненный (пример).

Перенос данных из 1C8 в 1C8 v8 КД Россия Бесплатно (free)

Пример переноса независимого справочника в подчиненный с помощью Конвертации 2.0.

15.08.2018    10822    Lyubogradov.P    6    

Конвертация 2.0. Перенос элементов и групп справочника, имеющих различный вид иерархии (пример).

Перенос данных из 1C8 в 1C8 v8 КД Россия Бесплатно (free)

Пример переноса справочника, имеющего различный вид иерархии, с помощью Конвертации 2.0.

13.08.2018    9996    Lyubogradov.P    0    

Интеграция «1С:Управление производственным предприятием» с «1С:Документооборот» Промо

Перенос данных из 1C8 в 1C8 Документооборот и делопроизводство Документооборот и делопроизводство v8 КА1 УПП1 ДО Бесплатно (free)

В данной статье пойдет речь о возможности интеграции 1С:Управление производственным предприятием ред. 1.3 с 1С:Документооборот КОРП и о том, что может получить предприятие от этой интеграции.

18.02.2013    62768    Vladimir_Konyrev    38    

hsИнтегратор - технология онлайнового обмена данными между базами на платформе 1С:Предприятие. Использование технологии в виде расширения, без изменения конфигураций баз данных, участвующих в обмене

Перенос данных из 1C8 в 1C8 v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

hsИнтегратор : Простое в использовании решение, работает в качестве клиента и сервиса (в мобильном приложении – только клиента). Не обязательно требует внесения изменений в конфигурации интегрируемых баз данных. Маленький трафик обмена между клиентом и сервером, быстрая реакция на запросы со стороны клиента. Единый сервис для обмена данными различной структуры, механизмы для обеспечения безопасности.

25.06.2018    12209    hobi    8    

Обмен через универсальный формат. Пример нестандартной конвертации данных

Обмен через XML Перенос данных из 1C8 в 1C8 v8 УТ11 Россия Бесплатно (free)

В статье описан небольшой пример обмена данными через EnterpriseData без снятия конфигурации с поддержки. Тестовая площадка: Управление торговлей, редакция 11 (11.4.3.126), версия платформы 8.3.11

18.06.2018    35687    artkor    14    

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть ІІ: Документы

Перенос данных из 1C8 в 1C8 v8 Бесплатно (free)

Продолжение статьи об универсальном обмене между идентичными конфигурации через REST интерфейс OData (https://infostart.ru/public/829356/). В части второй разберем особенности обмена документами.

19.05.2018    11573    V.Stavinsky    5    

Особенности обмена данными с использованием "ручной" регистрации Промо

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

Эта статья рассчитана на программистов, которые используют обмен данными с помощью метода "ВыбратьИзменения" и последующую их запись. Только для планов обменов, имеющих "ручную" регистрацию.

14.01.2013    33350    logarifm    6    

Как написать обмен с 50 поставщиками и не сойти с ума. Техника

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Бесплатно (free)

О том как из обмена с одним идеальным поставщиком сделать обмены с 50 реальными поставщиками.

16.04.2018    10218    m-rv    1    

Конвертация данных. Произвольная иерархия справочника

Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Источник: Бухгалтерский учет ред. 4.5 платформы 7.7. Приемник: Бухгалтерия предприятия 3.0. Задача: При загрузке справочника «Номенклатура» в приемнике, все элементы поместить в папку «Товары» с сохранением имеющейся иерархии в 7.7.

10.04.2018    10689    pyrkin_vanya    3    

Перенос помеченных на удаление объектов. Конвертация 2.1

Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Иногда при переносе данных возникает задача: не переносить помеченные на удаление документы, а те документы, которые были ранее перенесены в базу приемник и теперь в приемнике стали помеченными на удаления - переносить так, чтобы в базу приемник не тянулись связанные с объектом ссылки, но искомый объект помечался на удаление. В данной статье будет рассказано, как это можно сделать достаточно просто, используя конфигурацию "Конвертация 2.1".

02.04.2018    14095    Shmell    2    

СТАБИЛЬНАЯ Загрузка справочника номенклатуры в 1С:Управление торговлей 8 из прайс-листа в Excel (код открыт скачать можно бесплатно) Промо

Перенос данных из 1C8 в 1C8 Загрузка и выгрузка в Excel v8 УТ10 Россия Бесплатно (free)

В таких случаях многие заказывают соответствующие обработки у собственных штатных программистов, фирм-франчайзи или сторонних разработчиков, но это дополнительные расходы и время. Как быть, если по различным причинам такой возможности нет? У каждого пользователя профессиональной версии 1С:Предприятие 8 подобная обработка уже есть! На диске ИТС! Типовая обработка «ЗагрузкаДанныхИзТабличногоДокумента.epf», находиться в разделе «Технологическая поддержка» > «Методическая поддержка 1С:Предприятие 8» > «Универсальные отчеты и обработки» > «Загрузка данных из табличного документа». Обратите внимание, начиная с Февраля 2010 г. на диске ИТС данная обработка для конфигураций на платформе 8.1 находиться в другом разделе: «Технологическая поддержка» > «Методическая поддержка 1С:Предприятие 8» > «Платформа 1С:Предприятие 8.1» > «Универсальные отчеты и обработки» > «Загрузка данных из табличного документа».

07.11.2011    183322    SkyLink2012    132    

Совместная работа БП 3.0 и ЗУП 3.1. Устранение ошибки синхронизации персональных данных физических лиц

Перенос данных из 1C8 в 1C8 Управление персоналом (HRM) Управление персоналом (HRM) v8 БП3.0 ЗУП3.x Бесплатно (free)

При совместной работе указанных конфигураций с использованием встроенного плана обмена «ОбменЗарплата3Бухгалтерия3» персональные данные физических лиц передаются некорректно. Это связано с ошибкой в правилах обмена (замшелой уже, с учётом того, сколько времени эта ошибка «кочует» из версии в версию правил).

31.03.2018    14378    ser73461014    12