INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Ткаченко Денис | Конструктор | ОАО "РЖД"

«Корпоративные IT отделы на Дальнем Востоке обречены. Обречены на изменения»

Трансформируйся или умри, это Неизбежность корпоративного АйТи отдела. Модные слова про цифровизацию и клиентоориентированность спасут ненадолго, на срок провального проекта. Изменениям должна быть подвергнута система управления IT. Потому что IT изменилось и мы изменились. Эта отрасль уже не хобби энтузиастов и калька с учебников по управлению прошлого века не работает. Поднимаем голову от интриг и смотрим что случилось с кадровым рынком, если еще не посмотрели. Ну и где мы будем брать сотрудников в штат? А через пять лет? Из институтов? Готовим сами?, окей. Создали систему подготовки, мотивации и развития своих кадров? Эта система убъёт Ваш IT отдел. Отдали разработку и поддержку на аутсорс. Вы же понимаете, что это временно, их убьют те же проблемы. В общем нужно учиться управлять по другому, управлять не управляя. Нужно ли быть специалистом, чтобы управлять специалистами? Несомненно! это и есть ключевой момент. Заманчиво выглядит растворить систему менеджмента, в операционных процессах не увеличивая затраты? Очень. Формулируем Проблему. Рисуем Решение. Намечаем Шаги. Строим Систему.

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть ІІІ: Регистры сведений

Обмен - Перенос данных из 1C8 в 1C8

10
Часть III публикаций об универсальном обмен через REST интерфейс OData - обмен регистрами сведений

 

ПРЕДЫДУЩАЯ ЧАСТЬ. ЧАСТЬ ІІ. ДОКУМЕНТЫ

 

Если Вы уже знакомы с сериями об обмене справочниками и обмене документами, то уже догадываетесь/знаете, как мы "будем строить" наш обмен.

Перечислим процедуры и функции, которыми мы воспользуемся из предыдущих частей:

Функция ПолучитьКаналСвязиССерверомСбораДаних() // не изменится в этой статье, см. Часть І. Справочники
Функция НормализироватьКОбмену(ЭтотРеквизит) // не изменится в этой статье, , см. Часть І. Справочники
Функция СоединенияССерверомСбораДанныхУстановлено() Экспорт // не изменится в этой статье, , см. Часть І. Справочники
Процедура ОтправитьНаСерверСбораДанных(СсылкаИсточник, DELETE = Ложь, ТипОбъекта = 0, // не изменится в этой статье, см. Часть ІІ. Документы
БезКопии = Ложь, ОписаниеРеквизитовОтправки = Неопределено) Экспорт

 

Итак, для начала, в модуль набора записей регистра сведений в процедуру ПриЗаписи мы вставим следующее:

Если ОбменССерверомСбораДанных.СоединенияССерверомСбораДанныхУстановлено() Тогда // если база "подключена" к серверу
   Если ЭтотОбъект.Количество() Тогда // и если есть что передавать (ЭтотОбъект - это набор записей регистра)
      ОбменССерверомСбораДанных.ОтправитьНаСерверСбораДанных(ЭтотОбъект,, 3); // 3 - значит это регистр сведений
   КонецЕсли;	
КонецЕсли;

 

Далле через процедуру ОтправитьНаСерверСбораДанных мы попадем соответственно в такую функцию "доставки" записей регистра на сервер сбора данных (главную в этой статье):

 
 Функция РегистрСведенийДоставленоУспешно(НаборЗаписей, DELETE, Тень = Ложь)

 

Функция РегистрСведенийДоставленоУспешно(НаборЗаписей, DELETE, Тень = Ложь)
	
	Связь = ПолучитьКаналСвязиССерверомСбораДаних(); // служебное - см. Часть І. Справочники
	
	ИмяРегистра = НаборЗаписей.Метаданные().Имя;
	Если Тень Тогда
		ИмяРегистра = СтрЗаменить(ИмяРегистра,"_с_","");
	КонецЕсли;
			
	АдресРесурса = "/" + Связь.Порт + "/odata/standard.odata/InformationRegister_" + ИмяРегистра;
	
	Соединение = Новый HTTPСоединение(Связь.Сервер);		
	
	ЗаголовокHTTP = Новый Соответствие(); 
	
	ТекстШапкиЗапроса = "<?xml version=""1.0"" encoding=""UTF-8""?>	
	|<entry xmlns=""http://www.w3.org/2005/Atom""	
	|       xmlns:d=""http://schemas.microsoft.com/ado/2007/08/dataservices""	
	|        xmlns:m=""http://schemas.microsoft.com/ado/2007/08/dataservices/metadata""	
	|        xmlns:georss=""http://www.georss.org/georss"" 
	|        xmlns:gml=""http://www.opengis.net/gml""> 
	|<category term=""StandardODATA.InformationRegister_" + ИмяРегистра + """ scheme=""http://schemas.microsoft.com/ado/2007/08/dataservices/scheme""/> 	
	|<title type=""text""/> 	
	|<content type=""application/xml""> 	
	|<m:properties xmlns:d=""http://schemas.microsoft.com/ado/2007/08/dataservices"" xmlns:m=""http://schemas.microsoft.com/ado/2007/08/dataservices/metadata"">"; 
	
    // каждая запись будет доставляться отдельно
	Для Каждого кЗапись Из НаборЗаписей Цикл
		
		Если Константы.СерверСбораДанныхОфлайн.Получить() И (НЕ Тень) Тогда
			//СоздатьТеневуюКопиюРегистраСведенийДляОтложеннойОправки(НаборЗаписей, кЗапись); // отложенная отправка
			Продолжить;
		КонецЕсли;
		
		// чтобы успешно доставить запись сначала очистим данные по ключевым полям
		хАдресРесурса = АдресРесурса;	
		
		хСписокСтандартов = СоздатьОписанияОбязательнихРеквизитовРегистраСведений(НаборЗаписей, кЗапись);  // новое служебное - смотри далее
		хСписокИзмерений = СоздатьОписанияЗаписиРегистра(НаборЗаписей, кЗапись, "Измерения"); // новое служебное - смотри далее
		
		Если хСписокСтандартов.Количество() ИЛИ хСписокИзмерений.Количество() Тогда
			хАдресРесурса = хАдресРесурса + "(";
			
			Итератор = 1;
			Для Каждого хОписаниеРеквизита ИЗ хСписокСтандартов Цикл
				хАдресРесурса = хАдресРесурса + хОписаниеРеквизита.Ключ + "='" + хОписаниеРеквизита.Значение + "'" + ?(Итератор = хСписокСтандартов.Количество() + хСписокИзмерений.Количество(),"",",");
				Итератор = Итератор + 1;
			КонецЦикла;		
			
			Для Каждого хОписаниеИземерения ИЗ хСписокИзмерений Цикл
				хАдресРесурса = хАдресРесурса + хОписаниеИземерения.Ключ + "='" + хОписаниеИземерения.Значение + "'" + ?(Итератор = хСписокСтандартов.Количество() + хСписокИзмерений.Количество(),"",",");
				Итератор = Итератор + 1;
			КонецЦикла;		
			
			хАдресРесурса = хАдресРесурса + ")";
			
		КонецЕсли;
		
		Попытка
			хСоединение = Новый HTTPСоединение(Связь.Сервер);			
			хЗапрос = Новый HTTPЗапрос(хАдресРесурса);
			хОтвет = хСоединение.ВызватьHTTPМетод("DELETE", хЗапрос);
		Исключение
		КонецПопытки;
        
        // следовательно, "предыдущая" запись удалена, если она была
        // создаем новую
		
		ТекстЗапроса = ТекстШапкиЗапроса;
		
		// соответствие стандартных реквизитов
		Для Каждого ОписаниеРеквизита ИЗ хСписокСтандартов Цикл  // были описаны выше
			ТекстЗапроса = ТекстЗапроса + "
			|         <d:" + ОписаниеРеквизита.Ключ + ">" + СокрЛП(ОписаниеРеквизита.Значение) + "</d:" + ОписаниеРеквизита.Ключ + ">";	
		КонецЦикла;	
		
		// соответствие Измерений
		Для Каждого ОписаниеИзмерения ИЗ хСписокИзмерений Цикл // были описаны выше
			ТекстЗапроса = ТекстЗапроса + "
			|         <d:" + ОписаниеИзмерения.Ключ + ">" + СокрЛП(ОписаниеИзмерения.Значение) + "</d:" + ОписаниеИзмерения.Ключ + ">";	
		КонецЦикла;	
		
		// соответствие Ресурсов
		ОписаниеРесурсов = СоздатьОписанияЗаписиРегистра(НаборЗаписей, кЗапись, "Ресурсы");
		Для Каждого ОписаниеРесурса ИЗ ОписаниеРесурсов Цикл
			ТекстЗапроса = ТекстЗапроса + "
			|         <d:" + ОписаниеРесурса.Ключ + ">" + СокрЛП(ОписаниеРесурса.Значение) + "</d:" + ОписаниеРесурса.Ключ + ">";	
		КонецЦикла;
		
		// соответствие Реквизитов
		ОписаниеРеквизитов = СоздатьОписанияЗаписиРегистра(НаборЗаписей, кЗапись, "Реквизиты");
		Для Каждого ОписаниеРеквизита ИЗ ОписаниеРеквизитов Цикл
			ТекстЗапроса = ТекстЗапроса + "
			|         <d:" + ОписаниеРеквизита.Ключ + ">" + СокрЛП(ОписаниеРеквизита.Значение) + "</d:" + ОписаниеРеквизита.Ключ + ">";	
		КонецЦикла;	
		
		ТекстЗапроса = ТекстЗапроса + "	
		|      </m:properties>	
		|   </content>	
		|</entry>";
		
		Попытка
			Запрос = Новый HTTPЗапрос(АдресРесурса, ЗаголовокHTTP); 
	
			Запрос.УстановитьТелоИзСтроки(ТекстЗапроса);
			
			Ответ = Соединение.ВызватьHTTPМетод("POST", Запрос);
		Исключение
		КонецПопытки;
		
		Если Ответ.КодСостояния <> 200 Тогда
			Если НЕ Тень Тогда 
				//СоздатьТеневуюКопиюРегистраСведенийДляОтложеннойОправки(НаборЗаписей, кЗапись);  // отложенная отправка
			КонецЕсли;	
		Иначе
			Если Тень Тогда // если это отложена доставка
				НаборЗаписей.Очистить();
				НаборЗаписей.Записать(Истина);
			КонецЕсли;	
		КонецЕсли;	
	КонецЦикла;
   	
КонецФункции

 

 

Список необходимых функций обозначенных комментарием "новое служебное":

 
 Функция СоздатьОписанияОбязательнихРеквизитовРегистраСведений(НаборЗаписей, этаЗапись)
 
 Функция СоздатьОписанияЗаписиРегистра(НаборЗаписей, ЭтаЗапись, КоллекцияМетаданныхКОписанию)

Вот и все - единственный нюанс передачи регистров, перед тем как передать запись надо подготовить под нее место - удалить уже существующую на сервере (если она есть).

 

<<< В части IV (последней)  опишем конвертацию "на ходу" по протоколу OData >>>

 

Спасибо, что дочитали до конца! :)

10

См. также

Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение