Свойства Номенклатуры в узле свойств ХарактеристикиНоменклатуры универсального отчета

29.04.11

Задачи пользователя - Адаптация типовых решений

Частный случай отчетов с группировкой по характеристике номенклатуры, когда в одну (!) строку отчета нужно вывести в виде дополнительных полей и свойства характеристики, и свойства владельца характеристики (номенклатуры) - в случае, когда номенклатура не указывается как группировка в отчете.

Небольшая вставка в процедуру универсального отчета решает эту проблему. Плюс, естественно, работают отборы и группировки и по свойствам характеристики, и по свойствам номенклатуры. Естественно, свойство номенклатуры при настройке в данном случае нужно выбирать из узла Характеристика номенклатуры.

Скачать исходный код

Наименование Файл Версия Размер
Процедура УстановитьНачальныеНастройкиПоМетаданнымРегистра.txt
.txt 18,89Kb
68
.txt 18,89Kb 68 Скачать

Понадобилась фича для выгрузки в Excel отчета без иерархии по характеристике и номенклатуре со свойствами характеристик и номенклатуры...

Ниже вставка этого кусочка, в файле полная версия этой процедуры

Процедура УстановитьНачальныеНастройкиПоМетаданнымРегистра(ИмяРегистра)

...

            Для каждого Назначение из МассивНазначений Цикл
               
                ДобавитьСвойстваИКатегорииДляПоля("ИсточникДанных." + Измерение.Имя, Измерение.Имя, Измерение.Представление(), Назначение);
               
                // ANB (Добавил свойства владельца характеристики номенклатуры)
               
                Если ТипИзмерения = Тип("СправочникСсылка.ХарактеристикиНоменклатуры") Тогда
                    ДобавитьСвойстваИКатегорииДляПоля("ИсточникДанных." + Измерение.Имя + ".Владелец",
                        Измерение.Имя, "Номенклатура", // Измерение.Представление(),
                        ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Номенклатура, Истина);
                КонецЕсли;
               
            КонецЦикла;

...

Для отчетов, которые строятся не по регистру, а по запросу, в настройках отчета нужно похожий фокус сделать, например в отчете по товарам в резерве на складах

    // В универсальном отчете включен флаг использования свойств и категорий.
    Если УниверсальныйОтчет.ИспользоватьСвойстваИКатегории Тогда
       
        // Добавление свойств и категорий поля запроса в таблицу полей.
        // Необходимо вызывать для каждого поля запроса, предоставляющего возможность использования свойств и категорий.
       
        // УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля(. , , , );
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля( "РегЗаказы.Номенклатура" ,               "Номенклатура",               "Номенклатура",                ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Номенклатура);
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля( "РегЗаказы.ХарактеристикаНоменклатуры" , "ХарактеристикаНоменклатуры", "Характеристика номенклатуры", ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_ХарактеристикиНоменклатуры);
       
        // ANB (Добавил свойства владельца характеристики номенклатуры)
               
        УниверсальныйОтчет.ДобавитьСвойстваИКатегорииДляПоля(
            "РегЗаказы.ХарактеристикаНоменклатуры.Владелец", "ХарактеристикаНоменклатуры", "Номенклатура",
                ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Номенклатура, Истина);
           
        // Добавление свойств и категорий в исходный текст запроса.
        УниверсальныйОтчет.ДобавитьВТекстЗапросаСвойстваИКатегории(ТекстЗапроса);
       
    КонецЕсли;

См. также.

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    5010    11    5    

20

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3385    7    0    

26

Адаптация типовых решений Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4586    dimanich70    15    

20

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    2960    dimanich70    8    

15

Адаптация типовых решений Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2407    20    avmartynov    14    

44

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2670    40    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. OLGAFUTURUOlena 04.05.11 17:53 Сейчас в теме
Вот как раз совсем недавно билась с отчетом,где нужно было выводить значение одного из свойств справочника Номенклатура.
Как раз бы пригодилось наверное. Только отчет уже готов)
Оставьте свое сообщение