Печать чека с построчной суммой НДС

27.09.18

Задачи пользователя - Адаптация типовых решений

Печать чека с построчной суммой НДС (для УТ11/ERP/KA/...)

Последнее время я стал натыкаться на вопросы о выводе какой-либо дополнительной информации в чек.

Эта мини-статья для экономии времени по реализации сей "хотелки" - построчного вывода суммы НДС.

Напомню, что эта доработка носит рекомендательный характер: https://its.1c.ru/db/kkt#content:56:hdoc

Для полноты добавлю и требования к новым образцам чеков: https://its.1c.ru/db/kkt#content:54:hdoc@16d201e1

 

Итак, начнем.

1. Для начала необходимо получить сами данные "СуммаНДС" из табличных частей документ-оснований.

Идём в ДенежныеСредстваСервер.ЗаполнитьПозицииИТаблицуОплатЧека().

После инициализации запроса получения позиций в чеке изменим его текст, добавив нужное нам поле:

...
Запрос = Новый Запрос;
Запрос.МенеджерВременныхТаблиц = МенеджерВременныхТаблиц;
Запрос.Текст = ТекстЗапросаОплаченныеПозицииНоменклатуры();

//++
Запрос.Текст = СтрЗаменить(Запрос.Текст, 
	"ТаблицаДокумента.СтавкаНДС              КАК СтавкаНДС,", 
	"ТаблицаДокумента.СтавкаНДС              КАК СтавкаНДС, ТаблицаДокумента.СуммаНДС,");
Запрос.Текст = СтрЗаменить(Запрос.Текст, 
	"ТаблицаНоменклатуры.СтавкаНДС              КАК СтавкаНДС,", 
	"ТаблицаНоменклатуры.СтавкаНДС              КАК СтавкаНДС, ТаблицаНоменклатуры.СуммаНДС,");
//--
...

2. Далее следуем в МенеджерОборудованияВызовСервера.ПолучитьXMLПакетДляФискализацияЧека().

Здесь формируется XML строка для передачи в ККТ. После элемента "FiscalString" добавим нашу сумму НДС:

...
ЗаписьXML.ЗаписатьНачалоЭлемента("FiscalString");
ЗаписьXML.ЗаписатьАтрибут("Name"             , XMLСтрока(ТекущаяПозиция.Наименование));
ЗаписьXML.ЗаписатьАтрибут("Quantity"         , XMLСтрока(ТекущаяПозиция.Количество));
ЗаписьXML.ЗаписатьАтрибут("PriceWithDiscount", XMLСтрока(ЦенаСоСкидками));
ЗаписьXML.ЗаписатьАтрибут("SumWithDiscount"  , XMLСтрока(ТекущаяПозиция.Сумма));
ЗаписьXML.ЗаписатьАтрибут("DiscountSum"      , XMLСтрока(ТекущаяПозиция.СуммаСкидок));
ЗаписьXML.ЗаписатьАтрибут("Department"       , XMLСтрока(ТекущаяПозиция.НомерСекции));

Если НЕ ПустаяСтрока(ТекущаяПозиция.СтавкаНДС) Тогда 
	Если ТекущаяПозиция.СтавкаНДС = 118 Тогда
		ЗначениеСтавкаНДС = "18/118";
	ИначеЕсли ТекущаяПозиция.СтавкаНДС = 110 Тогда
		ЗначениеСтавкаНДС = "10/110";
	Иначе
		ЗначениеСтавкаНДС = ТекущаяПозиция.СтавкаНДС;
	КонецЕсли;
Иначе
	ЗначениеСтавкаНДС = "none";
КонецЕсли;

ЗаписьXML.ЗаписатьАтрибут("Tax", XMLСтрока(ЗначениеСтавкаНДС));

Если ТекущаяПозиция.Свойство("ПризнакСпособаРасчета") И НЕ ПустаяСтрока(ТекущаяПозиция.ПризнакСпособаРасчета) Тогда
	ПризнакСпособаРасчета = МенеджерОборудованияКлиентСервер.ПолучитьКодПризнакСпособаРасчета(ТекущаяПозиция.ПризнакСпособаРасчета);
	ЗаписьXML.ЗаписатьАтрибут("SignMethodCalculation", XMLСтрока(ПризнакСпособаРасчета));
КонецЕсли;
Если ТекущаяПозиция.Свойство("ПризнакПредметаРасчета") И НЕ ПустаяСтрока(ТекущаяПозиция.ПризнакПредметаРасчета) Тогда
	ПризнакПредметаРасчета = МенеджерОборудованияКлиентСервер.ПолучитьКодПризнакаПредметаРасчета(ТекущаяПозиция.ПризнакПредметаРасчета);
	ЗаписьXML.ЗаписатьАтрибут("SignCalculationObject", XMLСтрока(ПризнакПредметаРасчета));
КонецЕсли;

Если ТекущаяПозиция.Свойство("СуммаНДС") И НЕ ПустаяСтрока(ТекущаяПозиция.СуммаНДС) Тогда
	ЗаписьXML.ЗаписатьАтрибут("TaxSum", XMLСтрока(ТекущаяПозиция.СуммаНДС));
КонецЕсли;

Если ТекущаяПозиция.Свойство("ПризнакАгентаПоПредметуРасчета") И НЕ ПустаяСтрока(ТекущаяПозиция.ПризнакАгентаПоПредметуРасчета) Тогда
	ПризнакАгентаПоПредметуРасчета = МенеджерОборудованияКлиентСервер.ПолучитьКодПризнакаАгента(ТекущаяПозиция.ПризнакАгентаПоПредметуРасчета);
	ЗаписьXML.ЗаписатьАтрибут("SignSubjectCalculationAgent", XMLСтрока(ПризнакАгентаПоПредметуРасчета));
КонецЕсли;

Если ТекущаяПозиция.Свойство("ЕдиницаИзмеренияПредметаРасчета") И ТекущаяПозиция.ЕдиницаИзмеренияПредметаРасчета <> Неопределено Тогда
	ЗаписьXML.ЗаписатьАтрибут("MeasurementUnit"   , XMLСтрока(ТекущаяПозиция.ЕдиницаИзмеренияПредметаРасчета));
КонецЕсли;

ЗаписатьДанныеАгента(ЗаписьXML, ТекущаяПозиция.ДанныеАгента);
ЗаписатьДанныеПоставщика(ЗаписьXML, ТекущаяПозиция.ДанныеПоставщика);
ЗаписатьДанныеКодаТоварнойНоменклатуры(ЗаписьXML, ТекущаяПозиция.ДанныеКодаТоварнойНоменклатуры);

ЗаписьXML.ЗаписатьКонецЭлемента();

//++
Если ТекущаяПозиция.Свойство("СуммаНДС") Тогда  													 
	ЗаписьXML.ЗаписатьНачалоЭлемента("TextString");										 
	ЗаписьXML.ЗаписатьАтрибут("Text", "Сумма НДС: " + XMLСтрока(ТекущаяПозиция.СуммаНДС)); 										 
	ЗаписьXML.ЗаписатьКонецЭлемента(); 													 
КонецЕсли;
//--
...

Отмечу, что добавить вывод прямо в "FiscalString" у меня не получилось,  т.к. ККТ напрочь игнорирует необязательные поля в этой секции. 

Надеюсь, что кому-то пригодится. 

Доработка печати чека построчный вывод суммы НДС

См. также

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    5164    11    5    

20

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3538    8    0    

27

Адаптация типовых решений Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4738    dimanich70    15    

20

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    3669    dimanich70    8    

16

Адаптация типовых решений Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2806    21    avmartynov    14    

53
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. FloNes 14 01.11.18 08:26 Сейчас в теме
Стандартными средствами в настройках кассы (ККТ РР-02ф) вывести НДС в каждой строке не получилось. Воспользовался вашей допиской, все сработало. Спс

//++
Если ТекущаяПозиция.Свойство("СуммаНДС") Тогда
ЗаписьXML.ЗаписатьНачалоЭлемента("TextString");
ЗаписьXML.ЗаписатьАтрибут("Text", "Сумма НДС: " + XMLСтрока(ТекущаяПозиция.СуммаНДС));
ЗаписьXML.ЗаписатьКонецЭлемента();
КонецЕсли;
//--
2. triviumfan 95 01.11.18 09:23 Сейчас в теме
(1) Рад, что кому-то помогла статья)
3. FloNes 14 06.11.18 04:56 Сейчас в теме
Дело может быть не в ККТ, а в обработке обслуживания. На старых версия обработки обслуживания строка не выводиться, на новых все работает...
Прикрепленные файлы:
4. triviumfan 95 06.11.18 09:37 Сейчас в теме
(3) В моем случае дело не в обработке обслуживания. У меня при получении данных нету суммы ндс вовсе, мне пришлось запрос менять.
Оставьте свое сообщение