Вычеты сотрудников НДФЛ с возможностью сортировки

06.04.08

Учетные задачи - Зарплата

Отчет предназначен для анализа закрытия вычетов и контроля сумм вычетов. Отчет позволяет сортировать результаты по кодам вычетов или по сотрудникам.

Скачать исходный код

Наименование Файл Версия Размер
-
.1207495941 12,38Kb
973
.1207495941 12,38Kb 973 Скачать бесплатно

См. также

Обмен данными ЗУП 3.1 - Бухгалтерия 7.7

Зарплата Перенос данных 1C Бухгалтерский учет 7.7 Сложные периодические расчеты 1С:Бухгалтерия 7.7 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

Как известно, Бухгалтерия 7.7 не имеет штатной возможности для обмена с ЗУП 3.1. Данная разработка пригодится тем, кто перешел с ЗиК 2.3 на ЗУП 3.1, но вынужден по каким-то своим причинам оставаться на Бухгалтерии 7.7.

18000 руб.

29.09.2020    13623    2    0    

5

7.7 : Ставки налогов и отчислений. БУХ учет Украина 2014

Зарплата Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Украина Бухгалтерский учет НДФЛ Абонемент ($m)

Просто запустим обработку. Файл "СтавкиНалоговЗарплата2014.ert" - выполнить.

1 стартмани

22.01.2014    28515    2    kompas-dm    1    

1

Справка по форме 182Н для 1С:Бухгалтерии 7.7

Зарплата Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Производство+Услуги+Бухгалтерия 1С:Упрощенное налогообложение 7.7 Россия Бухгалтерский учет ФОМС, ЕФС Платные (руб)

Новая справка для расчета пособий по временной нетрудоспособности в соответствии с приказом Министерства труда и социальной защиты № 182Н от 30.04.2013 года (учитывая изменения вплоть до 2017 года). Справку необходимо выдавать на руки при увольнении сотрудника. Может помочь при расчете среднего заработка при нетрудоспособности сотрудников. Будет незаменимым помощником для бухгалтеров, осуществляющих расчеты по заработной плате, при отсутствии специализированной программы.

2000 руб.

03.08.2013    81344    31    21    

39

Подготовка сведений в ПФР за 2013 год с распределением суммы уплаченных взносов, превышающих начисленные

Регламентированный учет и отчетность Зарплата Расчет 7.7 1С:Зарплата и кадры 7.7 Россия Бухгалтерский учет ФОМС, ЕФС Абонемент ($m)

При подготовке к сдаче отчета в ПФР столкнулся с тем, что программа не учитывает переплату - не распределяет сумму уплаченных взносов, превышающую начисленную, даже если это оплата проходит в январе 2013 за декабрь 2012. В случае, когда есть долг по оплате на начало периода (например, за декабрь 2012 платят в январе 2013) сумма уплаченных взносов может быть больше суммы начисленных. Программа же ставит сумму уплаченных взносов равную сумме начисленных. В этой обработке распределяются суммы уплаченных взносов, превышающих начисленные, а так же внесены исправления, связанные с возможными ошибками при формировании штатной обработки из 335 релиза (в пачки попадали ненужные уволенные, неправильно распределялись уплаты взносов, при выгрузке в файл возникали ошибки).

1 стартмани

20.04.2013    30960    425    mirrr    65    

41

Расчетная ведомость для 1С:Бухгалтерии 7.7

Зарплата Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Для бухгалтера : удобный отчет по начислениям-выплатам-удержаниям И повод задуматься о переходе на ЗУП Для программиста : удобный инструмент сверки данных при переходе с 1С:Бухгалтерии 7.7 на 1С:ЗУП 2.5

4 стартмани

01.03.2013    37395    87    Designer1C    7    

10
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. LL57101 18.10.08 11:46 Сейчас в теме
Хороший отчет, понравилось, пригодилось
6. Michael_K 8 28.11.11 21:58 Сейчас в теме
Спасибо огромное! Небольшая переделка и на крупных предприятиях запросто выводятся сотрудники с тремя и более детьми, что сейчас очень актуально!
Вот, кому надо - пользуйтесь. Написано "на живую нитку", просьба сильно не пинать, было не до красоты. Если у сотрудника куча закрытых вычетов, например ежегодно закрывался и с НГ вводился новый - такие тоже попадут, кому надо доработайте, мне для анализа хватило. :))) Автору еще раз респект! В форму вставьте флажек с идентификатором флБольше3х и на закладке Дополнительно свяжите его с Процедурой ПриИзмененииФлага()

//******************************************************************************
Процедура ПриИзмененииФлага()
Если флБольше3х > 0 Тогда
флСортПоКодам=1;
КонецЕсли;

КонецПроцедуры

Процедура Сформировать()
спр = СоздатьОбъект("Справочник.Сотрудники");
тз = СоздатьОбъект("ТаблицаЗначений");
тз.НоваяКолонка("Сотрудник", "Справочник.Сотрудники");
тз.НоваяКолонка("Код", "Строка");
тз.НоваяКолонка("Начало", "Дата");
тз.НоваяКолонка("Окончание", "Дата");
тз.НоваяКолонка("Сумма", "Число");
спр1 = СоздатьОбъект("Справочник.ВычетыСотрудниковПоНДФЛ");
спр.ВыбратьЭлементы();
Пока спр.ПолучитьЭлемент() = 1 Цикл
Если спр.ЭтоГруппа() = 1 Тогда
Продолжить;
КонецЕсли;
спр1.ИспользоватьВладельца(спр.ТекущийЭлемент());
спр1.ВыбратьЭлементы();
Пока спр1.ПолучитьЭлемент() = 1 Цикл
тз.НоваяСтрока();
тз.Сотрудник = спр.ТекущийЭлемент();
тз.Код = спр1.ВидВычета.Код;
тз.Начало = спр1.ДатаНачала;
тз.Окончание = спр1.ДатаОкончания;
кв = СокрЛП(тз.Код);
Если спр1.Сумма = 0 Тогда
тз.Сумма = спр1.ВидВычета.Сумма.Получить(Дата1);
Иначе
тз.Сумма = спр1.Сумма;
КонецЕсли;
КонецЦикла;
КонецЦикла;
Если флСортПоКодам = 1 Тогда
тз.Сортировать("Код+, Сотрудник+");
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ВывестиСекцию("Шапка");
//КМЮ++
Если флБольше3х = 0 Тогда
тз.ВыбратьСтроки();
Пока тз.ПолучитьСтроку() = 1 Цикл
Таб.ВывестиСекцию("Строка");
КонецЦикла;
Иначе //а здесь выводим только с детьми больше 2-х
тзКопия = СоздатьОбъект("ТаблицаЗначений");
тзПечать = СоздатьОбъект("ТаблицаЗначений");
чИ=0;
чНачало=1;
чКонец=1;
сСотрудник="";
тз.Выгрузить(тзКопия);
тз.Выгрузить(тзПечать);
тзКопия.ВыбратьСтроки();
Пока тзКопия.ПолучитьСтроку() = 1 Цикл
чИ=чИ+1;
Если Число(тзКопия.Код) <> 108 Тогда
Продолжить;
Иначе

Если сСотрудник <> тзКопия.Сотрудник.Наименование Тогда
сСотрудник = тзКопия.Сотрудник.Наименование;
Если чКонец - чНачало + 1 > 2 Тогда //Выводим
тзПечать.Выгрузить(тз,чНачало,чКонец);
чНачало = чИ;
чКонец = чИ;
тз.ВыбратьСтроки();
Пока тз.ПолучитьСтроку() = 1 Цикл
//и убираем закрытые или не начатые вычеты
Если (тз.Начало > Дата1) Или ((ПустоеЗначение(тз.Окончание) = 0) И (тз.Окончание < Дата1)) Тогда
Продолжить;
Иначе

Таб.ВывестиСекцию("Строка");
КонецЕсли;
КонецЦикла;
Иначе
чНачало = чИ;
чКонец = чИ;
КонецЕсли;

Иначе //Добавляем
чКонец=чИ;
КонецЕсли;
КонецЕсли;
КонецЦикла;
//На всякий случай проверка на детей инвалидов
тзКопия.Выгрузить(тз);
тз.ВыбратьСтроки();
Пока тз.ПолучитьСтроку() = 1 Цикл
Если Число(тз.Код) <> 109 Тогда
Продолжить;
Иначе
//и убираем закрытые или не начатые вычеты
Если (тз.Начало > Дата1) Или ((ПустоеЗначение(тз.Окончание) = 0) И (тз.Окончание < Дата1)) Тогда
Продолжить;
Иначе

Таб.ВывестиСекцию("Строка");
КонецЕсли;
КонецЕсли;

КонецЦикла;
КонецЕсли;

//КМЮ--
Таб.ВывестиСекцию("Подвал");
Таб.ТолькоПросмотр(1);
Таб.ПараметрыСтраницы(2, 100, , , , , , , , 1);
Таб.Опции(0, 0, 3, 2);
Таб.Показать("Отчет");
КонецПроцедуры

//******************************************************************************
// ПриОткрытии()
//
Процедура ПриОткрытии()
Дата1 = РабочаяДата();
флСортПоКодам = 1;
КонецПроцедуры // ПриОткрытии
2. rimma_n 160 07.11.08 12:02 Сейчас в теме
Понравился отчет, хорошо бы еще добавить отбор по подразделениям либо конкретному сотруднику.
Переделаю, выложу.
3. Nata_22 05.02.09 06:19 Сейчас в теме
Спасибо огромное! Очень пригодился ваш отчет.
4. TED777 25.01.10 11:14 Сейчас в теме
Спасибо! Крутой отчёт!
5. Arin 29.09.11 18:25 Сейчас в теме
7. Гость 20.01.12 12:11
Отчет хороший. Очень хочется обработку для 7 зик по растаскиванию вычетов с 01/01/2011 на 114,115,116 и т.д. как в 8 зуп.
8. annabuh2006 16.02.12 11:35 Сейчас в теме
Спасибо. Очень дельно.
9. Milky_Way 40 19.08.15 14:36 Сейчас в теме
Спасибо... не пришлось создавать велосипед заново...
10. Abbra 23 06.08.17 16:34 Сейчас в теме
а 503 вычеты у меня не показывает
Оставьте свое сообщение