Вычеты сотрудников НДФЛ с возможностью сортировки

Публикация № 15708

Учет и отчетность - Зарплата

50
Отчет предназначен для анализа закрытия вычетов и контроля сумм вычетов. Отчет позволяет сортировать результаты по кодам вычетов или по сотрудникам.
50

Скачать файлы

Наименование Файл Версия Размер
-
.1207495941 12,38Kb
25.09.09
476
.1207495941 12,38Kb 476 Скачать бесплатно

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. LL57101 18.10.08 11:46 Сейчас в теме
Хороший отчет, понравилось, пригодилось
6. Michael_K 7 28.11.11 21:58 Сейчас в теме
Спасибо огромное! Небольшая переделка и на крупных предприятиях запросто выводятся сотрудники с тремя и более детьми, что сейчас очень актуально!
Вот, кому надо - пользуйтесь. Написано "на живую нитку", просьба сильно не пинать, было не до красоты. Если у сотрудника куча закрытых вычетов, например ежегодно закрывался и с НГ вводился новый - такие тоже попадут, кому надо доработайте, мне для анализа хватило. :))) Автору еще раз респект! В форму вставьте флажек с идентификатором флБольше3х и на закладке Дополнительно свяжите его с Процедурой ПриИзмененииФлага()

//******************************************************************************
Процедура ПриИзмененииФлага()
Если флБольше3х > 0 Тогда
флСортПоКодам=1;
КонецЕсли;

КонецПроцедуры

Процедура Сформировать()
спр = СоздатьОбъект("Справочник.Сотрудники");
тз = СоздатьОбъект("ТаблицаЗначений");
тз.НоваяКолонка("Сотрудник", "Справочник.Сотрудники");
тз.НоваяКолонка("Код", "Строка");
тз.НоваяКолонка("Начало", "Дата");
тз.НоваяКолонка("Окончание", "Дата");
тз.НоваяКолонка("Сумма", "Число");
спр1 = СоздатьОбъект("Справочник.ВычетыСотрудниковПоНДФЛ");
спр.ВыбратьЭлементы();
Пока спр.ПолучитьЭлемент() = 1 Цикл
Если спр.ЭтоГруппа() = 1 Тогда
Продолжить;
КонецЕсли;
спр1.ИспользоватьВладельца(спр.ТекущийЭлемент());
спр1.ВыбратьЭлементы();
Пока спр1.ПолучитьЭлемент() = 1 Цикл
тз.НоваяСтрока();
тз.Сотрудник = спр.ТекущийЭлемент();
тз.Код = спр1.ВидВычета.Код;
тз.Начало = спр1.ДатаНачала;
тз.Окончание = спр1.ДатаОкончания;
кв = СокрЛП(тз.Код);
Если спр1.Сумма = 0 Тогда
тз.Сумма = спр1.ВидВычета.Сумма.Получить(Дата1);
Иначе
тз.Сумма = спр1.Сумма;
КонецЕсли;
КонецЦикла;
КонецЦикла;
Если флСортПоКодам = 1 Тогда
тз.Сортировать("Код+, Сотрудник+");
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ВывестиСекцию("Шапка");
//КМЮ++
Если флБольше3х = 0 Тогда
тз.ВыбратьСтроки();
Пока тз.ПолучитьСтроку() = 1 Цикл
Таб.ВывестиСекцию("Строка");
КонецЦикла;
Иначе //а здесь выводим только с детьми больше 2-х
тзКопия = СоздатьОбъект("ТаблицаЗначений");
тзПечать = СоздатьОбъект("ТаблицаЗначений");
чИ=0;
чНачало=1;
чКонец=1;
сСотрудник="";
тз.Выгрузить(тзКопия);
тз.Выгрузить(тзПечать);
тзКопия.ВыбратьСтроки();
Пока тзКопия.ПолучитьСтроку() = 1 Цикл
чИ=чИ+1;
Если Число(тзКопия.Код) <> 108 Тогда
Продолжить;
Иначе

Если сСотрудник <> тзКопия.Сотрудник.Наименование Тогда
сСотрудник = тзКопия.Сотрудник.Наименование;
Если чКонец - чНачало + 1 > 2 Тогда //Выводим
тзПечать.Выгрузить(тз,чНачало,чКонец);
чНачало = чИ;
чКонец = чИ;
тз.ВыбратьСтроки();
Пока тз.ПолучитьСтроку() = 1 Цикл
//и убираем закрытые или не начатые вычеты
Если (тз.Начало > Дата1) Или ((ПустоеЗначение(тз.Окончание) = 0) И (тз.Окончание < Дата1)) Тогда
Продолжить;
Иначе

Таб.ВывестиСекцию("Строка");
КонецЕсли;
КонецЦикла;
Иначе
чНачало = чИ;
чКонец = чИ;
КонецЕсли;

Иначе //Добавляем
чКонец=чИ;
КонецЕсли;
КонецЕсли;
КонецЦикла;
//На всякий случай проверка на детей инвалидов
тзКопия.Выгрузить(тз);
тз.ВыбратьСтроки();
Пока тз.ПолучитьСтроку() = 1 Цикл
Если Число(тз.Код) <> 109 Тогда
Продолжить;
Иначе
//и убираем закрытые или не начатые вычеты
Если (тз.Начало > Дата1) Или ((ПустоеЗначение(тз.Окончание) = 0) И (тз.Окончание < Дата1)) Тогда
Продолжить;
Иначе

Таб.ВывестиСекцию("Строка");
КонецЕсли;
КонецЕсли;

КонецЦикла;
КонецЕсли;

//КМЮ--
Таб.ВывестиСекцию("Подвал");
Таб.ТолькоПросмотр(1);
Таб.ПараметрыСтраницы(2, 100, , , , , , , , 1);
Таб.Опции(0, 0, 3, 2);
Таб.Показать("Отчет");
КонецПроцедуры

//******************************************************************************
// ПриОткрытии()
//
Процедура ПриОткрытии()
Дата1 = РабочаяДата();
флСортПоКодам = 1;
КонецПроцедуры // ПриОткрытии
2. rimma_n 166 07.11.08 12:02 Сейчас в теме
Понравился отчет, хорошо бы еще добавить отбор по подразделениям либо конкретному сотруднику.
Переделаю, выложу.
3. Nata_22 05.02.09 06:19 Сейчас в теме
Спасибо огромное! Очень пригодился ваш отчет.
4. TED777 25.01.10 11:14 Сейчас в теме
5. Arin 29.09.11 18:25 Сейчас в теме
7. Гость 20.01.12 12:11
Отчет хороший. Очень хочется обработку для 7 зик по растаскиванию вычетов с 01/01/2011 на 114,115,116 и т.д. как в 8 зуп.
8. annabuh2006 16.02.12 11:35 Сейчас в теме
9. Milky_Way 37 19.08.15 14:36 Сейчас в теме
Спасибо... не пришлось создавать велосипед заново...
10. Abbra 22 06.08.17 16:34 Сейчас в теме
а 503 вычеты у меня не показывает
Оставьте свое сообщение

См. также

Записки на память. Зарплата и кадры 1С 7.7 (ЗиК 7.7 ) 54

Статья Системный администратор Программист Бухгалтер Нет файла v77::Расчет 1С7:ЗиК Россия БУ НУ УУ Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Бухгалтерский учет

ЗиК 7.7 постепенно сходит на нет. Но, возможно, кому-то из нас все-таки когда-либо еще не раз придется столкнуться с этой конфигурацией. Поскольку работы по ней и заказов всё меньше и меньше, знания о ней и опыт постепенно угасают. Мой опыт с ЗиК 7.7 длиной в 14 лет терять просто так неохота. В этой статье я запишу, чтобы не забыть, важные моменты об этой конфигурации, чтобы самому не забыть, и вдруг кто-то получит это в наследство на сопровождение и будет вынужден (иначе не скажешь) это обслуживать. Или еще можно рассматривать эту статью как модное нынче «Письмо самому себе в прошлое».

18.11.2014    34961    Lapitskiy    26       

Подготовка сведений для ПФР ЗиК Исправление ошибок 3

Статья Программист Нет файла v77::Расчет 1С7:ЗиК БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Адаптация типовых решений

Подготовка сведений для ПФР ЗиК Исправление ошибок. Для сотрудников, у которых во 2,3 или 4 квартале не было заработка, но есть стаж (например, декретницы) не заполняется «Сумма выплат с начала года».

30.07.2014    14263    Cvetic    4       

Подготовка сведений для ПФР ЗиК 339. СЗВ-6-4 две незначительные ошибки. 3

Статья Системный администратор Программист Бухгалтер Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

Подготовка сведений для ПФР ЗиК 339. СЗВ-6-4 две незначительные ошибки: 1.При переносе сотрудника из одной пачки в другую у него теряются сведения о выплатах. 2.Неактивна кнопка сортировки сотрудников.

11.10.2013    10642    Cvetic    7       

Ошибка в отчете "Справки по НДФЛ" в Комплексной р.517 6

Статья Программист Нет файла v77::Расчет 1С7:Комплекс Россия БУ Зарплата НДФЛ Бесплатно (free) Налоговые

Исправление ошибки расчета сумм вычетов (по кодам 311, 312, 318) в п. 4.1 отчета "Справки по НДФЛ".

24.02.2012    8637    yupi71    1       

Перерасчет ФСС НС за предыдущий период в ЗиК 315 11

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Адаптация типовых решений

Если изменить базу вида расчета «ФСС НС», то в релизе 1С:Зарплата и Кадры 7.70.315, в текущем расчетном периоде не происходит перерасчет за предыдущие периоды.

02.11.2011    14804    Nicholas    13       

Неправильное изменение категории плательщика ПФР при проведении справки МСЭК 6

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

В ЗиК (релиз 314) при проведении документа "Справка МСЭК" вкралась ошибка: проведение некорректно изменяет категорию плательщика ПФР на "Работник сельскохозяйственной организации - инвалид", затем на "Работник колхоза, совхоза и другого сельскохозяйственного предприятия". Связано это с разными типами ожидаемого и возвращаемого перечисления в функции "глКатегорияПФР": "КатегорияПлательщикаПФ" и "КатегорииЗастрахованныхЛицПФР". Решение: изменить функцию "глКатегорияПФР" (около 2932-й строки).

17.10.2011    3846    Krokokot    3       

ЗиК: Заполнение данных о заработке у предыдущих работодателей в больничном 9

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Доработка ЗиК 314. Заполнение данных в больничном за 2 предыдущих года у другого работодателя. Для работы необходимо добавить в конфигурацию новый справочник.

04.10.2011    9070    allexe    13       

Компенсация отпуска, оплата дней доноров и оплата льготных дней родителей в ЗиК 18

Статья Программист Нет файла v77::Расчет 1cv7.md 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

"Компенсация отпуска"," Оплата дней доноров" и "Оплата льготных дней родителей" - эти виды расчетов должны облагаться страховыми взносами с 01.01.2011 года.

04.10.2011    6543    maxim305    18       

Отпуск по уходу за ребенком. Печать расчета среднего заработка 1

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Печать расчета среднего заработка в документе "отпуск по уходу за ребенком" по старым/новым правилам, реализованная в ЗиК 7.70.313, содержит досадную ошибку - если вызвать печать в уже проведенном документе, всегда выдается отчет для новых правил.

23.09.2011    3545    Gr@nd@d    5       

1С 7.7 ЗиК. Доработка документа "Бригадный наряд" с возможностью увидеть часы в расчетном листке 8

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Маленькая доработка модуля документа "Бригадный наряд" с возможностью увидеть часы в расчетном листке. Не забудьте, когда будете заполнять документ "Бригадный наряд", поставить галочку "Учитывать отработанные часы".

08.09.2011    4484    Ироида    14       

Расчет сверхурочной работы 25

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК 1С7:Комплекс Россия БУ Зарплата Учет рабочего времени Бесплатно (free) Бухгалтерские

Сверхурочной работой считается работа, производимая работником по инициативе работодателя сверх нормального числа рабочих часов за учетный период (п.1 ч.2 ст. 99 ТК РФ). Данная обработка позволяет автоматически по итогам учетного периода (месяц, квартал, год) расчитать переработку сотрудников и расчитать им доплату за сверхурочную работу.

31.08.2011    18882    151    victuan    29       

Расшифровка внутренних расчетов 1С:Зарплата 10

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

Трассировка (расшифровка) промежуточных расчетов документов в 1С:Зарплата

20.07.2011    8456    buhinfo    5       

Регистр учета удержанных и перечисленных сумм по исполнительным документам 1

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Печатные формы документов

Заполните банковские реквизиты получателя и выберите способ - перечисление на банковский счет, тогда будут выводится банковские данные. Если в текущем месяце выплачена ЗП, тогда Фактически удержано = Следовало удержать.

04.07.2011    5742    41    fisgen    3       

Методика расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года (вариант) 32

Статья Программист Нет файла v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

В статье рассмотрен один из возможных вариантов расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года.

14.06.2011    19336    vkr    48       

Ошибка Выгрузки проводок из ЗиК 311 в Бухгалтерию бюджетного учреждения 7

Инструменты и обработки Системный администратор Бухгалтер Конфигурация (md, cf) v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Перенос данных из 1С7.7 в 1C8.X

При формировании свода проводок и выгрузке проводок из ЗиК 311 в Бухгалтерию бюджетного учр. используется как "новый" 401.20 так и "старый" счет 401.01 ( там собираются "копейки"). Бухгалтерия ред6.2 отказывается грузить такие проводки.

07.06.2011    6518    44    RUS63    6       

Лицевой счет для ЗиК 7.7 8

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Универсальные печатные формы Бухгалтерские

В ЗиКе есть отчет Лицевые счета и карточки-справки. Для хозрасчетных организаций печатная форма только одна Т-54а, для бюджетных организаций имеется еще 2 печатных формы довольно удобных. В обработке сохранен отчет с установленным флагом бюджетной организации. Может кому пригодится.

12.05.2011    7729    165    VladB50    7       

Форма 1-НДФЛ для 2011 года (Зарплата и Кадры 7.7, релиз 310) 29

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата НДФЛ Бесплатно (free) Практика программирования

В прежних релизах была возможность из справочника "Сотрудники" сформировать форму 1-НДФЛ по кнопке "Ввод данных" (там была возможность расшифровки сумм). Вернём полезную функцию!

29.04.2011    4314    Q-Q    9       

Две простенькие функции для правильного учета сторно-записей и записей-перерасчетов 9

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Часто при подсчете дней по записям журнала расчетов "Зарплата" берется знак "+" или "-" в зависимости от признака сторно-записи. Но рано или поздно результат получится ошибочным.

19.02.2011    8629    jack19    3       

Ошибки формата файла 2-НДФЛ в ЗиК релиз 306 100

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия НУ Зарплата НДФЛ Бесплатно (free) Практика программирования

Ошибки 2НДФЛ в релизе: файл формируется как для ЮЛ, даже если работодатель ИП, опечатка "Отчетсвто", и указание имени файла с расширением. Нужно подправить отчет "СправкиПоНДФЛ".

02.02.2011    17030    1st    6       

ПФР за год 10

Статья Бухгалтер Нет файла v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Учет и отчетность

Могу подсказать алгоритм, как надо заполнять документ "Расчеты по страховым взносам", чтобы отчет для ПФР сошелся в копеечку

29.01.2011    6768    Lika-Kalika    3       

ЗиК 305 ЗиК 306 Больничный лист. 107

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

Для переходящих больничных листов за счет работодателя оплачивается 2 дня, а не 3. Первоисточник: http://forums.kuban.ru/forum/viewtopi...669&page=2

25.01.2011    12144    Cvetic    26       

ЗиК 306 и ЗиК 305. Единовременные пособия из ФСС для организаций уплащивающих ЕНВД 10

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

Возникла ошибка когда Единовременные пособия из ФСС неправильно вставали в "Карточку расчета страховых взносов" если были выплаченны после сентября месяца. и сотвественно неправильно формируеться РСВ-1

25.01.2011    7789    *Zed*    2       

ЗиК 2011 (ставки ФОМС) 90

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ НУ Windows Зарплата Управление персоналом (HRM) ФОМС, ПФ, ФСС Бесплатно (free) Обработка справочников

Обработка устанавливает в типовой конфигурации "Зарплата и Кадры 7.7" (релиз 305) ставки страховых взносов, измененные с 1 января 2011 года Федеральным законом от 16.10.10 № 272-ФЗ.

09.01.2011    11483    588    Antia    11       

Награды (почётные звания) сотрудников, обработка-отчет для ЗиК 7.7 6

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Управление персоналом (HRM) Бесплатно (free) Бухгалтерские

Обработка предназначена для типовой конфигурации ЗиК 7.7, позволяет вести список наград (почётных званий) сотрудников и формировать отчет с несколькими вариантами отбора. Данные хранятся строкой в реквизите справочника "Сотрудники" - "Награды". В типовой конфигурации для заполнения используется "Форма Т-2" (форма элемента справочника "Сотрудники" -> "Ввод данных" -> "Форма Т-2" -> 7 раздел, награды и поощрения).

26.10.2010    7724    62    vovk_v    3       

Ошибка в ЗиК 300, 299, 298. Разные виды расчета имеют одинаковые синонимы. 0

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

В ЗиК 300, 299, 298 разные виды расчета имеют одинаковые синонимы. В следствие их неотличимости можно задать шаблон проводок не на тот вид расчета и получить ошибку "Некорректно сопоставляется проводка из подразделения сотрудника..."

19.09.2010    1705    safsn0    2       

ЗиК.300 Загогулина 59

Инструменты и обработки Программист Конфигурация (md, cf) v77::Расчет 1С7:ЗиК Россия Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

В конфигурации ЗиК.300 при использовании при расчетах любого единовременного пособия из соцстраха (рождение, погребение…) - возможна ошибка в своде проводок...

24.08.2010    12903    UV2    14       

Список сотрудников с особыми условиями труда для ПФР. (Версия от 16.07.2011) 25

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК Россия Зарплата Управление персоналом (HRM) Бесплатно (free) Бухгалтерские

Формирование и выгрузка списка сотрудников с особыми условиями труда в xml-файл под версию 1.9 Отчет переписан почти заново. Обновление 16.07.2011.

23.07.2010    16318    403    rechvladmir    22       

Ускоритель СЗВ 2010 для ЗиК 2.99 30

Статья Системный администратор Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

Ускоряет формирование СЗВ примерно вполовину за счет уменьшения числа запросов. Реально полезно, когда надо часто и много заходить в редактирование форм СЗВ. ЗиК 2.99

20.07.2010    7946    aves    7       

ЗиК 298 Ошибка в исчислении стажа. Отчетность ПФР СЗВ-6. 34

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Проблемы у сотрудников, имеющих Больничные листы, у которых либо Начало болезни = конец месяца либо Окончание болезни = начало месяца. В первом случае в СЗВ-6 началом болезни считается начало следующего месяца, во втором окончание болезни - конец месяца.

13.07.2010    11021    Cvetic    19       

ЗиК 7.7 заполнение данных по донорским дням в карточке "Сведения о стаже" 2

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

Сначала оговорюсь, что наша конфигурация неоднократно изменялась и от стандартной очень отличается, поэтому буду приводить куски кода без указания номеров строк. Документы по донорским дням вводятся в систему через документ «Оплата по среднему» вид расчета указывается «Дни доноров» (собственно добавленный нами вид расчета). Так как донорские дни не облагаются страховыми взносами, то и в стаж эти дни попадать не должны. Соответственно при сдачи отчетности в ПФР нужно заполнять карточку «Сведения о стаже». Это конечно можно было сделать вручную, когда документов не больше десятка, но когда их более 250, то бухгалтерам проблематично внести все отклонения в систему. Поэтому автоматизируем процесс :)

07.07.2010    3256    Zarema    3       

Подготовка сведений для ПФР за 1 полугодие 2010 года - ошибка (Конфигурация Зарплата и кадры 7.7. Релиз 298) 8

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Регламентированная отчетность

Обработка по формированию печатных форм и выгружаемых файлов в соответствии с требованиями ПФ РФ, полученная от krein, по ссылке http://infostart.ru/public/72604!

04.07.2010    9035    218    vladimir_astapov    7       

Штатное расписание по факту (со всеми надбавками, с оплатой по окладам и тарифам) 23

Отчеты и формы no Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Бухгалтерские

Учитываются не только оклады, но и часовые тарифы сотрудников, а также все постоянные надбавки, введены ли они через справочник "Штатное расписание" или документами.

18.06.2010    8749    312    pr_skm    12