Лицевой счет (Форма Т-54) дополненный

01.07.09

Учетные задачи - Зарплата

Дополненный лицевой счет формы Т-54

Скачать исходный код

Наименование Файл Версия Размер
-
.1220932737 108,00Kb
1368
.1220932737 108,00Kb 1368 Скачать

Удобная для бухгалтеров (расчетчиков) форма

Для щедрых людей которым помогла обработка:
Яндекс деньги № 41001241519720 , не откажусь :)

См. также

Обмен данными ЗУП 3.1 - Бухгалтерия 7.7

Зарплата Перенос данных 1C Бухгалтерский учет 7.7 Сложные периодические расчеты 1С:Бухгалтерия 7.7 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

Как известно, Бухгалтерия 7.7 не имеет штатной возможности для обмена с ЗУП 3.1. Данная разработка пригодится тем, кто перешел с ЗиК 2.3 на ЗУП 3.1, но вынужден по каким-то своим причинам оставаться на Бухгалтерии 7.7.

18000 руб.

29.09.2020    13623    2    0    

5

7.7 : Ставки налогов и отчислений. БУХ учет Украина 2014

Зарплата Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Украина Бухгалтерский учет НДФЛ Абонемент ($m)

Просто запустим обработку. Файл "СтавкиНалоговЗарплата2014.ert" - выполнить.

1 стартмани

22.01.2014    28515    2    kompas-dm    1    

1

Справка по форме 182Н для 1С:Бухгалтерии 7.7

Зарплата Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Производство+Услуги+Бухгалтерия 1С:Упрощенное налогообложение 7.7 Россия Бухгалтерский учет ФОМС, ЕФС Платные (руб)

Новая справка для расчета пособий по временной нетрудоспособности в соответствии с приказом Министерства труда и социальной защиты № 182Н от 30.04.2013 года (учитывая изменения вплоть до 2017 года). Справку необходимо выдавать на руки при увольнении сотрудника. Может помочь при расчете среднего заработка при нетрудоспособности сотрудников. Будет незаменимым помощником для бухгалтеров, осуществляющих расчеты по заработной плате, при отсутствии специализированной программы.

2000 руб.

03.08.2013    81344    31    21    

39

Подготовка сведений в ПФР за 2013 год с распределением суммы уплаченных взносов, превышающих начисленные

Регламентированный учет и отчетность Зарплата Расчет 7.7 1С:Зарплата и кадры 7.7 Россия Бухгалтерский учет ФОМС, ЕФС Абонемент ($m)

При подготовке к сдаче отчета в ПФР столкнулся с тем, что программа не учитывает переплату - не распределяет сумму уплаченных взносов, превышающую начисленную, даже если это оплата проходит в январе 2013 за декабрь 2012. В случае, когда есть долг по оплате на начало периода (например, за декабрь 2012 платят в январе 2013) сумма уплаченных взносов может быть больше суммы начисленных. Программа же ставит сумму уплаченных взносов равную сумме начисленных. В этой обработке распределяются суммы уплаченных взносов, превышающих начисленные, а так же внесены исправления, связанные с возможными ошибками при формировании штатной обработки из 335 релиза (в пачки попадали ненужные уволенные, неправильно распределялись уплаты взносов, при выгрузке в файл возникали ошибки).

1 стартмани

20.04.2013    30960    425    mirrr    65    

41

Расчетная ведомость для 1С:Бухгалтерии 7.7

Зарплата Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Для бухгалтера : удобный отчет по начислениям-выплатам-удержаниям И повод задуматься о переходе на ЗУП Для программиста : удобный инструмент сверки данных при переходе с 1С:Бухгалтерии 7.7 на 1С:ЗУП 2.5

4 стартмани

01.03.2013    37395    87    Designer1C    7    

10
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. buchals 09.09.08 11:37 Сейчас в теме
Желательно, что-бы данный об отпсуках брал не из начисления, а из приказа об отпуске
2. WiseSnake 1520 09.09.08 11:46 Сейчас в теме
(1) Они должны совпадать, но из начисления он важнее потому что делает движения по отпуску, а кадровый документ является всего лишь основанием.
3. buchals 15.09.08 16:18 Сейчас в теме
Но при формировании данные включаются дважды: из приказа и из начисления отпуска
4. ankr 19 08.03.09 13:40 Сейчас в теме
Скачал файл, а он не открывается :(
1С говорит: Неправильный формат файла...???
5. WiseSnake 1520 09.03.09 19:08 Сейчас в теме
6. GeenS 18.03.09 12:30 Сейчас в теме
все равно ругается на неправильный формат!
7. GeenS 18.03.09 12:32 Сейчас в теме
повторно качнул - не ругаецца...
8. WiseSnake 1520 18.03.09 20:18 Сейчас в теме
Если будут у кого проблемы, пишите в личку, вышлю на мыло
9. maxim48 28.07.09 15:15 Сейчас в теме
Ошибка: Неправильный формат файла
10. WiseSnake 1520 28.07.09 16:06 Сейчас в теме
(9) Читаем посты 5-7 вчитываемся в п.8
11. igoSolo 9 28.09.09 14:51 Сейчас в теме
А есть такой для бухгалтерии 80?
13. WiseSnake 1520 10.02.10 22:36 Сейчас в теме
(11) Нет, нету
(12) Писал это много-много лет назад... конечно уже не помню... но не вижу ничего сложного в вашей проблемме
12. Uragan 09.02.10 02:24 Сейчас в теме
Спасибо. Классно. Если не секрет можешь написать на a_l_e_k_s@mail.ru, как ты сделал, чтобы больничный по уходу за ребенком выводился, я мучался инифига
14. Armando 1400 07.07.10 12:07 Сейчас в теме
Все хорошо, но почему нельзя было сделать явное указание года?
15. struhin 28.07.11 12:02 Сейчас в теме
16. пользователь 18.10.11 15:22
Сообщение было скрыто модератором.
...
17. YuPiter 28.11.11 04:29 Сейчас в теме
Большое спасибо за обработку! Уж очень проверяющие хотят видеть эти лицевые счета, а бухгалтерша и не знала, что в ЗиК`е только есть Т-54а,а Т-54 нет. Подцепил - ее радости нет предела!!!
18. m-xolding 28.03.12 14:19 Сейчас в теме
Спасибо автору! Иногда сама дорабатываю печатную форму. Удачи Вам и побольше программ для нас-бухгалтеров!!!
19. АлексейН 2 28.02.13 14:10 Сейчас в теме
Автору респект и признательность,
облегчает работу бухгалтеров.
А то бухгалтер в "тихом шоке" надо распечать за последние 3 года на полсотни человек.
Спасибо
20. lvictor58 135 30.12.14 13:01 Сейчас в теме
немного подправил выбор периода:
СписокПериодов = СоздатьОбъект("СписокЗначений");
//	СписокПериодов.ДобавитьЗначение(1,	"за текущий год");
//	СписокПериодов.ДобавитьЗначение(2,	"за прошлый год");
//
//	ВыбранныйПериод = "";
//	Если СписокПериодов.ВыбратьЗначение(ВыбранныйПериод, , , , 1) = 0 тогда
//		Возврат;
//	КонецЕсли;
//
//	ЖрнЗарплата = СоздатьОбъект("ЖурналРасчетов.Зарплата");
//	ДатаНачГода = ЖрнЗарплата.НачалоТекущегоПериода();
//	
//	Если (ВыбранныйПериод = 1) тогда
//		ДатаНачГода = НачГода(ДатаНачГода);
//		ДатаКонГода = КонГода(ДатаНачГода);
//	ИначеЕсли (ВыбранныйПериод = 2) тогда
//		ДатаНачГода = НачГода(НачГода(ДатаНачГода) - 1);
//		ДатаКонГода = КонГода(ДатаНачГода);
//	КонецЕсли;  

	ТекГод = ДатаГод(ТекущаяДата()) + 1;
	ЖрнЗарплата = СоздатьОбъект("ЖурналРасчетов.Зарплата");
	Для А = 1 По 10 Цикл
		ПромДата = Дата(ТекГод - А, 01, 01);
    	   Рез = ЖрнЗарплата.ВыбратьПериодПоОбъекту(Человек, ПромДата);
		// сотрудник мог быть как принят на работу так и уволен в средине года 
		Если Рез = 0 Тогда
			ПромДата = Дата(ТекГод - А, 12, 31);
	        Рез = ЖрнЗарплата.ВыбратьПериодПоОбъекту(Человек, ПромДата); 
		КонецЕсли;
		Если Рез = 0 Тогда продолжить КонецЕсли;
		СписокПериодов.ДобавитьЗначение(ПромДата,	""+ДатаГод(ПромДата)+" год");
	КонецЦикла;
	
	ВыбранныйПериод = "";
	Если СписокПериодов.ВыбратьЗначение(ВыбранныйПериод, , , , 1) = 0 тогда
		Возврат;
	КонецЕсли;
	ДатаНачГода = НачГода(НачГода(ВыбранныйПериод));
	ДатаКонГода = КонГода(ВыбранныйПериод);
Показать


Еще изящнее - это добавить список периодов как элемент формы. Но ладно уж, и так сойдет.

И еще с приказами на отпуск как-то непонятно.
21. lvictor58 135 30.12.14 16:56 Сейчас в теме
Документы по отпуску должны следовать в последовательности Приказ ---> Начисление
Поэтому предлагаю такой алгоритм:

ДокументОтпуск = СоздатьОбъект("Документ");    
	ДокументПодч = СоздатьОбъект("Документ");
	НайденПриказ = 0;
	ДокументОтпуск.ВыбратьПоЗначению(ДатаНачГода, ДатаКонГода, "Сотрудник", Человек); 
	Пока ДокументОтпуск.ПолучитьДокумент() = 1 Цикл
		Если (ДокументОтпуск.Проведен()=0) Тогда
			Продолжить
		КонецЕсли; 
		Если (ДокументОтпуск.Вид()="ПриказПоОтпуску") ИЛИ (ДокументОтпуск.Вид()="НачислениеОтпуска") Тогда Иначе продолжить КонецЕсли;
		
		Если ДокументОтпуск.Вид()="ПриказПоОтпуску" Тогда   
			НайденПриказ = 1;
			НайденНачисление = 0;
			ТаблицаОтпусков.НоваяСтрока(); 
			ТаблицаОтпусков.Документ = ДокументОтпуск.ТекущийДокумент();
			ТаблицаОтпусков.Начало = ДокументОтпуск.Начало;
			ТаблицаОтпусков.Окончание = ДокументОтпуск.Окончание;
			Если ДокументПодч.ВыбратьПодчиненныеДокументы(ДатаНачГода,ДатаКонГода,ДокументОтпуск.ТекущийДокумент()) > 0 Тогда
				Пока ДокументПодч.ПолучитьДокументт() > 0 Цикл
					Если (ДокументПодч.Проведен()=0)или(ДокументПодч.Вид()<>"НачислениеОтпуска") Тогда
						Продолжить
					КонецЕсли;
					НайденНачисление = 1;
					ТаблицаОтпусков.Начало = ДокументПодч.Начало;
					ТаблицаОтпусков.Окончание = ДокументПодч.Окончание;
					ТаблицаОтпусков.КоличествоДней = ДокументПодч.КоличествоДнейОтпуска; 
					прервать;
				КонецЦикла;	
			КонецЕсли; 
			
			Если НайденНачисление = 0 Тогда
				ТаблицаОтпусков.Начало = ДокументОтпуск.Начало;
				ТаблицаОтпусков.Окончание = ДокументОтпуск.Окончание;
				ТаблицаОтпусков.КоличествоДней = ДокументОтпуск.КоличествоДнейОтпуска; 
			КонецЕсли;
		ИначеЕсли ДокументОтпуск.Вид()="НачислениеОтпуска" Тогда   
			Если НайденПриказ = 0 Тогда
				ТаблицаОтпусков.НоваяСтрока();
				ТаблицаОтпусков.Документ = ДокументОтпуск.ТекущийДокумент();
			КонецЕсли;
			ТаблицаОтпусков.Начало = ДокументОтпуск.Начало;
			ТаблицаОтпусков.Окончание = ДокументОтпуск.Окончание;
			ТаблицаОтпусков.КоличествоДней = ДокументОтпуск.КоличествоДнейОтпуска; 
			НайденПриказ = 0;
		КонецЕсли;
	КонецЦикла;	
Показать
Оставьте свое сообщение