Трудовой договор (внешняя печатная форма) для ЗУП 3.1

08.12.23

Учетные задачи - Печатные формы

Трудовой договор - внешняя печатная форма. Печатается из карточки сотрудника и из приема на работу.

Скачать файлы

Наименование Файл Версия Размер
Трудовой договор. Внешняя обработка для ЗУП:
.epf 28,85Kb
31
.epf 90_08 28,85Kb 31 Скачать

Подключается через Дополнительные отчеты и обработки.

Код открыт, меняйте по своему усмотрению. 

Разработка для релиза 3.1.12.144 (02.2020г.)

Постоянно поддерживается в работоспособном состоянии. Актуальна для текущих релизов.

Последнее тестирование на конфигурации Зарплата и управление персоналом, редакция 3.1 (3.1.28.12).

Аналогичная обработка формирует печатную форму дополнительного соглашения к трудовому договору из документов Кадровый перевод и Кадровый перевод списком. //infostart.ru/public/1719839/

См. также

Обновление для КА 1.1, ЗУП 2.5, БУХ 2.0: НДС, ЕФС-1, Расчет страховых взносов, Мобилизация, Статистика, Электронные трудовые книжки, 2-НДФЛ, Регламентированная отчетность, Кадровый учет, Прослеживаемость импортных товаров

Зарплата Регламентированный учет и отчетность Кадровый учет Обновление 1С Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 Бухгалтерский учет Налоговый учет Управленческий учет Акцизы ЕНВД ЕСН Земельный налог ИП, ПБОЮЛ, КФХ Налог на имущество Налог на прибыль НДС НДФЛ ФОМС, ЕФС Транспортный налог УСН ПСН (патентная система налогообложения) Платные (руб)

Обновления для конфигураций: КА 1.1; ЗУП 2.5; БУХ 2.0; КА 1.1 Комплексная автоматизация торговли алкогольной продукцией; КА 1.1 Комплексный учет сельскохозяйственного предприятия

19900 руб.

01.04.2020    139936    670    352    

231

Перенос данных из Парус 8 в ЗГУ 3

Зарплата Внешние источники данных Бюджетный учет Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Обработка позволяет перенести кадровую информацию и данные по заработной плате, фактических удержаниях, НДФЛ, вычетах, страховых взносах из базы Парус 8 учреждений в конфигурацию 1С:Зарплата и кадры государственного учреждения ред. 3 (ЗГУ) и начать с ней работать с любого месяца года.

84000 руб.

19.08.2020    22087    18    1    

21

Infostart PrintWizard

Пакетная печать Печатные формы Инструментарий разработчика Платформа 1С v8.3 Запросы 1С:Зарплата и кадры бюджетного учреждения 1С:Конвертация данных 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Платные (руб)

Инструмент, позволяющий абсолютно по-новому взглянуть на процесс разработки печатных форм. Благодаря конструктору можно значительно снизить затраты времени на разработку печатных форм, повысить качество и "прозрачность" разработки, а также навести порядок в многообразии корпоративных печатных форм.

18000 руб.

06.10.2023    6471    13    4    

35

Перенос данных из Парус 10 в ЗГУ ред.3

Внешние источники данных Кадровый учет Файловый обмен (TXT, XML, DBF), FTP Обмен между базами 1C Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Обработка позволяет перенести кадровую информацию и данные по заработной плате, фактических удержаниях, НДФЛ, вычетах, страховых взносах из базы Парус 10 учреждений в конфигурацию 1С:Зарплата и кадры государственного учреждения ред. 3 (ЗГУ) и начать с ней работать с любого месяца года.

60000 руб.

05.10.2022    9021    8    8    

10

Перенос данных из Камин 3.5 (5.5) в ЗиКГУ 3.х

Обмен между базами 1C Зарплата Бюджетный учет Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и Управление Персоналом 3.x Государственные, бюджетные структуры Россия Бюджетный учет Платные (руб)

Обработки для быстрого перехода с конфигураций «КАМИН:Расчет зарплаты для бюджетных учреждений 3.5» и «КАМИН:Зарплата для бюджетных учреждений 5.5» на конфигурацию «Зарплата и кадры государственного учреждения».

12000 руб.

28.07.2016    56626    136    139    

112

Запрет доступа к данным по зарплате для БП 3.0 и КА 2.5

Зарплата Роли и права Платформа 1С v8.3 Бухгалтерский учет Управление правами 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Молдова Россия Казахстан Бухгалтерский учет Платные (руб)

Расширение позволяет максимально полно ограничить доступ пользователей к данным по заработной плате, а именно закрывает доступ к документам начисления и выплаты заработной платы, не позволяет просматривать бухгалтерские отчеты по счету учета зарплаты а также убирает зарплатные проводки из журнала проводок. Расширение запрещает просматривать платежные документы на выплату зарплаты, так же не доступны регламентные отчеты в ПФР и ИФНС. Расширение предлагает готовые настроенные профили "Бухгалтер без зарплаты", "Только просмотр без зарплаты".

5700 руб.

27.05.2021    31659    199    89    

159
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. user1964427 03.07.23 14:41 Сейчас в теме
Добрый день!
Подскажите, пожалуйста, как настроить, чтобы автоматически заполнялось:
1. время начало работы (смены):
2. время окончания работы (смены)
3. время перерыва в работе для отдыха и питания 1 час
2. user1252779 128 04.07.23 07:37 Сейчас в теме
Эту информацию для трудового договора берем из графиков работы. Используем доп. текстовый реквизит "ОписаниеГрафикаРаботы" для справочника Графики работы сотрудников. Если кадровик его заполнил, то информация берется из него если нет, то заполняется в зависимости от количества рабочих дней в неделю.

&НаСервере
Процедура ПечатьДоговор
......
......
	ГрафикРаботыСотрудника = ПолучитьГрафикРаботы(СсылкаНаОбъект);		
	ОписаниеГрафикаРаботыИзДопРеквизита = ПолучитьОписаниеГрафикаРаботыИзДопРеквизита( ГрафикРаботыСотрудника);
	Если СокрЛП( Строка( ОписаниеГрафикаРаботыИзДопРеквизита)) = "" Тогда
		ОписаниеГрафикаРаботы = ПолучитьОписаниеГрафикаРаботы( ГрафикРаботыСотрудника);
	Иначе
		ОписаниеГрафикаРаботы = ОписаниеГрафикаРаботыИзДопРеквизита;
	КонецЕсли;	

......
......

	УсловияТруда                        = Макет.ПолучитьОбласть("УсловияТруда");
......
......
	//2. УСЛОВИЯ ТРУДА
	//2.2
	УсловияТруда.Параметры.ОписаниеГрафикаРаботы = ОписаниеГрафикаРаботы;
.......
.......
	ТабДокумент.Вывести(УсловияТруда);
.......
......

КонецПроцедуры

&НаСервере
Функция ПолучитьОписаниеГрафикаРаботыИзДопРеквизита( ГрафикРаботы) Экспорт
	Результат = "";
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	ДопРеквОписаниеГрафикаРаботы.Значение.ПолноеНаименование КАК ОписаниеГрафикаРаботыИзДопРеквизита
		|ИЗ 
		|	Справочник.ГрафикиРаботыСотрудников.ДополнительныеРеквизиты КАК ДопРеквОписаниеГрафикаРаботы
		|ГДЕ  
		|	ДопРеквОписаниеГрафикаРаботы.Ссылка = &ГрафикРаботы И ДопРеквОписаниеГрафикаРаботы.Свойство.Имя = &ОписаниеГрафикаРаботы
		|";
	
	Запрос.УстановитьПараметр("ГрафикРаботы", ГрафикРаботы.Ссылка);
	Запрос.УстановитьПараметр("ОписаниеГрафикаРаботы", "ОписаниеГрафикаРаботы");
	
	РезультатЗапроса = Запрос.Выполнить();			
	
	Если НЕ РезультатЗапроса.Пустой() Тогда		
		ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
			Результат = СокрЛП( Строка( ВыборкаДетальныеЗаписи.ОписаниеГрафикаРаботыИзДопРеквизита));
		КонецЦикла;	
	КонецЕсли;
	
	Возврат Результат;
КонецФункции

&НаСервере
Функция ПолучитьОписаниеГрафикаРаботы( ГрафикРаботы) Экспорт
	
	Если ГрафикРаботы.СпособЗаполнения = Перечисления.СпособыЗаполненияГрафиковРаботыСотрудников.ПоНеделям Тогда
					
		НомераРабочихДней = Новый Массив;
		Для Каждого СтрокаШаблонаЗаполнения Из ГрафикРаботы.ШаблонЗаполнения Цикл
			Если СтрокаШаблонаЗаполнения.ДеньВключенВГрафик Тогда  				
				НомераРабочихДней.Добавить(СтрокаШаблонаЗаполнения.НомерСтроки);
			КонецЕсли;
		КонецЦикла;
		
		КоличествоРабочихДней = НомераРабочихДней.Количество();
		
		Если КоличествоРабочихДней = 5 Тогда
			Результат = "работнику устанавливается пятидневная рабочая неделя с двумя выходными днями (суббота и воскресенье). Рабочий день с 8.00 до 17.00 часов, если при приеме на работу в связи с производственной необходимостью не оговорен другой режим рабочего времени. Продолжительность перерыва для отдыха и питания составляет один час.";
		ИначеЕсли КоличествоРабочихДней = 6 Тогда
			Результат = "работнику устанавливается шестидневная рабочая неделя с одним выходным днем (воскресенье). Рабочий день с 8.00 до 17.00 часов, если при приеме на работу в связи с производственной необходимостью не оговорен другой режим рабочего времени. Продолжительность перерыва для отдыха и питания составляет один час.";
		Иначе
			Результат = "недельный график";
		КонецЕсли;
		
	Иначе		
		Результат = "работа выполняется в двухсменном режиме. Продолжительность смены составляет 12 часов. Дневная смена с 8.00 до 20.00, ночная смена с 20.00 до 8.00.  Чередование рабочих смен и выходные дни определяются графиком сменности. Продолжительность перерыва для отдыха и питания составляет один час.";		
	КонецЕсли;	
	
	Возврат Результат;
																
КонецФункции
Показать
5. user1964427 04.07.23 13:41 Сейчас в теме
(2)
Вопрос, а что если у нас смены начинаются в разное время?
Например
1 вариант
1. время начало работы (смены): 11 часов
2. время окончания работы (смены): 23 часа
3. время перерыва в работе для отдыха и питания 1 час с 16:00 до 17:00
2 вариант
1. время начало работы (смены): 14 часов
2. время окончания работы (смены): 02 часа
3. время перерыва в работе для отдыха и питания 1 час с 19:00 до 20:00
Название полей
1. время начало работы (смены): [ВремяНачалаРабочегоДня];
2. время окончания работы (смены): [ВремяОкончанияРабочегоДня];
3. время перерыва в работе для отдыха и питания 1 час с [ВремяНачалаПерерыва] до [ВремяОкончанияПерерыва]
Не понимаю как логически прописать алгоритм.
Пример текст условия для пользовательского поля

Выбор
Когда ВидРасчета.Код = «НОЧН»
Тогда ОплаченоЧасов
Иначе 0
Конец
3. user1252779 128 04.07.23 08:52 Сейчас в теме
Дополнительный реквизит
Прикрепленные файлы:
4. user1252779 128 04.07.23 08:56 Сейчас в теме
для разных графиков можно в пользовательском режиме выбирать одно описание
Прикрепленные файлы:
6. user1252779 128 05.07.23 06:45 Сейчас в теме
(5) Если вы хотите динамично формировать описание графика, то где у вас хранится эта информация, оттуда и выуживайте.
В обработке все добывается автономными функциями. Добавьте еще одну, которая будет формировать что вам нужно.
У нас такой потребности не было, мы обошлись доп. реквизитом
Кадровики туда заполняют информацию, которая потом используется и для трудовых договоров и для допников
7. user1964427 05.07.23 09:12 Сейчас в теме
я нашла, что они хранятся в справочнике "Смены работы сотрудников"
8. user1252779 128 05.07.23 10:38 Сейчас в теме
(7) ЗдОрово, извлекайте нужную вам информацию запросом
9. user1252779 128 15.08.23 13:37 Сейчас в теме
(7) К сожалению этот справочник доступен только в ЗУП КОРП
Оставьте свое сообщение