Ведомость времени работы пользователей в базе

13.03.11

Учетные задачи - Учет рабочего времени

Обработка осуществляет парсинг файла журнала регистрации текущей базы и определяет время начала, окончания и продолжительность работы пользователей за выбранный период.

Скачать исходный код

Наименование Файл Версия Размер
Ведомость времени работы пльзователей
.ert 53,00Kb
123
.ert 53,00Kb 123 Скачать

Рассчитываются также суммарные и средние показания времени.

Детализация: пользователи и даты.

Точность: секунды или минуты.

Использован механизм чтения, предложенный в http://www.kb.mista.ru/article.php?id=311.

См. также

Производственный календарь для 1С 7.7

Учет рабочего времени Работа с интерфейсом Программист Бухгалтер Пользователь Платформа 1С v7.7 Конфигурации 1cv7 Россия Абонемент ($m)

Обработка производственного календаря с возможностью импорта и экспорта xls для 1С 7.7 (7.70.027) без изменения конфигурации.

1 стартмани

18.09.2019    12724    6    Jill    8    

3

Ведение табелей в 1С 7.7 (типовая форма П5, для Украины)

Печатные формы Учет рабочего времени Бухгалтер Бухгалтерский учет 7.7 Конфигурации 1cv7 Украина Бухгалтерский учет Абонемент ($m)

В стандартных конфигурациях не хватает этого функционала. Оформление табелей учета рабочего времени.

3 стартмани

28.12.2018    10573    2    Amel2010    0    

3

Табель учета рабочего времени для 1С: 7.7 любой конфигурации

Рабочее место Учет рабочего времени Кадровый учет Бухгалтер Руководитель проекта Платформа 1С v7.7 Конфигурации 1cv7 Управленческий учет Абонемент ($m)

Данное решение предназначено для упрощенного варианта электронного учёта рабочего времени сотрудников предприятия. Печать титульного листа и таблицы табеля учёта рабочего времени. Печать бейджиков сотрудников. Автоматическая регистрация и расчет рабочего времени по штрих-коду сотрудника. Загрузка сотрудников из справочника. Формирование штрих-кода сотрудника. Совместимо с любой конфигурацией 1С:7.7.

5 стартмани

13.12.2017    30319    17    etmarket    5    

5

Модуль учета рабочего времени для СКУД Parsec 2.5

Внешние источники данных Учет рабочего времени Программист Платформа 1С v7.7 Конфигурации 1cv7 Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Обработка позволяет подключаться к базе данных СКУД "Parsec" v 2.5 и формировать отчеты УРВ. По сути реализует функционал родного модуля парсека (и даже немного его расширяет), что позволяет слегка сэкономить на лицензиях.

1 стартмани

17.10.2017    15873    15    gamletspb    9    

6

Перенос документов "Невыходы" из 1С: ЗиК 7 в 1С:ЗУП 8

Учет рабочего времени Перенос данных 1C Системный администратор Программист Расчет 7.7 Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 2.5 1С:Зарплата и кадры 7.7 Россия Бухгалтерский учет Абонемент ($m)

Для тех, кто все еще параллельно ведет ЗиК и ЗУП... На большом предприятии с большим объемом документов в переходный период требуется перенос документов из одной базы в другую, чтобы избавить сотрудников от лишней работы. Невыходы сотрудников - одни из тех документов, которые можно безболезненно перекинуть. Предлагаю такую обработку.

1 стартмани

02.10.2017    17459    0    t225    0    

0

Расчет сверхурочных часов для конфигурации "1С:Зарплата и Кадры 7.7"

Зарплата Учет рабочего времени Бухгалтер Расчет 7.7 1С:Зарплата и кадры 7.7 Россия Бухгалтерский учет Абонемент ($m)

Отчет позволяет рассчитать и проконтролировать, не превышен ли предел сверхурочной работы за указанный период. В качестве параметров отчета задаются: вид расчета, по которому определяем отработанное время, предел сверхурочной работы в часах. Отчет является переработкой отчета по сверхурочным работам для программы "1С:Зарплата и Кадры 7.7" (http://infostart.ru/public/100704/)

1 стартмани

16.06.2016    13154    2    wash    1    

0
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. vcv 89 13.03.11 19:56 Сейчас в теме
А что это даёт? Время прихода на работу и ухода с работы? Я могу прибежать в офис за полчаса до начала рабочего дня, запустить 1С и на два часа в курилку потрепаться.
Без анализа времени реальной активности пользователей - длина удава в попугаях.
Да и с анализом реальной активности пользователей что-то осмысленное отчет даст только для операторов, у которых задача долбить данные, а не думать.
2. 1с2с 53 14.03.11 00:51 Сейчас в теме
(1)
А что это даёт? Время прихода на работу и ухода с работы?...

некоторым нужно именно это...
3. Altair777 645 14.03.11 10:14 Сейчас в теме
а зачем через журнал регистрации?
у меня в одной конфе было через справочник - очень удобно было видеть в реал-тайме и в отчетах
4. 1с2с 53 14.03.11 12:44 Сейчас в теме
(3) хороший вариант..., есть свои плюсы...
5. Altair777 645 14.03.11 13:14 Сейчас в теме
+(3) вот кусочек кода из глобальника

Перем глПользователь Экспорт;
Перем winUSERNAME;

Процедура ПриНачалеРаботыСистемы()  Экспорт
	Попытка
		WSH=СоздатьОбъект("WScript.Shell");
		winUSERNAME=СокрЛП(WSH.ExpandEnvironmentStrings("%USERNAME%"));
	Исключение
		winUSERNAME="";
	КонецПопытки;

	// установка текущего пользователя
	Если ПустоеЗначение(ИмяПользователя())=0 Тогда
		Спр=СоздатьОбъект("Справочник.Пользователи");
		Если Спр.НайтиПоКоду(ИмяПользователя())=0  Тогда
			Спр.Новый();
			Спр.Код=ИмяПользователя();
			Спр.Наименование=ИмяПользователя();
			Спр.Записать();
		ИначеЕсли Спр.ПометкаУдаления()=1 Тогда
			Предупреждение("Пользователь удален из системы!",20);
			СтатусВозврата(0);
			Возврат;
		КонецЕсли;
		глПользователь=Спр.ТекущийЭлемент();
	Иначе
		Предупреждение("Пользователь системы не определен!",20);
		СтатусВозврата(0);
		Возврат;
	КонецЕсли;


	Спр=СоздатьОбъект("Справочник.Сеансы1СПодробно");
	Спр.Новый();
	Спр.Пользователь=глПользователь;
	Спр.ДатаВхода=ТекущаяДата();
	Спр.ВремяВхода=ТекущееВремя();
	Спр.Терминал=winUSERNAME;
	Спр.Записать();
КонецПроцедуры

// ===============================
Процедура ПриЗавершенииРаботыСистемы()
	Перем Спр;
	Спр=СоздатьОбъект("Справочник.Сеансы1СПодробно");
	Спр.ПорядокКодов();
	Спр.ОбратныйПорядок(1);
	Спр.ВыбратьЭлементыПоРеквизиту("Пользователь",глПользователь,1,0);
	Пока Спр.ПолучитьЭлемент() = 1 Цикл
		Спр.ВремяВыхода=ТекущееВремя();
		Спр.Записать();
		Прервать;
	КонецЦикла;
КонецПроцедуры
Показать
6. 1с2с 53 14.03.11 14:38 Сейчас в теме
(5) удобно, особенно для конфигураций оперативного учета...
"+++": удобство, простота и оперативность получения результата...
"---":
необходимость внесения изменений в конфигурацию;
универсальность (далеко не везде есть спр. Пользователи);
обновления (в части дописок глоб. модуля);
невозможность получения результата за период, предшествующий...
7. Altair777 645 14.03.11 14:53 Сейчас в теме
(6)
1с2с пишет:
"---": универсальность (далеко не везде есть спр. Пользователи);

Даже если его и нет, то имеет смысл создать - к нему много чего прикручено (подчиненные справочники) или он сам где-то привинчен :)

1с2с пишет:
невозможность получения результата за период, предшествующий...

Для каждой базы это разовая операция, которую можно сделать парсингом журнала регистраций.
8. 1с2с 53 14.03.11 16:14 Сейчас в теме
(7) т.е. его нет, а к нему уже "много чего прикручено..."? :)
9. Altair777 645 14.03.11 16:23 Сейчас в теме
да, так и сеть :D
- ну, Жора, жарь рыбу
- так нету ж рыбы
- ты, Жора, жарь, а рыба будет

Перефразирую из (7):
Даже если его и нет, то имеет смысл создать - в "моих" конфигурациях к нему много чего прикручено (подчиненные справочники) или он сам где-то привинчен
P.S. вообще как-то не верится что такого справочника вообще нет. М.б. он просто называется как-то по-другому?
Типа Сотрудники, Юзеры, Юзвери и т.д. и т.п.
10. 1с2с 53 14.03.11 16:56 Сейчас в теме
(9) за скороговорку...
V.Nikonov; +1 Ответить
11. ivolga 15.10.11 02:10 Сейчас в теме
Лично мне пригодилась именно в таком виде, когда директору понадобилась информация о приходе-уходе сотрудников. Быстро и удобно. Спасибо!
12. volodya1122 8 06.07.12 13:21 Сейчас в теме
обработка не учитывает промежуточные отключения в пределах дня. Тоисть я рано пришел, включил 1С на 5 минут и вышел. Вечером опять пришел включил 1С. И мне обработка сказала что я честно отработал 9 часов...
Оставьте свое сообщение