Сравнение остатков и оборотов регистров бухгалтерии при переходе с БП 1.6 на БП 2.0

08.07.15

Задачи пользователя - Анализ учета

Подарок от фирмы 1с - новая редакция 2.0 обернулась геморроем.. И хоть правила обмена отлажены все равно расхождения между 1.6 и 2.0 значительные, а отчет о сравнении ведомостей - как иголка в стоге сена. Данная обработка позволяет сравнить остатки или обороты в двух базах и вывести подробный отчет по отличиям в разрезе субконто и распечатать в удобном виде для бухгалтера, который будет все это исправлять )

Скачать исходный код

Наименование Файл Версия Размер
СравнениеОстатковОборотов_16_20_81
.epf 29,45Kb
807
.epf 29,45Kb 807 Скачать
СравнениеОстатковОборотов_16_20_82
.epf 31,33Kb
242
.epf 31,33Kb 242 Скачать

Обработку открываем в базе 2.0, через ком подключаемся к 1.6, выбираем необходимые ресурсы, субконто и организацию.

Возможности:

- выбор локально установленных файловых информационных баз из списка

- выбор уровня детализации по субконто

- выбор остатков/оборотов

- установка порядка округления позволяет выбрать погрешность с которой устанавливается сравнение

(-1) до десятков

0 - до единиц

1 - до десятых

- отбор по конткретной организации

- настройка цветов для различающихся, совпадающих и ненайденных строк

- вывод в удобном виде на печать

- разворачиваение веток дерева результата

 

Создано и оттестировано на 8.1 (конвертированная под 8.2 прилагается )

БП 2.0.19.13 и БП 1.6.30.7

 

На создание вдохновила публикация,

//infostart.ru/public/21382/

автору отдельное спасибо!

См. также

Анализ расхождений выручки НДС и Налога на прибыль в декларациях (БП 3.0 ПРОФ и КОРП, КА 2, ЕRP)

Анализ учета Закрытие периода Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Налоговый учет Налог на прибыль НДС Платные (руб)

Каждый бухгалтер не раз сталкивался с требованием от налоговой инспекции пояснить расхождения в показателях декларации по Налогу на прибыль («Доходы от реализации» + «Внереализационные доходы») и налоговой базой по НДС за год. Являются ли ошибкой подобные расхождения? Как пояснить налоговой их причину? Отчет «Анализ расхождений выручки НДС и Налога на прибыль в декларациях» поможет найти все расхождения.

7200 руб.

21.10.2017    84748    267    171    

262

Управленческий учет в 1С УНФ: экспресс-проверка

Анализ учета Бухгалтер Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Расширение автоматически анализирует управленческий учёт 1С:УНФ, помогает находить и исправлять ошибки, а также проверять те места, которые хорошо бы проверить. Разработка для тех, кто хочет построить управленческий финансовый учет в УНФ.

12000 руб.

28.07.2022    8769    7    25    

21

Дополнительный анализ расходов УСН в 1С:Бухгалтерии 3.0

Учет доходов и расходов Анализ учета Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Налоговый учет УСН Платные (руб)

Мы добавили девять новых проверок в Экспресс-проверку учета. Цель таких проверок — узнать, есть ли потенциальные проблемы в учёте УСН.

7200 руб.

27.09.2021    13788    28    11    

36

Экселька. Универсальный инструмент, построенный по типу классических электронных таблиц, с возможностью использования данных 1С.

Загрузка и выгрузка в Excel Регламентированный учет и отчетность Анализ учета БДР, БДДС Бизнес-аналитик Бухгалтер Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Инструмент является симбиозом базового функционала Excel с возможностью получения и использования данных 1С для конструирования произвольных отчетов. Область применения - от простого получения нескольких контрольных сумм по типу "Отчет руководителю", до составления сложных аналитических отчетов всех видов учета.

12000 руб.

08.02.2021    19790    12    66    

29

Сверка остатков товаров БУХ3 - УТ11

Анализ учета Бухгалтер Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Россия Бухгалтерский учет Платные (руб)

Обработка позволяет сравнивать количественные остатки номенклатуры между Бухгалтерия 3.0 и УТ 11.5

3600 руб.

06.02.2023    4182    7    1    

12

Сверка данных УНФ - БУХ по документам и по долгам

Взаиморасчеты Анализ учета Бухгалтер Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Обработка позволяет сравнивать по документам и сверять по долгам покупателей и поставщиков между базами УНФ 1.6, УНФ 3.0 и Бухгалтерия 3.0,

6000 руб.

24.08.2022    6394    4    1    

6

Отчет контроля целостности остатков.

Анализ учета Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Если вы не хотите испортить базу и платить деньги за исправления - контролируйте и своевременно устраняйте проблемы! Наш отчет поможет вам выявить расхождения в остатках на ранней стадии, когда стоимость исправления ничтожно мала!

2400 руб.

09.08.2023    1715    3    0    

5
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. stail_en 25.03.11 09:26 Сейчас в теме
3. anig99 2844 25.03.11 12:01 Сейчас в теме
(1) потому что конвертировать из 8.1 в 8.2 можно, а обратно - фиг
2. anig99 2844 25.03.11 10:52 Сейчас в теме
4. maxval 25.03.11 18:19 Сейчас в теме
stail_en пишет:

а почему для 8.1?

вообще-то для 8.2 уже конвертировано :) открываем закладку файлы
5. AlexeyVZ 27.03.11 20:33 Сейчас в теме
У мну такая ситуевина:

1.6 на 8.1 було
2.0 на 8.2 щас

мне нужно конвертануть 1.6 на 8.2, потом использовать для 8.2?
6. Abbra 23 27.03.11 22:34 Сейчас в теме
При попытке подключения к информационной базе произошла ошибка:
Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V81.COMConnector.1): Ошибка при выполнении операции с информационной базой
Несовместимая версия файла базы данных 'I:\_1C\CLIENTS\ПАС\25-03-2011\Предприниматель-25-03-2011-82/1Cv8.1CD'


обе базы 8.2 и обработка соответственно тоже
в чем может быть причина?
7. anig99 2844 27.03.11 22:57 Сейчас в теме
(6) V81.COMConnector заменить на V82.COMConnector
8. Abbra 23 27.03.11 23:11 Сейчас в теме
anig99,
спасибо


в обработке заменил
ВерсияПлатформыИнформационнойБазыДляПодключения = "V81";
на
ВерсияПлатформыИнформационнойБазыДляПодключения = "V82";


заработало
9. Abbra 23 27.03.11 23:17 Сейчас в теме
Вообще при переносе первый раз вижу такое, что остатки по 41 счету перенеслись "как бы" не на 01.01.11, а на некоторую предстоящую дату, причем для каждого товара разную. При этом по 10 счету все нормально. Правила переноса последние от 23.03.2011 г. В чем может быть причина?
Предыдущие правила вообще ересь даже не похожую на правду переносят.
10. 1cmax 152 28.03.11 00:15 Сейчас в теме
upd
добавил в форму переключатели для версии платформы
11. Shum23str 29.03.11 13:22 Сейчас в теме
Чтото у меня вся колонка "Значение" пустое?
Не подскажите почему?
У меня 1.6.30.6 и 2.0.20.9
12. GoodWinSpr 402 29.03.11 18:19 Сейчас в теме
налоговые сопоставляет?
13. sbv2005 348 30.03.11 12:17 Сейчас в теме
Интересная обработка. Я написал тоже для сравнения БП 1.6 и БП 2.0, но в виде оборотной ведомости: http://infostart.ru/public/83429/
14. 1cmax 152 31.03.11 01:48 Сейчас в теме
GoodWinSpr пишет:

налоговые сопоставляет?

нет, так как сравнение идет по одинаковым измерениям и ресурсам одинковых видов регистра бухгалтерии.
а налогового плана счетов как известно в 2.0 нет
15. 1cmax 152 31.03.11 01:51 Сейчас в теме
Shum23str пишет:
подскажите

поле "Значение" - 2.0
Если все галочки поставлены, то возможно в базе 2.0 нет соответствующих данному разрезу по субконто остатков/оборотов,
что достаточно часто встречается
16. 1cmax 152 10.04.11 15:54 Сейчас в теме
upd
добавлена возможность выбора в зависимости от платформы

локально установленных файловых информационных баз из списка

сделано с использованием (vbscript)
17. diman85 25.09.11 19:52 Сейчас в теме
Интересная обработка.Позволила сэкономить время
18. gala2009 31 07.10.11 18:46 Сейчас в теме
мы как раз переходим, созрели наконец, пригодится
19. YuryKr 12.10.11 22:31 Сейчас в теме
Полезная обработка - баги все вылезли. время действительно сэкономили и все проверили.
20. 1cmax 152 12.10.11 22:34 Сейчас в теме
Рад, что вам помогло. Не забываем плюсовать :)
21. nata_07 106 31.10.11 14:04 Сейчас в теме
спасибо, пригодилось (для сравнения двух 2.0, кстати, тоже)
22. cv_admin 50 22.06.12 09:58 Сейчас в теме
Спасибо автору!
Помогает найти большинство косяков.
Плохо, что она не показывает результаты в виде таблицы значений (см. аттач) пришлось немного дописать
=============
Процедура СтрокиТЗПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
// Вставить содержимое обработчика.
сч=1;

если Не ДанныеСтроки.Дебет16=ДанныеСтроки.Дебет20 Тогда
ОформлениеСтроки.Ячейки.Дебет16.ЦветФона=ЦветРазличающихся;
ОформлениеСтроки.Ячейки.Дебет20.ЦветФона=ЦветРазличающихся;
КонецЕсли;

если Не ДанныеСтроки.Кредит16=ДанныеСтроки.Кредит20 Тогда
ОформлениеСтроки.Ячейки.Кредит16.ЦветФона=ЦветРазличающихся;
ОформлениеСтроки.Ячейки.Кредит20.ЦветФона=ЦветРазличающихся;
КонецЕсли;

КонецПроцедуры

=== Строка 99 - заменить на кусок кода
СтрокаЗаписи0=СтрокаОбъекта.Строки.Добавить();
СтрокаЗаписи0.НеНашли = НЕ Нашли;
СтрокаЗаписи0.Различаются = Истина;
СтрокаЗаписи0.Имя=Строка(Счетчик);
СтрокаЗаписи=СтрокаЗаписи0.Строки.Добавить();
СтрокаЗаписи.Имя="Измерения";

НоваяСтрокаТЗ=СтрокиТЗ.Добавить();

Для Каждого Измерение из Измерения Цикл
СтрокаИзмерения=СтрокаЗаписи.Строки.Добавить();
СтрокаИзмерения.Имя=?(Нашли,НайтиОбъект(стр[Измерение.Значение]),ВСтрокуCOM(стр[Измерение.Значение]));

//ДмитрийК
Если Нашли Тогда

Если Найти(Измерение.Значение,"Субконто")>0 Тогда
НоваяСтрокаТЗ[Измерение.Значение]=СтрокаИзмерения.Имя;
ИначеЕсли Измерение.Значение="Счет" ТОгда
НоваяСтрокаТЗ[Измерение.Значение]=СтрокаИзмерения.Имя;
КонецЕсли;


КонецЕсли;

КонецЦикла;

СтрокаЗаписи=СтрокаЗаписи0.Строки.Добавить();
СтрокаЗаписи.Имя="Ресурсы";
Для Каждого Ресурс из Ресурсы Цикл
Для Каждого Приставка2 из Приставка2М Цикл
СтрокаЗначения=СтрокаЗаписи.Строки.Добавить();
СтрокаЗначения.Имя=""+Ресурс.Значение+Приставка+Приставка2;
//СтрокаЗначения.Значение
СтрокаЗначения.Значение2=ОКР(стр[Ресурс.Значение+Приставка+Приставка2],Ресурс.РазрядностьДробнойЧасти);
Если Нашли Тогда
//СтрокаЗначения.Значение2
СтрокаЗначения.Значение=ОКР(стр1[Ресурс.Значение+Приставка+Приставка2],Ресурс.РазрядностьДробнойЧасти);
КонецЕсли;

Если Найти(СтрокаЗначения.Имя,"Дт")>0 Тогда
НоваяСтрокаТЗ.Дебет16=Число(СтрокаЗначения.Значение2);
НоваяСтрокаТЗ.Дебет20=Число(СтрокаЗначения.Значение);
ИначеЕсли Найти(СтрокаЗначения.Имя,"Кт")>0 Тогда
НоваяСтрокаТЗ.Кредит16=Число(СтрокаЗначения.Значение2);
НоваяСтрокаТЗ.Кредит20=Число(СтрокаЗначения.Значение);
КонецЕсли;

КонецЦикла;

КонецЦикла;

Если НоваяСтрокаТЗ.Дебет16=НоваяСтрокаТЗ.Дебет20 И НоваяСтрокаТЗ.Дебет20=НоваяСтрокаТЗ.Кредит20 Тогда
СтрокиТЗ.Удалить(НоваяСтрокаТЗ);
КонецЕсли;
Прикрепленные файлы:
Оставьте свое сообщение